Doing Mathematics

with Scientific WorkPlace®
& Scientific Notebook®

Version 6

by Darel Hardy
& Carol Walker

MacKichan Software, Inc.
Copyright ©2011 by MacKichan Software, Inc. All rights reserved. No part of this book may be reproduced, stored in a retrieval system, or transcribed, in any form or by any means—electronic, mechanical, photocopying, recording, or otherwise—without the prior written permission of the publisher, MacKichan Software, Inc., Poulsbo, Washington, USA. Information in this document is subject to change without notice and does not represent a commitment on the part of the publisher. The software described in this document is furnished under a license agreement and may be used or copied only in accordance with the terms of the agreement. It is against the law to copy the software on any medium except as specifically allowed in the agreement.

Printed in the United States of America
10 9 8 7 6 5 4 3 2 1

Trademarks
Scientific WorkPlace, Scientific Word, Scientific Notebook, and EasyMath are registered trademarks of MacKichan Software, Inc. EasyMath is the sophisticated parsing and translating system included in Scientific WorkPlace, Scientific Word, and Scientific Notebook that allows the user to work in standard mathematical notation, request computations from the underlying computational system (MuPAD 5 in this version) based on the implied commands embedded in the mathematical syntax or via menu, and receive the response in typeset standard notation or graphic form in the current document. MuPad is a registered trademark of SciFace GmbH & Co. KG. Acrobat is a registered trademark of Adobe Systems, Inc. \( \text{T}_{\text{E}}\text{X} \) is a trademark of the American Mathematical Society. pdf\( \text{T}_{\text{E}}\text{X} \) is the copyright of Hàn Thế Thành and is available under the GNU public license. VCam is based on VRS, which is a product developed by Hasso Plattner Institute of the University of Potsdam. Windows is a registered trademark of the Microsoft Corporation. Macintosh is a registered trademark of the Apple Corporation. Linux is a registered trademark of Linus Torvalds. RLM is a registered trademark of Reprise Software. Activation system licensed under patent No. 5,490,216. All other brand and product names are trademarks of their respective companies.

This document was produced with Scientific WorkPlace.®

Authors: Darel Hardy and Carol Walker
Manuscript Editor: John MacKendrick
Compositor: MacKichan Software Inc.
Designer: Patti Kearney
Printing and Binding: Malloy Lithographing, Inc.
Contents

1 Basic Techniques for Doing Mathematics .............. 1
   Conventions ........................................ 2
   Inserting Text and Mathematics ..................... 3
   Basic Guidelines for Computing ....................... 7

2 Numbers, Functions, and Units ......................... 19
   Integers and Fractions ................................ 19
   Elementary Number Theory ........................... 21
   Real Numbers ........................................ 23
   Functions and Relations ............................... 27
   Complex Numbers .................................... 32
   Units and Measurements ............................... 33
   Exercises ............................................ 36

3 Algebra .................................................. 39
   Polynomials and Rational Expressions ................. 39
   Substitution .......................................... 47
   Solving Equations ..................................... 48
   Defining Variables and Functions .................... 59
   Exponents and Logarithms ............................. 65
   Toolbars and Keyboard Shortcuts ..................... 69
   Exercises ............................................ 70
## Contents

4 **Trigonometry** ............................................. 75  
  Trigonometric Functions .................................. 75  
  Trigonometric Identities .................................. 80  
  Inverse Trigonometric Functions ......................... 83  
  Hyperbolic Functions ................................... 86  
  Complex Numbers and Complex Functions ............... 89  
  Exercises ................................................. 93

5 **Function Definitions** ..................................... 99  
  Function and Expression Names ........................... 99  
  Defining Variables and Functions ....................... 103  
  Handling Definitions .................................... 115  
  Formulas .................................................. 115  
  External Functions ...................................... 119  
  Trigtype Functions .................................... 122  
  Exercises ............................................... 124

6 **Plotting Curves and Surfaces** .......................... 129  
  Getting Started With 2D Plots ............................ 130  
  Interactive Tools for 2D Plots ............................ 138  
  Graph User Settings .................................... 140  
  2D Plots of Functions and Expressions .................. 151  
  Creating Animated 2D Plots .............................. 165  
  Creating 3D Plots ....................................... 171  
  Creating Animated 3D Plots .............................. 189  
  Exercises ............................................... 196

7 **Calculus** .................................................. 201  
  Evaluating Calculus Expressions ......................... 201  
  Limits ..................................................... 202  
  Differentiation .......................................... 209  
  Indefinite Integration ................................... 226  
  Methods of Integration .................................. 228  
  Definite Integrals ...................................... 231  
  Sequences and Series .................................... 260  
  Multivariable Calculus .................................. 268  
  Exercises ............................................... 277
<table>
<thead>
<tr>
<th>Section</th>
<th>Pages</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>8 Matrix Algebra</strong></td>
<td>285</td>
</tr>
<tr>
<td>Creating and Editing Matrices</td>
<td>286</td>
</tr>
<tr>
<td>Standard Operations</td>
<td>294</td>
</tr>
<tr>
<td>Row Operations and Echelon Forms</td>
<td>298</td>
</tr>
<tr>
<td>Equations</td>
<td>301</td>
</tr>
<tr>
<td>Matrix Operators</td>
<td>307</td>
</tr>
<tr>
<td>Polynomials and Vectors Associated with a Matrix</td>
<td>317</td>
</tr>
<tr>
<td>Vector Spaces Associated with a Matrix</td>
<td>321</td>
</tr>
<tr>
<td>Normal Forms of Matrices</td>
<td>326</td>
</tr>
<tr>
<td>Matrix Decompositions</td>
<td>334</td>
</tr>
<tr>
<td>Exercises</td>
<td>337</td>
</tr>
<tr>
<td><strong>9 Vector Calculus</strong></td>
<td>341</td>
</tr>
<tr>
<td>Vectors</td>
<td>341</td>
</tr>
<tr>
<td>Gradient, Divergence, Curl, and Related Operators</td>
<td>358</td>
</tr>
<tr>
<td>Plots of Vector Fields and Gradients</td>
<td>363</td>
</tr>
<tr>
<td>Scalar and Vector Potentials</td>
<td>372</td>
</tr>
<tr>
<td>Matrix-Valued Operators</td>
<td>375</td>
</tr>
<tr>
<td>Plots of Complex Functions</td>
<td>379</td>
</tr>
<tr>
<td>Exercises</td>
<td>381</td>
</tr>
<tr>
<td><strong>10 Differential Equations</strong></td>
<td>385</td>
</tr>
<tr>
<td>Ordinary Differential Equations</td>
<td>385</td>
</tr>
<tr>
<td>Systems</td>
<td>397</td>
</tr>
<tr>
<td>Numerical Methods</td>
<td>400</td>
</tr>
<tr>
<td>Exercises</td>
<td>407</td>
</tr>
<tr>
<td><strong>11 Statistics</strong></td>
<td>409</td>
</tr>
<tr>
<td>Introduction to Statistics</td>
<td>409</td>
</tr>
<tr>
<td>Measures of Central Tendency</td>
<td>411</td>
</tr>
<tr>
<td>Measures of Dispersion</td>
<td>416</td>
</tr>
<tr>
<td>Distributions and Densities</td>
<td>421</td>
</tr>
<tr>
<td>Families of Continuous Distributions</td>
<td>423</td>
</tr>
<tr>
<td>Families of Discrete Distributions</td>
<td>432</td>
</tr>
<tr>
<td>Random Numbers</td>
<td>435</td>
</tr>
<tr>
<td>Curve Fitting</td>
<td>436</td>
</tr>
<tr>
<td>Exercises</td>
<td>440</td>
</tr>
</tbody>
</table>
## Contents

### 12 Applied Modern Algebra

- Solving Equations ................................................. 445
- Integers Modulo m ................................................. 448
- Other Systems Modulo m ........................................ 454
- Polynomials Modulo Polynomials ............................ 456
- Linear Programming ............................................. 463
- Exercises .......................................................... 466

### A Menus and Shortcuts for Doing Mathematics ..... 473

- Compute Menu ......................................................... 473
- Toolbar and Keyboard Shortcuts for Compute Menu ... 488

### B Menus and Shortcuts for Entering Mathematics .... 489

- Entering Mathematics and Text ............................... 490
- Entering Mathematical Objects ............................... 491
- Entering Symbols and Characters ......................... 492
- Entering Units of Measure .................................. 496

### C Customizing the Program for Computing .......... 505

- Customizing the Toolbars .................................... 506
- Customizing the Sidebars .................................... 507
- Customizing the Compute Settings ..................... 507
- Customizing the Plot Settings ............................ 511
- Automatic Substitution .................................. 512

### D MuPAD Functions and Expressions ................... 515

- Constants .......................................................... 515
- Compute Menu Items ........................................ 516
- Functions and Expressions ................................. 522

## Index ................................................................. 527
Welcome to Version 6 of Scientific WorkPlace and Scientific Notebook. These programs have always provided easy text entry, natural notation mathematics, powerful symbolic and numeric computation, and flexible output of online, printed, and typeset documents in a Windows environment. With Version 6, these features are available for Linux and Mac OS/X users as well. With its entirely new Mozilla-based architecture, Version 6 provides more flexibility for your workplace. You can save or export your documents in multiple formats according to your publication and portability needs.

About Scientific WorkPlace and Scientific Notebook

The two products Scientific WorkPlace and Scientific Notebook provide a free-form interface to a computer algebra system that is integrated with a scientific word processor. The essential components of this interface are free-form editing and natural mathematical notation. Scientific WorkPlace and Scientific Notebook make sense out of as many different forms as possible, rather than requiring the user to adhere to a rigid syntax or just one way of writing an expression.

How can it be that mathematics, being after all a product of human thought independent of experience, is so admirably adapted to the objects of reality? Albert Einstein (1879–1955)
Preface

They are designed to fit the needs of a wide range of users, from the beginning student trying to solve a linear equation to the professional scientist who wants to produce typeset-quality documents with embedded advanced mathematical calculations. The text editors in Scientific WorkPlace and Scientific Notebook accept mathematical formulas and equations entered in natural notation. The symbolic computation system produces mathematical output inside the document that is formatted in natural notation, can be edited, and can be used directly as input to subsequent mathematical calculations.

The computational components of Scientific WorkPlace and Scientific Notebook use a MuPAD engine. All versions use standard libraries furnished by SciFace Software. Scientific WorkPlace and Scientific Notebook provide easy, direct access to all the mathematics needed by many users. For the user familiar with MuPAD, they also allow access to the full range of MuPAD functions and to functions programmed in MuPAD. By providing an interface with little or no learning cost, Scientific WorkPlace and Scientific Notebook make symbolic computation as accessible as any word processor.

Scientific WorkPlace and Scientific Notebook have great potential in educational settings. In a classroom equipped with appropriate projection equipment, the program’s ease of use and its combination of a free-form scientific word processor and computational package make it a natural replacement for the chalkboard. You can use it in the same ways you would a chalkboard and you have the added advantage of the computational system. You do not need to erase as you go along, so previous work can be recalled. Class notes can be edited and made available for viewing on line or printed. Scientific WorkPlace and Scientific Notebook provide a ready laboratory in which students can experiment with mathematics to develop new insights and to solve interesting problems; they also provide a vehicle for students to produce clear, well-written homework.

This document, Doing Mathematics with Scientific WorkPlace and Scientific Notebook, describes the use of the underlying computer algebra system for doing mathematical calculations. In particular, it explains how to use the built-in computer algebra system MuPAD to do a wide range of mathematics without dealing directly with MuPAD syntax.

This document is organized around standard topics in the undergraduate mathematics curriculum. Users can find the guidance they need without going to chapters involving mathematics beyond their
current level. The first four chapters introduce basic procedures for using the system and cover the content of the standard precalculus courses. Later chapters cover analytic geometry and calculus, linear algebra, vector analysis, differential equations, statistics, and applied modern algebra. Exercises are provided to encourage users to practice the ideas presented and to explore possibilities beyond those covered in this document.

Users with an interest in doing mathematical calculations are advised to read and experiment with the first five chapters—Basic Techniques for Doing Mathematics; Numbers, Functions, and Units; Algebra; Trigonometry; and Function Definitions—which provide a good foundation for doing mathematical calculations. You may also find it helpful to read parts of the sixth chapter Plotting Curves and Surfaces to get started creating plots. You can approach the remaining chapters in any order.

Experienced MuPAD users will find it helpful to read about accessing other MuPAD functions and adding user-defined MuPAD functions in Appendix D, "MuPAD Functions and Expressions." You will also want to refer to the tables in that chapter that pair MuPAD names with Scientific WorkPlace and Scientific Notebook names for constants, functions, and operations.

For information on the document-editing features of your system, refer to the online Help or to the document, Creating Documents with Scientific Word and Scientific WorkPlace.

Technical Support

If you can't find the answer to your questions in the manuals or the online Help, you can obtain technical support from the website at

http://www.mackichan.com/support.htm

or at the Web-based Technical Support forum at

http://www.mackichan.com/forum.htm

You can also contact the Technical Support staff by email or telephone. We urge you to submit questions by email whenever possible in case the technical staff needs to obtain your file to diagnose and solve the problem.

When you contact Technical Support by email, please provide complete information about the problem you're trying to solve. They must
Preface

be able to reproduce the problem exactly from your instructions. When you contact them by telephone, you should be sitting at your computer with the program running.

Please be prepared to provide the following information any time you contact Technical Support:

- The MacKichan Software product you have installed.
- The version and build numbers of your installation (see Help / About).
- The serial number of your installation (see Help / System Features).
- The type of hardware and operating system you’re using, (e.g., Windows 7, Mac OS X Leopard, Ubuntu 10.10, openSUSE 11.3, etc.).
- What happened and what you were doing when the problem occurred.
- The exact wording of any messages that appeared on your computer screen.

To contact technical support

- Contact Technical Support by email or telephone between 8 AM and 5 PM Pacific Time:

  Internet electronic mail address: support@mackichan.com
  Telephone number: 360-394-6033
  Toll-free telephone: 877-SCI-WORD (877-724-9673)
  Fax number: 360-394-6039

You can learn more about Scientific WorkPlace and Scientific Notebook on the MacKichan web site, which is updated regularly to provide the latest technical information about the program. The site also houses links to other \TeX\ and \LaTeX\ resources. There is also an unmoderated discussion forum and an unmoderated email list so users can share information, discuss common problems, and contribute technical tips and solutions. You can link to these valuable resources from the home page at http://www.mackichan.com.

Darel W. Hardy
Carol L. Walker
1
Basic Techniques for Doing Mathematics

How many times can you subtract 7 from 83, and what is left afterwards? You can subtract it as many times as you want, and it leaves 76 every time. Author Unknown

In this chapter, we give a brief explanation, with examples, of each of the basic computational features of Scientific WorkPlace and Scientific Notebook. You can begin computing as soon as you have opened a file. You are encouraged to open a new document and work the examples as you proceed.

To type and evaluate an expression
1. Place the insert point where you want the expression and choose Insert > Math.
2. Type a mathematical expression in the document—for example, $2 + 2$. (It will appear red in the document window.)
3. Choose Compute > Evaluate.

The expression $2 + 2$ will be replaced by the evaluation $2 + 2 = 4$.

Although there are substantial changes to Scientific WorkPlace and Scientific Notebook for Version 6, the computational behavior of the program is largely unchanged. The Compute menu will look very familiar to experienced users. There are some logical changes in the structure of other menus. Mathematics objects on earlier Insert menus have been gathered together under the heading Math Objects, a new item on the Insert menu. Symbol panels are available in a sidebar as well as on a Symbol toolbar.

Conventions
Inserting Text and Mathematics
Basic Guidelines for Computing

Note
If Insert > Math is checked, your insert point is already in mathematics mode and you are ready for step 2.

General procedure
- Enter an expression in mathematics
- Choose an appropriate command
Chapter 1 | Basic Techniques for Doing Mathematics

Conventions

Program tools are available from menus, toolbar buttons, and keyboard shortcuts. Many tools may be invoked in multiple ways to suit your style of work—via menus, toolbar buttons, or the keyboard. In this manual, we generally indicate only one of the possible ways of accessing a tool, usually via the menus. Appendices A and B list command shortcuts for doing or entering mathematics.

Understanding the notation and the terms used in our documentation will help you understand the instructions. We assume you’re familiar with the basic procedures and terminology for your operating system. In our manuals, we use the notation and terms listed below.

General Notation

- Text like this indicates text you should type exactly as it is shown.

- Text like this indicates information that you must supply, such as a filename.

- Text like this indicates an expression that is typed in mathematics mode.

- The word choose means to designate a command for the program to carry out. As with all standard applications, you can choose a command with the mouse or with the keyboard. Commands may be listed on a menu or shown on a button or in a dialog box. For example, the instruction “Choose File > Open” means you should first choose the File menu and then from that menu, choose the Open command. The instruction “choose OK” means to click OK with the mouse, or to press Tab to select the OK button and then press Enter.

- The word check means to turn on an option in a dialog box.

Keyboard Conventions

We also use standard computer conventions to give keyboard instructions.

- The names of keys in the instructions match the names shown on most keyboards. Ctrl (Windows) and Cmd (Mac) are synonymous, as are Enter (Windows) and Return (Mac), and right
click (Windows) and Cmd+click (Mac). Names of keys are always shown in Windows format. Mac users should substitute Mac keys (e.g. Cmd and Return) as appropriate.

- A plus sign (+) between the names of two keys indicates that you must press the first key and hold it down while you press the second key. For example, Ctrl+g means that you press and hold down the Ctrl key, press g, and then release both keys. Similarly, the notation Ctrl+word means that you must hold down the Ctrl key, type the word that appears after the +, then release the Ctrl key. Note that if a letter appears capitalized, you should type that letter as a capital.

### Inserting Text and Mathematics

*Scientific WorkPlace* and *Scientific Notebook* are modal in the sense that at all times during information entry you are either entering text or mathematics, and the results obtained from keystrokes and other user interface actions will differ depending on whether you are entering text or mathematics. Thus we refer to being in either text mode or mathematics mode. The default state is text mode; it is easy to toggle between the two modes and it is also easy to determine what mode you are in. Unless you actively change to mathematics, the program displays a “T” on the Standard toolbar and

- Interprets anything you type as text, displaying it in black in the program window.
- Displays alphabetic characters as upright, not italicized.
- Inserts a space when you press the spacebar.

When you start the program, the insert point is in text mode.

**To switch from text to mathematics**

- Click the “T” on the standard toolbar, or
  - Choose Insert > Math.

When in mathematics mode, the program

- Displays the insert point between brackets for mathematics.

**Mathematics mode**

When you switch from text to mathematics, the “T” changes to “M” on the toolbar, and the insert point changes to red and appears between brackets.
Chapter 1 | Basic Techniques for Doing Mathematics

- Interprets anything you type as mathematics, displaying it in red in the program window.
- Italicizes alphabetic characters and displays numbers upright.
- Automatically formats mathematical expressions, inserting correct spacing around operators such as + and relations such as =.
- Advances the insert point to the next mathematical object when you press the spacebar.

To switch from mathematics to text
- Click the “M” on the standard toolbar, or
  Choose Insert > Text.

On the screen, mathematics appears in red and text in black. The blinking vertical line on your screen is referred to as the insert point. You may have heard it called the insert cursor, or simply the cursor. The insert point marks the position where characters or symbols are entered when you type or click a symbol. You can change the position of the insert point with the arrow keys or by clicking a different screen position with the mouse. The position of the mouse is indicated by the mouse pointer, which assumes the shape of an I-beam over text and an arrow over mathematics.

Basic Guidelines

You can type information in a document in either text or mathematics. The mathematics that you type is recognized by the underlying computing engine as mathematics, and the text is ignored by the computing engine.

- Text is entered at the position of the insertion point when the Toggle Text/Math button in the Standard toolbar shows T.

- Mathematics is entered at the position of the insert point when the Toggle Text/Math button on the Standard toolbar shows a red M.

You can toggle between mathematics and text by clicking the Toggle Text/Math button or by pressing Ctrl+m or Ctrl+t on the keyboard. Entering a mathematics symbol by clicking a button on a toolbar automatically puts the state in mathematics at the position in which the symbol is entered. The state remains in mathematics as you type.

Spacing
Mathematics is automatically spaced differently from text as you enter it—for example, “2 + 2” rather than “2+2”—so you do not have to make adjustments.

Text mode
When you switch from mathematics to text, the “M” changes to “T” and the insert point changes to black.
characters or symbols to the right of existing mathematics, until you either toggle back into text or move the insert point into text by using the mouse or by pressing right arrow, left arrow, or the spacebar.

Choose View > Toolbars if any toolbar you would like to use does not automatically appear above your Document Window.

**To type a fraction, radical, exponent, or subscript**

1. Choose Insert > Math Objects > Fraction, Radical, Superscript, or Subscript for input boxes:

   \[
   \frac{\pi}{x^2} y
   \]

2. Enter expressions in the input boxes:

   \[
   \frac{2}{3} \sqrt{3} \ x^2 \ y_1
   \]

The spacebar and arrow keys move the insertion point through mathematical expressions and the tab key toggles between input boxes.

**To use symbols for addition, multiplication and division**

- Use standard symbols on the keyboard.

- Choose View > Toolbars and check Symbol Toolbar. Click one of the buttons on the Symbol Toolbar and a row of symbols will appear.

- Click the left or right sidebar pointer and choose Add > Symbol. Click one of the buttons and a panel of symbols will appear.

You select a piece of text with the mouse by holding down the left mouse button while moving the mouse, or from the keyboard by holding down shift and pressing right arrow or left arrow. Your selection appears on the screen in reversed colors. This technique is sometimes referred to as highlighting an area of the screen. This is also one of the ways you can select mathematics. See page 12 for a discussion of automatic and user selections for mathematics.

There are many brackets available for mathematics expressions. Brackets entered from buttons or dialogs, or from the keyboard with Ctrl/Cmd pressed, are expanding brackets (sometimes called fences) — both sides are entered and the resulting brackets change size (both height and width) depending on the contents. Expanding brackets will not break at the end of a line so lengthy expressions enclosed in
expanding brackets may need to be displayed. Left and right brackets entered from the keyboard (without Ctrl/Cmd pressed) act independently. They also have fixed height.

To insert expanding brackets in a mathematics expression
- Choose Insert > Math Objects > Brackets and select the desired brackets from the panel that appears.

Expanding parentheses and square brackets are also available on the Math toolbar.

Displaying Mathematics
Mathematics can be centered on a separate line in a display.

\[y = ax + b\]

To create a display
1. Choose Insert > Math Objects > Display.
2. Type or paste a mathematical expression in the display.

You can begin with an existing mathematical expression and put it into a display.

To put mathematics in a display
1. Select the mathematics with click and drag or Shift+right arrow.
2. Choose Insert > Math Objects > Display.

The default environment in a display is mathematics. You can, however, enter text in a display by toggling to text.

Centering Plots, Graphics and Text

If you have text that you wish to center on a separate line, the natural way to do this operation is with Centered, which you can choose from the Section/Body Tag pop-up menu.

If you have a plot or graphic that you wish to center on a separate line, you should choose the Displayed setting in the Layout dialog, as discussed in Chapter 6, “Plotting Curves and Surfaces.” To center a group of plots or graphics, choose the In Line setting in the Layout dialog and then use Centered.
Basic Guidelines for Computing

When you respond to the request, “place the insert point in the expression,” place the insert point within, or immediately to the right of, the expression. The position immediately to the left of a mathematical expression is not part of the mathematics.

Evaluating expressions

To type a mathematics expression for a computation, begin a new line with the mathematics expression or type the expression immediately to the right of text or a text space. If you type mathematics immediately to the right of other mathematics, the expressions may be combined in ways you do not intend.

To compute the sum 3 + 8
1. Choose Insert > Math
2. Type 3 + 8
3. Choose Compute > Evaluate

By following the same procedure, you can add, subtract, multiply, and divide, and perform a vast variety of other mathematical computations.

\[
\begin{align*}
\text{Compute} & \quad \text{Evaluate} \\
235 + 813 &= 1048 \\
235 - 813 &= -578 \\
235 \times 813 &= 191055 \\
235/813 &= \frac{235}{813} \\
\frac{\frac{3}{4}}{\frac{2}{7}} &= \frac{23}{28} \\
\frac{\frac{3}{4}}{\frac{2}{7}} &= \frac{5}{21} \\
\frac{3}{4} \div \frac{2}{7} &= \frac{23}{28} \\
\frac{\frac{3}{4}}{\frac{2}{7}} &= \frac{14}{9} \\
\end{align*}
\]

Rules
Except that it be mathematically correct, there are almost no rules about the form for entering a mathematical expression.
Chapter 1 | Basic Techniques for Doing Mathematics

One of the few exceptions to the claim of “no rules” is that vertical notation such as

\[
\begin{align*}
24 + 15 & \quad \text{and} \quad 234 - 47 \quad \text{and} \quad 2 \left\lfloor \frac{35}{7} \right\rfloor
\end{align*}
\]

used when doing mathematics by hand is not recognized. Write sums, differences, products, and quotients of numbers in natural linear notation, such as \(24 + 15\) and \(235 - 47\) and \(24.7/19.5\) and \(13 \div 22\), or natural fractional notation, such as \(\frac{78.9}{43.4}\) and \(\frac{3}{7} \cdot \frac{2}{3}\).

Certain constants are recognized in their usual forms—such as \(\pi\), \(i\), and \(e\)—as long as the context is appropriate. On the other hand, they are recognized as arbitrary constants, variables, or indices when appropriate to the context, helping to provide a completely natural way for you to type and perform mathematical computations.

Interpreting Expressions

If your mathematical notation is ambiguous, it may still be accepted. However, the way it is interpreted may or may not be what you intended. To be safe, remove an ambiguity by placing additional parentheses in the expression.

To check the interpretation of a mathematical expression

1. Leave the insert point in the expression.
2. Choose Compute > Interpret.

\[
\begin{align*}
\text{Compute } \rightarrow \text{ Interpret} \\
1/3x + 4 = \frac{1}{3}x + 4 & \quad 1/(3x + 4) = \frac{1}{3x+4} \\
1/(3x) + 4 = \frac{1}{3x} + 4 & \quad 1/3 (x + 4) = \frac{1}{3} (x + 4)
\end{align*}
\]

Math and Symbol Toolbars

Instructions in this manual rely almost entirely on menu items. However, toolbars and keyboard shortcuts offer efficient alternative methods. For descriptions of toolbars and keyboard shortcuts that perform the Compute menu commands, see Appendix A “Menus, Toolbars, and Shortcuts for Doing Mathematics.” For descriptions of toolbar buttons and keyboard shortcuts for entering mathematics, see Appendix B “Menus, Toolbars, and Shortcuts for Entering Mathematics.” For information about other toolbars and keyboard shortcuts, choose Help > Search or consult the manual Creating Documents with Scientific Workplace and Scientific Word.
Basic Guidelines for Computing

To display the Math Toolbar

- Choose View > Toolbars and check Math Toolbar.

The buttons on this toolbar duplicate items on the Compute and Insert > Math Objects menus.

**Example**
Here is how you can type the mathematical expression $\frac{2x-1}{\sqrt{x+3}}$ using the mouse:

1. Click Fraction $\frac{}{}$ and type $2x - 1$.
2. Click the denominator input box.
3. Click Radical $\sqrt{}$ and type $x$.
4. Click to the right of the square root symbol.
5. Type $+3$.

To display the Symbols Toolbar

- Choose View > Toolbars and check Symbols Toolbar.

From this toolbar, you can access Greek letters, many binary operation and binary relation symbols, and other common and not-so-common mathematical symbols.

**Greek letters**

**To enter a lowercase Greek letter**

- Click the Lowercase Greek button, then click the desired letter.

**To enter an uppercase Greek letter**

- Click the Uppercase Greek button, then click the desired letter.
Chapter 1 | Basic Techniques for Doing Mathematics

Binary Operations

To enter a binary operation

- Click the Binary Operations button and click the desired symbol.

Binary Relations

To enter a binary relation

- Click the Binary Relations button and click the desired symbol.

Negated Relations

To enter a negated relation

- Click the Negated Relations button and click the desired symbol.

Arrows

To enter an arrow

- Click the Arrows button and click the desired symbol.

Miscellaneous Symbols

To enter a miscellaneous symbol

- Click the Miscellaneous Symbols button and click the desired symbol.
Basic Guidelines for Computing

Delimiters

To enter a delimiter

- Click the Delimiters button and click the desired symbol

Sidebar tools

Symbol Sidebar

You will see left and right sidebar tools on the left and right edges of your window.

To view the left or right sidebar

- Click the left or right sidebar tool.

To view the Symbol sidebar

- Choose Add > Symbols

Keyboard Shortcuts

Keyboard shortcuts are available for many common tasks. For example, to toggle between mathematics and text, press Ctrl+m or Ctrl+t. See Appendix B, Keyboard Shortcuts for Entering Mathematics, for some useful keyboard shortcuts for entering symbols and mathematical objects.

Example

Here is how you can type the mathematical expression $\frac{2x-1}{\sqrt{x+3}}$ using keyboard shortcuts.
1. Press Ctrl+/.
2. Type \(2x - 1\).
3. Press Tab.
4. Press Ctrl+r.
5. Type \(x\).
6. Press spacebar.
7. Type +3.
8. Press spacebar.

### Selecting Mathematical Expressions

There are more ways than one to select a mathematical expression, as explained in the following sections. When you perform a mathematical operation, a mathematical expression is automatically selected for the operation, depending on the position of the insert point and the operation involved. These will be called **automatic selections**. You can also force other selections by selecting mathematics with the mouse. The latter will be called **user selections**.

### Understanding Automatic Selections

When you place the insert point in a mathematical expression and choose an operation from the Compute menu, the automatic selection depends primarily on the operation you choose. It also depends on the location of the mathematics, such as inline, in a matrix, or in a display. The following two possibilities occur for mathematical objects that are typed inline:

- Selection of an expression, that part of the mathematics containing the insert point that is enclosed between a combination of text and the class of symbols—such as \(=\), \(<\), or \(\leq\)—known as **binary relations**.

- Selection of the entire mathematical object, such as an equation or inequality.

The following examples illustrate situations where these two types of selections occur.
Basic Guidelines for Computing

Operations that Select an Expression

The majority of operations select an expression enclosed between text and binary relations.

To select an expression enclosed between text and binary relations

- Place the insert point anywhere inside the expression or immediately to the right of the expression, and choose a command that operates on expressions.

For example, place the insert point anywhere in the left side of the equals sign in the equation $2x + 3x = 1 + 4$ except to the left of the $2$, and choose Evaluate.

```
Compute > Evaluate
(Insert point in left side of the equation)
2x + 3x = 5x = 1 + 4
```

The expression $= 5x$ is inserted immediately after the expression $2x + 3x$, because only the expression on the left side of the equation was selected for evaluation. The left side of the equation is bounded on the left by text and on the right by the binary operation “$=$.”

Since the result of the evaluation was equal to the original expression, the result was placed next to the expression, preceded by an equals sign. After the operation is performed, the insert point appears at the right end of the result so that you can select another operation to apply to the result without moving the insert point.

Other commands, including Evaluate Numeric, Simplify, Combine, Factor, and Expand, make similar selections under similar conditions.

Operations that Select an Equation or Inequality

To select an equation

1. Place the insert point anywhere inside the equation or immediately to the right of the equation.

2. Choose a command that operates on equations.

```
Compute > Solve > Exact
2x + 3x = 1, Solution: $\frac{1}{5}$
3x + 5 ≤ 5x − 3, Solution: $[4, \infty)$
```
Chapter 1 | Basic Techniques for Doing Mathematics

In these cases, the entire mathematical object—that is, the equation or inequality—was selected. The solution is not equal to the selection, so it is not presented as a part of the original equation.

The other choices on the Solve submenu and the operation Check Equality also select an equation.

**Selections Inside Displays and Matrices**

Operations may behave somewhat differently when mathematics is entered in a display or in a matrix. If you place the insert point inside a display or matrix, the automatic selection is the entire array of entries, for any operation. Some operations apply to a matrix, and others to the entries of a matrix or contents of a display. If the operation is not appropriate for either a matrix or its entries or for all the contents of a display, you may receive a report of a syntax error.

**Selections Inside a Display**

Inside a one-line display, the automatic selection is the same mathematics as outside a display, and the result is generally returned inside the display.

**To select mathematics in a display**

- Place the insert point inside the display, and choose a command that operates on expressions or equations.

When you choose Evaluate with the insert point in the left side of the displayed equation

\[ 2x + 3x = 3 + 5 \]

you get the result

\[ 2x + 3x = 5x = 3 + 5 \]

and when you choose Evaluate with the insert point in the right side of the displayed equation you get the result

\[ 2x + 3x = 3 + 5 = 8 \]

A multiple-line display, however, behaves like a matrix (see next section). Note that multiple line displays are useful for solving systems of equations, or equations with initial-value conditions. Applying Compute > Solve > Exact to the following display yields

\[
\begin{align*}
5x + 2y &= 3 \\
6x - y &= 5
\end{align*}
\]

Solution: \( x = \frac{13}{17}, y = -\frac{7}{17} \)
Basic Guidelines for Computing

Selections Inside a Matrix

You can use a matrix to arrange mathematical expressions in a rectangular array.

To create a matrix

1. Choose Insert > Math Objects > Matrix.

2. Set the number of rows and columns.

3. Choose OK.

4. If you see nothing on your screen, choose View > Helper Lines, or
   Choose View > Input Boxes.

5. Type a number or any mathematical expression in each of the input boxes of the matrix.

To select mathematics in a matrix

- Place the insert point anywhere inside the matrix or immediately to the right of the matrix, and choose a command that operates on expressions.

<table>
<thead>
<tr>
<th>Compute &gt; Evaluate</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \begin{pmatrix} x + x &amp; 5 + 3 \ 5/2 &amp; 6^2 \end{pmatrix} ) = ( \begin{pmatrix} 2x &amp; 8 \ 5/2 &amp; 36 \end{pmatrix} )</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Compute &gt; Evaluate Numeric</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \begin{pmatrix} x + x &amp; 5 + 3 \ 5/2 &amp; 6^2 \end{pmatrix} ) ( \approx ) ( \begin{pmatrix} 2.0x &amp; 8.0 \ 2.5 &amp; 36.0 \end{pmatrix} )</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Compute &gt; Factor</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \begin{pmatrix} x + x &amp; 5 + 3 \ 5/2 &amp; 6^2 \end{pmatrix} ) = ( \begin{pmatrix} 2x &amp; 2^3 \ 5 \times 2^{-1} &amp; 2^2 \times 3^2 \end{pmatrix} )</td>
</tr>
</tbody>
</table>

Understanding User Selections

You can restrict a computation to a selection you have made and so override the automatic choice.

Tip

With Compute > Evaluate, all expressions in the matrix will be evaluated and the result displayed as a matrix. Evaluate Numeric, Simplify, Factor, and choices from Combine behave similarly.
Chapter 1 | Basic Techniques for Doing Mathematics

To make a user selection

- Hold down the left mouse button while moving the mouse over the material you want to select, then release the left mouse button.

Your selection is the expression that appears on the screen in reversed colors. This procedure will often be referred to as select with the mouse.

There are two options for applying operations to a user selection—operating on a selection displays the result of the operation but leaves the selection intact, and replacing a selection replaces the selection with the result of the operation. Following are two examples illustrating the behavior of the system when operating on a selection. The option of replacing a selection is referred to as computing in place, and examples are shown in the following section.

To operate on a user selection

- Use the mouse to make a selection, and apply an operation.

```
Compute > Evaluate
(2 + 3 selected)
2 + 3 - x : 5
```

In general, the result of applying an operation to a user selection is not equal to the entire original expression, so the result is placed at the end of the mathematics, separated by something in text (in this case, a colon). You can use the word-processing capabilities of your system to put the result where you want it in your document.

Replacing a user selection, an in-place computation, is described in the following section.

Computing in Place

You can replace part of an expression with the result of a computation on that part.

To replace a user selection

1. Use the mouse to select an expression.
2. Press and hold Ctrl while applying a command to the expression.

```
Old Expression    Selection     Compute > Expand
(x - 2)^2 (3x - 1) (x - 2)^2 x^2 - 4x + 4 (3x - 1)
```

Tip

When you operate on a user selection, the answer appears to the right of the entire expression, following a colon.

Computing in place

This “computing in place” — that is, holding down the Ctrl key as you choose an operation from the Compute menu—is a key feature. It provides a convenient way for you to manipulate expressions into the forms you desire.
The expression $x^2 - 4x + 4$ remains selected. Enclose it in parentheses to complete the replacement.

<table>
<thead>
<tr>
<th>Old Expression</th>
<th>Selection</th>
<th>Compute &gt; Factor</th>
</tr>
</thead>
<tbody>
<tr>
<td>$(x^2 - 4x + 4) (3x - 1)$</td>
<td>$(x^2 - 4x + 4)$</td>
<td>$(x - 2)^2 (3x - 1)$</td>
</tr>
</tbody>
</table>

With the help of the Ctrl key, you can perform any computation in place; that is, you can replace an expression directly with the results of that computation. This feature, combined with copy and paste, allows you to “fill in the steps” in demonstrating a computation.

**Stopping a Computation**

Most computations are done more or less instantaneously, but some may take several minutes to complete, and some may take a (much) longer time.

**To stop a computation**

- Press Ctrl+Break (Windows) or Cmd+period (Mac), or
- Click .

**Menus, Toolbars, and Shortcuts**

See Appendix A for a summary of the Compute menu commands, corresponding commands on the Math Toolbar, and keyboard shortcuts for these commands. See Appendix B for a complete summary of Insert > Math Objects menu choices, corresponding choices on the Math and Symbols Toolbars, and keyboard shortcuts related specifically to entering mathematics. For additional shortcuts, consult *Creating Documents with Scientific Workplace and Scientific Word, Version 6* or choose Help and search for keyboard shortcuts.

**Customizing Your Program**

There are many ways to customize your program to fit your special needs and preferences. See Appendix C for information on settings for computation. You can set the number of digits to be used in computations, the number of digits to be displayed, defaults for plot intervals, set various debugging choices, customize the appearance of solutions, and choose different defaults for input, output, matrices, derivatives, and other entities. There are also many possibilities for customizing the editing features of the program. These are described in detail in the Help and in the manual *Creating Documents with Scientific Workplace and Scientific Word*. 
Chapter 1 | Basic Techniques for Doing Mathematics

Computational Engine

The computational engine provided with Scientific WorkPlace and Scientific Notebook version 6 is MuPAD 5. To see if the computational engine is in active mode, or to deactivate the engine, choose Tools > Preferences > Computation, click Engine tab, and check or uncheck Engine On. (The path for a Mac is SWPPro > Preferences > Computation.)

See Appendix D “MuPAD Functions and Expressions” for a list of built-in functions and constants, descriptions of Compute menu commands in terms of the native commands of MuPAD, and descriptions of built-in functions in terms of the MuPAD syntax.
Numbers, Functions, and Units

No human investigation can be called real science if it cannot be demonstrated mathematically. Leonardo da Vinci (1452–1519)

Numbers and functions to be used for computing should be entered in mathematics mode and appear red (or gray) on your screen. If that is not the case, choose Insert > Math and retype the expression. Units to be used for computing must be entered as a Unit Name (see Units, page 34).

**To enter a mathematics expression for a computation**

- Begin a new line with the mathematics expression, or
  - Type the expression immediately to the right of text or a text space.

If you enter mathematics immediately to the right of other mathematics, the expressions will be combined in ways you may not intend. A safe way to begin is to press Enter and start on a new line.

**Integers and Fractions**

The first examples are centered around rational numbers—that is, integers and fractions. You will find examples of many of the same operations later in this chapter, using real numbers and then complex numbers. Similar operations will be illustrated in later chapters with a variety of different mathematical objects.

**Integers and Fractions**

**Elementary Number Theory**

**Real Numbers**

**Functions and Relations**

**Complex Numbers**

**Units and Measurements**

**New in Version 6**

Rewrite fraction as mixed number
Arithmetic with mixed numbers
Choice of letters and fonts for imaginary unit and exponential e
Overbar for complex conjugate
More control over thresholds for scientific notation
Chapter 2 | Numbers, Functions, and Units

Addition and Subtraction

To add 3, 6, and 14

1. Choose Insert > Math to put the insert point in mathematics mode.

2. Type $3 + 6 + 14$ (This expression should appear red in your document window.)

3. Leave the insert point in the expression $3 + 6 + 14$.

4. Choose Compute > Evaluate.

This sequence prompts the system to insert $= 23$ to the right of the $3 + 6 + 14$, resulting in the equation $3 + 6 + 14 = 23$.

By following the same steps, you can carry out subtraction and perform a vast variety of other mathematical computations. With the insert point in the sum (or difference), choose Compute > Evaluate.

| Compute > Evaluate | $235 + 813 = 1048$ | $\frac{2}{3} - \frac{8}{7} = -\frac{10}{21}$ | $96 - 27 + 2 = 71$ |

To obtain the fraction template

- Place the insert point in the position where you want the fraction, and choose Insert > Math Objects > Fraction.

The template will appear with the insert point in the upper input box, ready for you to begin entering numbers or expressions.

Multiplication and Division

Use any standard linear or fractional notation for multiplication and division, and with the insert point in the product (or quotient), choose Compute > Evaluate.

<table>
<thead>
<tr>
<th>Compute &gt; Evaluate</th>
<th>$16 \times 37 = 592$</th>
<th>$(84)(-39) = -3276$</th>
<th>$8.2/3.7 = 2.2162$</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>$103 \div 37 = \frac{103}{37}$</td>
<td>$\frac{213}{9} \div \frac{7}{9} = \frac{26}{63}$</td>
<td>$-\frac{2}{3} = -\frac{14}{117}$</td>
</tr>
</tbody>
</table>
Mixed Numbers and Long Division

A number written in the form $14\frac{5}{9}$ is interpreted as the mixed number $14 + \frac{5}{9}$. With the factory default, most commands applied to a mixed number return a fraction. For example, applying Evaluate or Simplify to $14\frac{5}{9}$ gives the result $\frac{131}{9}$. The reverse is accomplished by Compute > Rewrite > Mixed, which converts a fraction to a mixed number.

\[
\text{Compute > Evaluate} \\
\frac{5}{3} = 1\frac{2}{3} \quad \frac{18229}{94} = 193\frac{87}{94} \quad 1\frac{2}{3} + 2\frac{3}{4} = \frac{53}{12}
\]

\[
\text{Compute > Rewrite > Mixed} \\
\frac{5}{3} = 1\frac{2}{3} \quad \frac{18229}{94} = 193\frac{87}{94} \quad \frac{53}{12} = 4\frac{5}{12}
\]

You can change this default so that fractions are output as mixed numbers.

**To set mixed numbers as default for rational numbers**
2. Check “Output fractions as mixed numbers.”

With mixed number checked as the output default for fractions, the system behaves as follows.

\[
\text{Compute > Evaluate} \\
5\frac{3}{5} + 1\frac{2}{3} = 7\frac{4}{15}
\]

Elementary Number Theory

Prime Factorization

A prime is an integer greater than 1 whose only positive factors are itself and 1. You can factor integers into products of powers of primes. Place the insert point inside the number and choose Compute > Factor.

\[
\text{Compute > Factor} \\
12345 = 3 \times 5 \times 823 \quad -24 = -2^3 \times 3 \quad 2^{10} + 3^7 = 13^2 \times 19 \\
24! = 2^{22} \times 3^{10} \times 5^4 \times 7^3 \times 11^2 \times 13 \times 17 \times 19 \times 23
\]
Chapter 2 | Numbers, Functions, and Units

Greatest Common Divisor

The greatest common divisor of two integers is the largest integer that divides both integers evenly. You can find the greatest common divisor of a collection of integers by evaluating the function gcd applied to the list of numbers enclosed in parentheses or square brackets and separated by commas. Leave the insert point in the expression and choose Compute > Evaluate.

\[
\begin{align*}
\text{gcd}(35, 15, 65) &= 5 \\
\text{gcd}(2^{14} + 3^8 + 5^9, 3^4 + 7^3) &= 2 \\
\text{gcd}[-104, 221] &= 13
\end{align*}
\]

Least Common Multiple

You can find the least common multiple of a collection of integers by evaluating the function lcm applied to the list of numbers enclosed in parentheses or square brackets and separated by commas. Leave the insert point in the expression and choose Compute > Evaluate.

\[
\begin{align*}
\text{lcm}(35, 15, 65) &= 1365 \\
\text{lcm}[6, 8] &= 24 \\
\text{lcm}(104, 221) &= 1768
\end{align*}
\]

Factorials

Factorial is the function of a nonnegative integer \( n \) denoted by \( n! \) and defined for positive integers \( n \) as the product of all positive integers up to and including \( n \); that is, \( n! = 1 \times 2 \times 3 \times 4 \times \cdots \times n \). It is defined for zero by \( 0! = 1 \).

You can evaluate factorials.

\[
\begin{align*}
3! &= 6 \\
7! &= 5040 \\
10! &= 3628800
\end{align*}
\]

Binomial Coefficients

An expression of the form \( a + b \) is called a binomial. The formula that gives the expansion of \( (a + b)^n \) for any natural number \( n \) is

\[
(a + b)^n = \sum_{k=0}^{n} \frac{n!}{k!(n-k)!} a^{n-k} b^k
\]
This is the same formula that gives the number of combinations of \( n \) things taken \( k \) at a time. The coefficients \( \frac{n!}{k!(n-k)!} \) that occur in this formula are called binomial coefficients. These coefficients are often denoted by the symbols \( \binom{n}{k} \) or \( C_{n,k} \) or \( nC_k \). Use the symbol \( \binom{n}{k} \) to compute these coefficients.

To enter a binomial coefficient \( \binom{n}{k} \)
1. Choose Insert > Math Objects > Binomial.
2. Check None for Line and choose OK.
3. Type numbers in the input boxes.

\[
\binom{5}{2} = 10 \quad \binom{35}{7} = 6724520
\]

A Rewrite command will change a symbolic binomial to a factorial expression.

\[
\binom{m}{n} = \frac{m!}{(m-n)!n!} \quad \binom{m}{5} = \frac{m!}{120(m-5)!}
\]

**Real Numbers**

The real numbers include the integers and fractions (rational numbers), as well as irrational numbers such as \( \sqrt{2} \) and \( \pi \) that cannot be expressed as quotients of integers.

**Arithmetic**

You can do arithmetic with real numbers using Evaluate.

\[
9.6\pi - 2.7\pi = 6.9\pi \quad 42 \left( \frac{2}{3} + \frac{1}{4} \right) \sqrt{2} = 34\sqrt{2} \quad \frac{2}{3} \div \frac{8}{7} = \frac{7}{12}
\]

If any of the components of a combination of numbers is written in floating point form—that is, with a decimal—the result will be in decimal notation. Symbolic real numbers such as \( \sqrt{2} \) and \( \pi \) will retain symbolic form unless evaluated numerically.

Choose Compute > Rewrite > Rational to change a floating point number to a rational number.
Chapter 2 | Numbers, Functions, and Units

**Compute > Rewrite > Rational**

- \( 0.125 = \frac{1}{8} \quad 4.72 = \frac{118}{25} \)
- \( 6.9\pi = \frac{69}{10}\pi \quad 3.1416 = \frac{3927}{1250} \)

Choose Compute > Rewrite > Float to change a rational number or a symbolic number to a floating point number.

**Compute > Rewrite > Float**

- \( \frac{1}{8} = 0.125 \quad \frac{118}{25} = 4.72 \)
- \( \frac{69}{10}\pi = 21.677 \quad \frac{3927}{1250} = 3.1416 \)

Typing float while in mathematics gives the grayed function float. Evaluating float at a rational number gives the floating point form of the number.

**Compute > Evaluate**

- \( \text{float} \left( \frac{1}{8} \right) = 0.125 \quad \text{float} \left( \frac{118}{25} \right) = 4.72 \)

**Powers and Radicals**

To raise numbers to powers, use common notation for powers and apply Evaluate.

**Compute > Evaluate**

- \( 3^4 = 81 \quad (2.5)^{4/5} = 2.0814 \)
- \( 3^{-4} = \frac{1}{81} \quad 0.4^{32} = 1.8447 \times 10^{-13} \)

To insert the superscript template \( ^n \) or subscript template \( _n \)

1. Place the insert point in the position where you want the superscript (subscript).
2. Choose Insert > Math Objects > Superscript (Subscript).

The template will appear with the insert point in the upper (lower) input box, ready for you to begin entering numbers or expressions.

**Radical notation for roots**

Evaluate and Simplify will compute real roots of positive real numbers written in either symbolic or floating point notation. The result of either of these operations is presented in symbolic or floating point notation according to the form of the input. Evaluate and Simplify produce the same result from floating point numbers. Sometimes Simplify is useful with symbolic numbers.

**Input Boxes**

To see input boxes on the screen, choose View and check Input Boxes.
Real Numbers

To insert the radical template $\sqrt{\phantom{0}}$

1. Place the insert point where you want the radical.

2. Choose Insert $\to$ Math Objects $\to$ Radical.

The template will appear with the insert point in the input box, ready for you to begin entering numbers or expressions.

You can also Evaluate the built-in function simplify. Type simplify in mathematics mode and it will automatically turn gray.

To enter the expression $\sqrt{2}$

1. Choose Insert $\to$ Math Objects $\to$ Radical and type 2.

2. Press tab, type 3, and press space.

Compute $\to$ Evaluate
\[
\sqrt{0.008} = 0.20 \quad \sqrt{18.234} = 1.7872 \quad \sqrt{24} = 2\sqrt{6}
\]
\[
\sqrt[1]{\frac{16}{27}} = \frac{4}{3} \sqrt[3]{6} \quad \sqrt[1]{16} = 2 \quad \sqrt[1]{-8} = -2
\]

Compute $\to$ Simplify
\[
\sqrt[1]{\frac{16}{27}} = \frac{4}{3} \sqrt[3]{2} \quad \sqrt[1]{162\pi^6} = 3\sqrt[3]{2}\pi^2
\]

Compute $\to$ Evaluate
simplify $\left(\sqrt[1]{\frac{16}{27}}\right) = -\frac{2}{3} \sqrt[3]{2}$
simplify $\sqrt[1]{162\pi^6} = 3\pi^2 \sqrt[3]{2}$

Rationalizing a Denominator

To rationalize the denominator of a fraction

1. Place the insert point in the fraction.

2. Choose Compute $\to$ Simplify.

Compute $\to$ Simplify
\[
\frac{1}{\sqrt{2}} = \frac{1}{2} \sqrt{2}
\]
\[
\frac{1}{\sqrt{2} + \sqrt{3}} = \sqrt{3} - \sqrt{2}
\]
\[
\frac{\sqrt{3} + \sqrt{3}}{\sqrt{3} - \sqrt{4}} = -\frac{1}{2} \left(\sqrt{2} + \sqrt{3}\right) \left(\sqrt{3} + \sqrt{7}\right)
\]
Numerical Approximations

Numerical calculations are exact whenever appropriate. You can force a result to be in decimal notation either by choosing Evaluate Numeric or by starting with numbers in decimal notation. Contrast the responses to evaluation of the following expressions.

\[
\begin{array}{l}
\text{Compute} > \text{Evaluate} \\
82 \div 37 = \frac{82}{37} \\
936/14 = \frac{26}{7} \\
936/14.0 = 66.857 \\
\frac{142}{85.5} = 0.16608 \\
\frac{2}{3} \div \frac{8}{7} = \frac{7}{12} \\
\sqrt{234} = 3\sqrt{26} \\
(5^4)^5 = 95.367431640625
\end{array}
\]

\[
\begin{array}{l}
\text{Compute} > \text{Evaluate Numeric} \\
82 \div 37 \approx 2.2162 \\
936/14 \approx 66.857 \\
936/14.0 \approx 66.857 \\
\frac{142}{85.5} \approx 0.16608 \\
\frac{2}{3} \div \frac{8}{7} \approx 0.58333 \\
\sqrt{234} \approx 15.297 \\
(5^4)^5 \approx 9.5367 \times 10^{13}
\end{array}
\]

Evaluate Numeric gives decimal approximations, or floating point numbers.

\[
\begin{array}{l}
\text{Compute} > \text{Evaluate Numeric} \\
9.6\pi - 2.7\pi \approx 21.677 \\
42(\frac{2}{3} + \frac{1}{7}) \sqrt{2} \approx 48.083
\end{array}
\]

Rewrite > Float has a similar behavior.

\[
\begin{array}{l}
\text{Compute} > \text{Rewrite} > \text{Float} \\
9.6\pi - 2.7\pi = 21.677 \\
42(\frac{2}{3} + \frac{1}{7}) \sqrt{2} = 48.083
\end{array}
\]

Typing float while in mathematics gives the grayed function float. Evaluating float at a rational number gives the floating point form of the number.

\[
\begin{array}{l}
\text{Compute} > \text{Evaluate} \\
\text{float}(9.6\pi - 2.7\pi) = 21.677 \\
\text{float}\left(42\left(\frac{2}{3} + \frac{1}{7}\right) \sqrt{2}\right) = 48.083
\end{array}
\]

You can specify the number of decimal places to be displayed. See Appendix C, “Customizing the Program for Computing.”

Scientific Notation

Any nonzero real number \(x\) can be written in the form

\[x = c \times 10^n\]
with \(1 \leq |c| < 10\) and \(n\) an integer. A number in this form is in scientific notation. Following are some examples of scientific notation:

\[
\begin{align*}
12 &= 1.2 \times 10 \\
8274.9837 &= 8.2749837 \times 10^3 \\
0.000001234 &= 1.234 \times 10^{-6} \\
-54163.02 &= -5.416302 \times 10^4
\end{align*}
\]

To write a number in scientific notation

1. Enter the number \(c\) (in mathematics mode) to as many decimal places as appropriate.
2. Click the Binary Operations button on the Symbols Toolbar
3. Click \(\times\) in the symbols palette.
4. Type the number 10.
5. Choose Insert > Math Objects > Superscript and enter the integer \(n\) in the input box.

The results of a numerical computation are sometimes returned in scientific notation. This happens when the number of digits exceeds the setting for Upper Threshold for scientific notation output. See Appendix C “Customizing the Program for Computing” for details on changing this setting.

## Functions and Relations

Numbers or expressions to be used for computing should be entered in mathematics mode and appear red on your screen. If that is not the case, choose Insert > Math to change the expression to mathematics.

Following are some of the basic built-in functions (absolute value, maximum and minimum, greatest and smallest integer functions), and built-in relations (union, intersection, and difference of sets).

See Absolute Value, page 33 for information on absolute values of complex numbers.

### Absolute value

The absolute value of a number \(z\), the distance of \(z\) from zero, is denoted \(|z|\).
Chapter 2 | Numbers, Functions, and Units

To put vertical bars around an expression
1. Select the expression.
2. Choose Insert > Math Objects > Brackets.
3. Click the vertical bracket and click OK.

To compute an absolute value
1. Place the insert point in an expression between vertical bars.
2. Choose Compute > Evaluate.

\[
\text{Compute} > \text{Evaluate}
\]
\[|−7| = 7 \quad |−11.3| = 11.3 \quad |43| = 43\]

Maximum and Minimum
The functions max and min find the largest and smallest numbers in a list of numbers separated by commas and enclosed in brackets. Leave the insert point in the expression and choose Evaluate.

\[
\text{Compute} > \text{Evaluate}
\]
\[\text{max}\left(\frac{13}{2}, -\sqrt{63}, 7.3\right) = 7.3 \quad \text{min}\left(\frac{13}{2}, -\sqrt{63}, 7.3\right) = -3\sqrt{7}\]

To enter function names for maximum and minimum
1. Choose Insert > Math Objects > Math Name.
2. Select from the list.
   Or
2. Type max or min.

The binary operations join \(\vee\) and meet \(\wedge\) also give maximum and minimum.

\[
\text{Compute} > \text{Evaluate}
\]
\[27 \vee \frac{65}{2} \vee -14 = \frac{65}{2} \quad 27 \wedge \frac{65}{2} \wedge -14 = -14\]

Caution
The vertical lines from the symbol panel of Binary Relations will not be interpreted as absolute-value symbols in computations. Although they appear similar, they are not the same symbols. The keyboard vertical line will work to build an absolute value, but expanding brackets are less vulnerable to misinterpretation. Type Ctrl+\ for expanding absolute value bars.

Making the symbol toolbar visible
- Choose View > Toolbars
- Check Symbol toolbar
Functions and Relations

To enter vee and wedge symbols for maximum and minimum
1. Click Binary Operations [± + ▼] on the Symbol toolbar
2. Select ∨ or ∧ from the panel

To find the maximum or minimum of a finite sequence, enter the limits on the integer variable as a subscript on \( \text{max} \) or \( \text{min} \), either in the form of a double inequality such as \( 1 \leq n \leq 10 \) or as membership in an interval such as \( k \in [1; 10] \).

**Compute > Evaluate**

\[
\begin{align*}
\text{max}_{1 \leq n \leq 10} (\sin n) & = \sin 8 \\
\text{max}_{1 \leq n \leq 10} (\sin 1.5n) & = 0.99749 \\
\text{min}_{k \in [1; 10]} (\cos k) & = \cos 3 \\
\text{min}_{k \in [1; 10]} (\cos 2.6k) & = -0.99418
\end{align*}
\]

Note that the functions \( \text{max} \) and \( \text{min} \) look only at the sequence of values for integer variables. The notations \( x \in [-2; 2] \) and \( -2 \leq x \leq 2 \) both indicate that \( x \) assumes the range of values in the 5-element set \( \{-2, -1, 0, 1, 2\} \). In the last example the maximum is picked from among values of \( x^3 - 6x + 3 \) for \( x = -2, -1, 0, 1, 2 \).

**Greatest and Smallest Integer Functions**

You can find the greatest integer less than or equal to a number by using the floor function, denoted \( \lfloor z \rfloor \).

**To put floor brackets around an expression**
1. Select the expression with click and drag.
2. Choose Insert > Math Objects > Brackets.
3. Select the left floor bracket \( [ \) and click OK.

**To find a greatest integer value**
1. Place the insert point in an expression between floor brackets.
2. Choose Compute > Evaluate.

\[
\begin{align*}
\lfloor 5.6 \rfloor & = 5 \\
\lfloor \frac{43}{3} \rfloor & = 8 \\
\lfloor -11.3 \rfloor & = -12 \\
\lfloor \pi + e \rfloor & = 5
\end{align*}
\]

To find the smallest integer greater than or equal to a number, use the ceiling function, denoted \( \lceil z \rceil \).
Chapter 2 | Numbers, Functions, and Units

To put ceiling brackets around an expression
1. Select the expression with click and drag.
2. Choose Insert > Math Objects > Brackets.
3. Select the left ceiling bracket ⌈, and choose OK.

To find a smallest integer value
1. Place the insert point in a number between ceiling brackets.
2. Choose Compute > Evaluate.

Compute > Evaluate
⌈5.6⌉ = 6        ⌈43/3⌉ = 9
⌈-11.3⌉ = -11   ⌈π + e⌉ = 6

The floor and ceiling brackets are also available from the Delimiters tab ⟦⟧, although these are not expanding brackets.

Checking Equality and Inequality

You can verify equalities and inequalities with the command Check Equality or with the function istrue. There are three possible responses: true, false, and undecidable. The latter means that the test is inconclusive and the equality may be either true or false. The computational engine may use probabilistic methods to check equality, and there is a very small probability that an equation judged as true is actually false. Some expressions cannot be compared by this method—hence the inconclusive response.

Checking Equalities and Inequalities using Check Equality

To check whether an equality is true or false
1. Place the insert point in the equation.
2. Choose Check Equality.

Compute > Check Equality

\(e^{\pi} = -1\) is TRUE   \(\pi = 3.14\) is FALSE
arcsin \(\sin x = x\) is FALSE

You can also use Check Equality to check an inequality between two numbers. Set the difference of the two numbers equal to the absolute value of the difference, place the insert point in the equation, and choose Check Equality.
Functions and Relations

Compute > Check Equality

\[ \frac{9}{8} - \frac{8}{9} = \left| \frac{9}{8} - \frac{8}{9} \right| \text{ is TRUE} \quad \pi^e - e^\pi = |\pi^e - e^\pi| \text{ is FALSE} \]

These results verify that \( \frac{9}{8} - \frac{8}{9} \geq 0 \), or \( \frac{9}{8} \geq \frac{8}{9} \); and that \( \pi^e - e^\pi < 0 \), or \( \pi^e < e^\pi \).

Checking Equalities and Inequalities Using istrue

Type `istrue` in mathematics mode to get the function name `istrue`, or create it as a Math Name in the Insert > Math Objects > Math Name dialog box. Evaluate this function at an equation or inequality to test it.

Compute > Evaluate

\[- \left( \frac{9}{8} < \frac{8}{9} \right) = \text{FALSE} \quad \text{istrue} (2 + 2 = 4) = \text{TRUE} \]
\[- \left( \pi^e < e^\pi \right) = \text{TRUE} \quad \text{istrue} \left( (\sqrt{2})^2 = 2 \right) = \text{TRUE} \]

Checking Equalities and Inequalities Using Logical Operators

The operators \& (AND) and \| (OR) can be used as logical operators. The statement \( \alpha \& \beta \) is true if and only if both \( \alpha \) and \( \beta \) are true. The statement \( \alpha \| \beta \) is true if and only if at least one of \( \alpha \) and \( \beta \) is true. Using a tautology such as \( 0 = 0 \) or \( 1 = 1 \) as one of the statements, you can test the truth or falsity of another equation or inequality.

Compute > Evaluate

\[- (5^6 < 6^5) \& (1 = 1) = \text{FALSE} \quad (5^6 > 6^5) \& (1 = 1) = \text{TRUE} \]
\[- (5^6 > 6^5) \| (1 = 1) = \text{TRUE} \quad (5^6 < 6^5) \| (1 = 1) = \text{TRUE} \]
\[- (1 = 1) \| (1 = 0) = \text{TRUE} \quad (e^\pi = \pi^e) \& (0 = 0) = \text{FALSE} \]

Checking Inequalities with Evaluate Numeric

In some cases, you can recognize an inequality by inspection after applying Evaluate Numeric to each of the numbers.

Compute > Evaluate Numeric

\[- \left( \frac{9}{8} \approx 1.125 \right) \quad \frac{8}{9} \approx 0.88889 \]
\[- \left( \pi^e \approx 22.459 \right) \quad e^\pi \approx 23.141 \]

From this we see that \( \frac{9}{8} > \frac{8}{9} \) and \( \pi^e < e^\pi \).
Chapter 2 | Numbers, Functions, and Units

Union, Intersection, and Difference

You can find the union of two or more finite sets with Evaluate, by using the symbol \( \cup \) between the sets.

```
Compute > Evaluate
\{1, 2, 3\} \cup \{a, b, c\} = \{1, 2, 3, a, b, c\}
\{1, 2, 3\} \cup (\{3, 5\} \cup \{7\}) = \{1, 2, 3, 5, 7\}
\{\sqrt{2}, \pi, 3, 9, r\} \cup \{a, b, c\} = \{3, 9, \pi, a, b, c, r, \sqrt{2}\}
```

You can find the intersection of two or more finite sets with Evaluate, using the symbol \( \cap \) between the sets.

```
Compute > Evaluate
\{1, 2, 3\} \cap \{2, 4, 6\} = \{2\} 
\{a, b, c, d\} \cap \{d, e, f\} = \{d\}
\{1, 2, 3\} \cap \{a, b, c\} = \emptyset 
\{1, 2, 3\} \cap \{\} = \emptyset
```

If two sets have no elements in common, their intersection is the empty set, denoted by empty brackets \( \{} \) or the symbol \( \emptyset \). To enter the symbol \( \emptyset \) for the empty set, select it from the Miscellaneous Symbols panel under \( \equiv \).

You can find the difference of two finite sets with Evaluate, by placing between the sets a backslash \( \setminus \) or the setminus symbol \( \setminus \) from the Binary Operations panel.

```
Compute > Evaluate
\{1, 2, 3, 4\} \setminus \{2, 4\} = \{1, 3\} 
\{a, b, c, d\} \setminus \{d, e, f\} = \{a, b, c\}
\{1, 2, 3\} \setminus \{a, b, c\} = \{1, 2, 3\} 
\{1, 2, 3\} \setminus \{1, 2, 3\} = \emptyset
```

You can evaluate combinations of union, intersection, and difference after grouping expressions appropriately with expanding parentheses.

```
Compute > Evaluate
\{1, 2, 3, c\} \cap \{(2, 4, 6) \cup \{a, b, c\}\} = \{2, c\}
(\{(1, 2, 3) \cap \{2, 4, 6\}\} \cup \{(1, 2, 3) \cap \{a, b, c\}\}) = \{2, c\}
((\{2, 4, 6\} \cup \{a, b, c\}) \setminus \{2, a, b\}) = \{4, 6, c\}
```

Complex Numbers

The usual notation for a complex number is \( a + bi \) where \( a \) and \( b \) are real numbers and \( i \) satisfies \( i^2 = -1 \).
Units and Measurements

Arithmetic

You can do arithmetic with complex numbers using Evaluate. The result is the rectangular form \( a + bi \) of the complex number.

\[
\sqrt{-5} = i \sqrt{5} \quad \frac{i}{1+i} = \frac{1}{2} + \frac{1}{2}i \\
(1 + i) (3 - 2i) = 5 + i \quad (1 + i) \div (3 - 2i) = \frac{1}{13} + \frac{5}{13}i
\]

Absolute Value

The absolute value of a complex number \( a + bi \) is given by \( |a + bi| = \sqrt{a^2 + b^2} \). You can compute the absolute value of a complex number using Evaluate.

\[
|1 + i| = \sqrt{2} \quad |e^{i\pi}| = 1
\]

Complex Conjugate

The complex conjugate of \( a + bi \) is written \( (a + bi)^* \) or \( \overline{a + bi} \).

\[
(1 + i)^* = 1 - i \quad \overline{1+i} = 1 - i \\
(5 - 3i)^* = 5 + 3i \quad \overline{5-3i} = 5 + 3i
\]

Real and Imaginary Parts

You can find the real and imaginary parts of a complex number using the functions \( \text{Re} \) and \( \text{Im} \).

\[
\text{Re} (1 + i) = 1 \quad \text{Im} (5 - 3i) = -3
\]

See Complex Numbers and Complex Functions, page 89, for more advanced topics concerning complex numbers.

Appearance of imaginary unit

You may prefer a distinguished font for the imaginary \( i \). If so, choose Tools > Preferences > Computation, Entities tab, and check Imaginary \( I \). If you do not want \( i \) recognized as the imaginary unit, click the Input tab, and uncheck Recognize plain \( i \) as imaginary. Choose OK.

Complex Conjugate

To use overbar notation for complex conjugate, choose Tools > Preferences > Computation, Input tab, and check Overbar accent means conjugate. Choose OK.

Entering functions

When you enter the functions \( \text{Re} \) and \( \text{Im} \) in mathematics mode, they will automatically turn gray.

Units and Measurements

The available units include units from the System of International Units (SI units), an internationally agreed upon system of coherent units that is now in use for all scientific and most technological purposes in many countries. SI units are of three kinds: the base, supplementary, and derived units. There are seven base units for the seven di-
Chapter 2 | Numbers, Functions, and Units

Mensionally independent physical quantities: length, mass, time, electric current, thermodynamic temperature, amount of substance, and luminous intensity. Units from some other commonly used systems are also implemented. You can define other units in terms of the ones available in the Unit Name list.

Units

Units appear on your screen as dark green characters (unless you have changed this default to another color). Units are in mathematics mode and are active mathematical objects.

\[
\text{Compute} \rightarrow \text{Solve} \rightarrow \text{Exact}
\]

1 mi = \(x\) km, Solution: 1.6093
10 cm = \(x\) in, Solution: 3.937

To enter a unit name

1. Place the insert point at the position where you want the unit name.
2. Choose Insert > Math Objects > Unit Name.
3. Select a category from the Physical Quantity list.
4. Select a name from the Unit Name list and choose OK.

The unit name will appear at the position of the insert point. The Unit Name dialog will remain on your screen for further use. To close it, click the \(\times\) in the upper right corner of the dialog.

To replace a unit

1. Select the unit name you want to replace, either with click and drag or by placing the insert point to the right of the unit name.
2. Choose Insert > Math Objects > Unit Name.
3. Select a category from the Physical Quantity list.
4. Select a name from the Unit Name list.
5. Choose Replace.

The new unit name will replace the previous unit name. The Unit Name dialog will remain on your screen for further use. To close it, click the \(\times\) in the upper right corner of the dialog.
Units and Measurements

Units are automatically recognized and can be entered from the keyboard. See page 496 in Appendix B “Menus, Toolbars, and Shortcuts for Entering Mathematics,” for a complete list of unit symbols and keyboard shortcuts for each of the built-in physical quantities.

Arithmetic Operations with Units

You can carry out normal arithmetic operations with units using Evaluate. If the units differ, the results will be returned in terms of the basic unit in the category. Measurements will be returned in the metric system.

Compound names are written as fractions or products, such as ft/s, ft lbf, and acre ft.

<table>
<thead>
<tr>
<th>Compute &gt; Evaluate</th>
</tr>
</thead>
<tbody>
<tr>
<td>6 ft + 8 ft = 14 ft</td>
</tr>
<tr>
<td>6 ft × 8 ft = 48 ft²</td>
</tr>
<tr>
<td>4 ft + 16 in = 1.6256 m</td>
</tr>
<tr>
<td>1 acre ft = 1233.5 m³</td>
</tr>
</tbody>
</table>

Converting Units

You can convert from one unit to another. Place the insert point in an equation of the form 47 ft = x m or 47 ft = x and choose Compute > Solve > Exact.

<table>
<thead>
<tr>
<th>Compute &gt; Solve &gt; Exact</th>
</tr>
</thead>
<tbody>
<tr>
<td>7 ft = x in, Solution: 84.0</td>
</tr>
<tr>
<td>458.4 ° = x rad, Solution: 8.0006</td>
</tr>
<tr>
<td>50 mi/h = x km/h, Solution is: 80.467</td>
</tr>
<tr>
<td>1 acre ft = x gal, Solution: 3.2585 × 10⁵</td>
</tr>
<tr>
<td>47 lb = x kg, Solution: 21.319</td>
</tr>
<tr>
<td>7 ft = x m, Solution: 2.1336</td>
</tr>
<tr>
<td>8 rad = x °, Solution: 1440/π</td>
</tr>
<tr>
<td>10 acre = x hectare, Solution: 4.0469</td>
</tr>
<tr>
<td>47 lb/ft³ = x, Solution: 21.319</td>
</tr>
</tbody>
</table>

The difference between the notions of pound-mass (lb) and pound-force (lbf) is illustrated in the following examples.
Chapter 2 | Numbers, Functions, and Units

Compute > Solve > Exact

1 lbf = x lb, Solution: $9.8066 \text{m/s}^2$
47 lbf = x kg, Solution: $209.07 \text{m/s}^2$

Exercises

1. Find all the primes between 100 and 120.

2. Find two positive integers between 1000 and 1100 whose greatest common divisor is 23.

3. Evaluate numerically the power $(1 + \frac{1}{n})^n$ for $n = 2, 4, 8, 16, 32, 64, 128,$ and $256$. What well-known number is starting to emerge?

4. Experiment with numbers to test the potential identities
   
   $a \land (b \lor c) = (a \land b) \lor (a \land c)$
   
   $a \lor (b \land c) = (a \lor b) \land (a \lor c)$

5. Test the potential identity
   
   $A \cap (B \cup C) = (A \cap B) \cup (A \cap C)$
   
   using the sets $A = \{1, 3, 5, 7, 9\}$, $B = \{1, 4, 9, 16\}$, and $C = \{2, 3, 5, 7, 11\}$.

6. The weight of a block of aluminum is 403.2 lbf and the density is $168 \text{lbf/ft}^3$. What is its volume?

7. If a toy rocket shoots vertically upward with an initial velocity of $80 \text{m/s}$, at $t$ seconds after the rocket takes off, until it returns to the ground, it is at the height $80t - 16t^2 \text{m}$. Find the time it takes for the rocket to return to the ground. When does it reach its highest point?

Solutions

1. Test the odd integers between 100 and 120 by factoring:

   $101 = 101$  
   $103 = 103$  
   $105 = 3 \times 5 \times 7$  
   $107 = 107$  
   $109 = 109$  
   $111 = 3 \times 37$  
   $113 = 113$  
   $115 = 5 \times 23$  
   $117 = 3^2 \times 13$  
   $119 = 7 \times 17$

   Thus the primes in this range are 101, 103, 107, 109, and 113.
2. Rewrite > Mixed gives $\frac{1000}{23} = 43\frac{11}{23}$. Note that $44 \cdot 23 = 1012$ and $45 \cdot 23 = 1035$. Checking, we see that $\gcd(1012, 1035) = 23$. Find more pairs.

3. Note that 
\[
(1 + \frac{1}{2})^2 = 2.25 \quad \quad (1 + \frac{1}{2})^4 = 2.4414 \\
(1 + \frac{1}{4})^8 = 2.5658 \quad \quad (1 + \frac{1}{16})^{16} = 2.6379 \\
(1 + \frac{1}{32})^{32} = 2.677 \quad \quad (1 + \frac{1}{64})^{64} = 2.6973 \\
(1 + \frac{1}{128})^{128} = 2.7077 \quad \quad (1 + \frac{1}{256})^{256} = 2.713
\]
The number $e = 2.7182818284590452354$ is beginning to emerge.

4. With the numbers 1, 2, and 3 we have
\[
1 \wedge (2 \vee 3) = 1 \quad \quad \text{and} \quad \quad (1 \wedge 2) \vee (1 \wedge 3) = 1 \\
2 \wedge (3 \vee 1) = 2 \quad \quad \text{and} \quad \quad (2 \wedge 3) \vee (2 \wedge 1) = 2 \\
3 \wedge (1 \vee 2) = 2 \quad \quad \text{and} \quad \quad (3 \wedge 1) \vee (3 \wedge 2) = 2
\]
Similarly,
\[
1 \vee (2 \wedge 3) = 2 \quad \quad \text{and} \quad \quad (1 \vee 2) \wedge (1 \vee 3) = 2 \\
2 \vee (1 \wedge 3) = 2 \quad \quad \text{and} \quad \quad (2 \vee 1) \wedge (2 \vee 3) = 2 \\
3 \vee (1 \wedge 2) = 3 \quad \quad \text{and} \quad \quad (3 \vee 1) \wedge (3 \vee 2) = 3
\]
These provide experimental evidence that the following are identities:
\[
a \wedge (b \vee c) = (a \wedge b) \vee (a \wedge c) \\
a \vee (b \wedge c) = (a \vee b) \wedge (a \vee c)
\]

5. Note that $\{1, 3, 5, 7, 9\} \cap (\{1, 4, 9, 16\} \cup \{2, 3, 5, 7, 11\}) = \{1, 3, 5, 7, 9\}$ and $\{1, 3, 5, 7, 9\} \cap \{1, 4, 9, 16\} \cup \{1, 3, 5, 7, 9\} \cap \{2, 3, 5, 7, 11\} = \{1, 3, 5, 7, 9\}$.

6. The volume of the block of aluminum is
\[
\frac{403.2 \ \text{lb}^3}{168 \ \text{lb} \cdot \text{ft}^2} = 0.06796 \text{ m}^3
\]
The volume in cubic feet is the solution to the equation $0.06796 \text{ m}^3 = x \text{ ft}^3$. The solution is $x = 2.4$.  

Exercises
Chapter 2 | Numbers, Functions, and Units

7. The rocket returns to the ground when its height is 0 m. Solving \((80t - 16t^2) \text{ m} = 0\) gives the two solutions \(t = 0\) and \(t = 5\). The rocket thus returns to the ground in 5 s. The rocket reaches its highest point in half this time, that is, in \(\frac{5}{2} \text{ s} = 2.5 \text{ s}\). The maximum height of the rocket is \(80(2.5) - 16(2.5)^2 = 100.0 \text{ m}\).
Algebra

Algebraic operations are generalizations of arithmetic operations. Algebraic expressions are obtained by starting with variables and constants and combining them using addition, subtraction, multiplication, division, exponentiation, and roots. The simplest types of algebraic expressions use only addition, subtraction, and multiplication; these are called polynomials. The general form of a polynomial of degree \( n \) in the variable \( x \) is

\[
a_n x^n + a_{n-1} x^{n-1} + \cdots + a_1 x + a_0
\]

where \( a_0, a_1, \ldots, a_n \) are constants and \( a_n \neq 0 \).

**Polynomials and Rational Expressions**

You can perform the usual operations on polynomials. The general procedure is as described below.

**To work with a polynomial expression**

1. Enter the expression in mathematics mode and leave the insert point in the expression.

2. Apply one of the commands from the Compute menu.

You will find a variety of useful commands.
Chapter 3 | Algebra

The commands on the Compute menu that operate on polynomials include Evaluate, Simplify, Factor, Expand, Combine > Powers, and, from the Polynomials submenu, Collect, Divide, Partial Fractions, Roots, Sort, and Companion Matrix. See Companion Matrix and Rational Canonical Form on page 329 of Chapter 8 “Matrix Algebra” for a discussion of the Companion Matrix command. The remaining commands are discussed in this chapter.

Sums, Differences, Products, and Quotients of Polynomials

To perform basic operations on polynomials

1. Type the expression in mathematics mode and leave the insert point in the expression.

2. Choose Compute > Evaluate.

\[\begin{align*}
\text{Compute > Evaluate} \\
(3x^2 + 3x) + (8x^2 + 7) &= 11x^2 + 3x + 7 \\
(3x^2 + 3x) / (8x^2 + 7) &= \frac{3x^2+3x}{8x^2+7} \\
(x + 1)^{-1} (x - 1)^{-1} &= \frac{1}{(x-1)(x+1)} \\
x \div y &= \frac{3}{5}
\end{align*}\]

To expand products or quotients of polynomials

• With the insert point in the polynomial expression, choose Compute > Expand.

\[\begin{align*}
\text{Compute > Expand} \\
(3x^2 + 3x - 1)(8x^2 + 7) &= 24x^4 + 24x^3 + 13x^2 + 21x - 7 \\
(x + 1)^{-1} (x - 1)^{-1} &= \frac{1}{x^2-1}
\end{align*}\]

To enter the function expand

• Choose Insert > Math Objects > Math Name, type expand in the dialog box, check Function, and choose OK, or

In mathematics mode, type \(xpnd\).

\[\begin{align*}
\text{Compute > Evaluate} \\
\text{expand} \left( (3x^2 + 3x - 1) \left(8x^2 + 7\right) \right) &= 24x^4 + 24x^3 + 13x^2 + 21x - 7
\end{align*}\]

Reminder

The mathematics shown here depicts both what you enter

\[(3x^2 + 3x) + (8x^2 + 7)\]

and the result of the command Compute > Evaluate

\[= 11x^2 + 3x + 7\]
Division by Polynomials

You can convert a quotient of polynomials \( \frac{f(x)}{g(x)} \) with rational coefficients to the form \( q(x) + \frac{r(x)}{g(x)} \), where \( r(x) \) and \( q(x) \) are polynomials and \( \deg r(x) < \deg g(x) \).

To divide polynomials

1. Enter a quotient of polynomials.
2. Leave the insert point in the expression.
3. Choose Compute > Polynomials > Divide.

Compute > Polynomials > Divide

\[
\frac{3x^5 + 3x^3 - 4x^2 + 5}{8x^3 + 7} = \frac{3}{64}x - \frac{21x^2 - 17}{8x^3 + 7} + \frac{3x^3 - 1}{2}
\]

\[
\frac{5y^2 - 3y + 4}{3y - 5} = \frac{5}{3}y + \frac{116}{9}(3y - 5) + \frac{16}{9}
\]

Summation Notation

A polynomial in general form can be written in summation notation

\[
\sum_{k=0}^{n} a_k x^k = a_n x^n + a_{n-1} x^{n-1} + \cdots + a_1 x + a_0
\]

To enter a polynomial as a summation \( \sum_{k=0}^{5} a_k x^k \)

1. Choose Insert > Math Objects > Operator and choose \( \Sigma \).
2. Choose Insert > Math Objects > Subscript and type \( k = 0 \).
3. Press tab and type 5.
4. Press the spacebar and type \( a_k x^k \).

Compute > Evaluate

\[
\sum_{k=0}^{5} a_k x^k = a_5 x^5 + a_4 x^4 + a_3 x^3 + a_2 x^2 + a_1 x + a_0
\]

Sums and Differences of Rational Expressions

A quotient of two polynomials is called a rational expression.
To rewrite inverse notation as a rational expression
1. Type or select the expression.

2. Choose Compute > Rewrite > Rational (This preserves a factorization), or
Choose Compute > Simplify, or
Choose Compute > Rewrite > Normal Form (This expands a factorization.)

Compute > Rewrite > Rational
\[(8x^2 + 7)^{-1} (x + 2x^2 + 7)^{-1} = \frac{1}{(8x^2 + 7)(2x^2 + x + 7)}\]

Compute > Simplify
\[(8x^2 + 7)^{-1} (x + 2x^2 + 7)^{-1} = \frac{1}{(x + 2x^2 + 7)(8x^2 + 7)}\]

Compute > Rewrite > Normal Form
\[(8x^2 + 7)^{-1} (x + 2x^2 + 7)^{-1} = \frac{1}{16x^4 + 8x^3 + 70x^2 + 7x + 49}\]

To combine rational expressions over a common denominator
1. Enter the expressions.

2. Choose Compute > Rewrite > Normal Form, or
Choose Compute > Simplify, or
Choose Compute > Factor.

Compute > Rewrite > Normal Form
\[\frac{x}{x^2 - 1} + \frac{3x - 1}{x^2 - 3x + 2} = -\frac{4x^2 - 1}{-x^3 + 2x^2 + x - 2}\]

Compute > Simplify
\[\frac{x}{x^2 - 1} + \frac{3x - 1}{x^2 - 3x + 2} = -\frac{4x^2 - 1}{-x^3 + 2x^2 + x - 2}\]

Compute > Factor
\[\frac{x}{x^2 - 1} + \frac{3x - 1}{x^2 - 3x + 2} = \frac{(2x + 1)(2x - 1)}{(x - 1)(x - 2)(x + 1)}\]
Partial Fractions

The command Partial Fractions appears on both the Polynomials and Calculus submenus. With this command, you can write a rational expression as a sum of simpler fractions—essentially the reverse of the operation demonstrated in the previous section. See page 230 in Chapter 7 “Calculus” for an application of Partial Fractions.

The Partial Fractions command expands a rational expression into a sum of rational expressions having denominators that are multiples of powers of linear and irreducible quadratic factors of the denominator. In this case irreducible means the roots are neither rational nor rational combinations of the coefficients of the polynomials.

The numerators of the partial fractions are constants or, in the case the denominator is a power of an irreducible quadratic, linear. Thus each partial fraction is of the form

\[ \frac{A}{(ax + b)^n} \text{ or } \frac{Ax + B}{(ax^2 + bx + c)^m} \]

If more than one variable occurs in the expression, specify your choice of variable in the dialog box that appears. The other variables will be treated as arbitrary constants.

To write a rational expression as a sum of simpler rational expressions
1. Enter the rational expression in mathematics mode and leave the insert point in the expression.
2. Choose Polynomials > Partial Fractions, or
   Choose Calculus > Partial Fractions.
3. Specify variable if Need Polynomial Variable dialog appears.

**Compute > Polynomials > Partial Fractions**

\[
\frac{36}{(x-2)(x-1)^2(x+1)^2} = \frac{4}{x-2} - \frac{9}{(x-1)^2} - \frac{3}{(x+1)^2} - \frac{4}{x+1}
\]

\[
\frac{x^3+x^2+1}{x(x-1)(x^2+x+1)(x^2+1)^2} = \frac{\frac{3}{2}x^2 + \frac{3}{2}}{x^2+1} - \frac{\frac{1}{2}x^2 + \frac{1}{2}}{x^2+1} + \frac{15}{x^2+1} + \frac{1}{8(x-1)} = \frac{x+1}{x^2+x+1} - \frac{1}{x}
\]

(Variable: \(y\)) \[ \frac{\frac{3}{2}y^2}{(x-y)^2(x+1)} = \frac{\frac{3}{2}y^2}{(x-y)^2(x+1)} - \frac{1}{(x-y)(x+1)} \]

(Variable: \(x\)) \[ \frac{y^3}{(x-y)^2(x+1)} = \frac{y^3}{(x+y)(x^2+2y+1)} - \frac{y^3}{(x-y)(x^2+2y+1)} = \frac{y}{(x-y)^2} \]

This operation does not accept decimal or floating-point numbers, so write the coefficients as integers or quotients of integers. Use
Chapter 3 | Algebra

Compute > Rewrite > Rational if you have expressions with decimal or floating-point numbers (see Real Numbers, page 23).

Collecting and Ordering Terms

The Sort command on the Polynomials submenu collects numeric coefficients of terms of a polynomial expression and returns the terms in order of decreasing degree. The Collect command on the Polynomials submenu collects all coefficients of terms of a polynomial expression, but does not necessarily sort the terms by degree. Specify your choice of polynomial variable in the dialog box that appears.

**Compute > Polynomials > Sort**

\[ x^2 + 3x + 5 - 3x^3 + 5x^2 + 4x^3 + 13 + 2x^4 = 2x^4 + x^3 + 6x^2 + 3x + 18 \]

\[ 5t^2 + 3tx^2 - 16t^5 + y^3 - 2tx^2 + 9 = t^2x - 16t^5 + 5t^2 + y^3 + 9 \] (Variable: \( x \))

\[ 5t^2 + 3tx^2 - 16t^5 + y^3 - 2tx^2 + 9 = -16t^5 + t^2(x + 5) + y^3 + 9 \] (Variable: \( t \))

**Compute > Polynomials > Collect**

\[ 5t^2 + 3tx^2 - 16t^5 + y^3 - 2tx^2 + 9 = t^2x - (16t^5 + 5t^2 - y^3 - 9) \] (Variable: \( x \))

\[ 5t^2 + 3tx^2 - 16t^5 + y^3 - 2tx^2 + 9 = -16t^5 + (x + 5)t^2 + y^3 + 9 \] (Variable: \( t \))

Factoring Polynomials

The ability to factor polynomials is an important algebraic tool. You will find that the factoring capabilities of your computer algebra system are powerful and useful. You can factor polynomials with integer or rational roots and with other roots directly related to the coefficients of the expanded polynomial. To factor a polynomial, you must type it without using decimal notation.

**To factor a polynomial with exact coefficients**

- With the insert point in the polynomial, choose Compute > Factor.

**Compute > Factor**

\[ 5x^3 + 5x^4 - 10x^3 - 10x^2 + 5x + 5 = 5(x - 1)^2(x + 1)^3 \]

\[ \frac{1}{16}x^2 - \frac{7}{5}x + \frac{1}{6}ix - \frac{66}{16}i = \frac{1}{16}(x - \frac{113}{8})(x + \frac{6}{5}i) \]

\[ 120x^3 + 20(-3 + 2\sqrt{3})x^2 - \frac{5}{2}(8\sqrt{3} - 3)x + \frac{5}{2}\sqrt{3} = 120(x + \frac{1}{2}\sqrt{3})(x - \frac{1}{4})^2 \]

Floating-point numbers

Numbers such as 1.5 are interpreted as floating-point numbers, and Factor does not handle polynomials with floating-point coefficients. Replace decimal numbers with fractions (such as \( 1.5 = \frac{3}{2} \)) using Rewrite > Rational, and then choose Factor.
The Factor command is effective primarily for polynomials with
integer or rational coefficients, although it also factors polynomials
whose roots are closely related to the coefficients, as demonstrated in
two of the preceding examples. Technically, the polynomial is fac-
tored over the field generated by its coefficients. If all the coefficients
are rational, then the polynomial is factored over the rationals. If you
know the form of the root, you can multiply by an appropriate expres-
sion to obtain a factorization.

\[
\text{Compute} \triangleright \text{Factor}
\]
\[
5x^2 + x + 3 = 5x^2 + x + 3
\]
\[
i\sqrt{59} (5x^2 + x + 3) = 5i\sqrt{59} \left( x + \frac{1}{10} - \frac{i}{10}i\sqrt{59} \right) \left( x + \frac{1}{10} + \frac{i}{10}i\sqrt{59} \right)
\]

Alternatively, while in mathematics mode, type \textit{factor}, enter the
polynomial inside parentheses, and choose Evaluate. For the com-
mand expand, type \textit{xpnd} in mathematics mode. If your system is
not set for automatic recognition, you can enter \textit{factor} or \textit{expand} as a
Math Name.

\[
\text{Compute} \triangleright \text{Evaluate}
\]
\[
\text{factor} \left( 5x^5 + 5x^4 - 10x^3 - 10x^2 + 5x + 5 \right) = 5 \left( x - 1 \right)^2 \left( x + 1 \right)^3
\]
\[
\text{expand} \left( 5 \left( x - 1 \right)^2 \left( x + 1 \right)^3 \right) = 5x^5 + 5x^4 - 10x^3 - 10x^2 + 5x + 5
\]

You can factor not only the difference of two squares and the sum
and difference of two cubes, but also the difference of any two equal
powers.

\[
\text{Compute} \triangleright \text{Factor}
\]
\[
x^2 - y^2 = (x - y) (x + y)
\]
\[
x^3 - y^3 = (x - y) (x^2 + xy + y^2)
\]
\[
x^4 - y^4 = (x - y) (x + y) (x^2 + y^2)
\]

You can also factor the sum of any two equal odd powers.

\[
\text{Compute} \triangleright \text{Factor}
\]
\[
x^3 + y^3 = (x + y) (x^2 - xy + y^2)
\]
\[
x^5 + y^5 = (x + y) (x^4 - x^3y + x^2y^2 - xy^3 + y^4)
\]
\[
x^7 + y^7 = (x + y) (x^6 - x^5y + x^4y^2 - x^3y^3 + x^2y^4 - xy^5 + y^6)
\]
Chapter 3 | Algebra

Greatest Common Divisor of Two Polynomials

The greatest common divisor of two or more polynomials is computed in the same way as the greatest common divisor of two or more integers. (See Greatest Common Divisor, page 22.)

To find the greatest common divisor of two or more polynomials

1. Type \( \text{gcd} \) in mathematics mode. (This changes to a gray \( \text{gcd} \) as you type the final \( d \).)

2. Type the polynomials enclosed by parentheses and separated by commas.

3. Choose Compute > Evaluate.

\[
\text{gcd}(5x^2 - 5x, 10x - 10) = 5x - 5
\]

\[
\text{gcd}\left(x^2 + 3x + yx + 3y, x^2 - 4yx - 5y^2, 3x^2 + 2yx - y^2\right) = x + y
\]

You can check these results by factoring the polynomials and comparing the factors.

\[
\text{Compute} > \text{Factor}
\]

\[
x^2 + 3x + yx + 3y = (x + 3)(x + y)
\]

\[
x^2 - 4yx - 5y^2 = (x - 5y)(x + y)
\]

\[
3x^2 + 2yx - y^2 = (3x - y)(x + y)
\]

The least common multiple function (see Least Common Multiple, page 22) is also available for polynomials.

To find the least common multiple of two or more polynomials

1. Type \( \text{lcm} \) in mathematics mode. (It will turn gray.)

2. Type the polynomials enclosed by parentheses and separated by commas.

3. Choose Evaluate.

\[
\text{Compute} > \text{Evaluate}
\]

\[
\text{lcm}(yx + 3x - 5y - 15, xz - 5z - 5x + 265
\]

\[
= 265y - 159x - 15z - 53xy + 3xz - 5yz + xyz + 795
\]
Substitution

Apply Factor to the polynomials and to their least common multiple to reveal the relationship among these polynomials.

**Compute > Factor**

\[yx + 3x - 5y - 15 = (y + 3)(x - 5)\]
\[xz - 53x - 5z + 265 = (z - 53)(x - 5)\]
\[265y - 159x - 15z - 53xy + 3xz - 5yz + xyz + 795 = (z - 53)(y + 3)(x - 5)\]

**Substitution**

Use common notation for variable substitution:

\[F(x) \big|_{x=a} = F(a) \quad \text{and} \quad F(x) \big|_{x=b} = F(b) - F(a)\]

**Substituting for a Variable**

To substitute a number or new expression for a variable
1. Enclose the expression in square brackets.
2. Choose Insert > Math Objects > Subscript.
3. Type an assignment for the variable in the subscript input box.
4. Choose Compute > Evaluate.

**Compute > Evaluate**

\[x^2 + 2x - 3 \big|_{x=a} = a^2 + 2a - 3 \quad \text{and} \quad x^2 + 2x - 3 \big|_{x=5} = 32\]
\[x + y \big|_{x=y+z} = 2y + z \quad \text{and} \quad x + y \big|_{y=x-z} = 2x - z\]
\[x^2 + 2x - 3 \big|_{y=x-z} = 2y - 2z + (y - z)^2 - 3\]

**Evaluating at Endpoints**

To substitute two expressions for a variable and compute the difference
1. Enclose the expression in square brackets.
2. Choose Insert > Math Objects > Subscript.
3. Type an assignment for the variable in the subscript input box.
4. Press tab to create a superscript box.
5. Type another assignment for the variable in the superscript input box.

**Assignments**

The expression in the subscript is an assignment for the variable on the left of the equals sign. Notice that, in particular, \(x = a\) and \(a = x\) are not equivalent assignments; and \(x = y + z, y = x - z,\) and \(z = x - y\) are not equivalent assignments.
Solving Equations

You can solve polynomial equations by choosing Compute > Polynomials > Roots or by choosing Compute > Solve. We first look at examples for finding roots of polynomials. Then we look at the more general problems of solving equations with one or more variables.

Roots of Polynomials

If zero is obtained when a number is substituted for the variable in a polynomial, then that number is a root of the polynomial. In other words, the roots of a polynomial \( p(x) \) are the solutions to the equation \( p(x) = 0 \). For example, \( 1 \) is a root of \( x^2 - 1 \) since \( [x^2 - 1]_{x=1} = 0 \).

You can find all real and complex roots of a real or complex polynomial with rational coefficients by choosing Compute > Polynomials > Roots.

To find the roots of a polynomial

1. Type the polynomial and leave the insert point in the expression.

2. Choose Compute > Polynomials > Roots.

You can simplify complex radical expressions with Rewrite > Rectangular.

\[
\begin{align*}
5x^2 + 2x - 3, \text{ roots: } & -1, \frac{3}{5} \\
x^3 - \frac{13}{2}x^2 - 8x^2 + \frac{29}{2}ix + \frac{81}{2}x + 6i - \frac{18}{2}, \text{ roots: } & 3, 5 + 3i, -\frac{2}{5}i
\end{align*}
\]

Useful Fact

A number \( r \) is a root of a polynomial if and only if \( x - r \) is a factor of that polynomial.
Solving Equations

To find (only) real roots of a polynomial
1. While in mathematics mode, type \( \text{assume} \ (x, \text{real}) \) and choose Compute > Evaluate.

2. Place the insert point in the polynomial and choose Compute > Polynomials > Roots.

Compute > Evaluate
\[ \text{assume} \ (x, \text{real}) = \mathbb{R} \]

Compute > Polynomials > Roots
\[ x^3 - \frac{13}{2} ix^2 - 8x^2 + \frac{29}{2} ix + \frac{81}{5} x + 6i - \frac{18}{5}, \text{ roots: 3} \]
\[ 5x^2 + x + 3, \text{ roots: } \emptyset \]

The symbol \( \emptyset \) denotes the empty set, meaning there is no real solution.

To return to the default mode
1. While in mathematics mode, type \( \text{unassume} \ (x) \).

2. Choose Compute > Evaluate.

It follows from the Fundamental Theorem of Algebra that the number of roots (including complex roots and counting multiplicities) is the same as the degree of the polynomial. For polynomials with rational (real or complex) coefficients, the computer algebra system uses the usual formulas for finding roots symbolically for polynomials of degree 4 or less, and it finds the roots numerically for polynomials of higher degree. This implementation was dictated by the mathematical phenomenon that there is no general formula in terms of radical expressions for the roots of polynomials of degree 5 and higher. For polynomials of any degree with floating point or decimal coefficients, the computer algebra system finds the roots numerically.

Second-Degree Polynomials
You can obtain the familiar quadratic formula for roots of \( ax^2 + bx + c \). The solution includes all cases. The logical symbol \( \land \) is used for AND, so \( a = 0 \land b = 0 \land c = 0 \) is the case that all three coefficients, \( a, b, c \), are zero. (Interpret this as \((a = 0) \land (b = 0) \land (c = 0)\).) The symbol \( \mathbb{C} \) denotes the set of all complex numbers. The symbol \( \emptyset \) denotes the empty set; that is, the case when there are no solutions.
Chapter 3 | Algebra

**Compute > Polynomials > Roots** (Variable: \(x\))

\[
ax^2 + bx + c, \text{ roots:}
\]
\[
\left\{ \begin{array}{l}
\left( \frac{b - \sqrt{-4ac+b^2}}{2a} \right), \left( \frac{b + \sqrt{-4ac+b^2}}{2a} \right) \\
\{ -\frac{c}{b} \}
\end{array} \right. 
\]

if \(a \neq 0\)

\[
\{ \}
\]

if \(a = 0 \land b \neq 0\)

\[
\{ \}
\]

if \(a = 0 \land b = 0 \land c = 0\)

\[
\{ \}
\]

if \(a = 0 \land b = 0 \land c \neq 0\)

**Third- and Fourth-Degree Polynomials**

The roots of third- and fourth-degree polynomials can be complicated, with multiple embedded radicals in the expressions. To put those roots in simpler form, you may want numerical approximations. You get numerical results if you enter at least one coefficient in decimal notation. You can also get a numerical form directly from the symbolic one by applying Evaluate Numeric to the matrix of roots. The following examples show both a symbolic solution and a numerical solution (with Digits Shown in Results set to 6).

**Compute > Polynomials > Roots**

\[
\sqrt{\frac{1}{2} \sqrt{3} - \frac{1}{2}} - \sqrt{\frac{1}{2} \sqrt{3} - \frac{1}{2}}
\]

\[
x^3 + 3x + 1, \text{ roots:}
\]
\[
\frac{1}{2 \sqrt{\frac{1}{2} \sqrt{3} - \frac{1}{2}}} - \frac{1}{2} \sqrt{\frac{1}{2} \sqrt{3} - \frac{1}{2}} - \frac{i}{2} \sqrt{\frac{1}{2} \sqrt{3} - \frac{1}{2}} + \sqrt{\frac{1}{2} \sqrt{3} - \frac{1}{2}}
\]

\[
\frac{1}{2 \sqrt{\frac{1}{2} \sqrt{3} - \frac{1}{2}}} - \frac{1}{2} \sqrt{\frac{1}{2} \sqrt{3} - \frac{1}{2}} + \frac{i}{2} \sqrt{\frac{1}{2} \sqrt{3} - \frac{1}{2}} + \sqrt{\frac{1}{2} \sqrt{3} - \frac{1}{2}}
\]

\[x^3 + 3x + 1.0, \text{ roots:} -0.32219, 0.16109 - 1.7544i, 0.16109 + 1.7544i\]

Substituting the exact roots for \(x\) in the polynomial \(x^3 + 3x + 1\) gives zero, as it should. Applying Evaluate has little effect, but Simplify gives the following result.

**Compute > Simplify**

\[
x = \frac{1}{2} \sqrt{\frac{1}{2} \sqrt{3} - \frac{1}{2}} - \frac{1}{2} \sqrt{\frac{1}{2} \sqrt{3} - \frac{1}{2}} + \frac{i}{2} \sqrt{\frac{1}{2} \sqrt{3} - \frac{1}{2}} + \sqrt{\frac{1}{2} \sqrt{3} - \frac{1}{2}} = 0
\]
Solving Equations

Using the numerical approximations to the roots, you may get a very small, but nonzero, value. To get closer approximations to the roots, increase the number of digits shown in the display of these roots by making changes in the computation output settings. For details, see Appendix C “Customizing the Program for Computing.”

Compute > Evaluate

\((-0.322185)^3 + 3(-0.322185) + 1.0 = 1.174312318 \times 10^{-6}\)

\((-0.32218535462608559291)^3 + 3(-0.32218535462608559291) + 1 = 4.870126439 \times 10^{-21}\)

Compute > Polynomials > Roots

\(x^4 + 3x^3 - 2x^2 + x + 1.0,\)
roots: \(-3.6096, -0.42898, 0.51928 + 0.61332i, 0.51928 - 0.61332i\)
\(x^4 - 7x^3 + 2x^2 + 64x - 96, \) roots: \(-3, 2, 4, 4\)

Example

The factorization

\[x^3 - \frac{8}{3}x^2 - \frac{5}{3}x + 2 = \frac{1}{3} (x - 3) (3x - 2) (x + 1)\]
identifies the three roots \(3, \frac{2}{3}, -1,\) which are precisely the values of the \(x\)-coordinate where the graph of \(y = x^3 - \frac{8}{3}x^2 - \frac{5}{3}x + 2\) crosses the \(x\)-axis. The plot depicts this polynomial expression. Chapter 6 “Plotting Curves and Surfaces” tells how to create plots.

Example

The factorization of the complex polynomial

\[x^3 - \frac{13}{5}ix^2 - \frac{29}{5}ix + \frac{81}{5}x + 6i - \frac{18}{5} = (x - 3) (x + \frac{2}{5}i) (x - (5 + 3i))\]
displays the three roots \(3, -\frac{2}{5}i, 5 + 3i\).

Polynomials of Degree 5 and Higher

Numerical approximations are returned for roots of polynomials of degree 5 and higher. You can change the number of digits shown in the display of these roots by making changes in the Scientific Notation Output settings at Tools > Preferences > Computation, Output page. For details, see Appendix C “Customizing the Program for Computing.”
Chapter 3 | Algebra

Compute > Polynomials > Roots

5x^5 + 5x^4 - 10x^3 - 10x^2 + 5x + 5, roots: -1.0, -1.0, -1.0, 1.0, 1.0

x^8 + x^7 + x^6 + x^5 + x^4 + x^3 + x^2 + x + 1, roots: 0.76604 - 0.64279i,
-0.5 + 0.86603i, -0.93969 + 0.34202i, -0.5 - 0.86603i, 0.76604 + 0.64279i,
0.17365 + 0.98481i, 0.17365 - 0.98481i, -0.93969 - 0.34202i

Since

x^9 - 1 = \left( x^8 + x^7 + x^6 + x^5 + x^4 + x^3 + x^2 + x + 1 \right) (x - 1)

the roots of x^8 + x^7 + x^6 + x^5 + x^4 + x^3 + x^2 + x + 1 consist of ninth roots of 1. In the complex plane, these points lie on a circle of radius 1.

Equations with One Variable

There are four options on the Solve submenu: Exact, Integer, Numeric, and Recursion. The option Exact is general in nature and is used in most situations. It returns symbolic solutions when it can and numerical solutions otherwise. If any of the components of the problem use numerical notation, the response is a numerical solution. The three options Integer, Numeric, and Recursion are used in more specialized situations. These will be discussed later—see Numerical Solutions, page 56, Numerical Solutions to Equations, page 215, Integer Solutions, page 445, and Recursive Solutions, page 447.

Solutions given for polynomial equations include complex solutions.

To solve an equation with one variable

1. Place the insert point in the equation.

2. Choose Compute > Solve > Exact.

Your system returns an explicit or implicit solution.

Note that in the following examples, integer or rational coefficients yield algebraic solutions and real (floating-point) coefficients yield decimal approximations.

Compute > Solve > Exact

5x^2 + 3x = 1, Solution: \frac{1}{10} \sqrt{29} - \frac{3}{10}, -\frac{1}{10} \sqrt{29} - \frac{3}{10}

5x^2 + 3x = 1.0, Solution: 0.23852, -0.83852

x^3 - 3x^2 + x - 3 = 0, Solution: i, -i, 3
Solving Equations

When there are multiple roots, only distinct roots are displayed.

```
Compute > Solve > Exact
(x - 5)^3 (x + 1) = 0, Solution: 5, -1
```

You can solve equations with rational expressions, and equations involving absolute values.

```
Compute > Solve > Exact
14
--- - 1
a + 2 a - 4 = 1, Solution: 5, 10
|3x - 2| = 5, Solution: \( \{ \frac{5}{3} e^{2ix} + \frac{2}{3} x \in [0, \pi]\} \)
```

If you want only real roots, first evaluate `assume (x, real)`. When you enter these words in mathematics mode, they automatically turn upright and gray. You can also use `Insert > Math Objects > Math Name` to enter `assume (x, real)`. (See Assumptions About Variables, page 111 for more information on the “assume” function.)

```
Compute > Evaluate
assume (x, real) = \(\mathbb{R}\)
```

In general, explicit solutions in terms of radicals for polynomial equations of degree greater than 4 do not exist. In these cases, implicit solutions are given in terms of roots of a polynomial. When the equation is a polynomial equation with degree 3 or 4, the explicit solution can be very complicated—and too large to preview, print, or save. To avoid this problem, you can set the engine to return large complicated solutions in implicit form for smaller degree polynomials as well. See Appendix C “Customizing the Program for Computing” for details.

With a setting of 1 for maximum degree, only rational or other relatively simple solutions are computed for all polynomials. With a setting of 2 or 3, this behavior occurs for polynomials of degree greater than 2.

```
Compute > Solve > Exact
(Maximum Degree set to 1)
5x^2 + 3x = 1, Solution: RootOf \( \frac{3}{5} Z + Z^2 - \frac{1}{5} \)
```

```
x^4 + x = 0, Solution: \{-1, 0\} \cup RootOf \{-Z + Z^2 + 1\}
```
Chapter 3 | Algebra

**Compute > Solve > Exact**

(Maximum Degree set to 2 or 3)

- $5x^2 + 3x = 1$, Solution: $\frac{1}{10} \sqrt{29} - \frac{3}{10}, -\frac{1}{10} \sqrt{29} - \frac{3}{10}$
- $x^4 + x = 0$, Solution: $\frac{1}{2} + \frac{1}{2} i \sqrt{3}, \frac{1}{2} - \frac{1}{2} i \sqrt{3}, -1, 0$
- $x^4 + x - 1 = 0$, Solution: RootOf ($Z + Z^4 - 1$)

**Compute > Solve > Exact**

(Maximum Degree set to 4)

- $x^4 + x = 0$, Solution: $\frac{1}{2} + \frac{1}{2} i \sqrt{3}, \frac{1}{2} - \frac{1}{2} i \sqrt{3}, -1, 0$
- $x^4 + x - 1 = 0$ (Solution too long to display here)

The function solve takes an equation as input. Evaluate solve at an equation and the output is a list of solutions. To make the function name, type `solve` while in mathematics mode and it will automatically gray, or create the name with Insert > Math Objects > Math Name.

**Compute > Evaluate**

$solve (5x^2 + 3x = 1) = \{[x = -\frac{1}{10} \sqrt{29} - \frac{3}{10}], [x = \frac{1}{10} \sqrt{29} - \frac{3}{10}]\}$

**Checking the Answer**

Substitution provides a convenient way of testing solutions.

**Example**

Check the solutions to several of the preceding equations.

**Compute > Evaluate**

$$\left[\frac{14}{a+2} - \frac{1}{a-4}\right]_{a=5} = 1$$

$$[5x^2 + 3x]_{x=0.23852} = 1.0$$

$$[5x^2 + 3x]_{x=-0.83852} = 1.0$$

**Compute > Simplify**

$$[5x^2 + 3x]_{x=-\frac{3}{10} + \frac{1}{10} \sqrt{29}} = 1$$

**Equations with Several Variables**

If there is more than one variable, enter the Variable(s) to Solve for in the dialog box that opens when you choose Compute > Solve > Exact.
## Solving Equations

### Compute > Solve > Exact

1. \( \frac{1}{x} + \frac{1}{y} = 1 \), (Enter \( x \)), Solution:
   \[ \begin{cases} \emptyset & \text{if } y = 1 \\ \left\{ \frac{1}{y} \right\} & \text{if } y \neq 1 \end{cases} \]

2. \( \frac{1}{y} + \frac{1}{z} + \frac{1}{x} = 1 \), (Enter \( z \)), Solution:
   \[ \begin{cases} \emptyset & \text{if } \frac{1}{x} + \frac{1}{y} = 1 \\ \left\{ \frac{1}{y} \frac{1}{z} \right\} & \text{if } \frac{1}{x} + \frac{1}{y} \neq 1 \end{cases} \]

3. \( \frac{1}{r_1} + \frac{1}{r_2} = \frac{1}{R} \), (Enter \( R \)), Solution:
   \[ \begin{cases} \emptyset & \text{if } r_1 + r_2 = 0 \\ \left\{ \frac{r_1 r_2}{r_1 + r_2} \right\} & \text{if } r_1 + r_2 \neq 0 \end{cases} \]

### Systems of Equations

You can create a system of equations either by entering equations in a one-column matrix or by entering equations in a multi-row display.

**To create a system of equations using a matrix**

1. Choose Insert > Math Objects > Matrix.

2. Set the number of rows equal to the number of equations.

3. Set the number of columns to 1, and choose OK.

4. Type the equations in the matrix, one equation to a row.

**Tip**

From the View menu, check Helper Lines or Input Boxes to help place equations in a matrix or display.

**To create a system of equations using a display**

1. Choose Insert > Math Objects > Display.

2. Type the equations in the display, one equation to a row, adding rows as needed with the Enter key.

**To solve a system of equations**

1. Create a system of equations and leave the insert point in the system.

2. Choose Compute > Solve > Exact.

3. If a dialog box opens asking Variable(s) to Solve for, type the variable name(s) in the box, separated by commas.

Following are examples for systems of two equations.
Chapter 3 | Algebra

Compute > Solve > Exact

\[ 2x - y = 5 \]
\[ x + 3y = 4 \]
Solution: \([x = \frac{19}{7}, y = \frac{3}{7}]\)

\[ x^2 - y^2 = 5 \]
\[ x + y = 1 \]
Solution: \([x = 3, y = -2]\)

\[ x^2 - 3y = 7 \]
\[ 6x + 4y = 9 \]
Solution: \([x = \frac{1}{4} \sqrt{30} - \frac{9}{4}, y = \frac{45}{8} - \frac{3}{8} \sqrt{30}]\), \([x = -\frac{1}{4} \sqrt{30} + \frac{9}{4}, y = \frac{3}{8} \sqrt{30} + \frac{45}{8}]\)

When the number of unknowns is larger than the number of equations, you are asked to specify variables in a dialog box.

Compute > Solve > Exact

\[ x + 3y = 4 \]
\[ 3x - 4z = 7 \]
Variable(s): \(x, y\)
Solution: \([x = \frac{4}{3}z + \frac{7}{3}, y = \frac{4}{3} - \frac{4}{9}z]\)

\[ 2x - y = 1 \]
\[ x + 3z = 4 \]
Variable(s): \(x, y, z\)
\[ w + x = -3 \]
Solution: \([x = -w - 3, y = -2w - 7, z = \frac{1}{3}w + \frac{7}{3}]\)

Numerical Solutions

You can find numerical solutions in two ways. You can choose Compute > Solve > Exact after entering at least one coefficient in floating-point form—that is, with a decimal.

Compute > Solve > Exact

\[ x^2 + 7x - 5.2 = 0 \]
Solution: 0.67732, -7.6773

\[ x^3 - 3.8x - 15.6 = 0 \]
Solution: 3.0, -1.5 + 1.7176i, -1.5 - 1.7176i

You can choose Compute > Solve > Numeric. This gives all solutions, both real and complex, to a polynomial equation or system of polynomial equations.
Solving Equations

**Compute > Solve > Numeric**

\[ x^2 + 7x - 5.2 = 0 \]
Solution: \[ \{ [x = 0.67732], [x = -7.6773] \} \]

\[ x^3 - 3.8x - 15.6 = 0 \]
Solution: \[ \{ [x = -1.5 + 1.7176i], [x = -1.5 - 1.7176i], [x = 3.0] \} \]

\[ x^8 + 3x^2 - 1 = 0 \]
Solution: \[ \{ [x = -1.0023 + 0.63210i], [x = -1.0023 - 0.63210i], [x = 1.0023 + 0.63210i], [x = 1.0023 - 0.63210i], [x = -0.57394], [x = -1.2408i], [x = 1.2408i] \} \]

\[
\begin{pmatrix}
  x^2 + y^2 = 5 \\
  x^2 - y^2 = 1
\end{pmatrix},
\]
Solution: \[ \{ [x = -1.7321, y = -1.4142], [x = 1.7321, y = -1.4142], [x = 1.7321, y = 1.4142] \} \]

The choice Compute > Solve > Numeric is particularly useful when solving transcendental equations or systems of transcendental equations, or when you want to specify a search interval for the solution.

**To find a numerical solution within a specified range of the variable**

1. Add a row to the bottom of the matrix, or
   Press Enter to generate a new input box in a display.

2. Write the intervals of your choice, and use the membership symbol \( \in \) to indicate that the variable lies in that interval.

**Compute > Solve > Numeric**

\[ x^2 + y^2 = 5 \]
\[ x^2 - y^2 = 1 \]
\[ x \in (-2, 0) \]
\[ y \in (0, 2) \]
Solution: \[ \{ x = -1.7321, y = 1.4142 \} \]

**To find all numerical solutions to a system of polynomial equations**

1. Change at least one of the coefficients to floating-point form.

2. Choose Compute > Solve > Exact.

**Compute > Solve > Exact**

\[ x^2 + y^2 = 5.0 \]
\[ x^2 - y^2 = 1.0 \]
Solution:
\[ \{ y = -1.4142, x = 1.7321 \} \]
\[ \{ y = -1.4142, x = -1.7321 \} \]
\[ \{ y = 1.4142, x = 1.7321 \} \]
\[ \{ y = 1.4142, x = -1.7321 \} \]

57
These four solutions are illustrated in the graph on the right, as the four points of intersection of two curves. See Implicit Plots on page 132 for guidelines on making such graphs.

See Appendix C “Customizing the Program for Computing” for details on changing the appearance of these numerical solutions by re-setting Digits Rendered, Upper Threshold, and Lower Threshold for Scientific Notation Output.

### Inequalities

You can find exact solutions for many inequalities.

**To solve an inequality**

- With the insert point in the inequality, choose Compute > Solve > Exact.

```
Compute > Solve > Exact
16 - 7y ≥ 10y - 4, Solution: \(-\infty, \frac{20}{17}\)
```

```
x^3 + 1 > x^2 + x, Solution: (-1, 1) ∪ (1, ∞)
x^2 + 2x - 3 > 0, Solution: (1, ∞) ∪ (-∞, -3)
|2x + 3| ≤ 1, Solution: \(\frac{1}{3}xe^y - \frac{1}{3}|x| \in [0, 1], y \in [0, 2\pi]\)
```

```
7 - 2x > x - 2, Solution: (2, 7]
```

These solutions are intervals—open, closed, or half-open and half-closed:

```
(a, b) = \{x : a < x < b\} \quad [a, b] = \{x : a ≤ x ≤ b\}
(a, b] = \{x : a < x ≤ b\} \quad [a, b) = \{x : a ≤ x < b\}
```

For two sets (intervals) \(A\) and \(B\),

```
A ∪ B = \{x : x ∈ A or x ∈ B\}
A ∩ B = \{x : x ∈ A and x ∈ B\}
```

The solution to the last inequality, \(x^2 + 2x - 3 > 0\), can also be read from the graph of the polynomial \(y = x^2 + 2x - 3\). In the plot on the right, you see the graph passes through the \(x\)-axis at \(x = -3\) and \(x = 1\), and the solution includes every point to the left of \(-3\) or to the right of \(1\).
Defining Variables and Functions

The Definitions commands enable you to define a symbol to be a mathematical object and to define a function using an expression or a collection of expressions. Four operations on the Define submenu—New Definition, Undefine, Show Definitions, Clear Definitions—are explained briefly in this section for the types of expressions and functions that occur in precalculus.

See Chapter 5 “Function Definitions,” for greater detail on these operations and other aspects of definitions. For examples of these operations pertinent to topics such as calculus, vector calculus, and matrix algebra, see the chapter covering the topic.

Assigning Values to Variables

You can assign a value to a variable using Definitions > New Definition.

To assign the value 5 to \( z \)

1. Type \( z = 5 \) in mathematics mode.
2. Choose Compute > Definitions > New Definition.

Thereafter, until you undefine the variable, the system recognizes \( z \) as 5 and will evaluate the expression \( 3 + z \) as 8.

Variables normally have single-character names. (See Valid Names for Functions and Expressions or Variables on page 100 for other possibilities.) The value assigned can, however, be any mathematical expression. For example, you could define a variable to be any of the following:

- Number: \( a = 245 \)
- Polynomial: \( p = x^3 + 3x^2 - 5x + 1 \)
- Rational expression: \( b = \frac{x^2 + 1}{x^2 + 1} \)
- Matrix: \( z = \begin{bmatrix} a & b \\ c & d \end{bmatrix} \)

Defining Functions of One Variable

You follow a similar procedure to define a function. Write a function name followed by parentheses containing the variable, and set this equal to an expression.

Defined expressions

The symbol \( p \) defined here represents the expression \( x^3 + 3x^2 - 5x + 1 \). It is not a function, and in particular, \( p(2) \) is not the expression evaluated at \( x = 2 \). In fact, \( p(2) \) is interpreted simply as the product \( 2p = 2x^3 + 6x^2 - 10x + 2 \).

Defined Functions

Defining \( f(y) = ay^2 + by + c \) defines the same function as defining \( f(x) = ax^2 + bx + c \). The symbol used for the function argument in making the definition does not matter. This point illustrates the subtle but essential difference between expressions and functions. In particular, the two expressions \( y = x^2 + \sqrt{x} \) and \( y = t^2 + \sqrt{t} \) are different (because \( y \) gets replaced by an expression in \( x \) under the first definition and \( y \) gets replaced by an expression in \( t \) under the second definition). However, the functions \( f(x) = x^2 + \sqrt{x} \) and \( f(t) = t^2 + \sqrt{t} \) are identical.
Chapter 3 | Algebra

To define the function \( f \) whose value at \( x \) is \( ax^2 + bx + c \)

1. In mathematics mode, type \( f(x) = ax^2 + bx + c \).

2. Choose Compute > Definitions > New Definition

Thereafter, until you undefine the function, the symbol \( f \) represents the defined function and behaves like a function.

\[
\text{Compute} \quad \text{Definitions} \quad \text{New Definition}
\]

\[
\begin{align*}
f(x) & = ax^2 + bx + c \\
\end{align*}
\]

\[
\text{Compute} \quad \text{Evaluate}
\]

\[
\begin{align*}
f(t) & = at^2 + bt + c \\
f(-6) & = 36a - 6b + c \\
f(17) & = 289a + 17b + c \\
\end{align*}
\]

If \( g \) and \( h \) are previously defined functions, then the following equations are examples of legitimate definitions:

- \( f(x) = 2g(x) \)
- \( f(x) = g(x) + h(x) \)
- \( f(x) = g(x)h(x) \)
- \( f(x) = g(h(x)) \)

Make a definition for \( g \) and \( h \), and then apply Evaluate to \( f(t) \) for each definition of \( f \). Each time you redefine \( f \), the new definition replaces the old one. Also, once you have defined both \( g(x) \) and \( f(x) = 2g(x) \), then changing the definition of \( g(x) \) redefines \( f(x) \).

The algebra of functions includes objects such as \( f \pm g \), \( f \circ g \), \( fg \), and \( f^{-1} \). For the value of \( f + g \) at \( x \), write \( f(x) + g(x) \); for the value of the composition of two defined functions \( f \) and \( g \), write \( f(g(x)) \) or \( (f \circ g)(x) \); and for the value of the product of two defined functions, write \( f(x)g(x) \).

You can obtain the inverse for some functions \( f(x) \) by applying Solve > Exact to the equation \( f(y) = x \) and specifying \( y \) as the Variable to Solve for.

To find the inverse (if it exists) of a function \( y = f(x) \)

- Solve the equation \( x = f(y) \) (variable \( y \))

In particular, if \( f(x) = 5x - 3 \), then \( f(y) = 5y - 3 \). Solve the equation \( x = 5y - 3 \) for \( y \) to get \( y = \frac{1}{5}x + \frac{3}{5} \).
Defining Variables and Functions

**Compute > Solve > Exact**

\[ x = f(y), \text{ (Enter } y\text{), Solution: } \frac{1}{5}x + \frac{3}{5} \]

Thus \( f^{-1}(x) = \frac{1}{5}x + \frac{5}{3} \). To check this result, define \( f(x) = 5x - 3 \) and \( g(x) = \frac{1}{5}x + \frac{3}{5} \). (The symbol \( f^{-1} \) will not work as a function name.) Evaluating the expressions \( f(g(x)) \) and \( g(f(x)) \) gives \( f(g(x)) = x \) and \( g(f(x)) = x \), demonstrating that the function \( g \) is indeed the inverse of the function \( f \).

You can use a matrix of inputs to find a matrix of outputs of a defined function.

**To find the value of the expression** \( x^2 + 3x + 5 \) **at** \( x = 0, 1, 2, 3, 4 \)

1. Choose Insert > Math Objects > Matrix and set the number of rows at 6 and the number of columns at 1.

2. Enter \( x \) and five input values in the matrix:

\[
\begin{bmatrix}
0 \\
1 \\
2 \\
3 \\
4 \\
5 \\
\end{bmatrix}
\]

3. Define the function \( f(x) = x^2 + 3x + 5 \) with Compute > Definitions > New Definition.

4. Choose Compute > Matrices > Map function.

5. Enter \( f(x) \) in the Function or Expression dialog box that appears.

**Compute > Matrices > Map Function**

(Enter \( f(x) \) for function.)

\[
\begin{bmatrix}
x \\
0 \\
1 \\
2 \\
3 \\
4 \\
\end{bmatrix}, \text{ result of map } \begin{bmatrix}
x^2 + 3x + 5 \\
5 \\
9 \\
15 \\
23 \\
33 \\
\end{bmatrix}
\]
Chapter 3 | Algebra

Compute > Matrices > Concatenate

\[
\begin{bmatrix}
  x \\
  x^2 + 3x + 5 \\
  0 \\
  5 \\
  1 \\
  9 \\
  2 \\
  15 \\
  3 \\
  23 \\
  4 \\
  33
\end{bmatrix}, \quad \text{Concatenation:} \quad \begin{bmatrix}
  x \\
  x^2 + 3x + 5 \\
  0 \\
  5 \\
  1 \\
  9 \\
  2 \\
  15 \\
  3 \\
  23 \\
  4 \\
  33
\end{bmatrix}
\]

Defining Functions of Several Variables

To define a function of several variables
1. Write an equation such as \( f(x, y, z) = ax + y^2 + 2z \) or \( g(x, y) = 2x + \sin 3xy \).

2. Choose Compute > Definitions > New Definition

Compute > Evaluate

\[
\begin{align*}
  f(1, 2, 3) &= a + 10 \\
  g(1, 2) &= \sin 6 + 2
\end{align*}
\]

Piecewise-Defined Functions

You can define functions of one variable that are described by different expressions on different parts of their domain. These functions are referred to as piecewise-defined functions, case functions or multicase functions. Most of the operations introduced in calculus are supported for piecewise-defined functions. You can evaluate, plot, differentiate, and integrate piecewise-defined functions.

To define a piecewise-defined function \( f \)

1. Type an expression of the form \( f(x) = \).

2. Choose Insert > Math Objects > Brackets, and choose a curly brace \( \{ \) for the left bracket and the dashed vertical line (or null bracket) \( \) for the right bracket.

3. Choose Insert > Math Objects > Matrix.

4. Set the number of rows equal to the number of "pieces."

5. Set the number of columns to 3 or 2.

Note

Piecewise-defined functions must be specified by a two- or three-column matrix with at least two rows. The function values must be in the first column, and the range conditions must be in the last column. If there are only two columns, the "if" must be in text. The matrix must be enclosed by expanding brackets with a left brace and a "null" right delimiter. (The null right delimiter appears as a red dashed line on the screen when Helper Lines are selected on the View menu, and does not appear when the document is printed or when Helper Lines are turned off.)
6. Choose OK.

7. Type function values in the first column.

8. Type if in the second column (in text or mathematics mode if you use 3 columns, and text if 2 columns).

9. Type the range condition in the third column (or in the second column after the “if” if you use only 2 columns), preferably beginning with the smallest values of the variable.

\[
\begin{align*}
f(x) &= \begin{cases} 
x + 2 & \text{if } x < 0 \\
2 & \text{if } 0 \leq x \leq 1 \\
2/x & \text{if } 1 < x 
\end{cases} \\
g(t) &= \begin{cases} 
t & \text{if } t < 0 \\
0 & \text{if } 0 \leq t < 1 \\
1 & \text{if } 1 \leq t < 2 \\
2 & \text{if } 2 \leq t < 3 \\
6 - t & \text{if } 3 \leq t 
\end{cases}
\end{align*}
\]

Note

The function \( f \) has three “cases” or range conditions on the independent variable, and the function \( g \) has five. Note that the intervals for the range conditions are arranged in order with the smallest values of the independent variable in the first row and the largest values in the bottom row.

Defining Generic Functions and Generic Constants

You can choose Compute > Definitions > New Definition to declare an expression of the form \( f(x) \) to be a function without specifying any of the function values or behavior. Thus you can use the function name as input when defining other functions or performing various operations on the function.

To define a generic function

- Place the insert point to the right of an expression of the form \( f(x) \) and choose Compute > Definitions > New Definition.

In the following example, we define \( f \) as a generic function and we define a particular function \( h \) to illustrate the behavior of \( f \).

\[
\begin{align*}
f(x) &= \frac{x-1}{x+1} \\
h(x) &= \frac{x-1}{x+1}
\end{align*}
\]
Chapter 3 | Algebra

**Compute > Evaluate**

\[
h(f(x)) = \frac{f(x) - 1}{f(x) + 1} \\
f(h(x)) = f\left(\frac{x - 1}{x + 1}\right)
\]

You can choose Compute > Definitions > New Definition to declare a character to be a constant.

**To declare a character to be a (generic) constant**
- Place the insert point to the right of the character and choose Compute > Definitions > New Definition.

**Compute > Definitions > New Definition**

\[a\]

**Showing and Removing Definitions**

After making definitions of functions or expressions, you need to know techniques for keeping track of them, saving them, and deleting them.

**To view the list of currently defined variables and functions**
- Choose Compute > Definitions > Show Definitions.

**Example**
Define \(a = b, p = ax,\) and \(f(x) = ax.\) Choose Compute > Definitions > Show Definitions to see the list

\[
f(x) = ax \\
p = ax \\
a = b
\]

of defined functions and expressions. Evaluation of \(p\) and \(f(x)\) produces \(p = bx\) and \(f(x) = bx.\) Redefining \(a\) with the equation \(a = c\) and again evaluating \(p\) and \(f(x)\) produces \(p = cx\) and \(f(x) = cx.\)

**To remove a definition from a document**
1. Place the insert point in the equation you wish to undefine, or select the name of the function or expression.
2. Choose Compute > Definitions > Undefine.

Choose Compute > Definitions > Show Definitions to verify that the definition has been removed from the list of defined functions and expressions.

**Show Definitions**
Show Definitions opens a window showing the active definitions. In general, the defined variables and functions are listed in the order in which the definitions were made. Check the Show Definitions list from time to time. If your mathematics is behaving strangely, this list is a place to look for a possible explanation.

**Caution**
It is easy to forget that a symbol has been defined to be some expression. If you use that symbol later, you can get surprising results. For example, if you define \(a = x^2,\) forget about it, and later compute \(f(a)\) for some function \(f\) that you have just defined, you are in for a surprise. In complicated computations the error may not be apparent.
Exponents and Logarithms

To remove all definitions from a document
• Choose Compute > Definitions > Clear Definitions.

If you have worked the preceding examples, you have made several definitions and you should remove them before continuing. Definitions that you do not remove remain active as long as a document is open. As a default, definitions are saved and then restored when you reopen a document.

To check for overlooked definitions
• Choose Compute > Definitions > Show Definitions

Exponents and Logarithms

You can work with exponential and logarithmic functions written in their natural forms: \( e^x \), \( \exp x \), \( \log_5 x \), \( \ln x \), and so forth. These functions are inverses of one another, as exemplified by the identities \( e^{\ln x} = x \) and \( \ln e^x = x \).

Exponents and Exponential Functions

Exponential functions are used in modeling many real-life situations. The laws of exponents are an important feature of these functions.

Combining Exponentials

To combine expressions involving exponential functions with base \( e \)
• Choose Compute > Combine > Exponentials or Compute > Expand

\[
\begin{align*}
(\text{e}^x)^y &= \text{e}^{xy} \\
\text{e}^x \text{e}^y &= \text{e}^{x+y}
\end{align*}
\]

Combining Powers

To combine expressions involving exponential functions with symbolic base
• Choose Compute > Combine > Powers (or Compute > Simplify)

\[
\text{Compute} > \text{Combine} > \text{Powers}
\]
\[
a^x a^y = a^{x+y}
\]
Laws of Exponents

You can demonstrate some of the laws of exponents with some of the menu commands. These laws apply for real or complex exponents and for other expressions as well.

To demonstrate laws of exponents

• Choose a menu command.

<table>
<thead>
<tr>
<th>Compute &gt; Combine &gt; Powers</th>
<th>Compute &gt; Combine &gt; Exponentials</th>
</tr>
</thead>
<tbody>
<tr>
<td>$2^x 2^y = 2^{x+y}$</td>
<td>$a^x a^y = a^{x+y}$</td>
</tr>
<tr>
<td>$a^x / a^y = a^{x-y}$</td>
<td></td>
</tr>
<tr>
<td>$10^{x+3} 10^{x-3} = 10^2$</td>
<td></td>
</tr>
</tbody>
</table>

The function exp satisfies $\exp(x) = e^x$. (Note that exp is a gray Math Name.) Exponential expressions are normally returned to your document in the form $e^{f(x)}$ rather than $\exp(f(x))$, unless the expression $f(x)$ is unusually complicated.

Evaluating Exponential Expressions

To evaluate an exponential expression

• Choose Compute > Evaluate, or
  Choose Compute > Evaluate Numeric

For numerical approximations, use Evaluate Numeric or use floating-point notation. You can change the number of digits shown in these approximations by changing the number for Digits rendered in the Scientific Notation Output settings at Tools > Preferences > Computation, Output page. For details, see Appendix C “Customizing the Program for Computing.” In these examples, Digits rendered is set to 5.

<table>
<thead>
<tr>
<th>Evaluate</th>
<th>Evaluate Numeric</th>
</tr>
</thead>
<tbody>
<tr>
<td>$e^2 = e^2$</td>
<td>$e^2 \approx 7.3891$</td>
</tr>
<tr>
<td>$e^{0.0025} = 1.0025$</td>
<td>$e^{0.0025} \approx 1.0025$</td>
</tr>
<tr>
<td>$5^4 = 625$</td>
<td>$5^4 \approx 625.0$</td>
</tr>
<tr>
<td>$2\sqrt{3} = 2\sqrt{3}$</td>
<td>$2\sqrt{3} \approx 4.7111$</td>
</tr>
</tbody>
</table>
Logarithms and Logarithmic Functions

The function \( \ln x \) is interpreted as the natural logarithm—that is, the logarithm with base \( e \). Logarithms to other bases are entered with a subscript on the function \( \log \). Evaluation gives \( \log_5 25 = 2 \) and \( \log_{10} 10^3 = 3 \). By default, the symbol \( \log x \) is also interpreted as the natural logarithm (base \( e \)). You can change this default.

To change the default for the function name \( \log \) from base \( e \) to base 10

2. Click the box to remove the check mark from the line “Base of \( \log \) is \( e \) (otherwise 10).”

Properties of Logarithms

You can demonstrate properties of logarithms with Simplify and Combine. Assume \( x, y, a, b \) are positive for the results below.

<table>
<thead>
<tr>
<th>Evaluate</th>
<th>Evaluate</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \text{assume (x, positive) } = (0, \infty) )</td>
<td>( \text{assume (a, positive) } = (0, \infty) )</td>
</tr>
<tr>
<td>( \text{assume (y, positive) } = (0, \infty) )</td>
<td>( \text{assume (b, positive) } = (0, \infty) )</td>
</tr>
<tr>
<td>( \text{Compute &gt; Simplify} )</td>
<td>( \text{Compute &gt; Combine &gt; Logs} )</td>
</tr>
<tr>
<td>( \ln x^y = y \ln x )</td>
<td>( \ln x + \ln y = \ln (xy) )</td>
</tr>
<tr>
<td>( \log 3^8 = 8 \log 3 )</td>
<td>( \ln a - \ln b = \ln \frac{a}{b} )</td>
</tr>
<tr>
<td>2 ( \ln 3 = \ln 9 )</td>
<td>2 ( \ln 3 = \ln 9 )</td>
</tr>
</tbody>
</table>

Evaluating Logarithmic Expressions

To evaluate a logarithmic expression

- Choose Compute > Evaluate, or
  Choose Compute > Evaluate Numeric

For numerical approximations, use Evaluate Numeric or use floating-point notation. You can change the number of digits shown in these approximations by changing the number for Digits rendered in the Scientific Notation Output settings at Tools > Preferences > Computation, Output page. For details, see Appendix C “Customizing the Program for Computing.” In these examples, Digits rendered is set to 5.
Chapter 3 | Algebra

Solving Exponential and Logarithmic Equations

To find a symbolic solution to an exponential and logarithmic equation

- Choose Compute > Solve > Exact. Enter Variable(s) if requested.

\[
3^x = 8, \ \text{Solution:} \ \{3 \log_3 2 + \frac{2\pi k}{\ln 3} \mid k \in \mathbb{Z}\}
\]

\[
e^x = y, \ \text{Solution:} \ \left\{\begin{array}{ccc}
0 & \text{if} & y = 0 \\
\ln y + 2\pi k & \text{if} & y \neq 0
\end{array}\right. \quad k \in \mathbb{Z}
\]

\[
\sin x = 1/2, \ \text{Solution:} \ \left\{\frac{\pi}{6} + \frac{2\pi k}{\ln 3} \mid k \in \mathbb{Z}\right\} \cup \left\{\frac{5\pi}{6} + \frac{2\pi k}{\ln 3} \mid k \in \mathbb{Z}\right\}
\]

\[
\ln(3x + y) = 8, \ \text{Solution:} \ \frac{1}{3}e^8 - \frac{1}{3}y
\]

Note that the solution to \(e^x = y\) includes both a special case, \(y = 0\), and multiple values. Also the solution to \(\sin x = 1/2\) includes multiple values.

To ignore special cases of a solution

- Choose Tools > Preferences > Computation, Engine page, and check Ignore Special Cases.

\[
3^x = 8, \ \text{Solution:} \ \{3 \log_3 2 + \frac{2\pi k}{\ln 3} \mid k \in \mathbb{Z}\}
\]

To compute only the principal values of a solution

- Choose Tools > Preferences > Computation, Engine page, and check Principal Value Only.

\[
3^x = 8, \ \text{Solution:} \ 3 \log_3 2
\]

\[
\ln 4x^2 = 5, \ \text{Solution:} \ \frac{1}{2}e^{\frac{5}{2}}
\]

\[
\sin x = 1/2, \ \text{Solution:} \ \frac{1}{2}\pi
\]

To find a numerical solution to an exponential and logarithmic equation

- Enter a coefficient in decimal notation and choose Compute > Solve > Exact, or
Toolbars and Keyboard Shortcuts

Choose Compute > Solve > Exact and then choose Compute > Evaluate Numeric, or
With a single variable, choose Compute > Solve > Numeric.

Compute > Solve > Exact (Variable: x)
$3^x = 8.0$, Solution: 1.8928

$\log_5 (4x^2 - 3y) = 5^{\frac{x}{5}}$, Solution: $-\frac{1}{2} \sqrt{3y + 5^{\frac{x}{5}}}$

Compute > Evaluate Numeric
$-\frac{1}{2} \sqrt{3y + 5^{\frac{x}{5}}} \approx -0.5 \sqrt{3.0y + 5.4494 \times 10^{103}}$

Compute > Solve > Numeric
$3^x = 8$, Solution: $\{x = 1.8928\}$

Toolbars and Keyboard Shortcuts

This manual gives most instructions in terms of menu items. Toolbars and keyboard shortcuts are designed to make common tasks both easier and faster. See Appendix A “Menus, Toolbars, and Shortcuts for Doing Mathematics” and Appendix B “Menus, Toolbars, and Shortcuts for Entering Mathematics” for details. See Appendix C “Customizing the Program for Computing” for details on customizing toolbars to suit your needs.

Math Toolbar

The Math Toolbar contains clickable buttons that duplicate many menu items. If it does not appear above your document window, choose View > Toolbars and check Math Toolbar.

Symbol Toolbar

The Symbol Toolbar makes it convenient to enter a wide variety of special symbols. If it does not appear above your document window, choose View > Toolbars and check Symbol Toolbar. These buttons are also available in a Sidebar.

Keyboard Shortcuts

A standard keyboard contains several mathematical symbols such as $+$, $-$, $/$, $<$, and $>$ that can be typed directly. You can also use the following keyboard shortcuts:

Tooltips
Use your mouse and hover over a tool to learn what it does.
### Exercises

1. Given that when $x^2 - 3x + 5k$ is divided by $x + 4$ the remainder is 9, find the value of $k$ by choosing Compute > Polynomials > Divide and then choosing Compute > Solve > Exact.

2. Define functions $f(x) = x^3 + x \ln x$ and $g(x) = x + e^x$. Evaluate $f(g(x))$, $g(f(x))$, $f(x)g(x)$, and $f(x) + g(x)$.

3. Find the equation of the line passing through the two points $(x_1, y_1), (x_2, y_2)$.

4. Find the equation of the line passing through the two points $(2, 5), (3, -7)$.

5. Find the equation of the line passing through the two points $(1, 2), (2, 4)$.

6. Find the slope of the line given by the equation $sx + ty = c$.

7. Factor the difference of powers $x^n - y^n$ for several values of $n$, and deduce a general formula.
8. Applying Factor to \(x^2 + \left(\sqrt{5} - 3\right)x - 3\sqrt{5}\) gives the factorization
\[
x^2 + \left(\sqrt{5} - 3\right)x - 3\sqrt{5} = \left(x + \sqrt{5}\right)(x - 3)
\]
showing that the system can factor some polynomials with irrational roots. However, applying Factor to \(x^2 - 3\) and \(x^3 + 3x^2 - 5x + 1\) does not do anything. Find a way to factor these polynomials.

9. Find the standard form for the equation of the circle \(x^2 - 6x + 18 + y^2 + 10y = 0\) by “completing the square.” Determine the center and radius of this circle.

Solutions

1. Choose Compute > Polynomials > Divide to get
\[
\frac{x^2 - 3x + 5k}{x + 4} = x + \frac{(5k + 28)}{x + 4} - 7
\]
Thus, the remainder is \(5k + 28\). Solve the equation \(5k + 28 = 9\) to get \(k = -\frac{19}{5}\).

2. Defining functions \(f(x) = x^3 + x \ln x\) and \(g(x) = x + e^x\) and evaluating gives
\[
\begin{align*}
f(g(x)) &= (x + e^x)^3 + \ln (x + e^x) (x + e^x) \\
g(f(x)) &= e^{1n.x+x^3} + x \ln x + x^3 \\
f(x)g(x) &= (x + e^x) (x \ln x + x^3) \\
f(x) + g(x) &= x + e^x + x \ln x + x^3
\end{align*}
\]

3. For any two distinct points \((x_1, y_1)\) and \((x_2, y_2)\) in the plane, there is a unique line \(ax + by + c = 0\) through these two points. Substituting these points in the equation for the line gives the two equations \(ax_1 + by_1 + c = 0\) and \(ax_2 + by_2 + c = 0\). Set Tools > Preferences > Computation, Engine page, to Principal Value Only and Ignore Special Cases, then choose Compute > Solve > Exact with the insert point in this system
\[
\begin{align*}
ax_1 + by_1 + c &= 0 \\
ax_2 + by_2 + c &= 0
\end{align*}
\]
Chapter 3 | Algebra

of linear equations, solving for the variables $a, b$.

Solution: \[
\begin{bmatrix}
a = \frac{cy_1 - cy_2}{x_1 y_2 - x_2 y_1} \\
b = -\frac{cx_1 - cx_2}{x_1 y_2 - x_2 y_1}
\end{bmatrix}
\]

Consequently, the equation for the line is

\[
\frac{cy_1 - cy_2}{x_1 y_2 - x_2 y_1} x - \frac{cx_1 - cx_2}{x_2 y_1 - x_1 y_2} y + c = 0
\]

or, clearing fractions and collecting coefficients,

\[
(y_1 - y_2)x - (x_1 - x_2)y + (x_1 y_2 - y_1 x_2) = 0
\]

4. For the points $(2, 5), (3, -7)$, the system of equations is

\[
\begin{align*}
2a + 5b + c &= 0 \\
3a - 7b + c &= 0
\end{align*}
\]

Choose Compute > Solve > Exact to get

Solution: \[
\begin{bmatrix}
a = -\frac{12}{29} c, b = -\frac{1}{29} c
\end{bmatrix}
\]

Consequently, the equation for the line is $-\frac{12}{29} cx - (\frac{1}{29}) cy + c = 0$, or, clearing fractions and simplifying,

\[-12x + y + 29 = 0.
\]

5. Since the point $(0, 0)$ lies on the line, you do not get a unique solution to the system of equations for the pair $a, b$. Thus, choosing Solve + Exact and specifying $a, b$ for the variables gives no response. However, specifying $a, c$ for Variable(s) to Solve for gives the solution

\[
[a = -2b, c = 0]
\]

Thus, the equation for the line is

\[-2bx + by = 0
\]

or, dividing by $b$ and applying Simplify,

\[
(-2bx + by) \frac{1}{b} = -2x + y = 0
\]
6. The slope-intercept form of the equation for a line is \( y = mx + b \), where \( m \) is the slope and \( b \) the y-intercept. If a line is given as a linear equation in the form \( sx + ty = c \), you can find the slope by solving the equation for \( y \). Expand the solution \( y = \frac{c - st x}{t} \) to get \( y = \frac{1}{t} - \frac{s}{t} x \), revealing the slope to be \( -\frac{s}{t} \).

7. Apply factor to several differences:

\[
x^2 - y^2 = (x - y)(x + y)
\]

\[
x^3 - y^3 = (x - y)(x^2 + xy + y^2)
\]

\[
x^4 - y^4 = (x - y)(x + y)(x^2 + y^2)
\]

\[
x^5 - y^5 = (x - y)(x^4 + x^3y + x^2y^2 + xy^3 + y^4)
\]

\[
x^6 - y^6 = (x - y)(x + y)(x^2 + xy + y^2)(x^2 - xy + y^2)
\]

\[
x^7 - y^7 = (x - y)(x^6 + x^5y + x^4y^2 + x^3y^3 + x^2y^4 + xy^5 + y^6)
\]

After looking at only these few examples, you might find it reasonable to conjecture that, for \( n \) odd,

\[
x^n - y^n = (x - y) \sum_{k=0}^{n-1} x^{n-k-1} y^k
\]

We leave the general conjecture for you. Experiment.

8. Using the clue from the example that the system will factor over roots that appear as coefficients, factor the product \( \sqrt{3} \left(x^2 - 3\right) \) to get \( \sqrt{3} \left(x^2 - 3\right) = \sqrt{3} (x - \sqrt{3}) (x + \sqrt{3}) \). Now you can divide out the extraneous \( \sqrt{3} \) to get \( x^2 - 3 = (x - \sqrt{3}) (x + \sqrt{3}) \).

For the polynomial \( x^3 + 3x^2 - 5x + 1 \), choose Compute > Polynomials > Roots to find the roots: \( \left[1, \sqrt{5} - 2, -\sqrt{5} - 2\right] \). You can multiply by \( \sqrt{5} \) to factor this polynomial:

\[
\sqrt{5} \left(x^3 + 3x^2 - 5x + 1\right) = \sqrt{5} \left(x + \sqrt{5} + 2\right) \left(x - \sqrt{5} + 2\right) (x - 1)
\]

Then, dividing out the extraneous factor of \( \sqrt{5} \), you have

\[
x^3 + 3x^2 - 5x + 1 = (x - 1) \left(x + 2 + \sqrt{5}\right) \left(x + 2 - \sqrt{5}\right)
\]
Chapter 3 | Algebra

9. To find the center and radius of the circle

\[ x^2 - 6x + 18 + y^2 + 10y = 0, \]

first subtract the constant term 18 from both sides of the equation to get

\[ x^2 - 6x + 18 + y^2 + 10y - 18 = 0 - 18 \]

Simplify each side of the equation. This gives the equation \( x^2 - 6x + y^2 + 10y = -18 \). Add parentheses to put the equation in the form

\[ (x^2 - 6x) + (y^2 + 10y) = -18. \]

To complete the squares, add the square of one-half the coefficient of \( x \) to both sides. Do the same for the coefficient of \( y \).

\[
\left( x^2 - 6x + \left( \frac{-6}{2} \right)^2 \right) + \left( y^2 + 10y + \left( \frac{10}{2} \right)^2 \right) = -18 + \left( \frac{-6}{2} \right)^2 + \left( \frac{10}{2} \right)^2
\]

Factor the terms \( \left( x^2 - 6x + \left( \frac{-6}{2} \right)^2 \right) \) and \( \left( y^2 + 10y + \left( \frac{10}{2} \right)^2 \right) \):

\[ (x - 3)^2 + (y + 5)^2 = -18 + \left( \frac{-6}{2} \right)^2 + \left( \frac{10}{2} \right)^2 \]

Simplify the right side of the equation to get

\[ (x - 3)^2 + (y + 5)^2 = 16. \]

You can read the solution to this problem from this form of the equation. The center of the circle is \((3, -5)\) and the radius is \(\sqrt{16} = 4\).
Since you are now studying geometry and trigonometry, I will give you a problem. A ship sails the ocean. It left Boston with a cargo of wool. It grosses 200 tons. It is bound for Le Havre. The main mast is broken, the cabin boy is on deck, there are 12 passengers aboard, the wind is blowing east-north-east, the clock points to a quarter past three in the afternoon. It is the month of May. How old is the captain?

Gustave Flaubert (1821–1880)

Trigonometry developed from the study of triangles, particularly right triangles, and the relations between the lengths of their sides and the sizes of their angles. The trigonometric functions that measure the relationships between the sides of similar triangles have far-reaching applications that extend well beyond their use in the study of triangles. While the history of trigonometry is closely connected with geometry and with astronomical studies, it has become essential in many branches of science and technology.

Trigonometric Functions

Most of the trigonometric computations demonstrated here use six basic trigonometric functions. The two fundamental trigonometric functions, sine and cosine, can be defined in terms of the unit circle—the set of points in the Euclidean plane of distance 1 from the origin.

A point on this circle has coordinates \((\cos t, \sin t)\), where \(t\) is a measure (in radians) of the angle at the origin between the positive \(x\)-axis and the ray from the origin through the point measured in the counterclockwise direction.
Chapter 4 | Trigonometry

For $0 < t < \frac{\pi}{2}$, these functions can be found as a ratio of certain sides of a right triangle that has one angle of radian measure $t$.

The other four basic trigonometric functions can be defined in terms of these two—namely,

$$\tan x = \frac{\sin x}{\cos x} \quad \text{sec} x = \frac{1}{\cos x}$$

$$\cot x = \frac{\cos x}{\sin x} \quad \operatorname{csc} x = \frac{1}{\sin x}$$

**To enter a trigonometric function**

- Put the insert point in mathematics mode and type the three letters of the function name. (The function name automatically turns gray when you type the final letter of the name.)

On the domain of real numbers, the sine and cosine functions take values in the interval $[-1, 1]$. To restrict computations to real numbers, you can use the function "assume."

**To make the assumption that variables are real**

1. Type `assume` in mathematics mode. It will automatically turn upright and gray when you type the final letter.

2. Inside parentheses, type `$x$, real` (or any variable name in place of $x$). The math "real" will automatically turn upright and gray when you type the final letter.

3. Choose Compute > Evaluate.

**Tip**
See page 111 for further information on making assumptions about variables.

**Function names**
The symbols used for the six basic trigonometric functions—$\sin$, $\cos$, $\tan$, $\cot$, $\sec$, $\csc$—are abbreviations for the words sine, cosine, tangent, cotangent, secant, and cosecant, respectively.

**Note**
The sine and cosine functions are defined for all real and complex numbers. In this section, we address only real numbers. For complex arguments, see page 92.

**Caution**
The default behavior of your system allows trigonometric functions without parentheses.
Radians and Degrees

The notation you use determines whether the argument is interpreted as radians or degrees.

\begin{align*}
\text{Compute} & \rightarrow \text{Evaluate Numeric} \\
\sin 30 & \approx -0.98803 \\
\sin 30^\circ & \approx 0.5 \text{ (small red circle as superscript)} \\
\sin 30^\circ & \approx 0.5 \text{ (green Unit Name)}
\end{align*}

The degree symbol is available in two forms—a green Unit Name or a small red circle entered as a superscript. With no symbol, the argument of a trigonometric function is interpreted as radians, and with either a green or red degree symbol, the argument is interpreted as degrees. All operations will convert angle measure to radians.

\textbf{To enter the angle 33°47′13″ with green degrees, minutes, and seconds}

1. In mathematics mode type 33.
2. Choose Insert \textgreater\ Math Objects \textgreater\ Unit Name and select Plane Angle, Degree.
3. Type 47.
4. Choose Insert \textgreater\ Math Objects \textgreater\ Unit Name and select Plane Angle, Minute.
5. Type 13.
6. Choose Insert \textgreater\ Math Objects \textgreater\ Unit Name and select Plane Angle, Second.

\textbf{To enter the angle 33°47′13″ with red degrees, minutes, and seconds}

- In mathematics mode type 33.
- Choose Insert \textgreater\ Math Objects \textgreater\ Superscript and from the Symbol toolbar select the Binary operations tool and click the small red circle \(\circ\).
- Press Enter and type 47′13″ where the double quote is entered by typing ‘ twice.

Numerically evaluating an angle in degrees gives a numerical result in radians.
Chapter 4 | Trigonometry

**Compute > Evaluate Numeric**

33°47′13″ ≈ 0.58969 rad (Green Unit Names)
33°47′13″ ≈ 0.58969 rad (Small red degrees, minutes, seconds)

When any operation is applied, degrees are automatically converted to radians. To go in the other direction, solve for the number of degrees.

*To convert radians to degrees symbolically*

1. Start with an equation such as $2 = \theta^\circ$, using the red degree symbol.

2. Choose Compute > Solve > Exact.

**Compute > Solve > Exact**

$2 = \theta^\circ$, Solution: $\frac{360}{\pi}$

Thus 2 radians = $\frac{360}{\pi}$ degrees.

*To convert radians to degrees numerically*

1. Start with an equation such as $2\text{ rad} = \theta^\circ$, using the green unit name symbol.

2. Choose Compute > Solve > Exact.

**Compute > Solve > Exact**

$2\text{ rad} = \theta^\circ$, Solution: 114.59

Thus $2\text{ rad} = 114.59^\circ$.

**Solving Trigonometric Equations**

When evaluating the trigonometric functions, translations by integer multiples of $\pi$ are eliminated from the argument. Further, arguments that are rational multiples of $\pi$ lead to simplified results. Explicit expressions are returned for the arguments

\[
0, \frac{\pi}{2}, \frac{\pi}{3}, \frac{2\pi}{3}, \frac{\pi}{4}, \frac{2\pi}{4}, \frac{\pi}{5}, \frac{2\pi}{5}, \frac{\pi}{6}, \frac{2\pi}{6}, \frac{\pi}{8}, \frac{2\pi}{8}, \frac{\pi}{10}, \frac{2\pi}{10}, \frac{\pi}{12}, \frac{2\pi}{12}
\]

as well as for the same angles expressed in degrees.

*To find values of the trigonometric functions*

1. Place the insert point in a trigonometric expression.

2. Choose Compute > Evaluate, or

Choose Compute > Evaluate Numeric.
Trigonometric Functions

- **Compute > Evaluate**
  \[
  \sin \frac{3\pi}{4} = \frac{1}{2}\sqrt{2} \\
  \sin 1 = \sin 1 \\
  \sin 60^\circ = \frac{1}{2}\sqrt{3} \\
  \sin (-x) = -\sin x \\
  \cos (x + 7\pi) = -\cos x \\
  \cot \frac{\pi}{8} = \sqrt{2} + 1
  \]
  All arguments that are rational multiples of \(\pi\) are transformed to arguments from the interval \([0, \frac{\pi}{2})\).

- **Compute > Evaluate Numeric**
  \[
  \sin \frac{3\pi}{4} \approx 0.70711 \\
  \sin 1 \approx 0.84147 \\
  \sin 60^\circ \approx 0.86603 \\
  \sin (-x) \approx -1.0\sin x \\
  \cos (x + 7\pi) \approx -1.0\cos x \\
  \cot \frac{\pi}{8} \approx 2.4142
  \]

**Tip**
Choose Tools > Preferences > Computation > Output to set the number of digits rendered in response to Evaluate Numeric.

- **Compute > Evaluate**
  \[
  \sin \frac{\pi}{2} = \sin \left(\frac{\pi}{2}\right) \\
  \cos \left(-\frac{20\pi}{11}\right) = \cos \left(\frac{2\pi}{11}\right) \\
  \tan \frac{123\pi}{11} = \tan \left(\frac{2\pi}{11}\right)
  \]

  You can choose both Compute > Solve > Exact and Compute > Solve > Numeric to find solutions to trigonometric equations. These operations also convert degrees to radians. Use of decimal notation in the equation gives you a numerical solution.

  With radians or with red degree symbols, Solve > Exact gives symbolic solutions and Solve > Numeric gives numerical solutions.

- **Compute > Solve > Exact**
  \[
  x = \sin \frac{\pi}{4}, \text{ Solution: } \frac{1}{2}\sqrt{2} \\
  \sin 22^\circ = \frac{14}{15}, \text{ Solution: } \frac{14}{\sin \frac{14}{15}\pi} \\
  x = 3^\circ 54', \text{ Solution: } \frac{13}{600}\pi
  \]
  With green unit name symbols, Solve > Exact gives numerical solutions.

- **Compute > Solve > Exact**
  \[
  x = \sin \frac{\pi}{4}, \text{ Solution: } \{x = 0.70711\} \\
  \sin 22^\circ = \frac{14}{15}, \text{ Solution: } \{c = 37.373\} \\
  x = 3^\circ 54', \text{ Solution: } \{x = 0.068068\}
  \]

To solve a trigonometric equation
1. Place the insert point in the equation.
2. Choose Compute > Solve > Exact, or Choose Compute > Solve > Numeric.
Chapter 4 | Trigonometry

The command Solve > Exact finds a complete solution in many cases, either symbolic or numerical depending on the form of the equation.

Compute > Solve > Exact
\[
sin t = \sin 2t, \text{ Solution: } \{2\pi k \mid k \in \mathbb{Z}\} \cup \left\{ \frac{1}{2} \pi + \frac{2}{3} \pi k \mid k \in \mathbb{Z}\right\}
\]
\[2 \sin x + 5 \cos x = 5, \text{ Solution: } \{2\pi k \mid k \in \mathbb{Z}\} \cup \left\{-i \ln \left(\frac{21}{29} + \frac{20}{29} i\right) + 2\pi k \mid k \in \mathbb{Z}\right\}
\]
The command Solve > Numeric finds one numerical solution.

Compute > Solve > Numeric
\[
sin t = \sin 2t, \text{ Solution: } \{t = 0.0\}\}
\]
\[2 \sin x + 5 \cos x = 5, \text{ Solution: } \{x = 0.0\}\}

To find a numerical solution in a specified interval
1. Enter the equation and a range in different rows of a one-column matrix.
2. Choose Compute > Solve > Numeric.

Compute > Solve > Numeric
\[
\left[\begin{array}{l}
\sin t = \sin 2t \\
t \in (0.5, 2.5)
\end{array}\right], \text{ Solution: } [t = 1.0472]
\]

Here is an example illustrating how plots of functions are helpful for selecting intervals for numeric solutions—especially when the solutions are not periodic in nature.

Compute > Solve > Numeric
\[
\left[\begin{array}{l}
x = 10 \sin x \\
x \in (5, 7.5)
\end{array}\right], \text{ Solution: } [x = 7.0682]
\]

The interval (5, 7.5) was specified for the solution. By specifying other intervals, you can find all seven solutions: \(x = 0, \pm 2.8523, \pm 7.0682, \pm 8.4232\). These are depicted as the intersection points of the graphs of \(y = x\) and \(y = 10 \sin x\).

Trigonometric Identities

This section illustrates the effects of some operations on trigonometric functions. First, simplifications and expansions of various trigonometric expressions illustrate many of the familiar trigonometric identities.
Definitions in terms of Basic Trigonometric Functions

To express a trigonometric function in terms of sine and cosine

• Place the insert point in the function and choose Compute > Rewrite > Sin and Cos.

\[
\begin{align*}
\sec x &= \frac{1}{\cos x} & \tan x &= \frac{\sin x}{\cos x} \\
\csc x &= \frac{1}{\sin x} & \cot x &= \frac{\cos x}{\sin x}
\end{align*}
\]

\[\cos x \sin x - 2 \sec x \csc x = \cos x \sin x - \frac{2}{\cos x \sin x}\]

Alternatively, for \(\sec\) and \(\csc\), choose Simplify.

\[
\begin{align*}
\sec x &= \frac{1}{\cos x} & \csc x &= \frac{1}{\sin x}
\end{align*}
\]

To express a trigonometric function in terms of the sine function

1. Place the insert point in the function.
2. Choose Compute > Rewrite > Sin.

\[
\begin{align*}
\cos x \sin x - 2 \sec x \csc x &= \frac{2}{(2 \sin^2 \left(\frac{1}{2}x\right) - 1) \sin x} - \sin x \left(2 \sin^2 \left(\frac{1}{2}x\right) - 1\right)
\end{align*}
\]

To express a trigonometric function in terms of the cosine function

1. Place the insert point in the function.
2. Choose Compute > Rewrite > Cos.

\[
\cos x \sin^2 x = - (\cos x) (\cos^2 x - 1)
\]

To express a trigonometric function in terms of the tangent function

1. Place the insert point in the function.
2. Choose Compute > Rewrite > Tan.

\[
\sin x = \frac{2 \tan \left(\frac{1}{2}x\right)}{\tan^2 \left(\frac{1}{2}x\right) + 1}
\]
Chapter 4 | Trigonometry

Pythagorean Identities

To compute Pythagorean identities

1. Place the insert point in an expression.

2. Choose Compute > Simplify, or
   Compute > Rewrite > Sin and Cos.

3. Use basic techniques for simplifying such expressions.

\[
\text{Compute} \rightarrow \text{Simplify}
\]
\[
\sin^2 x + \cos^2 x = 1
\]

\[
\text{Compute} \rightarrow \text{Rewrite} \rightarrow \text{Sin and Cos, Simplify}
\]
\[
\tan^2 x - \sec^2 x = \frac{\sin^2 x}{\cos^2 x} - \frac{1}{\cos^2 x} = -1
\]

Addition Formulas

To compute addition formulas

1. Place the insert point in an expression.

2. Choose Compute > Expand.

\[
\text{Compute} \rightarrow \text{Expand}
\]
\[
\sin (x + y) = \cos x \sin y + \cos y \sin x \quad \sin (x + \frac{n \pi}{2}) = \cos x
\]
\[
\cos (x + y) = \cos x \cos y - \sin x \sin y \quad \cos (x - \frac{n \pi}{2}) = \sin x
\]

Combine and Expand act as reverse operations in many cases.

\[
\text{Compute} \rightarrow \text{Combine} \rightarrow \text{Trigonometric Functions}
\]
\[
\cos x \sin y + \cos y \sin x = \sin (x + y)
\]
\[
\cos x \cos y - \sin x \sin y = \cos (x + y)
\]

Multiple-Angle Formulas

You can obtain multiple-angle formulas with Expand.

To reduce a multiple-angle expression

- Place the insert point in the expression and choose Compute > Expand.

\[
\text{Compute} \rightarrow \text{Expand}
\]
\[
\sin 2\theta = 2 \cos \theta \sin \theta \quad \cos 2\theta = \cos^2 \theta - \sin^2 \theta
\]
\[
\tan 2\theta = \frac{2 \tan \theta}{\tan^2 \theta - 1}
\]
\[
\sin 6\theta = 6 \cos^5 \theta \sin \theta - 20 \cos^3 \theta \sin^3 \theta + 6 \cos \theta \sin^5 \theta
\]
Combining and Simplifying Trigonometric Expressions

Products and powers of trigonometric functions and hyperbolic functions are combined into a sum of trigonometric functions or hyperbolic functions whose arguments are integral linear combinations of the original arguments.

To simplify sums of products and powers of trigonometric expressions

1. Place the insert point in the expression.
2. Choose Compute > Combine > Trigonometric Functions.

Compute > Combine > Trigonometric Functions
\[
\sin x \sin y = \frac{1}{2} \cos(x - y) - \frac{1}{2} \cos(x + y) \\
\sin^2 x = \frac{1}{2} - \frac{1}{2} \cos(2x) \\
\sin x \cos y = \frac{1}{2} \sin(x - y) + \frac{1}{2} \sin(x + y) \\
\sin^3 x \cos^5 x = \frac{5}{256} \sin(2x) - \frac{5}{512} \sin(6x) + \frac{1}{512} \sin(10x)
\]

Here is another example where Expand and Combine act as reverse operations.

Compute > Expand
\[
\frac{1}{2} \cos(x - y) - \frac{1}{2} \cos(x + y) = \sin x \sin y \\
\frac{1}{2} \sin(x - y) + \frac{1}{2} \sin(x + y) = \cos y \sin x
\]

Simplify also combines and simplifies trigonometric expressions.

Compute > Simplify
\[
\sin^3 a + 4 \sin^3 a = 3 \sin a
\]

Inverse Trigonometric Functions

The following type of question arises frequently when working with the trigonometric functions: for which angles \( x \) is \( \sin x = y \)? There are many correct answers to these questions, since the trigonometric functions are periodic. The inverse trigonometric functions provide solutions that lie within restricted ranges. The angle returned by these functions is measured in radians, not in degrees.

<table>
<thead>
<tr>
<th>Inverse function</th>
<th>Domain</th>
<th>Range</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \arcsin x ) or ( \sin^{-1} x )</td>
<td>([-1, 1])</td>
<td>(\left[-\frac{\pi}{2}, \frac{\pi}{2}\right])</td>
</tr>
<tr>
<td>( \arccos x ) or ( \cos^{-1} x )</td>
<td>([-1, 1])</td>
<td>([0, \pi])</td>
</tr>
<tr>
<td>( \arctan x ) or ( \tan^{-1} x )</td>
<td>((\infty, \infty))</td>
<td>(\left(-\frac{\pi}{2}, \frac{\pi}{2}\right))</td>
</tr>
</tbody>
</table>
Chapter 4 | Trigonometry

The other standard inverse functions are the following:

<table>
<thead>
<tr>
<th>Inverse function</th>
<th>Domain</th>
<th>Range</th>
</tr>
</thead>
<tbody>
<tr>
<td>arcsec ( x ) or ( \sec^{-1} x )</td>
<td>((-\infty, -1] \cup [1, \infty))</td>
<td>([0, \frac{\pi}{2}) \cup (\frac{\pi}{2}, \pi])</td>
</tr>
<tr>
<td>arccsc ( x ) or ( \csc^{-1} x )</td>
<td>((-\infty, -1] \cup [1, \infty))</td>
<td>([-\frac{\pi}{2}, 0) \cup (0, \frac{\pi}{2}])</td>
</tr>
<tr>
<td>arccot ( x ) or ( \cot^{-1} x )</td>
<td>((-\infty, \infty))</td>
<td>([-\frac{\pi}{2}, 0) \cup (0, \frac{\pi}{2}])</td>
</tr>
</tbody>
</table>

You can check the relationships between the inverse functions with Check Equality.

**Compute > Check Equality**
- \( \text{arcsec } x = \arccos \frac{1}{x} \) is TRUE
- \( \text{arccot } x = \arctan \frac{1}{x} \) is TRUE
- \( \text{arccsc } x = \arcsin \frac{1}{x} \) is TRUE

**Combining and Rewriting Inverse Trigonometric Functions**

The sum of inverse tangent functions can be combined.

**Compute > Combine > Arctan**
- \( \arctan x + \arctan y = -\arctan \frac{1}{x+y} (x+y) \)
- \( \arctan x - \arctan y = \arctan \frac{x-y}{x+y+1} \)

The Rewrite commands convert from one inverse trigonometric function to another.

**Compute > Rewrite > Arcsin**
- \( \arctan x = -\text{signIm } (ix) \left( \arcsin \frac{1}{\sqrt{x^2+1}} - \frac{1}{2} \pi \right) \)
- \( \cos^{-1} x = \frac{1}{2} \pi - \arcsin x \)

The sign imaginary function of a complex variable \( z \) is given by

\[
\text{signIm } (z) = \begin{cases} 
1 & \text{if } \Im (z) > 0 \text{ or } z < 0 \\
0 & \text{if } z = 0 \\
-1 & \text{if } \Im (z) < 0 \text{ or } z > 0 
\end{cases}
\]

Thus if \( x \) is real, then

\[
\arctan x = \begin{cases} 
- \left( \arcsin \frac{1}{\sqrt{x^2+1}} - \frac{1}{2} \pi \right) & \text{if } x > 0 \\
0 & \text{if } x = 0 \\
\arcsin \frac{1}{\sqrt{x^2+1}} - \frac{1}{2} \pi & \text{if } x < 0 
\end{cases}
\]
Inverse Trigonometric Functions

Compute > Rewrite > Arccos
\[ \arcsin x = \frac{1}{2} \pi - \arccos x \]

Compute > Rewrite > Arctan
\[ \arcsin x = 2 \arctan \frac{x}{\sqrt{1-x^2}} \quad \arccos x = \frac{1}{2} \pi - 2 \arctan \frac{x}{\sqrt{1-x^2}} \]

Compute > Rewrite > Arccot
\[ \arctan x = \arccot \frac{1}{x} \quad \cos^{-1} x = \frac{1}{2} \pi - 2 \arccot \left( \frac{\sqrt{1-x^2}}{x} \right) \]

Trigonometric Equations and Inverse Functions

With Solve > Exact, solutions of trigonometric equations may be given in terms of inverse trigonometric functions that you can evaluate numerically. You can get numerical results directly by starting with decimal notation in the equation.

For real solutions only, first evaluate \( \text{assume} (x, \text{real}) \). To return to the default, evaluate \( \text{unassume} (x) \).

Notation
The union symbol \( \cup \) is used for OR. The letter \( \mathbb{Z} \) denotes the set of integers.

Compute > Evaluate
\[ \text{assume} (x, \text{real}) = \mathbb{R} \]

Compute > Solve > Exact
\[ \sin x = \frac{7}{10}, \text{Solution:} \ {\pi - \arcsin \frac{7}{10} + 2\pi k \mid k \in \mathbb{Z}} \cup \{ \arcsin \frac{7}{10} + 2\pi k \mid k \in \mathbb{Z} \} \]
\[ \sin x = 0.7, \text{Solution:} \ {6.2832k + 0.77540 \mid k \in \mathbb{Z}} \cup \{ 6.2832k + 2.3662 \mid k \in \mathbb{Z} \} \]
\[ \tan^2 x - \cot^2 x = 1, \text{Solution:} \ {\arcsin \frac{\sqrt{2}}{\sqrt{5}+1} + \pi k \mid k \in \mathbb{Z}} \cup \{ -\arcsin \frac{\sqrt{2}}{\sqrt{5}+1} + \pi k \mid k \in \mathbb{Z} \} \]

Compute > Evaluate Numeric
\[ \arctan \sqrt{\frac{1}{2} \sqrt{5} - \frac{1}{2}} \approx 0.66624 \]

To obtain a principal solution only
2. Click the Engine tab.
3. Check Principal Value Only.
Chapter 4 | Trigonometry

Compute > Solve > Exact (Principal Value Only)

- sin\(t = \sin 2t\), Solution: 0
- \(8\tan x - 13 + 5\tan^2 x = 3\), Solution: arctan \(\frac{4}{5} \sqrt{6 - \frac{4}{5}}\)
- \(\tan^2 x - \cot^2 x = 1\), Solution: arcsin \(\frac{\sqrt{5}}{\sqrt{5} + 1}\)

Hyperbolic Functions

Certain functions, known as the hyperbolic sine, hyperbolic cosine, hyperbolic tangent, hyperbolic cotangent, hyperbolic secant, and hyperbolic cosecant, occur as combinations of the exponential functions \(e^x\) and \(e^{-x}\) having the same relationship to the hyperbola that the trigonometric functions have to the circle. It is for this reason that they are called hyperbolic functions.

<table>
<thead>
<tr>
<th>Hyperbolic functions</th>
</tr>
</thead>
<tbody>
<tr>
<td>sinh(x = \frac{e^x - e^{-x}}{2})</td>
</tr>
<tr>
<td>cosh(x = \frac{e^x + e^{-x}}{2})</td>
</tr>
<tr>
<td>tanh(x = \frac{\sinh x}{\cosh x} = \frac{e^{2x} - 1}{e^{2x} + 1})</td>
</tr>
<tr>
<td>csch(x = \frac{1}{\sinh x} = \frac{2}{e^x - e^{-x}})</td>
</tr>
<tr>
<td>sech(x = \frac{1}{\cosh x} = \frac{2}{e^x + e^{-x}})</td>
</tr>
<tr>
<td>coth(x = \frac{\cosh x}{\sinh x} = \frac{e^{2x} + 1}{e^{2x} - 1})</td>
</tr>
</tbody>
</table>

The function names used for the basic hyperbolic functions are sinh, cosh, tanh, coth, sech, and csch. Most of these function names automatically turn upright and gray when typed in mathematics mode. When they do not, choose Insert > Math Objects > Math Name, type the name in the Name box, and select Apply.

To obtain exponential expressions for the hyperbolic functions

1. Place the insert point in a hyperbolic function.
2. Choose Compute > Rewrite > Exponential.

Compute > Rewrite > Exponential

- sinh\(x = \frac{1}{2}e^x - \frac{1}{2}e^{-x}\)
- \(\cosh x = \frac{1}{2}e^x + \frac{1}{2}e^{-x}\)
- tanh\(x = \frac{e^{2x} - 1}{e^{2x} + 1}\)

To find values of hyperbolic functions

- Place the insert point in the expression and choose Compute > Evaluate Numeric.

Hyperbolic Functions

Note

The hyperbolic functions are “trigtype” functions, allowing you to enter arguments without parentheses.

Note

The hyperbolic cosine function occurs naturally as a description of the curve formed by a hanging cable.
Compute > Evaluate Numeric
sinh 1 ≈ 1.1752  \ cosh 2 ≈ 3.7622  \ \tanh 3 ≈ 0.99505

To solve equations involving hyperbolic functions
• Place the insert point in the equation and choose Compute > Solve > Exact or Compute > Solve > Numeric.

Compute > Solve > Exact
sinh x + cosh x = 3, Solution: \{ln 3 + 2i\pi k \mid k \in \mathbb{Z}\}

Compute > Solve > Numeric
sinh x + cosh x = 3, Solution: \{x = 1.0986\}

To obtain addition formulas for hyperbolic functions
• Place the insert point in an expression and choose Compute > Expand.

Compute > Expand
\sinh(x + y) = \cosh x \sinh y + \cosh y \sinh x
\cosh(x + y) = \cosh x \cosh y + \sinh x \sinh y

To rewrite hyperbolic expressions in terms of sinh and cosh
1. Place the insert point in an expression.

2. Choose Compute > Rewrite > Sinh and Cosh.

Compute > Rewrite > Sinh and Cosh
\tanh x + \sinh x \tanh x = \frac{\sinh x}{\cosh x} + \frac{\sinh^2 x}{\cosh x}

Products and powers of hyperbolic functions can be combined into a sum of hyperbolic functions whose arguments are integral linear combinations of the original arguments.

To combine products and powers of hyperbolic functions
1. Place the insert point in the expression.

2. Choose Compute > Combine > Hyperbolic Trigonometric Functions

Compute > Combine > Hyperbolic Trigonometric Functions
\sinh x \sinh y = \frac{1}{2} \cosh(x + y) - \frac{1}{2} \cosh(x - y)
\sinh x \cosh y = \frac{1}{2} \sinh(x + y) + \frac{1}{2} \sinh(x - y)
\cosh x \cosh y = \frac{1}{2} \cosh(x + y) + \frac{1}{2} \cosh(x - y)
Chapter 4 | Trigonometry

Inverse Hyperbolic functions

Since the hyperbolic functions are defined in terms of exponential functions, the inverse hyperbolic functions can be expressed in terms of logarithmic functions.

<table>
<thead>
<tr>
<th>Inverse Hyperbolic functions</th>
<th>Domain</th>
</tr>
</thead>
<tbody>
<tr>
<td>arcsinh ( x ) = ( \ln \left( x + \sqrt{x^2 + 1} \right) )</td>
<td>( x \in \mathbb{R} )</td>
</tr>
<tr>
<td>arccosh ( x ) = ( \ln \left( x + \sqrt{x^2 - 1} \right) )</td>
<td>( x \geq 1 )</td>
</tr>
<tr>
<td>arctanh ( x ) = ( \frac{1}{2} \ln \left( \frac{1 + x}{1 - x} \right) )</td>
<td>( -1 &lt; x &lt; 1 )</td>
</tr>
</tbody>
</table>

To enter the inverse hyperbolic function names

1. Choose Insert > Math Name.
2. Type the function name in the Name box, and choose OK.

To obtain logarithmic expressions for these functions, use the Rewrite command.

\[
\begin{align*}
\text{Compute} & > \text{Rewrite} > \text{Logarithm} \\
arcsinh x & = \ln \left( x + \sqrt{x^2 + 1} \right) \\
arccosh x & = \ln \left( x + \sqrt{x^2 - 1} \right) \\
arctanh x & = \frac{1}{2} \ln \left( \frac{1 + x}{1 - x} \right)
\end{align*}
\]

To find values of the inverse hyperbolic functions, use Evaluate Numeric.

\[
\begin{align*}
\text{Compute} & > \text{Evaluate Numeric} \\
arcsinh 5 & = 2.3124 \\
cosh^{-1} 10 & = 2.9932
\end{align*}
\]

To solve equations involving inverse hyperbolic functions, use Solve > Exact or Solve > Numeric.

\[
\begin{align*}
\text{Compute} & > \text{Solve} > \text{Exact} \\
arcsinh x - \text{arccosh} x & = 0.3, \quad \text{Solution:} \ 1.3395
\end{align*}
\]

The following special values are implemented:

\[
\begin{align*}
\text{Compute} & > \text{Evaluate} \\
arcsinh 0 & = 0 \\
arccosh 1 & = 0 \\
arctanh 0 & = 0
\end{align*}
\]
Complex Numbers and Complex Functions

Complex numbers are numbers of the form \(a + bi\) where \(a\) and \(b\) are real numbers and \(i^2 = -1\). See Complex Numbers, page 32, for general information on working with complex numbers.

Argument of a Complex Number

The polar coordinate system is a coordinate system that describes a point \(P\) in terms of its distance \(r\) from the origin and the angle \(\theta\) between the polar axis (that is, the \(x\)-axis) and the line \(OP\), measured in a clockwise direction from the polar axis. The point in the plane corresponding to a pair \((a, b)\) of real numbers can be represented in polar coordinates \(P(r, \theta)\) with

\[ a = r \cos \theta \quad \text{and} \quad b = r \sin \theta \]

where \(r = \sqrt{a^2 + b^2}\) is the distance from the point \((a, b)\) to the origin and \(\theta\) is an angle satisfying \(\tan \theta = \frac{a}{b}\).

The angle \(\theta\) is called the amplitude or argument of \(z\). Note that the argument is not unique. However, any two arguments of \(z\) differ by an integer multiple of \(2\pi\). The function that gives the argument between \(-\pi\) and \(\pi\) is denoted \(\text{arg} z\). The form \(z = r(\cos \theta + i \sin \theta)\) for a complex number is called the (trigonometric) polar form of \(z\).

To find the argument of a complex number

1. Type \(\text{arg}\) in mathematics mode. It will automatically turn to a gray math name when you type the last letter.

2. Type the number enclosed in parentheses.

3. Choose Compute > Evaluate, or
   Choose Compute > Evaluate Numeric.

4. Choose Compute > Simplify if required.

\[
\text{Compute > Evaluate,} \quad \text{Compute > Simplify}
\]

\[
\text{arg} (3 + 5i) = \arctan \frac{5}{3}
\]

\[
\text{arg} (5^2 - 3i) = -\arctan \left( \frac{\sin(3\ln 5)}{\cos(3\ln 5)} \right) = 2\pi - \ln 125
\]
Chapter 4 | Trigonometry

**Compute > Evaluate Numeric**

\[ \arg (3 + 5i) \approx 1.0304 \]
\[ \arg (5^2 - 3i) \approx 1.4549 \]

**Forms of a Complex Number**

A form of writing a complex number that involves \( r \) and \( \theta \) rather than \( x \) and \( y \), where \( r = \sqrt{a^2 + b^2} \) and \( \theta = \arctan \frac{b}{a} \), is called a *polar form* of the complex number. This leads to three standard forms for complex numbers:

<table>
<thead>
<tr>
<th>Rectangular</th>
<th>Trigonometric Polar</th>
<th>Exponential Polar</th>
</tr>
</thead>
<tbody>
<tr>
<td>( z = a + ib )</td>
<td>( z = r (\cos \theta + i \sin \theta) )</td>
<td>( z = re^{i\theta} )</td>
</tr>
</tbody>
</table>

**To put a complex number in exponential polar form**

1. Place the insert point in the number.
2. Choose Compute > Rewrite > Polar.

**Compute > Rewrite > Polar**

\[
3 + 5i = \sqrt{34}e^{i\left(\arctan \frac{5}{3}\right)}
\]
\[
16\pi - \sqrt{2}i = \sqrt{2}e^{i\left(\arctan \frac{\sqrt{2}}{16}\right)}(-i)\sqrt{128\pi^2 + 1}
\]

**To put a complex number in rectangular form**

1. Place the insert point in the number.
2. Choose Compute > Rewrite > Rectangular.

**Compute > Rewrite > Rectangular**

\[
\sqrt{34}e^{i\left(\arctan \frac{5}{3}\right)} = 3 + 5i
\]
\[
\sqrt{2}\exp\left(-i\arctan \frac{\sqrt{2}}{16}\right)\sqrt{128\pi^2 + 1} = \sqrt{2}\cos\left(\frac{1}{\pi}\sqrt{2}\arctan \frac{1}{16}\right)\sqrt{128\pi^2 + 1} - i\sqrt{2}\sin\left(\frac{1}{\pi}\sqrt{2}\arctan \frac{1}{16}\right)\sqrt{128\pi^2 + 1}
\]

**Compute > Simplify**

\[
\frac{\sqrt{2}\sqrt{128\pi^2 + 1}}{\sqrt{128\pi^2 + 1}} - i\frac{\sqrt{128\pi^2 + 1}}{8\pi\sqrt{128\pi^2 + 1}} = 16\pi - i\sqrt{2}
\]

For the *Euler identity*

\[ re^{i\theta} = r (\cos \theta + i \sin \theta) \]
use Rewrite to change from exponential polar form to trigonometric polar form.

To change from exponential polar form to trigonometric polar form

- Place the insert point in the expression.
- Choose Compute > Rewrite > Sin and Cos.

\[
re^{it} = r(\cos t + (i \sin t))
\]

Complex Powers and Roots of Complex Numbers

Euler’s identity \(re^{it} = r(\cos t + i \sin t)\) provides a method of taking complex powers of complex numbers. If \(z \neq 0\) and \(w\) are complex numbers, write \(z = re^{it}\) and \(w = a + ib\), with \(r, a, b\) real numbers and \(r\) positive. Then the principal value of \(z^w\) is given by

\[
z^w = (re^{it})^{a+ib} = \left(e^{lnr}e^{it}ight)^{a+ib} = e^{a\ln r}e^{ib\ln r}e^{ia^t}e^{-bt}
\]

\[
= e^{a\ln r - bt}e^{i(a+b\ln r)} = r^ae^{-bt}(\cos(a + b\ln r) + i\sin(a + b\ln r))
\]

This function is multi-valued because \(e^{iy} = e^{iy+2\pi k}\) for any integer \(k\). The Rewrite command computes the principal value.

\[
i = e^{-\frac{1}{2}\pi}
\]

\[
5^2i = \cos(2\ln5) + i\sin(2\ln5)
\]

DeMoivre’s Theorem

DeMoivre’s theorem says that if \(z = r(\cos \theta + i \sin \theta)\) and \(n\) is a positive integer, then

\[
z^n = (r(\cos t + i \sin t))^n = r^n (\cos nt + i \sin nt)
\]

To obtain DeMoivre’s Theorem

1. Type \((r(\cos t + i \sin t))^3\).
2. Choose Compute > Expand.
3. Choose Compute > Simplify.

\[
(r(\cos t + i \sin t))^3 = r^3 \cos^3 t + 3ir^3 \cos^2 t (\sin t) - 3r^3 \cos t \sin^2 t - ir^3 (\sin^3 t)
\]
Chapter 4 | Trigonometry

Compute > Simplify
\[ r^3 \cos^3 t + 3ir^3 \cos^2 t \sin t - 3r^3 \cos^2 t - ir^3 \sin^3 t = r^3 (\cos (3t) + i r^3 \sin (3t)) \]

Complex Trigonometric and Hyperbolic Functions

All trigonometric, inverse trigonometric, and hyperbolic functions are defined for complex arguments. Arguments that are rational multiples of \( i \) are rewritten in terms of hyperbolic functions.

The function \( \text{arcsinh} \) produces values with imaginary parts in the interval \([-\frac{3}{2}, \frac{3}{2} \pi ]\).

Compute > Evaluate
\[
\begin{align*}
\sin 5i &= i (\sinh 5) & \text{arcsin} 5i &= i (\text{arcsinh} 5) \\
\cos \frac{5i}{4} &= \cosh \frac{5}{4} & \text{arccos} \frac{5i}{4} &= \frac{1}{2} \pi + i (\text{arcsinh} \frac{5}{4}) \\
\tan (-3i) &= (\text{tanh} 3) (-i) & \text{arctan} (-3i) &= (\text{arctanh} 3) (-i)
\end{align*}
\]

Hyperbolic functions with arguments that are integer multiples of \( \pi i / 2 \) are simplified by Evaluate.

Compute > Evaluate
\[
\begin{align*}
\sinh \left( \frac{\pi i}{2} \right) &= i \\
\cosh (40i \pi) &= 1 \\
\cosh^{-1} 0 &= \frac{1}{2} i \pi
\end{align*}
\]

For other complex arguments, use Expand to rewrite trigonometric and hyperbolic functions.

Compute > Expand
\[
\begin{align*}
\sin (5i + \frac{2\pi i}{3}) &= \frac{1}{2} \sqrt{3} \cosh 5 - \frac{1}{2} i (\sinh 5) \\
\sinh (x + i\pi) &= -\sinh x
\end{align*}
\]

Use Rewrite to obtain a representation in terms of specific target functions.

Compute > Rewrite > Sin and Cos
\[
e^{2ix} \tan x = \frac{(\sin x)(\cos (2x) + i \sin (2x))}{\cos x}
\]

For \( \text{arcsin} \) and \( \text{arccos} \), the branch cuts are the real intervals \((-\infty, -1)\) and \((1, \infty)\). For \( \text{arctan} \), the branch cuts are the intervals \((-\infty, i, i] \) and \([i, \infty \cdot i \) on the imaginary axis. For \( \text{arcsec} \) and \( \text{arcsec} \), the branch cut is the real interval \((-1, 1)\). For \( \text{arccot} \), the branch cut is the interval \([i, -i]\) on the imaginary axis. The values jump when the arguments cross a branch cut.
Exercises

**Compute > Evaluate**

\[
\arcsin(-1.2) = -1.5708 + 0.62236i \\
\arcsin\left(-1.2 + \frac{i}{10^{10}}\right) = -1.5708 + 0.62236i \\
\arcsin\left(-1.2 - \frac{i}{10^{10}}\right) = -1.5708 - 0.62236i \\
\]

Note that arccot is defined by \(\text{arccot} x = \arctan \frac{1}{x}\) although arccot does not rewrite itself in terms of arctan. As a consequence of this definition, the real line crosses the branch cut and arccot has a jump discontinuity at the origin.

**Compute > Evaluate**

\[
\text{arcsinh}(\sinh(3 + 25i)) = 3 - 8i\pi + 25i \\
\]

With the default setting, Solve > Exact finds complex as well as real solutions to trigonometric equations.

**Compute > Solve > Exact**

\[
\tan^2 x - \cot^2 x = 1 \\
\text{Solution: } \begin{cases}
\arcsin \sqrt{-\frac{1}{2} \sqrt{5} - \frac{1}{2} + \pi k} | k \in \mathbb{Z} \\
\cup \arcsin \sqrt{\frac{1}{2} \sqrt{5} - \frac{1}{2} + \pi k} | k \in \mathbb{Z} \\
\cup -\arcsin \sqrt{-\frac{1}{2} \sqrt{5} - \frac{1}{2} + \pi k} | k \in \mathbb{Z} \\
\cup -\arcsin \sqrt{\frac{1}{2} \sqrt{5} - \frac{1}{2} + \pi k} | k \in \mathbb{Z} 
\end{cases}
\]

*Note* In this example,

\[
\sqrt{-\frac{1}{2} \sqrt{5} - \frac{1}{2}} \approx 1.272i
\]

To obtain the principal solutions only


2. Check Principal Value Only.

**Compute > Solve > Exact**

\[
\tan^2 x - \cot^2 x = 1, \text{ Solution: } \arcsin \frac{\sqrt{5}}{\sqrt{5} + 1}
\]

Exercises

1. Define the functions \(f(x) = x^3 + x\sin x\) and \(g(x) = \sin x^2\). Evaluate \(f(g(x)), g(f(x)), f(x)g(x),\) and \(f(x) + g(x)\).

2. At Metropolis Airport, an airplane is required to be at an altitude of at least 800 ft above ground when it has attained a
Chapter 4 | Trigonometry

horizonal distance of 1 mi from takeoff. What must be the (minimum) average angle of ascent?

3. Experiment with expansions of \(\sin nx\) in terms of \(\sin x\) and \(\cos x\) for \(n = 1, 2, 3, 4, 5, 6\) and make a conjecture about the form of the general expansion of \(\sin nx\).

4. Experiment with parametric plots of \((\cos t, \sin t)\) and \((t, \sin t)\). Attach the point \((\cos 1, \sin 1)\) to the first plot and \((1, \sin 1)\) to the second. Explain how the two graphs are related.

5. Experiment with parametric plots of \((\cos t, \sin t)\), \((\cos t, t)\), and \((t, \cos t)\), together with the point \((\cos 1, \sin 1)\) on the first plot, \((\cos 1, 1)\) on the second, and \((1, \cos 1)\) on the third. Explain how these plots are related.

6. To convert radians to degrees using ratios, write the equation \(\frac{x}{\pi} = \frac{\theta}{180}\), where \(x\) represents the angle in radians. Choose Compute > Solve > Exact or Compute > Solve > Numeric and name \(\theta\) as the variable. Use this method to convert \(x = \frac{13}{600}\pi\) radians to degrees.

7. To solve a triangle means to determine the lengths of the three sides and the measures (in degrees or radians) of the three angles.
   a. Solve the right triangle with one side of length \(c = 2\) and one angle \(\alpha = \frac{\pi}{3}\).
   b. Solve the right triangle with two sides \(a = 19\) and \(c = 23\).

8. The law of sines
   \[
   \frac{a}{\sin \alpha} = \frac{b}{\sin \beta} = \frac{c}{\sin \gamma}
   \]
   enables you to solve a triangle if you are given one side and two angles, or if you are given two sides and an angle opposite one of these sides. Solve the triangle with one side \(c = 2\) and two angles \(\alpha = \frac{\pi}{3}, \beta = \frac{2\pi}{3}\).

9. Using both the law of sines and the law of cosines,
   \[
   a^2 + b^2 - 2ab \cos \gamma = c^2
   \]
Exercises

you can solve a triangle given two sides and the included angle, or given three sides.

a. Solve the triangle with sides $a = 2.34$, $b = 3.57$, and included angle $\gamma = \frac{29}{16}\pi$.

b. Solve the triangle with three given sides $a = 2.53$, $b = 4.15$, and $c = 6.19$.

10. Fill in the steps to show that $\theta = e^{-\frac{x}{2}}$. Find the general solution.

Solutions

1. Defining functions $f(x) = x^3 + x \sin x$ and $g(x) = \sin x^2$ and evaluating gives

$$f(g(x)) = \sin^3 x^2 + \sin x^2 \sin (\sin x^2)$$
$$g(f(x)) = \sin (x^3 + x \sin x)^2$$
$$f(x)g(x) = (x^3 + x \sin x) \sin x^2$$
$$f(x) + g(x) = x^3 + x \sin x + \sin x^2$$

2. You can find the minimum average angle of ascent by considering the right triangle with legs of length 800 ft and 5280 ft. The angle in question is the acute angle with sine equal to $\frac{800}{\sqrt{800^2 + 5280^2}}$.

Find the answer in radians with Compute > Evaluate > Numeric:

$$\arcsin \frac{800}{\sqrt{800^2 + 5280^2}} \approx 0.15037$$

You can express this angle in degrees by using the following steps:

$$360 \times \frac{0.15037}{2\pi} \approx 8.6157$$
$$0.6157 \times 60 = 36.942$$
$$\theta \approx 8^\circ 37'$$

or solve the equation $0.15037 \text{ rad} = x^\circ$ to get 8.6156, then solve $0.6156^\circ = x'$ to get 36.936.
Chapter 4 | Trigonometry

3. Note that
\[
\begin{align*}
\sin 2x &= 2 \sin x \cos x \\
\sin 3x &= 4 \sin x \cos^2 x - \sin x \\
\sin 4x &= 8 \sin x \cos^3 x - 4 \sin x \cos x \\
\sin 5x &= 16 \sin x \cos^4 x - 12 \sin x \cos^2 x + \sin x \\
\sin 6x &= 32 \sin x \cos^5 x - 32 \sin x \cos^3 x + 6 \sin x \cos x
\end{align*}
\]

We leave the conjecture up to you.

4. Figure 4a shows a circle of radius 1 with center at the origin. The graph is drawn by starting at the point \((1, 0)\) and is traced in a counter-clockwise direction. Figure 4b shows the \(y\)-coordinates of the first figure as the angle varies from 0 to \(2\pi\). The point \((\cos 1, \sin 1)\) is marked with a small circle in the first figure. The corresponding point \((1, \sin 1)\) is marked with a small circle in the second figure.

5. Figure 5a shows a circle of radius 1 with center at the origin. The graph is drawn by starting at the point \((1, 0)\) and is traced in a counter-clockwise direction.

Figure 5b shows the \(x\)-coordinates of the first figure as the angle varies from 0 to \(2\pi\). The point \((\cos 1, \sin 1)\) is marked with a small circle in the first figure. The corresponding point \((\cos 1, 1)\) is marked with a small circle in the second figure.

Figure 5c shows the graph in the second figure with the horizontal and vertical axes interchanged. Figure 5c shows the usual view of \(y = \cos x\).

6. Write the equation \(\theta = \frac{11 \pi}{20}\). With the insert point in this equation, choose Compute > Solve > Exact to get \(\theta = \frac{29}{10}\) degrees, or choose Numeric to get \(\theta = 3.9\) degrees.

7. To obtain the solutions in the simple form shown below, choose Compute > Engine Settings and check Principal Value Only.

a. Choose Compute > Definitions > New Definition for each of the given values \(\alpha = \frac{\pi}{6}\) and \(c = 2\). Evaluate \(\beta = \frac{\pi}{2} - \alpha\) to get \(\beta = \frac{7}{10}\pi\). Evaluate \(c \sin \alpha\) to get \(a = 2 \sin \frac{1}{6}\pi\) \((= 0.68404)\). Evaluate \(c \cos \alpha\) to get \(b = 2 \cos \frac{1}{5}\pi\) \((= 1.8794)\).
Exercises

b. Choose Compute > Definitions > New Definition to each of the given values, \( a = 19 \) and \( c = 23 \). Place the insert point in the equation \( a^2 + b^2 = c^2 \) and choose Compute > Solve > Exact (Numeric) to get \( b = 2\sqrt{42} (= 12.96) \). Place the insert point in each of the equations \( \sin \alpha = \frac{a}{c} \), \( \cos \beta = \frac{a}{c} \) in turn, and choose Compute > Solve > Exact to get \( \alpha = \arcsin \frac{19}{23}, \beta = \arccos \frac{19}{23} \); or place the insert point in each of the one-column matrices

\[
\begin{bmatrix}
\sin \alpha &= a/c \\
\alpha &\in (0, \pi/2)
\end{bmatrix}
\quad \text{and} \quad
\begin{bmatrix}
\cos \beta &= a/c \\
\beta &\in (0, \pi/2)
\end{bmatrix}
\]

in turn, and choose Compute > Solve > Numeric to get \( \alpha = 0.9721, \beta = 0.5987 \).

8. Choose Compute > Definitions > New Definition to define \( \alpha = \frac{\pi}{3}, \beta = \frac{2\pi}{3}, \) and \( c = 2 \). Evaluate \( \gamma = \pi - \alpha - \beta \) to get \( \gamma = \frac{\pi}{3} \). Choose Compute > Solve > Exact to solve the equations \( \frac{a}{\sin \alpha} = \frac{c}{\sin \gamma} \) and \( \frac{b}{\sin \beta} = \frac{c}{\sin \gamma} \) to get \( a = \frac{\sqrt{3}}{2} \sin \frac{1}{2} \pi \) and \( b = \frac{1}{2} \sqrt{3} \sin \frac{\pi}{2} \). To get numerical solutions, choose Compute > Solve > Numeric.


a. Define each of \( a = 2.34, b = 3.57, \) and \( \gamma = \frac{20}{\sqrt{75}} \pi \). Choose Compute > Solve > Exact to solve the equation \( a^2 + b^2 - 2ab \cos \gamma = c^2 \). You should get \( c = 1.7255 \). Define \( c = 1.7255 \). Choose Compute > Solve > Exact to solve the equations \( \frac{a}{\sin \alpha} = \frac{c}{\sin \gamma} \) and \( \frac{b}{\sin \beta} = \frac{c}{\sin \gamma} \), or with the insert point in each of the matrices

\[
\left( \begin{array}{c}
\frac{a}{\sin \alpha} = \frac{c}{\sin \gamma} \\
\alpha &\in (0, \pi/2)
\end{array} \right) \quad \text{and} \quad
\left( \begin{array}{c}
\frac{b}{\sin \beta} = \frac{c}{\sin \gamma} \\
\beta &\in (0, \pi/2)
\end{array} \right)
\]

choose Compute > Solve > Numeric to get \( \alpha = 0.58859 \) and \( \beta = 1.0104 \).

A triangle with three sides given is solved similarly: interchange the actions on \( \gamma \) and \( c \) in the steps just described.
Chapter 4 | Trigonometry

b. Define \( a = 2.53, b = 4.15, \) and \( c = 6.19. \) Choose Compute > Solve > Exact to solve the equation \( a^2 + b^2 - 2ab \cos \gamma = c^2 \) to get \( \gamma = 2.3458. \) Define \( \gamma = 2.3458. \) Choose Compute > Solve > Exact to solve each of the equations \( \frac{a}{\sin \alpha} = \frac{c}{\sin \gamma} \) and \( \frac{b}{\sin \beta} = \frac{c}{\sin \gamma}, \) or put the insert point in each of the matrices

\[
\begin{pmatrix}
\frac{a}{\sin \alpha} &=& \frac{c}{\sin \gamma} \\
\alpha &\in& (0, \pi/2)
\end{pmatrix}
\quad \text{and} \quad
\begin{pmatrix}
\frac{b}{\sin \beta} &=& \frac{c}{\sin \gamma} \\
\beta &\in& (0, \pi/2)
\end{pmatrix}
\]

and choose Compute > Solve > Numeric to get \( \alpha = 0.29632 \) and \( \beta = 0.49948. \)

10. In polar form,

\[ i = \cos \left( \frac{\pi}{2} \right) + i \sin \left( \frac{\pi}{2} \right) = e^{\frac{\pi}{2}i}. \]

Then

\[ i^i = \left( e^{\frac{\pi}{2}i} \right)^i = e^{-\frac{\pi}{2}}. \]

For the general solution, for any integer \( k, \)

\[ i = \cos \left( \frac{\pi}{2} + 2\pi k \right) + i \sin \left( \frac{\pi}{2} + 2\pi k \right) = e^{i\left( \frac{\pi}{2} + 2\pi k \right)} \]

and

\[ i^i = \left( e^{i\left( \frac{\pi}{2} + 2\pi k \right)} \right)^i = e^{-\frac{\pi}{2} - 2\pi k} \]
Definitions enable you to define a symbol to be a mathematical object, and to define a function using an expression or a collection of expressions. Function definition is a powerful tool. Before elaborating on definitions, we discuss criteria for names of functions, constants, and expressions.

### Function and Expression Names

A mathematical expression is a collection of valid expression names combined in a mathematically correct way. The notation for a function consists of a valid function name followed by a pair of parentheses containing a list of variables, called arguments. Trigonometric functions and certain others (trigtype functions) do not always require the parentheses around the argument. The argument of a function can also occur as a subscript.

- Examples of mathematical expressions: $x, a^2, b^2, c, x \sin y + 3 \cos z, a_1 a_2 - 3 b_1 b_2$
- Examples of ordinary function notation: $a(x), G(x, y, z), f_5(a, b)$

### Function and Expression Names

- **Defining Variables and Functions**
- **Handling Definitions**
- **Formulas**
- **External Functions**
- **Trigtype Functions**

**New in Version 6**
- Overbar for complex conjugate
- Decorated characters as expression names
- Passthru Code to Engine
Chapter 5 | Function Definitions

Valid Names for Functions and Expressions or Variables

A variable or function name must be either

- A single character (other than a standard constant), with or without a subscript.
  Or
- A custom Math Name, with or without a subscript.

Expression names, but not function names, may include decorated characters such as $\hat{Z}$.

- Examples of valid expression names include $\alpha_X$, $f_{123}$, $g_{\theta}$, $\Omega_{\omega}$, $e_2$, $r$ (decorated character), Waldo (custom name), John$_3$ (custom name with subscript).

- Examples of valid function names include $\alpha_X$, $f_{123}$, $g_{\theta}$, $\Omega_{\omega}$, $e_2$, sin, Alice (custom name), Lana$_2$ (custom name with subscript).

- Examples of invalid function names include $\Delta F$ (two characters), $\pi$, $e$ (standard constants), $f_{ab}$ (two-character subscript), $r'$ (reserved for derivative).

In the example of function names, the subscript on $f_{123}$ is properly regarded as the number one hundred twenty-three, not "one, two, three."

Custom Names

In general, function or expression names must be single characters or subscripted characters. However, the system includes a number of predefined functions with names that appear to be multicharacter—such as gcd, cos, and lcm—but that behave like a single character in the sense that they can be deleted with a single backspace. You can create custom names with similar behavior that are legitimate function or expression names.

There are three types of custom names: Operator, Function, and Variable. When you choose Name Type to be Operator, the custom name behaves like $\sum$ or $\int$ with regard to Operator Limit Placement. When you choose Name Type to be Function or Variable, it behaves like an ordinary character with regard to subscripts and superscripts. Observe the different behaviors of these types for inline and displayed situations:
Function and Expression Names

- Inline Operator: $\sum_{k=1}^{n} \cdot \int_{0}^{1} \cdot \text{operator}_{a}^{b}$
- Inline Function or Variable: $a_{k}^{j} \cdot \text{variable}_{c}^{d}$
- Displayed Operator, and displayed Function or Variable:

$$\sum_{k=1}^{n} \int_{0}^{1} \operatorname{operator}_{a}^{b} \cdot \text{variable}_{c}^{d}$$

To create a custom math name

1. Choose Insert > Math Objects > Math Name.
2. Type a custom name in the text box under Name.
3. For Name Type, choose Operator or Function or Variable.
4. If you choose Operator, check your choice of Operator Limit Placement.
5. If you want this name to automatically gray when typed in mathematics mode, check Add Automatic Substitution.
6. Choose OK.
Chapter 5 | Function Definitions

The gray custom name appears on the screen at the insert point. You can use this name to define a function or expression. You can copy and paste or click and drag this grayed name on the screen, or you can recreate it with the Math Name dialog.

To create a decorated character
1. Type a character.
2. Select the character and choose Edit > Properties > Character Properties.
3. Click the desired accent and choose OK.

Compute > Definitions > New Definition
\[ a = 3 \]
\[ \bar{a} = x^2 + y^2 \]

Compute > Definitions > Evaluate
\[ a\bar{a} = 3x^2 + 3y^2 \]

Automatic Substitution
When automatic substitution is enabled, function names such as sin, arcsin, and gcd automatically turn gray when typed in mathematics. For a list of these names, choose Tools > Auto Substitution.

To enable auto substitution in mathematics
- Choose Tools > Auto Substitution and under Enable auto substitution, check In Math.

If automatic substitution is not enabled in mathematics, no function names automatically gray and such names must be selected from the Auto Substitution list or created by choosing Insert > Math Objects > Math Name.

You can evoke the automatic substitution behavior with new custom names using the Automatic Substitution dialog.

To make a custom name automatically gray
2. Type the keystrokes that you wish to use. (This may be an abbreviated form of the custom name.)
3. Click the Substitution box to place the cursor there and, leaving Auto Substitution open, choose Insert > Math Objects > Math Name.
4. Choose a custom name from the scroll-down list or type a custom name in the Name text box in the Math Name dialog.

5. Choose Apply. (The custom name will appear in gray in the Substitution box of the Automatic Substitution dialog.)

6. In the Math Name dialog box, choose OK. (The Math Name dialog will close.)

7. In the Auto Substitution dialog box, choose Save and choose OK.

**Defining Variables and Functions**

When you choose Compute > Definitions, the submenu that opens contains five items: New Definition, Undefine, Show Definitions, Clear Definitions, and Define MuPAD Name. The choice New Definition can be applied both for defining functions or variables and for naming expressions.

**Assigning Values to Variables, or Naming Expressions**

You can assign a value to a variable by choosing Compute > Definitions > New Definition. There are two options for the behavior of the defined variable, depending on the symbol you use for assignment. The default behavior, triggered by =, is deferred evaluation, meaning
Chapter 5 | Function Definitions

the definition is stored exactly as you make it. The alternate behavior, triggered by :=, is full evaluation, meaning the definition that is stored takes into account earlier definitions in force that might affect it. See Full Evaluation and Assignment page 105 for a discussion of the latter option.

Deferred Evaluation

- Use an equal sign = to make an assignment for deferred evaluation.

To assign the value 25 to \( z \) for deferred evaluation

1. Type \( z = 25 \) in mathematics.
2. Leave the insert point in the equation.
3. Choose Compute > Definitions > New Definition.

Thereafter, until you exit the document or undefine the variable, the system recognizes \( z \) as 25. For example, evaluating the expression “\( 3 + z \)” returns “\( = 28 \).”

Another way to describe this operation is to say that an expression such as \( x^2 + \sin x \) can be given a name. Type \( y = x^2 + \sin x \), leave the insert point anywhere in the expression, and choose Compute > Definitions > New Definition.

Note

These variables or names are single characters. See page 100 for information on multicharacter names.

Functions and expressions

The symbol \( p \) represents the expression \( x^3 - 5x + 1 \). It is not a function, so, for example, \( p(2) \) is not the polynomial evaluated at 2, but rather is \( p(2) = 2p = 2x^3 - 10x + 2 \), the product of \( p \) and 2.
Defining Variables and Functions

• An integral: \[ d = \int x^2 \sin x \, dx \]

You will find this feature useful for a variety of purposes.

**Compound Definitions with Deferred Evaluation**

It is legitimate to define expressions in terms of other defined expressions.

**To make compound definitions with deferred evaluation**

• Assign a value to a variable and then use that variable name in the definition of a second variable.

```
Compute > Definitions > New Definition
\[ r = 3p - cq \quad s = nr + q \]
```

**Full Evaluation and Assignment**

With **full evaluation**, variables previously defined are evaluated before the definition is stored. Thus, definitions of expressions can depend on the order in which they are made.

**To make an assignment symbol for full evaluation**

• Type a colon followed by an equals sign `:=`.

**To assign the value 25a to z for full evaluation**

1. Type `z := 25a` in mathematics.
2. Leave the insert point in the equation.
3. Choose Compute > Definitions > New Definition.

Thereafter, until you exit the document or redefine the variable `z`, if `a` has not been previously defined, the system recognizes `z` as `25a`. If `a` has previously been defined to be `x + y`, then the system recognizes `z` as `25(x + y)`.

Try the following examples that contrast the two types of assignments. After making the definitions, choose Compute > Definitions > Show Definitions for each case.

1. Make the assignments `a = 1`, `x := a`, `y = a`, and `a = 2` (in that order), and evaluate `x` and `y`. The result should be `x = 1`, `y = 2`. 
Chapter 5 | Function Definitions

2. Make the assignments \( a = b, x := a^2, y = a^2, \) and \( a = 6 \) (in that order), and evaluate \( x \) and \( y \). The result should be \( x = b^2, y = 36 \).

3. Define \( r = 3p - cq \) and then \( s := nr + q \) and \( t := nr + q \). Evaluating \( s \) and \( t \) will then give \( s = q + n(3p - cq), t = q + n(3p - cq) \). Now define \( r = x + y \). Evaluating \( s \) and \( t \) will now give \( s = q + n(x + y), t = q + n(3p - cq) \).

Functions of One Variable

By using function notation, you can use the same general procedure to define a function as was described for defining a variable.

**To define the function \( f \) whose value at \( x \) is \( ax^2 + bx + c \)**

1. Type the equation \( f(x) = ax^2 + bx + c \).

2. Place the insert point in the equation.

3. Choose Compute > Definitions > New Definition.

After following this procedure, the symbol \( f \) represents the defined function and it behaves like a function.

**Tip**

After defining a function, you can make a table of values for selected points in the domain of the function. See Chapter 7 “Calculus,” page 205 for examples.

**Compound Definitions**

The algebra of functions includes objects such as \( f + g, f - g, f \circ g, fg, \) and \( f^{-1} \). For the value of \( f + g \) at \( x \), write \( f(x) + g(x) \); for the value of the composition of two defined functions \( f \) and \( g \), write \( f(g(x)) \) or \( (f \circ g)(x) \); and for the value of the product of two defined functions, write \( f(x)g(x) \). You can obtain the inverse (or inverse relation) for some functions \( f(x) \) by choosing Compute > Solve > Exact with the equation \( f(y) = x \) and specifying \( y \) as the Variable to Solve for.
**Defining Variables and Functions**

**To make compound definitions**

1. Define functions by choosing Compute > Definitions > New Definition, either as generic functions or in terms of an expression.

2. Combine these functions in standard ways and define the resulting functions by choosing Compute > Definitions > New Definition.

Define $g(x)$ and $h(x)$. Then the following equations are examples of legitimate definitions:

- $f(x) = 2g(x)$
- $f(x) = g(x) + h(x)$
- $f(x) = g(x)h(x)$
- $f(x) = g(h(x))$ or $f(x) = (g \circ h)(x)$
- $f(x) = \frac{g(x)}{h(x)}$

Once you have defined both $g(x)$ and $f(x) = 2g(x)$, then changing the definition of $g(x)$ will change the value of $f(x)$.

**Subscripts as Function Arguments**

A subscript can be interpreted either as part of the name of a function or variable, or as a function argument.

**To define a subscript as a function argument**

1. Place the insert point in an equation such as $a_i = 3i$ with a symbolic subscript and choose Compute > Definitions > New Definition.

2. In the Interpret Subscript dialog that opens, check A function argument.

Observe the different behavior in the following examples.

- **Compute > Definitions > New Definition**
  
  $a_i = 3i$ (subscript a function argument)
  
  $b_i = 3i$ (subscript a part of the name)
Chapter 5 | Function Definitions

Compute > Evaluate

\[ a_2 = 6 \]
\[ b_2 = b_2 \]

Choose Compute > Definitions > Show Definitions to see how these definitions are listed:

Compute > Definitions > Show Definitions

\[ a_i = 3i \] (variable subscript)
\[ b_i = 3i \]

Thus \( a_i \) denotes a function with argument \( i \), and \( b_i \) is only a subscripted variable.

Compute > Definitions > New Definition

\[ f_a (y) = 3ay \]

Note

A function cannot have both subscripted and inline variables. For example, if you define \( f_a (y) = 3ay \), then \( a \) is part of the function name and \( y \) is the function argument.

Compute > Evaluate

\[ f_a (5) = 15a \]
\[ f_3 (5) = 5f_3 \]

Piecewise-Defined Functions

You can define functions of one variable that are described by different expressions on different parts of their domain. These functions are referred to as piecewise-defined functions, case functions, or multicase functions. Most of the operations introduced in calculus are supported for piecewise-defined functions. You can evaluate, plot, differentiate, and integrate piecewise-defined functions.

Structure of a piecewise-defined function

- The function definition must be specified in a two- or three-column matrix with at least two rows, with the function values in the first column, “if” (text) or “\( if \)” (math) in the second column of a three-column matrix (and “\( if \)” or any text, or no text, in the second column of a two-column matrix), followed by the range condition in the last (second or third) column.
- The matrix must be fenced with a left brace and null right delimiter, as in the following examples.

To form a matrix for a piecewise-defined function

1. Choose Insert Math Objects > Brackets and choose \( [ \) for the left bracket and the null delimiter (dashed vertical line) for the
right bracket.

2. Choose Insert > Math Objects > Matrix.

3. Set the numbers for Rows (number of conditions) and Columns (2 or 3), and choose OK.

**To define a piecewise-defined function \( f \) using a matrix with three columns**
1. Type \( f(x) = \) followed by a matrix enclosed in brackets as described.

2. Type function values in the first column.

3. Type \( \text{if} \) in the second column in text or mathematics mode.

4. Type the range conditions in the third column.

5. Leave the insert point in the equation and choose Compute > Definitions > New Definition.

**To define a piecewise-defined function \( f \) using a matrix with two columns**
1. Type \( f(x) = \) followed by a matrix enclosed in brackets as described.

2. Type function values in the first column.

3. (Optional) Type \( \text{if} \) in text mode in the second column.

4. Type the range conditions in mathematics mode in the second column.

5. Leave the insert point in the equation and choose Compute > Definitions > New Definition.

Functions should be entered as in the following examples.
Chapter 5 | Function Definitions

**Compute > Definitions > New Definition**

\[
f(x) = \begin{cases} 
  x + 2 & \text{if } x < 0 \\
  2 & \text{if } 0 \leq x < 1 \\
  2x & \text{if } 1 \leq x 
\end{cases} \quad (3 \times 3 \text{ matrix})
\]

\[
g(t) = \begin{cases} 
  t & \text{if } t < 0 \\
  0 & \text{if } 0 \leq t < 1 \\
  1 & \text{if } 1 \leq t < 2 \\
  2 & \text{if } 2 \leq t < 3 \\
  6 - t & \text{if } 3 \leq t 
\end{cases} \quad (5 \times 2 \text{ matrix})
\]

\[
h(x) = \begin{cases} 
  x + 2 & \text{if } x < 1 \\
  3x & \text{if } 1 \leq x 
\end{cases} \quad (2 \times 3 \text{ matrix})
\]

\[
k(x) = \begin{cases} 
  x + 2 & \text{if } x < 1 \\
  3x & \text{if } 1 \leq x 
\end{cases} \quad (2 \times 2 \text{ matrix})
\]

\[
m(x) = \begin{cases} 
  x + 1 & \text{whenever } x < 1 \\
  \sqrt{x} & \text{whenever } 1 \leq x 
\end{cases} \quad (2 \times 2 \text{ matrix})
\]

**Compute > Evaluate**

\[
f(-1) = 1 \\ f(1/2) = 2
\]

\[
f'(x) = \begin{cases} 
  1 & \text{if } x < 0 \\
  0 & \text{if } 0 < x \land x < 1 \\
  -\frac{2}{x^2} & \text{if } 1 < x 
\end{cases}
\]

See page 155 for details on plotting piecewise-defined functions.

**Defining Generic Functions**

You can choose Compute > Definitions > New Definition to declare an expression of the form \( f(x) \) to be a function without specifying any of the function values or behavior. Thus you can use the function name as input when defining other functions or performing various operations on the function.

To define a generic function

1. Write an expression of the form \( f(x) \).

2. With the insert point in the expression, choose Compute > Definitions > New Definition.
Here, \( f \) is defined as a generic function and \( g \) as a specific function. The examples show how \( f \) and \( g \) interact.

<table>
<thead>
<tr>
<th>Compute &gt; Definitions &gt; New Definition</th>
<th>( f(x) ) ( g(x) = x^2 - 3x )</th>
</tr>
</thead>
</table>

| Compute > Evaluate                   | \( f(g(x)) = f(x^2 - 3x) \) \( g(f(x)) = f^2(x) - 3f(x) \) |

**Defining Generic Constants**

You can choose Compute > Definitions > New Definition to declare any valid expression name to be a constant.

**To define a generic constant**

1. Write a valid constant name in mathematics.
2. Choose Compute > Definitions > New Definition.

<table>
<thead>
<tr>
<th>Compute &gt; Definitions &gt; New Definition</th>
<th>( a )</th>
</tr>
</thead>
</table>

**Functions of Several Variables**

Define functions of several variables in essentially the same way as functions of one variable.

**To define a function of several variables**

1. Write an equation such as \( f(x, y, z) = ax + y^2 + 2z \) or \( g(x, y) = 2x + \sin 3xy \).
2. With the insert point in the equation, choose Compute > Definitions > New Definition.

**Assumptions About Variables**

In some situations it is useful to restrict the domain of a variable. For example, you may want the variable to assume only positive values or only real values. Such restrictions are made with the function “assume.” The functions available for making or checking or removing assumptions are

\[
\text{assume, additionally, about, unassume}
\]

These functions place restraints on specific variables, provide information on the restraints, or remove restraints. The function \( \text{assume} \)

**Note**

Just as in the case of functions of one variable, the system always operates on expressions that it obtains from evaluating the function at a point in the domain of the function.

**Note**

The normal global default is the complex plane. Variables are assumed to be complex variables and solutions to equations include complex solutions.
enables you to place a restraint on a variable. The function \textit{additionally} allows you to place additional restraints. The function \textit{about retrieves} information on the restraints. The function \textit{unassume} removes restraints.

Allowable assumptions include

real complex integer positive negative nonzero

The functions and assumptions listed above will automatically turn upright and gray when typed in mathematics mode. The following assumptions are also allowed for real variables $x$ and $y$, and complex $z$:

\[
x < y \quad x < 3 \quad x \neq 0 \quad x \leq y \quad x \geq 5
\]

\[
\text{Im}(z) > 0 \quad \text{Re}(z) < 0 \quad \text{Re}(z) \neq 0
\]

To enter the names of the functions and assumptions

- Type the name in mathematics mode. (It will automatically turn gray.) Or

- Choose Insert $>$ Math Objects $>$ Math Name and type the name in the input box or select from the list of names.

**Note**

After making the assumption \texttt{assume($x$, real) = $\mathbb{R}$}, only real solutions will be computed:

\[
\text{Im}(z) > 0 \quad \text{Re}(z) < 0 \quad \text{Re}(z) \neq 0
\]

To make an assumption about a variable

1. In mathematics, type \texttt{assume}.

2. Choose Insert $>$ Math Objects $>$ Brackets and click the left paren $[ $.

3. Type the variable name, followed by a comma, followed by the desired assumption.

**Tip**

Use the keyboard shortcut Ctrl+9 or Ctrl+1 to enter expanding parentheses.
4. Choose Compute > Evaluate.

```
Compute > Evaluate
assume(x, real) = \mathbb{R}
```

To place an additional assumption on a variable without removing previous assumptions

1. In mathematics, type additionally.
2. Choose Insert > Math Objects > Brackets and click `[ ]`.
3. Inside the parentheses, type the variable name, followed by a comma, followed by the desired assumption.
4. Choose Compute > Evaluate.

Evaluation of the expressions `assume(n, positive)` and `additionally(n, integer)`, followed by evaluation of the expression about `n`, produces the following output:

```
Compute > Evaluate
assume(n, positive) = (0, \infty)
additionally(n, integer) = \mathbb{Z} \cap (0, \infty)
about(n) = \mathbb{Z} \cap (0, \infty)
```

To restrict the domain of a real variable `x`

1. Make the assumption that `x` is real.
2. Use the function additionally for additional restraints on `x`.

```
Compute > Evaluate
assume(x, real) = \mathbb{R}
additionally (x < 10) = (-\infty, 10)
additionally (x \geq -10) = [-10, 10)
```

```
Compute > Solve > Exact
\sin x = 0, Solution: -3\pi, -2\pi, -\pi, 0, \pi, 2\pi, 3\pi
```

To assume the variable `n` is positive

- Place the insert point in the expression `assume(n, positive)`,
  and choose Compute > Evaluate.

Note
An additional assumption placed on a variable using `assume` would negate any previous assumption.
To clear the assumptions about a variable

- Select the variable and choose Compute > Definitions > Undefine, or
  
  Evaluate unassume (name of variable).

After either procedure, you can check the status of the variable \( n \) with the function about.

\[
\text{Compute > Evaluate about (} n \text{) = } n
\]

This response indicates there are no assumptions on the variable \( n \).

Note

If you assume that \( n \) is an integer, the system will recognize that \( n^2 \) is a positive integer.

\[
\begin{align*}
\text{Compute > Evaluate} & \quad \text{assume (} n, \text{ integer) = } \mathbb{Z} \\
& \quad \text{about (} n^2 \text{) = } \mathbb{Z} \cap [0, \infty) \\
& \quad |n^2 + 1| = n^2 + 1
\end{align*}
\]

In the default mode, both real and complex solutions will be computed:

\[
\begin{align*}
\text{Compute > Solve > Exact} & \quad x^4 = 1, \text{ Solution: } -i, -1, i, 1 \\
\end{align*}
\]

Assuming \( x \) is positive leads to only real positive solutions:

\[
\begin{align*}
\text{Compute > Evaluate} & \quad \text{assume (} x, \text{ positive) = (} 0, \infty) \\
\text{Compute > Solve > Exact} & \quad x^2 = 1, \text{ Solution: } 1 \\
& \quad x^4 = 1, \text{ Solution: } 1
\end{align*}
\]

To restrict the domain of a complex variable \( z \)

- Make assumptions on the real and imaginary parts of \( z \).

\[
\begin{align*}
\text{Compute > Evaluate} & \quad \text{assume (Re (} z \text{) > 0) = (} 0, \infty) + \mathbb{R} \\
& \quad \text{additionally (Im (} z \text{) < 0) = (} 0, \infty) + i(-\infty, 0)
\end{align*}
\]
Handling Definitions

After making definitions of functions or expressions, you need to know techniques for keeping track of them. The choices on the Definitions submenu are New Definition, Undefine, Show Definitions, Clear Definitions, and Define MuPAD Name. The choice Show Definitions also appears on the Math toolbar as $\text{Show Definitions}$.

Showing Definitions

To view the complete list of currently defined variables and functions

• Choose Compute > Definitions > Show Definitions.

A window opens showing the active definitions. The defined variables and functions are listed in the order in which the definitions were made.

Removing and Changing Definitions

To remove all definitions

• Choose Compute > Definitions > Clear Definitions.

To remove a single definition

• Select the defining equation or select the name of the defined expression or function and choose Compute > Definitions > Undefine.

To change a definition

• Make a new definition using the same function or variable name.

You can select the equation or name by placing the insert point within or on the right side of the equation or name that you wish to remove, or you can select the entire equation, expression, or function name with the mouse. You can find the equation or name in the Show Definitions window if you do not have a copy readily at hand. Copy an expression from this window into your document, then select the expression and choose Undefine.

Formulas

The Formula dialog provides a way to enter an expression and a Compute operation. What appears on the screen is the result of the
Chapter 5 | Function Definitions

operation and depends upon active definitions of variables that appear in the formula. Formulas remain active in your document—that is, changing definitions of relevant variables changes the data on the screen.

To insert a formula
1. Choose Insert > Math Objects > Formula.
2. Type an expression in the input box.
3. In the Operation area, select the operation you want to perform on the expression. (Click the arrow at the right of the box for a list of available operations.)
4. Choose OK.

The results of the operation will be displayed in your document window.

To recognize a formula on the screen from a background color
- Choose View and turn on Helper Lines.

To change the formula background color
1. Choose Tag > Appearance.
2. Check Modify Style Defaults.
4. Under Special Objects choose Formula and click Modify.
5. Select background color and choose OK.
6. Choose Save if you wish to make a permanent change in the screen style, and choose OK.

Example Choose Insert > Math Objects > Formula. In the Formula box, type \( a \), and under Operations choose evaluate. Choose OK. The \( a \) will appear on your screen at the position of the insert point. Now, at any point in your document, define \( a = \sin x \). The variable \( a \) will be replaced by the expression \( \sin x \) wherever \( a \) appears in the document. Make another definition for \( a \). The variable \( a \) will again be replaced by the new definition everywhere \( a \) appears in the document.

Note
With Helper Lines on, a Formula appears with a colored background. The default is yellow.
Example  Insert a $2 \times 2$ matrix. With the insert point in the first input box, choose Insert $>$ Math Objects $>$ Formula. In the Formula box, type $a$. Under Operations, choose Evaluate. Choose OK. Repeat for each matrix entry, typing $b$, $a + 2b$, and $(a - b)^2$, in turn, in the formula box to get the matrix

$$\begin{bmatrix} a & b \\ a + 2b & (a - b)^2 \end{bmatrix}$$

Now define $a = \sin x$ and $b = \cos x$. The matrix will be replaced by the matrix

$$\begin{bmatrix} \sin x & \cos x \\ \sin x + 2\cos x & (\sin x - \cos x)^2 \end{bmatrix}$$

Define $a = \ln x$ and $b = e^x$. The matrix will then be replaced by the matrix

$$\begin{bmatrix} \ln x & e^x \\ \ln x + 2e^x & (\ln x - e^x)^2 \end{bmatrix}$$

Example  Insert a table with 2 columns and 5 rows. Insert formulas $x$, $y$, $z$, and $x + y + z$ in the column on the right.

<table>
<thead>
<tr>
<th>Date</th>
<th>Income</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/31/96</td>
<td>$x$</td>
</tr>
<tr>
<td>2/28/96</td>
<td>$y$</td>
</tr>
<tr>
<td>3/31/96</td>
<td>$z$</td>
</tr>
<tr>
<td>Total</td>
<td>$x + y + z$</td>
</tr>
</tbody>
</table>

Define $x = 20.56$, $y = 18.92$, $z = 23.45$ to get the table

<table>
<thead>
<tr>
<th>Date</th>
<th>Income</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/31/96</td>
<td>20.56</td>
</tr>
<tr>
<td>2/28/96</td>
<td>18.92</td>
</tr>
<tr>
<td>3/31/96</td>
<td>23.45</td>
</tr>
<tr>
<td>Total</td>
<td>62.93</td>
</tr>
</tbody>
</table>

Formulas are useful for writing multiple choice examinations with variations. The next example outlines a way for constructing them manually.

The questions in an examination depend on definitions that are made globally for each document—they’re not local to each question.
Chapter 5 | Function Definitions

or variant. This means that you often should use a Math Name instead of a single character name for variables. A sample question is shown in the next example. The variables \( a_1 \) and \( b_1 \) shown in the next example are math names.

**To enter a Math Name in a Formula window**

1. Choose Insert > Math Objects > Formula.

2. With the insert point in the Formula window, choose Insert > Math Objects > Math Name.

3. Type or select a Math Name and choose OK.

**Example** You can create an examination with variations by making different definitions for the variables such as the \( a_1 \) and \( b_1 \) shown in the following question. Turn on Helper Lines in your document and look for background color to check that all appropriate entries are formulas.

1. For which values of the variable \( x \) is \( a_1 x - b_1 < 0 \)?
   
   a. \( x < b_1 / a_1 \)
   
   b. \( x > b_1 / a_1 \)
   
   c. \( x > b_1 \)
   
   d. \( x < b_1 \)
   
   e. None of these

Define \( a_1 = 2 \) and \( b_1 = 5 \) by placing the insert point in each equation and choosing Compute > Definitions > New Definition. On your screen you should see

1. For which values of the variable \( x \) is \( 2x - 5 < 0 \)?
   
   a. \( x < 5/2 \)
   
   b. \( x > 5/2 \)
   
   c. \( x > 5 \)
   
   d. \( x < 5 \)
   
   e. None of these

After printing a quiz, make different definitions for all the variables such as \( a_1 \) and \( b_1 \) to obtain variations of the quiz.
External Functions

You can access functions available to the computation engine that do not appear as menu items. These can be either functions from one of the libraries of the computation engine or user-defined functions.

Functions defined with the Compute > Definitions > Define MuPAD Name dialog, with their MuPAD name correspondences, appear in the Show Definitions window but they may not be removed by Clear Definitions.

To remove a defined MuPAD function

• Select the function name and choose Compute > Definitions > Undefine.

Accessing Functions in MuPAD Libraries

The following example defines the function divisors, which computes the divisors of a positive integer.

To access the MuPAD function divisors and to name it D

1. Choose Compute > Definitions > Define MuPAD Name.

2. Respond to the dialog box as follows:

• MuPAD Name: numlib::divisors(x)
• Scientific Notebook (WorkPlace) Name: D(x)
• Check “That is built in to MuPAD” or “is automatically loaded”

3. Choose OK.

Compute > Evaluate

\[ D(24) = [1, 2, 3, 4, 6, 8, 12, 24] \]

An extensive MuPAD library is included with your system. Here is a short list of functions from the many examples that are available using the Define MuPAD Name dialog.
Chapter 5 | Function Definitions

<table>
<thead>
<tr>
<th>MuPAD Name</th>
<th>Sample SWP/SNB Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>nextprime(n)</td>
<td>p(n)</td>
</tr>
<tr>
<td>ithprime(n)</td>
<td>I(n)</td>
</tr>
<tr>
<td>isprime(n)</td>
<td>q(n)</td>
</tr>
<tr>
<td>numlib::phi(n)</td>
<td>ϕ(n)</td>
</tr>
<tr>
<td>numlib::legendre(a,b)</td>
<td>L(a,b)</td>
</tr>
<tr>
<td>numlib::divisors(x)</td>
<td>d(x)</td>
</tr>
<tr>
<td>polylib::resultant(a,b,x)</td>
<td>r(a,b,x)</td>
</tr>
<tr>
<td>lllint(a)</td>
<td>L(a)</td>
</tr>
</tbody>
</table>

The following example defines the function \textit{ithprime}, which produces the \textit{i}th member of the sequence of prime integers.

**To access the MuPAD function \textit{ithprime} and to name it \textit{I}\textsuperscript{th}**

1. Choose Compute > Definitions > Define MuPAD Name.
2. In the MuPAD Name box, type \textit{ithprime}(x).
3. In the Scientific WorkPlace (Notebook) Name box, type \textit{I}(x).
4. Check “That is built in to MuPAD or is automatically loaded.”
5. Choose OK.

**Compute > Evaluate**

\[
I(100) = 541 \\
I(1000000000) = 22801763489
\]

See page 453 for another example. In that section, the MuPAD function \textit{nextprime} is used.

The guidelines for valid function and expression names (see page 100) apply to the names that can be entered in the Define MuPAD Name dialog box. You can give a multicharacter name to a function as follows: with the Define MuPAD Name dialog box open and the insert point in the Scientific WorkPlace/Scientific Notebook Name box, choose Insert > Math Objects > Math Name, type the desired function name, and click OK.

The preceding comments also apply to user-defined MuPAD functions discussed in the following section.

**User-Defined MuPAD Functions**

You can access user-defined functions written in the MuPAD language. Write a MuPAD function or procedure with MuPAD or any ASCII editor, and save to a file \texttt{filename.mu}. While in a \textit{Scientific WorkPlace (Notebook)} document, choose Compute > Definitions > Define MuPAD Name.
To access the function myfunc and name it M
1. Choose Compute > Definitions > Define MuPAD Name.

2. Respond to the dialog box as follows:
   - MuPAD Name: type myfunc(x).
   - Scientific WorkPlace (Notebook) Name: type M(x).
   - The MuPAD Name is a Procedure:
     - Check In MuPAD format file (.mu file) for MuPAD file.
     - Choose Browse and locate your file.

3. Choose OK.

This procedure defines a function $M(x)$ that behaves according to your MuPAD program.

Example
Create an ASCII file with the following content.
```
myfunc := proc(x)
begin
  return(sin(2*x));
end_proc;
```
Save the file under the name myfunc.muo, and define the function $M$ in Scientific Notebook or Scientific Workplace according to the instructions preceding this example. You can then evaluate $M(2)$.

Compute > Evaluate
$M(2) = \sin 4$

Passthru Code to Engine
You can also pass MuPAD code directly to the MuPAD engine. This is similar to using Define MuPAD Name, but is convenient for accessing a MuPAD function that you may only use once or twice. It requires knowledge of the exact MuPAD syntax.

To solve the system of equations $2x + y = 7, 3x - 2y = 0$
1. Type the MuPAD code `solve({2*x+y=7,3*x-2*y=0},{x,y})` in text.

2. Select the code with your mouse.

3. Choose Compute > Passthru Code to Engine.
Chapter 5 | Function Definitions

Compute > Passthru Code to Engine

\[
\begin{align*}
\text{solve}\{2x+y=7,3x-2y=0\},\{x,y\} \\
\{x = 2, y = 3\}
\end{align*}
\]

To list the numbers \(\pi, \sqrt{10}, e, 11/4, 2.718\) in increasing order

1. Type the MuPAD code \(\text{sort([\pi,\sqrt{10},E,11/4,2.718])}\) in text.

2. Select the code with your mouse.

3. Choose Compute > Passthru Code to Engine.

\[
\begin{align*}
\text{Compute > Passthru Code to Engine} \\
\text{sort([sqrt(10),11/4,2.718])} \\
[2.718, \frac{11}{4}, \sqrt{10}]
\end{align*}
\]

Trigtype Functions

*Scientific WorkPlace* and *Scientific Notebook* recognize two types of functions—ordinary functions and trigtype functions. The functions \(\Gamma(x)\) and \(\exp(x)\) are examples of ordinary functions while \(\sin x\) and \(\ln x\) are examples of trigtype functions. The distinction is that the argument of an ordinary function is always enclosed in parentheses and the argument of a trigtype function often is not.

Twenty six functions are interpreted as trigtype functions: the six trigonometric functions, the corresponding hyperbolic functions, the inverses of these functions written as “arc” functions (e.g. \(\arctan(x)\)), and the logarithmic functions \(\log\) and \(\ln\). These functions are identified as trigtype functions because they are commonly printed differently from ordinary functions in books and journal articles.

You can reset your system so that all output is written with parentheses around arguments.

To disable trigtype output


2. Check Use Parentheses for Trig Functions.

3. Choose OK.

Your system will continue to interpret \(\sin x\) as a function with argument \(x\), but the output of all computations will be of the form \(\sin(x)\) with the argument enclosed in parentheses.
Determining the Argument of a Trigtype Function

There is no ambiguity in determining the argument of an ordinary function because it is always enclosed in parentheses. However, it can be rather tricky to find the argument of a trigtype function. Consider $\Gamma(a + b)x$ and $\sin(a + b)x$ for example. It is clear that one intends to evaluate $\Gamma$ at $a + b$ and then multiply the result by $x$. However, with the similar construction $\sin(a + b)x$, it is quite likely that the sine function is intended to be evaluated at the product $(a + b)x$. If this is not what is intended, the expression is normally written as $x\sin(a + b)$, or as $(\sin(a + b))x$.

To determine how an expression you enter will be interpreted

- Place the insert point in the expression and choose Compute $>$ Interpret.

In the following examples, Use Parentheses for Trig Functions has been checked.

<table>
<thead>
<tr>
<th>Compute $&gt;$ Interpret</th>
<th>Argument of $\sin$</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sin x/2 = \frac{1}{2} \sin x$</td>
<td>$x$</td>
</tr>
<tr>
<td>$\sin x/y = \sin \left( \frac{x}{y} \right)$</td>
<td></td>
</tr>
</tbody>
</table>

Roughly speaking, the algorithm that decides when the end of the argument of a trigtype function has been reached when it finds a $+$ or $-$ sign, but tends to keep going as long as things are still being multiplied together. There are many exceptions, some of which are shown in the following examples.

<table>
<thead>
<tr>
<th>Compute $&gt;$ Interpret</th>
<th>Argument of $\sin$</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sin x + 5 = \sin (x) + 5$</td>
<td>$x$</td>
</tr>
<tr>
<td>$\sin (a + b)x = \sin (a + b)x$</td>
<td>$(a + b)$</td>
</tr>
<tr>
<td>$\sin x(a + b) = \sin (x(a + b))$</td>
<td>$x(a + b)$</td>
</tr>
<tr>
<td>$\sin x \cos x = \sin (x) \cos (x)$</td>
<td>$x$</td>
</tr>
<tr>
<td>$\sin x (\cos x + \tan x) = \sin \left( x \left( \cos x + \tan x \right) \right)$</td>
<td>$x(\cos x + \tan x)$</td>
</tr>
<tr>
<td>$(\sin x)(\cos x + \tan x) = (\sin (x))(\cos x + \tan x)$</td>
<td>$x$</td>
</tr>
<tr>
<td>$\sin xe^x = \sin (xe^x)$</td>
<td>$xe^x$</td>
</tr>
<tr>
<td>$e^x \sin x = e^x \sin (x)$</td>
<td>$x$</td>
</tr>
</tbody>
</table>

When in doubt, use extra parentheses or choose Compute $>$ Interpret. Note that there is no ambiguity in the expression $e^x \sin x$. The expression $\sin xe^x$ may or may not be interpreted in the way you intended.
Chapter 5 | Function Definitions

Exercises

1. Define $a = 5$. Define $b = a^2$. Evaluate $b$. Now define $a = \sqrt{2}$. Guess the value of $b$ and check your answer by evaluation.

2. Define $f(x) = x^2 + 3x + 2$. Evaluate
   \[
   \frac{f(x + h) - f(x)}{h}
   \]
   and simplify the result. Do computing in place to show intermediate steps in the simplification.

3. Define $f(x) = x^2 - 1$, $g(x) = 3x + 2$, $h(x) = x^2 + 3x$. Compute $f + g$, $(f + g)h$, and $fh + gh$. Compute $(f + g)h$, and $f \circ h + g \circ h$.

4. Redefine the function $f(x) = \max(x^2 - 1, 7 - x^2)$ as a piecewise-defined function.

5. Experiment with the Euler phi function $\phi(n)$, which counts the number of positive integers $k \leq n$ such that $\gcd(k, n) = 1$. Test the statement “If $\gcd(n, m) = 1$ then $\phi(nm) = \phi(n)\phi(m)$” for several specific choices of $n$ and $m$. Choose Compute > Definitions > Define MuPAD Name to open a dialog. Type numlib::phi(n) as the MuPAD Name, $\phi(n)$ as the Scientific Workplace/Notebook Name, check That is Built Into MuPAD or automatically loaded, and click OK.

6. Choose Compute > Definitions > Define MuPAD Name to open a dialog. Define $d(n)$ by typing numlib::divisors(n) as the MuPAD name, $d(n)$ as the Scientific Workplace/Notebook Name, check That is Built Into MuPAD or automatically loaded, and click OK. Explain what the function $d(n)$ produces. (This is an example of a set-valued function, since the function values are sets instead of numbers.)

Solutions

1. If $a = 5$ then defining $b = a^2$ produces $b = 25$. Now define $a = \sqrt{2}$. The value of $b$ is now $b = 2$. 
2. Evaluate followed by Simplify yields

\[
\frac{f(x+h)-f(x)}{h} = \frac{1}{h} \left( 3h - x^2 + (h+x)^2 \right) = 2x+h+3
\]

Select the expression \(\frac{f(x+h)-f(x)}{h}\) and, with the Ctrl key down, drag the expression to create a copy. Select the expression \(f(x+h)\) and, with the Ctrl key down, choose Evaluate. Add similar steps (use Factor to rewrite \(2xh+h^2+3h\)) until you have the following:

\[
\frac{f(x+h)-f(x)}{h} = \frac{3h + 3x + (h+x)^2 + 2 - (3x + x^2 + 2)}{h} = \frac{3h + 3x + 2hx + h^2 + x^2 + 2 - 3x - x^2 - 2}{h} = \frac{3h + 2hx + h^2}{h} = \frac{h(h + 2x + 3)}{h} = h + 2x + 3
\]

3. The sum is given by \((f+g)(x) = f(x) + g(x)\) so

\[
(f+g)(x) = (x^2 - 1) + (3x + 2) = x^2 + 3x + 1
\]

The product is given by \(((f+g)h)(x) = ((f+g)(x))(h(x))\)
so

\[
((f+g)h)(x) = (x^2 + 3x + 1) (x^2 + 3x) = x^4 + 6x^3 + 10x^2 + 3x
\]

The sum of the products is \((fh+gh)(x) = f(x)h(x) + g(x)h(x)\)
so

\[
(fh+gh)(x) = (x^2 - 1) (x^2 + 3x) + (3x + 2) (x^2 + 3x)
= x^4 + 6x^3 + 10x^2 + 3x
\]

Define \(k(x) = f(x) + g(x)\) then \((f + g) \circ h = k \circ h\) so

\[
((f + g) \circ h)(x) = (k \circ h)(x) = (x^2 + 3x)^2 + 1 + 3x^2 + 9x
= x^4 + 6x^3 + 12x^2 + 9x + 1
\]

Finally, \((f \circ h + g \circ h)(x) = (f \circ h)(x) + (g \circ h)(x)\) so that
Chapter 5 | Function Definitions

\[
(f \circ h)(x) + (g \circ h)(x) = \left((x^2 + 3x)^2 - 1\right) + (3x^2 + 9x + 2)
= x^4 + 6x^3 + 12x^2 + 9x + 1
\]

This demonstrates that both product and composition distribute over addition.

4. To redefine \( f(x) = \max(x^2 - 1, 7 - x^2) \) as a piecewise-defined function, first note that the equation \( x^2 - 1 = 7 - x^2 \) has the solutions \( x = -2 \) and \( x = 2 \). The function \( f \) is given by

\[
g(x) = \begin{cases} 
  x^2 - 1 & \text{if } x < -2 \\
  7 - x^2 & \text{if } -2 \leq x \leq 2 \\
  x^2 - 1 & \text{if } x > 2 
\end{cases}
\]

As a check, note that \( f(-5) = 24, g(-5) = 24, f(1) = 6, g(1) = 6, f(3) = 8, \) and \( g(3) = 8 \).

5. Construct the following table:

<table>
<thead>
<tr>
<th>( n )</th>
<th>( \varphi(n) )</th>
<th>( n )</th>
<th>( \varphi(n) )</th>
<th>( n )</th>
<th>( \varphi(n) )</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>11</td>
<td>10</td>
<td>21</td>
<td>12</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>12</td>
<td>4</td>
<td>22</td>
<td>10</td>
</tr>
<tr>
<td>3</td>
<td>2</td>
<td>13</td>
<td>12</td>
<td>23</td>
<td>22</td>
</tr>
<tr>
<td>4</td>
<td>2</td>
<td>14</td>
<td>6</td>
<td>24</td>
<td>8</td>
</tr>
<tr>
<td>5</td>
<td>4</td>
<td>15</td>
<td>8</td>
<td>25</td>
<td>20</td>
</tr>
<tr>
<td>6</td>
<td>2</td>
<td>16</td>
<td>8</td>
<td>26</td>
<td>12</td>
</tr>
<tr>
<td>7</td>
<td>6</td>
<td>17</td>
<td>16</td>
<td>27</td>
<td>18</td>
</tr>
<tr>
<td>8</td>
<td>4</td>
<td>18</td>
<td>6</td>
<td>28</td>
<td>12</td>
</tr>
<tr>
<td>9</td>
<td>6</td>
<td>19</td>
<td>18</td>
<td>29</td>
<td>28</td>
</tr>
<tr>
<td>10</td>
<td>4</td>
<td>20</td>
<td>8</td>
<td>30</td>
<td>8</td>
</tr>
</tbody>
</table>

Notice, for example, that

\[
\varphi(4 \cdot 5) = 8 = \varphi(4) \varphi(5)
\]
\[
\varphi(4 \cdot 7) = 12 = \varphi(4) \varphi(7)
\]
\[
\varphi(3 \cdot 8) = 8 = \varphi(3) \varphi(8)
\]
6. Construct the following table:

<table>
<thead>
<tr>
<th>$n$</th>
<th>$\varphi(n)$</th>
<th>$n$</th>
<th>$\varphi(n)$</th>
<th>$n$</th>
<th>$\varphi(n)$</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>11</td>
<td>[1, 11]</td>
<td>21</td>
<td>[1, 3, 7, 21]</td>
</tr>
<tr>
<td>2</td>
<td>[1, 2]</td>
<td>12</td>
<td>[1, 2, 3, 4, 6, 12]</td>
<td>22</td>
<td>[1, 2, 11, 22]</td>
</tr>
<tr>
<td>3</td>
<td>[1, 3]</td>
<td>13</td>
<td>[1, 13]</td>
<td>23</td>
<td>[1, 23]</td>
</tr>
<tr>
<td>4</td>
<td>[1, 2, 4]</td>
<td>14</td>
<td>[1, 2, 7, 14]</td>
<td>24</td>
<td>[1, 2, 3, 4, 6, 8, 12, 24]</td>
</tr>
<tr>
<td>6</td>
<td>[1, 2, 3, 6]</td>
<td>16</td>
<td>[1, 2, 4, 8, 16]</td>
<td>26</td>
<td>[1, 2, 13, 26]</td>
</tr>
<tr>
<td>7</td>
<td>[1, 7]</td>
<td>17</td>
<td>[1, 17]</td>
<td>27</td>
<td>[1, 3, 9, 27]</td>
</tr>
<tr>
<td>8</td>
<td>[1, 2, 4, 8]</td>
<td>18</td>
<td>[1, 2, 3, 6, 9, 18]</td>
<td>28</td>
<td>[1, 2, 4, 7, 14, 28]</td>
</tr>
<tr>
<td>9</td>
<td>[1, 3, 9]</td>
<td>19</td>
<td>[1, 19]</td>
<td>29</td>
<td>[1, 29]</td>
</tr>
<tr>
<td>10</td>
<td>[1, 2, 5, 10]</td>
<td>20</td>
<td>[1, 2, 4, 5, 10, 20]</td>
<td>30</td>
<td>[1, 2, 3, 5, 6, 10, 15, 30]</td>
</tr>
</tbody>
</table>

Notice that $d(n)$ consists of all the divisors of $n$. 
The plotting capabilities of symbolic algebra systems are among their most powerful features. With the system you are using, you can carry out operations interactively. You can plot functions and expressions, examine the results, revise the plot and examine the results of the revision, add multiple functions to the plot, and carry out a variety of other plotting procedures. This adds an experimental dimension to problem solving that was not easily accessible in the past. In the preceding chapter, several plots were provided to illustrate properties of functions. You will find yourself creating plots in many situations to help answer questions about the behavior of different functions or families of functions.

In this chapter, you will find techniques for creating plots, showing how to plot lines and curves in the Euclidean plane, and lines, curves, and surfaces in three-dimensional Euclidean space. These techniques use the basic routines Rectangular, Polar, Implicit, and Parametric from the Plot 2D submenu, and Rectangular, Cylindrical, Spherical, Implicit, and Tube from the Plot 3D submenu. The submenus of Plot 2D, Plot 3D, and Calculus also contain a variety of specialized plotting routines for advanced topics in calculus, vector calculus, and differential equations. Those plotting options are introduced and discussed elsewhere, along with the related mathematics.
Chapter 6 | Plotting Curves and Surfaces

Getting Started With 2D Plots

You can plot an expression or function in several ways, as described in the following sections. Most of these are variations on the following basic procedure.

To plot an expression involving one variable
1. Place the insert point in the expression.
2. Choose Compute > Plot 2D > Rectangular.

Note
Shown here are both the expression \( x^3 \) and its plot on the default interval \(-6 \leq x \leq 6\).

A frame containing a plot of the expression appears after the expression, either displayed or in line (that is, with the lower edge resting on the text baseline) and the insert point appears at the right of the plot. In the plot layout section you will find information on repositioning and resizing the frame. Following that is information on revising plots.

The first attempt at a plot uses the default parameters. There are many settings you can adjust to obtain the view you prefer.

To plot the function \( y = x \sin x \) on the default interval \(-6 \leq x \leq 6\)
1. Leave the insert point in the expression \( x \sin x \).
2. Choose Compute > Plot 2D > Rectangular.

To add the expression \( x^2 \) to a plot
- Drag and drop the expression \( x^2 \) onto the plot frame.
Getting Started With 2D Plots

**Rectangular Coordinates**
When you choose Compute > Plot 2D > Rectangular, the view that appears is determined by inequalities of the form $a \leq x \leq b$ and $c \leq y \leq d$. The standard default for the view is the region bounded by $-6 \leq x \leq 6$ and $c \leq y \leq d$, where $c$ and $d$ are chosen by the underlying computational system and depend on the shape of the function plot.

**To create a 2D plot with rectangular coordinates**
1. Place the insert point in a mathematical expression with one variable.
2. Choose Compute > Plot 2D > Rectangular.

**Polar Coordinates**
In polar coordinates, you specify a point $P$ by giving the angle $\theta$ that the ray from the origin to the point $P$ makes with the polar axis and the distance $r$ from the origin. The equations that relate rectangular coordinates to polar coordinates are given by

$$x = r \cos \theta \quad \text{and} \quad y = r \sin \theta$$
or equivalently,

\[ x^2 + y^2 = r^2 \quad \text{and} \quad \tan \theta = \frac{y}{x} \]

When you choose Compute > Plot 2D > Polar, the view that appears is determined by the inequality \(-\pi \leq \theta \leq \pi\) on the angle. The view intervals are chosen by the underlying computational system and depend on the shape of the function plot.

**To make a 2D plot in polar coordinates**

1. Place the insert point in a mathematical expression with one variable.
2. Choose Compute > Plot 2D > Polar.

To obtain the view shown in the following plots, check Equal Scaling on Both Axes (see page 143).

**Implicit Plots**

When you choose Compute > Plot 2D > Implicit, the view is determined by inequalities of the form \(a \leq x \leq b\) and \(c \leq y \leq d\). The default values for the Plot Intervals are \(-6 \leq x \leq 6\) and \(-6 \leq y \leq 6\), and the default View Intervals are determined by the underlying computer algebra system.

**To create an implicit 2D plot with rectangular coordinates**

1. Place the insert point in a mathematical equation with two variables.
2. Choose Compute > Plot 2D > Implicit.
The following are default views.

**Compute > Plot 2D > Implicit**

\[ x^2 + y^2 = 49 \]
\[ x^2 + y^2 = 25 \]

You can make an implicit plot of the equation \( x = f(y) \) to plot the inverse function or inverse relation of a function \( y = f(x) \).

**To plot the inverse function or relation of a function \( y = f(x) \) as an implicit plot**

- Reverse the variable names in the equation and make an implicit plot.

For example, to plot the cube root function \( y = x^{1/3} \), observe that it is the inverse function to \( y = x^3 \) and create an implicit plot of \( x = y^3 \). Revise the plot and set Plot Intervals to \(-5 < x < 5\) and \(-1.75 < y < 1.75\). The default assigns \( y \) a wider domain, therefore computing many points outside the view and producing a rather rough looking curve.

**Compute > Plot 2D > Implicit**

\[ y^3 = x \]

For the inverse relation of the sine function \( y = \sin x \), do an implicit plot of \( x = \sin y \). Changing the view appropriately will give the
Chapter 6 | Plotting Curves and Surfaces

plot of the inverse sine function. For a smooth curve, revise the plot and set the Plot Intervals to match the view that appears in the plot.

**Compute > Plot 2D > Implicit**

\[ \sin y = x \]

Tip

See page 135 for plotting arcsin \( x \) using a parametric plot.

**Parametric Plots**

When you choose Compute > Plot 2D > Parametric, the default values for the Plot Interval are \(-6 \leq t \leq 6\) and the View Intervals \(a \leq x \leq b\) and \(c \leq y \leq d\) are determined by the underlying computer algebra system.

To plot a 2D parametric curve with rectangular coordinates

1. Make the two defining expressions the components of a vector.
   
   You can use any of the standard notations for a vector, including the forms \([\sin 2t, \cos 3t]\), \((\sin 2t, \cos 3t)\), \([\sin 2t \cos 3t]\), \((\sin 2t \cos 3t)\), \((\sin 2t \cos 3t)\), \((\sin 2t \cos 3t)\), \((\sin 2t \cos 3t)\). (The last four vectors are \(1 \times 2\) and \(2 \times 1\) matrices, respectively.)

2. Place the insert point in the vector.

3. Choose Compute > Plot2D > Parametric.

The following are default views.
Getting Started With 2D Plots

Compute > Plot 2D > Parametric

\[(6 \cos x, 6 \sin x) \quad \quad \quad (3 \cos x, 3 \sin x)\]

The following plot shows the parametric curve defined by \(x = \sin 2t\), \(y = \cos 3t\) as the parametric plot of the vector \([\sin 2t, \cos 3t]\) with \(0 \leq t \leq 2\pi\) and Equal Scaling Along Each Axis.

Compute > Plot 2D > Parametric

\[(\sin 2t, \cos 3t)\]

To plot the inverse function or inverse relation of a function \(y = f(x)\)
- Make a parametric plot of the pair \((f(x), x)\).

For example, to plot the cube root function \(y = x^{1/3}\), observe that it is the inverse function to \(y = x^3\) and create a parametric plot.

Compute > Plot 2D > Parametric

\((x^3, x)\)

The inverse relation of \(\sin x\) follows. Adjust the view to get the plot of \(\sin^{-1} x\).
You can generate a regular pentagon with an enclosed five-point star by creating two parametric plots of \((\sin 2\pi x, \cos 2\pi x)\) and changing the Plot Intervals and number of Points Sampled.

Inequality Plots

You can plot the set of points \((x, y)\) such that \(g(x, y) < h(x, y)\).

To plot an inequality

1. Enter an expression of the form \(g(x, y) < h(x, y)\).

2. With the insert point in the expression choose Compute > Plot 2D > Inequality.
Getting Started With 2D Plots

\[ y < x^2 \]

You can change the fill and background colors on the Items Plotted page of the Properties of Function Graph dialog box (see page 140).

\[ x + y^2 < 5 \]

Note

By default, the region inside the rectangular region \(-6 \leq x \leq 6, -6 \leq y \leq 6\) that satisfies the inequality \(g(x, y) < h(x, y)\) is shown in blue, and the region that does not satisfy the inequality is in red.

You can also plot the set of points \((x, y)\) that satisfy multiple inequalities by placing the inequalities in a row matrix and choosing Compute > Plot 2D > Inequality.

To plot multiple inequalities

1. Enter an expression of the form \[ g_1(x, y) < h_1(x, y) \quad g_2(x, y) < h_2(x, y) \quad g_3(x, y) < h_3(x, y) \].

2. With the insert point in the expression, choose Compute > Plot 2D > Inequality.
Chapter 6 | Plotting Curves and Surfaces

**Compute > Plot 2D > Inequality**

\[
\begin{align*}
  x + y^2 &< 5 \\
  -x + y^2 &< 5 \\
  x + 2y &< 5 \\
  -x + y &< 3 \\
  x - 3y &< 4
\end{align*}
\]

Other types of 2D plots

There are several other options under Compute > Plot 2D. See Chapter 9 "Vector Calculus" for Conformal (page 379), Gradient (page 367), and Vector Field (page 363). See Chapter 10 "Differential Equations" for ODE (page 401). See Chapter 7 "Calculus" for Approximate Integral (page 238).

Interactive Tools for 2D Plots

When a plot frame is selected, several plotting tools become visible just below other toolbars at the top of the screen.

The tool on the left is Reset Viewpoint. Next is the Selection Tool, then the Zooming Tool, the Moving Tool, and the Query Tool.

To display plotting tools

1. Click to the right of the plot.
2. Move the mouse to the insert point. (The arrow changes to a hand.)
3. Click when you see a hand. (This creates a resizable frame and brings the plotting tools into view.)

Or

- If a frame is visible, click the frame.
Interactive Tools for 2D Plots

Reset Viewpoint
Click the Reset Viewpoint tool to reset the viewpoint to a default position.

Zooming In and Out
The Zooming Tool shows a small arrow pointing up and a larger arrow pointing down.

To zoom in or out
1. Click the Zooming Tool.
2. Move the mouse pointer over the view.
3. Click and drag towards the top of the screen to zoom out, or click and drag towards the bottom of the screen to zoom in.

Translating the View
Changing the Plot Intervals reveals different portions of a plot. To see different portions of a plot in an interactive way, you can translate the view with the Moving Tool. The Moving Tool shows four arrows, similar to the north, south, east, west arrows commonly shown on a map.

To translate the view
1. Select the Moving Tool.
2. Move the mouse pointer over the view.
3. Click and drag in the direction you want to translate the plot.

Plot Coordinates
The default tool for 2D plots is the Query Tool. This is used to view the coordinates of points on a plot.

To view plot coordinates
1. Select the Query Tool.
2. Move the mouse pointer to a point of interest on the plot.
3. Press and hold the left mouse button to view coordinates.
Graph User Settings

From the Graph User Settings dialog box, you can change properties of Items Plotted, Axes, Layout, Labelling, and View.

**To open the Graph User Settings dialog box**
- Double click the gray plot frame.

If there is no visible plot frame,

1. Click to the right of the plot.
2. Move the mouse to the insert point. (The arrow changes to a hand.)
3. Click when you see a hand. (This will create a resizable frame.)
4. Double click the blue frame.

There is a keyboard shortcut to make the Graph User Settings dialog box open when a plot is created, so that you can customize settings before generating the plot.

**To open the Graph User Settings dialog box while creating a plot**
1. Place the insert point to the right of a mathematics expression or function name.
2. Press Ctrl while choosing the plot command.

This brings up the Graph User Settings dialog box with the tabbed pages Items Plotted, Axes, Layout, Labelling, and View.

**Items Plotted**

From the Items Plotted page of the Graph User Settings dialog box you can edit, add, and delete expressions to be plotted. This page shows the Dimensions (2 or 3), the Plot Type (Rectangular, Polar, Implicit, Inequality, Parametric, Conformal, Gradient, Vector Field, ODE, or Approximate Integral), and whether or not the plot is animated.
Editing a plot

To edit a plot

1. Open the Graph User Settings dialog box, choose the Items Plotted page, and select an Item Number.

2. Select the Line Style (Solid, Dash, or Dots), Point Marker (Squares, Circles, Crosses, Diamonds, Filled Squares, Filled Circles, Filled Diamonds, Stars, or X Crosses), Line Thickness (Thin, Medium, or Thick), and Color.

3. If the graph has a discontinuity and you want asymptotes to be plotted, uncheck Adjust Plot for Discontinuities.

Line Style

The line style can be solid, dash, or dots.

Points can be plotted by using Squares, Circles, Crosses, Diamonds, Filled Squares, Filled Circles, Filled Diamonds, Stars, or X Crosses. Here are examples of a few of these point markers:

To plot points

1. Open the Graph User Settings dialog box.

2. On the Items Plotted page under Plot Style, check Point.

3. Select the Point Marker.
Chapter 6 | Plotting Curves and Surfaces

**Compute > Plot 2D > Rectangular**

\[ x \sin(x) \]

Circle  
Cross  
Box  
Diamond

**Line Thickness**

The line thickness can be Thin, Medium, or Thick.

**To change the line thickness**

1. Open the Graph User Settings dialog box and choose the Items Plotted page.

2. Select the line thickness (Thin, Medium, or Thick) and choose OK.

**Continuity**

The options Not Specified, Adjust for Discontinuities, Show Asymptotes, and Don’t Adjust are available for discontinuous functions. Here are the two most common choices:
Graph User Settings

Compute > Plot 2D > Rectangular

\[ \frac{x}{1-x} \]

To change the method for plotting a discontinuous function
1. Open the Graph User Settings dialog box, select the item, choose the Items Plotted page.

2. Select one of Not Specified, Adjust Plot for Discontinuities, Show Asymptotes, and Don’t Adjust.

New Item

To add a new item to an existing graph
- Select an expression and drag it to the plot.

Or

1. Open the Graph User Settings dialog box, choose the Items Plotted page, and click New.

2. Type or paste a new expression in the window and choose OK.

To delete an item from an existing graph
1. Open the Graph User Settings dialog box and choose the Items Plotted page.

2. Select an item number, click Delete, and choose OK.

Axes

From the Axes page of the Graph User Settings dialog box you can change the Axes Scaling (Linear, Lin Log, Log Lin, or Log Log).
Chapter 6 | Plotting Curves and Surfaces

choose Equal Scaling Along Each Axis, change the labels for the coordinate axes, change the Axis Tick Marks (None, Low, Medium, or High), turn the axes tips on or off, turn the grid lines on or off, and change the Axes Type (Not Specified, Automatic, Normal, Boxed, Frame, or None).

Axes Scaling

To edit the axes scaling

1. Open Graph User Settings and choose the Axes page.

2. Select Linear (horizontal and vertical axes both linear scaling), Lin Log (horizontal axis linear and vertical axis logarithmic scaling), Log Lin (horizontal axis logarithmic and vertical axis linear scaling), or Log Log (horizontal and vertical axes both logarithmic scaling).

Compute > Plot 2D > Rectangular

A Lin Log plot is a two-dimensional plot with the vertical axis given in a log scale. Exponential functions $f(x) = cb^x$ plot as straight lines on a Log coordinate system.
A Log Log plot is a two-dimensional plot with both the vertical and horizontal axes given in a logarithmic scale.

**Note**
Power functions \( f(x) = ax^n \) plot as straight lines on a Log-Log coordinate system.

You can also make the scales equal along the horizontal and vertical axes.

**To make the scaling equal along the horizontal and vertical axes**

1. Open the Graph User Settings dialog box and choose the Axes page.

2. Turn on Equal Scaling Along Each Axis.
Chapter 6 | Plotting Curves and Surfaces

Axes Labels
The default labels for the axes are $x$ and $y$ for two-dimensional plots, or $x$, $y$, and $z$ for three-dimensional plots. You can edit the default labels.

To edit the labels for the axes
1. Open the Graph User Settings dialog box and choose the Axes page.
2. Type labels in the axis label boxes.

Axes Appearance
You can change the appearance of the tick marks and turn on or off the axes tips and grid lines.

To edit the number of tick marks shown on the axes
1. Open the Graph User Settings dialog box and choose the Axes page.
2. Edit the number of Axis Tick Marks by selecting None, Low, Normal, or High.

To turn axes tips on or off
1. Open the Graph User Settings dialog box and choose the Axes page.
2. Check or uncheck Axes tips on.

To turn grid lines on or off
1. Open the Graph User Settings dialog box and choose the Axes page.
2. Check or uncheck Grid lines on.

Tip
The number of grid lines is determined by the setting for tick marks (Low, Normal, or High).

Axes Type
You can change the axis type to be Not Specified, Automatic, Normal, Boxed, Frame, or None.

To edit the axis type
1. Open the Graph User Settings dialog box and choose the Axes page.
2. Select an Axes Type.
Graph User Settings

Compute > Plot 2D > Rectangular

\[ x \sin x \]

Plot Interval \(0.1 < x < 1.1\)

### Layout

Layout properties include the size of a graphic, its placement within your document, and the print and screen display attributes. The defaults for the layout can be changed on the Layout page of the Graph User Settings dialog box.

### Resizing the Frame

All plots have an attribute known as fit to frame. When you resize the frame, the plot is resized with it. You can resize the frame either with the mouse or with the Graph User Settings dialog box.

**To resize the frame with the mouse**

1. Click to the right of the plot.
2. Move the mouse to the insert point. (The arrow changes to a hand.)
3. Click when you see a hand. (This will create a resizable frame.)
4. Resize the frame by dragging one of the eight handles.

**Or**

1. If a gray frame is visible, click the frame.
2. Resize the frame by dragging one of the eight handles.

When the plot frame is selected, eight handles are visible and you can resize the frame by dragging one of the handles. The corner han-
Chapter 6 | Plotting Curves and Surfaces

Dashes leave the opposite vertex fixed while moving the two sides adjacent to the handle, creating a frame that has edges proportional to the original frame. The edge handles move only the corresponding edge in or out. Either type of change stretches or shrinks a plot in the view, along with the frame. Resizing the frame retains the same domain and view intervals. For example, use one of the side handles to create a tall and narrow frame or use one of the handles on the top or bottom to create a short and fat frame.

The examples in the previous paragraph illustrate the use of inline plots, one of the two placement options described in the next section.

To resize the frame with the Graph User Settings dialog box
1. Select the plot and open the Graph User Settings dialog box.
2. Click the Layout tab.
3. In the Size boxes for Width and Height, set the sizing options you want.
4. Select desired units (inches, centimeters, picas, or points).
5. Choose OK.

Screen Display Attributes
The model screen attributes can be turned on or off. When turned on, placement and display attributes will be automatically determined. When turned off, these attributes can be set manually for each plot.

Screen Display Layout
To change the screen display attributes of the frame and plot
1. Select the plot and open the Graph User Settings dialog box.
2. Click the Layout tab.

3. Select one of the Screen Display Layout attributes (Plot in Frame, Plot Only, Frame Only, or Iconified).

4. Choose OK.

**Compute > Plot 2D > Rectangular**

\[ x \sin x \]

*Plot in Frame*  
*Plot Only*  
*Frame Only*

**Placement**

With *Scientific Notebook*, there are two choices for frame placement—In Line and Displayed. With *Scientific WorkPlace* you can also choose Floating.

Open the Graph User Settings dialog box to see how a frame is placed in your document.

**To verify and/or change the placement**

1. Select the frame and open the Graph User Settings dialog box.

2. Choose the Layout tab and check your choice for Placement.

**In-Line Placement**

An inline frame behaves like a word in the text, in the sense that the frame is pushed along in the line when you enter additional items to the left of it.

**To change a plot or graphic to in line**

1. Select the frame and open the Graph User Settings dialog box.

2. Choose the Layout tab and change the Placement to In Line.

When the placement is In Line, you can move it up or down within the line.
To move an inline frame up or down with the mouse
1. Select the frame.
2. Drag the frame up or down.

You can drag the plot frame such that its lower edge is resting on the text baseline like ▼, is centered on the line like =, hangs with the upper edge at the text baseline like ▲, or rests anywhere in between.

Displayed Frames
When the placement is Displayed, the frame appears on the screen centered on a separate line like ▼

To change a plot or graphic to displayed
1. Select the frame and open the Graph User Settings dialog box.
2. Choose the Layout tab and change the Placement to Displayed.

Floating Frames
Floating placement is a typesetting option, available in Scientific WorkPlace or Scientific Word only. Floating frames containing plots aren’t anchored to a precise location in your document. Instead, they are positioned when you typeset the document, according to the options you choose for placement: Here, On a Page of Floats, Top of Page, or Bottom of Page. Floating frames can carry numbers, captions, and keys. The number is created automatically by \LaTeX{} unless you suppress it. If you don’t typeset, in the File > Preview screen or on paper, floating frames behave like displayed frames.

Displayed frame placement versus mathematics Display
Choose Displayed to center a plot. To minimize vertical white space above and/or below the plot, use the backspace or delete key to remove any new paragraph symbols ¶ that occur immediately before/after the plot. (To see these symbols, choose View and select Invisibles.)

The use of the mathematics display, which treats the frame like mathematics, can lead to unpredictable results when you preview or print your document. If the frame appears red on your screen, you can change the frame to text mode by selecting it with the mouse and clicking the Math/Text button.
To change a plot or graphic to floating

1. Open the Graph User Settings dialog box.

2. Choose the Layout tab and change the Placement to Floating.

2D Plots of Functions and Expressions

In the equation $f(x) = x \sin x$, each of the two sides—$f(x)$ and $x \sin x$—is an expression while $f$ is a function. The function $f$ is a rule that assigns to each number the product of that number and the sine of that number. Thus the function $f$ defined by the equation $f(x) = x \sin x$ is the same function as the function $g$ defined by the equation $g(t) = t \sin t$. The expression $x \sin x$ (or $f(x)$ or $g(x)$) is different from the expression $t \sin t$ (or $f(t)$ or $g(t)$), since $x \sin x$ is tied to the variable $x$, and $t \sin t$ is tied to the variable $t$.

Expressions

To plot an expression involving a single variable

- Type the expression and choose Compute > Plot 2D > Rectangular.

Add the caption $y = x \sin \frac{5}{x}$ by typing it into the Graph User Settings > Labelling dialog box in the Caption entry field. (See page 140.)
Chapter 6 | Plotting Curves and Surfaces

To add an expression to a plot

- Select the expression with the mouse and drag it onto the plot.

Or

1. Open the Graph User Settings dialog box and click New.
2. Type or paste the expression in the Plot Expression box.

Functions of Degrees

You can plot trigonometric functions written as functions of degrees rather than radians.

To plot trigonometric functions of degrees

1. Type the expression(s) in your document window, using either the red degree symbol in a superscript or the green degree symbol from the Insert > Math Objects > Unit Names dialog box.
2. With the insert point in an expression, choose Compute > Plot 2D > Rectangular.
3. With the plot selected, open the Graph User Settings dialog box.
4. Click the Items Plotted tab and choose Variables and Intervals.
5. Change Plot Intervals to $-180 < x < 180$ (or other limits as appropriate).
6. Choose OK.

Select and drag additional expressions onto the plot, as desired.
2D Plots of Functions and Expressions

**Compute > Plot 2D > Rectangular**

\[ \sin x^\circ, \cos 2x^\circ \]  
(Select and drag to the frame.)

\[ y = \sin x^\circ, y = \cos 2x^\circ \]

**Note**
To get this view, change the Plot Interval to 
\(-180 < x < 180\).

**Compute > Plot 2D > Rectangular**

\[ \sin 2x^\circ + \cos 3x^\circ \]
(Change Plot Intervals to 
\(-360 < x < 360\))

**Defined Functions**

You can plot a defined function.

**To plot a defined function** \( f \) of one variable

1. Select the function name \( f \) or select the expression \( f(x) \).
2. Choose Compute > Plot 2D < Rectangular.

**Compute > Definitions > New Definition**

\[ g(x) = \tan \sin (x^2) \]

**Recall**
You can define a function such as \( f(x) = x \sin x \) by placing the insert point in the expression and choosing Compute > Definitions > New Definition.
Chapter 6 | Plotting Curves and Surfaces

Continuous and Discontinuous Plots

The appearance of the plot of a discontinuous function depends on the setting for Adjust for Discontinuities.

To change the appearance of a discontinuous function

- From the Plot User Settings dialog box, select Not Specified, Adjust for Discontinuities, Show Asymptotes, or Don’t adjust.
This setting applies to individual items so it is possible to plot together two functions that require opposite settings.

There may be expressions that do not plot with the setting Adjust for discontinuities, but that will plot with the setting Show Asymptotes. If you know before creating a plot that you wish to change this setting (Not specified is the default), hold down the Ctrl key while applying the plot command. The Graph User Settings dialog box will open for you to edit before the system generates the plot.

For more examples of continuous and discontinuous piecewise-defined functions, see the following sections.

**Plotting Piecewise-Defined Functions**

A piecewise-defined function must be entered in a two- or three-column matrix enclosed in expanding brackets—a left brace and right null bracket (see Piecewise-Defined Functions, page 108 for details).

**To plot a piecewise-defined function**

1. Place the insert point in a matrix of a piecewise-defined function.

2. Choose Compute > Plot 2D > Rectangular

![Graph of piecewise-defined function](image)

You can also plot a continuous graph from a discontinuous expression $g(x)$ (or directly from the defining matrix) by checking Show Asymptotes, as described on page 154.
Chapter 6 | Plotting Curves and Surfaces

Compute > Plot 2D > Rectangular

\[
\begin{align*}
\begin{cases}
  x^2 - 1 & \text{if } x < -1 \\
  20 - x^2 & \text{if } -1 \leq x \leq 1 \\
  x^2 - 1 & \text{if } 1 < x 
\end{cases}
\]

Adjust for Discontinuities

Show Asymptotes

Compute > Plot 2D > Rectangular

\[
\begin{align*}
\begin{cases}
  t & \text{if } t < 0 \\
  0 & \text{if } 0 \leq t < 1 \\
  1 & \text{if } 1 \leq t < 2 \\
  2 & \text{if } 2 \leq t < 3 \\
  6 - t & \text{if } 3 \leq t 
\end{cases}
\]

Adjust for Discontinuities

Vertical Asymptotes

Special Functions

Greatest integer function and floor function

The function \( \lfloor x \rfloor \) is the greatest integer function, or floor function.

To use the greatest integer function (floor function)

1. Choose Insert > Math Objects > Brackets.
2D Plots of Functions and Expressions

2. Select the left floor bracket \[ and choose OK.

Absolute value function

To use the absolute value function
- Choose Insert > Math Objects > Brackets and select the vertical brackets.

The following shows the graph of \( f(x) = |\sin x| \).

Gamma function

The Gamma function \( \Gamma(x) \) extends the factorial function in the sense that for each nonnegative integer \( n \), \( \Gamma(n+1) = n! \).

To use the Gamma function
1. Click the Uppercase Greek button on the Symbols toolbar.
2. Select \( \Gamma \) from the Greek panel that opens.

The plot of the Gamma function displays the vertical asymptotes along with the graph if Vertical Asymptotes is checked, and displays only the graph when Adjust for Discontinuities is checked as in the following example.

Note
You can get a continuous plot of this function by checking Vertical Asymptotes.

Tip
You can also use the keyboard shortcut Ctrl+\ to insert expanding absolute values.

Tip
You can also use the keyboard shortcut Ctrl+g,G for the Greek letter \( \Gamma \).
Chapter 6 | Plotting Curves and Surfaces

Heaviside function

The Heaviside function \( \text{Heaviside}(x) = \begin{cases} 
0 & \text{if } x < 0 \\
\frac{1}{2} & \text{if } x = 0 \\
1 & \text{if } x > 0 
\end{cases} \) provides an alternative method for creating piecewise-defined functions. Note that

\[
\text{Heaviside}(x - 2) \sin(x) + \text{Heaviside}(-x) \cos x = \begin{cases} 
\sin x & \text{if } x \geq 2 \\
0 & \text{if } 0 \leq x \leq 2 \\
\cos x & \text{if } x \leq 0 
\end{cases}
\]
Polygons and Point Plots

You can plot the points \{(x_1, y_1), (x_2, y_2), (x_3, y_3), \ldots, (x_n, y_n)\}, or a polygon whose vertices lie at these points, by typing the vector \((x_1, y_1, x_2, y_2, x_3, y_3, \ldots, x_n, y_n)\) or by entering the matrix

\[
\begin{bmatrix}
  x_1 & y_1 \\
  x_2 & y_2 \\
  x_3 & y_3 \\
  \vdots & \vdots \\
  x_n & y_n 
\end{bmatrix}
\]

To plot a polygon connecting points

1. Create a list of \(n\) pairs of points or an \(n \times 2\) matrix containing the points.
2. Place the insert point in the list or matrix and choose Compute > Plot 2D > Rectangular.

**Note**
The beginning point \((1, 1)\) is also the last point.
Chapter 6 | Plotting Curves and Surfaces

To plot points
1. Create a list of \( n \) pairs of points or an \( n \times 2 \) matrix containing the points.
2. Place the insert point in the list or matrix and choose Compute > Plot 2D > Rectangular.
3. Double click the frame to open the Graph User Settings dialog box.
4. On the Items Plotted page, change Plot Style to Point, Point Marker to Circle, and choose OK.

\[
\begin{bmatrix}
1 & 1 \\
2 & 1 \\
2 & 2 \\
1 & 2 \\
\end{bmatrix}
\text{, View Intervals: } 0 < x < 3, 0 < y < 3
\]

To generate a regular pentagon with an enclosed five-point star
1. Place the insert point in the vector
\[
\left(0, 1, \sin \frac{2\pi}{5}, \cos \frac{2\pi}{5}, \sin \frac{4\pi}{5}, \cos \frac{4\pi}{5}, \sin \frac{6\pi}{5}, \cos \frac{6\pi}{5}, \sin \frac{8\pi}{5}, \cos \frac{8\pi}{5}, 0, 1\right)
\]
and choose Compute > Plot 2D > Rectangular.
2. Select the vector
\[
\left(0, 1, \sin \frac{4\pi}{5}, \cos \frac{4\pi}{5}, \sin \frac{8\pi}{5}, \cos \frac{8\pi}{5}, \sin \frac{2\pi}{5}, \cos \frac{2\pi}{5}, \sin \frac{6\pi}{5}, \cos \frac{6\pi}{5}, 0, 1\right)
\]
with the mouse and drag it to the frame.
3. Graph User Settings > Axes, under Axes Scaling select Equal Scaling Along Each Axis and under Axes Type select None.

4. Choose OK.

Compute > Plot 2D > Rectangular

\[ (0, 1, \sin \frac{2\pi}{5}, \cos \frac{2\pi}{5}, \sin \frac{4\pi}{5}, \cos \frac{4\pi}{5}, \sin \frac{6\pi}{5}, \cos \frac{6\pi}{5}, \sin \frac{8\pi}{5}, \cos \frac{8\pi}{5}, 0, 1) \]

\[ (0, 1, \sin \frac{4\pi}{5}, \cos \frac{4\pi}{5}, \sin \frac{8\pi}{5}, \cos \frac{8\pi}{5}, \sin \frac{2\pi}{5}, \cos \frac{2\pi}{5}, \sin \frac{6\pi}{5}, \cos \frac{6\pi}{5}, 0, 1) \]

You may find it convenient to combine Line and Point styles, as in the following plot that combines a data cloud with a line of best fit. (See page 436 in Chapter 11 “Statistics” for information on curves of best fit.) That technique was used to obtain the expression \( \frac{2792}{647} + \frac{957}{647}x \) used in the next example.

Compute > Plot 2D > Rectangular

\[
\begin{bmatrix}
1 & 3 & 4 & 6 & 7 & 7 & 10 & 11 \\
8 & 7 & 9 & 12 & 15 & 19 & 21
\end{bmatrix}^T
\]

\( \frac{2792}{647} + \frac{957}{647}x \) (Select and drag to the frame.)

Graph User Settings, Item 1
Plot Style: Points
Point Marker: Squares
Chapter 6 | Plotting Curves and Surfaces

You can create line graphs and bar charts with polygonal plots, as demonstrated in the following two examples. The first example is a line graph depicting the data

<table>
<thead>
<tr>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.11</td>
<td>0.24</td>
<td>0.28</td>
<td>0.21</td>
<td>0.1</td>
<td>0.031</td>
</tr>
</tbody>
</table>

**Compute > Plot 2D > Rectangular**

(1, 0, 1, 0.11)

Enter, select, and drag to the frame each of the following.

(2, 0, 2, 0.24), (3, 0, 3, 0.28), (4, 0, 4, 0.21), (5, 0, 5, 0.1), (6, 0, 6, 0.031)

Following is a bar chart, or histogram, depicting the data

<table>
<thead>
<tr>
<th>1-2</th>
<th>2-3</th>
<th>3-4</th>
<th>4-5</th>
<th>5-6</th>
<th>6-7</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.11</td>
<td>0.24</td>
<td>0.28</td>
<td>0.21</td>
<td>0.1</td>
<td>0.031</td>
</tr>
</tbody>
</table>

**Compute > Plot 2D > Rectangular**

(1, 0, 1, 0.11, 2, 0.11)

Enter, select, and drag to the frame each of the following.

(2, 0, 2, 0.24, 3, 0.24), (3, 0, 3, 0.28, 4, 0.28, 4, 0) (4, 0.21, 5, 0.21, 5, 0) (5, 0.1, 6, 0.1, 6, 0) (6, 0.031, 7, 0.031, 7, 0)
Plotting a Grid

To create a grid:
- Create a 2D plot
- Open the Graph User Settings dialog box, Axes page, and turn grid lines on.

Grid lines
The number of grid lines is determined by the Tick Marks setting (None, Low, Medium, or High) on the Axes page.

Envelopes
An interesting phenomenon occurs when simple curves are displayed as the “envelope” of a more complicated function. Such things happen in practice when low-frequency waves (say, frequencies in the audible range for the human ear) ride carrier waves broadcast from a radio station.

To create a plot with an envelope:
1. Type an expression $R(x)$ for the envelope.
2. With the insert point in the expression, choose Compute > Plot 2D > Rectangular.
3. Select and drag the product $R(x)c(x)$ of the envelope and the carrier wave to the plot.
Chapter 6 | Plotting Curves and Surfaces

The following example shows the curve \( y = 4 \sin x + 3 \cos 3x \) “riding” on top of the carrier \( y = \sin 30x \). To get an accurate plot, increase the point sampled—from the Items Plotted page of the Plot Properties dialog box, raise Item Number to 2, choose Variables and Intervals, and raise the number of Points Sampled to 150 or higher.

Compute > Plot 2D > Rectangular

\( 4 \sin x + 3 \cos 3x \)

Select and drag to the frame \((4 \sin x + 3 \cos 3x) \sin 30x\)

Parametric Polar Plots

You can make a parametric polar plot using an expression of the form \((r(t), \theta(t))\) where \(r(t)\) is a function for the radius and \(\theta(t)\) is a function for the angle. You can use any of the forms \((r(t), \theta(t))\), \([r(t), \theta(t)]\), \((r(t) \ \theta(t))\), or \(\begin{bmatrix} r(t) \\ \theta(t) \end{bmatrix}\), where the last two expressions are \(1 \times 2\) and \(2 \times 1\) matrices, respectively.

To make a parametric polar plot
- Place the insert point in a pair of expressions in one variable and choose Compute > Plot 2D > Polar.

The polar plot of \(\theta = r^2\) is the 2D polar plot of the vector \((r, r^2)\).

Compute > Plot 2D > Polar

\((r, r^2)\)
Both the radius \( r \) and the angle \( \theta \) may be defined in terms of some third variable \( t \). You can make the polar plot of the parametric curve defined by the equations \( r = 1 - \sin t, \ \theta = \cos t \) as the polar plot of the vector \((1 - \sin t, \cos t)\). Revise the first plot, choosing Polar and setting the Plot Intervals to \( 0 \leq t \leq 2\pi \).

Creating Animated 2D Plots

For an animated 2D plot, you specify a second variable. One of the two variables will be designated as the Animation Variable. The standard variable names are \( x \) for the horizontal axis and \( t \) for the Animation Variable. The default intervals for \( x \) and \( t \) are \(-6 < x < 6 \) and \(-6 < t < 6 \). To change these settings, see page 166.

When the frame of an animated plot is selected, several plotting tools become visible just below other toolbars at the top of the screen. The tool on the left is Reset Viewpoint. Next is the Selection Tool, then the Zooming Tool, the Moving Tool, and the Query Tool. The remaining tools are designed to control the animation. These include jumps to the beginning or the end, begin animation, a slider for manually moving through the animation sequence, and loop controls (Run once, Back and forth, Loop), and speed controls (8× slower to 8× faster).

To display the animation tools
- Click to the right of the animated plot, move the mouse to the insert point, and click when you see a hand. (This creates a resizeable frame and brings the animation tools into view.)
Chapter 6 | Plotting Curves and Surfaces

To create a 2D animation

- Type an expression in \( x \) and \( t \), and choose Compute > Plot 2D Animated > Rectangular.

**Compute > Plot 2D Animated > Rectangular**

\[ xt \]

The following animated plot shows the graph of \( y = \sin 2x \) smoothly transform itself into the graph of \( y = \cos 3x \).

**To edit the animation**

1. Click the plot.frame to bring up the animation toolbar.

2. Reset Viewpoint, Animation Style, or Animation Speed.
Creating Animated 2D Plots

To make a parameterized animated plot in rectangular coordinates

1. Type an expression of the form \((x(s,t), y(s,t))\).

2. Choose Compute > Plot 2D Animated > Parametric, or
   Choose Compute > Plot 2D Animated > Rectangular.

To animate the following Lissajous figure, select the frame and open the Graph User Settings dialog box. Choose the Items Plotted page, Variables and Intervals, and set \(0 \leq x \leq 1\) and \(0 \leq t \leq 1\). On the Axes page turn on Equal Scaling Along Each Axis.

The first formula draws the small circle at the leading edge of the figure. The second formula shows a static figure in light gray. The third formula shows the animated curve.

\[
\text{Compute} > \text{Plot 2D Animated} > \text{Parametric}
\]

\[
\begin{align*}
& (\sin 8\pi t + 0.02 \cos 2\pi x, \cos 10\pi t + 0.02 \sin 2\pi x) \\
& (\sin 8\pi x, \cos 10\pi x) \\
& (\sin 8\pi xt, \cos 10\pi xt)
\end{align*}
\]

A circle of radius 1 with an arm of length 2 rolls around a second circle of radius 1, leaving behind a smoke trail. The resulting curve is called a Limaçon.
Animated Plots In Polar Coordinates

In polar coordinates, you specify a point $P$ by giving the angle $\theta$ that the ray from the origin to the point $P$ makes with the polar axis and the distance $r$ from the origin.

For an animated plot in polar coordinates you also need an animation variable such as $t$.

To make an animated plot in polar coordinates

1. Type an expression in two variables.

2. Choose Compute > Plot 2D Animated > Polar.

The following animation shows the effect of the parameter $t$ on the polar equation $r = \sin \theta t$ as a three-leaved rose changes into an eight-leaved rose and finally into a five-leaved rose.

For this animation, open the Graph User Settings dialog box. Click the Items Plotted tab, choose Variables and Intervals, and set $-3.14159 \leq \theta \leq 3.14159$ and $3 \leq t \leq 5$. On the View page, select Equal Scaling Along Each Axis.
Creating Animated 2D Plots

To make a parameterized animated plot in polar coordinates

- Type an expression of the form \((r(s,t), \theta(s,t))\), and choose Compute > Plot 2D Animated > Polar.

The following animation shows the effect of the parameter \(t\) in the polar equation \(r = 1 - t \cos \theta\) as \(t\) varies from \(-2\) to \(2\).

For the following animation, select the frame and open the Graph User Settings dialog box. Click the Items Plotted tab, choose Variables and Intervals, and set \(-3.14159 \leq \theta \leq 3.14159\) and \(-2 \leq t \leq 2\). On the View page, select Equal Scaling Along Each Axis.

Note

The limaçon, also called the limaçon of Pascal, is a polar curve of the form \(r = b + a \cos \theta\).
Chapter 6 | Plotting Curves and Surfaces

Animated Implicit Plots

To make an animated implicit plot

1. Type an equation in three variables.

2. With the insert point in the expression, choose Compute > Plot 2D Animated > Implicit.

The following animation shows the effect of the parameter $t$ on the rectangular equation $x^2 + ty^2 = 1$ as $t$ varies from $-1$ (which yields a hyperbola) to $+1$ (which yields the unit circle). For this animation, select the frame and open the Graph User Settings dialog box. On the Items Plotted page, choose Variables and Intervals, and set $-2 \leq x \leq 2$, $-2 \leq y \leq 2$, and $-1 \leq t \leq 1$. Click the View tab and select Equal Scaling Along Each Axis. (You may notice a substantial delay as an animated implicit plot is generated.)

Animated Inequality Plots

To plot an animated inequality

1. Enter an expression of the form $g(x,y,t) < h(x,y,t)$.

2. With the insert point in the expression, choose Compute > Plot 2D Animated > Inequality.

In the following, $-1 < x < 1$, $-1 < y < 1$, and $0 < t < 1$. 
Creating 3D Plots

The environment for plotting curves and surfaces in space is similar to the environment for plotting in the plane. The view is a box, a rectangular solid determined by inequalities of the form $x_0 \leq x \leq x_1$, $y_0 \leq y \leq y_1$, and $z_0 \leq z \leq z_1$. The frame is a rectangular region of the computer screen.

The default view has the Plot Intervals $-6 \leq x \leq 6$, $-6 \leq y \leq 6$, with the $z$-coordinates determined automatically from properties of the plot. If you use other variable names, the order is determined alphabetically.

To plot an expression involving two variables

- Place the insert point in the expression and choose Compute > Plot 3D > Rectangular.

The following plot shows the surface $z = x^3 - 3xy^2$ with the default Plot Intervals for $x$ and $y$, and the default View Intervals for $x$, $y$, and $z$.

To make this plot, leave the insert point in the expression $x^3 - 3xy^2$ and choose Compute > Plot 3D > Rectangular.
Chapter 6 | Plotting Curves and Surfaces

**Compute > Plot 3D > Rectangular**

\[ x^3 - 3xy^2 \]

To add expressions involving two variables to an existing 3D plot

- Select the expression and drag the expression onto the plot.

Or

1. Open the Graph User Settings dialog box.

2. Choose New and type or paste the expression in the Plot expression input box.

**Interactive Tools for 3D Plots**

Plots can be explored by using the Plot 3D toolbar.
Creating 3D Plots

To activate the 3D Interactive Toolbar
1. Click to the right of a 3D plot.
2. Move the mouse to the Insert Point and click the hand that appears.

Description of tools from left to right

To reset the viewpoint
- Click the Reset Viewpoint tool.

To fit the plot to the frame
- Click the Fit Contents tool.

To select a plot and copy as graphic
- Click the Selection tool and choose Edit > Copy.

To rotate the plot horizontally
- Click the Rotation tool and then click and drag across the plot.

To zoom in [out]
- Click the Zooming tool and then click and drag towards the bottom [top] of the window.

To move the plot
- Click the Moving tool and then click and drag in the direction you want the plot to move.

To view plot coordinates
- Click the Query tool and then hover over a point on the plot.

To start or stop a slow or fast rotation
- Click one of the four Rotate tools. (A second click will stop that rotation.)

To start or stop a slow or fast zoom
- Click the Zoom In tool or the Zoom Out tool. (The plus sign to zoom in and the minus sign to zoom out. A second click will stop that motion.)
Chapter 6 | Plotting Curves and Surfaces

To control the speed of rotation and zoom

- Click the Action Speed tool and set the desired speed.

When the mouse pointer is over a 3D plot it turns into a double arrow. Press the left button and move the mouse to rotate the plot. Release the left button. The plot remains in its new position.

To change the orientation of a 3D Plot

1. Place the insert point over the plot and press and hold down the left mouse button.

2. Drag to the desired orientation and release the mouse button.

Defined Functions

You can plot a defined function of two variables in two different ways.

To plot a defined function \( f \) of two variables

1. Select the function name \( f \) or select the expression \( f(x, y) \).

2. Choose Compute > Plot 3D > Rectangular.

To add a defined function \( g \) of two variables to a 3D plot

1. Select the function name \( g \) or select the expression \( g(x, y) \).

2. Drag your selection onto the plot.

For the example that follows, define \( f(x, y) = x^2 + y^2 \) and \( g(x, y) = -5 \). This example shows 3D rectangular plots of both \( f(x, y) \) and \( g(x, y) \), with Plot Intervals \( -6 \leq x \leq 6 \) and \( -6 \leq y \leq 6 \), and View Intervals \( -6 \leq x \leq 6 \), \( -6 \leq y \leq 6 \), and \( -5 \leq z \leq 40 \).
Creating 3D Plots

Parametric Plots

Parameterized surfaces in rectangular coordinates are defined by three functions \( x = f(s,t), \) \( y = g(s,t), \) and \( z = h(s,t) \) of a two variables. These three functions can be presented as a row vector: 
\[
\begin{bmatrix}
  f(s,t) \\
g(s,t) \\
h(s,t)
\end{bmatrix}
\]
or as a column vector: 
\[
\begin{bmatrix}
f(s,t) \\
g(s,t) \\
h(s,t)
\end{bmatrix}
\]
or as a fenced list: 
\[
(f(s,t), g(s,t), h(s,t))\]
These are very general and allow you to generate a wide variety of interesting plots.

To plot a parameterized surface

1. Type expressions in a vector, making each expression a separate component.

2. Place the insert point in the vector and choose Compute > Plot 3D > Rectangular.

In the following plot, \( 0 \leq s \leq 2\pi \) and \( 0 \leq t \leq \pi. \)
Ellipsoid

The parameterized surface \((a \cos \theta \cos \phi, b \sin \theta \cos \phi, c \sin \phi)\) is an ellipsoid that fits in a box of dimensions \(2a \times 2b \times 2c\).

Hyperboloid of two sheets

In the following example, \(0 \leq s \leq 1.2\) and \(-3.1416 \leq t \leq 3.1416\).
Creating 3D Plots

**Compute > Plot 3D > Parametric**

\[
\begin{bmatrix}
2 \tan s \sin t, 3 \tan s \cos t, \sec s \\
2 \tan s \sin t, 3 \tan s \cos t, -\sec s
\end{bmatrix}
\]

Hyperboloid of one sheet

In this example, \(-1 \leq s \leq 1\) and \(3.1416 \leq t \leq 3.1416\).

**Compute > Plot 3D > Rectangular**

\[
\begin{bmatrix}
2 \sec s \sin t, 3 \sec s \cos t, \tan s
\end{bmatrix}
\]

Implicit Plots

You can plot an equation involving three variables by choosing Compute > Plot 3D > Implicit. You will find the Switch Variables option in the Plot Components tabbed dialog useful when the variables are not interpreted as you intended.

**To obtain an implicit plot of an equation involving three variables**

1. Type the equation in three variables.

2. Choose Compute > Plot 3D > Implicit.
Chapter 6 | Plotting Curves and Surfaces

The next example shows a 3D implicit plot of \( x^2 + y^2 + z^2 + 1 = (x + y + z + 1)^2 \) with Boxed axes, View Intervals \(-6 \leq x \leq 6, -6 \leq y \leq 6, \) and \(-6 \leq z \leq 6\).

Curves in Space

A space curve is defined by three functions \( x = f(t), y = g(t), \) \( z = h(t) \) of a single variable. These three functions can be presented as a row vector: \( [f(t) \ g(t) \ h(t)] \) or \( (f(t) \ g(t) \ h(t)) \); a column vector: \( \begin{bmatrix} f(t) \\ g(t) \\ h(t) \end{bmatrix} \) or \( \begin{pmatrix} f(t) \\ g(t) \\ h(t) \end{pmatrix} \); or as a fenced list: \( (f(t), g(t), h(t)) \)

or \( [f(t), g(t), h(t)] \).

To plot a space curve as a rectangular plot

1. Type the three defining expressions as the components of a three-element vector.

2. Choose Compute > Plot 3D > Curve in Space, or

Choose Compute > Plot 3D > Rectangular.

In the following example, \(-6 \leq t \leq 6\).
Creating 3D Plots

For the following, $-3.1416 \leq t \leq 3.1416$.

**Compute > Plot 3D > Rectangular**

$$\begin{bmatrix} t & 2 \sin t & t^2 \end{bmatrix}$$

```
\begin{bmatrix}
10 \cos t - 2 \cos(5t) + 15 \sin(2t) \\
-15 \cos(2t) + 10 \sin t - 2 \sin(5t) \\
10 \cos(3t)
\end{bmatrix}
```

**Tube Plots**

You can create a “fat curve” by choosing Compute > Plot 3D > Tube by specifying a radius for the curve in the Plot Properties dialog box. This radius can be constant or can be a function of $t$. The Sample Size is the number of computed points along the curve; the Number of Tube Points is the number of computed points in a cross section of the tube. Ranges refers to the range of computed values for the parameter $t$. The View Intervals include intervals for $x$, $y$, and $z$ of the
Chapter 6 | Plotting Curves and Surfaces

form \(x_0 \leq x \leq x_1, y_0 \leq y \leq y_1, z_0 \leq z \leq z_1\).

**To plot a space curve as a tube plot**

1. Type the three defining expressions as a three-element vector.

2. Choose Compute > Plot 3D > Tube.

3. To change the radius, open the Plot Properties dialog and change the setting on the Items Plotted page.

The “fat curve” is designed to show which parts of the curve are close to the observer and which are far away. Otherwise, a curve in space is difficult to visualize. In the following example, Radius is set to 1, the Plot Interval is set to \(0 \leq t \leq 6.28 \approx 2\pi\) and Surface Style is set to Hidden Line. To draw the “thin curve” as a tube plot, set the radius to 0 in the Radius box.

\[
\begin{bmatrix}
-10 \cos t - 2 \cos(5t) + 15 \sin(2t) \\
-15 \cos(2t) + 10 \sin t - 2 \sin(5t) \\
10 \cos(3t)
\end{bmatrix}
\]

Surfaces of Revolution

By typing an expression in \(t\) for the radius and choosing the curve to be a straight line, you can get surfaces of revolution. In the following example, the radius is set to \(1 - \sin t\), the range for \(t\) is \(-2\pi \leq t \leq 2\pi\).
Creating 3D Plots

To plot the polygon whose vertices lie at the points

\[ \{ (x_1, y_1, z_1), (x_2, y_2, z_2), (x_3, y_3, z_3), \ldots, (x_n, y_n, z_n) \} \]

enter the three-column matrix

\[
\begin{bmatrix}
  x_1 & y_1 & z_1 \\
  x_2 & y_2 & z_2 \\
  x_3 & y_3 & z_3 \\
  \vdots & \vdots & \vdots \\
  x_n & y_n & z_n \\
\end{bmatrix}
\]

or in a fenced list

\[(x_1, y_1, z_1, x_2, y_2, z_2, x_3, y_3, z_3, \ldots, x_n, y_n, z_n)\]

and choose Compute > Plot 3D > Rectangular. The points are connected with straight-line segments in the order that they are listed, as in the following box.
Chapter 6 | Plotting Curves and Surfaces

Compute > Plot 3D > Rectangular

\[
\begin{pmatrix}
0 & 0 & 1 & 1 & 0 \\
0 & 1 & 1 & 0 & 0 \\
0 & 0 & 0 & 0 & 0
\end{pmatrix}^T
\]

Select and drag to the frame each of the following:

\[
\begin{pmatrix}
0 & 0 & 1 & 1 & 0 \\
0 & 1 & 1 & 0 & 0 \\
1 & 1 & 1 & 1 & 1
\end{pmatrix}^T, \quad \begin{pmatrix}
1 & 1 & 0 & 0 \\
1 & 1 & 1 & 1 \\
0 & 1 & 1 & 0
\end{pmatrix}^T, \quad \begin{pmatrix}
1 & 1 & 0 & 0 \\
0 & 0 & 0 & 0 \\
0 & 1 & 1 & 0
\end{pmatrix}^T
\]

Select and drag to the frame:

Rotate the box.

Here are two stars, one of which floats above the other.
Creating 3D Plots

**Compute > Plot 3D > Rectangular**

\[
\begin{bmatrix}
1 & \cos \frac{4\pi}{5} & \cos \frac{8\pi}{5} & \cos \frac{12\pi}{5} & \cos \frac{16\pi}{5} & 1 \\
0 & \sin \frac{4\pi}{5} & \sin \frac{8\pi}{5} & \sin \frac{12\pi}{5} & \sin \frac{16\pi}{5} & 0 \\
1 & 1 & 1 & 1 & 1 & 1
\end{bmatrix}
\]

Select and drag to the frame:

\[
\begin{bmatrix}
1 & \cos \frac{4\pi}{5} & \cos \frac{8\pi}{5} & \cos \frac{12\pi}{5} & \cos \frac{16\pi}{5} & 1 \\
0 & \sin \frac{4\pi}{5} & \sin \frac{8\pi}{5} & \sin \frac{12\pi}{5} & \sin \frac{16\pi}{5} & 0 \\
0 & 0 & 0 & 0 & 0 & 0
\end{bmatrix}
\]

You can plot polygonal paths by adjusting the Points Sampled in a rectangular plot. For Items 1 and 2 below, set Plot Intervals to $0 \leq t \leq 1$, and Points Sampled to 6.

**Compute > Plot 3D > Rectangular**

$(\cos 4\pi t, \sin 4\pi t, 0)$

Select and drag to the frame: $(\cos 4\pi t, \sin 4\pi t, 1)$

**Cylindrical Coordinates**

In the cylindrical coordinate system, a point $P$ is represented by a triple $(r, \theta, z)$, where $(r, \theta)$ represents a point in polar coordinates.
and $z$ is the usual rectangular third coordinate. Thus, to convert from cylindrical to rectangular coordinates, we use the equations

$$x = r \cos \theta \quad y = r \sin \theta \quad z = z$$

To go from rectangular to cylindrical coordinates, we use the equations

$$r^2 = x^2 + y^2 \quad \tan \theta = \frac{y}{x} \quad z = z$$

The default assumption is that $r$ is a function of $\theta$ and $z$. As usual, you can plot several surfaces on the same axes by dragging expressions onto a plot.

**Expressions**

**To make a cylindrical plot of an expression**

1. Type the expression in two variables.

2. With the insert point in the expression, choose Compute $>$ Plot 3D $>$ Cylindrical.

The following example shows a plot of the cylinder $r = 1$ and a cone $r = 1 - z$, obtained as the 3D cylindrical plot of the expressions $1$ and $1 - z$, with $0 \leq \theta \leq 2\pi$, and $0 \leq z \leq 1$.

**Parameterized Surfaces in Cylindrical Coordinates**

You can create a cylindrical plot of the parameterized surface $r = f(s,t)$, $\theta = g(s,t)$, $z = h(s,t)$ by entering the expressions for $r$, $\theta$, and $z$ into a vector $(f(s,t), g(s,t), h(s,t))$ or list $(f(s,t), g(s,t), h(s,t))$ and choosing Compute $>$ Plot 3D $>$ Cylindrical.
Creating 3D Plots

To create a parameterized cylindrical plot

1. Type the three defining expressions for $r$, $\theta$, and $z$ as the components of a row vector \( \begin{bmatrix} f(s,t) & g(s,t) & h(s,t) \end{bmatrix} \) or a column vector \( \begin{bmatrix} f(s,t) \\ g(s,t) \\ h(s,t) \end{bmatrix} \) or as a list \( (f(s,t), g(s,t), h(s,t)) \).

2. With the insert point in the vector, choose Compute > Plot 3D > Cylindrical.

The following example shows the “spiral staircase” $z = \theta$, a 3D cylindrical plot of the vector $[r, \theta, \theta]$, with $0 \leq r \leq 1$, $0 \leq \theta \leq 4\pi$, and Surface Style set to Color Patch.

Spherical Coordinates

The spherical coordinates $(\rho, \theta, \phi)$ locate a point $P$ in space by giving the distance $\rho$ from the origin, the angle $\theta$ projected onto the $xy$-plane (the polar angle), and the angle $\phi$ with the positive $z$-axis (the vertical angle). The conversion into rectangular coordinates is given by

\[
x = \rho \sin \phi \cos \theta \\
y = \rho \sin \phi \sin \theta \\
z = \rho \cos \phi
\]

and the distance formula implies

\[
\rho^2 = x^2 + y^2 + z^2
\]
Chapter 6 | Plotting Curves and Surfaces

The default assumption is that \( \rho \) is a function of \( \phi \) and \( \theta \). You can use other names for the polar and vertical angles. Any two variables you give will be interpreted as the polar and vertical angles. Even when you use the standard notation, however, the roles of the variables may be reversed in the default interpretation from what you intended. You can correct this interpretation with the Switch Variables option in the Plot Properties dialog box.

You can plot more than one surface on the same axes by dragging additional expressions to the plot or by adding additional items on the Items Plotted page of the Plot Properties dialog.

**Expressions**

To make a spherical plot

1. Type an expression involving \( \theta \) and \( \phi \).

1. Choose Compute > Plot 3D > Spherical.

A sphere and a cylinder can each be plotted as a function of the radius. Following is a sphere of radius 2. Set \( 0 \leq \theta \leq 2\pi \) and \( 0 \leq \phi \leq \pi \), check Equal Scaling on Each Axis, and choose Color Patch for Surface Style.

Changing the setting for Points Plotted of \( \theta \) to 4 creates a solid with a triangular cross section. In the following example, the plotting intervals are set to \( -\pi \leq \theta \leq \pi \), \( -1 \leq z \leq 1 \), and \( 0 \leq \phi \leq \pi \).
Creating 3D Plots

**Compute > Plot 3D > Spherical**

---

**Defined Functions**

You can create a plot of a function defined in spherical coordinates $r = \rho(\theta, \phi)$.

**To make a spherical plot of a defined function $\rho$ of $\theta$ and $\phi$**

1. Define $\rho$ as a function of $\theta$ and $\phi$ by choosing Compute > Definitions > New Definition.

2. Select the function name $\rho$ or select the expression $\rho(\theta, \phi)$.

3. Choose Compute > Plot 3D > Spherical.

**Example**

To plot the nautilus determined by the expression $(1.2)^{\phi} \sin(\theta)$, you can do any one of the following:

- Plot the expression $(1.2)^{\phi} \sin(\theta)$ and then choose Switch Variables on the Items Plotted page of the Plot Properties dialog. Use the ranges $-1 \leq \phi \leq 2\pi$ and $0 \leq \theta \leq \pi$ to get the view of the nautilus shown below.

- Define $\rho(\theta, \phi) = (1.2)^{\phi} \sin(\theta)$, plot the expression $\rho(\theta, \phi)$, and then choose Switch Variables on the Items Plotted page of the Plot Properties dialog. Use the ranges $-1 \leq \phi \leq 2\pi$ and $0 \leq \theta \leq \pi$ to get the view of the nautilus shown below.

- Define the function $\rho(\phi, \theta) = (1.2)^{\phi} \sin(\theta)$ and plot the expression $\rho(\theta, \phi)$. (Note the variables are already switched here.) Use the ranges $-1 \leq \theta \leq 2\pi$ and $0 \leq \phi \leq \pi$ to get the view of the nautilus shown below.
Parameterized Surfaces in Spherical Coordinates

Parameterized surfaces in spherical coordinates are given by equations of the form \( \rho = f(s, t), \theta = g(s, t), \) and \( \phi = h(s, t) \).

These equations are very general and allow you to generate a wide variety of interesting plots.

To plot a parameterized surface

1. Type the defining expressions as the three components of a vector, \((f(s, t), g(s, t), h(s, t))\).

2. Place the insert point in the vector.

3. Choose Compute > Plot 3D > Spherical.

The 3D spherical plot of the vector \([\rho, \theta, 1]\) gives the cone \(\phi = 1\).

For the following plot, the view is set as \(-1 \leq \rho \leq 1\) and \(0 \leq \theta \leq 2\pi\). The Surface Style is Color Patch, and the Surface Mesh is Mesh.
You can plot the surface defined by $\rho = s$, $\theta = s^2 + t^2$, $\phi = t$ by entering the three expressions as coordinates of a vector. For the following plot, take $0 \leq s \leq 1$ and $-1 \leq t \leq 1$.

For an animated plot, you specify a third animation parameter. The default animation parameter is $t$. 

Creating Animated 3D Plots
Chapter 6 | Plotting Curves and Surfaces

Animated 3D Plots in Rectangular Coordinates

To make an animated plot in rectangular coordinates

1. Type an expression in three variables.

2. With the insert point in the expression, choose Compute > Plot 3D Animated > Rectangular.

The next example shows a 3D animated plot with Boxed Axes and Intervals $-6 \leq x \leq 6, -6 \leq y \leq 6, -3 \leq t \leq 3$, where $t$ is the animation variable. The surface changes from a hyperbolic paraboloid ($t < 0$), to a paraboloid ($t = 0$), then to a hyperbolic paraboloid with a different orientation ($t > 0$).

To make a parameterized animated plot in rectangular coordinates

1. Type an expression of the form $(x(r,s,t), y(r,s,t), z(r,s,t))$.

2. Choose Compute > Plot 3D Animated > Parametric, or Choose Compute > Plot 3D Animated > Rectangular.

The next example shows a surface of revolution generated by rotating the graph of $z = 2 + \sin y$ about the $y$-axis with Boxed Axes and Intervals $-6 \leq s \leq 6, 0 \leq r \leq 1, 0 \leq t \leq 1$, where $t$ is the animation variable.
Creating Animated 3D Plots

Animated Curves in Three Space

To make an animated curve in space

1. Type an expression of the form \((x(s,t), y(s,t), z(s,t))\).

2. Choose Compute > Plot 3D Animated > Curve in Space.

Here is a curve that plays “follow the leader.”

\[
\begin{pmatrix}
-10\cos(t+s) - 2\cos(5(t+s)) + 15\sin(2(t+s)) \\
-15\cos(2(t+s)) + 10\sin(t+s) - 2\sin(5(t+s)) \\
10\cos(3(t+s))
\end{pmatrix}
\]

\(0 \leq s \leq 3, 0 \leq t \leq 6.28\), Animation Variable: \(t\)
Animated Plots in Cylindrical Coordinates

To make an animated plot in cylindrical coordinates
1. Type an expression in three variables

2. With the insert point in the expression, choose Compute > Plot 3D Animated > Cylindrical.

The next example shows a blooming flower, with Intervals $0 \leq z \leq 1$, $0 \leq \theta \leq 20$, and $0 \leq t \leq 1$.

To make a parametric animated plot in cylindrical coordinates
1. Type an expression of the form $(r(u,v,t), \theta(u,v,t), z(u,v,t))$

2. With the insert point in the expression, choose Compute > Plot 3D Animated > Cylindrical.

The next example shows a cone being generated as the line $z = r$ is rotated about the $z$-axis with Intervals $0 \leq r \leq 1$, $0 \leq s \leq 1$, and $0 \leq t \leq 1$. 
Creating Animated 3D Plots

Animated Plots in Spherical Coordinates

To make an animated plot in spherical coordinates

1. Type an expression in three variables.

2. With the insert point in the expression, choose Compute > Plot 3D Animated > Spherical.

The next example shows a sphere growing from radius 1 to radius 2, with animation variable Interval $1 \leq t \leq 2$ and Boxed Axes.
Chapter 6 | Plotting Curves and Surfaces

To make an parameterized animated plot in spherical coordinates

1. Type an expression of the form \((\rho (r,s,t), \theta (r,s,t), \phi (r,s,t))\)

2. With the insert point in the expression, choose Compute > Plot 3D Animated > Spherical.

The next animation shows the surface that morphs from a sphere into a surface shaped like a bagel. The Intervals are \(0 \leq r \leq 1\), \(0 \leq s \leq 1\), and \(0 \leq t \leq 1\).

Compute > Plot 3D Animated > Spherical

\((1 - t \cos 2\pi r, 2\pi s, \pi r)\)

---

Animated 3D Implicit Plots

To make an animated implicit plot

1. Type an equation in four variables.

2. With the insert point in the expression, choose Compute > Plot 3D Animated > Implicit.

The next animation shows a hyperboloid on two sheets that morphs into a sphere. The intervals are \(-2 \leq x \leq 2, -2 \leq y \leq 2, -2 \leq z \leq 2, -1 \leq t \leq 1\).
Creating Animated 3D Plots

**Animated Tube Plot**

To make an animated tube plot:

1. Type an expression in one or two variables.
2. With the insert point in the expression, choose Compute > Plot 3D Animated > Tube.
3. In the Plot Properties dialog, on the Items Plotted page, change
   Radius to an expression of your choice, using the same variables.

The next animation shows a knot being drawn. The Intervals are
$0 \leq s \leq 2\pi$ and $0.01 < t < 1$, and Radius is set to 3.

```
Compute > Plot 3D Animated > Tube

\([-10\cos ts - 2\cos 5ts + 15\sin 2ts - 15\cos 2ts + 10\sin ts - 2\sin 5ts - 10\cos 3ts] \]
\([-10\cos ts - 2\cos 5s + 15\sin 2s - 15\cos 2s + 10\sin s - 2\sin 5s - 10\cos 3s] \]
```
Chapter 6 | Plotting Curves and Surfaces

Exercises

1. Choose Compute > Plot 2D > Implicit to plot the conic sections \(x^2 + y^2 = 1, x^2 - y^2 = 1,\) and \(x + y^2 = 0\) all on the same coordinate axes.

2. Choose Compute > Plot 2D > Implicit to plot the conic sections \((x - 1)^2 + (y + 2)^2 = 1, (x - 1)^2 - (y + 2)^2 = 1,\) and \((x - 1) + (y + 2)^2 = 0\) on one pair of coordinate axes. With the hand symbol visible over the view, translate the view so that the curves match the curves in Exercise 1. In which direction did the axes move?

3. Plot \(x^2 + y^2 = 4\) and \(x^2 - y^2 = 1\) together. How many intersection points are there? Zoom in on the one in the first quadrant to estimate where the curves cross each other. Verify your estimate by typing the formulas into a matrix and choosing Compute > Solve > Numeric.

4. Plot the astroid \(x^{2/3} + y^{2/3} = 1.\)

5. Plot the folium of Descartes \(x^3 + y^3 = 6xy.\)

6. Plot the surface \(z = \sin xy,\) with \(-4 \leq x \leq 4\) and \(-4 \leq y \leq 4.\) Compare the location of the ridges with the implicit plot of the three curves \(xy = \frac{x}{2}, xy = \frac{3x}{2},\) and \(xy = \frac{5x}{2}.

7. A standard calculus problem involves finding the intersection of two right circular cylinders of radius 1. View this problem by choosing Compute > Plot 3D > Rectangular to plot the two parametric surfaces \(s, \cos t, \sin t\) and \(\cos t, s, \sin t.\) Obtain a second view by creating a tube plot of \([0, 0, t]\) and setting the radius to \(\sqrt{2}\sqrt{1 - t^2}\) and number of tube points to 5.

8. Do the two space curves

\[
[(2 + \sin t)10 \cos t, (2 + \cos t)10 \sin t, 3 \sin 3t]
\]

and

\[
[20 \cos t, 20 \sin t, -3 \sin 3t]
\]

intersect? Choose Compute > Plot 3D > Tube and rotate the curves to find out.
9. View the intersection of the sphere \( x^2 + y^2 + z^2 = 1 \) and the plane \( x + y + z = \frac{1}{2} \) by expressing these equations in parametric form and choosing Compute \( > \) Plot 3D \( > \) Rectangular. Verify that the points of intersection lie on an ellipse (it is actually a circle) by solving \( x + y + z = \frac{1}{2} \) for \( z \), substituting this value into the equation \( x^2 + y^2 + z^2 = 1 \), and calculating the discriminant of the resulting equation.

10. Explore the meaning of contours by plotting the surface \( z = xy \). Rotate the surface until only the top face of the cube is visible, and interpret the meaning of the curves that you see. Rotate the cube until the top face just disappears, and interpret the meaning of the contours that appear.

Solutions

1. Compute \( > \) Plot 2D \( > \) Implicit: \( x^2 + y^2 = 1, x^2 - y^2 = 1, x + y^2 = 0 \)
   (Take \(-2 \leq x \leq 2\) and \(-2 \leq y \leq 2\). Choose Equal Scaling Along Each Axis.)

2. Compute \( > \) Plot 2D \( > \) Implicit: \( (x - 1)^2 + (y + 2)^2 = 1, (x - 1)^2 - (y + 2)^2 = 1, (x - 1) + (y + 2)^2 = 0 \)
   (Take \(-1 \leq x \leq 3\) and \(-4 \leq y \leq 0\). Choose Equal Scaling Along Each Axis.)

3. Compute \( > \) Plot 2D \( > \) Implicit: \( x^2 + y^2 = 4, x^2 - y^2 = 1 \)
   (Take \(-5 \leq x \leq 5\) and \(-5 \leq y \leq 5\). Choose Equal Scaling Along Each Axis.)

   \[
   \begin{align*}
   x^2 + y^2 &= 4 \\
x^2 - y^2 &= 1 \\
x &\in (1, 2) \\
y &\in (1, 2)
   \end{align*}
   \]

   Solution: \( \{ x = 1.58113883, y = 1.224744871 \} \)

4. Compute \( > \) Plot 2D \( > \) Implicit: \( |x|^{2/3} + |y|^{2/3} = 1 \)
   (Take \(-1 \leq x \leq 1\) and \(-1 \leq y \leq 1\).)

   Without the absolute values, you obtain only the first quadrant portion of the graph.
Chapter 6 | Plotting Curves and Surfaces

5. Compute > Plot 2D > Implicit: $x^3 + y^3 = 6xy$

(Take $-5 \leq x \leq 5$ and $-5 \leq y \leq 5$ and set the grid to 50 by 50.)

Notice how the folium of Descartes shows up as a level curve on the surface $z = x^3 + y^3 - 6xy$.

Compute > Plot 3D > Rectangular: $x^3 + y^3 - 6xy$

Compute > Plot 3D > Rectangular: 0

(Use Patch & Contour and take $-5 \leq x \leq 5$, $-5 \leq y \leq 5$, Turn 16, and Tilt 10.)

6. Compute > Plot 3D > Rectangular: $\sin(xy)$

(Choose Patch and Contour and take $-4 \leq x \leq 4$, $-4 \leq y \leq 4$, Turn 108, and Tilt 17.)

Compute > Plot 2D > Implicit: $xy = \pi/2, xy = 5\pi/2, xy = 3\pi/2$

(Take $-4 \leq x \leq 4$ and $-4 \leq y \leq 4$.)

7. Compute > Plot 3D > Rectangular: $[s, \cos t, \sin t]$

Drag $[\cos t, s, \sin t]$ onto the plot, and set Plot Intervals at $-2 \leq s \leq 2$ and $0 \leq t \leq 2\pi$. Compute > Plot 3D > Tube: $[0, 0, t]$, set the Radius to $\sqrt{2} \times \sqrt{1 - t^2}$, set Plot Intervals at $-1 \leq t \leq 1$. 
8. Compute > Plot 3D > Tube:

\[
\begin{bmatrix}
20\cos t \\
20\sin t \\
-3\sin 3t
\end{bmatrix}
\]

Drag onto the plot, set \(0 \leq t \leq 2\pi\), and set the radius for both items to 1.

Compute > Solve > Exact:

\[
\begin{bmatrix}
(2 + \sin t)10\cos t \\
(2 + \cos t)10\sin t \\
3\sin 3t
\end{bmatrix}
\]

Solution: \(\{t = 0, s = 0\}, \{t = \pi, s = \pi\}\)

9. The plane \(x + y + z = 1/2\) can be expressed in parametric form as

\[(x, y, z) = \left( s, t, \frac{1}{2} - s - t \right)\]

and the sphere \(x^2 + y^2 + z^2 = 1\) can be expressed in parametric form as

\[(x, y, z) = \left( \sqrt{1 - s^2 \cos t}, \sqrt{1 - s^2 \sin t}, s \right)\]

For the plane, take \(-1 \leq s \leq 1, -1 \leq t \leq 1\), style Patch & Contour. For the sphere, take \(-1 \leq s \leq 1\) and \(0 \leq t \leq 6.283 (2\pi)\), style Hidden Line. Set Equal Scaling Along Each Axis.) Solving for \(z\) on the plane gives \(z = \frac{1}{2} - x - y\), giving the equation for points on the intersection of the plane and sphere:

\[x^2 + y^2 + \left( \frac{1}{2} - x - y \right)^2 = 1\]
Expanding this expression yields the equation

$$2x^2 + 2xy + 2y^2 - x - y - \frac{3}{4} = 0$$

for the curve of intersection. The discriminant $B^2 - 4AC$ is

$$2^2 - 4(2)(2) = -12 < 0$$

which indicates that the curve of intersection is an ellipse.

10. Here are three views:

Wireframe

Contour

The contours trace paths where the elevation is constant.
This chapter covers the standard topics from differential and integral calculus, including limits, sequences, and series. The notion of a function is fundamental to the study of calculus. Functions were introduced in Chapter 3 “Algebra,” with a description of procedures for naming expressions and functions. Basic information on working with functions and expressions is summarized in Chapter 5 “Function Definitions,” along with additional information on storing and retrieving definitions. In this chapter we assume that you have read and understand how to define and manipulate functions. We give several examples in this chapter that illustrate connections between calculus and the function plots introduced in Chapter 6 “Plotting Curves and Surfaces.”

Evaluating Calculus Expressions

You can evaluate calculus expressions in the same manner as expressions from algebra or trigonometry.

To calculate a derivative or an integral
1. Enter a derivative or integral in standard mathematical notation.
2. Choose Compute > Evaluate.

New in Version 6
Dot notation for derivatives
Specify center of a power series
Specify both dependent and independent variables for implicit differentiation
Chapter 7 | Calculus

To calculate the derivative $\frac{d}{dx}x \sin x$
1. Choose Insert > Math Objects > Fraction
2. Type $d$ in the numerator, and press tab to take the insert point to the denominator.
3. Type $dx$ and press spacebar to put the insert point back in line, then type $x \sin x$.
4. Leave the insert point in the expression $\frac{d}{dx}x \sin x$ and choose Compute > Evaluate.

Compute > Evaluate
$\frac{d}{dx}x \sin x = \sin x + x \cos x$

To calculate the definite integral $\int_0^\pi x \sin x \, dx$
1. Choose Insert > Math Objects > Operator and select $\int$.
2. Choose Insert > Math Objects > Subscript and type the lower limit 0 in the subscript box.
3. Press tab and enter the upper limit $\pi$ in the superscript box.
4. Press spacebar to put the insert point back in line, and type $x \sin x \, dx$.
5. Leave the insert point in the expression $\int_0^\pi x \sin x \, dx$ and choose Compute > Evaluate.

Compute > Evaluate
$\int_0^\pi x \sin x \, dx = \pi$

Limits

The concept of a limit is fundamental to the study of calculus. It is the central idea of the subject and is what distinguishes calculus from earlier mathematics. The notion, which encompasses subtle concepts such as instantaneous velocity, can be fully understood only through experience and experimentation. With Scientific WorkPlace and Scientific Notebook, you have a variety of tools for computing and experimenting with limits.
Limits

Notation for Limits

The limit of \( f \) as \( x \) approaches \( a \) is \( L \), written

\[ \lim_{x \to a} f(x) = L \]

if for each number \( \varepsilon > 0 \) there exists a number \( \delta > 0 \) such that

\[ |f(x) - L| < \varepsilon \]

whenever \( 0 < |x - a| < \delta \).

To find a limit of the form \( \lim_{x \to a} f(x) \)

1. Choose Insert > Math and type \( \lim \).
2. Choose Insert > Math Objects > Subscript and enter the subscript \( x \to a \). When you type the name \( \lim \), it will turn from red to gray as you type the third letter.
3. Press spacebar to put the insert point back in line, then type a mathematical expression \( f(x) \).
4. Choose Compute > Evaluate.

Compute > Evaluate

\[ \lim_{x \to 1} \frac{x^2 - 1}{x - 1} = 2 \]

Limits of rational functions are not always apparent. You cannot evaluate the following expression at \( x = -3/2 \), because the denominator is 0 for this value of \( x \). The expression does, however, have a limit at \(-3/2\).

Compute > Evaluate

\[ \lim_{x \to -3/2} \frac{4x^4 + 6x^2 + 19x + 6x^3 + 15}{2x^3 + 5x^2 + 5x + 3} = -\frac{25}{7} \]

Factoring the numerator and denominator suggests a method for evaluating this limit by direct substitution.

Compute > Factor

\[ 4x^4 + 6x^2 + 19x + 6x^3 + 15 = (2x + 3)(x + 1)(2x^2 - 2x + 5) \]
\[ 2x^3 + 5x^2 + 5x + 3 = (2x + 3)(x^2 + x + 1) \]

If an expression has a removable singularity, factoring in place may allow you to fill in the steps leading to evaluation by direct substitution. This is illustrated in the following example, where the second

Informally, \( \lim_{x \to a} f(x) = L \), if \( f(x) \) gets close to \( L \) as \( x \) gets close to \( a \).

When you type the name \( \lim \), it will turn from red to gray as you type the third letter.

Limit

The result \( \lim_{x \to 1} \frac{x^2 - 1}{x - 1} = 2 \) is reasonable since \( x \neq 1 \) implies \( \frac{x^2 - 1}{x - 1} = x + 1 \), which is close to 2 when \( x \) is close to 1.
Chapter 7 | Calculus

Step removes the singularity from the expression. Copy the entire expression after an equals sign, and carry out in-place operations.

\[
\lim_{x \to -3/2} \frac{4x^4 + 6x^3 + 6x^2 + 19x + 15}{2x^3 + 5x^2 + 5x + 3} = \lim_{x \to -3/2} \frac{(2x + 3)(x + 1)(2x^2 - 2x + 5)}{(2x + 3)(x^2 + x + 1)} \\
= \lim_{x \to -3/2} \frac{(x + 1)(2x^2 - 2x + 5)}{(x^2 + x + 1)} \\
= \left[ \frac{(x + 1)(2x^2 - 2x + 5)}{(x^2 + x + 1)} \right]_{x = -3/2} \\
= -\frac{25}{7}
\]

You can do the substitution (see Substitution, page 47) in the preceding example as follows:

**To substitute a value into an expression**

1. Select the expression \((x + 1)(2x^2 - 2x + 5)\) with the mouse, and copy and paste in a new line.

2. Choose Insert > Math Objects > Brackets and select the left dashed line and right vertical line.

3. Choose Insert > Math Objects > Subscript.

4. Enter the subscript \(x = -3/2\), and choose Compute > Evaluate.

**Compute > Evaluate**

\[
\left[ \frac{(x + 1)(2x^2 - 2x + 5)}{x^2 + x + 1} \right]_{x = -3/2} = -\frac{25}{7}
\]

You can also carry out a replacement using the editing features.

**To do an automatic replacement of mathematics**

1. Select the expression \(\frac{(x + 1)(2x^2 - 2x + 5)}{x^2 + x + 1}\) with the mouse.

2. Choose Edit > Find and Replace.

3. Fill in the choices in the dialog box in mathematics mode.

   a. Search for: \(x\)
b. Replace with: \((-3/2)\)

The result is the expression

\[
\frac{((-3/2) + 1) \left(2 \cdot (-3/2)^2 - 2 \cdot (-3/2) + 5\right)}{(-3/2)^2 + (-3/2) + 1}
\]

### Special Limits

You can compute one-sided limits, limits at infinity, and infinite limits.

<table>
<thead>
<tr>
<th>Compute &gt; Evaluate</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \lim_{x \to 0^+} \frac{x}{</td>
</tr>
<tr>
<td>( \lim_{x \to ^+x^+ \to ^+2} \frac{x}{x} = \infty )</td>
</tr>
<tr>
<td>( \lim_{x \to 0^+} \sin \left(\frac{1}{x}\right) = \lim_{x \to 0} \left(\sin \frac{1}{x}\right) )</td>
</tr>
</tbody>
</table>

### Tables of Values and Plots

You can generate a table of values by applying a function to a vector of domain values and then concatenating matrices, or you can do it in one step by defining appropriate auxiliary functions. The limit \( \lim_{x \to 0} \frac{\sin x}{x} = 1 \) is of special interest. After evaluating this limit, the following paragraphs examine the behavior of the function \( f(x) = \frac{\sin x}{x} \) near the origin, first by looking at numerical evidence and then at plots containing the origin. Two methods are then illustrated for constructing a table of values for this function.

<table>
<thead>
<tr>
<th>Compute &gt; Evaluate</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \lim_{x \to 0} \frac{\sin x}{x} = 1 )</td>
</tr>
</tbody>
</table>

To see numerical evidence that \( \lim_{x \to 0} \frac{\sin x}{x} = 1 \), you can evaluate the expression \( \frac{\sin x}{x} \) for several values of \( x \) near 0. First define a function \( f \) to be equal to this expression so that it can be evaluated easily, then evaluate numerically at several points near zero.

<table>
<thead>
<tr>
<th>Compute &gt; Definitions &gt; New Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>( f(x) = \frac{\sin x}{x} )</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Compute &gt; Evaluate Numeric</th>
</tr>
</thead>
<tbody>
<tr>
<td>( f(0.1) \approx 0.99833 )</td>
</tr>
</tbody>
</table>
Chapter 7 | Calculus

Note that the function values appear to approach 1. The graph of 
y = \frac{\sin x}{x} on an interval containing 0 gives additional strong evidence 
that \( \lim_{x \to 0} \frac{\sin x}{x} = 1. \)

Creating a Table of Values Using Auxiliary Functions

The matrix command Fill Matrix is useful for creating tables of values.

To create a table of values using auxiliary functions
1. Define the function \( f(x) \).
2. Define a function \( g(n) \) to provide a sample of values of the independent variable.
3. Define the function \( h(i, j) = (2 - j)g(i) + (j - 1)f(g(i)) \).
4. Choose Compute > Matrices > Fill Matrix.
5. Set Columns to 2 and set Rows to match the size of your sample.
6. Under Fill with, choose Defined by function.
7. In the input box for function name, type \( h \). Choose OK.
The following example illustrates this procedure for the function \( f(x) = \frac{\sin x}{x} \), with a sample of 10 values for the independent variable.

**Example**  
We create a table of values for the function \( y = \frac{\sin x}{x} \).

\[
\begin{align*}
\text{Compute} & \quad \text{Definitions} & \quad \text{New Definition} \\
\quad f(x) &= \frac{\sin x}{x} \\
\quad g(i) &= i \times 10^{-2} \\
\quad h(i, j) &= (2 - j)g(i) + (j - 1)f(g(i))
\end{align*}
\]

Choose Insert > Math Objects > Brackets, select square brackets, and leave the insert point in the input box.

\[
\text{Compute} & \quad \text{Matrices} & \quad \text{Fill Matrix} \\
\quad \text{(Rows 10, Columns 2, Matrix Type: Defined by Function, Function h)}
\]

\[
\begin{bmatrix}
\frac{1}{100} & 100 \sin \frac{1}{100} \\
\frac{1}{50} & 50 \sin \frac{1}{50} \\
\frac{3}{100} & 100 \sin \frac{3}{100} \\
\frac{1}{25} & 25 \sin \frac{1}{25} \\
\frac{1}{20} & 20 \sin \frac{1}{20} \\
\frac{3}{50} & 50 \sin \frac{3}{50} \\
\frac{7}{100} & 100 \sin \frac{7}{100} \\
\frac{2}{25} & 25 \sin \frac{2}{25} \\
\frac{9}{100} & 100 \sin \frac{9}{100} \\
\frac{1}{10} & 10 \sin \frac{1}{10}
\end{bmatrix}
\]

In the matrix that results, the numbers in the first column are values of the independent variable, and the numbers in the second column are the corresponding function values.

Evaluate numerically to put the matrix in numeric format.
To generate a table of values by concatenating matrices

1. Type the equation \( f(x) = \frac{\sin x}{x} \) and, with the insert point in the equation, choose Compute > Definitions > New Definition.

2. Type the equation \( g(i, j) = 0.01i \)

3. Choose Compute > Matrices > Fill Matrix.

4. Specify some number of rows, 1 column, check Defined by Function, type \( g \) in the Item/Function/List box, and choose OK.

5. Choose Compute > Matrices > Map Function.

6. Type \( f \) in the Function or Expression box, and choose OK.

With the same function as in the previous example, this gives

\[
\begin{bmatrix}
\frac{1}{100} & 100 \sin \frac{1}{100} \\
\frac{1}{50} & 50 \sin \frac{1}{50} \\
\frac{1}{25} & 25 \sin \frac{1}{25} \\
\frac{1}{20} & 20 \sin \frac{1}{20} \\
\frac{3}{100} & \frac{3}{10} \sin \frac{3}{100} \\
\frac{7}{100} & \frac{7}{10} \sin \frac{7}{100} \\
\frac{2}{25} & \frac{2}{5} \sin \frac{2}{25} \\
\frac{9}{100} & \frac{9}{10} \sin \frac{9}{100} \\
\frac{1}{10} & 10 \sin \frac{1}{10}
\end{bmatrix} \approx \begin{bmatrix}
0.01 & 0.99998 \\
0.02 & 0.99993 \\
0.03 & 0.99985 \\
0.04 & 0.99973 \\
0.05 & 0.99958 \\
0.06 & 0.9994 \\
0.07 & 0.99918 \\
0.08 & 0.99893 \\
0.09 & 0.99865 \\
0.1 & 0.99833
\end{bmatrix}
\]

and concatenating produces

\[
\begin{bmatrix}
1.0 \times 10^{-2} \\
2.0 \times 10^{-2} \\
3.0 \times 10^{-2}
\end{bmatrix} \begin{bmatrix}
0.99998 \\
0.99993 \\
0.9985
\end{bmatrix}, \text{concatenate:} \begin{bmatrix}
0.01 & 0.99998 \\
0.02 & 0.99993 \\
0.03 & 0.9985
\end{bmatrix}
\]
Differentiation

The derivative \(f'(x)\) of a function \(f\) is defined by the equation

\[
f'(x) = \lim_{h \to 0} \frac{f(x+h) - f(x)}{h}
\]

The derivative of a function \(f\) at the point \(x\) is the slope of the graph of \(f\) at the point \((x, f(x))\).

Notation for Derivative

You can use a variety of notations for the derivative, including the forms

\[
\frac{d}{dx}, \frac{d^n}{dx^n}, D_x, D_{xx}, D_{xy}, D_{x^2y^2}, \frac{\partial}{\partial x}, \text{ and } \frac{\partial^n}{\partial x^n}\partial y^n
\]

To compute a derivative

1. Enter an expression using one of the above forms.
2. With the insert point in the expression, choose Compute > Evaluate.

Compute > Evaluate

\[
\frac{d}{dx} (x^3) = 3x^2 \\
\frac{d^n}{dx^n} (3x^8) = 5040x^4 \\
\frac{\partial}{\partial x} (\sin^2 x) = \sin (2x) \\
D_{x^2y^2} (x^9 y^3) = 90720x^4 y \\
\frac{\partial^3}{\partial x^2 \partial y^3} (\sin x \cos y) = -\sin x \sin y
\]

If \(f\) is defined as a function of one variable, then the forms \(f'(x), f''(x), \ldots, f^{(n)}(x)\) are recognized as first, second, and \(n\)th derivatives, respectively.

Compute > Definitions > New Definition

\(f(x) = \sin x \cos x\)

Compute > Evaluate

\[
f''(x) = \cos^2 x - \sin^2 x \\
f^{(4)}(x) = 16 \cos x \sin x \\
f''''(x) = -4 \cos x \sin x \\
f^{(4)}(x) = \cos^4 x \sin^4 x
\]

The following examples include some time-saving steps for keyboard entry.

(See Concatenate and Stack Matrices, page 292, for details on concatenating matrices.)
Chapter 7 | Calculus

**To enter a derivative of the form** \( \frac{d}{dx} x^2 \)

1. Place the insert point where you want the derivative to appear, even in an existing input box.

2. Choose Insert > Math Objects > Fraction, and type the numerator.

3. Move to the denominator by pressing down arrow, or pressing tab, or clicking the denominator input box; and type the denominator (usually similar to \( dx \)).

4. Press right arrow or spacebar to leave the fraction, and type the mathematical expression.

**To enter a derivative of the form** \( f^{(3)}(x) \)

1. Choose Insert > Math and type \( f \).

2. Choose Insert > Math Objects > Superscript.

3. Choose Insert > Brackets and select parentheses.

4. Type 3 in the input box.

5. Press right arrow twice to leave the superscript.

6. Choose Insert > Math Objects > Brackets and select parentheses.

7. Type \( x \) in the input box.

**To find the derivative of** \( x^2 \)

1. Place the insert point in the expression \( \frac{d}{dx} (x^2) \).

2. Choose Compute > Evaluate.

You obtain the same result from any of the following expressions.

\[
\frac{d}{dx} x^2 \quad \frac{d}{dx} x^2 \quad \frac{d}{dx} (x^2) \quad \frac{\partial}{\partial x} (x^2)
\]

\[
D_x x^2 \quad D_x (x^2) \quad \frac{\partial x^2}{\partial x} \quad \frac{\partial}{\partial x} x^2
\]

The “prime” notation works only for defined functions, not for expressions.

210
Differentiation

Compute > Evaluate

\[ (x + \sin x)' = \cos x + 1 \]

A derivative is applied to the term directly to the right of the operator, as illustrated in the following two examples.

Compute > Evaluate

\[ \frac{d^2}{dx^2} x^2 + 3x = 3x + 2 \]
\[ \frac{d^2}{dx^2} (x^2 + 3x) = 2 \]

Using good notation is important. The program may accept ambiguous notation, but it may lead to an unexpected output. Experiment with expressions such as

\[ \frac{d^2}{dx^2} (x^2 + 3x) \quad \text{and} \quad \frac{d^2}{dx^2} (x^2 + 3x) \]

to see examples of how ill-formed expressions are interpreted. Choose Compute > Interpret to observe the interpretation of an expression.

The derivative of a piecewise-defined function is again a piecewise-defined function. (See Piecewise-Defined Functions, page 108 for more information on piecewise-defined functions.)

Compute > Definitions > New Definition

\[ f(x) = \begin{cases} x & \text{if} \quad x < 0 \\ 3x^2 & \text{if} \quad x \geq 0 \end{cases} \]

Compute > Evaluate

\[ \frac{d}{dx} f(x) = \begin{cases} 6x & \text{if} \quad 0 < x \\ 1 & \text{if} \quad x < 0 \end{cases} \]

It is not necessary to name a piecewise function in order to take its derivative.

Compute > Evaluate

\[ \frac{d}{dx} \left( \begin{cases} x + 2 & \text{if} \quad x < 0 \\ 2 & \text{if} \quad 0 < x < 1 \\ 2/x & \text{if} \quad 1 < x \end{cases} \right) = \begin{cases} 1 & \text{if} \quad x < 0 \\ 0 & \text{if} \quad 0 < x \wedge x < 1 \\ -\frac{2}{x^2} & \text{if} \quad 1 < x \end{cases} \]

The symbol \( \wedge \) means that both of the conditions \( 0 < x \) and \( x < 1 \) are true. This is equivalent to the compound inequality \( 0 < x < 1 \).
Chapter 7 | Calculus

Plotting Derivatives

You can plot several functions on the same graph. In particular, a function can be plotted together with one or more of its derivatives. Defining the function first is often convenient.

Compute > Definitions > New Definition

\[ f(x) = x^4 - 7x^3 + 14x^2 - 8x \]

To view the graph of \( f \) with its first and second derivatives

1. Type \( f(x) \) and, with the insert point in \( f(x) \), choose Compute > Plot 2D > Rectangular.
2. Type \( f'(x) \), select it and drag it to the frame
3. Type \( f''(x) \), select it and drag it to the frame.

Open the Graph User Settings dialog and change settings to distinguish the three curves. You can change line thickness or line color for each curve. Another way to distinguish the graphs is by determining the values at 0. Use Evaluate (or inspection) to find \( f(0) = 0 \), \( f'(0) = -8 \), and \( f''(0) = 28 \).

It is not necessary to define the functions. You can plot an expression and drag the first and second derivatives to the plot, as indicated below.

Compute > Plot 2D > Rectangular

\[ \sin 2x \quad \frac{d}{dx} (\sin 2x) \quad \frac{d^2}{dx^2} (\sin 2x) \]

It is possible to specify the symbol \( f(x) \) to be an arbitrary, or generic, function. Simply define \( f(x) \) to be a function, without associating it with a formula. (See Defining Generic Functions, page 110.)
Differentiation

Compute > Definitions > New Definition

\[ f(x) \]

\[ g(x) \]

Standard rules of calculus apply to generic functions.

Compute > Evaluate

\[ \frac{d}{dx} (f(x) + g(x)) = \frac{df(x)}{dx} + \frac{dg(x)}{dx} \]

\[ \frac{d}{dx} \int_0^x f(t) \, dt = f(x) \]

\[ D_x (f(x)g(x)) = f(x)D_x g(x) + g(x)D_x f(x) \]

\[ D_x \frac{f(x)}{g(x)} = -\frac{(f(x)D_x g(x) - g(x)D_x f(x))}{g^2(x)} \]

Implicit Differentiation

Variables can be linked to one another implicitly via an equation rather than in an explicit way. For example, \( xy = 1 \) implicitly determines \( y \) as a function of \( x \). This example is easily solved to give the explicit formula \( y = 1/x \). Many other equations cannot easily be solved for one of the variables. Also, some equations, such as \( x^2 + y^2 = 1 \), do not determine a function, but pieces of the curves determined by such equations are functions. Implicit Differentiation, an item on the Calculus submenu, finds derivatives from an equation without explicitly solving the equation for any one variable.

You specify the differentiation variable—that is, the independent variable. It is important to remember this variable in order to interpret the result, because the derivative is returned in the prime notation \( y' \).

To find a derivative of an implicitly defined function

1. Place the insert point in the equation.

2. Choose Compute > Calculus > Implicit Differentiation.

3. Place the insert point in the solution and solve for the derivative with Solve > Exact.
Chapter 7 | Calculus

Compute > Calculus > Implicit Differentiation

\[ xy + \sin x = y \] (Independent variable \( x \), Dependent variable \( y \))

Solution: \( \cos x + y(x) + xy'(x) = y'(x) \)

\[ xyz - x^2y = 0 \] (Independent variable \( t \), Dependent variables \( x, y, z \))

Solution: \( x(t)y(t)z'(t) - 2x(t)y(t)x'(t) + x(t)z(t)y'(t) + y(t)z(t)x'(t) - x(t)^2y'(t) = 0 \)

Note that in the first example above, \( y' = \frac{dy}{dx} \). In the second example above, \( x' = \frac{dx}{dt}, y' = \frac{dy}{dt}, \) and \( z' = \frac{dz}{dt} \).

To ignore special cases

- Choose Tools > Preferences > Computation > Engine, and check Ignore Special Cases.

Compute > Solve > Exact

\[ y + xy' + \cos x = y' \] (Variable(s) to Solve For: \( y' \)),

Solution: \( \frac{1}{y} \left( -y - \cos x \right) \)

\[ xyz' - 2xxy' + xzy' + yzx' - x^2y' = 0 \] (Variable(s) to Solve For: \( z' \))

Solution: \( \frac{1}{xy} \left( 2xxy' - xzy' - yzx' + x^2y' \right) \)

Use Implicit Differentiation combined with word processing editing features to find the second derivative \( y'' \).

1. Leave the insert point in \( y' = -\frac{\sin x}{x - 1} \), and choose Compute > Calculus > Implicit Differentiation. Type \( x \) for the Independent variable and \( y \) for the Dependent variable. Choose OK.

This returns the equation

\[ \frac{\partial y'(x)}{\partial x} = \frac{\cos x + y(x)}{(x - 1)^2} + \frac{\sin x - y'(x)}{x - 1} \]

2. Use editing techniques to replace \( \frac{\partial y'(x)}{\partial x} \) by \( y'' \) and to replace \( y'(x) \) by \(-\frac{\sin x + \cos x}{x - 1}\).

3. Apply Compute > Simplify to obtain the following:

\[ y'' = \frac{\cos x + y(x)}{(x - 1)^2} + \frac{\sin x - \left( -\frac{\sin x + \cos x}{x - 1} \right)}{x - 1} \]

\[ = \frac{2 \cos x + 2y(x) - \sin x + x \sin x}{(x - 1)^2} \]
You can use Implicit Differentiation to find an equation of a tangent line. Find the derivative $y'$, evaluate at a point on the curve to find the slope of the tangent at that point, and use the point-slope formula to find the equation for the tangent line. You can then plot the graph of the equation together with the tangent line. In the following example, we find the equation for the tangent line at the point $(1,1)$ on the curve $x^3 + 3x^2 y = 2y^3 + 2$.

**To find the equation of a tangent line**

1. Place the insert point in the equation $x^3 + 3x^2 y = 2y^3 + 2$ and choose Compute > Calculus > Implicit Differentiation (Independent variable $x$, Dependent variable $y$) to obtain

   Solution: $6xy(x) + 3x^2 + 3x^2 y'(x) = 6y^2(x) y'(x)$

2. Remove all the $(x)$ and choose Solve > Exact (Variable(s) $y'$) for the result

   Solution: $\begin{cases} \emptyset & \text{if } x^2 + 2xy \neq 0 \land x^2 = 2y^2 \\ \mathbb{C} & \text{if } x^2 + 2xy = 0 \land x^2 = 2y^2 \\ \frac{-x^2 + 2x}{x^2 - 2y^2} & \text{if } x^2 \neq 2y^2 \end{cases}$

3. For the slope at the point $(1,1)$ on the curve, enclose the expression in expanding brackets, add limits in a subscript, and choose Evaluate. This yields

   \[ \left[ \frac{2xy + x^2}{2y^2 - x^2} \right]_{x=1,y=1} = 3 \]

4. Place the insert point in the point-slope formula $y - 1 = 3(x - 1)$ and choose Solve > Exact (Variable(s) $y$) to find the formula for the tangent line in standard form: $y = 3x - 2$.

5. Place the insert point in the equation $x^3 + 3x^2 y = 2y^3 + 2$ and choose Compute > Plot 2D > Implicit to plot the curve. Select and drag the equation for the tangent line to the plot.

**Numerical Solutions to Equations**

You can use both exact and numerical methods for solving equations, as illustrated in the following three examples.
Chapter 7 | Calculus

Compute > Solve > Exact
5x^3 - 5x^2 = x, Solution: 0, \(\frac{1}{2} - \frac{3}{10}\sqrt{5}, \frac{3}{10}\sqrt{5} + \frac{1}{2}\)
5.0x^3 - 5.0x^2 = x, Solution: 0, -0.17082, 1.1708

Compute > Solve > Numeric
5x^3 - 5x^2 = x, Solution: \{[x = 1.1708], [x = -0.17082], [x = 0.0]\}

Iteration
You can also obtain numerical solutions for many equations of the
form \(f(x) = x\) by using Iterate from the Calculus submenu. This tech-
ique works for functions satisfying \(|f'(x)| < 1\) near the intersection
of the curve \(y = f(x)\) and the line \(y = x\). You start with an estimate
\(x_0\) for the root, and Iterate returns the list of values
\[f(x_0), f(f(x_0)), f(f(f(x_0))), f(f(f(f(x_0)))), \ldots\]
up to the number of iterations you specify. In appropriate situations,
these values converge to a root of the equation \(f(x) = x\). For example,
solve the equation \(\cos x = x\).

Compute > Definitions > New Definition
\(f(x) = \cos x\)

Choosing Compute > Calculus > Iterate opens a dialog. In the
box, type \(f(x)\) as the Expression, 1.0 as Initial evaluation point, and
10 as the Number of iterates. With Digits Shown in Results set to 5,
you receive the following vector of iterates:

Compute > Calculus > Iterate
Expression: \(f(x)\)
Initial evaluation point: 1.0
Number of iterates: 5

\[
\begin{bmatrix}
1.0 \\
0.54030 \\
0.85755 \\
0.65429 \\
0.79348 \\
0.70137
\end{bmatrix}
\]

These entries are the initial value, followed by the values
\(f(1.0), f(f(1.0)), \ldots, f(f(f(f(f(f(1.0)))))))\)
You can generate these numbers geometrically by starting at the point \((1, 0)\) and moving vertically to the curve \(y = \cos x\), then horizontally to the line \(y = x\), then vertically to the curve \(y = \cos x\), then horizontally to the line \(y = x\), and so forth, as illustrated in the figure.

This figure can be generated by plotting \(\cos x\) and \(x\) as usual, then selecting the matrix

\[
\begin{bmatrix}
1.0 & 0 \\
1.0 & 0.5403 \\
0.5403 & 0.5403 \\
0.5403 & 0.85755 \\
0.85755 & 0.85755 \\
0.85755 & 0.65429 \\
0.65429 & 0.65429 \\
0.65429 & 0.79348 \\
0.79348 & 0.79348 \\
0.79348 & 0.70137 \\
0.70137 & 0.70137
\end{bmatrix}
\]

and dragging it to the frame. This matrix can be created from two copies of the column computed previously, modified appropriately, using Matrices > Concatenate. (See Concatenate and Stack Matrices, page 292 for details on concatenating matrices.)

**Newton’s Method**

The iteration method in the previous section can work very slowly. However, it provides the basis for Newton’s method, which is usually much faster than direct iteration. Newton’s method is based on the observation that the tangent line is a good local approximation to the graph of a function.

Let \((x_0, f(x_0))\) be a point on the graph of the function \(f\). The tangent line is given by the equation

\[
y - f(x_0) = f'(x_0)(x - x_0)
\]

This line crosses the \(x\)-axis when \(y = 0\). The corresponding value of \(x\) is given by

\[
x = x_0 - \frac{f(x_0)}{f'(x_0)}
\]

In general, given an approximation \(x_n\) to a zero of a function \(f(x)\), the tangent line at the point \((x_n, f(x_n))\) crosses the \(x\)-axis at the point...
Chapter 7 | Calculus

\[(x_{n+1}, 0)\] where

\[x_{n+1} = x_n - \frac{f(x_n)}{f'(x_n)}\]

The Newton iteration function for a function \(f\) is the function \(g\) defined by

\[g(x) = x - \frac{f(x)}{f'(x)}\]

Given a first approximation \(x_0\), Newton's method produces a list \(x_1, x_2, \ldots, x_n\) of approximations to a zero of \(f\). In the graph, \(f(x) = x - x^3\), \(x_0 = 0.44, x_1 \approx -0.41, x_2 \approx 0.27\), and \(x_3 \approx -0.048\).

This figure can be generated by plotting \(x - x^3\) as usual, zooming in to change the viewing rectangle, then selecting the matrix

\[
\begin{bmatrix}
0.44 & 0 \\
0.44 & 0.90475 \\
-0.41 & 0 \\
-0.41 & 0.91712 \\
0.27 & 0 \\
0.27 & 0.96377 \\
-0.048 & 0 \\
-0.048 & 0.99885
\end{bmatrix}
\]

and dragging it to the frame.

You can use Newton's method to solve the equation \(x = \cos x\).

**Compute > Definitions > New Definition**

\[f(x) = x - \cos x\]
\[g(x) = x - \frac{f(x)}{f'(x)}\]

With Digits Rendered set at 20, you receive the vector of values shown below.

**Compute > Calculus > Iterate**

Expression \(g(x)\); Initial evaluation point 0.7; Number of iterates 5

- 0.73943649784805819543
- 0.7390851604651073986
- 0.73908513321516080562
- 0.73908513321516064166
- 0.73908513321516064166
These values converge to the display precision in four iterations. As a check, use Evaluate to verify that
\[
\cos(0.73908513321516064166) = 0.73908513321516064165
\]
A graph of \( y = \cos x \) and \( y = x \) displays the approximate solution to the equation \( x = \cos x \).

You can observe that there is only one solution, so you do not need to specify the interval for the solution. Type the equation \( \cos x = x \), leave the insert point in the equation, and choose Compute > Solve > Numeric.

\[\text{Compute} > \text{Solve} > \text{Numeric}\]
\[\cos x = x, \text{Solution}: \{ [x = 0.7390851332] \}\]

### Optimization

Many of the applications of differentiation involve finding a value of \( x \) that yields a local maximum or local minimum value of some function \( f(x) \). A good way to begin the investigation, when you know the function \( f(x) \) either implicitly or explicitly, is to examine a plot of the function.

A plot suggests that the function \( f(x) = \cos x + \sin 3x \) has numerous extreme values.

\[\text{Compute} > \text{Plot 2D} > \text{Rectangular}\]
\[\cos x + \sin 3x\]

You can locate extreme values by solving \( f'(x) = 0 \) with Solve > Numeric, since the function \( f(x) = \cos x + \sin 3x \) is everywhere differentiable.

\[\text{Compute} > \text{Solve} > \text{Numeric}\]
\[\frac{d}{dx}(\cos x + \sin 3x) = 0\]
\[\text{Solution: } \{ [x = 1.6833] \}\]

This calculation yields only one critical number, although the graph indicates many more. You can specify the interval for a solution by

Tip

A graph of \( y = \cos x \) and \( y = x \) displays the approximate solution to the equation \( x = \cos x \).

With the insert point near the point of intersection, press the left mouse button to view the coordinates.

Tip

For most purposes, we suggest using floating point coefficients for optimization problems. Although Compute > Solve > Exact will give symbolic solutions to equations with rational coefficients, for many equations the solutions are very long, full of nested radicals, and awkward to work with.

In these examples, Digits Rendered is set at 5 on the Tools > Preferences > Computation > Output dialog. See Appendix C “Customizing the Program for Computing” for details on changing this setting.
Chapter 7 | Calculus

placing the equation in a one-column matrix and entering a solution
interval in the second row.

Compute > Solve > Numeric
\[
\frac{d}{dx} (\cos x + \sin 3x) = 0, \text{ Solution: } [x = 0.4728]
\]
\(x \in (0, 2)\)

Another strategy is to give the function a floating point coefficient
and then use an exact method.

Compute > Definitions > New Definition
\[
f(x) = 1.0 \cos x + \sin 3x
\]

Compute > Solve > Exact
\[
f'(x) = 0, \text{ Solution: } \{6.2832k + z \mid k \in \mathbb{Z},
\]
\(z \in \{-2.6688, -1.4583, -0.58534, 0.47280, 1.6833, 2.5563\}\)

Indeed, the absolute minimum \(f(-2.6688) \approx -1.8787\) occurs
at \(x \approx -2.6688\) (and at \(-2.6688 + 2\pi n\) for any integer \(n\)), and the
absolute maximum \(f(0.4728) \approx 1.8787\) occurs at \(x \approx 0.4728\) (and
at \(0.4728 + 2\pi n\) for any integer \(n\)).

Example The extreme values of \(y = x^3 - 5x + 1\) can be found directly.

Compute > Calculus > Find Extrema
\[
x^3 - 5x + 1, \text{ Candidate(s) for extrema: } \left\{\frac{10}{9}\sqrt{15} + 1, -\frac{10}{9}\sqrt{15} + 1\right\},
\]
at \[\left\{\left[x = \frac{1}{3}\sqrt{15}\right], \left[x = -\frac{1}{3}\sqrt{15}\right]\right\}\]

Floating-point coefficients produce floating-point approximations.
Thus, applying Find Extrema to \(x^3 - 5.0x + 1.0\) gives numerical approximations to the extreme values.

Compute > Calculus > Find Extrema
\[
x^3 - 5.0x + 1.0 \text{ Candidate(s) for extrema: } \{-3.3033, 5.3033\},
\]
at \{\[x = -1.2910\], \[x = 1.2910\]\}

Geometrically, the points \((-1.291, 5.3033)\) and \((1.291, -3.3033)\)
represent a high point and a low point, respectively.
Differentiation

Example
To find the minimum distance between the point \((-2, 2.25)\) and the graph of the function \(f(x) = \cos 3x - \sin 2x\), first plot the graph of \(f\) on the interval \(-5 \leq x \leq 1\) and drag the point \((-2, 2.25)\) and the circle \((-2 + 2 \cos 2\pi x, 2.25 + 2 \sin 2\pi x)\) with center \((-2, 2.25)\) and radius 2 to the plot frame. The plot shows that there are three regions of the graph of \(f\) that are all roughly a distance 2 from the point \((-2, 2.25)\).

Let
\[
g(x) = \sqrt{(-2 - x)^2 + (2.25 - f(x))^2}
\]
denote the distance between the point \((-2, 2.25)\) and the point
(x, f(x)) on the graph of f. There are three candidates for a point on the graph of f closest to the point (−2, 2.25). Locate a minimum value of g by setting the derivative equal to 0 and solving numerically in appropriate intervals.

**Compute > Solve > Numeric**

\[ g'(x) = 0 \]

Solution: \[ x = -3.8667 \]

\[ g'(x) = 0 \]

Solution: \[ x = -1.9212 \]

\[ g'(x) = 0 \]

Solution: \[ x = -0.3959 \]

Compare these trial solutions to locate the minimum.

**Compute > Evaluate Numeric**

\[ g(-3.8667) \approx 1.9898 \quad g(-1.9212) \approx 2.0283 \quad g(-0.3959) \approx 1.9823 \]

The minimum distance is 1.9823.

**Curve Sketching**

A default plot may well obscure some of the subtle, and even not so subtle, detail of a plot. You may need to adjust both the domain and the range to obtain a useful plot. For example, let us examine the graph of the function \( f(x) = x^2 - 20x + 100 \). In the default plot, a decreasing curve is visible, not giving much clue about the overall shape of the graph.

**Tip**

For a better ideal about the overall shape of the graph, experiment with plot intervals such as \( 0 \leq x \leq 20 \) to get the view.

As a striking example of frustration, the first attempt at plotting the equation \( 7x^2 + 36xy - 50y^2 + 594x - 2363y - 26500 = 0 \) will not create a visible plot because there are no points on the graph in the

222
When feasible, the view of a graph should be adjusted so that the points where these extreme values occur are included in the view. Zooming and panning can help you to accomplish this.

To locate the relative extreme values of a graph
- Solve $f'(x) = 0$.

In the following example, we locate extreme values of the function

$$f(x) = \frac{x^6 - 5x^3 + 10x^2 - 40x}{(x^2 - 4)^2}$$

The default plot of this expression gives a good view of the three extreme values.

You can find the points where extreme values might occur with Solve.

You can find approximate real roots of this seventh-degree polynomial with Numeric from the Solve submenu. In the following, Digits
Chapter 7 | Calculus

Rendered is set at 5 on the Output page of the Tools > Computation dialog box.

**Compute > Solve > Numeric**

\[2(-40Z + 90Z^2 - 10Z^3 + \frac{5}{2}Z^4 - 12Z^5 + Z^7 + 80)\]

Solution: \{[Z = 2.2359], [Z = 3.0327], [Z = -3.8864],

\[Z = -0.90484 + 1.6422i], [Z = -0.90484 - 1.6422i],

\[Z = 0.21375 - 0.90433i], [Z = 0.21375 + 0.90433i]\}

The three real roots of \(f'\) give two local minimums: \(f(-3.8864) = 32.812\) and \(f(3.0327) = 22.553\), and one local maximum: \(f(2.2359) = 29.656\).

You can gain additional insight into the graph of a rational function by rewriting it as a polynomial plus a fraction.

**Compute > Polynomials > Divide**

\[
\frac{x^6 - 5x^3 + 10x^2 - 40x}{(x^2 - 4)^2} = x^2 - \frac{5x^3 - 58x^2 + 40x + 128}{(x^2 - 4)^2} + 8
\]

Select and drag the polynomial \(x^2 + 8\) to the plot to see both curves in the same picture. Note how well the graph of \(y = x^2 + 8\) matches the graph of \(y = f(x)\) for large values of \(x\).

**Compute > Plot 2D > Rectangular**

\[
\frac{x^6 - 5x^3 + 10x^2 - 40x}{(x^2 - 4)^2} \text{ and } x^2 + 8
\]

To determine concavity of a graph

- Find intervals where the second derivative is positive or negative.
Differentiation

To locate the intervals where the graph of \( f(x) = x^4 + 3x^3 - x^2 - 3x \) is concave upward, evaluate \( f''(x) \) to obtain \( f''(x) = 12x^2 + 18x - 2 \), and solve the inequality \( 12x^2 + 18x - 2 > 0 \).

### Compute > Solve > Exact

\( 12x^2 + 18x - 2 > 0 \)

Solution: \((-\infty, -\frac{1}{\sqrt{36}} \sqrt{35\sqrt{48} - \frac{3}{4}}) \cup (\frac{1}{\sqrt{36}} \sqrt{35\sqrt{48} - \frac{3}{4}, \infty})\)

To solve more complicated inequalities or systems of inequalities, you can set expressions equal to zero and test for sign changes. One way to answer the question of where the graph of

\[
f(x) = \frac{x^6 - 5x^3 + 10x^2 - 40x}{(x^2 - 4)^2}
\]

is concave upward is to find the sign of the second derivative.

### Compute > Definitions > New Definition

\[
f(x) = \frac{x^6 - 5x^3 + 10x^2 - 40x}{(x^2 - 4)^2}
\]

Apply Evaluate and Factor to find the second derivative as the quotient of two polynomials.

### Compute > Evaluate, Compute > Factor

\[
f''(x) = \frac{2(x^8 - 16x^6 - 5x^5 + 270x^4 - 400x^3 + 320x^2 - 1200x + 160)}{(x - 2)^4(x + 2)^4}
\]

Since the denominator is always nonnegative, it is sufficient to investigate the sign of the numerator. Apply Solve > Numeric to the equation

\[0 = x^8 - 16x^6 - 5x^5 + 270x^4 - 400x^3 + 320x^2 - 1200x + 160\]

to find the real solutions

\[[x \approx 0.13759], [x \approx 2.3414]\]

Compute the value at any point to the left, between, and to the right of these solutions, using Evaluate Numeric:

\[
\begin{align*}
  f''(0) & \approx 1.25 \\
  f''(1) & \approx -21.481 \\
  f''(2.4) & \approx 40.964
\end{align*}
\]
Chapter 7 | Calculus

Taking into account the vertical asymptotes, the graph is concave upward on the intervals \((-\infty, -2), (-2, 0.1376)\), and \((2.3414, \infty)\), and concave downward on the intervals \((0.13759, 2)\) and \((2, 2.3414)\).

**Indefinite Integration**

An antiderivative of a function \(f(x)\) is any function \(g(x)\) whose derivative is \(f(x)\). If \(g(x)\) is an antiderivative of \(f(x)\), then \(g(x) + C\) is another antiderivative. In fact, every antiderivative is of the form \(g(x) + C\) for some constant \(C\).

The indefinite integral of \(f(x)\) is the family of all antiderivatives of \(f(x)\) and is denoted \(\int f(x)\,dx\).

**To evaluate an indefinite integral**

- Place the insert point anywhere in an integral and choose Evaluate.

**Compute > Evaluate**

\[
\int (2x^2 + 3x + 5)\,dx = \frac{1}{6}x(4x^2 + 9x + 30)
\]

The system does not automatically return the constant of integration—often called the arbitrary constant—so you must remain alert and add the constant when needed. Simply type \(+ C\) to change from

\[
\int (2x^2 + 3x + 5)\,dx = \frac{2}{3}x^3 + \frac{3}{2}x^2 + 5x
\]

to

\[
\int (2x^2 + 3x + 5)\,dx = \frac{2}{3}x^3 + \frac{3}{2}x^2 + 5x + C
\]

Such constants are needed, for example, if you have a formula for acceleration and you want to find an expression for velocity.

You can evaluate indefinite integrals of piecewise-defined functions. You can define a function from a piecewise expression, or work directly with the piecewise expression, as shown in the following examples. Turn on Helper Lines to see the null brackets on the right.

**Spacing**

It is common, although hardly necessary, to add a thin space between \(f(x)\) and \(dx\) in an integral \(\int f(x)\,dx\). The Thin Space (found under Insert + Spacing + Horizontal Space) is for readability only, and in no way affects the way in which an integral is interpreted by the underlying computing engine.

**Compute > Definitions > New Definition**

\[f(x) = \begin{cases} 
  x & \text{if } x < 0 \\
  3x^2 & \text{if } x \geq 0
\end{cases}\]
Indefinite Integration

\[ \int f(x) \, dx = \begin{cases} \frac{1}{2}x^2 & \text{if } x \leq 0 \\ \frac{1}{3}x^3 & \text{if } 0 < x \end{cases} \]

\[ \int \begin{cases} x & \text{if } x < 0 \\ 3x^2 & \text{if } x \geq 0 \end{cases} \, dx = \begin{cases} \frac{1}{2}x^2 & \text{if } x \leq 0 \\ \frac{1}{3}x^3 & \text{if } 0 < x \end{cases} \]

Interpreting an Expression

The computer algebra system interprets many expressions that might be considered ambiguous. You can check the interpretation without evaluating an expression.

To interpret an expression without evaluation:

- Place the insert point in the expression and choose Compute > Interpret.

\[ \frac{xy}{z} = \frac{y}{z} \quad f(ax^3) = \int ax^3 \, d \
\sin \left( \frac{x}{y} \right) = \sin \left( \frac{1}{y} \right) \quad f(x^3 a) = \int x^3 a \, d \]

Even though the interpretations of the integral expressions do not indicate the variable of integration, they show that the expressions are interpreted as indefinite integrals. If such an expression is evaluated, a choice will be made, generally based on the alphabetical order of the characters.

\[ \int ax^3 = \frac{1}{4}ax^4 \quad \int yx^3 = \frac{1}{4}x^4 y \]

\[ \int x^3 a = \frac{1}{4}ax^4 \quad \int x^3 y = \frac{1}{4}x^4 y \]

If \( f \) is not defined as a function, then it is treated as a variable or constant.

\[ \int f(x) \, dx = \frac{1}{2}fx^2 \]

In these expressions, \( f \) behaves the same as any other variable, and \( f(x) \) is interpreted as simply the product of \( f \) and \( x \).
Methods of Integration

Even though you can evaluate many integrals directly, several standard techniques of integration—such as integration by parts, change of variables by substitution, and partial fractions—are also available in Scientific WorkPlace and Scientific Notebook. These techniques were necessary before computational systems were available, and are still important to the understanding of calculus.

Integration by Parts

The integration by parts formula states that

\[ \int u \, dv = uv - \int v \, du \]

This formula comes from the product formula for differentials

\[ d(\ uv) = u\ dv + v\ du \]

and the linearity of integration, which implies that

\[ \int d(\ uv) = \int u\ dv + \int v\ du \]

and the fundamental theorem of calculus, which allows you to replace \( \int d(\ uv) \) by \( uv \) in the formula for integration by parts.

To use integration by parts

1. Place the insert point in an integral.
2. Choose Compute > Calculus > Integrate by Parts.
3. In the dialog box, type an appropriate expression for the Part to Differentiate.
4. Choose OK.

For the integral \( \int x \ln x \, dx \), for example, choosing \( \ln x \) for the Part to Differentiate gives the following result:

\[
\text{Compute} > \text{Calculus} > \text{Integrate by Parts} \text{ (Part to Differentiate: } \ln x )
\]

\[ \int x \ln x \, dx = \frac{1}{2} x^2 \ln (x) - \int \frac{1}{2} x \, dx \]

Since \( \int \frac{1}{2} x \, dx \) can easily be integrated, this solves the problem of integrating \( x \ln x \). Note that in this example, \( u = \ln x \) and \( dv = x \, dx \), so that \( du = \frac{1}{x} \, dx \) and \( v = \frac{1}{2} x^2 \).
Change of Variable

It follows from the chain rule that if $u = g(x)$, then $du = g'(x)\,dx$. This yields the change of variable formula for integration:

$$\int f(g(x))g'(x)\,dx = \int f(u)\,du$$

To perform a change of variable

1. Enter the integral $\int x\sin x^2 \,dx$.
2. Choose Compute $>$ Calculus $>$ Change Variable.
3. In the dialog box, type an appropriate substitution $u = g(x)$.
4. Choose OK.

For the integral $\int x\sin x^2 \,dx$, the substitution $u = x^2$ gives the following:

Compute $>$ Calculus $>$ Change Variable

(Expression for $u$: $x^2$)

$$\int x\sin x^2 \,dx = \int \frac{1}{2}\sin(u) \,du$$

This replaces the problem of integrating $x\sin x^2$ by two much easier problems: first integrating $\frac{1}{2}\sin u$ and then replacing $u$ by $x^2$ in the result. Note that $u = g(x) = x^2$, $f(u) = \sin u$, and $du = 2x\,dx$.

For the integral $\int x^5\sqrt{x^3+1} \,dx$, the substitution $u = x^3 + 1$ is useful.

Compute $>$ Calculus $>$ Change Variable

(Expression for $u$: $x^3 + 1$)

$$\int x^5\sqrt{x^3+1} \,dx = \int \frac{1}{3}\sqrt{u}(u-1) \,du$$

Then do an in-place replacement with $u = x^3 + 1$:

$$\frac{2}{15}u^{5/2} - \frac{2}{9}u^{3/2} = \frac{2}{15}(x^3 + 1)^{5/2} - \frac{2}{9}(x^3 + 1)^{3/2}$$
Partial Fractions

The method of partial fractions is based on the fact that a factorable rational function can be written as a sum of simpler fractions. Notice how evaluation of the following integral gives the answer as a sum of terms.

\[
\int \frac{3x^2 + 2x + 4}{(x-1)(x^2 + 1)} \, dx = \frac{9}{2} \ln(x - 1) - \frac{x}{2} + \frac{1}{4} \ln \left( \frac{3}{4} + \frac{1}{4} \right) - \frac{x}{2} + \frac{1}{4} \ln \left( \frac{3}{4} - \frac{1}{4} \right)
\]

To gain an appreciation for how this calculation might be done internally, consider the method of partial fractions.

To use the method of partial fractions

- Replace a rational function by its partial fractions expansion before carrying out its integration.

Example  Here is how you use this method on the integral \( \int \frac{3x^2 + 2x + 4}{(x-1)(x^2 + 1)} \, dx \).

1. Enter the rational expression \( \frac{3x^2 + 2x + 4}{(x-1)(x^2 + 1)} \).

2. With the insert point in this expression, choose Compute > Calculus > Partial Fractions or choose Compute > Polynomials > Partial Fractions.

\[
\frac{3x^2 + 2x + 4}{(x-1)(x^2 + 1)} = \frac{9}{2(x-1)} - \frac{3x - 1}{x^2 + 1}
\]

Thus

\[
\int \frac{3x^2 + 2x + 4}{(x-1)(x^2 + 1)} \, dx = \int \left( \frac{9}{2(x-1)} - \frac{3x - 1}{x^2 + 1} \right) \, dx
\]

3. Write the preceding integral as a sum of three integrals.

\[
\int \frac{9}{2(x-1)} \, dx - \frac{3}{2} \int \frac{x}{x^2 + 1} \, dx + \frac{1}{2} \int \frac{1}{x^2 + 1} \, dx
\]
4. Evaluate each of these integrals.

\[ \int \frac{9}{2(x-1)} \, dx = \frac{9}{2} \ln(x-1) \]
\[ -\frac{3}{2} \int \frac{x}{x^2+1} \, dx = -\frac{3}{4} \ln(x^2+1) \]
\[ \frac{1}{2} \int \frac{1}{x^2+1} \, dx = \frac{1}{2} \tan^{-1}(x) \]

5. The original integral is the sum of the expressions above on the right,

\[ \int \frac{3x^2 + 2x + 4}{(x-1)(x^2+1)} \, dx = \frac{9}{2} \ln(x-1) - \frac{3}{4} \ln(x^2+1) + \frac{1}{2} \tan^{-1}x - \frac{1}{4} \pi \]

which differs from the answer previously computed directly with Evaluate only by a constant.

**Definite Integrals**

The definite integral \( \int_{a}^{b} f(x) \, dx \) of a function \( f(x) \) defined on the interval \([a, b]\) is given by

\[ \int_{a}^{b} f(x) \, dx = \lim_{\|P\| \to 0} \sum_{i=1}^{n} f(\bar{x}_i) \Delta x_i \]

where \( \bar{x}_i \) is a point in the \( i \)th subinterval of the partition

\[ P = \{ a = x_0 < x_1 < x_2 < \cdots < x_n = b \} \]

of the interval \([a, b]\), \( \Delta x_i = x_i - x_{i-1} \), and \( \|P\| = \max \{ \Delta x_i \} \). The sum

\[ \sum_{i=1}^{n} f(\bar{x}_i) \Delta x_i \]

is called a Riemann sum. The function \( f \) is integrable on \([a, b]\) if the preceding limit exists.

If \( f \) is integrable on \([a, b]\), then

\[ \int_{a}^{b} f(x) \, dx = \lim_{n \to \infty} \frac{b-a}{n} \sum_{i=1}^{n} f \left( a + \frac{b-a}{n} \right) \]
In particular, if \( f \) is continuous on \([a, b]\), then \( f \) is integrable on \([a, b]\).

For positive-valued functions \( f \), the sum

\[
\frac{b-a}{n} \sum_{i=1}^{n} f \left( a + \frac{b-a}{n} i \right)
\]

can be interpreted as the sum of areas of rectangles of base \( \frac{b-a}{n} \) with height determined by the value of the function \( f \) at right endpoints of subintervals. For example, assume \( a = -1, b = 1, n = 10 \), and \( f(x) = \frac{1}{x^2+1} \). Then

\[
\frac{1-(-1)}{10} \sum_{i=1}^{n} f \left( -1 + i \frac{1-(-1)}{10} \right)
\]

represents the sum of the areas of the 10 rectangles in the figure. (See Left and Right Boxes, page 240, for a discussion of Riemann sums using left and right boxes.)

### Entering and Evaluating Definite Integrals

#### To enter a definite integral
1. Choose Insert > Math Objects > Operator and choose \( \int \).
2. Choose Insert > Math Objects > Subscript, and type the lower limit.
3. Press tab and type the upper limit of integration. (Limits of integration work the same as any other subscripts or superscripts.)
4. Press the spacebar or the right arrow to move out of the superscript, and type the rest of the expression.

#### To evaluate a definite integral
- Leave the insert point in the expression and choose Evaluate or Evaluate Numeric.

Compute > Evaluate
\[
\int_{0}^{1} x^2 \sqrt{x^3+1} \, dx = \frac{3}{4} \sqrt{2} - \frac{2}{3}
\]

Compute > Evaluate Numeric
\[
\int_{0}^{1} x^2 \sqrt{x^3+1} \, dx \approx 0.40632
\]
Integrals involving absolute values or piecewise-defined functions can be treated as any other function.

Compute \( \int_{-2}^{2} |x^2 - 1| \, dx = 4 \)

To understand this computation, determine the intervals for which \( x^2 - 1 \) is positive or negative, and write the integral as a sum of several integrals with the absolute value sign removed.

Compute \( \int_{-1}^{1} (1 - x^2) \, dx = 4 \) \( \int_{1}^{2} (x^2 - 1) \, dx = 4 \) \( \int_{-2}^{-1} (x^2 - 1) \, dx = 4 \)

You can find the definite integral of a piecewise function either by integrating the expression directly or by defining a piecewise function \( f(x) \).

Compute \( \int_{-2}^{2} f(x) \, dx = \frac{43}{3} \)

To understand this computation, write the integral as a sum of integrals involving ordinary functions. This yields

\[
\int_{-2}^{2} f(x) \, dx = \int_{-2}^{0} x^2 \, dx + \int_{0}^{3} x \, dx = \frac{8}{3} + \frac{9}{2} = \frac{43}{6}
\]
Chapter 7 | Calculus

Methods of Integration with Definite Integrals

Methods that were introduced for indefinite integration—in- tegration by parts, change of variables, and partial fractions—can also be applied to definite integrals. See Methods of Integration, page 228 for general details about these methods.

To integrate by parts with a definite integral
1. Place the insert point in a definite integral.
2. Choose Compute > Calculus > Integrate by Parts.
3. Type in the dialog box an appropriate expression for the Part to Differentiate.
4. Choose OK.

\[
\int_{1}^{2} \ln(x) \, dx = \ln(2) - \frac{1}{2} \ln(1) = \ln(2)
\]

To use a change of variables with a definite integral
1. Place the insert point in a definite integral.
2. Choose Compute > Calculus > Change Variable.
3. Type in the dialog box an Expression for \( u \), and choose OK.

\[
\int_{1}^{2} \sqrt{x^2 + 1} \, dx = \int_{1}^{3} \frac{1}{2} \sqrt{u} \, du
\]

This gives an integral that can be computed by elementary methods. Note that the limits have changed to match the new variable.

To use partial fractions with a definite integral
- Replace a rational expression with its partial fractions expansion.

\[
\frac{3x^2 + 2x + 4}{(x-1)^2} = \frac{8}{x-1} + \frac{9}{(x-1)^2} + 3
\]
Deönite Integrals

\[ \int_3^7 \frac{3x^2 + 2x + 4}{(x - 1)^2} \, dx = \int_3^7 3 \, dx + \int_3^7 \frac{9}{(x - 1)^2} \, dx + \int_3^7 \frac{8}{x - 1} \, dx = 12 + 3 + 8 \ln 3 \]

Improper Integrals

If the proper integral \( \int_a^b f(x) \, dx \) exists for every \( b \geq a \), the limit

\[ \int_a^\infty f(x) \, dx = \lim_{b \to \infty} \int_a^b f(x) \, dx \]

defines an improper integral of the first kind. The integral is said to converge if this limit exists and is finite.

To compute an improper integral of the first kind

- Place the insert point in the integral and choose Evaluate or Evaluate Numeric.

\[
\begin{align*}
\int_1^\infty x^{-2} \, dx & = 1 & \int_1^\infty x^{-1} \, dx & = \infty \\
\int_0^\infty e^{-3x} \, dx & = \frac{1}{3} & \int_{-\infty}^0 e^{-3x} \, dx & = \infty \\
\int_{-\infty}^\infty e^{-x^2} \, dx & = \sqrt{\pi} & \int_0^\infty \sin x \, dx & = \text{undefined}
\end{align*}
\]

To evaluate an improper integral of the second kind

1. Place the insert point in the integral.
Chapter 7 | Calculus

2. Choose Compute > Evaluate. or

Compute > Evaluate Numeric.

**Compute > Evaluate**

\[ \int_0^1 \ln x \, dx = -1 \]

If \( f \) has a discontinuity at a point \( c \), and both \( \int_a^c f(x) \, dx \) and \( \int_c^b f(x) \, dx \) are convergent, then \( \int_a^b f(x) \, dx = \int_a^c f(x) \, dx + \int_c^b f(x) \, dx \).

If either diverges, then so does \( \int_a^b f(x) \, dx \).

**Compute > Evaluate**

\[
\begin{align*}
\int_1^3 \frac{dx}{x-1} &= \infty \\
\int_{1/2}^1 \frac{dx}{x-1} &= -\infty \\
\int_{-1}^1 \frac{dx}{x-1} &= \text{undefined}
\end{align*}
\]

If \( f \) is not defined when \( x = \cos x \). This improper integral is examined further in the exercises at the end of this chapter.

Use special care when working with improper integrals and make certain that answers look reasonable. Limits that straddle a discontinuity, such as \( \int_1^3 \frac{dx}{x-1} \) or \( \int_{-1}^{1/2} \frac{dx}{x-1} \), should be avoided entirely. The latter will take a very long time to return a result and then simply returns the form you entered. Any time the system appears to hang up like this, examine the expression for a discontinuity.

Note that the indefinite integral \( \int \frac{dx}{(x-\cos x)^2} \) produces a solution:

**Compute > Evaluate**

\[ \int \frac{1+\sin x}{(x-\cos x)^2} \, dx = -\frac{1}{x-\cos x} \]

A naive approach to this problem, namely computing the indefinite integral and evaluating at the endpoints,

\[ \left[ -\frac{1}{x-\cos x} \right]_{-\pi}^\pi = -\frac{1}{\pi-1} - \frac{1}{\pi+1} = -\frac{2\pi}{\pi^2 - 1} \]

gives an answer that is quite wrong. It is important to observe that the function \( \frac{1+\sin x}{(x-\cos x)^2} \) is not defined when \( x = \cos x \). This improper integral is examined further in the exercises at the end of this chapter.
Assumptions about Variables

The four functions assume, additionally, about, and unassume, were discussed in Chapter 5 “Function Definitions,” beginning on page 111. We review this topic briefly to add an example of their application in calculus. The function assume enables you to place a restraint on a specific variable or on all variables. The function additionally allows you to place additional restraints on the same variable. The function about shows which restraints are active. The function unassume removes restraints.

Consider the following integral.

\[ \int_0^1 x^{2n-1} \, dx = \begin{cases} \frac{1}{2n} & \text{if } n \neq 0 \\ \infty & \text{if } n = 0 \end{cases} \]

This integral cannot be computed with no restraints because it converges for \( n \geq 0 \), but fails to converge for \( n < 0 \). You can evaluate this integral after applying the function “assume” to restrict possible values of \( n \).

\[ \text{Assume}(n, \text{positive}) = (0, \infty) \]

\[ \int_0^1 x^{2n-1} \, dx = \frac{1}{2n} \]

The available assumptions on variables include real, complex, integer, positive, negative, and nonzero. When typed in mathematics mode, these function names turn upright and gray. These assumptions can be made locally (for a specific variable) or globally. Additional information about making assumptions is available on page 111.

Definite Integrals from the Definition

You can use text editing and computing in place to fill in the steps for finding definite integrals from the definition.

**Example** Define \( f \) by the equation \( f(x) = x^3 \). Calculate the integral \( \int_1^4 f(x) \, dx \) as follows.

1. Enter the equation

\[ \int_1^4 f(x) \, dx = \lim_{n \to \infty} \sum_{i=1}^{n} f \left( 1 + i \frac{4-1}{n} \right) \frac{4-1}{n} \]
Chapter 7 | Calculus

2. Select the term to the right of the summation sign.

3. Press and hold down the Ctrl key and choose Compute > Evaluate, then choose Compute > Factor.

4. Select the series.

5. Press Ctrl+Evaluate, then choose Compute > Expand, then add parentheses.

6. With the insert point in the expression, choose Compute > Evaluate.

These steps produce the following sequence of expressions:

\[
\int_{1}^{4} f(x) \, dx = \lim_{n \to \infty} \sum_{i=1}^{n} f \left( 1 + i \frac{4 - 1}{n} \right) \frac{4 - 1}{n} \\
= \lim_{n \to \infty} \sum_{i=1}^{n} 3 \left( \frac{n + 3i}{n^4} \right) \\
= \lim_{n \to \infty} \left( \frac{189}{2n} + \frac{135}{4n^2} + \frac{255}{4} \right) \\
= \frac{255}{4}
\]

For comparison, you can compute this integral directly:

\[
\int_{1}^{4} x^3 \, dx = \frac{255}{4}
\]

Pictures of Riemann Sums

You can plot pictures of Riemann sums obtained from midpoints, left endpoints, or right endpoints of subintervals. The choices are Middle Boxes, Left Boxes, Right Boxes, and Left and Right Boxes.

Middle Boxes

The Riemann sum determined by the midpoints is given by

\[
\frac{b - a}{n} \sum_{i=0}^{n-1} f \left( a + \frac{b - a}{2n} + i \frac{b - a}{n} \right)
\]

which is the sum of the areas of rectangles whose heights are determined by midpoints of subintervals.
Deönite Integrals

To make a Middle Boxes plot
1. Place the insert point inside the expression you want to plot.
2. Choose > Compute > Calculus > Plot Approximate Integral. A Middle Boxes plot will appear with default interval settings.
3. Click the plot to select the frame, or double-click the plot to select the view.
4. Choose Edit > Properties and select the Items Plotted page.
   a. Reset Number of Boxes as desired.
   b. Choose Variables and Intervals and reset the Plot Interval as desired.
5. Choose OK twice to close the dialog.

Example The following Middle Boxes plot uses $0 < x < 7$ and Number of Boxes is 6.

\[ \text{Compute} > \text{Calculus} > \text{Plot Approximate Integral} \]
\[ \sin 3x + 3 \cos x \]
\[ \text{Edit} > \text{Properties} \text{(Reset Number of Boxes and Plot Interval)} \]

For the expression $\sin 3x + 3 \cos x$, with six rectangles and limits $-1$ and 7, the approximating Middle Boxes Riemann sum is as follows:

\[ \text{Compute} > \text{Calculus} > \text{Approximate Integral} \]
(Formula: Midpoint; Subintervals: 6; Lower Bound: -1; Upper Bound: 7)
\[ \sin 3x + 3 \cos x \]
Approximate integral (midpoint rule) is $\frac{4}{3} \sum_{i=0}^{5} \left( \sin (4i - 1) + 3 \cos \left( \frac{4i - 1}{3} \right) \right)$
Chapter 7 | Calculus

Compare with the actual value:

Compute > Evaluate Numeric

\[
\frac{4}{3} \sum_{i=0}^{5} (\sin (4i/3 - 1) + 3 \cos (\frac{4}{3}i/3 - \frac{1}{3})) \approx 4.5222 \\
\int_{-1}^{7} (\sin 3x + 3 \cos x) \, dx \approx 4.3480
\]

Left Boxes and Right Boxes

In general, the left endpoint approximation \( L_n \) for \( \int_{a}^{b} f(x) \, dx \) with \( n \) subdivisions is given by

\[
\int_{a}^{b} f(x) \, dx \approx L_n = \frac{b-a}{n} \sum_{i=0}^{n-1} f \left( a + i \frac{b-a}{n} \right)
\]

and the right endpoint approximation \( R_n \) for \( \int_{a}^{b} f(x) \, dx \) with \( n \) subdivisions is given by

\[
\int_{a}^{b} f(x) \, dx \approx R_n = \frac{b-a}{n} \sum_{i=1}^{n} f \left( a + i \frac{b-a}{n} \right)
\]

To make a Left [Right] Boxes plot

1. Place the insert point inside the expression to be plotted.

2. Choose Compute > Calculus > Plot Approximate Integral. A Middle Boxes plot will appear with default range settings.

3. Click the plot to select the frame, or double-click the plot to select the view.

4. Choose Edit > Properties and select the Items Plotted page.

   a. Check Left [Right] Boxes. Reset the number of boxes as desired.

   b. Choose Variables and Intervals and reset the Plot Interval as desired.

   c. Select Show Info option (No Info, Approximated Value, Approximated and Exact Values, Both Values and Error)

5. Choose OK twice to close the dialog.
For the expression $\sin 3x + 3 \cos x$, with six rectangles and $-1 \leq x \leq 7$, the approximating Left [Right] Riemann sums are

$$\frac{4}{3} \sum_{k=0}^{5} \left( \sin \left( 3 \left(-1 + \frac{4}{3}k \right) \right) + 3 \cos \left(-1 + \frac{4}{3}k \right) \right) \approx 2.8647 \text{ (Left)}$$

$$\frac{4}{3} \sum_{k=1}^{6} \left( \sin \left( 3 \left(-1 + \frac{4}{3}k \right) \right) + 3 \cos \left(-1 + \frac{4}{3}k \right) \right) \approx 5.0228 \text{ (Right)}$$

**Upper Boxes and Lower Boxes**

An upper [lower] Riemann sum is given by

$$\int_{a}^{b} f(x) \, dx \approx \sum_{i=1}^{n} f(\bar{x}_i) \Delta x_i$$

where $\bar{x}_i$ is a point in the $i$th subinterval $x_{i-1} \leq x \leq x_i$ of the partition

$$P = \{a = x_0 < x_1 < x_2 < \cdots < x_n = b\}$$
such that \( f(\bar{x}_i) = \max \{ f(x) \mid x_{i-1} \leq x \leq x_i \} \) and \( f(\bar{x}_i) = \min \{ f(x) \mid x_{i-1} \leq x \leq x_i \} \).

To make a plot of an upper [lower] sum

1. Place the insert point inside the expression to be plotted.

2. Choose Compute > Calculus > Plot Approximate Integral. A Middle Boxes plot will appear with default range settings.

3. Open the Graph User Settings dialog.
   a. Check Upper [Lower] Boxes. Reset the number of boxes as desired.
   b. Choose Variables and Intervals and reset the Plot Interval as desired.
   c. Select desired Plot Info.

4. Choose OK twice to close the dialog.

Compute > Calculus > Plot Approximate Integral

\[ \sin 3x + 3 \cos x \]

(Formula: Lower [Upper, Both] Boxes; Subintervals: 6; Lower Bound: -1; Upper Bound: 7)
**Upper Absolute and Lower Absolute Boxes**

An upper [lower] absolute Riemann sum is given by

\[
\int_{a}^{b} f(x) \, dx \approx \sum_{i=1}^{n} f(\bar{x}_i) \Delta x_i
\]

where \(\bar{x}_i\) is a point in the \(i\)th subinterval \(x_{i-1} \leq x \leq x_i\) of the partition

\[
P = \{ a = x_0 < x_1 < x_2 < \cdots < x_n = b \}
\]

such that

\[
|f(\bar{x}_i)| = \max \{ |f(x)| : x_{i-1} \leq x \leq x_i \}
\]

\[
|f(\bar{x}_i)| = \min \{ |f(x)| : x_{i-1} \leq x \leq x_i \}.
\]

**To make a plot of an upper [lower] absolute sum**

1. Place the insert point inside the expression to be plotted.

2. Choose Compute > Calculus > Plot Approximate Integral. A Middle Boxes plot will appear with default range settings.

3. Open the Graph User Settings dialog.

   a. Check Upper [Lower] Absolute Boxes. Reset the number of boxes as desired.

   b. Choose Variables and Intervals and reset the Plot Interval as desired.

   c. Select desired Plot Info.

4. Choose OK twice to close the dialog.
Chapter 7 | Calculus

**Compute > Calculus > Plot Approximate Integral**

\(\sin 3x + 3\cos x\)

(Formula: Lower [Upper, Both] Absolute; Subintervals: 6; Lower Bound: -1; Upper Bound: 7)

![Riemann Lower Abs: 1.29](image1)

![Riemann Upper Abs: 5.87](image2)

**Trapezoidal Sums**

The formula for the trapezoid rule approximation \(T_n\) is given by

\[
\int_a^b f(x) \, dx \approx T_n = \frac{b - a}{2n} \left( f(a) + 2 \sum_{i=1}^{n-1} f \left( a + i \frac{b - a}{n} \right) + f(b) \right)
\]

with an error bound of

\[
\left| T_n - \int_a^b f(x) \, dx \right| \leq K \frac{(b-a)^3}{12n^2}
\]

where \(K\) is any number such that \(|f''(x)| \leq K\) for all \(x \in [a, b]\).

**To make a trapezoid plot**

1. Place the insert point inside the expression to be plotted.
2. Choose Compute > Calculus > Plot Approximate Integral. A Middle Boxes plot will appear with default range settings.
3. Open the Graph User Settings dialog.
   a. Check Approximation Method: Trapezoid. Reset the number of boxes as desired.
   b. Choose Variables and Intervals and reset the Plot Interval as desired.
   c. Select desired Plot Info.

4. Choose OK twice to close the dialog.

**Compute > Calculus > Plot Approximate Integral**

\[ \sin 3x + 3 \cos x \]

(Formula: Trapezoid; Subintervals: 6; Lower Bound: -1; Upper Bound: 7)

\[ \text{Trapezoid: 3.94} \]

**Simpson’s Rule**

Simpson’s rule gives the approximation \( S_n \) (\( n \) an even positive integer) for an arbitrary function \( f \) by

\[
\int_a^b f(x) \, dx \approx S_n = \frac{b-a}{3n} \left( f(a) + f(b) + 4 \sum_{i=1}^{n/2} f \left( a + (2i - 1) \frac{b-a}{n} \right) + 2 \sum_{i=1}^{1+n/2} f \left( a + 2i \frac{b-a}{n} \right) \right)
\]

The error bound for Simpson’s rule is given by

\[
\left| S_n - \int_a^b f(x) \, dx \right| \leq K \frac{(b-a)^5}{180n^4}
\]

where \( K \) is any number such that \( |f^{(4)}(x)| \leq K \) for all \( x \in [a, b] \). In particular, Simpson’s rule is exact for integrals of polynomials of degree at most 3 (because the fourth derivative of such a polynomial is identically zero).
Chapter 7 | Calculus

To make a Simpson plot

1. Place the insert point inside the expression to be plotted.

2. Choose Compute > Calculus > Plot Approximate Integral. A Middle Boxes plot will appear with default range settings.

3. Open the Graph User Settings dialog.
   a. Check Approximation Method: Trapezoid. Reset the number of boxes as desired.
   b. Choose Variables and Intervals and reset the Plot Interval as desired.
   c. Select desired Plot Info.

4. Choose OK twice to close the dialog.

Compute > Calculus > Plot Approximate Integral

\[ \sin 3x + 3 \cos x \]  
(Formula: Simpson; Subintervals: 6; Lower Bound: -1; Upper Bound: 7)

Simpson: 4.33

Approximation Methods

You can use the midpoint method, the trapezoidal rule, and Simpson’s rule for approximating definite integrals. To apply each of these approximation methods, place the insert point in a mathematical expression, choose Compute > Calculus > Approximate Integral, and then choose the appropriate method in the dialog box.

Midpoint Rule

In general, the midpoint approximation \( M_n \) for \( \int_a^b f(x) \, dx \) with \( n \) subdivisions is given by

\[
\int_a^b f(x) \, dx \approx M_n = \frac{b-a}{n} \sum_{i=0}^{n-1} f \left( a + \frac{b-a}{2n} + i\frac{b-a}{n} \right)
\]
with an error bound of
\[ |M_n - \int_a^b f(x) \, dx| \leq K \frac{(b-a)^3}{24n^2} \]

where \( K \) is any number such that \(|f''(x)| \leq K\) for all \( x \in [a, b] \).

**To approximate \( \int_a^b f(x) \, dx \) using the midpoint method**

1. Place the insert point in an expression of the form \( \int_a^b f(x) \, dx \).

2. Choose Compute > Calculus > Approximate Integral.

3. In the dialog that appears, choose Midpoint and specify the number of Subintervals.

   Or

1. Place the insert point in an expression \( f(x) \).

2. Choose Compute > Calculus > Approximate Integral.

3. In the dialog, choose Midpoint, specify the number of Subintervals, and specify Lower Bound and Upper Bound.

   To obtain the following output, in the dialog that appears, specify 10 Subintervals. The system returns a summation that you can evaluate numerically.

\[
\text{Compute > Calculus > Approximate Integral}
\]
\[
\int_0^\pi x \sin x \, dx \text{ Approximate integral (midpoint rule) is}
\]
\[
\frac{\pi}{10} \sum_{i=0}^{9} \frac{1}{10} \pi \left(i_3 + \frac{1}{2}\right) \sin \frac{1}{10} \pi \left(i_3 + \frac{1}{2}\right)
\]

   For the following output, specify 10 Subintervals, type 0 as Lower Bound, and type 3.14159 as Upper Bound.

\[
\text{Compute > Calculus > Approximate Integral}
\]
\[
x \sin x \text{ Approximate integral (midpoint rule) is}
\]
\[
0.31416 \sum_{i=0}^{9} (0.31416i_4 + 0.15708) \sin (0.31416i_4 + 0.15708)
\]

   Compare these results with direct computations of the integral.
Chapter 7 | Calculus

**Compute > Evaluate Numeric**

\[
\frac{1}{n} \pi \sum_{i=3}^{9} \frac{1}{n} \pi \left( i_3 + \frac{1}{2} \right) \sin \frac{1}{n} \pi \left( i_3 + \frac{1}{2} \right) \approx 3.1545
\]

\[
0.31416 \sum_{i=0}^{9} (0.31416i_4 + 0.15708) \sin (0.31416i_4 + 0.15708) \approx 3.1545
\]

\[
\int_0^\pi x \sin x \, dx \approx 3.1416
\]

**Left Boxes and Right Boxes**

In general, the left endpoint approximation \( L_n \) for \( \int_a^b f(x) \, dx \) with \( n \) subdivisions is given by

\[
\int_a^b f(x) \, dx \approx L_n = \frac{b-a}{n} \sum_{i=0}^{n-1} f\left( a + i \frac{b-a}{n} \right)
\]

and the right endpoint approximation \( R_n \) for \( \int_a^b f(x) \, dx \) with \( n \) subdivisions is given by

\[
\int_a^b f(x) \, dx \approx R_n = \frac{b-a}{n} \sum_{i=1}^{n} f\left( a + i \frac{b-a}{n} \right)
\]

**To approximate \( \int_a^b f(x) \, dx \) using left [right] boxes**

1. Place the insert point in the expression \( \int_a^b f(x) \, dx \).
2. Choose Compute > Calculus > Approximate Integral.
3. In the dialog that appears, choose Left [Right] Boxes and specify the number of Subintervals.
   Or
   1. Place the insert point in the expression \( f(x) \).
   2. Choose Compute > Calculus > Approximate Integral.
   3. In the dialog, choose Left [Right] Boxes, specify the number of Subintervals, and specify Lower Bound and Upper Bound.

For the following output, in the dialog that appears, select Left Boxes and specify 10 Subintervals. The system returns a summation that you can evaluate numerically.
Deönite Integrals

\[ \int_{0}^{\frac{\pi}{2}} x \sin x \, dx \]

Approximate integral is \( \frac{1}{20} \pi \sum_{i=0}^{9} \frac{1}{20} \pi i \sin \frac{1}{20} \pi i \)

For the following output, in the dialog that appears, select Right Boxes and specify 10 Subintervals.

\[ \int_{0}^{\frac{\pi}{2}} x \sin x \, dx \]

Approximate integral is \( \frac{1}{20} \pi \sum_{i=1}^{10} \frac{1}{20} \pi i \sin \frac{1}{20} \pi i \)

For the following output, specify Left Boxes, specify 10 Subintervals, and type 0 as Lower Bound and 1.5708 as Upper Bound.

\[ x \sin x \]

Approximate integral (left boxes) is 0.15708 \( \sum_{i=0}^{9} 0.15708 i \sin 0.15708 i \)

For the following output, specify Right Boxes, specify 10 Subintervals, and type 0 as Lower Bound and 1.5708 as Upper Bound.

\[ x \sin x \]

Approximate integral (right boxes) is 0.15708 \( \sum_{i=1}^{10} 0.15708 i \sin 0.15708 i \)

Evaluate numerically to compare these outputs with one another and with the integral.

\[ \frac{1}{20} \pi \sum_{i=1}^{9} \frac{1}{20} \pi i \sin \frac{1}{20} \pi i \approx 0.87869 \]
\[ \frac{1}{20} \pi \sum_{i=1}^{10} \frac{1}{20} \pi i \sin \frac{1}{20} \pi i \approx 1.1254 \]
\[ 0.15708 \sum_{i=0}^{9} 0.15708 i \sin 0.15708 i \approx 0.87869 \]
\[ 0.15708 \sum_{i=1}^{10} 0.15708 i \sin 0.15708 i \approx 1.1254 \]
\[ \int_{0}^{\frac{\pi}{2}} x \sin x \, dx \approx 1.0 \]

The left boxes underestimate this integral, and the right boxes overestimate it.
Chapter 7 | Calculus

Trapezoid Rule

The formula for the trapezoid rule approximation $T_n$ is given by

$$\int_a^b f(x)dx \approx T_n = \frac{b-a}{2n} \left( f(a) + 2 \sum_{i=1}^{n-1} f\left(a + \frac{i(b-a)}{n}\right) + f(b) \right)$$

with an error bound of

$$\left| T_n - \int_a^b f(x)dx \right| \leq \frac{K(b-a)^3}{12n^2}$$

where $K$ is any number such that $|f''(x)| \leq K$ for all $x \in [a, b]$.

To approximate a definite integral using the trapezoid rule

1. Place the insert point in an expression of the form $\int_a^b f(x)dx$.

2. Choose Compute > Calculus > Approximate Integral.

3. In the dialog that appears, choose Trapezoid and specify the number of Subintervals.

Or

1. Place the insert point in an expression $f(x)$.

2. Choose Compute > Calculus > Approximate Integral.

3. In the dialog, select Trapezoid, specify the number of Subintervals, and specify Lower Bound and Upper Bound.

To obtain the following output, specify 10 Subintervals.

**Compute > Calculus > Approximate Integral**

$f_0^\pi x \sin x dx$ Approximate integral (trapezoid rule) is\[\frac{\pi}{10} \sum_{i=1}^{10} \frac{1}{10} \pi i \sin \left(\frac{1}{10} \pi i \right)\]

To obtain the following output, specify 10 Subintervals, 0 as Lower Bound, and 3.14159 as Upper Bound.

**Compute > Calculus > Approximate Integral**

$x \sin x$ Approximate integral (trapezoid rule) is\[0.31416 \sum_{i_{10}=1}^{9} 0.31416 i_{10} \sin 0.31416 i_{10} + 1.3095 \times 10^{-6}\]
Compute > Evaluate Numeric

\[
\frac{1}{n^2} \pi \sum_{i=1}^{9} \frac{1}{n^2} \pi i_9 \sin \frac{1}{n^2} \pi i_9 \approx 3.1157 \quad \int_0^\pi x \sin x \, dx \approx 3.1416
\]

\[0.31416 \sum_{i=10}^9 0.31416 i_9 \sin 0.31416 i_9 + 1.3095 \times 10^{-6} \approx 3.1157\]

**Simpson’s Rule**

Simpson’s rule gives the approximation \(S_n\) (where \(n\) is an even positive integer) for an arbitrary function \(f\) by

\[
\int_a^b f(x) \, dx \approx S_n
\]

\[
= \frac{b-a}{3n} \left( f(a) + f(b) + 4 \sum_{i=1}^{n/2} f \left( a + (2i-1) \frac{b-a}{n} \right) \right) + 2 \sum_{i=1}^{1+n/2} f \left( a + 2i \frac{b-a}{n} \right)
\]

The error bound for Simpson’s rule is given by

\[
\left| S_n - \int_a^b f(x) \, dx \right| \leq K \frac{(b-a)^5}{180n^4}
\]

where \(K\) is any number such that \(|f^{(4)}(x)| \leq K\) for all \(x \in [a, b]\). In particular, Simpson’s rule is exact for integrals of polynomials of degree at most 3 (because the fourth derivative of such a polynomial is identically zero).

**To approximate \( \int_a^b f(x) \, dx \) using Simpson’s rule**

1. Place the insert point in the expression \( \int_a^b f(x) \, dx \).
2. Choose Compute > Calculus > Approximate Integral.
3. In the dialog that appears, select Simpson and specify Number of Subintervals.
   Or
1. Place the insert point in the expression \( f(x) \).
2. Choose Compute > Calculus > Approximate Integral.
3. In the dialog, select Simpson, specify the number of Subintervals, and specify Lower Bound and Upper Bound.
Chapter 7 | Calculus

For the following output, select Simpson and specify 10 Subintervals in the dialog that appears.

\[ \int_0^\pi x \sin x \, dx \]

Approximate integral is

\[ \frac{1}{30} \pi \left( 2 \sum_{i_{11}=1}^{4} \frac{1}{3} \pi i_{11} \sin \frac{1}{3} \pi i_{11} + 4 \sum_{i_{11}=1}^{5} \frac{1}{10} \pi (2i_{11} - 1) \sin \frac{1}{10} \pi (2i_{11} - 1) \right) \]

For the following output, select Simpson, specify 10 Subintervals, and type 0 as Lower Bound and 3.14159 as Upper Bound.

\[ \int x \sin x \, dx \]

Approximate integral is

\[ 0.20944 \sum_{i_{12}=1}^{4} 0.62832i_{12} \sin 0.62832i_{12} + 0.41888 \sum_{i_{12}=1}^{5} (0.62832i_{12} - 0.31416) \sin (0.62832i_{12} - 0.31416) + 8.7299 \times 10^{-7} \]

Compare these results by evaluating numerically:

\[ \frac{1}{30} \pi \left( 2 \sum_{i_{11}=1}^{4} \frac{1}{3} \pi i_{11} \sin \frac{1}{3} \pi i_{11} + 4 \sum_{i_{11}=1}^{5} \frac{1}{10} \pi (2i_{11} - 1) \sin \frac{1}{10} \pi (2i_{11} - 1) \right) \approx 3.1418 \]

\[ 0.20944 \sum_{i_{12}=1}^{4} 0.62832i_{12} \sin 0.62832i_{12} + 0.41888 \sum_{i_{12}=1}^{5} (0.62832i_{12} - 0.31416) \sin (0.62832i_{12} - 0.31416) + 8.7299 \times 10^{-7} \approx 3.1414 \]

\[ \int_0^\pi x \sin x \, dx \approx 3.1416 \]

Example

To find the number of subdivisions required to approximate \( \int_0^1 e^{-x^2} \, dx \) using Simpson’s rule with an error of at most \( 10^{-5} \), you need to find an upper bound for the fourth derivative of \( e^{-x^2} \) on the interval \([0, 1]\). One way you can do this is by plotting the fourth derivative on the interval \([0, 1]\). Define \( f(x) = e^{-x^2} \). Then evaluate the expression \( f^{(4)}(x) \)

\[ f^{(4)}(x) = 12e^{-x^2} - 48x^2 e^{-x^2} + 16x^4 e^{-x^2} \]
and with the insert point in this expression, choose Compute > Plot 2D > Rectangular.

From the graph, you can see that \( f^{(4)}(x) \) has a maximum value on this interval of \( f^{(4)}(0) = 12 \). Solve the inequality

\[
12 \frac{(1 - 0)^5}{180n^4} \leq 10^{-5}
\]

to find the potential solutions

\[
\left\{ n \leq \frac{10}{3} \sqrt[4]{6} \right\}, \left\{ n = 0 \right\}, \left\{ \frac{10}{3} \sqrt[4]{6} \leq n \right\}
\]

Since \( n \) must be an even positive integer, and also \( n \geq \frac{10}{3} \sqrt[4]{6} = 9.036 \), we take \( n = 10 \). Calculating,

\[
S_{10} \approx \frac{1}{30} + \frac{1}{30} e^{-1} + \frac{2}{15} \sum_{i=1}^{5} e^{-\left(\frac{1}{2} - \frac{1}{10}\right)i^2} + \frac{1}{15} \sum_{i=1}^{4} e^{-\frac{1}{2} i^2} \approx 0.7468249483
\]

Direct evaluation using Evaluate Numeric yields

\[
\int_{0}^{1} e^{-x^2} \, dx \approx 0.7468241328
\]

and the approximation just computed is indeed within the specified margin of error since

\[
|0.7468241328 - 0.7468249483| = 8.155 \times 10^{-7} < 10^{-5}
\]

**Numerical Integration**

Many integrals (such as \( \int_{0}^{1} e^{-x^2} \, dx \) and \( \int_{0}^{\pi} \sin t \, dt \)) cannot be evaluated exactly, but you can obtain numerical approximations by choosing Evaluate Numeric. See page 508 for information on changing settings that affect these approximations.

**Compute > Evaluate Numeric**

- \( \int_{0}^{1} e^{-x^2} \, dx \approx 0.7468241328 \)
- \( \int_{0}^{\pi} \frac{\sin t}{t} \, dt \approx 1.851937052 \)
Chapter 7 | Calculus

Example  Given a curve \( y = f(x) \), the arc length between \( x = a \) and \( x = b \) is given by the integral

\[
\int_{a}^{b} \sqrt{1 + (f'(x))^2} \, dx
\]

For example, given \( f(x) = x \sin x \), which has derivative \( f'(x) = \sin x + x \cos x \), you can find the length of the arc between \( x = 0 \) and \( x = \pi \) by applying Evaluate Numeric. Integrals associated with arc lengths of curves can almost never be evaluated exactly.

\[
\text{Compute > Definitions > New Definition}
\]
\[
f(x) = x \sin x
\]

\[
\text{Compute > Evaluate}
\]
\[
\int_{0}^{\pi} \sqrt{1 + (f'(x))^2} \, dx = \int_{0}^{\pi} \sqrt{x \sin (2x) - \cos^2 x + x^2 + 2} \, dx
\]

\[
\text{Compute > Evaluate Numeric}
\]
\[
\int_{0}^{\pi} \sqrt{x \sin (2x) - \cos^2 x + x^2 + 2} \, dx \approx 5.04040692
\]

Curves in the plane or three-dimensional space can be represented parametrically.

Example  In the following we compute the arc length of the circular helix \( (\cos \theta, \sin \theta, \theta) \) for \( 0 \leq \theta \leq 2\pi \) and then plot a view of this helix.

\[
\text{Compute > Definitions > New Definition}
\]
\[
x = \cos \theta \\
y = \sin \theta \\
z = \theta
\]

\[
\text{Compute > Evaluate Numeric}
\]
\[
\int_{0}^{2\pi} \sqrt{(dx/d\theta)^2 + (dy/d\theta)^2 + (dz/d\theta)^2} \, d\theta \approx 8.8858
\]
Definite Integrals

**Example**  In polar coordinates arc length is given by the integral

\[ \int_{\alpha}^{\beta} \sqrt{r^2 + \left( \frac{dr}{d\theta} \right)^2} \, d\theta \]

Following are the plot and arc length for the spiral \( r = \theta \) with \( 0 \leq \theta \leq 6.2832 \).

**Tip**
Rotate such plots on your screen with your mouse to better visualize the curve.

\[ \int_{0}^{2\pi} \sqrt{r^2 + \left( \frac{dr}{d\theta} \right)^2} \, d\theta = \frac{1}{2} \text{arcsinh}(2\pi) + \pi\sqrt{4\pi^2 + 1} \]
Chapter 7 | Calculus

Evaluate Numeric

\[
\frac{1}{2} \arcsinh(2\pi) + \pi \sqrt{4\pi^2 + 1} \approx 21.25629415
\]

Visualizing Solids of Revolution

Problems of finding volumes and surface areas can be simplified by visualizing the solid.

Rectangular Coordinates

Assume the curve \( y = 1 - x^2 \) is rotated about the \( x \)-axis to form a solid. First, sketch the curve.

Then use a tube plot to visualize the surface.
Definite Integrals

The volume is given by the integral

$$\int_{-1}^{1} \pi y^2 \, dx = \pi \int_{-1}^{1} (1-x^2)^2 \, dx$$

**Compute > Evaluate**

$$\pi \int_{-1}^{1} (1-x^2)^2 \, dx = \frac{16}{15} \pi$$

The surface area is given by

$$\int 2\pi y \, ds = 2\pi \int_{-1}^{1} (1-x^2) \sqrt{1 + \left( \frac{dy}{dx} (1-x^2) \right)^2} \, dx$$

**Compute > Evaluate**

$$2\pi \int_{-1}^{1} (1-x^2) \sqrt{1 + \left( \frac{dy}{dx} (1-x^2) \right)^2} \, dx = 2\pi \left( \frac{7}{15} \sqrt{3} - \frac{17}{32} \ln \left( -2 + \sqrt{5} \right) \right)$$

**Compute > Evaluate Numeric**

$$2\pi \left( \frac{7}{15} \sqrt{3} - \frac{17}{32} \ln \left( -2 + \sqrt{5} \right) \right) \approx 10.96548466$$

Consider the problem of rotating the circle $x^2 + (y - 2)^2 = 1$ about the $x$-axis. We first sketch the circle.

**Compute > Plot 2D > Rectangular**

$$(\cos t, 2 + \sin t)$$

To rotate this circle about the $x$-axis, use a tube plot with spine $(2 \cos t, 0, 2 \sin t)$ and radius 1.
A differential of volume is equal to \((2\pi y) 2x \, dy\) and hence the volume is equal to the integral

\[
4\pi \int_1^3 y \sqrt{1 - (y - 2)^2} \, dy
\]

\[
\text{Compute > Evaluate}
\]

\[
4\pi \int_1^3 y \sqrt{1 - (y - 2)^2} \, dy = 4\pi^2
\]

The result \(4\pi^2\) is intuitive because the volume is generated by rotating a circle of area \(\pi\) and the center of the circle travels a distance of \(4\pi\).

**Parametric Equations**

To find the volume generated by rotating the region bounded by the \(x\)-axis and one cycle of the curve \(x = t + \sin t, y = 1 - \cos t\), we first draw the curve.
Compute > Plot 2D > Rectangular

\( (t - \sin t, 1 - \cos t) \)

Use a tube plot to visualize the solid of revolution.

Compute > Plot 3D > Tube (Radius: \( 1 - \cot t \))

\( (0, t - \sin t, 0) \)

To compute the volume, note that a differential of volume is given by \( \pi y^2 \, dx \) and hence the volume is

\[
\int_0^{2\pi} \pi y^2 \, dx = \pi \int_0^{2\pi} (1 - \cos t)^2 (1 - \cos t) \, dt
\]

\[= \pi \int_0^{2\pi} (1 - \cos t)^3 \, dt
\]

\( \pi \int_0^{2\pi} (1 - \cos t)^3 \, dt = 5\pi^2 \)

Polar Coordinates

To find the volume of the solid generated by rotating \( r = 1 - \cos \theta \)
\((0 \leq \theta \leq \pi)\) about the \( x \)-axis, we note that \( x = r \cos \theta = (1 - \cos \theta) \cos \theta \)
and \( y = r \sin \theta = (1 - \cos \theta) \sin \theta \).
Chapter 7 | Calculus

Use a tube plot to visualize the surface of revolution.

Sequences and Series

A sequence can be thought of as an infinite list, and a series as a sum of the terms of a sequence.

Sequences

A sequence \( \{a_n\}_{n=1}^{\infty} \) is a function whose domain is the set of positive integers. Calculate limits of sequences by selecting an expression such as \( \lim_{n \to \infty} (1 + \frac{1}{n})^n \) and choosing Compute > Evaluate, or by defining \( a_n \), writing \( \lim_{n \to \infty} a_n \), and choosing Compute > Evaluate.

Compute > Evaluate

\[
\lim_{n \to \infty} \left(1 + \frac{1}{n}\right)^n = e
\]
Sequences and Series

The terms of the sequence can be defined as function values, with the subscript as function argument (see page 107).

**To define the sequence** \( a_n = \left(1 + \frac{1}{n}\right)^n \)

1. With the insert point in the equation \( a_n = \left(1 + \frac{1}{n}\right)^n \), choose Compute > Definitions > New Definition.

2. In the Interpret Subscript dialog that appears, check Subscript is function argument and choose OK.

**Compute > Definitions > New Definition**

(ck check Subscript is function argument)

\[ a_n = \left(1 + \frac{1}{n}\right)^n \]

**Compute > Evaluate**

\[ \lim_{n \to \infty} a_n = e \]

**To compute several terms of a sequence**

1. With the insert point in mathematics, type \( \text{seq} \). (It should turn gray.)

2. Type the number of terms in the form \( n = 1 \ldots 4 \) as a subscript, to obtain \( \text{seq}_{n=1..4} \)

3. Type the general expression and choose Evaluate.

**Compute > Evaluate**

\[
\begin{align*}
\text{seq}_{n=1..4} \left(1 + \frac{1}{n}\right)^n &= 2 \cdot 4^2 \cdot 64^3 \cdot 256^4 \\
\text{seq}_{n=1..4} \left(1.0 + \frac{1}{n}\right)^n &= 2.0, 2.25, 2.3704, 2.4414 \\
\text{seq}_{x=1..5} \cos x &= \cos 1, \cos 2, \cos 3, \cos 4, \cos 5
\end{align*}
\]

A sequence such as \( \left\{ \left(1 + \frac{1}{n}\right)^n \right\}_{n=1}^{\infty} \) can be visualized graphically by plotting the expression \( \left(1 + \frac{1}{n}\right)^n \) at integer values of \( n \). You can generate this figure by plotting \( \left(1 + \frac{1}{n}\right)^n \), then revising the Items Plotted page so that the Plot Style is Point, the Point Marker is Circle, the Plot Interval is 1 to 50, and the Sample Size is 50.
Chapter 7 | Calculus

Compute > Plot 2D > Rectangular

\[(1 + \frac{1}{n})^n\]

This plot indicates that \[\lim_{n \to \infty} (1 + \frac{1}{n})^n \approx 2.7\]. Indeed, Evaluate yields \(e\) and Evaluate Numeric produces \(e \approx 2.718281828\).

**Series**

The *partial sums* of the series \[\sum_{k=1}^{\infty} a_k\] are the finite sums \(s_n = \sum_{k=1}^{n} a_k\). These partial sums form a sequence \(\{s_n\}\). If \(\lim_{n \to \infty} s_n = s\) exists, then \(s\) is called the *sum* of the series \[\sum_{k=1}^{\infty} a_k\]. To sum a series, place the insert point in the series and choose Evaluate. (See page 41 for details on entering the symbols \[\sum_{k=1}^{\infty} a_k\].)

**Finite sequences**

For further information on finite sequences, see page 28.

### Compute > Evaluate

\[
\sum_{n=1}^{\infty} (0.99)^n = 99.0 \\
\sum_{n=0}^{\infty} \frac{20^n}{n!} = e^{20} \\
\sum_{n=1}^{\infty} (-1)^n \frac{n}{n} = -\ln 2 \\
\sum_{n=1}^{\infty} \frac{1}{n^2} = \zeta (2) \\
\sum_{n=1}^{\infty} \sin n\pi = \text{undefined}
\]

Occasionally, a result is obtained that may be obscure, such as the response to \[\sum_{n=1}^{\infty} \frac{1}{n}\]. This series and the values of the zeta function \(\zeta (\cdot)\) can be estimated numerically.

### Compute > Evaluate Numeric

\[
\sum_{n=1}^{\infty} \frac{1}{n^3} \approx 1.202056903 \\
\zeta (3) \approx 1.202056903
\]

To sum a series in a form similar to \[\sum_{n=1}^{\infty} a_n\], enter an equation such as \(a_n = \frac{n^2}{2^n}\) and choose Compute > Definitions > New Definition.
Sequences and Series

Check Subscript is function argument in the Interpret Subscript box that opens.

**Compute > Definitions > New Definition**

(Subscript is function argument)

\[ a_n = \frac{n^2}{2^n} \]

**Compute > Evaluate**

\[ \sum_{n=1}^{\infty} a_n = 6 \]

**Ratio Test**

A series \( \sum_{n=1}^{\infty} a_n \) converges absolutely if \( \sum_{n=1}^{\infty} |a_n| \) converges, in which case the series \( \sum_{n=1}^{\infty} a_n \) also converges. The ratio test states that a series \( \sum_{n=1}^{\infty} a_n \) converges absolutely (and therefore converges) if

\[
\lim_{n \to \infty} \left| \frac{a_{n+1}}{a_n} \right| = L < 1
\]

To apply the ratio test to the series \( \sum_{n=1}^{\infty} \frac{n^2}{2^n} \), define \( a_n = \frac{n^2}{2^n} \) and compute \( \lim_{n \to \infty} \frac{a_{n+1}}{a_n} \) to find if it is less than 1.

**Compute > Definitions > New Definition**

(Subscript is function argument)

\[ a_n = \frac{n^2}{2^n} \]

**Compute > Evaluate**

\[
\lim_{n \to \infty} \frac{a_{n+1}}{a_n} = \frac{1}{2}
\]

Thus, \( L = \frac{1}{2} \), which is less than 1, so the series converges absolutely.

**Root Test**

The root test states that a series \( \sum_{n=1}^{\infty} a_n \) converges absolutely (and therefore converges) if

\[
\lim_{n \to \infty} \sqrt[n]{|a_n|} = L < 1
\]

To apply the root test to the series \( \sum_{n=1}^{\infty} \frac{n^2}{2^n} \), define \( a_n = \frac{n^2}{2^n} \) and compute \( \lim_{n \to \infty} \sqrt[n]{|a_n|} \) to find if it is less than 1.
Chapter 7 | Calculus

Compute > Definitions > New Definition
(Subscribe is function argument)

\[ a_n = \frac{n^2}{2\pi} \]

Compute > Evaluate

\[ \lim_{n \to \infty} \sqrt[n]{|a_n|} = \frac{1}{2} \]

Thus, \( L = \frac{1}{2} \), which is less than 1, showing that this series converges absolutely.

Integral Test

The integral test states that a series \( \sum_{n=1}^{\infty} a_n \) converges absolutely if there exists a positive decreasing function \( f \) such that \( f(n) = |a_n| \) for each positive integer \( n \) and

\[ \int_{1}^{\infty} f(x) \, dx < \infty \]

To verify convergence of the series \( \sum_{n=1}^{\infty} \frac{n^2}{2\pi} \) using the integral test, define \( f \) by \( f(x) = \frac{x^2}{2\pi} \), compute \( \int_{1}^{\infty} \frac{x^2}{2\pi} \, dx \) and determine if it is finite.

Compute > Definitions > New Definition

\[ f(x) = \frac{x^2}{2\pi} \]

Compute > Evaluate, Compute > Evaluate Numeric

\[ \int_{1}^{\infty} \frac{x^2}{2\pi} \, dx = \frac{(\ln 4 + \ln^2 2 + 2)}{2\ln^2 2} \approx 5.805497209 \]

Thus, this integral is finite. (Although for \( f(x) = \frac{x^2}{2\pi} \), it is true that \( f(1) < f(2) < f(3) \), you can verify that \( f \) is decreasing for \( x > 3 \). In fact,

\[ f'(x) = \frac{2}{2\pi} x - \frac{1}{2\pi} x^2 \ln 2 \]

is positive only on the interval \( 0 < x < \frac{2}{\ln^2 2} = 2.8854 \), so \( f \) is decreasing on \( 3 < x < \infty \). Since convergence of a series depends on the tail end of the series only, it is sufficient that the sequence of terms be eventually decreasing.)

264
Sequences and Series

Maclaurin Series

The Maclaurin series of a function $f$ is the series

$$
\sum_{n=0}^{\infty} \frac{f^{(n)}(0)}{n!} x^n
$$

where $f^{(n)}(0)$ indicates the $n$th derivative of $f$ evaluated at 0. It is a power series expanded about $x = 0$.

To expand a function $f(x)$ in a Maclaurin series

1. Place the insert point in the expression $f(x)$.
2. Choose Compute > Power Series.
3. Specify Variable, Center, and Order.
4. Choose OK.

With $f(x) = \frac{\sin x}{x}$ and 10 terms, the result is as follows.

Compute > Power Series (Variable x; Center 0; Order 10)

$\frac{\sin x}{x}$ Series expansion $1 - \frac{1}{6} x^2 + \frac{1}{120} x^4 - \frac{1}{30240} x^6 + \frac{1}{1209600} x^8 + O(x^{10})$

The $O(x^{10})$ term indicates that all the remaining terms in the series contain at least $x^{10}$ as a factor.

Plot 2D provides an excellent visual comparison between a function and an approximating polynomial.

Compute > Plot 2D > Rectangular

$\frac{\sin x}{x}$

$1 - \frac{1}{6} x^2 + \frac{1}{120} x^4$

2D plot of $\frac{\sin x}{x}$ and its Maclaurin series approximation.
Chapter 7 | Calculus

To determine which graph corresponds to which equation, evaluate one of the expressions where the graphs show some separation. For example, \( \frac{\sin x}{x} \approx -0.1892006238 \), and hence the graph of \( \frac{\sin x}{x} \) is the one that is negative at \( x = 4 \).

You can define a generic function and reproduce the general formula for a power series.

**Compute > Definitions > New Definition**

\[ f(x) \]

**Compute > Power Series** (Variable \( x \); Center \( 0 \); Order 5)

\[ f(x) \text{ Series expansion} \]

\[ f(0) + x f'(0) + \frac{1}{2} x^2 f''(0) + \frac{1}{6} x^3 f'''(0) + \frac{1}{24} x^4 f^{(4)}(0) + O(x^5) \]

The following are additional examples of Maclaurin series expansions.

**Compute > Power Series** (Variable \( x \); Center \( 0 \); Order 7, 10, 7 resp.)

\[ e^x \text{ Series expansion} \]

\[ 1 + x + \frac{1}{2} x^2 + \frac{1}{6} x^3 + \frac{1}{24} x^4 + \frac{1}{120} x^5 + \frac{1}{720} x^6 + O(x^7) \]

\[ \sin x \text{ Series expansion} \]

\[ x - \frac{1}{6} x^3 + \frac{1}{120} x^5 - \frac{1}{5040} x^7 + \frac{1}{362880} x^9 + O(x^{10}) \]

\[ e^x \sin x \text{ Series expansion} \]

\[ x + x^2 + \frac{1}{2} x^3 - \frac{1}{6} x^4 - \frac{1}{120} x^5 - \frac{1}{720} x^6 - \frac{1}{5040} x^7 + O(x^8) \]

Remember that output can be copied and pasted (with ordinary word-processing tools) to create input for further calculations. In particular, select and delete the \( + O(x^n) \) expression to convert the series into a polynomial. It is reassuring to note that, if the first few terms of the Maclaurin series for \( e^x \) are multiplied by the first few terms of the Maclaurin series for \( \sin x \), then the result is the same as the first few terms of the Maclaurin series for \( e^x \sin x \).

**Compute > Expand**

\[ (1 + x + \frac{1}{2} x^2 + \frac{1}{6} x^3 + \frac{1}{24} x^4 + \frac{1}{120} x^5) \left( x - \frac{1}{6} x^3 + \frac{1}{120} x^5 \right) \]

\[ = \frac{1}{11460} x^{10} + \frac{1}{2580} x^9 - \frac{1}{360} x^7 - \frac{1}{90} x^6 - \frac{1}{30} x^5 + \frac{1}{5} x^3 + x^2 + x \]

**Taylor Series**

The Maclaurin series is a special case of the more general Taylor series. The Taylor series of \( f \) expanded about \( x = a \) is given by

\[ \sum_{n=0}^{\infty} \frac{f^{(n)}(a)}{n!} (x-a)^n \]  

and hence is expanded in powers of \( x - a \) and centered about \( a \).
Sequences and Series

To expand a function \( f(x) \) in a Taylor series in powers of \( x - a \)

1. Place the insert point in the expression \( f(x) \).
2. Choose Compute > Power Series.
3. Specify Variable \( x \), Center \( a \), and Order.
4. Choose OK.

To find the Taylor series of \( \ln x \) expanded about \( x = 1 \), choose Power Series. In the dialog box, type the variable \( x \), type the center 1, and select the desired order of the approximating polynomial.

\[
\text{Compute} > \text{Power Series} \ (\text{Variable} \ x; \ \text{Center} \ 1; \ \text{Order} \ 5)
\]

\[
\ln x \text{ Series expansion } x - 1 - \frac{1}{2} (x - 1)^2 + \frac{1}{3} (x - 1)^3 - \frac{1}{4} (x - 1)^4 + \frac{1}{5} (x - 1)^5 + O \left( (x - 1)^6 \right)
\]

A comparison between \( \ln x \) and the polynomial

\[
(x - 1) - \frac{1}{2} (x - 1)^2 + \frac{1}{3} (x - 1)^3 - \frac{1}{4} (x - 1)^4
\]

is illustrated graphically in the following figure. Note how closely the polynomial fits the graph of \( \ln x \) in the neighborhood of the point \( x = 1 \).

\[
\text{Compute} > \text{Plot 2D} > \text{Rectangular}
\]

\[
\ln x \quad (x - 1) - \frac{1}{2} (x - 1)^2 + \frac{1}{3} (x - 1)^3 - \frac{1}{4} (x - 1)^4
\]
Chapter 7 | Calculus

Multivariable Calculus

Multivariable calculus extends the fundamental ideas of differential and integral calculus to functions of several variables. The Compute menu commands that have been described for one-variable calculus easily adapt to functions of several variables. We look first at the general area of optimization, which calls upon many of the ideas of differential calculus. Following that we will briefly consider Taylor polynomials in two variables and total differentials, and then describe the general approach for working with iterated integrals.

Optimization

Optimization of functions of several variables requires special techniques. The example immediately following demonstrates a direct approach, locating pairs where the partial derivatives are zero. Also see Lagrange multipliers (page 271) and Compute > Calculus > Find Extrema (page 220).

Extreme Values on a Surface

To find all candidates for the extreme values of a function such as $f(x, y) = x^3 - 3xy + y^3$, it is sufficient to locate all pairs $(x, y)$ where both partial derivatives are zero. Since only real solutions are pertinent, it is useful to assume the variables represent real numbers.

\[
\begin{align*}
\text{Compute} & > \text{Evaluate} \\
\text{assume} & (x, \text{real}) = \mathbb{R} \\
\text{assume} & (y, \text{real}) = \mathbb{R}
\end{align*}
\]

\[
\begin{align*}
\text{Compute} & > \text{Definitions} > \text{New Definition} \\
f(x, y) & = x^3 - 3xy + y^3
\end{align*}
\]

\[
\begin{align*}
\text{Compute} & > \text{Solve} > \text{Exact} \\
\frac{\partial}{\partial x} f(x, y) & = 0 \\
\frac{\partial}{\partial y} f(x, y) & = 0 \\
\text{Solution:} & \ [x = 1, y = 1], [x = 0, y = 0]
\end{align*}
\]

Thus the only candidates for real extreme values are $(0, 0)$ and $(1, 1)$. You can identify the nature of these two points using the second derivative test:

\[
\left[ D_{xx} f(x, y) D_{yy} f(x, y) - (D_{xy} f(x, y))^2 \right]_{x=0,y=0} = -9 < 0
\]
hence \((0, 0)\) represents a saddle point; and

\[
\left[ D_{xx}f(x, y)D_{yy}f(x, y) - (D_{xy}f(x, y))^2 \right]_{x=1, y=1} = 27 > 0
\]

and

\[
[D_{xx}f(x, y)]_{x=1, y=1} = 6 > 0
\]

so the surface has a local minimum at \((1, 1)\).

You can visualize the local minimum at \((1, 1)\) by generating a plot of the surface. To create the following plot, with the insert point in the expression \(x^3 - 3xy + y^3\), choose Compute > Plot 3D > Rectangular. In the Items Plotted page of the Plot Properties dialog, choose Hidden Line and Mesh. Choose Variables and Intervals and set the Plot Intervals to \(-1 \leq x \leq 2\) and \(-1 \leq y \leq 2\). On the Axes page, set Axes Type to Framed.

The level curve \(x^3 - 3xy + y^3 = 0\) goes through the point \((0, 0, 0)\).

For a better view of this level curve, make a 2D plot of \(x^3 - 3xy + y^3 = 0\) and add the level curve \(x^3 - 3xy + y^3 = -0.5\) to the plot.
The thick curve is the level curve at 0 and the thin curves are components of the level curve at $-0.5$. This view gives an idea of where the $z$-values are positive and where they are negative. Note that the $z$-values on the surface $z = x^3 - 3xy + y^3$ are negative inside the loop in the first quadrant and in the lower left corner of the $xy$-plane.

Extreme values of differentiable functions such as $x^3 - 3xy + y^3$ can also be found choosing Compute > Calculus > Find Extrema. In general, each application of Find Extrema reduces the number of variables by one and rephrases the problem in one less variable. Using this method with two or more variables requires multiple appropriate applications of the command.

Choose Compute > Calculus > Find Extrema for the following examples. Use floating point coefficients for these problems to obtain numeric solutions. It is convenient to restrict the computations to real variables.

**Compute > Evaluate**

```
assume (x, real) = R
assume (y, real) = R
```

**Compute > Calculus > Find Extrema (Variable y)**

$x^3 - 3xy + y^3$ Candidate(s) for extrema: $\{x^3 - 2x^2, x^3 + 2x^2\}$,

at $\{y = \sqrt{x}, y = -\sqrt{x}\}$

Note that for $y = \pm \sqrt{x}$, the expression $x^3 - 3xy + y^3$ simplifies
to $x^3 \pm 2x^2$. To find the extreme values, apply the command again to the simplified expressions.

**Compute > Calculus > Find Extrema** (Variable $y$)

$x^3 - 2x^2$ Candidate(s) for extrema: $\{-1, 0\}$, at $\{[x = 0], [x = 1]\}$

$x^3 + 2x^2$ Candidate(s) for extrema: $\{0\}$, at $\{[x = 0]\}$

The solution $y = \sqrt{x}$ yields the points $(0, 0)$ and $(1, 1)$, and $y = -\sqrt{x}$ yields the point $(0, 0)$. To determine the nature of these two critical points, use the second derivative test (page 268).

**Lagrange Multipliers**

You can use Lagrange multipliers to find constrained optima. To find extreme values of $f(x, y)$ subject to a constraint $g(x, y) = k$, it is sufficient to find all values of $x, y,$ and $\lambda$ such that

$$
\nabla f(x, y) = \lambda \nabla g(x, y)
$$

and $g(x, y) = k$ where $\nabla$ is the gradient operator

$$
\nabla f(x, y) = \left( \frac{\partial f}{\partial x}(x, y), \frac{\partial f}{\partial y}(x, y) \right)
$$

The variable $\lambda$ is called the Lagrange multiplier.

**Example** To find $x$ and $y$ whose sum is 5 and whose product is as large as possible

1. Define $f(x, y) = xy$ and $g(x, y) = x + y$.
2. Solve the equation $\nabla f(x, y) = \lambda \nabla g(x, y)$ subject to $g(x, y) = 5$.

**Compute > Definitions > New Definition**

$f(x, y) = xy \quad g(x, y) = x + y$

**Compute > Evaluate**

$$
\nabla f(x, y) = \begin{bmatrix} y \\ x \\ 0 \end{bmatrix} \quad \nabla g(x, y) = \begin{bmatrix} 1 \\ 1 \\ 0 \end{bmatrix}
$$

**Compute > Solve > Exact**

$y = \lambda$

$x = \lambda$  Solution: $[x = \frac{5}{2}, y = \frac{5}{2}, \lambda = \frac{5}{2}]$

$x + y = 5$
Example  Optimization problems may require numerical solutions in given search intervals.

\[ \nabla (x + 2y) = \begin{pmatrix} 1 \\ 2 \\ 0 \end{pmatrix} \quad \nabla (ye^x + xe^y) = \begin{pmatrix} e^y + ye^x \\ e^x + xe^y \\ 0 \end{pmatrix} \]

Compute > Solve > Numeric
1. \( 1 = \lambda (ye^x + e^y) \)
2. \( 2 = \lambda (e^x + xe^y) \)
\( ye^x + xe^y = 5 \)
\( x \in (0, 10) \)
\( y \in (0, 10) \)
\( \lambda \in (-5.5) \)

Solution: \( \{ x \approx 1.6665, y \approx 0.45056, \lambda \approx 0.25290 \} \)

For \( f(x, y) = x + 2y \) and \( g(x, y) = ye^x + xe^y \), these numbers give

\[
\begin{align*}
g(1.6665, 0.45056) & \approx 5.0001 \\
f(1.6665, 0.45056) & \approx 2.5676
\end{align*}
\]

The point \( (1.6665, 0.45056) \) gives a possible extreme value for \( f(x, y) \) satisfying the constraint \( g(x, y) = 5 \).

Taylor Polynomials in Two Variables
Let \( z \) be a function of two variables. The second-degree Taylor polynomial of \( z \) at \( (a, b) \) is given by

\[
T_2(x, y) = z(a, b) + D_x z(a, b)(x - a) + D_y z(a, b)(y - b) + \frac{1}{2} D_{xx} z(a, b)(x - a)^2 + D_{xy} z(a, b)(x - a)(y - b) + \frac{1}{2} D_{yy} z(a, b)(y - b)^2
\]

To evaluate a partial derivative of a function \( z \) at \( (a, b) \)
1. Evaluate the partial derivative at \( (x, y) \) using an expression such as
   \( \frac{\partial}{\partial x} z(x, y), D_x z(x, y), \frac{\partial^2}{\partial x^2} z(x, y) \), or \( D_{x^2} z(x, y) \).
2. Evaluate at \( (a, b) \) using square brackets with the subscript \( x = a, y = b \).

These steps can be combined into a single step:
To find the second-degree Taylor polynomial of
\[ z = \frac{1}{1+x^2+y^2} \]
at \((0,0)\), first define the function \( z(x,y) \), then compute the second degree Taylor polynomial as follows:

**Compute > Definitions > New Definition**
\[ z(x,y) = \frac{1}{1+x^2+y^2} \]

**Compute > Evaluate**
\[
\begin{align*}
\left[ \frac{\partial}{\partial x} (x^2y) \right]_{x=1,y=2} &= 4 \\
\left[ \frac{\partial}{\partial y} (x^2y) \right]_{x=1,y=2} &= 4
\end{align*}
\]

These steps yield the second degree Taylor polynomial
\[ T_2(x,y) = 1 - x^2 - y^2 \]

The following plot has Plot Intervals \(-0.5 \leq x \leq 0.5\) and \(-0.5 \leq y \leq 0\). Turn 75 and Tilt 75. This cutaway plot shows how well the second-degree Taylor polynomial (the lower surface) matches the function \( z \) near \((0,0)\).
Chapter 7 | Calculus

Total Differential

To compute the total differential of a function of two variables, define a function \( u(x, y) \), represent each differential by a Math Name (\( du, dx, \) and \( dy \)) so that it will be treated as a variable. Then evaluate the expression

\[
du = \frac{\partial}{\partial x} u(x, y) \, dx + \frac{\partial}{\partial y} u(x, y) \, dy
\]

A similar procedure produces the total differential of a function of three variables.

1. **Compute > Definitions > New Definition**
   
   \[ u(x, y) = x^3 y^2 \]

   To create the grayed function names \( du, dx, \) and \( dy \)
   1. Choose Insert > Math Objects > Math Name.
   2. Type the function name in the Name box and choose OK.

2. **Compute > Evaluate**
   
   \[
du = \frac{\partial}{\partial x} u(x, y) \, dx + \frac{\partial}{\partial y} u(x, y) \, dy = 3x^2 y^2 \, dx + 2x^3 y \, dy
   \]

   **Iterated Integrals**

   You can enter and evaluate iterated integrals. If \( a \leq b, f(x) \leq g(x) \) for all \( x \in [a, b] \), and \( k(x, y) \geq 0 \) for all \( x \in [a, b] \) and all \( y \in [f(x), g(x)] \), then the iterated integral

   \[
   \int_a^b \int_{f(x)}^{g(x)} k(x, y) \, dy \, dx
   \]

   can be interpreted as the volume of the solid bounded by the three inequalities \( a \leq x \leq b, f(x) \leq y \leq g(x), \) and \( 0 \leq z \leq k(x, y) \).

3. **Example**  
   Find the volume of the solid under the surface \( z = 1 + xy \) and above the triangle with vertices \((1, 1), (4, 1), \) and \((3, 2)\).
   1. Plot the triangle with the given vertices.

   2. Find the equations of the bounding lines:
      
      \[
      y = \frac{1}{5} x + \frac{1}{2}, \quad y = 5 - x, \quad y = 1
      \]
3. Solve for $x$ in terms of $y$: 
\[ x = 2y - 1 \]
\[ x = 5 - y \]

4. Set up and evaluate an iterated integral: 
\[ \int_{1}^{2} \int_{2y-1}^{5} (1 + xy) \, dx \, dy = \frac{55}{8} \]

The solid can be viewed as a parameterized surface.

**To view the integral $\int_{a}^{b} \int_{f(s)}^{g(s)} k(x,y) \, dy \, dx$ as the volume of a solid**

1. Plot the expression $(x, f(x) (1 - s) + g(x) s, k(x, f(x) (1 - s) + g(x) s))$.
2. Revise the plot, setting the intervals to $a \leq x \leq b$ and $0 \leq s \leq 1$.
3. Drag each of the expressions $(x, f(x), sk(x, f(x)))$, $(x, g(x), sk(x, g(x)))$, $(a, y, sk(a, y))$, and $(b, y, sk(b, y))$ to the plot frame.
4. Revise the plot, setting the intervals for the fourth item to $f(a) \leq y \leq g(a)$, $0 \leq s \leq 1$ and the intervals for the fifth item to $f(b) \leq y \leq g(b)$ and $0 \leq s \leq 1$.

**Example** In the following, the $x$- and $y$-coordinates are interchanged to view the integral $\int_{1}^{2} \int_{2y-1}^{5} (1 + xy) \, dx \, dy$.

Compute $>$ Plot 3D $>$ Rectangular (Intervals: $0 \leq s \leq 1$, $1 \leq x \leq 4$, $1 \leq y \leq 2$)

\[
(5 - y) (1 - s) + (2y - 1)s, y, 1 + y((5 - y) (1 - s) + (2y - 1)s))
\]
\[
(2y - 1, y, s(1 + y(2y - 1)))
\]
\[
(5 - y, y, s(1 + y(5 - y)))
\]
\[
(x, 1, s(1 + x))
\]

(Revise the plot by changing the intervals for the fourth item to $1 \leq x \leq 4$, $0 \leq s \leq 1$.)
Chapter 7 | Calculus

Here are two examples of iterated integrals.

**Compute > Evaluate, Compute > Evaluate Numeric**

\[
\int_0^1 \int_0^x x^2 \cos y \, dy \, dx = \cos 1 + 2 \sin 1 - 2 \approx 0.22324
\]

\[
\int_0^3 \int_0^x e^{x^2} \, dy \, dx = \frac{1}{6} e^9 - \frac{1}{6} \approx 1350.3
\]

Following is an example illustrating a method for reversing the order of integration.

**Example** Attempting to evaluate the double integral

\[
\int_0^1 \int_0^1 \sqrt{x^3 + 1} \, dx \, dy
\]

exactly leads to frustration. However, you can reverse the order of integration by looking carefully at the region of integration in the plane.

This region is bounded above by \( y = x^2 \) and below by \( y = 0 \). The new integral is

\[
\int_0^{x^2} \int_0^1 \sqrt{x^3 + 1} \, dy \, dx
\]

This double integral can be evaluated directly. You can gain some insight by iterated integration. The inner integral is just

\[
\int_0^{x^2} \sqrt{x^3 + 1} \, dy = x^2 \sqrt{x^3 + 1}
\]

You can integrate the resulting outer integral \( \int_0^1 x^2 \sqrt{x^3 + 1} \, dx \) by choosing Compute > Calculus > Change Variable, say with \( u = x^3 + 1 \). Then choosing Compute > Evaluate and Compute > Evaluate Numeric, yields

\[
\int_0^1 \sqrt{(x^3 + 1)x^2} \, dx = \int_1^2 \frac{1}{3} \sqrt{u} \, du = \frac{4}{9} \sqrt{2} - \frac{2}{9} \approx 0.4063171388
\]

For double and triple indefinite integrals you can use either repeated integral signs or the double and triple integrals available in the Operators dialog. Analogous to single indefinite integrals, for which you must add an arbitrary constant to the result of computing an indefinite integral, for a double integral \( \iint f(x,y) \, dx \, dy \) you must add an arbitrary function of the form \( \Phi(x) + \Psi(y) \). For a triple integral \( \iiint f(x,y,z) \, dx \, dy \, dz \) you must add an arbitrary function of the form \( \Phi(x,y) + \Psi(y,z) + \lambda(x,z) \).
To enter and evaluate a double or triple integral

1. Choose Insert > Math Objects > Operator.

2. Select the double or triple integral and choose OK.

3. Enter the function and the differentials. (The latter are necessary.)

4. With the insert point in the integral, choose Compute > Evaluate.

5. For a double integral, add an arbitrary function of the form \( \varphi(x) + \psi(y) \); for a triple integral, add \( \varphi(x, y) + \psi(y, z) + \lambda(x, z) \).

\[
\int xy
dx
dy = \frac{1}{4}x^2y^2 + \varphi(x) + \psi(y)
\]
\[
\int x\sin x\cos y
dx
dy = (\sin x - x\cos x)\sin y + \varphi(x) + \psi(y)
\]
\[
\int \int \int xy^2z
dx
dy
dz = \frac{1}{12}x^2y^3z^2 + \varphi(x, y) + \psi(y, z) + \lambda(x, z)
\]

Exercises

1. Verify the formula \( \frac{d}{dx}(x^8) = 8x^7 \) by starting with the definition of derivative and choosing submenu items such as Expand and Simplify.

2. Use Newton’s method on the function \( f(x) = x^2 + 1 \), starting with \( x_0 = 0.5 \). What conclusions can you draw?

3. Find the equation of one line that is tangent to the graph of

\[
f(x) = x(x - 1)(x - 3)(x - 6)
\]

at two different points.

4. For \( 0 < k < 1 \), the elliptic integral \( E = \int_0^{\pi/2} \sqrt{1 - k\sin^2 \theta} d\theta \) has no elementary solution. Use a series expansion of the integrand to estimate \( E \).

5. Find all the solutions to \( x^y = y^x \) for unequal positive integers \( x \) and \( y \).
6. Blood flowing through an artery flows fastest at the center of the artery, and slowest near the walls of the artery where friction is a factor. In fact, the velocity is given by the formula \( v(r) = \alpha(R^2 - r^2) \), where \( \alpha \) is a constant, \( R \) is the radius of the artery, and \( r \) is the distance from the center.

Set up an integral that gives the total blood flow through an artery. Show that if an artery is constricted to one-half of its original radius, the blood flow (assuming constant blood pressure) is reduced to \( \frac{1}{16} \) of its original flow.

7. The mass of an object traveling at a velocity \( v \) with rest mass \( m_0 \) is given by
   \[
   m = m_0 \left(1 - \frac{v^2}{c^2}\right)^{-1/2}
   \]
   where \( c \) is the speed of light. Use a Maclaurin series expansion to show the increase in mass at low velocities.

8. Evaluate \( \int 2x \cos bx \, dx \).

9. Evaluate \( \int_{-\pi}^{\pi} \frac{1 + \sin x}{(x - \cos x)^2} \, dx \). Hint: Don’t try to do it directly.

10. Evaluate \( \lim_{h \to 0^+} \int_0^\infty \sin(x^2 + h) \, dx \).

11. The Fundamental Theorem of Calculus says that if \( f \) is continuous on a closed interval \([a, b]\), then
   a. If \( g \) is defined by \( g(x) = \int_a^x f(t) \, dt \) for \( x \in [a, b] \), then \( g'(x) = f(x) \), and
   b. If \( F \) is any antiderivative of \( f \), then \( \int_a^b f(x) \, dx = F(b) - F(a) \).

   Demonstrate that these two conditions hold for each of the three functions \( f(x) = x^3 \), \( f(x) = xe^x \), and \( f(x) = \sin^2 x \cos x \).

12. The arithmetic-geometric mean of two positive numbers \( a > b \) was defined by Gauss as follows. Let \( a_0 = a \) and \( b_0 = b \). Given \( a_n \) and \( b_n \), let \( a_{n+1} \) be the arithmetic mean of \( a_n \) and \( b_n \), and \( b_{n+1} \) the geometric mean of \( a_n \) and \( b_n \):
   \[
   a_{n+1} = \frac{a_n + b_n}{2} \quad \text{and} \quad b_{n+1} = \sqrt{a_nb_n}
   \]
Exercises

Using mathematical induction, you can show that \( a_n > a_{n+1} > b_{n+1} > b_n \) and deduce that both series \( \{a_n\} \) and \( \{b_n\} \) are convergent, and, in fact, that \( \lim_{n \to \infty} a_n = \lim_{n \to \infty} b_n \).

Compute the arithmetic-geometric mean of the numbers 2 and 1 to five decimal places.

13. Two numbers \( x \) and \( y \) are chosen at random in the unit interval \([0, 1]\). What is the average distance between two such numbers?

Solutions

1. By definition,

\[
\frac{d}{dx}(x^8) = \lim_{h \to 0} \frac{(x + h)^8 - x^8}{h} = \lim_{h \to 0} \frac{8x^7h + 28x^6h^2 + \cdots + 28x^2h^6 + 8xh^7 + h^8}{h} = \lim_{h \to 0} \left( 8x^7 + 28x^6h + \cdots + 28x^2h^5 + 8xh^6 + h^7 \right) = 8x^7
\]

2. Defining \( g(x) = x - f(x)/f'(x) \), choose \( \text{Compute} > \text{Calculus} > \text{Iterate} \) to obtain

\[
\begin{bmatrix}
0.5 \\
-0.75 \\
0.29167 \\
-1.5684 \\
-0.4654 \\
0.84164
\end{bmatrix}
\]

If this result seems to be headed nowhere, it is doing so for good reason. The function \( f \) is always positive, so it has no zeroes. Newton’s method is searching for something that does not exist.

3. It is sufficient to find three numbers \( a, b, \) and \( m \) that satisfy \( f'(a) = m, f'(b) = m, \) and \( \frac{f(b) - f(a)}{b - a} = m. \) Put these three equations inside a 3 \( \times \) 1 matrix and choose \( \text{Compute} > \text{Solve} > \text{Exact} \) to get several solutions, including the real solutions

\[
\begin{bmatrix}
\frac{5}{2} - \frac{1}{2}\sqrt{21}, b = \frac{5}{2} - \frac{1}{2}\sqrt{21}, m = -8
\end{bmatrix}
\]
Chapter 7 | Calculus

\[
\begin{align*}
[a &= \frac{5}{2} - \frac{1}{2}\sqrt{21}, b = \frac{1}{2}\sqrt{21} + \frac{5}{2}, m = -8] \\
[a &= \frac{1}{2}\sqrt{21} + \frac{5}{2}, b = \frac{5}{2} - \frac{1}{2}\sqrt{21}, m = -8] \\
[a &= \frac{1}{2}\sqrt{21} + \frac{5}{2}, b = \frac{1}{2}\sqrt{21} + \frac{5}{2}, m = -8] \\
[a &= \frac{5}{2}, b = \frac{5}{2}, m = -8] \\
\end{align*}
\]

Three of the solutions are not allowed, because the problem requires \( a \neq b \). The two remaining solutions have the roles of \( a \) and \( b \) reversed. Assuming \( a < b \), that leaves the solution \( \left[ a = \frac{5}{2} - \frac{1}{2}\sqrt{21}, b = \frac{1}{2}\sqrt{21} + \frac{5}{2}, m = -8 \right] \). Evaluating and expanding,

\[
f(a) = \left( \frac{5}{2} - \frac{1}{2}\sqrt{21} \right) \left( \frac{3}{2} - \frac{1}{2}\sqrt{21} \right) \left( -\frac{1}{2} - \frac{1}{2}\sqrt{21} \right) \left( -\frac{7}{2} - \frac{1}{2}\sqrt{21} \right) = -21 + 4\sqrt{21}
\]

so that

\[
y = f(a) + m(x - a) = -21 + 4\sqrt{21} - 8 \left( x - \frac{5}{2} + \frac{1}{2}\sqrt{21} \right) = -1 - 8x
\]

Plot the two curves \( (x-1)(x-3)(x-6) \) and \( -1 - 8x \), just for visual verification. Use a viewing window with domain interval \(-1 \leq x \leq 6.5\) to generate the following picture.

4. The series is given by \( \sqrt{1 - k \sin^2 t} = 1 + \left( -\frac{1}{2}k \right) t^2 + \left( \frac{1}{6}k - \frac{1}{8}k^2 \right) t^4 + O(t^5) \). Thus, an estimate for \( E \) is given by

\[
E \approx \int_0^{\pi/2} \left[ 1 + \left( -\frac{1}{2}k \right) t^2 + \left( \frac{1}{6}k - \frac{1}{8}k^2 \right) t^4 \right] dt = \frac{1}{2} \pi - \frac{1}{48} \pi^3 k + \frac{1}{160} \pi^5 \left( \frac{1}{6}k - \frac{1}{8}k^2 \right)
\]
Exercises

As a check, \( k = 1 \) yields 1.0045 compared with the exact value
\[
\int_0^{\pi/2} \sqrt{1 - \sin^2 t} \, dt = 1
\]
and \( k = 0 \) yields \( \frac{1}{2} \pi \), which agrees precisely with
\[
\int_0^{\pi/2} \, dt = \frac{1}{2} \pi
\]

5. Compute natural logs on both sides and separate variables to get
\[
\ln x = \ln y
\]
Plot \( \ln x \) on the interval \( 1 \leq x \leq 10 \). Locate the extreme values of \( \ln x \) by solving \( \frac{dx}{dx} (\ln x) = 0 \). Note that 2 is the only integer between 1 and \( e \), and verify that \( 2^4 = 4^2 \) is true.

6. The flow is given by the integral
\[
\int_0^R \alpha (R^2 - r^2) 2\pi r \, dr = \frac{1}{2} \alpha \pi R^4
\]
If \( R \) is reduced by one-half, then \( R^4 \) is reduced to \( \frac{1}{16} \) of the original amount.

7. The series expansion is given by
\[
m_0 \left( 1 - \frac{v^2}{c^2} \right)^{-1/2} = m_0 + \frac{1}{2c^2} v^2 m_0 + \frac{3}{8c^4} v^4 m_0 + O(v^5)
\]
If \( \frac{v}{c} \) is small, then the model \( m \approx m_0 + \frac{1}{2c^2} v^2 \) is useful for estimating the increased mass.

8. Evaluation yields
\[
\int 2^x \cos bx \, dx = \frac{2^x (b \sin bx + \cos bx \ln 2)}{b^2 + \ln^2 2}
\]

9. The integral
\[
\int_{-\pi}^{\pi} \frac{1 + \sin x}{(x - \cos x)^2} \, dx
\]
is improper, because \( x - \cos x = 0 \) has a root \( (\approx 0.73909) \) between \( -\pi \) and \( \pi \). Evaluate Numeric gives
\[
\int_{-\pi}^{739} \frac{1 + \sin x}{(x - \cos x)^2} \, dx \approx 7018.2, \text{ and}
\int_{7392}^{\pi} \frac{1 + \sin x}{(x - \cos x)^2} \, dx \approx 5201.4
\]
Chapter 7 | Calculus

Change “Digits rendered” to 10, in the Output page of the Tools > Preference > Computation dialog box. Solving $\cos x = x$ numerically gives $x \approx 0.7390851332$.

Using this as a limit, Evaluate Numeric gives

$$\int_{-\pi}^{0.73908} \frac{1 + \sin x}{(x - \cos x)^2} \, dx \approx 116400.4055$$

$$\int_{0.73909}^{\pi} \frac{1 + \sin x}{(x - \cos x)^2} \, dx \approx 122772.6822$$

providing some evidence that both integrals diverge.

10. You obtain the result $\lim_{h \to 0^+} \int_0^\infty \sin (x^2 + h) \, dx = 1$. This result is reasonable, because the integral $f(h) = \int_0^\infty \sin (x^2 + h) \, dx$ can be viewed as a convergent alternating series for $h > 0$, and $g(y) = \int_0^y \sin x \, dx = 1 - \cos y$ ranges in value between 0 and 2, with an average value of 1.

11. We need to show that for each of the three functions $f(x) = x^3$, $f(x) = xe^x$, and $f(x) = \sin^2 x \cos x$, (a) and (b) hold:

(a) If $g$ is defined by $g(x) = \int_a^x f(t) \, dt$ for $x \in [a, b]$, then $g'(x) = f(x)$.

(b) If $F$ is any antiderivative of $f$, then $\int_a^b f(x) \, dx = F(b) - F(a)$.

For $f(x) = x^3$, $g(x) = \int_a^x t^3 \, dt = \frac{1}{4} x^4 - \frac{1}{4} a^4$ and $g'(x) = \frac{d}{dx} \left( \frac{1}{4} x^4 - \frac{1}{4} a^4 \right) = x^3$. The antiderivatives of $f$ are of the form $F(x) = \int x^3 \, dx = \frac{1}{4} x^4 + C$ for different constants $C$. Now

$$F(b) - F(x) = \left[ \frac{1}{4} x^4 + C \right]_{x=a}^{x=b} = \frac{1}{4} b^4 - \frac{1}{4} a^4$$

which is the same as $\int_a^b x^3 \, dx = \frac{1}{4} b^4 - \frac{1}{4} a^4$.

For $f(x) = xe^x$, $g(x) = \int_a^x te^t \, dt = xe^t - e^t - ae^a + e^a$ and $g'(x) = \frac{d}{dx} \left( xe^x - e^x - ae^a + e^a \right) = xe^x$. The antiderivatives of $f$ are of the form $F(x) = \int xe^x \, dx = xe^x - e^x + C$ for different constants $C$. Now

$$F(b) - F(x) = [xe^x - e^x + C]_{x=a}^{x=b} = be^b - e^b - ae^a + e^a$$
Exercises

which is the same as \( \int_a^b x e^x \, dx = be^b - e^b - ae^a + e^a \).

For \( f(x) = \sin^2 x \cos x \),

\[
g(x) = \int_a^x \sin^2 t \cos t \, dt = \frac{1}{4} \sin x - \frac{1}{4} \sin a + \frac{1}{12} \sin 3a - \frac{1}{12} \sin 3x
\]

and

\[
g'(x) = \frac{d}{dx} \left( \frac{1}{4} \sin x - \frac{1}{4} \sin a + \frac{1}{12} \sin 3a - \frac{1}{12} \sin 3x \right)
= \frac{1}{4} \cos x - \frac{1}{4} \cos 3x
\]

To check to see if this is the same as \( f(x) \), apply Compute > Combine > Trigonometric Functions to the expression \( \sin^2 x \cos x \) to see that indeed \( \sin^2 x \cos x = \frac{1}{4} \cos x - \frac{1}{4} \cos 3x \). The antiderivatives of \( f \) are of the form

\[
F(x) = \int \sin^2 x \cos x \, dx = \frac{1}{4} \sin x - \frac{1}{12} \sin 3x + C
\]

for different constants \( C \). Now

\[
F(b) - F(x) = \left[ \frac{1}{4} \sin x - \frac{1}{12} \sin 3x \right]_{x=a}^{x=b}
= \frac{1}{4} \sin b - \frac{1}{4} \sin a + \frac{1}{12} \sin 3a - \frac{1}{12} \sin 3b
\]

while

\[
\int_a^b \sin^2 x \cos x \, dx = \frac{1}{4} \sin b - \frac{1}{4} \sin a + \frac{1}{12} \sin 3a - \frac{1}{12} \sin 3b
\]

12. Since the arithmetic-geometric mean lies between \( a_n \) and \( b_n \) for all \( n \), we know the arithmetic-geometric mean to five decimal places when these two numbers agree to that many places.

- \( a_1 = \frac{2 + 1}{2} = \frac{3}{2} = 1.5 \) and \( b_1 = \sqrt{2 \times 1} = \sqrt{2} \approx 1.41421 \)
- \( a_2 = \frac{3 + \sqrt{2}}{2} = \frac{3}{2} + \frac{1}{2} \sqrt{2} = 1.45711 \) and \( b_2 = \sqrt{\frac{3}{2} \sqrt{2}} \approx 1.45648 \)
- \( a_3 = \frac{\frac{3}{2} + \sqrt{2}}{2} + \sqrt{\frac{\frac{3}{2} \sqrt{2}}{2}} = \frac{3}{4} + \frac{1}{4} \sqrt{2} + \frac{1}{4} \sqrt{6 \sqrt{2}} \approx 1.45679 \)

and \( b_3 = \sqrt{\left( \frac{3}{4} + \frac{1}{4} \sqrt{2} \right) \sqrt{\frac{3}{2} \sqrt{2}}} \approx 1.45679 \)
Chapter 7 | Calculus

13. An average value can be determined by evaluating an integral. The average distance between $x$ and $y$ is given by

$$\int_0^1 \int_0^1 |x - y| \, dy \, dx = \frac{1}{3}.$$ 

This can be verified using the following steps:

$$\int_0^1 \int_0^1 |x - y| \, dy \, dx = \int_0^1 \int_0^x |x - y| \, dy \, dx + \int_0^1 \int_x^1 |x - y| \, dy \, dx$$

$$= \int_0^1 \int_0^x (x - y) \, dy \, dx + \int_0^1 \int_x^1 (y - x) \, dy \, dx$$

$$= \frac{1}{6} + \frac{1}{6} = \frac{1}{3}$$
Matrices are used throughout mathematics and in related fields such as physics, engineering, economics, and statistics. The algebra of matrices provides a model for the study of vector spaces and linear transformations.

A rectangular array of mathematical expressions is called a matrix. A matrix with $m$ rows and $n$ columns is called an $m \times n$ matrix. Matrices are sometimes referred to simply as arrays, and an $m \times 1$ or $1 \times n$ array is also called a vector. Several methods for creating matrices are described in the ensuing sections.

Entries in matrices can be real or complex numbers, or mathematical expressions with real or complex coefficients. Most of the choices from the Matrices submenu operate on both real and complex matrices. The QR and SVD factorizations discussed later in this chapter assume real matrices.

Matrix entries are identified by their row and column number. The matrix can be considered as a function on pairs of positive integers. If the matrix is given a name, this feature can be used to retrieve the entries, with the arguments entered as subscripts.

```
Compute > Definitions > New Definition

A = [ [-85, -55, -37], [-35, 97, 50], [79, 56, 49] ]
```

New in Version 6
Map a function to a matrix
Chapter 8 | Matrix Algebra

**Compute > Evaluate**

\[ A_{2,3} = 50 \]
\[ A_{3,3} = 49 \]

Note that the subscripted row and column numbers are separated by a comma.

**Creating and Editing Matrices**

You can create a matrix via the Matrix dialog box or from the Matrices submenu. There is also a keyboard shortcut, described at the end of this chapter.

Each method involves different choices, as described in the following paragraphs.

**To create a matrix**

1. Choose Insert > Math Objects > Matrix.

2. Select the number of rows and columns by clicking in the lowest, right-most box you want.

3. Choose OK.

4. Type or copy entries into the input boxes.

The entries can be any valid mathematical expression. Both real and complex numbers are legitimate entries, as well as algebraic expressions. The built-in delimiters have the same appearance as expanding brackets on the screen, but they require less horizontal space when typeset.

**Matrix Delimiters**

You can make choices in the View menu that affect the appearance of matrices on the screen. Helper Lines and Input Boxes can be shown or hidden. The default is to show them to make it easier to handle entries on the screen. Matrix helper lines and input boxes normally do not appear when you preview or print the document.

It is standard to enclose a matrix in brackets, either built-in or added manually. These two options provide the same screen appearance and mathematical properties. They differ only under Typeset—in which case, the built-in brackets fit more tightly around the matrix entries than added brackets. If you have a matrix without built-in delimiters, you will generally want to add brackets around it. The result of
an operation on matrices usually appears with the same brackets as the original matrices.

**To set the default matrix delimiters**
1. Choose Tools > Computation > Matrices.
2. Select the desired option: none, [], or ().

**Fill Matrix**
You can generate a matrix whose entries are defined by a function.

**To define a Hilbert matrix**
1. Define \( f(i, j) = \frac{1}{i + j - 1} \).
2. Choose Compute > Matrices > Fill Matrix > Defined by Function.
3. Type \( f \) in the box for the function name.
4. Set rows and columns. (Enter 2 or 3 for the following example.)
5. Choose OK.

![Compute > Matrices > Fill Matrix > Defined by Function](image)

Function: \( f \)

\[
\begin{bmatrix}
1 & \frac{1}{2} \\
\frac{1}{2} & \frac{1}{3}
\end{bmatrix}
\begin{bmatrix}
1 & \frac{1}{2} & \frac{1}{3} \\
\frac{1}{2} & \frac{1}{3} & \frac{1}{4} \\
\frac{1}{3} & \frac{1}{4} & \frac{1}{5}
\end{bmatrix}
\]

2 × 2 3 × 3

**To define a Vandermonde matrix**
1. Define the function \( g(i, j) = x_j^{i-1} \).
2. Choose Compute > Matrices > Fill Matrix > Defined by Function.
3. Type \( g \) for the function name.
4. Set the Dimensions and choose OK.
Chapter 8 | Matrix Algebra

**Compute > Matrices > Fill Matrix > Defined by Function**

Function: $g$, Rows: 4, Columns: 4

\[
\begin{bmatrix}
1 & x_1 & x_1^2 & x_1^3 \\
1 & x_2 & x_2^2 & x_2^3 \\
1 & x_3 & x_3^2 & x_3^3 \\
1 & x_4 & x_4^2 & x_4^3
\end{bmatrix}
\]

To define a generic matrix

1. Define the function $a(i,j) = a_{i,j}$.
2. Choose Compute > Matrices > Fill Matrix > Defined by Function.
3. Type $a$ for the function name.
4. Set the Dimensions and choose OK.

**Compute > Matrices > Fill Matrix > Defined by Function**

Function: $a$, Rows: 3, Columns: 3

\[
\begin{bmatrix}
a_{1,1} & a_{1,2} & a_{1,3} \\
a_{2,1} & a_{2,2} & a_{2,3} \\
a_{3,1} & a_{3,2} & a_{3,3}
\end{bmatrix}
\]

You can use the following trick to create a general matrix up to $9 \times 9$ with no commas in the subscripts.

To define a generic matrix with no commas in the subscripts

1. Define the function $b(i,j) = a_{10i+j}$.
2. Choose Compute > Matrices > Fill Matrix > Defined by Function.
3. Type $b$ for the function name.
4. Set the Dimensions and choose OK.

**Compute > Matrices > Fill Matrix > Defined by Function**

Function: $b$, Rows: 3, Columns: 3

\[
\begin{bmatrix}
a_{11} & a_{12} & a_{13} \\
a_{21} & a_{22} & a_{23} \\
a_{31} & a_{32} & a_{33}
\end{bmatrix}
\]
Creating and Editing Matrices

To define a constant matrix
1. Choose Compute > Matrices > Fill Matrix > Defined by Function.
2. Type 5 for the function name.

```
Compute > Matrices > Fill Matrix > Defined by Function
Function: 5, Rows: 2, Columns: 2
\[
\begin{bmatrix}
  5 & 5 \\
  5 & 5 \\
\end{bmatrix}
```

Band

To define a band matrix
1. Choose Compute > Matrices > Fill Matrix > Band
2. Type a comma-delimited list such as $a, b, c$ with an odd number of entries in the List box.
3. Set the Dimensions and choose OK.

```
Compute > Matrices > Fill Matrix > Band

\[
\begin{bmatrix}
  a & 0 \\
  0 & a \\
\end{bmatrix}
\begin{bmatrix}
  b & c \\
  a & b \\
\end{bmatrix}
\begin{bmatrix}
  b & c & 0 & 0 & 0 \\
  a & b & c & 0 & 0 \\
  0 & a & b & c & 0 \\
  0 & 0 & a & b & c \\
  0 & 0 & 0 & a & b \\
\end{bmatrix}
\]
```

List: $a$ List: $a, b, c$ List: $a, b, c$
Rows: 2, Columns: 2 Rows: 2, Columns: 2 Rows: 5, Columns: 5

Create a Band matrix with the single digit 0, the single digit 1, or the list 0, $\lambda$, 1 to get a zero matrix, an identity matrix, or a Jordan block, respectively.

```
Compute > Matrices > Fill Matrix > Band

\[
\begin{bmatrix}
  0 & 0 & 0 \\
  0 & 0 & 0 \\
  0 & 0 & 0 \\
\end{bmatrix}
\begin{bmatrix}
  1 & 0 & 0 \\
  0 & 1 & 0 \\
  0 & 0 & 1 \\
\end{bmatrix}
\begin{bmatrix}
  \lambda & 1 & 0 \\
  0 & \lambda & 1 \\
  0 & 0 & \lambda \\
\end{bmatrix}
\]
```

List: 0 List: 1 List: 0, $\lambda$, 1
Rows: 3, Columns: 3 Rows: 3, Columns: 3 Rows: 3, Columns: 3
Chapter 8 | Matrix Algebra

Revising Matrices

You can add or delete rows, columns, or a full block of rows or columns from a matrix. The alignment of rows and columns can be reset. Entries in a rectangular block can be deleted or replaced.

Adding Rows and Columns

To add rows or columns to a matrix

1. Select the matrix by placing the insert point in a cell of the matrix or by placing the insert point at the right of the matrix (but not outside of any brackets).

2. Choose Edit > Insert Matrix Rows, or Edit > Insert Matrix Columns.

3. Make appropriate choices from the dialog that appears and choose OK.

Deleting Rows and Columns

To delete a block of rows or columns

1. Select a block of rows or columns with the mouse or with Shift+arrow.

2. Press Del.

You can also use the procedure described above to delete entries from a rectangular block that does not include a complete row or column of a matrix.

The choices Insert Row(s) and Insert Column(s) appear on the Edit menu only when a matrix is selected. If they do not appear, reposition the insertion point or select the matrix with click and drag, being careful to select only the inside of the matrix—that is, not including the exterior Helper Lines.

To lengthen a vector represented as an $n \times 1$ or $1 \times n$ matrix

- Place the insert point in the last input box and press Enter.

To shorten a vector represented as an $n \times 1$ or $1 \times n$ matrix

- Place the insert point in the last input box and press Backspace.

You can start with a display box, or the input boxes that appear with the fraction, radical, or bracket buttons, and make similar changes
Changing Alignment

To change the alignment of entries
1. Select the matrix using the mouse.
2. Choose Edit > Properties and make appropriate choices from the dialog box that appears.

Replacing a Rectangular Block

You can replace a rectangular block in an existing matrix with Copy and Paste or with Fill Matrix.

To replace a rectangular block with Copy and Paste
1. Copy a rectangular matrix to the clipboard with Edit > Copy.
2. With the mouse or Shift+arrow, select a rectangular portion of the same dimensions in any matrix and choose Edit > Paste.

To change a matrix with Fill Matrix
1. Select a rectangular portion of the matrix with the mouse or Shift+arrow.
2. Choose Compute > Matrices > Fill Matrix.
3. Choose one of the items from the dialog.
4. Choose OK.

The selected region of the matrix is filled with the entries that you chose.

Example

To change the lower-right $2 \times 2$ corner of the matrix to the zero matrix, select the lower-right $2 \times 2$ corner of the matrix using the mouse. Choose Compute > Matrices > Fill Matrix. Choose Zero. Choose OK.

$$\begin{bmatrix}
1 & 1 & 9 & 4 \\
5 & 3 & -1 & 5 \\
-6 & 1 & 2 & 3 \\
9 & 5 & 5 & 4
\end{bmatrix} \quad \begin{bmatrix}
1 & 1 & 9 & 4 \\
5 & 3 & -1 & 5 \\
-6 & 1 & 2 & 3 \\
9 & 5 & 0 & 0
\end{bmatrix}$$

The lower-right corner is replaced by the $2 \times 2$ zero matrix. No new matrix is created.
Chapter 8 | Matrix Algebra

You can delete a block of entries in a matrix by selecting a rectangular portion of the matrix with the mouse and pressing del.

Example To delete the entries in the lower-right $2 \times 2$ corner of the matrix, select the lower-right $2 \times 2$ corner of the matrix using the mouse and press del.

\[
\begin{bmatrix}
8 & -9 & 4 \\
0 & 5 & -6 \\
1 & 2 & 3 \\
5 & 5 & 4 \\
7 & 8 & 9
\end{bmatrix}
\begin{bmatrix}
8 & -9 & 4 \\
0 & 5 & -6 \\
1 & 2 & 3 \\
5 & □ & □ \\
7 & □ & □
\end{bmatrix}
\]

Concatenate and Stack Matrices

You can merge two matrices horizontally into one if they have the same number of rows. You can merge two matrices vertically into one if they have the same number of columns.

To concatenate two matrices with the same number of rows
1. Place two matrices adjacent to each other.
2. Leave the insert point in one of the matrices.
3. Choose Compute > Matrices > Concatenate.

\[
\begin{bmatrix}
1 & 2 \\
3 & 4
\end{bmatrix}
\begin{bmatrix}
5 & 6 \\
7 & 8
\end{bmatrix}
\text{Concatenation}
\begin{bmatrix}
1 & 2 & 5 & 6 \\
3 & 4 & 7 & 8
\end{bmatrix}
\]

\[
\begin{bmatrix}
x+1 & 2 \\
3y & 4t+2
\end{bmatrix}
\begin{bmatrix}
5+w \\
\sqrt{7z}
\end{bmatrix}
\text{Concatenation}
\begin{bmatrix}
x+1 & 2 & 5+w \\
3y & 4t+2 & \sqrt{7z}
\end{bmatrix}
\]

To stack two matrices with the same number of columns
1. Place two matrices adjacent to each other.
2. Leave the insert point in one of the matrices.
3. Choose Compute > Matrices > Stack.
Creating and Editing Matrices

Create and Edit Matrices

Compute > Matrices > Stack

\[
\begin{pmatrix}
1 & 2 \\
3 & 4 \\
-5 & 7
\end{pmatrix}
\begin{pmatrix}
5 & 6
\end{pmatrix}
\begin{pmatrix}
1 & 2 \\
3 & 4 \\
-5 & 7
\end{pmatrix}
\begin{pmatrix}
5 & 6
\end{pmatrix}
\]

\[
\begin{pmatrix}
x+1 \\
y \\
5 & 6
\end{pmatrix}
\begin{pmatrix}
w + 5 & 2 \\
3y & 4t + 2 \\
z\sqrt{7}
\end{pmatrix}
\begin{pmatrix}
x+1 \\
y \\
5 & 6
\end{pmatrix}
\begin{pmatrix}
w + 5 & 2 \\
3y & 4t + 2 \\
z\sqrt{7}
\end{pmatrix}
\]

Reshaping Lists and Matrices

A list of expressions entered in mathematics and separated by commas can be turned into a matrix whose entries, reading left to right and top to bottom, are the entries of the list in the given order.

To make a matrix from a list

1. Place the insert point within the list.
2. Choose Compute > Matrices > Reshape.
3. Specify the number of columns.

The number of rows depends on the length of the list. Extra input boxes at the end are left blank.

Compute > Matrices > Reshape (3 columns)

\[
\begin{bmatrix}
45 & 21 & 8 \\
19 & 0 & 5 \\
15 & 6 & \square
\end{bmatrix}
\]

A matrix filled with data can be reshaped, with the new matrix corresponding to the same list as the original data.

To reshape a matrix

1. Place the insert point in the matrix.
2. Choose Compute > Matrices > Reshape.
3. Specify the new number of columns.

Compute > Matrices > Reshape (3 columns)

\[
\begin{bmatrix}
-85 & -55 & -37 & -35 \\
97 & 50 & 79 & 56
\end{bmatrix}
\begin{bmatrix}
-85 & -55 & -37 \\
-35 & 97 & 50 \\
79 & 56 & \square
\end{bmatrix}
\]
Chapter 8 | Matrix Algebra

Standard Operations

You can perform standard operations on matrices, such as addition, subtraction, scalar multiplication, and matrix multiplication, by evaluating expressions entered in natural notation.

Matrix Addition and Scalar Multiplication

You add two matrices of the same dimension by adding corresponding entries. The numbers or other expressions used as matrix entries are called scalars. You multiply a scalar with a matrix by multiplying every entry of the matrix by the scalar.

To perform matrix addition and multiplication and other operations with scalars and matrices, place the insert point anywhere inside the expression, and choose Compute > Evaluate.

Compute > Evaluate

\[
\begin{bmatrix}
1 & -2 \\
4 & 3 \\
-5 & 7
\end{bmatrix} + 
\begin{bmatrix}
5 & 6 \\
8 & 7 \\
3 & 9
\end{bmatrix} = 
\begin{bmatrix}
6 & 4 \\
12 & 10 \\
-2 & 16
\end{bmatrix}
\]

Note that the sum appears with the same brackets as the original matrices.

Inner Products and Matrix Multiplication

The product of a \(1 \times n\) matrix with an \(n \times 1\) matrix (the product of two vectors) produces a scalar (called the inner product or dot product in case the matrices are real). The matrix product of an \(m \times k\) matrix with a \(k \times n\) matrix is an \(m \times n\) matrix obtained by taking such products of rows and columns, the \(i/j\) entry of the product \(AB\) being the product of the \(i\)th row of \(A\) with the \(j\)th column of \(B\).
Standard Operations

Compute > Evaluate

\[
\begin{pmatrix} a & b \\ u & v \end{pmatrix} \begin{pmatrix} c \\ d \end{pmatrix} = \begin{pmatrix} ac + bd \\ uc + vd \end{pmatrix}
\]

\[
\begin{pmatrix} 1 & 2 \\ 4 & 3 \end{pmatrix} \begin{pmatrix} 5 & 6 \\ 8 & 7 \end{pmatrix} = \begin{pmatrix} 21 & 20 \\ 44 & 45 \end{pmatrix}
\]

\[
\begin{bmatrix} 5 & 6 \end{bmatrix}^3 = \begin{bmatrix} 941 & 942 \\ 1256 & 1255 \end{bmatrix}
\]

To put an exponent on a matrix, place the insert point immediately to the right of the matrix, choose Insert > Math Objects > Superscript, and type the exponent in the input box.

Rows and Columns

You can find the vector that is the \( n \)th row or column of a matrix \( A \) with the functions \( \text{row}(A, n) \) and \( \text{col}(A, n) \). These function names automatically gray when typed in mathematics mode if Automatic Substitution is enabled. Otherwise, you can create them by choosing Insert > Math Object > Math Name.

\[
\begin{align*}
\text{row}\left( \begin{bmatrix} 1 & 2 \\ 4 & 3 \end{bmatrix}, 2 \right) &= \begin{bmatrix} 4 & 3 \end{bmatrix} \\
\text{col}\left( \begin{bmatrix} 1 & 2 \\ 4 & 3 \end{bmatrix}, 2 \right) &= \begin{bmatrix} 2 \\ 3 \end{bmatrix}
\end{align*}
\]

Identity and Inverse Matrices

The \( n \times n \) identity matrix \( I \) has ones down the main diagonal (upper-left corner to lower-right corner) and zeroes elsewhere. The \( 3 \times 3 \) identity matrix, for example, is

\[
I = \begin{bmatrix} 1 & 0 & 0 \\ 0 & 1 & 0 \\ 0 & 0 & 1 \end{bmatrix}
\]

Complex numbers

The inner product of two vectors \( \mathbf{u} = (u_1, u_2, \ldots, u_n) \) and \( \mathbf{v} = (v_1, v_2, \ldots, v_n) \) with complex components is given by

\[
\mathbf{u} \cdot \mathbf{v} = \sum_{k=1}^{n} u_k v_k^*
\]

where \( v_k^* \) is the complex conjugate of \( v_k \).
Chapter 8 | Matrix Algebra

The inverse of an $n \times n$ matrix $A$ is an $n \times n$ matrix $B$ satisfying $AB = I$. To find the inverse of an invertible matrix $A$, place the insert point in the matrix and choose Compute > Matrices > Inverse; or type $A^{-1}$ as a superscript and choose Compute > Evaluate.

Compute > Matrices > Inverse

\[
\begin{pmatrix}
5 & 6 \\
8 & 7 \\
\end{pmatrix}
\text{Inverse: }
\begin{pmatrix}
-7/13 & 6/13 \\
8/13 & -5/13 \\
\end{pmatrix}
\]

Compute > Evaluate

\[
\begin{pmatrix}
5 & 6 \\
8 & 7 \\
\end{pmatrix}^{-1} = \begin{pmatrix}
-7/13 & 6/13 \\
8/13 & -5/13 \\
\end{pmatrix}
\]

To check that this matrix satisfies the defining property, evaluate the product.

Compute > Evaluate

\[
\begin{pmatrix}
5 & 6 \\
8 & 7 \\
\end{pmatrix} \begin{pmatrix}
-7/13 & 6/13 \\
8/13 & -5/13 \\
\end{pmatrix} = \begin{pmatrix}
1 & 0 \\
0 & 1 \\
\end{pmatrix}
\]

Choose Compute > Evaluate Numeric to get a numerical approximation of the inverse. The accuracy of this numerical approximation depends on properties of the matrix, as well as on the settings for Digits and Digits Rendered (see Appendix C, Customizing the Program for Computing).

Compute > Evaluate Numeric

\[
\begin{pmatrix}
5 & 6 \\
8 & 7 \\
\end{pmatrix}^{-1} \approx \begin{pmatrix}
-0.53846 & 0.46154 \\
0.61538 & -0.38462 \\
\end{pmatrix}
\]

Checking the product of a matrix with its inverse gives you an idea of the degree of accuracy of the approximation.

Compute > Evaluate

\[
\begin{pmatrix}
5 & 6 \\
8 & 7 \\
\end{pmatrix} \begin{pmatrix}
-0.53846 & 0.46154 \\
0.61538 & -0.38462 \\
\end{pmatrix} = \begin{pmatrix}
0.99998 & -0.00002 \\
-0.00002 & 0.99998 \\
\end{pmatrix}
\]

Since $(A^n)^{-1} = (A^{-1})^n$, you can compute negative powers of invertible matrices.
"Compute60" — 2011/12/20 — 14:27 — page 297 — #307

Standard Operations

Compute > Evaluate
\[
\begin{pmatrix} 5 & 6 \\ 8 & 7 \end{pmatrix}^{-3} = \begin{pmatrix} -\frac{1255}{2197} & \frac{942}{2197} \\ \frac{1256}{2197} & -\frac{941}{2197} \end{pmatrix}
\]

The \( m \times n \) matrix with every entry equal to zero is the identity for addition; that is, for any \( m \times n \) matrix \( A \),
\[
A + 0 = 0 + A = A
\]
and the additive inverse of a matrix \( A \) is the matrix \((-1)A\).

Polynomials with Matrix Values

You can apply a polynomial function of one variable to a matrix.

To evaluate a polynomial \( p(x) \) at a square matrix \( A \)

- With the insert point in the expression \( p(A) \), choose Compute > Evaluate.

\[
p(x) = x^2 - 5x - 2
\]
\[
A = \begin{bmatrix} 2 & -2 \\ -4 & 0 \end{bmatrix}
\]

\[
\text{Compute} > \text{Evaluate}
\]
\[
p(A) = \begin{bmatrix} 0 & 6 \\ 12 & 6 \end{bmatrix}
\]

You can also define the function \( f(x) = x^2 - 5x - 2x^0 \) and evaluate \( f \) at a square matrix.

\[
\text{Compute} > \text{Definitions} > \text{New Definition}
\]
\[
f(x) = x^2 - 5x - 2x^0
\]

\[
\text{Compute} > \text{Evaluate}
\]
\[
f\left( \begin{bmatrix} 1 & 2 \\ 4 & 3 \end{bmatrix} \right) = \begin{bmatrix} 2 & -2 \\ -4 & 0 \end{bmatrix}
\]

Note

The expression \(-5 \begin{bmatrix} 1 & 2 \\ 4 & 3 \end{bmatrix} = -2\) is not, strictly speaking, a proper expression. However, when evaluated, the final \(2\) is interpreted in this context as \( \begin{bmatrix} 2 & 0 \\ 0 & 2 \end{bmatrix} \), or twice the \(2 \times 2\) identity matrix.
Chapter 8 | Matrix Algebra

Operations on Matrix Entries

To operate on one entry of a matrix, select the entry, press and hold the Ctrl key, and choose a command. The program will perform the operation in place, leaving the rest of the matrix unchanged. Because you are in a word-processing environment, you can edit individual entries (click in the input box and then edit) and apply other word-processing features to entries, such as copy and paste or click and drag.

Many of the commands on the Compute menu operate directly on the entries when applied to a matrix, as can be seen from the following examples.

\[
\text{Compute > Factor}
\begin{bmatrix}
5 & 6 \\
8 & 7
\end{bmatrix}
= 
\begin{bmatrix}
5 & 2 \times 3 \\
2^3 & 7
\end{bmatrix}
\]

\[
\text{Compute > Evaluate}
\begin{bmatrix}
\frac{d}{dx} \sin x & \int 6x^2 \, dx \\
\frac{d^2}{dx^2} \ln x & x + 3x
\end{bmatrix}
= 
\begin{bmatrix}
\cos x & 2x^3 \\
-\frac{1}{x^2} & 4x
\end{bmatrix}
\]

\[
\text{Compute > Evaluate Numeric}
\begin{bmatrix}
sin^2 \pi & e \\
\ln 5 & x + 3x
\end{bmatrix}
\approx 
\begin{bmatrix}
0.0 & 2.7183 \\
1.6094 & 4.0x
\end{bmatrix}
\]

\[
\text{Compute > Combine > Trigonometric Functions}
\begin{bmatrix}
sin^2 x + \cos^2 x & 6x^2 \\
4 \sin 4x \cos 4x & \sin x \cos y + \sin y \cos x
\end{bmatrix}
= 
\begin{bmatrix}
1 & 6x^2 \\
2 \sin (8x) & \sin (x + y)
\end{bmatrix}
\]

\[
\text{Compute > Evaluate}
\frac{d}{dx}
\begin{bmatrix}
x + 1 & 2x^3 - 3 \\
\sin 4x & 3 \sec x
\end{bmatrix}
= 
\begin{bmatrix}
1 & 6x^2 \\
4 \cos (4x) & \frac{3}{\cos x} \sin x
\end{bmatrix}
\]

Row Operations and Echelon Forms

One of the elementary applications of matrix arrays is storing and manipulating coefficients of systems of linear equations. The various steps that you carry out in applying the technique of elimination to a system of linear equations
Row Operations and Echelon Forms

\[ a_{11}x_1 + a_{12}x_2 + \ldots + a_{1n}x_n = b_1 \]
\[ a_{21}x_1 + a_{22}x_2 + \ldots + a_{2n}x_n = b_2 \]
\[ \vdots \quad \vdots \quad \vdots \]
\[ a_{m1}x_1 + a_{m2}x_2 + \ldots + a_{mn}x_n = b_m \]

can be applied equally well to the matrix of coefficients and scalars

\[
\begin{bmatrix}
  a_{11} & a_{12} & \ldots & a_{1n} & b_1 \\
  a_{21} & a_{22} & \ldots & a_{2n} & b_2 \\
  \vdots & \vdots & \ldots & \vdots & \vdots \\
  a_{m1} & a_{m2} & \ldots & a_{mn} & b_m \\
\end{bmatrix}
\]

For this and numerous other reasons, you perform elementary row operations on matrices. The goal of elementary row operations is to put the matrix in a special form, such as a row echelon form, in which the number of leading zeroes increases as the row number increases.

The Matrices menu provides the choices Fraction-free Gaussian Elimination, Gaussian Elimination, and Reduced Row Echelon Form for obtaining a row echelon form. The last of these produces the reduced row echelon form satisfying the following conditions:

- The number of leading zeroes increases as the row number increases.
- The first nonzero entry in each nonzero row is equal to 1.
- Each column that contains the leading nonzero entry for any row contains only zeroes above and below that entry.

Gaussian Elimination and Row Echelon Form

The three row echelon forms that can be obtained from the Matrices submenu are illustrated in the following examples.

\[
\text{Compute} \quad \text{Matrices} \quad \text{Fraction-free Gaussian Elimination}
\]

\[
\begin{bmatrix} a & b \\ c & d \end{bmatrix} \quad \text{Fraction Free Gaussian Elimination:} \quad \begin{bmatrix} a & b \\ 0 & ad - bc \end{bmatrix}
\]

\[
\begin{bmatrix} 8 & 2 & 3 \\ 2 & -5 & 8 \end{bmatrix} \quad \text{Fraction Free Gaussian Elimination:} \quad \begin{bmatrix} 8 & 2 & 3 \\ 0 & -44 & 58 \end{bmatrix}
\]
Chapter 8 | Matrix Algebra

**Compute > Matrices > Gaussian Elimination**

\[
\begin{bmatrix}
a & b \\
c & d
\end{bmatrix}
\]
Gaussian Elimination:

\[
\begin{bmatrix}
a \\ 0
\end{bmatrix}
\]

\[
\begin{bmatrix}
a & b \\
(ad-bc) & \frac{a}{a}
\end{bmatrix}
\]

\[
\begin{bmatrix}
8 & 2 & 3 \\
2 & -5 & 8
\end{bmatrix}
\]
Gaussian Elimination:

\[
\begin{bmatrix}
8 & -5 & 8 \\
0 & 22 & -29
\end{bmatrix}
\]

**Compute > Matrices > Reduced Row Echelon Form**

\[
\begin{bmatrix}
a & b \\
c & d
\end{bmatrix}
\]
Reduced Row Echelon Form:

\[
\begin{bmatrix}
1 & 0 \\
0 & 1
\end{bmatrix}
\]

\[
\begin{bmatrix}
8 & 2 & 3 \\
2 & -5 & 8
\end{bmatrix}
\]
Reduced Row Echelon Form:

\[
\begin{bmatrix}
1 & 0 & \frac{31}{22} \\
0 & 1 & -\frac{29}{22}
\end{bmatrix}
\]

**Elementary Row Operations**

You can perform elementary row operations by multiplying on the left by appropriate elementary matrices—the matrices obtained from an identity matrix by applying an elementary row operation. The technique is illustrated in the following examples.

To create an elementary matrix, choose Compute > Matrices > Fill Matrix > Identity and edit the identity matrix. Choose Compute > Evaluate to get the following products.

- **Add \( \lambda \) times row 3 to row 1**

\[
\begin{bmatrix}
1 & 0 & \lambda \\
0 & 1 & 0 \\
0 & 0 & 1
\end{bmatrix}
\]

\[
\begin{bmatrix}
-5 & -2 & -1 \\
3 & -6 & 2 \\
1 & 4 & 1
\end{bmatrix}
\]

\[
\begin{bmatrix}
\lambda - 5 & 4\lambda - 2 & \lambda - 1 \\
3 & -6 & 2 \\
1 & 4 & 1
\end{bmatrix}
\]

- **Interchange rows 2 and 3**

\[
\begin{bmatrix}
1 & 0 & 0 \\
0 & 0 & 1 \\
0 & 1 & 0
\end{bmatrix}
\]

\[
\begin{bmatrix}
-50 & -12 & -18 \\
31 & -26 & -62 \\
1 & -47 & -91
\end{bmatrix}
\]

\[
\begin{bmatrix}
-50 & -12 & -18 \\
1 & -47 & -91 \\
31 & -26 & -62
\end{bmatrix}
\]

- **Multiply row 2 by \( \lambda \)**

\[
\begin{bmatrix}
1 & 0 & 0 \\
0 & \lambda & 0 \\
0 & 0 & 1
\end{bmatrix}
\]

\[
\begin{bmatrix}
80 & -2 & -18 \\
33 & -26 & 82 \lambda \\
14 & -47 & -91
\end{bmatrix}
\]

\[
\begin{bmatrix}
80 & -2 & -18 \\
33\lambda & -26\lambda & 82\lambda \\
14 & -47 & -91
\end{bmatrix}
\]
Equations

You can perform other row or column operations that are available in the MuPAD library, as in the following example.

Example

To access the MuPAD function `swapRow` and name it `S`:

1. Choose Compute > Definitions > Define MuPAD Name.

2. Respond to the dialog box as follows:
   - MuPAD Name: `linalg::swapRow(x,i,j)`
   - Scientific WorkPlace (Notebook) Name: `S(x,i,j)`
   - In the area titled The MuPAD Name is a Procedure, check That is built in to MuPAD or is automatically loaded.

3. Check OK.

This procedure defines a function `S(x,i,j)` that interchanges the rows `i` and `j` of a matrix `x`. Define

\[
    x = \begin{bmatrix}
        -85 & -55 & -37 & -35 \\
        97  & 50  & 79  & 56  \\
        49  & 63  & 57  & -59 
    \end{bmatrix}
\]

and evaluate `S(x, 1, 2)` to get

\[
    S(x, 1, 2) = \begin{bmatrix}
        97  & 50  & 79  & 56  \\
        -85 & -55 & -37 & -35 \\
        49  & 63  & 57  & -59 
    \end{bmatrix}
\]

Equations

Elementary methods for solving systems of equations are discussed on page 55. The algebra of matrices provides you with additional tools for solving systems of linear equations, both directly and by translating into matrix equations.

Systems of Linear Equations

You identify a system of equations by entering the equations in an \( n \times 1 \) matrix, with one equation to a row. When you have the same number of unknowns as equations, put the insert point anywhere in the system, and choose Compute > Solve > Exact. The variables are
found automatically without having to be specified, as in the following example.

**Compute > Solve > Exact**

\[
\begin{align*}
    x + y - 2z &= 1 \\
    2x - 4y + z &= 0 \\
    2y - 3z &= -1
\end{align*}
\]

Solution: \[x = \frac{17}{7}, y = \frac{11}{7}, z = \frac{5}{4}\]

To solve a system of equations with two equations and three unknowns, you must specify Variables to Solve for in a dialog box. Put the insert point anywhere in the matrix and choose Compute > Solve > Exact. A dialog box opens asking you to specify the variables. Type the variable names, separated by commas.

**Compute > Solve > Exact**

(Variable(s) to Solve for : \(x, y\))

\[
\begin{align*}
    2x - y &= 1 \\
    x + 3z &= 4
\end{align*}
\]

Solution: \([y = -6z + 7, x = -3z + 4]\)

(Variable(s) to Solve for : \(x, z\))

\[
\begin{align*}
    2x - y &= 1 \\
    x + 3z &= 4
\end{align*}
\]

Solution: \([x = \frac{1}{2} + \frac{1}{2}y, z = \frac{7}{6} - \frac{1}{6}y]\)

**Matrix Equations**

The system of equations

\[
\begin{align*}
    a_{11}x_1 + a_{12}x_2 + \cdots + a_{1n}x_n &= b_1 \\
    a_{21}x_1 + a_{22}x_2 + \cdots + a_{2n}x_n &= b_2 \\
    \vdots & \vdots \vdots \\
    a_{m1}x_1 + a_{m2}x_2 + \cdots + a_{mn}x_n &= b_m
\end{align*}
\]

is the same as the matrix equation

\[
\begin{bmatrix}
    a_{11} & a_{12} & \cdots & a_{1n} \\
    a_{21} & a_{22} & \cdots & a_{2n} \\
    \vdots & \vdots & \ddots & \vdots \\
    a_{m1} & a_{m2} & \cdots & a_{mn}
\end{bmatrix}
\begin{bmatrix}
    x_1 \\
    x_2 \\
    \vdots \\
    x_n
\end{bmatrix}
= 
\begin{bmatrix}
    b_1 \\
    b_2 \\
    \vdots \\
    b_m
\end{bmatrix}
\]
Example: To put the system of equations

\[
\begin{align*}
  x + y - 2z &= 1 \\
  2x - 4y + z &= 0 \\
  2y - 3z &= -1
\end{align*}
\]

in matrix form, multiply the coefficient matrix \[
\begin{bmatrix}
  1 & 1 & -2 \\
  2 & -4 & 1 \\
  0 & 2 & -3 
\end{bmatrix}
\]

by the vector \[
\begin{bmatrix}
  x \\
  y \\
  z
\end{bmatrix}
\].

\[
\begin{bmatrix}
  1 & 1 & -2 \\
  2 & -4 & 1 \\
  0 & 2 & -3 
\end{bmatrix}
\begin{bmatrix}
  x \\
  y \\
  z
\end{bmatrix} = \begin{bmatrix}
  x + y - 2z \\
  2x - 4y + z \\
  2y - 3z
\end{bmatrix} = \begin{bmatrix}
  1 \\
  0 \\
  -1
\end{bmatrix}
\]

You can solve matrix equations by choosing Compute > Solve > Exact. There are advantages to solving systems of equations in this way, and often you can best deal with systems of linear equations by solving the matrix version of the system.

**Compute > Solve > Exact**

\[
\begin{bmatrix}
  1 & 1 & -2 \\
  2 & -4 & 1 \\
  0 & 2 & -3 
\end{bmatrix}
\begin{bmatrix}
  x \\
  y \\
  z
\end{bmatrix} = \begin{bmatrix}
  1 \\
  0 \\
  -1
\end{bmatrix}, \text{ Solution: } \begin{bmatrix}
  \frac{17}{8} \\
  \frac{11}{8} \\
  \frac{5}{4}
\end{bmatrix}
\]

\[
\begin{bmatrix}
  2 & -1 & 0 \\
  1 & 0 & 3
\end{bmatrix}
\begin{bmatrix}
  x \\
  y \\
  z
\end{bmatrix} = \begin{bmatrix}
  1 \\
  4
\end{bmatrix}, \text{ Solution: } \begin{bmatrix}
  4 - 3\hat{t}_3 \\
  7 - 6\hat{t}_3 \\
  \hat{t}_3
\end{bmatrix}
\]

In the first case, you can also solve the equation by multiplying both the left and right sides of the equation by the inverse of the coefficient matrix, and evaluating the product.

**Compute > Evaluate**

\[
\begin{bmatrix}
  x \\
  y \\
  z
\end{bmatrix} = \begin{bmatrix}
  1 & 1 & -2 \\
  2 & -4 & 1 \\
  0 & 2 & -3
\end{bmatrix}^{-1} \begin{bmatrix}
  1 \\
  0 \\
  -1
\end{bmatrix} = \begin{bmatrix}
  \frac{17}{8} \\
  \frac{11}{8} \\
  \frac{5}{4}
\end{bmatrix}
\]
Chapter 8 | Matrix Algebra

You can convert a system of linear equations to a matrix, and a matrix to a system of equations by choosing Compute > Rewrite > Equations as Matrix and Compute > Rewrite > Matrix as Equations, respectively.

To convert a system of equations to a matrix
1. Place the insert point in a system of equations that has been created as a list or one-column matrix.
2. Choose Compute > Rewrite > Equations as Matrix.
3. In the dialog that appears, type the variables separated by commas. Choose OK.

**Compute > Rewrite > Equations as Matrix**

(Variable(s): \(x, y\))

\[ \begin{align*} x + 2y &= 3, \quad 3x - 5y = 0 \end{align*} \]

Corresponding matrix: 
\[
\begin{bmatrix}
1 & 2 & 3 \\
3 & -5 & 0 \\
\end{bmatrix}
\]

(Variable(s): \(x, y, z\))

\[
\begin{align*}
x + y - 2z &= 1 \\
2x - 4y + z &= 0 \\
2y - 3z &= -1
\end{align*}
\]

Corresponding matrix: 
\[
\begin{bmatrix}
1 & 1 & -2 & 1 \\
2 & -4 & 1 & 0 \\
0 & 2 & -3 & -1
\end{bmatrix}
\]

To change a matrix to a system of equations
1. Place the insert point in an \(m \times n\) matrix.
2. Choose Compute > Rewrite > Matrix as Equations.
3. In the dialog that appears, type the variables separated by commas and choose OK.

**Compute > Rewrite > Matrix as Equations**

(Variable List: \(x, y\))

\[
\begin{pmatrix}
1 & 1 & -1 \\
2 & -3 & 1
\end{pmatrix}
\]

Corresponding equations: \(\{x + y = -1, 2x - 3y = 1\}\)

**Compute > Rewrite > Matrix as Equations**

(Variable List: \(x, y, z\))

\[
\begin{pmatrix}
1 & 1 & -2 & 1 \\
2 & -4 & 1 & 0 \\
0 & 2 & -3 & -1
\end{pmatrix}
\]

Corresponding equations: \(\{x + y - 2z = 1, 2x - 4y + z = 0, 2y - 3z = -1\}\)
The response is a list of equations. If you want these equations in a one-column matrix, use Matrices > Reshape, and specify 1 column.

**Compute > Matrices > Reshape**

\{x + y = -1, 2x - 3y = 1\}, \begin{cases} x + y = -1 \\ 2x - 3y = 1 \end{cases}

**Rotation Matrices**

The matrix product

\[
\begin{pmatrix}
\cos \theta & -\sin \theta \\
\sin \theta & \cos \theta
\end{pmatrix}
\begin{pmatrix}
x \\
y
\end{pmatrix}
= \begin{pmatrix}
x \cos \theta - y \sin \theta \\
y \cos \theta + x \sin \theta
\end{pmatrix}
\]

has the effect of rotating the vector \( \begin{pmatrix} x \\ y \end{pmatrix} \) through an angle \( \theta \) in a counter-clockwise direction about the origin. You can visualize this by using an animation.

**Compute > Plot 2D Animated > Rectangular**

\[
\begin{pmatrix}
\cos \theta & -\sin \theta \\
\sin \theta & \cos \theta
\end{pmatrix}
\begin{pmatrix}
x \\
0
\end{pmatrix}
\]

\(0 \leq \theta \leq 2\pi, \ 0 \leq x \leq 1\)

You can also rotate a parametric curve. In the following, the curve \((x^2, x^3)\) is rotated through an angle \(\theta\), as \(\theta\) increases from 0 to \(2\pi\).
Chapter 8 | Matrix Algebra

Compute > Plot 2D Animated > Rectangular

$$\begin{pmatrix} \cos \theta & -\sin \theta \\ \sin \theta & \cos \theta \end{pmatrix} \begin{pmatrix} x^2 \\ x^3 \end{pmatrix}$$

$$0 \leq \theta \leq 2\pi, -1 \leq x \leq 1$$

The following depicts the rotation of the surface $(x, y, \sin x + \cos y)$ about the $y$-axis.

Compute > Plot 3D Animated > Rectangular

$$\begin{pmatrix} \cos \theta & 0 & -\sin \theta \\ 0 & 1 & 0 \\ \sin \theta & 0 & \cos \theta \end{pmatrix} \begin{pmatrix} x \\ y \\ \sin x + \cos y \end{pmatrix}$$

$$0 \leq \theta \leq 2\pi, -6 \leq x \leq 6, -6 \leq y \leq 6$$

This three-dimensional animation uses one of these $3 \times 3$ rotation matrices.
Matrix Operators

A matrix operator is a function that operates on matrices. The Matrices menu contains a number of matrix operators.

Trace

The trace of an $n \times n$ matrix is the sum of the diagonal elements. This operation applies to square matrices only.

To compute the trace of a square matrix

1. Place the insert point in the matrix.

2. Choose Compute > Matrices > Trace.

Compute > Matrices > Trace

\[
\begin{pmatrix}
a & b \\
c & d
\end{pmatrix}
\text{Trace: } a + d
\begin{pmatrix}
-85 & -55 & -37 \\
-35 & 97 & 50 \\
79 & 56 & 49
\end{pmatrix}
\text{Trace: } 61
\]

Transpose and Hermitian Transpose

The transpose of an $m \times n$ matrix is the $n \times m$ matrix that you obtain from the first matrix by interchanging the rows and columns.

To compute the transpose of a matrix

1. Place the insert point in the matrix.

2. Choose Compute > Matrices > Transpose.

Compute > Matrices > Transpose

\[
\begin{pmatrix}
a & b \\
c & d
\end{pmatrix}
\text{Transpose: } \begin{pmatrix}
a & c \\
b & d
\end{pmatrix}
\]

You can also compute the transpose of a matrix or vector by using the superscript $T$. 

\[
\begin{pmatrix}
cos \theta & -\sin \theta \\
\sin \theta & cos \theta
\end{pmatrix}
\begin{pmatrix}
0 & 0 & 1 \\
0 & 0 & 0
\end{pmatrix}
\begin{pmatrix}
1 & 0 & 0 \\
0 & cos \theta & -sin \theta
\end{pmatrix}
\begin{pmatrix}
0 & 0 & 0 \\
sin \theta & cos \theta & 0
\end{pmatrix}
\begin{pmatrix}
0 & 0 & 1 \\
sin \theta & 0 & cos \theta
\end{pmatrix}
\begin{pmatrix}
1 & 0 & 0 \\
0 & sin \theta & cos \theta
\end{pmatrix}
\]

Rotate about $z$ axis

Rotate about $y$ axis

Rotate about $x$ axis
Chapter 8 | Matrix Algebra

Compute > Evaluate

\[
\begin{pmatrix}
a & b & c \\
d & e & f
\end{pmatrix}^T =
\begin{pmatrix}
a & d \\
b & e \\
c & f
\end{pmatrix}
\]

\[
\begin{pmatrix}
a \\
b
\end{pmatrix}^T
\begin{pmatrix}
c \\
d
\end{pmatrix} = ac + bd
\]

The last example demonstrates a common way to take the inner product of vectors.

The Hermitian transpose of a matrix is the transpose together with the replacement of each entry by its complex conjugate. It is also referred to as the adjoint or Hermitian adjoint or conjugate transpose of a matrix (not to be confused with the classical adjoint or adjugate, discussed elsewhere in this chapter.)

To compute the Hermitian transpose of a matrix

1. Place the insert point in the matrix.

2. Choose Compute > Matrices > Hermitian Transpose.

\[
\begin{pmatrix}
2 + i & -i \\
4 - i & 2 + i
\end{pmatrix} \text{ Hermitian Transpose: } \begin{pmatrix}
2 - i & 4 + i \\
i & 2 - i
\end{pmatrix}
\]

You can also compute the Hermitian transpose of a matrix using the superscript \( H \).

\[
\begin{pmatrix}
i & 2 + i \\
4i & 3 - 2i
\end{pmatrix}^H = \begin{pmatrix}
-i & -4i \\
2 - i & 3 + 2i
\end{pmatrix}
\]

To compute the Hermitian transpose of a matrix with non-numeric entries, first assume real variables.

**Note**

Type `assume` and `real` in mathematics mode, and they will turn upright and gray.

\[
\begin{align*}
\text{Compute } & > \text{ Evaluate} \\
\text{assume } (a, \text{real}) &= \mathbb{R} \\
\text{assume } (b, \text{real}) &= \mathbb{R} \\
\text{assume } (c, \text{real}) &= \mathbb{R} \\
\text{assume } (d, \text{real}) &= \mathbb{R} \\
\text{Compute } & > \text{ Evaluate} \\
\text{assume } (e, \text{real}) &= \mathbb{R} \\
\text{assume } (f, \text{real}) &= \mathbb{R} \\
\text{assume } (g, \text{real}) &= \mathbb{R} \\
\text{assume } (h, \text{real}) &= \mathbb{R}
\end{align*}
\]
Matrix Operators

**Compute > Matrices > Hermitian Transpose**

$$\begin{pmatrix} a + ib & c + id \\ e + if & g + ih \end{pmatrix} \text{ Hermitian Transpose: } \begin{pmatrix} a - ib & e - if \\ c - id & g - ih \end{pmatrix}$$

**Determinant**

The determinant of an $n \times n$ matrix $(a_{ij})$ is the sum and difference of certain products of the entries. Specifically,

$$\det(a_{ij}) = \sum_{\sigma} (-1)^{\text{sgn}(\sigma)} a_{1\sigma(1)}a_{2\sigma(2)} \cdots a_{n\sigma(n)}$$

where $\sigma$ ranges over all the permutations of $\{1, 2, \ldots, n\}$ and $(-1)^{\text{sgn}(\sigma)} = \pm 1$, depending on whether $\sigma$ is an even or odd permutation.

**Note**

Determinants apply to square matrices only.

To compute the determinant of a square matrix

1. Place the insert point in the matrix.
2. Choose Compute > Matrices > Determinant.

**Compute > Matrices > Determinant**

$$\begin{pmatrix} a & b \\ c & d \end{pmatrix} \text{ Determinant: } ad - bc \quad \begin{pmatrix} -85 & -55 & -37 \\ -35 & 97 & 50 \\ 79 & 56 & 49 \end{pmatrix} \text{ Determinant: } -121529$$

$$\begin{pmatrix} a_{1,1} & a_{1,2} & a_{1,3} \\ a_{2,1} & a_{2,2} & a_{2,3} \\ a_{3,1} & a_{3,2} & a_{3,3} \end{pmatrix} \text{ Determinant: } a_{1,1}a_{2,2}a_{3,3} - a_{1,1}a_{2,3}a_{3,2} - a_{2,1}a_{1,2}a_{3,3} + a_{2,1}a_{1,3}a_{3,2} + a_{3,1}a_{1,2}a_{2,3} - a_{3,1}a_{1,3}a_{2,2}$$

You can compute the determinant by enclosing the matrix in vertical expanding brackets or by using the function $\det$, then choosing Compute > Evaluate.

**Compute > Evaluate**

$$\begin{vmatrix} -35 & 50 \\ 79 & 49 \end{vmatrix} = -5665 \quad \det \begin{pmatrix} a & b \\ c & d \end{pmatrix} = ad - bc$$

$$\det \begin{vmatrix} -35 & 50 \\ 79 & 49 \end{vmatrix} = -5665 \quad \begin{vmatrix} -85 & -55 & 82 \\ -35 & 97 & -17 \\ 42 & 33 & -65 \end{vmatrix} = 223857$$

**Tip**

Create vertical brackets by selecting the matrix and typing Ctrl+\ or by choosing Insert > Math Objects > Brackets and clicking $\lbrack$.

To obtain the function $\det$, type the letters $det$ in mathematics, and they will turn gray when the $t$ is typed. You can also choose Insert > Math Objects > Math Names and select $\det$ from a list.
Chapter 8 | Matrix Algebra

Adjugate

The adjugate or classical adjoint of a matrix $A$ is the transpose of the matrix of cofactors of $A$. The $i, j$ cofactor $A_{ij}$ of $A$ is the scalar $(-1)^{i+j} \det A \ (i|j)$, where $A \ (i|j)$ denotes the matrix that you obtain from $A$ by removing the $i$th row and $j$th column.

**Compute > Matrices > Adjugate**

$$
\begin{pmatrix}
  a & b \\
  c & d \\
\end{pmatrix}
\text{Adjugate: }
\begin{pmatrix}
  d & -b \\
  -c & a \\
\end{pmatrix}
$$

$$
\begin{pmatrix}
  a & b & c \\
  d & e & f \\
  g & h & j \\
\end{pmatrix}
\text{Adjugate: }
\begin{pmatrix}
  e j - f h & -b j + c h & b f - c e \\
  -d j + f g & a j - c g & -a f + c d \\
  d h - e g & -a h + b g & a e - b d \\
\end{pmatrix}
$$

$$
\begin{bmatrix}
  9 & 6 & 7 & -5 \\
  4 & -8 & -3 & 92 \\
 -3 & -6 & 7 & 6 \\
  5 & -5 & 0 & -1 \\
\end{bmatrix}
\text{Adjugate: }
\begin{bmatrix}
  3384 & 469 & -3183 & 7130 \\
  3329 & 301 & -3200 & -8153 \\
  4068 & -261 & 6896 & -2976 \\
  275 & 840 & 85 & -1116 \\
\end{bmatrix}
$$

The product of a matrix with its adjugate is diagonal, with the entries on the diagonal equal to the determinant of the matrix.

$$
\begin{pmatrix}
  a & b \\
  c & d \\
\end{pmatrix}
\begin{pmatrix}
  d & -b \\
  -c & a \\
\end{pmatrix}
= 
\begin{pmatrix}
  ad - bc & 0 \\
  0 & ad - bc \\
\end{pmatrix}
$$

This relationship yields a well-known formula for the inverse of an invertible matrix $A$:

$$
A^{-1} = \frac{1}{\det A} \text{adjugate} A
$$
Matrix Operators

Permanent

The permanent of an $n \times n$ matrix $(a_{ij})$ is the sum of certain products of the entries. Specifically,

$$\text{permanent}(a_{ij}) = \sum_\sigma a_{1\sigma(1)}a_{2\sigma(2)}\cdots a_{n\sigma(n)}$$

where $\sigma$ ranges over all the permutations of $\{1, 2, \ldots, n\}$. This operation applies to square matrices only.

To compute the permanent of a matrix

1. Place the insert point in the matrix.

2. Choose Compute > Matrices > Permanent.

Maximum and Minimum Matrix Entries

The functions max and min applied to a matrix with integer entries will return the entry with maximum or minimum value.
Chapter 8 | Matrix Algebra

**Compute > Evaluate**

\[
\begin{bmatrix}
-85 & -55 & -37 & -35 & 97 \\
50 & 79 & 56 & 49 & 63 \\
57 & -59 & 45 & -8 & -93
\end{bmatrix}
\]

\[\max = 97\]

\[
\begin{bmatrix}
92 & 43 & -62 & 77 & 66 \\
54 & -5 & 99 & -61 & -50 \\
-12 & -18 & 31 & -26 & -62 \\
1 & -47 & -91 & -47 & -61
\end{bmatrix}
\]

\[\min = -91\]

**Matrix Norms**

Choosing Compute > Matrices > Norm gives the Euclidean norm of a vector or matrix. The Euclidean norm, or 2-norm, of a vector is the Euclidean length of the vector:

\[
\left\| \begin{bmatrix} a \\ b \end{bmatrix} \right\| = \sqrt{a^2 + b^2} \\
\left\| \begin{bmatrix} a \\ b \\ c \\ d \end{bmatrix} \right\| = \sqrt{a^2 + b^2 + c^2 + d^2}
\]

The Euclidean norm, or 2-norm, of a matrix \(A\) with real or complex entries is its largest singular value—the number defined by

\[
\|A\| = \max_{x \neq 0} \frac{\|Ax\|}{\|x\|}
\]

This can also be computed as \(\max \{ \sqrt{|E_i|} \} \) where the \(E_i\)'s range over the eigenvalues of the matrix \(AA^H\).

**Compute > Matrices > Norm**

\[
\begin{bmatrix} 2 & 3 \\ 5 & 7 \end{bmatrix} \text{ Norm: 9.3268} \\
\begin{bmatrix} 2 & -1 & 0 \\ -1 & 2 & -1 \\ 0 & -1 & 2 \end{bmatrix} \text{ Norm: 3.4142}
\]

\[
\begin{bmatrix} 3 \\ 4 \end{bmatrix} \text{ Norm: 5} \\
\begin{bmatrix} 1 & 1 \\ 2 & 1 \\ 1 & 1 \end{bmatrix} \text{ Norm: } \sqrt{\frac{1^2}{2} + \frac{0^2}{2}}
\]

\[
\begin{bmatrix} 2 + 3i \\ 6 \end{bmatrix} \text{ Norm: 9.9378} \\
\begin{bmatrix} 3 + 4i \\ 1 - 5i \end{bmatrix} \text{ Norm: } \sqrt{51}
\]
Matrix Operators

The Euclidean norm of a matrix can also be obtained with double brackets.

To put norm symbols around a matrix
1. Select the matrix by using the mouse.
2. Choose Insert > Math Objects > Brackets, and select the norm symbols.
3. Choose OK.

Compute > Evaluate

\[
\begin{bmatrix} 0.2 & 0.3 \\ 0.5 & 0.7 \end{bmatrix} = 0.93268 \quad \begin{bmatrix} 5 & 7 \\ -13 & 6 \end{bmatrix} = 14.454
\]

\[
\begin{bmatrix} 2 + 3i & 5 \\ 6 & -7 + 2i \end{bmatrix} = 9.9378
\]

The 1-norm of a matrix is the maximum among the sums of the absolute values of the terms in a column:

\[
\| A \|_1 = \max_{1 \leq j \leq n} \left( \sum_{i=1}^{n} |a_{ij}| \right)
\]

To generate the 1-norm
- Type 1 as a subscript on the norm brackets.

Compute > Evaluate

\[
\begin{bmatrix} a & b \\ c & d \end{bmatrix}_1 = \max (|a| + |c|, |b| + |d|) \quad \begin{bmatrix} 0.2234 & 0.3158 \\ -0.5624 & 0.7111 \end{bmatrix}_1 = 1.0269
\]

\[
\begin{bmatrix} 5 & 7 \\ -13 & 6 \end{bmatrix}_1 = 18 \quad \begin{bmatrix} 5 + 3i & 7 \\ -13 & 6 - 5i \end{bmatrix}_1 = \sqrt{34} + 13
\]

The \(\infty\)-norm of a matrix is the maximum among the sums of the absolute values of the terms in a row:

\[
\| A \|_\infty = \max_{1 \leq j \leq n} \left( \sum_{i=1}^{n} |a_{ij}| \right)
\]
Chapter 8 | Matrix Algebra

To generate the $\infty$-norm

- Enter $\infty$ as a subscript on the norm brackets.

\[
\begin{bmatrix} a & b \\ c & d \end{bmatrix}_{\infty} = \max(|a| + |b|, |c| + |d|)
\]

\[
\begin{bmatrix} 0.2234 & 0.3158 \\ -0.5624 & 0.7111 \end{bmatrix}_{\infty} = 1.2735
\]

\[
\begin{bmatrix} 5 & 7 \\ -13 & 6 \end{bmatrix}_{\infty} = 19
\]

\[
\begin{bmatrix} 5+3i & 7 \\ -13 & 6-5i \end{bmatrix}_{\infty} = 13 + \sqrt{61}
\]

The Hilbert-Schmidt norm (or Frobenius norm) $\|A\|_F$ of a matrix $A$ is the square root of the sums of the squares of the terms of the matrix $A$. This is also sometimes called the Euclidean norm, although it is not the same as the 2-norm (see page 312).

\[
\|A\|_F = \left( \sum_{1 \leq i,j \leq n} |a_{ij}|^2 \right)^{\frac{1}{2}}
\]

\[
\begin{bmatrix} 5+3i & 7 \\ -13 & 6-5i \end{bmatrix}_F = \sqrt{313}
\]

\[
\begin{bmatrix} a & b \\ c & d \end{bmatrix}_F = \sqrt{(|a|^2 + |b|^2 + |c|^2 + |d|^2)}
\]

\[
\begin{bmatrix} 0.2234 & 0.3158 \\ -0.5624 & 0.7111 \end{bmatrix}_F = 0.98569
\]

Spectral Radius

The spectral radius of a real symmetric matrix is the largest of the absolute values of the eigenvalues of the matrix.

\[
\begin{bmatrix} 5 & -3 & 1 \\ -3 & 0 & 5 \\ 1.0 & 5 & 4 \end{bmatrix} \text{ Spectral Radius: 7.7627}
\]

\[
\begin{bmatrix} 5 & -4 \\ -4 & 3.0 \end{bmatrix} \text{ Spectral Radius: 8.1231}
\]
Matrix Operators

Compute > Matrices > Eigenvalues

\[
\begin{bmatrix}
5 & -3 & 1 \\
-3 & 0 & 5 \\
1.0 & 5 & 4
\end{bmatrix}
\]
Eigenvalues: 7.7627, 5.6174, -4.3801

\[
\begin{bmatrix}
5 & -4 \\
-4 & 3.0
\end{bmatrix}
\]
Eigenvalues: 8.1231, -0.1231

**Condition Number**

The condition number of an invertible matrix $A$ is the product of the 2-norm of $A$ and the 2-norm of $A^{-1}$. This number measures the sensitivity of some solutions of linear equations $Ax = b$ to perturbations in the entries of $A$ and $b$. The matrix with condition number 1 is perfectly conditioned.

Compute > Matrices > Condition Number

\[
\begin{bmatrix}
0 & 1 \\
1 & 0
\end{bmatrix}, \text{ condition number: 1.0}
\]

\[
\begin{bmatrix}
1 & 1 & 1 & 1 \\
1/2 & 1/3 & 1/4 & 1/5 \\
1/3 & 1/4 & 1/5 & 1/6 \\
1/4 & 1/5 & 1/6 & 1/7
\end{bmatrix}, \text{ condition number: 15514.0}
\]

Compute > Matrices > Condition Number

\[
\begin{bmatrix}
18 & 7 \\
3 & -4
\end{bmatrix}, \text{ Condition Number: 4.0315}
\]

\[
\begin{bmatrix}
1 & 1 \\
1 & 1.00001
\end{bmatrix}, \text{ Condition Number: } 4.0 \times 10^5
\]

These final two matrices are extremely ill-conditioned. Small changes in some entries of $A$ or $b$ may result in large changes in the solution to linear equations of the form $Ax = b$ in these two cases.
Chapter 8 | Matrix Algebra

Exponential Functions

A natural way to define $e^M$ is to imitate the power series for $e^x$

$$e^x = 1 + x + \frac{1}{2}x^2 + \frac{1}{6}x^3 + \frac{1}{24}x^4 + \cdots$$

$$e^M = 1 + M + \frac{1}{2}M^2 + \frac{1}{6}M^3 + \frac{1}{24}M^4 + \cdots$$

and more generally,

$$e^{tM} = \sum_{k=0}^{\infty} \frac{(tM)^k}{k!}$$

To evaluate the expression $e^M$ (or $\exp(M)$) for a matrix $M$

- Leave the insert point in the expression $e^M$ and choose Compute > Evaluate.

\[
A = \begin{bmatrix} 1 & 2 \\ 0 & 3 \end{bmatrix} \quad B = \begin{bmatrix} 1 & 2 \\ 0 & 1 \end{bmatrix}
\]

\[
C = \begin{bmatrix} 0 & 1 & 0 \\ 0 & 0 & 1 \\ 0 & 0 & 0 \end{bmatrix} \quad D = \begin{bmatrix} 1 & 3 & 0 \\ 0 & 1 & 0 \\ 0 & 0 & 1 \end{bmatrix}
\]

\[
e^A = \begin{bmatrix} e & e^3 - e \\ 0 & e^3 \end{bmatrix} \quad e^A = \begin{bmatrix} e^t & e^{3t} - e^t \\ 0 & e^{3t} \end{bmatrix}
\]

\[
\exp(A) = \begin{bmatrix} e & -e + e^3 \\ 0 & e^3 \end{bmatrix} \quad \exp(tA) = \begin{bmatrix} e^t & -e^t + e^{3t} \\ 0 & e^{3t} \end{bmatrix}
\]

\[
e^{A+B} = \begin{bmatrix} e^2 & -2e^2 + 2e^4 \\ 0 & e^4 \end{bmatrix} \quad De^C D^{-1} = \begin{bmatrix} 1 & t & \frac{3t + \frac{1}{2}t^2}{2} \\ 0 & 1 & t \\ 0 & 0 & 1 \end{bmatrix}
\]

\[
e^{A+B} = \begin{bmatrix} e^2 & 2e^2 - e(e - e^3) \\ 0 & e^4 \end{bmatrix} \quad e^{DtCD^{-1}} = \begin{bmatrix} 1 & t & t^2 \left( \frac{3}{t} + \frac{1}{2} \right) \\ 0 & 1 & t \left( \frac{3}{t} + 1 \right) - 3 \\ 0 & 0 & 1 \end{bmatrix}
\]
Note that one of the properties of exponents that holds for real numbers fails for matrices. The equality \( e^{A+B} = e^A e^B \) requires that \( AB = BA \), and this property fails to hold for the matrices in the example. However, exponentiation preserves the property of similarity, as demonstrated by \( D e^{C D^{-1}} = e^{D C D^{-1}} \).

**Polynomials and Vectors Associated with a Matrix**

A square matrix has a characteristic and a minimal (minimum) polynomial. The characteristic polynomial determines eigenvalues and eigenvectors of the matrix. Eigenvalues are an important feature of any dynamical system. One important application is to the solution of a system of ordinary differential equations.

**Characteristic Polynomial and Minimal Polynomial**

The characteristic polynomial of a square matrix \( A \) is the determinant of the characteristic matrix \( x I - A \).

**Compute > Matrices > Characteristic Polynomial**

\[
\begin{pmatrix}
4 & 1 & 0 \\
0 & 4 & 0 \\
0 & 0 & 4
\end{pmatrix}
\]

Characteristic Polynomial: \( X^3 - 12X^2 + 48X - 64 \)

**Compute > Evaluate**

\[
X \begin{pmatrix}
1 & 0 & 0 \\
0 & 1 & 0 \\
0 & 0 & 1
\end{pmatrix}
- \begin{pmatrix}
4 & 1 & 0 \\
0 & 4 & 0 \\
0 & 0 & 4
\end{pmatrix}
= \begin{pmatrix}
-4 + X & -1 & 0 \\
0 & -4 + X & 0 \\
0 & 0 & -4 + X
\end{pmatrix}
\]

\[
\det \begin{pmatrix}
-4 + X & -1 & 0 \\
0 & -4 + X & 0 \\
0 & 0 & -4 + X
\end{pmatrix}
= (X - 4)^3
\]

The minimal polynomial of a square matrix \( A \) is the monic polynomial \( p(x) \) of smallest degree such that \( p(A) = 0 \). This is often called the minimum polynomial of \( A \).

By the Cayley-Hamilton theorem, \( f(A) = 0 \) if \( f(x) \) is the characteristic polynomial of \( A \). The minimal polynomial of \( A \) is a factor of the characteristic polynomial of \( A \).
Chapter 8 | Matrix Algebra

**Compute > Matrices > Minimal Polynomial**

\[
\begin{pmatrix}
4 & 1 & 0 \\
0 & 4 & 0 \\
0 & 0 & 4 \\
\end{pmatrix}
\]

Minimal Polynomial: \( X^2 - 8X + 16 \)

**Compute > Factor**

\( X^2 - 8X + 16 = (X - 4)^2 \)

**Example**

This example illustrates the Cayley-Hamilton theorem.

Define \( p(X) = X^2 - 8X + 16X^0 \) and \( A = \begin{pmatrix}
4 & 1 & 0 \\
0 & 4 & 0 \\
0 & 0 & 4 \\
\end{pmatrix} \).

Choose Compute > Evaluate to get

\[
p(A) = \begin{pmatrix}
0 & 0 & 0 \\
0 & 0 & 0 \\
0 & 0 & 0 \\
\end{pmatrix}
\]

The minimal and characteristic polynomial operations have to return a variable for the polynomial. In the preceding examples, they returned \( X \). However, the variable used depends on the matrix entries and you do not need to avoid \( X \) in the matrix. You will be asked to supply a name for the polynomial variable.

**Compute > Matrices > Minimal Polynomial**

(Polynomial Variable \( \lambda \))

\[
\begin{pmatrix}
3X & x \\
5 & y \\
\end{pmatrix}
\]

Minimal Polynomial: \( \lambda^2 + (-3X - y)\lambda + 3Xy - 5x \)

**Eigenvalues and Eigenvectors**

Given a matrix \( A \), the matrix commands Eigenvectors and Eigenvalues on the Matrices submenu find scalars \( c \) and nonzero vectors \( v \) for which \( Av = cv \). If there is a floating-point number in the matrix, the result is a numerical solution. Otherwise, the result is an exact symbolic solution or no solution. When a solution is not found, change at least one entry to floating point to obtain a numeric solution.

These scalars and vectors are sometimes called characteristic values and characteristic vectors. The eigenvalues, or characteristic values, are roots of the characteristic polynomial.

318
Polynomials and Vectors Associated with a Matrix

Compute > Matrices > Eigenvalues

\[
\begin{pmatrix}
\cos \alpha & -\sin \alpha \\
\sin \alpha & \cos \alpha \\
\end{pmatrix}
\]

Eigenvalues: \(\cos \alpha + (i \sin \alpha), \cos \alpha - (i \sin \alpha)\)

This matrix has characteristic polynomial \(X^2 - 2X \cos \alpha + 1\). Replacing \(X\) by the eigenvalue \(\cos \alpha + i \sin \alpha\) and applying Simplify gives

\[
(\cos \alpha + i \sin \alpha)^2 - 2(\cos \alpha + i \sin \alpha)\cos \alpha + 1 = 0
\]
demonstrating that eigenvalues are roots of the characteristic polynomial. Note the different results obtained using integer versus floating-point entries.

Compute > Matrices > Eigenvalues

\[
\begin{pmatrix}
1 & 2 \\
3 & 4 \\
\end{pmatrix}
\]

Eigenvalues: \(\frac{1}{2} \sqrt{33} + \frac{5}{2}, \frac{5}{2} - \frac{1}{2} \sqrt{33}\)

\[
\begin{pmatrix}
1.0 & 2 \\
3 & 4 \\
\end{pmatrix}
\]

Eigenvalues: \(5.3723, -0.37228\)

When you choose Compute > Matrices > Eigenvectors, the system returns eigenvectors paired with the corresponding eigenvalues. The eigenvectors are grouped by eigenvalues, making the multiplicity for each eigenvalue apparent. Symbolic solutions will be returned in some cases. When a symbolic solution is not found, change at least one entry to floating point to obtain a numeric solution.

Compute > Matrices > Eigenvectors

\[
\begin{pmatrix}
49 & -69 & 99 \\
23 & -81 & 20 \\
48 & 1.0 & -87 \\
\end{pmatrix}
\]

Eigenvalues: \(\begin{pmatrix} 0.93733 \\ 0.18622 \\ 0.29451 \end{pmatrix}\) ↔ 66.398

\[
\begin{pmatrix}
0.1599 \\
0.88794 \\
0.43127 \\
\end{pmatrix}
\]

↔ -67.144, \(\begin{pmatrix} 0.54043 \\ 0.11389 \\ -0.83364 \end{pmatrix}\) ↔ -118.25

\[
\begin{pmatrix}
5 & -6 & -6 \\
-1 & 4 & 2 \\
3 & -6 & -4 \\
\end{pmatrix}
\]

Eigenvalues: \(\begin{pmatrix} -\frac{1}{3} \\ \frac{2}{3} \\ 0 \end{pmatrix}\) ↔ 1, \(\begin{pmatrix} 2 \\ 1 \\ 0 \end{pmatrix}\) ↔ 2
Chapter 8 | Matrix Algebra

In the preceding example, 1 is an eigenvalue occurring with multiplicity 1, and 2 is an eigenvalue occurring with multiplicity 2. The defining property $Av = cv$ is illustrated in the following example:

**Compute > Evaluate**

$$
\begin{pmatrix}
5 & -6 & -6 \\
-1 & 4 & 2 \\
3 & -6 & -4
\end{pmatrix}
\begin{pmatrix}
2 \\
1 \\
0
\end{pmatrix} =
\begin{pmatrix}
4 \\
2 \\
0
\end{pmatrix} = 2
\begin{pmatrix}
2 \\
1 \\
0
\end{pmatrix}
$$

$$
\begin{pmatrix}
5 & -6 & -6 \\
-1 & 4 & 2 \\
3 & -6 & -4
\end{pmatrix}
\begin{pmatrix}
2 \\
0 \\
1
\end{pmatrix} =
\begin{pmatrix}
4 \\
0 \\
2
\end{pmatrix} = 2
\begin{pmatrix}
2 \\
0 \\
1
\end{pmatrix}
$$

$$
\begin{pmatrix}
5 & -6 & -6 \\
-1 & 4 & 2 \\
3 & -6 & -4
\end{pmatrix}
\begin{pmatrix}
-3 \\
1 \\
-3
\end{pmatrix} =
\begin{pmatrix}
-3 \\
1 \\
-3
\end{pmatrix}
$$

**Positive Definite Matrices**

A square matrix is called Hermitian if it is equal to its conjugate transpose. A Hermitian matrix with real entries is the same as a symmetric matrix.

A Hermitian matrix $A$ is positive definite if all the eigenvalues of $A$ are positive. Otherwise, the computational engine MuPAD classifies $A$ as indefinite.

An indefinite Hermitian matrix $A$ is sometimes classified as positive semidefinite if all the eigenvalues of $A$ are nonnegative; as negative definite if all the eigenvalues are negative; and as negative semidefinite if all the eigenvalues are nonpositive.

**Compute > Matrices > Definiteness Tests**

$$
\begin{pmatrix}
2 & -1 \\
-1 & 2
\end{pmatrix}
\text{is positive definite}
\quad
\begin{pmatrix}
1 & -1 \\
-1 & 1
\end{pmatrix}
\text{is indefinite}
$$

$$
\begin{pmatrix}
2 & -i \\
i & 1
\end{pmatrix}
\text{is positive definite}
\quad
\begin{pmatrix}
-2 & i \\
-i & -2
\end{pmatrix}
\text{is indefinite}
$$
Vector Spaces Associated with a Matrix

Four vector spaces are naturally associated with an $m \times n$ matrix $A$: the row space, the column space, and the left and right nullspaces.

A basis for a vector space is a linearly independent set of vectors that spans the space. Commands on the Matrices submenu find bases for these vector spaces. These bases are not unique and different methods may compute different bases.

The Row Space

The row space of a matrix $A$ is the vector space spanned by the row vectors of $A$. Any choice of row basis has the same number of vectors and spans the same vector space. However, there is no natural choice for the vectors that make up a row basis.

You can find other bases for the row space by choosing Compute > Matrices > Reduced Row Echelon Form, or by choosing Compute > Matrices > Fraction-Free Gaussian Elimination and then taking the nonzero rows from the result.

To find a basis for the row space

1. Leave the insert point in the matrix.

2. Choose Compute > Matrices > Row Basis.
Chapter 8 | Matrix Algebra

**Compute > Matrices > Row Basis**

\[
\begin{bmatrix}
-1 & 3 \\
5 & -15
\end{bmatrix}
\]
Row Basis: \[
\begin{bmatrix}
-1 & 3 \\
5 & -15
\end{bmatrix}
\]

\[
\begin{bmatrix}
-85 & -55 & -37 & -35 \\
97 & 50 & 79 & 56 \\
49 & 63 & 57 & -59 \\
-36 & 8 & 20 & -94
\end{bmatrix}
\]
Row Basis:

\[
\left[
\begin{bmatrix}
-85 & -55 & -37 & -35 \\
97 & 50 & 79 & 56 \\
49 & 63 & 57 & -59 \\
-36 & 8 & 20 & -94
\end{bmatrix}
\right]
\]

**Compute > Matrices > Reduced Row Echelon Form**

\[
\begin{bmatrix}
-85 & -55 & -37 & -35 \\
97 & 50 & 79 & 56 \\
49 & 63 & 57 & -59 \\
-36 & 8 & 20 & -94
\end{bmatrix}
\]
Reduced Row Echelon Form:

\[
\begin{bmatrix}
1 & 0 & 0 & \frac{133337}{68264} \\
0 & 1 & 0 & -\frac{74049}{34132} \\
0 & 0 & 1 & -\frac{3085}{9752} \\
0 & 0 & 0 & 0
\end{bmatrix}
\]

The nonzero rows in the preceding matrix give the following basis for the row space:

\[
\begin{bmatrix}
1 & 0 & 0 & \frac{133337}{68264} \\
0 & 1 & 0 & -\frac{74049}{34132} \\
0 & 0 & 1 & -\frac{3085}{9752}
\end{bmatrix}
\]

**Compute > Matrices > Fraction Free Gaussian Elimination**

\[
\begin{bmatrix}
-85 & -55 & -37 & -35 \\
97 & 50 & 79 & 56 \\
49 & 63 & 57 & -59 \\
-36 & 8 & 20 & -94
\end{bmatrix}
\]
Fraction Free Gaussian Elimination:

\[
\begin{bmatrix}
-85 & -55 & -37 & -35 \\
0 & 1085 & -3126 & -1365 \\
0 & 0 & 136528 & -43190 \\
0 & 0 & 0 & 0
\end{bmatrix}
\]

The nonzero rows in the preceding matrix give the following basis for the row space:

\[
\begin{bmatrix}
-85 & -55 & -37 & -35 \\
0 & 1085 & -3126 & -1365 \\
0 & 0 & 136528 & -43190
\end{bmatrix}
\]
Vector Spaces Associated with a Matrix

**Compute > Matrices > Gaussian Elimination**

\[
\begin{bmatrix}
-85 & -55 & -37 & -35 \\
97 & 50 & 79 & 56 \\
49 & 63 & 57 & -59 \\
-36 & 8 & 20 & -94
\end{bmatrix}
\]

Gaussian Elimination:

\[
\begin{bmatrix}
49 & 63 & 57 & -59 \\
0 & 380/7 & 3032/49 & -6730/49 \\
0 & 0 & 4876/95 & -617/38 \\
0 & 0 & 0 & 0
\end{bmatrix}
\]

The nonzero rows in the preceding matrix give the following basis for the row space:

\[
\begin{bmatrix}
\end{bmatrix}
\]

**The Column Space**

The column space of a matrix \(A\) is the vector space spanned by the columns of \(A\).

To find a basis for the column space

1. Leave the insert point in the matrix.
2. Choose Compute > Matrices > Column Basis.

**Compute > Matrices > Column Basis**

\[
\begin{bmatrix}
-85 & -55 & -37 & -35 \\
97 & 50 & 79 & 56 \\
49 & 63 & 57 & -59 \\
-36 & 8 & 20 & -94
\end{bmatrix}
\]

Column Basis:

\[
\begin{bmatrix}
-85 \\
97 \\
49 \\
-36
\end{bmatrix},
\begin{bmatrix}
-55 \\
50 \\
63 \\
8
\end{bmatrix},
\begin{bmatrix}
-37 \\
79 \\
57 \\
20
\end{bmatrix}
\]

You can also take the transpose of \(A\) and apply to the transpose the various other methods demonstrated in the previous section, because the column space of \(A\) is the same as the row space of \(A^T\).

**The Left and Right Nullspaces**

The (right) nullspace is the vector space consisting of all \(n \times 1\) vectors \(X\) satisfying \(AX = 0\). You find a basis for the nullspace by choosing Compute > Matrices > Nullspace Basis.
Chapter 8 | Matrix Algebra

**Compute > Matrices > Nullspace Basis**

\[
\begin{bmatrix}
-85 & -55 & -37 & -35 \\
97 & 50 & 79 & 56 \\
49 & 63 & 57 & -59 \\
-36 & 8 & 20 & -94
\end{bmatrix}
\]

Nullspace Basis:

\[
\begin{bmatrix}
-133337 \\
68264 \\
74049 \\
34732 \\
3085 \\
9752 \\
1
\end{bmatrix}
\]

The left nullspace is the vector space consisting of all \( 1 \times m \) vectors \( Y \) satisfying \( YA = 0 \). You find a basis for the left nullspace by first taking the transpose of \( A \) and then choosing Compute > Matrices > Nullspace Basis.

**Compute > Evaluate**

\[
\begin{bmatrix}
-85 & -55 & -37 & -35 \\
97 & 50 & 79 & 56 \\
49 & 63 & 57 & -59 \\
-36 & 8 & 20 & -94
\end{bmatrix}^T
\]

\[
\begin{bmatrix}
-85 & 97 & 49 & -36 \\
-55 & 50 & 63 & 8 \\
-37 & 79 & 57 & 20 \\
-35 & 56 & -59 & -94
\end{bmatrix}
\]

**Compute > Matrices > Nullspace Basis**

\[
\begin{bmatrix}
-85 & 97 & 49 & -36 \\
-55 & 50 & 63 & 8 \\
-37 & 79 & 57 & 20 \\
-35 & 56 & -59 & -94
\end{bmatrix}
\]

Nullspace Basis:

\[
\begin{bmatrix}
-1 \\
0 \\
-1 \\
1
\end{bmatrix}
\]

To check that this vector is in the left nullspace, take the transpose of the vector and check the product.

**Compute > Evaluate**

\[
\begin{bmatrix}
-1 \\
0 \\
-1 \\
1
\end{bmatrix}^T
\]

\[
\begin{bmatrix}
-85 & -55 & -37 & -35 \\
97 & 50 & 79 & 56 \\
49 & 63 & 57 & -59 \\
-36 & 8 & 20 & -94
\end{bmatrix}
\]

\[
\begin{bmatrix}
0 & 0 & 0 & 0
\end{bmatrix}
\]

**Orthogonal Matrices**

An orthogonal matrix is a real matrix for which the inner product of any two different columns is zero and the inner product of any column with itself is one. The matrix is said to have orthonormal columns. Such a matrix necessarily has orthonormal rows as well.
The QR Factorization and Orthonormal Bases

Any real matrix $A$ with at least as many rows as columns can be factored as a product $QR$, where $Q$ is an orthogonal matrix—that is, the columns of $Q$ are orthonormal (the inner product of any two different columns is 0, and the inner product of any column with itself is 1) and $R$ is upper-right triangular with the same rank as $A$. If the original matrix $A$ is square, then so is $R$. If $A$ is a square matrix with linearly independent columns, $R$ is invertible.

To obtain the QR factorization

1. Leave the insert point in a matrix.
2. Choose Compute $\to$ Matrices $\to$ QR Decomposition.

Compute $\to$ Matrices $\to$ QR Decomposition

$$
\begin{pmatrix}
3 & 0 \\
4 & 5 \\
\end{pmatrix}
$$

QR Decomposition:

$$
\begin{pmatrix}
\frac{3}{5} & -\frac{4}{5} \\
\frac{4}{5} & \frac{3}{5} \\
\end{pmatrix}
\begin{pmatrix}
5 & 4 \\
0 & 3 \\
\end{pmatrix}
$$

$$
\begin{pmatrix}
-4 & 2 \\
1 & -1 \\
0 & 2 \\
\end{pmatrix}
$$

QR Decomposition:

$$
\begin{pmatrix}
-\frac{4}{17}\sqrt{17} & -\frac{1}{17}\sqrt{2\sqrt{17}} \\
\frac{3}{17}\sqrt{17} & \frac{\sqrt{2}}{51}\sqrt{17} \\
0 & \frac{6}{51}\sqrt{2}\sqrt{17} \\
\end{pmatrix}
\begin{pmatrix}
\frac{\sqrt{17}}{51} & -\frac{9}{51}\sqrt{17} \\
0 & \frac{6}{51}\sqrt{2}\sqrt{17} \\
0 & 0 \\
\end{pmatrix}
$$

When $A$ is a square matrix with linearly independent columns, the two matrices $Q$ and $A = QR$ have the same column spaces.

Example  The preceding product comes from the following linear combinations.

$$
\begin{pmatrix}
3 \\
4 \\
\end{pmatrix} = 5 \begin{pmatrix}
\frac{3}{5} \\
\frac{4}{5} \\
\end{pmatrix} + 0 \begin{pmatrix}
-\frac{4}{5} \\
\frac{3}{5} \\
\end{pmatrix}
$$

and

$$
\begin{pmatrix}
0 \\
5 \\
\end{pmatrix} = 4 \begin{pmatrix}
\frac{3}{5} \\
\frac{4}{5} \\
\end{pmatrix} + 3 \begin{pmatrix}
-\frac{4}{5} \\
\frac{3}{5} \\
\end{pmatrix}
$$
Observe that the columns of $A$ are linear combinations of the columns of $Q$. Then, since both column spaces have dimension 2 and one contains the other, it follows that they must be the same space.

This conversion of the columns of $A$ into the orthonormal columns of $Q$ is referred to as the Gram–Schmidt orthogonalization process. In general, since $R$ is upper-right triangular, the subspace spanned by the first $k$ columns of the matrix $A = QR$ is the same as the subspace spanned by the first $k$ columns of the matrix $Q$.

**Rank and Dimension**

The rank of a matrix is the dimension of the column space. It is the same as the dimension of the row space or the number of nonzero singular values.

**Normal Forms of Matrices**

Any equivalence relation on a set of matrices partitions the set of matrices into a collection of equivalence classes. A normal form, or canonical form, for a matrix is a choice of another matrix that displays certain invariants for that equivalence class, usually together with an algorithm for constructing the form from the given matrix.

Two such equivalence relations are similarity and equivalence. Two $n \times n$ matrices $A$ and $B$ are similar if there is an invertible $n \times n$ matrix
Normal Forms of Matrices

C such that $B = C^{-1} AC$. Two $m \times n$ matrices $A$ and $B$ are equivalent if one can be obtained from the other by a sequence of elementary row and column operations. In other words, $B = QAP$ for some invertible matrices $Q$ and $P$.

When the context is matrices over the integers, “invertible” should be interpreted as “unimodular;” that is, both the matrix and its inverse have integer entries—in particular, a unimodular matrix has determinant 1. When the context is matrices over the ring $F[x]$ for a field $F$, “invertible” means both the matrix and its inverse have entries in $F[x]$.

Smith Normal Form

Every matrix $A$ over a principal ideal domain (PID) is equivalent to a diagonal matrix of the form

$$\text{diag}(1, \ldots, 1, p_1, p_2, \ldots, p_k, 0, \ldots, 0)$$

where for each $i$, $p_i$ is a factor of $p_{i+1}$. This matrix, which is uniquely determined by $A$, is called the Smith normal form of $A$. The diagonal entries of the Smith normal form of a matrix $A$ are the invariant factors of $A$. The Smith normal form of $A$ can be obtained as a matrix $S = QAP$ where $Q$ and $P$ are invertible over the PID.

Integer Matrices

The Smith normal form of an integer matrix $A$ is a matrix $S = QAP$ where $Q$ and $P$ are unimodular—nonsingular matrices with integer entries whose inverses also have integer entries. In particular, $Q$ and $P$ have determinant 1. You can find the Smith normal form of a square integer matrix.

| Compute > Matrices > Smith Normal Form |
| 2 9 5 | Smith Normal Form: | 1 0 0 |
| 3 4 3 | | 0 1 0 |
| 4 1 -1 | | 0 0 56 |

The following product illustrates the equivalence relation. The two new matrices that occur are unimodular.

$$\begin{pmatrix} 2 & 9 & 5 \\ 3 & 4 & 3 \\ 4 & 1 & -1 \end{pmatrix} \cdot \begin{pmatrix} 1 & 0 & 0 \\ 1 & 0 & 0 \\ 0 & 0 & 56 \end{pmatrix} = \begin{pmatrix} 1 & 0 & 0 \\ 1 & 0 & 21 \\ 0 & 0 & 1 \end{pmatrix} \cdot \begin{pmatrix} 2 & 9 & -5 \\ 3 & 4 & -3 \\ 4 & 1 & -2 \end{pmatrix} \cdot \begin{pmatrix} 1 & 0 & 0 \\ 0 & 1 & 0 \\ 0 & 0 & 1 \end{pmatrix}$$
Chapter 8 | Matrix Algebra

Matrices over \( F[x] \)

It is a remarkable fact that two \( n \times n \) matrices with entries in a field \( F \) are similar if and only if their characteristic matrices \( xI - A \) and \( xI - B \) are equivalent. These characteristic matrices are matrices over the principal ideal domain \( F[x] \), and two square matrices with polynomial entries are equivalent if and only if they have the same Smith normal form. The entries can be any polynomials with rational or symbolic coefficients.

### Compute > Matrices > Smith Normal Form

\[
\begin{pmatrix}
x^2 & -2i(x^3 + x^2) + 2x^2 \\
0 & \sqrt{2}i(x^3 + x^2)
\end{pmatrix}
\]

Smith Normal Form: \[
\begin{pmatrix}
x^2 & 0 \\
0 & x^2 + x^3
\end{pmatrix}
\]

The Smith normal form can be used to test whether two matrices are similar. The field in question can be the rationals or any finite field extension of the rationals. We illustrate this with an example.

**Example**

Take two similar matrices: \( A = \begin{pmatrix} 1 & 2 \\ 3 & 4 \end{pmatrix} \) and \( B = \begin{pmatrix} 1 & 9 \\ 3 & 4 \end{pmatrix} \) then

\[
B = \begin{pmatrix} 1 & 9 \\ -3 & 4 \end{pmatrix}^{-1} \begin{pmatrix} 1 & 2 \\ 3 & 4 \end{pmatrix} \begin{pmatrix} 1 & 9 \\ -3 & 4 \end{pmatrix} = \begin{pmatrix} 61 & -319 \\ -24 & 94 \end{pmatrix}
\]

These matrices have the following characteristic matrices:

\[
xI - A = \begin{pmatrix} x & 0 \\ 0 & x \end{pmatrix} - \begin{pmatrix} 1 & 2 \\ 3 & 4 \end{pmatrix} = \begin{pmatrix} x - 1 & -2 \\ -3 & x - 4 \end{pmatrix}
\]

\[
xI - B = \begin{pmatrix} x & 0 \\ 0 & x \end{pmatrix} - \begin{pmatrix} 61 & -319 \\ -24 & 94 \end{pmatrix} = \begin{pmatrix} x - 61 & 319 \\ 24 & x - 94 \end{pmatrix}
\]

with Smith normal forms both equal to

\[
\begin{pmatrix} 1 & 0 \\ 0 & x^2 - 5x - 2 \end{pmatrix}
\]

See page 331 for another example relating Smith normal forms and characteristic polynomials.

### Hermite Normal Form

Given a matrix \( A \) with entries in a PID, the Hermite normal form of \( A \) is a row echelon matrix \( H = QA \) where \( Q \) is invertible in the...
ring of matrices over the PID. The first nonzero entry in each row is from a prespecified set of nonassociates, and the entries above that first nonzero entry are from a prespecified set of representatives of the ring modulo that entry. If the PID is the ring of integers, the first nonzero entry in each row is a positive integer \( n_{ij} \), and the entries above that first nonzero entry are often chosen from the set \( \{ 0, 1, 2, \ldots, n_{ij} - 1 \} \).

**Compute > Matrices > Hermite Normal Form**

\[
\begin{pmatrix}
7 & 34 & 46 \\
4 & 20 & 27
\end{pmatrix}
\]

Hermite Normal Form: \[
\begin{pmatrix}
1 & 2 & 3 \\
0 & 4 & 5
\end{pmatrix}
\]

\[
\begin{pmatrix}
2 & 5 \\
-4 & 5
\end{pmatrix}
\]

Hermite Normal Form: \[
\begin{pmatrix}
2 & 5 \\
0 & 15
\end{pmatrix}
\]

**Companion Matrix and Rational Canonical Form**

The companion matrix of a monic polynomial \( a_0 + a_1X + \cdots + a_{n-1}X^{n-1} + X^n \) of degree \( n \) is the \( n \times n \) matrix with a subdiagonal of ones, final column

\[
\begin{bmatrix}
-a_0 & -a_1 & \cdots & -a_{n-1}
\end{bmatrix}^T
\]

and other entries zero.

**Compute > Polynomials > Companion Matrix**

\( x^4 + 3x^2 - 2x + 1 \), Companion:

\[
\begin{pmatrix}
0 & 0 & 0 & -1 \\
1 & 0 & 0 & 2 \\
0 & 1 & 0 & -3 \\
0 & 0 & 1 & 0
\end{pmatrix}
\]

(System Variable \( x \))

\( x^3 + ax^2 + bx + c \), Companion:

\[
\begin{pmatrix}
0 & 0 & -c \\
1 & 0 & -b \\
0 & 1 & -a
\end{pmatrix}
\]

Note that the first of the following matrices is the companion matrix of its own characteristic and minimal polynomials.
Chapter 8 | Matrix Algebra

**Compute > Matrices > Minimal Polynomial**

\[
\begin{pmatrix}
0 & 0 & 0 & -a \\
1 & 0 & 0 & -b \\
0 & 1 & 0 & -c \\
0 & 0 & 1 & -d \\
0 & 0 & 0 & 1
\end{pmatrix}
\]

- Minimal Polynomial: \(X^5 + eX^4 + dX^3 + cX^2 + bX + a\)

A rational canonical form, sometimes called a Frobenius form, is a block diagonal matrix with each block the companion matrix of its own minimal and characteristic polynomials. Each of the minimal polynomials of these blocks is a factor of the characteristic polynomial of the original matrix. The polynomials that determine the blocks of the rational canonical form sequentially divide one another.

Choosing Compute > Matrices > Rational Canonical Form produces a factorization of a square matrix as \(PBP^{-1}\), where \(B\) is in rational canonical form. The matrix \(B\) will have entries from the smallest subring of the complex numbers containing the entries of the original matrix. The invertible matrices will have entries from the smallest subfield of the complex numbers containing the entries of the original matrix. For example, if the matrix has integer entries, the rational canonical form will also, and the invertible matrices will have rational entries.

**Compute > Matrices > Rational Canonical Form**

\[
\begin{pmatrix}
1 & 2 & 3 \\
4 & 5 & 6 \\
7 & 8 & 9
\end{pmatrix}
\]

Rational Canonical Form:

\[
\begin{pmatrix}
1 & 1 & 30 \\
0 & 4 & 66 \\
0 & 7 & 102
\end{pmatrix}
= \begin{pmatrix} 1 & -2 & 1 \\ 0 & -\frac{17}{9} & 11/9 \\ 0 & 7/54 & -27/27 \end{pmatrix}
\]

Notice that the rational canonical form in the preceding example is the companion matrix of its minimal polynomial \(X^3 - 15X^2 - 18X\). Now look at the companion matrix of this same matrix.

**Compute > Evaluate**

\[
x \begin{pmatrix}
1 & 0 & 0 \\
0 & 1 & 0 \\
0 & 0 & 1
\end{pmatrix}
- \begin{pmatrix}
1 & 2 & 3 \\
4 & 5 & 6 \\
7 & 8 & 9
\end{pmatrix}
= \begin{pmatrix}
x - 1 & -2 & -3 \\
-4 & x - 5 & -6 \\
-7 & -8 & x - 9
\end{pmatrix}
\]
Normal Forms of Matrices

**Smith Normal Form**

\[
\begin{bmatrix}
  x - 1 & -2 & -3 \\
  -4 & x - 5 & -6 \\
  -7 & -8 & x - 9
\end{bmatrix}
\]

Smith Normal Form:

\[
\begin{bmatrix}
  1 & 0 & 0 \\
  0 & 1 & 0 \\
  0 & 0 & -18x - 15x^2 + x^3
\end{bmatrix}
\]

Notice that the polynomial occurring in the preceding Smith normal form is the same polynomial as occurred earlier.

**Rational Canonical Form**

\[
\begin{bmatrix}
  5 & -6 & -6 \\
  -1 & 4 & 2 \\
  3 & -6 & -4
\end{bmatrix}
\]

Rational Canonical Form:

\[
\begin{bmatrix}
  3 & 9 & 2 \\
  0 & -2 & 0 \\
  1 & -1 & -2
\end{bmatrix}
\]

There are two blocks in the preceding rational canonical form:

1. The companion matrix \( \begin{bmatrix} 0 & -2 \\ 1 & 3 \end{bmatrix} \) of \( X^2 - 3X + 2 = (X - 1)(X - 2) \)

2. The companion matrix \( \begin{bmatrix} 2 \end{bmatrix} \) of \( X - 2 \)

**Characteristic Polynomial**

\[
\begin{bmatrix}
  5 & -6 & -6 \\
  -1 & 4 & 2 \\
  3 & -6 & -4
\end{bmatrix}
\]

Characteristic polynomial: \( X^3 - 5X^2 + 8X - 4 = (X - 1)(X - 2)^2 \)

**Minimal Polynomial**

\[
\begin{bmatrix}
  5 & -6 & -6 \\
  -1 & 4 & 2 \\
  3 & -6 & -4
\end{bmatrix}
\]

Minimal polynomial: \( X^2 - 3X + 2 = (X - 1)(X - 2) \)

The characteristic matrix \( xI - A \) of the preceding matrix \( A \) is

\[
\begin{bmatrix}
  1 & 0 & 0 \\
  0 & 1 & 0 \\
  0 & 0 & 1
\end{bmatrix}
\begin{bmatrix}
  5 & -6 & -6 \\
  -1 & 4 & 2 \\
  3 & -6 & -4
\end{bmatrix}
= \begin{bmatrix}
  x - 5 & 6 & 6 \\
  -1 & x - 4 & -2 \\
  -3 & 6 & x + 4
\end{bmatrix}
\]

**Smith Normal Form**

\[
\begin{bmatrix}
  5 & -6 & -6 \\
  -1 & 4 & 2 \\
  3 & -6 & -4
\end{bmatrix}
\]

Smith Normal Form:

\[
\begin{bmatrix}
  1 & 0 & 0 \\
  0 & 2 & 0 \\
  0 & 0 & 2
\end{bmatrix}
\]
The previous examples illustrate a relationship among the Smith normal form, the characteristic matrix, and the rational canonical form of a matrix.

**Jordan Normal Form**

Choosing Compute > Matrices > Jordan Normal Form produces a factorization of a square matrix as $PJP^{-1}$, where $J$ is in Jordan normal form. This form is a block diagonal matrix with each block an elementary Jordan matrix. More specifically, the Jordan normal form of an $n \times n$ matrix $A$ with $k$ linearly independent eigenvectors is a matrix of the form

$$J(A) = \begin{bmatrix} J_{n_1}(\lambda_1) & 0 & \cdots & 0 \\ 0 & J_{n_2}(\lambda_2) & \cdots & 0 \\ \vdots & \vdots & \ddots & \vdots \\ 0 & 0 & \cdots & J_{n_k}(\lambda_k) \end{bmatrix}$$

where $n_1 + n_2 + \cdots + n_k = n$, and each diagonal block $J_{n_i}(\lambda_i)$ is an $n_i \times n_i$ elementary Jordan matrix of the form

$$J_{n_i}(\lambda_i) = \begin{bmatrix} \lambda_i & 1 & \cdots & 0 & 0 \\ 0 & \lambda_i & \cdots & 0 & 0 \\ \vdots & \vdots & \ddots & \vdots & \vdots \\ 0 & 0 & \cdots & \lambda_i & 1 \\ 0 & 0 & \cdots & 0 & \lambda_i \end{bmatrix}$$

The matrix $J(A)$ is similar to $A$ and its form is as nearly diagonal as possible among all matrices of the form $P^{-1}AP$.

**Compute > Matrices > Jordan Normal Form**

$$\begin{bmatrix} 2 & -1 & 0 \\ -1 & 2 & -1 \\ 0 & -1 & 2 \end{bmatrix} = \begin{bmatrix} \frac{1}{4} & \frac{1}{4} \sqrt{2} & -\frac{1}{4} \\ \frac{1}{4} \sqrt{2} & -\frac{1}{4} \sqrt{2} & 0 \\ \frac{1}{4} \sqrt{2} & \frac{1}{4} \sqrt{2} & \frac{1}{2} \end{bmatrix} \begin{bmatrix} 2 - \sqrt{2} & 0 & 0 \\ 0 & \sqrt{2} + 2 & 0 \\ 0 & 0 & \sqrt{2} + 2 \end{bmatrix} \begin{bmatrix} 1 & \sqrt{2} & -1 \\ \frac{1}{\sqrt{2}} & \frac{1}{\sqrt{2}} & \frac{1}{\sqrt{2}} \\ 0 & 0 & 1 \end{bmatrix}$$

Thus, the Jordan normal form of

$$A = \begin{bmatrix} 2 & -1 & 0 \\ -1 & 2 & -1 \\ 0 & -1 & 2 \end{bmatrix}$$

is

$$J\left( \begin{bmatrix} 2 & -1 & 0 \\ -1 & 2 & -1 \\ 0 & -1 & 2 \end{bmatrix} \right) = \begin{bmatrix} 2 & 0 & 0 \\ 0 & \sqrt{2} + 2 & 0 \\ 0 & 0 & -\sqrt{2} + 2 \end{bmatrix}$$
Normal Forms of Matrices

In this case, $J(A)$ is diagonal, so each $J_{\lambda_i}$ is a $1 \times 1$ matrix. The matrix $A$ has the characteristic and minimal polynomial

$$-4 + 10X - 6X^2 + X^3 = (X - 2) \left( X - 2 - \sqrt{2} \right) \left( X - 2 + \sqrt{2} \right)$$

whose roots $\{2, 2 + \sqrt{2}, 2 - \sqrt{2}\}$ are the diagonal entries of the Jordan normal form.

Thus, the Jordan normal form is

$$J \left( \begin{bmatrix} 2 & 0 & 0 & 0 \\ 1 & 2 & 0 & 0 \\ 0 & 0 & 2 & 0 \\ 0 & 0 & -3 & 2 \end{bmatrix} \right) = \begin{bmatrix} 2 & 0 & 0 & 0 \\ 1 & 2 & 0 & 0 \\ 0 & 0 & 2 & 0 \\ 0 & 0 & 1 & 2 \end{bmatrix}$$

In this case, $J_{\lambda_1}(A) = J_{\lambda_2}(A) = \begin{bmatrix} 2 & 0 \\ 1 & 2 \end{bmatrix}$, the companion matrix of the minimal polynomial of

$$A = \begin{bmatrix} 2 & 0 & 0 & 0 \\ 1 & 2 & 0 & 0 \\ 0 & 0 & 2 & 0 \\ 0 & 0 & -3 & 2 \end{bmatrix}$$

The characteristic polynomial of the matrix $A$ is $(X - 2)^4$ with repeated roots $\{2, 2, 2, 2\}$, and the minimal polynomial of $A$ is $X^2 - 4X + 4 = (X - 2)^2$.

The preceding matrix is already in Jordan normal form. Its minimal polynomial is $X - 2$ and its characteristic polynomial is $(X - 2)^4$. 
Chapter 8 | Matrix Algebra

the same characteristic polynomial as the previous one, but a different minimal polynomial and a different Jordan normal form.

Compute > Matrices > Jordan Normal Form

\[
\begin{bmatrix}
1 & 2 \\
-1 & -1
\end{bmatrix}
= \begin{bmatrix}
i & -i \\
\frac{1}{2} - \frac{i}{2} & \frac{1}{2} + \frac{i}{2}
\end{bmatrix}
\begin{bmatrix}
-i & 0 \\
0 & i
\end{bmatrix}
\begin{bmatrix}
\frac{1}{2} - \frac{i}{2} & 1 \\
\frac{1}{2} + \frac{i}{2} & 1
\end{bmatrix}
\]

In this case, \(J_{\lambda_1}(1) = [i]\) and \(J_{\lambda_2}(2) = [-i]\) are \(1 \times 1\) matrices. The matrix \(\begin{bmatrix}1 & 2 \\
-1 & -1
\end{bmatrix}\) has the characteristic and minimal polynomial \(x^2 + 1 = (x + i)(x - i)\).

Matrix Decompositions

There are various ways to decompose a matrix into the product of simpler matrices of special types. These decompositions are frequently useful in numerical matrix calculations.

Singular Value Decomposition

Any \(m \times n\) real matrix \(A\) can be factored into a product \(A = UDV\), with \(U\) and \(V\) real orthogonal \(m \times m\) and \(n \times n\) matrices, respectively, and \(D\) a diagonal matrix with positive numbers in the first rank entries on the main diagonal, and zeroes everywhere else. The entries on the main diagonal of \(D\) are called the singular values of \(A\). This factorization \(A = UDV\) is called a singular value decomposition (SVD) of \(A\).

Compute > Matrices > Singular Values

\[
\begin{bmatrix}
5 & -5 & -3 \\
-3 & 0 & 5 \\
1.0 & 5 & 4
\end{bmatrix}
\text{ Singular Values: [10.053, 4.6119, 3.5588]}$

\[
\begin{bmatrix}
5 & -5 & -3 \\
-3 & 0 & 5
\end{bmatrix}
\text{ Singular Values: [8.8882, 3.7417]}
\]
Matrix Decompositions

**Compute > Matrices > Singular Value Decomposition**

\[
\begin{bmatrix}
5 & -5 & -3 \\
-3 & 0 & 5 \\
1 & 5 & 4
\end{bmatrix}
= \begin{bmatrix}
0.72152 & 0.19119 & 0.66547 \\
-0.45504 & -0.59348 & 0.66387 \\
-0.52187 & 0.78181 & 0.34121
\end{bmatrix}.
\]

\[
\begin{bmatrix}
10.053 & 0 & 0 \\
0 & 4.6119 & 0 \\
0 & 0 & 3.5588
\end{bmatrix}
= \begin{bmatrix}
0.44273 & -0.61841 & -0.64927 \\
0.76285 & 0.64032 & -8.9706 \times 10^{-2} \\
0.47122 & -0.45558 & 0.75525
\end{bmatrix}
\]

These two outer matrices fail the orthogonality test because they are numerical approximations only. You can check the inner products of the columns to see that they are approximately orthogonal.

**Compute > Matrices > Singular Values**

\[
\begin{bmatrix}
1 & 2 \\
3 & 4
\end{bmatrix}
\text{Singular Values: [5.4650, 0.36597]}
\]

**Compute > Matrices > Singular Value Decomposition**

\[
\begin{bmatrix}
1 & 2 \\
3 & 4
\end{bmatrix}
= \begin{bmatrix}
0.40455 & -0.91451 \\
0.91451 & 0.40455
\end{bmatrix}
\begin{bmatrix}
5.4650 & 0 \\
0 & 0.36597
\end{bmatrix}
\begin{bmatrix}
0.57605 & 0.81742 \\
0.81742 & -0.57605
\end{bmatrix}
\]

**PLU Decomposition**

Any \( m \times n \) real or complex matrix \( A \) can be factored into a product \( A = PLU \), with \( L \) and \( U \) lower and upper triangular \( m \times m \) and \( m \times n \) matrices, respectively, with 1’s on the main diagonal of \( L \), and with \( P \) a permutation matrix. This factorization \( A = PLU \) is called the PLU decomposition of \( A \). The matrices \( P \) and \( L \) are invertible and the matrix \( U \) is a row echelon form of \( A \).

**Compute > Matrices > PLU Decomposition**

\[
\begin{bmatrix}
1 & 2 & 3 \\
2 & 4 & 6 \\
3 & 2 & 1
\end{bmatrix}
\text{PLU Decomposition:}
\begin{bmatrix}
1 & 0 & 0 \\
0 & 0 & 1 \\
0 & 1 & 0
\end{bmatrix}
\begin{bmatrix}
1 & 0 & 0 \\
3 & 1 & 0 \\
2 & 0 & 1
\end{bmatrix}
\begin{bmatrix}
1 & 2 & 3 \\
0 & -4 & -8 \\
0 & 0 & 0
\end{bmatrix}
\]

\[
\begin{bmatrix}
0.532 & 1.95 \\
1.5 & 0.0013
\end{bmatrix}
\text{PLU Decomposition:}
\begin{bmatrix}
0 & 1 \\
1 & 0
\end{bmatrix}
\begin{bmatrix}
1.0 & 0.0 \\
0.35467 & 1.0
\end{bmatrix}
\begin{bmatrix}
1.5 & 0.0013 \\
0.0 & 1.9495
\end{bmatrix}
\]

\[
\begin{bmatrix}
5i & \sqrt{2} \\
-7 & 2\pi/3
\end{bmatrix}
\text{PLU Decomposition:}
\begin{bmatrix}
1 & 0 \\
0 & 1
\end{bmatrix}
\begin{bmatrix}
1 & 0 \\
\frac{2}{3}i & 1
\end{bmatrix}
\begin{bmatrix}
5i & \sqrt{2} \\
0 & \frac{2}{3}\pi - \frac{2}{3}i\sqrt{2}
\end{bmatrix}
\]
Chapter 8 | Matrix Algebra

Note that the upper triangular matrix in the first line of the preceding example is the same as that in the following example. In general, the upper triangular matrix in the PLU decomposition is the echelon form of the original matrix obtained by Gaussian elimination.

**Compute > Matrices > Fraction Free Gaussian Elimination**

\[
\begin{bmatrix}
1 & 2 & 3 \\
2 & 4 & 6 \\
3 & 2 & 1 \\
\end{bmatrix}
\]

Fraction Free Gaussian Elimination:

\[
\begin{bmatrix}
1 & 2 & 3 \\
0 & -4 & -8 \\
0 & 0 & 0 \\
\end{bmatrix}
\]

**QR Decomposition**

A real \( m \times n \) matrix \( A \) with \( m \geq n \) can be factored as a product \( QR \), where \( Q \) is an orthogonal \( m \times m \) matrix (the columns of \( Q \) are orthonormal—that is, \( QQ^T \) is the \( m \times m \) identity matrix) and \( R \) is upper-right triangular with the same rank as \( A \). If the original matrix \( A \) is square, then so is \( R \). If \( A \) has linearly independent columns, then \( R \) is invertible. (See more examples on page 325.)

The QR decomposition is often used to solve the linear least squares problem, and is the basis for a particular eigenvalue algorithm, called the QR algorithm.

**To obtain the QR factorization**

- With the insert point in a matrix, choose compute > matrices > qr decomposition.

\[
\begin{bmatrix}
\frac{\sqrt{2}}{2} & 0 \\
\frac{\sqrt{2}}{2} & 1 \\
\end{bmatrix}
\]

QR Decomposition:

\[
\begin{bmatrix}
\frac{1}{2} \sqrt{2} & -\frac{1}{2} \sqrt{2} \\
\frac{1}{2} \sqrt{2} & \frac{1}{2} \sqrt{2} \\
\end{bmatrix}
\]

\[
\begin{bmatrix}
1 & 1 \\
0 & -2 \\
3 & -1 \\
\end{bmatrix}
\]

QR Decomposition:

\[
\begin{bmatrix}
\frac{1}{10} \sqrt{10} & \frac{3}{35} \sqrt{5} \sqrt{7} & \frac{3}{14} \sqrt{14} \\
0 & -\frac{1}{5} \sqrt{5} \sqrt{7} & \frac{1}{7} \sqrt{14} \\
\frac{3}{10} \sqrt{10} & -\frac{3}{35} \sqrt{5} \sqrt{7} & -\frac{1}{14} \sqrt{14} \\
\end{bmatrix}
\]

\[
\begin{bmatrix}
\sqrt{10} & -\frac{1}{5} \sqrt{10} \\
0 & \frac{2}{3} \sqrt{5} \sqrt{7} \\
0 & 0 \\
\end{bmatrix}
\]

**Cholesky Decomposition**

For a real square matrix that happens to be symmetric (\( A = A^T \)) and positive definite (all eigenvalues are positive), there is a particularly efficient triangular decomposition, significantly faster than alternative methods for solving linear equations.

An \( n \times n \) real symmetric positive-definite matrix \( A \) can be factored into a product \( A = GG^T \), with \( G \) a real positive-definite lower triangular \( n \times n \) matrix. This factorization \( A = GG^T \) is called the Cholesky
Cholesky Decomposition

\[
\begin{bmatrix}
2 & -1 \\
-1 & 2
\end{bmatrix}
\]

Cholesky Decomposition:

\[
\begin{bmatrix}
\sqrt{2} & 0 \\
-\frac{1}{2}\sqrt{2} & \frac{1}{2}\sqrt{2}\sqrt{3}
\end{bmatrix}
\begin{bmatrix}
\sqrt{2} & -\frac{1}{2}\sqrt{2} \\
0 & \frac{1}{2}\sqrt{2}\sqrt{3}
\end{bmatrix}
\]

\[
\begin{bmatrix}
2.0 & -1.0 \\
-1.0 & 2.0
\end{bmatrix}
\]

Cholesky Decomposition:

\[
\begin{bmatrix}
1.4142 & 0 \\
-0.70711 & 1.2247
\end{bmatrix}
\begin{bmatrix}
1.4142 & -0.70711 \\
0 & 1.2247
\end{bmatrix}
\]

\[
\begin{bmatrix}
1 & \frac{1}{2} & \frac{1}{3} \\
\frac{1}{2} & \frac{1}{3} & \frac{1}{4} \\
\frac{1}{3} & \frac{1}{4} & \frac{1}{5}
\end{bmatrix}
\]

Cholesky Decomposition:

\[
\begin{bmatrix}
1 & 0 & 0 \\
\frac{1}{2} & \frac{1}{6}\sqrt{3} & 0 \\
\frac{1}{3} & \frac{1}{6}\sqrt{3} & \frac{1}{30}\sqrt{3}
\end{bmatrix}
\begin{bmatrix}
1 & \frac{1}{2} & \frac{1}{3} \\
\frac{1}{6}\sqrt{3} & \frac{1}{6}\sqrt{3} \\
\frac{1}{30}\sqrt{3} & 0 & 0
\end{bmatrix}
\]

Exercises

1. The vectors \( u = [1 \ 1 \ 0] \) and \( v = [1 \ 1 \ 1] \) span a plane in \( \mathbb{R}^3 \). Find the projection matrix \( P \) onto the plane, and find a nonzero vector \( b \) that is projected to zero.

2. For the matrix

\[
\begin{bmatrix}
2 & 0 & 0 & 0 \\
1 & 2 & 0 & 0 \\
0 & 0 & 2 & 0 \\
0 & 0 & -3 & 2
\end{bmatrix}
\]

find the characteristic polynomial, minimal polynomial, eigenvalues, and eigenvectors. Discuss the relationships among these, and explain the multiplicity of the eigenvalue.

3. Which of the following statements are correct for the matrix

\[
A = \begin{bmatrix}
1 & 1 & 1 \\
1 & 0 & 2
\end{bmatrix}
\]

The set of all solutions \( x = \begin{bmatrix} x_1 \\ x_2 \\ x_3 \end{bmatrix} \) of the equation \( Ax = \begin{bmatrix} 0 \\ 0 \end{bmatrix} \) is the column space of \( A \); the row space of \( A \); a nullspace of \( A \); a plane; a line; a point.

4. Show that \( \text{det} \begin{bmatrix} x & y & 1 \\ a & b & 1 \\ c & d & 1 \end{bmatrix} = 0 \) is the equation of the line through the two points \( (a, b) \) and \( (c, d) \).
Chapter 8 | Matrix Algebra

5. Show that the $4 \times 4$ Vandermonde matrix has determinant

$$(x_2 - x_1) (x_3 - x_1) (x_3 - x_2) (x_1 - x_4) (x_2 - x_4) (x_4 - x_3).$$

**Solutions**

1. The projection matrix $P$ onto the plane in $R^3$ spanned by the vectors $u = [1, 1, 0]$ and $v = [1, 1, 1]$ is the product $P = A (A^T A)^{-1} A^T$, where $u$ and $v$ are the columns of $A$.

$$P = \begin{bmatrix} 1 & 1 & 0 \\ 1 & 1 & 1 \\ 0 & 1 & 0 \end{bmatrix} \left( \begin{bmatrix} 1 & 1 & 1 \\ 1 & 1 & 1 \\ 0 & 1 & 0 \end{bmatrix}^T \begin{bmatrix} 1 & 1 & 0 \\ 1 & 1 & 1 \\ 0 & 1 & 0 \end{bmatrix} \right)^{-1} \begin{bmatrix} 1 & 1 & 0 \\ 1 & 1 & 1 \\ 0 & 1 & 0 \end{bmatrix}^T = \begin{bmatrix} 1 & 1 & 0 \\ \frac{1}{2} & \frac{1}{2} & 0 \\ 0 & 0 & 1 \end{bmatrix}$$

Note that $Pw$ is a linear combination of $u$ and $v$ for any vector $w = (x, y, z)$ in $R^3$, so $P$ maps $R^3$ onto the plane spanned by $u$ and $v$.

$$\begin{bmatrix} \frac{1}{2} & \frac{1}{2} & 0 \\ \frac{1}{2} & \frac{1}{2} & 0 \\ 0 & 0 & 1 \end{bmatrix} \begin{bmatrix} x \\ y \\ z \end{bmatrix} = \begin{bmatrix} \frac{1}{2}x + \frac{1}{2}y \\ \frac{1}{2}x + \frac{1}{2}y \\ \frac{1}{2} \end{bmatrix} = \left( \frac{x + y}{2} - z \right) \begin{bmatrix} 1 \\ 1 \\ 0 \end{bmatrix} + z \begin{bmatrix} 1 \\ 1 \end{bmatrix}$$

To find a nonzero vector $b$ that is projected to zero, leave the insertion point in the matrix $P$ and choose Compute > Matrices > Nullspace Basis.

$$\begin{bmatrix} \frac{1}{2} & \frac{1}{2} & 0 \\ \frac{1}{2} & \frac{1}{2} & 0 \\ 0 & 0 & 1 \end{bmatrix} \text{ Nullspace Basis: } \begin{bmatrix} -1 \\ 1 \\ 0 \end{bmatrix}$$

2. The matrix

$$\begin{bmatrix} 2 & 0 & 0 & 0 \\ 1 & 2 & 0 & 0 \\ 0 & 0 & 2 & 0 \\ 0 & 0 & -3 & 2 \end{bmatrix}$$

has characteristic polynomial

$$(X - 2)^4$$

minimal polynomial

$$4 - 4X + X^2 = (X - 2)^2,$$ and
Exercises

eigenvalues 2. To compute eigenvectors, first change at least one entry to floating point.

$$\begin{pmatrix} 0.0 \\ 0.0 \\ 0.0 \\ 1.0 \end{pmatrix} \leftrightarrow 2.0, \begin{pmatrix} 0.0 \\ 1.0 \\ 0.0 \\ 0.0 \end{pmatrix} \leftrightarrow 2.0$$

$$\begin{pmatrix} 0.0 \\ 0.0 \\ 0.0 \\ 0.0 \end{pmatrix} \leftrightarrow 2.0, \begin{pmatrix} 0.0 \\ 0.0 \\ 0.0 \\ 0.0 \end{pmatrix} \leftrightarrow 2.0$$

The minimal polynomial is a factor of the characteristic polynomial. The eigenvalue 2 occurs with multiplicity 4 as a root of the characteristic polynomial $(X - 2)^4$. The eigenvalue 2 has two linearly independent eigenvectors. Note that

$$\begin{pmatrix} 2 & 0 & 0 \\ 1 & 2 & 0 \\ 0 & 0 & -3 \end{pmatrix} \begin{pmatrix} 0 \\ 0 \\ 1 \end{pmatrix} = \begin{pmatrix} 0 \\ 0 \\ 2 \end{pmatrix} = 2 \begin{pmatrix} 0 \\ 0 \\ 1 \end{pmatrix}$$

3. The solutions of this equation are in $\mathbb{R}^3$, and the column space of $A$ is a subset of $\mathbb{R}^2$, so these solutions cannot be the column space of $A$. They do form the nullspace of $A$ by the definition of nullspace; consequently, this set is a subspace of $\mathbb{R}^3$. The product of $A$ with the first row of $A$ is

$$\begin{pmatrix} 1 & 1 \\ 1 & 0 \\ 1 & 1 \end{pmatrix} \begin{pmatrix} 1 \\ 1 \\ 1 \end{pmatrix} = \begin{pmatrix} 3 \\ 3 \end{pmatrix},$$

which is not $\begin{pmatrix} 0 \\ 0 \end{pmatrix}$, so the solution set is not the row space of $A$. To determine the nature of this space, solve the sys-

339
tem of equations by choosing Compute > Solve > Exact to get
\[
\begin{bmatrix}
1 & 1 & 1 \\
0 & 1 & 2
\end{bmatrix}
\begin{bmatrix}
x_1 \\
x_2 \\
x_3
\end{bmatrix} =
\begin{bmatrix}
0 \\
0
\end{bmatrix}, \text{ Solution: }
\begin{bmatrix}
-2t_1 \\
t_1 \\
0
\end{bmatrix}
\]

The subspace is the line that passes through the origin and the point \([-2 1 1]\).

4. Solving the equation 
\[
\det \begin{pmatrix}
x & y & 1 \\
a & b & 1 \\
c & d & 1
\end{pmatrix} = 0
\]

for \(y\) gives the solution \(y = \frac{xd - xb + cb - ad}{c - a}\), which can be rewritten as
\[
y = \frac{d - b}{c - a} x + \frac{cb - ad}{c - a}. \text{ If } c \neq a, \text{ this is the equation of the line through the two points } (a, b) \text{ and } (c, d). \text{ If } c = a, \text{ the equation of the line through the points } (a, b) \text{ and } (a, d).
\]

5. Choose Evaluate, then Factor to obtain
\[
\begin{vmatrix}
1 & x_1 & x_1^2 & x_1^3 \\
1 & x_2 & x_2^2 & x_2^3 \\
1 & x_3 & x_3^2 & x_3^3 \\
1 & x_4 & x_4^2 & x_4^3
\end{vmatrix}
= (x_2 - x_1) (x_3 - x_1) (x_3 - x_2) (x_1 - x_4) (x_2 - x_4) (x_4 - x_3)
\]
Vector calculus is the calculus of functions that assign vectors to points in space. It is concerned with differentiation and integration of vector fields, primarily in 3-dimensional Euclidean space.

Vector calculus operations are of particular importance in solving physical problems. They can be applied to problems such as finding the work done by a force field in moving an object along a curve or finding the rate of fluid flow across a surface.

V

ectors

The term vector is used to indicate a quantity that has both magnitude and direction. A vector is often represented by an arrow or a directed line segment. The length of the arrow represents the magnitude of the vector and the arrow points in its direction. Two directed line segments are considered equivalent if they have the same length and point in the same direction. In other words, a vector \( v \) can be thought of as a set of equivalent directed line segments.

A two-dimensional vector is an ordered pair \( \mathbf{a} = (a_1, a_2) \) of real numbers. A three-dimensional vector is an ordered triple \( \mathbf{a} = (a_1, a_2, a_3) \) of real numbers. More generally, an \( n \)-dimensional vector is an ordered \( n \)-tuple \( \mathbf{a} = (a_1, a_2, \ldots, a_n) \) of real numbers. The numbers \( a_1, a_2, \ldots, a_n \) are called the components of \( \mathbf{a} \).
Chapter 9 | Vector Calculus

Notation for Vectors

You can represent vectors in any of the following ways.

- $n$-tuples within parentheses or square brackets: $(2, -1, 0), (x_1, x_2, x_3), [3, 2, 1], [x_1, x_2, x_3]$
- $1 \times n$ matrices: $\begin{bmatrix} 1 & 2 & 3 \\ x_1 & x_2 & x_3 & x_4 \end{bmatrix}, \begin{bmatrix} 5 & -1 & 3 & 17 & -8 & 2 \end{bmatrix}$
- $n \times 1$ matrices: $\begin{bmatrix} 1 \\ 0 \\ -1 \end{bmatrix}, \begin{bmatrix} 35 \\ -4 \end{bmatrix}, \begin{bmatrix} x_1 \\ x_2 \end{bmatrix}$

This flexibility allows you to use the output of previous work as input, without undue worry about the shape of the output. For purposes of clear exposition, you will find it preferable to use consistent notation for vectors.

To create a vector in matrix form
1. Choose Insert > Math Objects > Matrix.
2. Set the number of rows (or columns) to $1$ and the number of columns (or rows) to the dimension of the vector.
3. Type the values for the components in the input boxes.
4. Select the vector with the mouse and choose Insert > Math Objects > Brackets and click a left bracket to enclose the vector in expanding brackets.

To create a vector in list form
1. Choose Insert > Math Objects > Brackets and click a left bracket.
2. With the insert point inside the expanding brackets, type the vector components, separated by commas.

Plots of vectors in 2D and 3D

To plot the vector $\mathbf{a} =$
1. Define $\mathbf{a} = \begin{bmatrix} 3 \\ 2 \end{bmatrix}$.
2. Place the insert point in the expression $\mathbf{xa}$.
3. Choose Compute > Plot 2D > Rectangular.
4. Revise the plot. Change the Plot Interval to $0 \leq x \leq 1$.

Or

1. Place the insert point in the matrix $\begin{pmatrix} 0 & 0 \\ 3 & 2 \end{pmatrix}$.

2. Choose Compute $>$ Plot 2D $>$ Rectangular.

To plot the vector $\mathbf{a} = \begin{pmatrix} 3 \\ 2 \\ 1 \end{pmatrix}$

1. Define $\mathbf{a} = \begin{pmatrix} 3 \\ 2 \\ 1 \end{pmatrix}$.

2. Place the insert point in the expression $\mathbf{x} \mathbf{a}$.

3. Choose Compute $>$ Plot 3D $>$ Rectangular.

4. Revise the plot, changing the Interval to $0 \leq x \leq 1$.

Or

1. Place the insert point in the matrix $\begin{pmatrix} 0 & 0 & 0 \\ 3 & 2 & 1 \end{pmatrix}$.

2. Choose Compute $>$ Plot 3D $>$ Rectangular.
Chapter 9 | Vector Calculus

**Compute > Plot 3D Rectangular**

\[
\begin{pmatrix}
0 & 0 & 0 \\
3 & 2 & 1
\end{pmatrix}
\]

**Vector Sums and Scalar Multiplication**

The *sum* of two vectors \([x_1, x_2, ..., x_n]\) and \([y_1, y_2, ..., y_n]\) is defined by

\[
[x_1, x_2, ..., x_n] + [y_1, y_2, ..., y_n] = [x_1 + y_1, x_2 + y_2, ..., x_n + y_n]
\]

The *product* of a scalar \(a\) and a vector \([x_1, x_2, ..., x_n]\) is defined by

\[
a [x_1, x_2, ..., x_n] = [ax_1, ax_2, ..., ax_n]
\]

**To evaluate a vector sum**

- Type the expression in mathematics mode and choose Compute > Evaluate.

**Vector output**

Although the vectors for the input can be in any standard form, the output is always a matrix.
Vectors

Compute > Evaluate

\[
\begin{pmatrix}
a \\
b
\end{pmatrix} + \begin{pmatrix}
c \\
d
\end{pmatrix} = \begin{pmatrix}
a + c \\
b + d
\end{pmatrix}
\]

\[
\begin{bmatrix}
1 \\
2
\end{bmatrix} - \begin{bmatrix}
-3 \\
1
\end{bmatrix} = \begin{bmatrix}
4 \\
1
\end{bmatrix}
\]

\[
\begin{bmatrix}
x & y
\end{bmatrix} + \begin{bmatrix}
w & z
\end{bmatrix} = \begin{bmatrix}
w + x & y + z
\end{bmatrix}
\]

Compute > Plot 3D > Rectangular

To evaluate the product of a scalar with a vector

- Type the expression in mathematics mode and choose Compute
  > Evaluate.

Compute > Evaluate

\[
a \begin{bmatrix}
x_1 & x_2 & x_3
\end{bmatrix} = \begin{bmatrix}
ax_1 & ax_2 & ax_3
\end{bmatrix}
\]

\[
6 \begin{bmatrix}
2 & 3 & -5
\end{bmatrix} = \begin{bmatrix}
12 & 18 & -30
\end{bmatrix}
\]

\[
i\sqrt{3} \begin{bmatrix}
2 & -6i & 5 - 3i
\end{bmatrix} = \begin{bmatrix}
2i\sqrt{3} & 6\sqrt{3} & (3 + 5i)\sqrt{3}
\end{bmatrix}
\]

Vector sum

The vector sum \( \mathbf{a} + \mathbf{b} \) appears as the diagonal of a parallelogram with edge vectors \( \mathbf{a} \) and \( \mathbf{b} \).

Rotate the plot for better visualization.
Chapter 9 | Vector Calculus

**Dot Product**

The dot product (or inner product) of two vectors \((a_1, a_2, \ldots, a_n)\) and \((b_1, b_2, \ldots, b_n)\) with real entries is defined by

\[
(a_1, a_2, \ldots, a_n) \cdot (b_1, b_2, \ldots, b_n) = a_1b_1 + a_2b_2 + \cdots + a_nb_n
\]

and the inner product of two vectors with complex entries is defined by

\[
(a_1, a_2, \ldots, a_n) \cdot (b_1, b_2, \ldots, b_n) = a_1b_1^* + a_2b_2^* + \cdots + a_nb_n^*
\]

where \(b^* = x - iy\) is the complex conjugate of \(b = x + iy\). For real numbers \(b\), it is clear that \(b^* = b\), so these two definitions are consistent. The dot product can also be obtained by matrix multiplication:

\[
(a_1, a_2, \ldots, a_n) \cdot (b_1, b_2, \ldots, b_n) = \begin{bmatrix} a_1 & a_2 & \cdots & a_n \\ \end{bmatrix} \begin{bmatrix} b_1^* \\ b_2^* \\ \vdots \\ b_n^* \end{bmatrix} = \begin{bmatrix} a_1 & a_2 & \cdots & a_n \end{bmatrix}^T \begin{bmatrix} b_1^* \\ b_2^* \\ \vdots \\ b_n^* \end{bmatrix}
\]

**Complex Conjugate**

To use overbar notation for complex conjugate, choose Tools > Preferences > Computation > Input and check “Overbar accent means conjugate.”

**To enter the dot used for the dot product**

- Select \(\cdot\) from the Binary Operations tab.

**To compute a dot product**

1. Type the expression.

2. With the insert point in the expression, choose Compute > Evaluate.

---

**Compute > Evaluate**

\[
(1, 2, 3) \cdot (3, 2, 1) = 10
\]

\[
[3x, -1, 5] \cdot [1, 1, 1] = 3x + 4
\]

\[
(1 + 2i, -3i) \cdot (5, 1 - i) = 8 + 7i
\]

\[
\begin{pmatrix} 1 + 2i & -3i \end{pmatrix} \begin{pmatrix} 5 \\ (1-i)^* \end{pmatrix} = 8 + 7i
\]

The standard default on variables returns complex solutions. You can change this default with the function assume.
Compute > Evaluate

\((u, v, w) \cdot (x, y, z) = ux^* + vy^* + wz^*\)
assume \((u, \text{real}) = \mathbb{R}\)
assume \((v, \text{real}) = \mathbb{R}\)
assume \((w, \text{real}) = \mathbb{R}\)
assume \((x, \text{real}) = \mathbb{R}\)
assume \((y, \text{real}) = \mathbb{R}\)
assume \((z, \text{real}) = \mathbb{R}\)

\((u, v, w) \cdot (x, y, z) = ux + vy + wz\)

For the following examples of dot products with \(n = 3\), define

\[
\mathbf{a} = \begin{bmatrix} 1 & 2 & 3 \end{bmatrix}, \quad \mathbf{b} = \begin{bmatrix} 1 \\ 0 \\ -1 \end{bmatrix}, \quad \mathbf{c} = [3, 2, 1], \quad \mathbf{d} = (2, -1, 0)
\]

by placing the insert point in each equation and choosing Compute > Definitions > New Definition.

Compute > Evaluate

\(\mathbf{a} \cdot \mathbf{c} = 10 \quad \mathbf{a} \cdot \mathbf{b} = -2 \quad \mathbf{c} \cdot \mathbf{d} = 4\)

Cross Product

The cross product of three-dimensional vectors \(\mathbf{a} = (a_1, a_2, a_3)\) and \(\mathbf{b} = (b_1, b_2, b_3)\) is defined by

\[\mathbf{a} \times \mathbf{b} = (a_2b_3 - a_3b_2, a_3b_1 - a_1b_3, a_1b_2 - a_2b_1)\]

To enter the cross used for the cross product

- Select \(\times\) from the Binary Operations panel under \([\pm \div]\).

To compute a cross product

- Place the insert point in the cross product and choose Compute > Evaluate.

For the following examples, use the vectors \(\mathbf{a} = \begin{bmatrix} 1 & 2 & 3 \end{bmatrix}, \quad \mathbf{b} = \begin{bmatrix} 1 \\ 0 \\ -1 \end{bmatrix}, \quad \mathbf{c} = [3, 2, 1], \quad \mathbf{d} = (2, -1, 0)\) defined in the previous section.
Chapter 9 | Vector Calculus

**Compute > Evaluate**

\[ \mathbf{a} \times \mathbf{b} = \begin{bmatrix} -2 & 4 & -2 \end{bmatrix} \quad \mathbf{a} \times \mathbf{c} = \begin{bmatrix} -4 & 8 & -4 \end{bmatrix} \]

\[ \mathbf{c} \times \mathbf{d} = \begin{bmatrix} 1 & 2 & -7 \end{bmatrix} \]

\[
\begin{bmatrix} 0.35 \\ -0.73 \\ 1.2 \end{bmatrix} \times \begin{bmatrix} 0.85 \\ 0.32 \\ -0.77 \end{bmatrix} = \begin{bmatrix} 0.1781 \\ 1.2895 \\ 0.7325 \end{bmatrix}
\]

\[ \begin{bmatrix} 1 & -2 & 5 \end{bmatrix} \times \begin{bmatrix} 5 & 3 & -5 \end{bmatrix} = \begin{bmatrix} -5 & 30 & 13 \end{bmatrix} \]

An important geometric property of the cross product is that the vector \( \mathbf{u} \times \mathbf{v} \) is perpendicular to both \( \mathbf{u} \) and \( \mathbf{v} \). In the following example, define \( \mathbf{u} = \begin{bmatrix} 1 & 1 & 0 \end{bmatrix} \), \( \mathbf{v} = \begin{bmatrix} 1 & 0 & 1 \end{bmatrix} \), and \( \mathbf{w} = \mathbf{u} \times \mathbf{v} = \begin{bmatrix} 1 & -1 & -1 \end{bmatrix} \). Plot these three vectors and revise the plot (on the Axes page, select Equal Scaling Along Each Axis).

**Compute > Plot 3D Rectangular**

\[ \begin{bmatrix} 0 & 0 & 0 \\ 1 & 1 & 0 \end{bmatrix} \begin{bmatrix} 0 & 0 & 0 \\ 1 & 0 & 1 \end{bmatrix} \begin{bmatrix} 0 & 0 & 0 \end{bmatrix} \]

**Cross product**

Rotate the plot on your screen to observe that vector \( \mathbf{w} \) is perpendicular to both \( \mathbf{u} \) and \( \mathbf{v} \).

**Standard Basis**

Three-dimensional vectors are often written in terms of the standard basis:

\[ \mathbf{i} = (1, 0, 0) \]
\[ \mathbf{j} = (0, 1, 0) \]
\[ \mathbf{k} = (0, 0, 1) \]
The cross product of the two vectors \( a_1 \mathbf{i} + a_2 \mathbf{j} + a_3 \mathbf{k} \) and \( b_1 \mathbf{i} + b_2 \mathbf{j} + b_3 \mathbf{k} \) can then be computed by using the determinant

\[
\begin{vmatrix}
\mathbf{i} & \mathbf{j} & \mathbf{k} \\
a_1 & a_2 & a_3 \\
b_1 & b_2 & b_3
\end{vmatrix} = \mathbf{i}(a_2 b_3 - a_3 b_2) - \mathbf{j}(a_1 b_3 - a_3 b_1) + \mathbf{k}(a_1 b_2 - a_2 b_1)
\]

**Triple Cross Product**

Since the cross product of two vectors produces another vector, it is possible to string cross products together. Use the same vectors \( \mathbf{a}, \mathbf{b}, \mathbf{c}, \) and \( \mathbf{d} \) as before for these *triple vector products*. Note that different choices of position for parentheses generally produce different results. This demonstrates that the cross product is not an associative operation.

The default order of operations for products is from left to right.

**To compute a triple cross product**

1. Enter the cross product with appropriate choices of parentheses
2. With the insert point in the expression, choose Compute > Evaluate.

For the following examples, use the vectors \( \mathbf{a} = \begin{bmatrix} 1 & 2 & 3 \end{bmatrix}, \mathbf{b} = \begin{bmatrix} 1 \\ 0 \\ -1 \end{bmatrix}, \mathbf{c} = [3, 2, 1], \) and \( \mathbf{d} = (2, -1, 0) \) defined earlier.

\[
\begin{align*}
\mathbf{a} \times \mathbf{b} \times \mathbf{c} &= \begin{bmatrix} 8 & -4 & -16 \end{bmatrix} \\
\mathbf{a} \times (\mathbf{b} \times \mathbf{c}) &= \begin{bmatrix} 16 & 4 & -8 \end{bmatrix} \\
(\mathbf{a} \times (\mathbf{b} \times \mathbf{c})) \times \mathbf{d} &= \begin{bmatrix} -8 & -16 & -24 \end{bmatrix}
\end{align*}
\]

To obtain intermediate results, select a subexpression that is surrounded by parentheses and hold the Ctrl key down while evaluating. This technique does an in-place computation, as illustrated in the following examples.
Chapter 9 | Vector Calculus

Ctrl+Compute > Evaluate
\[ \mathbf{a} \times (\mathbf{b} \times \mathbf{c}) = \mathbf{a} \times \begin{pmatrix} 2 \\ -4 \\ 2 \end{pmatrix} \]

Compute > Evaluate
\[ \mathbf{a} \times \begin{pmatrix} 2 \\ -4 \\ 2 \end{pmatrix} = \begin{pmatrix} 16 \\ 4 \\ -8 \end{pmatrix} \]

(a × b) × c = (−2 4 −2) × c

(−2 4 −2) × c = (8 −4 −16)

Triple Scalar Product

A triple scalar product is the dot product of one vector with the cross product of two vectors.

To compute a triple scalar product
1. Enter the triple scalar product with appropriate choices of parentheses.
2. With the insert point in the expression, choose Compute > Evaluate.

Ctrl+Evaluate, Compute > Evaluate
\[ (1,0,1) \cdot ((1,2,3) \times (3,2,1)) = −8 \]
\[ ((1,0,1) \times (1,2,3)) \cdot (3,2,1) = −8 \]
\[ (1,0,1) \cdot (1,2,3) \times (3,2,1) = (12 8 4) \]

To find the volume of the parallelepiped spanned by the vectors A, B, and C
- Evaluate the absolute value of the triple scalar product \( A \cdot (B \times C) \).

To plot the parallelepiped spanned by the vectors A, B, and C
1. Define each of the vectors A, B, and C.
2. With the insert point in the expression \( sA + tB \), choose Compute > Plot 3D > Rectangular.
3. Revise the plot intervals to \( 0 \leq s \leq 1 \) and \( 0 \leq t \leq 1 \).
4. Select and drag to the plot each of the expressions \( sA + tC, sB + tC, sA + B + tC, \) and \( sA + tB + C \).

Compute > Definitions > New Definition
\[ A = [0, 1, 1] \quad B = [1, 0, 1] \quad C = [1, 1, 0] \]

Compute > Evaluate
\[ |A \cdot (B \times C)| = 2 \quad |B \cdot (C \times A)| = 2 \quad |C \cdot (A \times B)| = 2 \]

Tip
When mixing cross products with scalar products, use parentheses for clarity. As always, careful and consistent use of mathematical notation is in order. Whenever in doubt, add an extra set of parentheses to clarify an expression.

Caution
\( (1,0,1) \cdot (1,2,3) \times (3,2,1) \) is not interpreted as a triple scalar product, but as the product of the scalar \( (1,0,1) \cdot (1,2,3) = 4 \) with the vector \( (3,2,1) \).

Volume
The volume of the parallelepiped spanned by three vectors A, B, and C is equal to \( |A \cdot (B \times C)| \).

The volume of a parallelepiped does not depend on the order in which the triple scalar product is computed.
Vectors

**Compute > Plot 3D > Rectangular**

$sA + tB$ \((0 \leq s \leq t, 0 \leq s \leq 1)\)

$sA + tC, sB + tC, A + sB + tC, sA + B + tC, sA + tB + C$

Tip

Any three-dimensional object can be rotated on the screen to view the back side.

Volume of a parallelepiped

It is clear from this equation that if all the vertices of a parallelepiped have integer coordinates, then the volume is also an integer.

Vector Norms

You can compute vector norms \(\|v\|_n\) for vectors \(v = (v_1, \ldots, v_k)\) and positive integers \(n\) and for \(\infty\), where

\[
\|v\|_n = \left( \sum_{i=1}^{k} |v_i|^n \right)^{1/n} \quad \|v\|_\infty = \max(|v_i|)
\]

with entries \(v_i\) either real or complex, as illustrated by the following examples.

To compute a vector norm

1. Select the vector, choose Insert > Math Objects > Brackets, and choose the norm symbols. Choose OK.

2. Choose Insert > Subscript, and type a positive integer or the symbol \(\infty\).
Chapter 9 | Vector Calculus

3. With the insert point in the vector, choose Compute > Evaluate.

Compute > Evaluate

\[ \| (a, b, c) \|_1 = |a| + |b| + |c| \]
\[ \| (a, b, c) \|_3 = \sqrt[3]{|a|^3 + |b|^3 + |c|^3} \]
\[ \| (\ldots) \|_5 = \sqrt[5]{\ldots} \]
\[ \| (a, b, c, d) \|_\infty = \max (|a|, |b|, |c|, |d|) \]
\[ \| \begin{pmatrix} a \\ b \end{pmatrix} \|_2 = \sqrt{a^2 + b^2} \]

You can also obtain the 2-norm by choosing Compute > Matrices > Norm.

Compute > Matrices > Norm

\[
\begin{pmatrix} a & b & c \end{pmatrix}, 2\text{-norm: } \sqrt{|a|^2 + |b|^2 + |c|^2}
\]
\[ \begin{pmatrix} 8 & -10 & 2 + i \end{pmatrix}, 2\text{-norm: } 13 \]

Before doing the next set of examples, make the following definition.

Compute > Definitions > New Definition

\[ \mathbf{v} = [3, 2, 1] \]

Compute > Evaluate, Compute > Evaluate Numeric

\[ \| \mathbf{v} \|_1 = 6 \]
\[ \| \mathbf{v} \|_2 = \sqrt{14} \]
\[ \| \mathbf{v} \|_6 = \sqrt{794} \]
\[ \| \mathbf{v} \|_{20} = \sqrt[20]{3487832978} \]
\[ \| \mathbf{v} \|_\infty = 3 \]

Interesting tidbit

This series of examples suggests that

\[ \lim_{n \to \infty} \| \mathbf{v} \|_n = \| \mathbf{v} \|_\infty \]

Example

The area of the parallelogram in the plane with vertices \((0,0), (a_1, a_2), (b_1, b_2),\) and \((a_1 + b_1, a_2 + b_2)\) is given by

\[ \| (a_1, a_2, 0) \times (b_1, b_2, 0) \| \]

In particular, the area of the parallelogram spanned by the two vectors \((1, 2)\) and \((2, 1)\) is given by

\[ \| (1, 2, 0) \times (2, 1, 0) \| = 3 \]
This parallelogram appears in the following plot.

Since \( A \cdot B = ||A|| \ ||B|| \ \cos \theta \), where \( \theta \) is the angle between the vectors \( A \) and \( B \), you can use the dot product to find the angle between two vectors.

The angle between the vectors \((1, 2, -3)\) and \((-2, 1, 2)\) is given by the principal solution to the equation 
\[-6 = 3 (\cos \theta) \sqrt{14}.\] For this, choose Tools > Preferences > Computation, Engine page, and check Principal Value Only.

Thus the angle between these two vectors is approximately 2.1347 rad or roughly 122.31°.

**Planes and Lines in \( \mathbb{R}^3 \)**

A vector equation of the plane through the point \((x_0, y_0, z_0)\) and orthogonal to the vector \((a, b, c)\) is given by

\[
[(x, y, z) - (x_0, y_0, z_0)] \cdot (a, b, c) = 0
\]
Chapter 9 | Vector Calculus

To find an equation of the plane through three points

1. For the points \((x_0, y_0, z_0)\), \((x_1, y_1, z_1)\), and \((x_2, y_2, z_2)\), compute the differences

\[
\mathbf{u} = (x_0, y_0, z_0) - (x_1, y_1, z_1)
\]

and

\[
\mathbf{v} = (x_0, y_0, z_0) - (x_2, y_2, z_2)
\]

2. Compute the cross product

\[
\mathbf{n} = \mathbf{u} \times \mathbf{v}
\]

3. Simplify the equation

\[
[(x, y, z) - (x_0, y_0, z_0)] \cdot \mathbf{n} = 0
\]

Example

To find an equation of the plane through the points \((1, 1, 0)\), \((1, 0, 1)\), and \((0, 1, 1)\), we first compute the vectors

\[
\mathbf{u} = (1, 1, 0) - (1, 0, 1) = (0, 1, -1)
\]

\[
\mathbf{v} = (1, 1, 0) - (0, 1, 1) = (1, 0, -1)
\]

and the cross product

\[
\mathbf{n} = (0, 1, -1) \times (1, 0, -1) = (-1, -1, -1)
\]

and simplify the equation

\[
[(x, y, z) - (1, 1, 0)] \cdot (-1, -1, -1) = 0
\]

\[
x + 2y - z = 0
\]

\[
x + y + z = 2
\]

We plot this plane by first solving for \(z\).

Compute > Solve > Exact (Variable: \(z\))

\[x + y + z = 2, \text{ Solution: } 2 - y - x\]
A vector form of this plane is given by

\[
\begin{bmatrix}
0 & 1 & 1 \\
0 & 1 & 0 \\
1 & 0 & 1 \\
\end{bmatrix}
+ s \begin{bmatrix}
0 & 1 & -1 \\
0 & 1 & 1 \\
1 & 0 & 1 \\
\end{bmatrix}
+ t \begin{bmatrix}
1 & 0 & -1 \\
1 & 0 & -1 \\
1 & 0 & 0 \\
\end{bmatrix}
\]

Filled parallelogram

If \( s \) and \( t \) are restricted to the unit interval

\((0 \leq s \leq 1, 0 \leq t \leq 1)\), then the plot of

\[w + su + tv\]

is a filled parallelogram with edges \( u \) and \( v \).

To plot the filled triangle with edges \( a \) and \( b \), starting at the point \( c \)

- With the insert point in the expression \( c + sa + s(1-t)b \),
  choose Compute > Plot 3D > Rectangular.
A vector equation of the line through the point \((a, b, c)\) in the direction of \(\mathbf{m} = (u_1, u_2, u_3)\) is given by

\[(x, y, z) = (a, b, c) + t (u_1, u_2, u_3)\]

This is equivalent to the system of three parametric equations

\[
\begin{align*}
  x &= a + tu_1 \\
  y &= b + tu_2 \\
  z &= c + tu_3
\end{align*}
\]

To find the equation of a line through two points

1. For the two points \((a_1, b_1, c_1)\) and \((a_2, b_2, c_2)\), compute the difference

\[(a_1, b_1, c_1) - (a_2, b_2, c_2) = (a_1 - a_2, b_1 - b_2, c_1 - c_2)\]

   to find a vector that is parallel to the line.

2. An equation for the line is

\[(x, y, z) = (a_1, b_1, c_1) + t (a_1 - a_2, b_1 - b_2, c_1 - c_2)\]
Example To find an equation of the line through the two points 
(1, 2, 3) and (2, 1, 2), first compute a vector

$$\mathbf{m} = (1, 2, 3) - (2, 1, 2) = (-1, 1, 1)$$

that is parallel to the line, then simplify the equation

$$(x, y, z) = (1, 2, 3) + t(-1, 1, 1) = (1 - t, 2 + t, 3 + t)$$

The line can now be plotted.

Lines and other curves in space can sometimes be more easily visualized by using a fat curve.
Gradient, Divergence, Curl, and Related Operators

Three operations are of particular importance in vector calculus:

- **gradient**: measures the rate and direction of change in a scalar field; the gradient of a scalar field is a vector field.
- **divergence**: measures a vector field’s tendency to originate from or converge upon a given point.
- **curl**: measures a vector field’s tendency to rotate about a point; the curl of a vector field is another vector field.

The operators gradient, divergence, curl, and the Laplacian are implemented with their usual notation \( \nabla \), \( \nabla \cdot \), \( \nabla \times \), and \( \nabla \cdot \nabla \), respectively, followed by Evaluate. They also appear as special commands on the Vector Calculus menu. Directional derivatives have a similar implementation.

To enter the nabla symbol \( \nabla \) select the nabla from the Miscellaneous Symbols tab \( \text{∞} \).

**Gradient**

If \( f(x_1, x_2, \ldots, x_n) \) is a scalar function of \( n \) variables, then the vector

\[
\left( \frac{\partial f}{\partial x_1} (c_1, c_2, \ldots, c_n), \frac{\partial f}{\partial x_2} (c_1, c_2, \ldots, c_n), \ldots, \frac{\partial f}{\partial x_n} (c_1, c_2, \ldots, c_n) \right)
\]

is the gradient of \( f \) at the point \( (c_1, c_2, \ldots, c_n) \) and is denoted \( \nabla f \).

For \( n = 3 \), the vector \( \nabla f \) at \( (a, b, c) \) is normal to the level surface \( f(x, y, z) = f(a, b, c) \) at the point \( (a, b, c) \).

**To compute the gradient of a function** \( f(x, y, z) \)

1. Place the insert point in the expression \( \nabla f(x, y, z) \).

2. Choose Compute > Evaluate.

Or

1. Place the insert point in the expression \( f(x, y, z) \).

2. Choose Compute > Vector Calculus > Gradient.

Potential energy and force

In physics, \( f \) represents potential energy, and \( \nabla f \) represents force.
Gradient, Divergence, Curl, and Related Operators

**Compute > Evaluate**

\[ \nabla (xyz) = \begin{bmatrix} yz \\ xz \\ xy \end{bmatrix} \]

**Compute > Vector Calculus > Gradient**

\( xyz \), Gradient is \[ \begin{bmatrix} yz \\ xz \\ xy \end{bmatrix} \]

You can also operate on a function name after defining the function. For example, if \( f \) is defined by the equation \( f(x, y, z) = xyz \), then you can evaluate \( \nabla f(x, y, z) \).

**Compute > Evaluate**

\[ \nabla f(x, y, z) = \begin{bmatrix} yz \\ xz \\ xy \end{bmatrix} \]

The default basis variables are \( x, y, z \), in that order. You can change the default by setting new basis variables.

**To specify basis variables**

1. Choose Compute > Vector Calculus > Set Basis Variables.

2. Enter a new set of basis variables in the dialog that appears. The basis variables should be in mathematics mode, separated by red commas.

3. Choose OK.

After setting \( u, v, w \) as basis variables, the computing engine regards \( c \) as a constant.

**Compute > Evaluate**

\[ \nabla (cuv + v^2w) = \begin{bmatrix} cv \\ cu + 2vw \\ v^2 \end{bmatrix} \]

In the following example, we regard \( xy \) as the value of a function of the default basis variables \( x, y, \) and \( z \).
Chapter 9 | Vector Calculus

**Compute > Evaluate**

\[ \nabla (xy) = \begin{pmatrix} y \\ x \\ 0 \end{pmatrix} \]

**Divergence**

A vector field is a vector-valued function. If

\[ F(x,y,z) = [p(x,y,z), q(x,y,z), r(x,y,z)] \]

is a vector field, then the scalar

\[ \nabla \cdot F = \frac{\partial p}{\partial x} (a,b,c) + \frac{\partial q}{\partial y} (a,b,c) + \frac{\partial r}{\partial z} (a,b,c) \]

is the divergence of \( F \) at the point \((a,b,c)\). The dot product notation is used because the symbol \( \nabla \) can be thought of as the vector operator

\[ \nabla = \left( \frac{\partial}{\partial x}, \frac{\partial}{\partial y}, \frac{\partial}{\partial z} \right) \]

To compute the divergence of a vector field \( F(x,y,z) \)

- Place the insert point in the expression \( \nabla \cdot F(x,y,z) \) and choose Compute > Evaluate.

The default is that the field variables are \( x, y, \) and \( z \), in that order. If you want to label the field variables differently, or change the order of the variables, reset the default with Set Basis Variables on the Vector Calculus submenu.

For the following example, choose Compute > Definitions > New Definition to define the vector fields \( F, G, H, \) and \( J \).

**Compute > Definitions > New Definition**

\[ F = [yz, 2xz, xy] \quad H = \begin{bmatrix} yz & 2xz & xy \end{bmatrix} \]
\[ G = (xz, 2yz, z^2) \quad J = \begin{pmatrix} x^2 \\ xy \\ 2xz \end{pmatrix} \]

Compute divergence by choosing Compute > Evaluate, or by choosing Compute > Vector Calculus > Divergence.

**Compute > Evaluate**

\[ \nabla \cdot F = 0 \quad \nabla \cdot H = 0 \]
\[ \nabla \cdot G = 5z \quad \nabla \cdot J = 5x \]
\[ \nabla \cdot (xz, 2yz, z^2) = 5z \]
\[ \nabla \cdot [ax, bxy, cz^2] = a + bx + 2cz \]
Gradient, Divergence, Curl, and Related Operators

**Compute > Vector Calculus > Divergence**

\[
\begin{align*}
\n & [yz, 2xz, xy], \text{ Divergence is } 0 \\
& [yz, 2xz, xy], \text{ Divergence is } 0 \\
& (xz, 2yz, z^2), \text{ Divergence is } 5z \\
& \left( \begin{array}{c} \alpha x^2 \\ \beta xy \\ 2cxy \end{array} \right), \text{ Divergence is } 5x
\end{align*}
\]

**Curl**

If \( F(x, y, z) = (p(x, y, z), q(x, y, z), r(x, y, z)) \) is a vector field, then the vector

\[
\nabla \times F = \left( \frac{\partial r}{\partial y} - \frac{\partial q}{\partial z}, \frac{\partial p}{\partial z} - \frac{\partial r}{\partial x}, \frac{\partial q}{\partial x} - \frac{\partial p}{\partial y} \right)
\]

is called the **curl** of \( F \). The default is that the field variables are \( x, y, \) and \( z \), in that order. If you wish to label the field variables differently, reset the default with Set Basis Variables on the Vector Calculus submenu.

To compute the curl of a vector field \( F(x, y, z) \)

1. Enter the curl in standard notation.
2. Choose Compute > Evaluate.
   
   Or

1. Place the insert point in a vector field.
2. Choose Compute > Vector Calculus > Curl.

The vector field \( F \) in the following example is defined to be \( F = [yz, 2xz, xy] \), as in the previous section.

**Compute > Evaluate**

\[
\nabla \times (yz, 2xz, xy) = \left( \begin{array}{c} -x \\ 0 \\ z \end{array} \right) \quad \nabla \times F = \left( \begin{array}{c} -x \\ 0 \\ z \end{array} \right)
\]

\[
\nabla \times \left[ \begin{array}{c} \alpha x^2 \\ \beta xy \\ 2cxy \end{array} \right] = \left[ \begin{array}{c} 0 \\ -2cz \\ by \end{array} \right]
\]

**Compute > Vector Calculus > Curl**

\[
\begin{align*}
\n & (yz, 2xz, xy), \text{ Curl is } \left( \begin{array}{c} -x \\ 0 \\ z \end{array} \right) \\
& \left( \begin{array}{c} x^2 \\ xy \\ 2xz \end{array} \right), \text{ Curl is } \left( \begin{array}{c} 0 \\ -2z \\ y \end{array} \right)
\end{align*}
\]
In terms of the basis
\[ i = (1, 0, 0), \quad j = (0, 1, 0), \quad k = (0, 0, 1) \]
the curl of \( F \) can be interpreted as the determinant
\[ \nabla \times F = \begin{vmatrix} i & j & k \\ \frac{\partial}{\partial x} & \frac{\partial}{\partial y} & \frac{\partial}{\partial z} \\ p(x,y,z) & q(x,y,z) & r(x,y,z) \end{vmatrix} = i \left( \frac{\partial r}{\partial y} - \frac{\partial q}{\partial z} \right) + j \left( \frac{\partial p}{\partial z} - \frac{\partial r}{\partial x} \right) + k \left( \frac{\partial q}{\partial x} - \frac{\partial p}{\partial y} \right) \]

**Laplacian**

The Laplacian of a scalar field \( f(x,y,z) \) is the divergence of \( \nabla f \) and is written
\[ \nabla^2 f = \nabla \cdot \nabla f = \nabla \cdot \left( \frac{\partial f}{\partial x} \frac{\partial f}{\partial y} \frac{\partial f}{\partial z} \right) = \frac{\partial^2 f}{\partial x^2} + \frac{\partial^2 f}{\partial y^2} + \frac{\partial^2 f}{\partial z^2} \]

The name of this operator comes from its relationship to the Laplace's equation
\[ \frac{\partial^2 f}{\partial x^2} + \frac{\partial^2 f}{\partial y^2} + \frac{\partial^2 f}{\partial z^2} = 0 \]

The default field variables for the Laplacian are \( x, y, \) and \( z, \) in that order. If you wish to label the field variables differently, reset the default with Set Basis Variables on the Vector Calculus submenu.

**To compute the Laplacian of a scalar field** \( f(x,y,z) \)

1. Type the Laplacian in standard notation.

Or

1. Place the insert point in a scalar field.

2. Choose Compute > Vector Calculus > Laplacian.

**Compute > Evaluate**
\[ \nabla^2 (x + y^2 + 2z^3) = 12z + 2 \quad \nabla \cdot \nabla (x + y^2 + 2z^3) = 12z + 2 \]

**Compute > Vector Calculus > Laplacian**
\( x + y^2 + 2z^3, \) Laplacian is \( 12z + 2 \) \quad \( 1 - 2y + 6z^2, \) Laplacian is 12
Directional Derivatives

The directional derivative of a function $f$ at the point $(a, b, c)$ in the direction $\mathbf{u} = (u_1, u_2, u_3)$ is given by the inner product of $\nabla f$ and $\mathbf{u}$ at the point $(a, b, c)$. That is, for a vector $\mathbf{u}$ of unit length and a scalar function $f$,

$$D_{\mathbf{u}} f(a, b, c) = \nabla f(a, b, c) \cdot \mathbf{u} = \frac{\partial f}{\partial x}(a, b, c) u_1 + \frac{\partial f}{\partial y}(a, b, c) u_2 + \frac{\partial f}{\partial z}(a, b, c) u_3$$

To compute the directional derivative of $f(x, y, z)$ in the direction $\mathbf{u} = (u_1, u_2, u_3)$

1. Enter the dot product $(\nabla (f(x, y, z))) \cdot (u_1, u_2, u_3)$. Note that the expression $\nabla (f(x, y, z))$ is enclosed in parentheses.

2. Leave the insert point in the expression.

3. Choose Compute $>$ Evaluate, or Choose Compute $>$ Evaluate Numeric.

In the following example, we compute the directional derivative of $f(x, y, z) = xyz$ in the direction $\mathbf{u} = \left( \cos \frac{\pi}{8}, \sin \frac{\pi}{8}, \sin \frac{\pi}{9}, \cos \frac{\pi}{9} \right)$

**Compute $>$ Evaluate**

$$(\nabla (xyz)) \cdot (\cos \frac{\pi}{8}, \sin \frac{\pi}{8}, \sin \frac{\pi}{9}, \cos \frac{\pi}{9})
= xy \cos \frac{1}{2} \pi + \frac{1}{2} xz \left( \sin \frac{1}{2} \pi \right) \sqrt{2} - \sqrt{2} + \frac{1}{2} yz \left( \sin \frac{1}{2} \pi \right) \sqrt{\sqrt{2} + 2}$$

**Compute $>$ Evaluate Numeric**

$$(\nabla (xyz)) \cdot (\cos \frac{\pi}{8}, \sin \frac{\pi}{8}, \sin \frac{\pi}{9}, \cos \frac{\pi}{9})
\approx 0.93969 xy + 0.13089 xz + 0.31599 yz$$

Plots of Vector Fields and Gradients

A function that assigns a vector to each point of a region in two- or three-dimensional space is called a vector field. The gradient of a scalar-valued function of two variables is a vector field.
Plots and Animated Plots of 2D Vector Fields

The operation Compute > Plot 2D > Vector Field requires a pair of expressions in two variables representing the horizontal and vertical components of the vector field.

To plot a two-dimensional vector field
1. Type a pair of two-variable expressions, representing the horizontal and vertical components of a vector field, into a vector.

2. Leave the insert point in the vector, and choose Compute > Plot 2D > Vector Field.

To visualize the vector field \( F(x, y) = [x + y, x - y] \), place the insert point in the vector \([x + y, x - y]\), and choose Compute > Plot 2D > Vector Field.

\[
F(x, y) = \left( \frac{dy}{dx}, \frac{dx}{dy} \right)
\]

At a point \((x, y)\) on a solution curve of a differential equation of the form \( \frac{dy}{dx} = f(x, y) \) the curve has slope \( f(x, y) \). You can get an idea of the appearance of the graphs of the solution of a differential equation from the direction field—that is, a plot depicting short line segments with slope \( f(x, y) \) at points \((x, y)\). This can be done using Plot 2D > Vector Field and the vector-valued function

\[
F(x, y) = \left( \frac{1}{x}, \frac{1}{y} \right)
\]
Plots of Vector Fields and Gradients

that assigns to each point \((x, y)\) a vector of length one in the direction of the derivative at the point \((x, y)\).

The direction field for the differential equation \(dy/dx = y - x^2\) is the two-dimensional vector field plot of the vector valued function

\[
F(x, y) = \frac{(1, y - x^2)}{\| (1, y - x^2) \|}
\]

Compute > Plot 2D > Vector Field

Several of the solution curves are depicted in the plot on the right.

To plot an animated two-dimensional vector field

1. Type a pair of three-variable expressions, representing the horizontal and vertical components of a vector field, into a vector.

2. Leave the insert point in the vector and choose Compute > Plot 2D Animated > Vector Field.

To visualize the animated vector field \([x + ty, x - ty]\), place the insert point in the vector \([x + ty, x - ty]\), and choose Compute > Plot 2D Animated > Vector Field. From the Items Plotted page of the Plot Properties dialog, choose Intervals and set \(-1 \leq t \leq 1\).
Plots and Animated Plots of 3D Vector Fields

The operation Compute > Plot 3D > Vector Field requires three expressions in three variables representing the rectangular components of the vector field.

To plot a three-dimensional vector field

1. Type three three-variable expressions, representing the $x$-, $y$-, and $z$-components of a vector field, into a vector.

2. Leave the insert point in the vector and choose Plot 3D > Vector Field.

Tip
The three-dimensional version is often a challenge to visualize. Rotate a 3D plot on the screen for a better view.

To rotate the view

- Press the left mouse button as you move the mouse over the plot.
Animated views and boxed axes can be helpful in visualizing a vector field.

**To plot an animated three-dimensional vector field**

1. Type three four-variable expressions, representing the three components of a vector field with an animation variable, into a vector.

2. Leave the insert point in the vector, and choose Compute > Plot 3D Animated > Vector Field.

To visualize the vector field $[x + ty + z, x + y - tz, tx - y + z]$ as $t$ varies from $-1$ to $1$, place the insert point in the vector, and choose Compute > Plot 3D Animated > Vector Field. Change the interval for the animation variable to $-1 \leq t \leq 1$.

**Compute > Plot 3D Animated > Vector Field**

$[x + ty + z, x + y - tz, tx - y + z]$ (Interval $-1 \leq t \leq 1$)

---

**Plots and Animated Plots of 2D Gradient Fields**

Scalar-valued functions of two variables can be visualized in several ways. Given the function $f(x, y) = xy \sin xy$, choosing Compute > Plot 3D > Rectangular produces a surface represented by the function values.

Another way to visualize such a function is to choose Compute > Plot 2D > Gradient. This choice produces a plot of the vector field that is the gradient of this expression, plotting vectors at grid points whose magnitude and direction indicate the steepness of the surface and the direction of steepest ascent.
Chapter 9 | Vector Calculus

The vector field that assigns to each point \((x, y)\) the gradient of \(f\) at \((x, y)\) is called the gradient field associated with the function \(f\).

\[
\begin{align*}
\text{Gradient field} & \\
\text{Gradient field} & \\
\end{align*}
\]

To plot a gradient field

1. Type an expression \(f(x, y)\).
2. Choose Compute > Plot 2D > Gradient.

For example, type the expression \(x^2 + 2y^2\), and choose Compute > Plot 2D > Gradient. This procedure produces a plot of the vector field that is the gradient of this expression. The first plot shows the...
relative steepness, the second is the surface, and the third shows the contour lines.

Compute > Plot 2D > Gradient

\[ x^2 + 2y^2 \]

Gradient field

Compute > Plot 3D > Rectangular

\[ x^2 + 2y^2 \]

To plot an animated gradient field
1. Type an expression \( f(x,y,t) \).
Chapter 9 | Vector Calculus

2. With the insert point in the expression, choose Compute > Plot 2D Animated > Gradient.

Type the expression

$$1 / \left(10 + (x + 3\cos t)^2 + (y + 3\sin t)^2\right)$$

and choose Compute > Plot 2D Animated > Gradient. This produces an animated plot of the vector field that is the gradient of this expression.

The following animation shows a point of attraction that moves around a circle of radius 3. Set the interval for the animation variable to $-3.1416 \leq t \leq 3.1416$.

Plots and Animated Plots of 3D Gradient Fields

The gradient field for a scalar-valued function $f(x, y, z)$ of three variables is a three-dimensional vector field where each vector represents the direction of maximal increase. The surface represented by the function values is embedded in four-dimensional space, so you must use indirect methods such as plotting the gradient field to help you visualize this surface.
Another way to visualize the function $f(x, y, z)$ is to plot a series of implicit plots of surfaces of constant values. The gradient field points from surfaces of lower constant values to surfaces with higher constant values.

To plot an animated gradient field in 3D
1. Type an expression $f(x, y, z, t)$. 
Chapter 9 | Vector Calculus

2. With the insert point in the expression, choose Compute > Plot 3D Animated > Gradient.

For example, type \(1/(10 + (x + t)^2 + (y + t)^2 + (z + t)^2)\) and choose Compute > Plot 3D Animated > Gradient. This procedure produces an animated plot of the vector field that is the gradient of this expression. The following animation shows the interest generated in a fish tank as a tasty morsel moves from one corner to the opposite corner of the tank. From the Items Plotted page of the Plot Properties dialog, choose Variables, Intervals, and Automation and set \(-6 \leq t \leq 6\).

Scalar and Vector Potentials

The Scalar Potential command on the Vector Calculus menu produces the inverse of the gradient in the sense that it finds a scalar function whose gradient is the given vector field, or it tells you that such a function does not exist. The vector potential has an analogous interpretation in terms of the curl.

**Scalar Potential**

A scalar potential exists for a vector field \(F\) if and only if the curl is 0:

\[\nabla \times F = 0\]

That is, the vector field is *irrotational*.

The following are examples of scalar potential with the standard basis variables.
Scalar and Vector Potentials

\textbf{Compute} \rightarrow \textbf{Vector Calculus} \rightarrow \textbf{Scalar Potential}

\( (x,y,z) \) Scalar potential is \( \frac{1}{2}x^2 + \frac{1}{2}y^2 + \frac{1}{2}z^2 \)

\( (x,z,y) \) Scalar potential is \( \frac{1}{2}x^2 + yz \)

\( (y,z,x) \) Scalar potential does not exist.

The vector field \((y,z,x)\) does not have a scalar potential because its curl is not \(0\).

\textbf{Compute} \rightarrow \textbf{Evaluate}

\[ \nabla \times (y,z,x) = \begin{bmatrix} -1 \\ -1 \\ -1 \end{bmatrix} \neq \begin{bmatrix} 0 \\ 0 \\ 0 \end{bmatrix} \]

In the next example, choose \textbf{Compute} \rightarrow \textbf{Evaluate} and then choose \textbf{Compute} \rightarrow \textbf{Vector Calculus} \rightarrow \textbf{Scalar Potential}. Because the vector field is a gradient, it has the original function as a scalar potential.

\textbf{Compute} \rightarrow \textbf{Evaluate}

\[ \nabla (xy^2 + yz^3) = \begin{bmatrix} y^2 \\ z^3 + 2xy \\ 3yz^2 \end{bmatrix} \]

\textbf{Compute} \rightarrow \textbf{Vector Calculus} \rightarrow \textbf{Scalar Potential}

\[ \begin{bmatrix} y^2 \\ z^3 + 2xy \\ 3yz^2 \end{bmatrix} \] Scalar potential is \( xy^2 + yz^3 \)

You would normally expect the scalar potential of the vector field \((cv, cu + 2vw, v^2)\) to be \(ucv + v^2w\); that is, you expect \(c\) to be treated as a constant. When the number of variables differs from the number of components in the field vector, a dialog box asks for the field variables. In this case, you can type \(u, v, w\) to get the expected result.

The dialog box also appears when you ask for the scalar potential of a vector field that specifies fewer than three variables, such as \((y,x,0)\). Type \(x, y, z\) in the dialog box to get the expected result \(xy\) for the scalar potential of this vector field.

\textbf{Vector Potential}

A vector potential exists for a vector field \(\vec{F}\) if and only if

\[ \text{div} \, F = \nabla \cdot F = 0 \]
Chapter 9 | Vector Calculus

That is, the vector field is \textit{solenoidal}.

Unless otherwise specified, the operators \textit{curl} and \textit{vector potential} apply to scalar or vector functions of a set of exactly three standard basis variables. The default is \(x, y, z\), but you can use other sets of basis variables by choosing Compute > Vector Calculus > Set Basis Variables and changing the default variables.

Start with \(\nabla \times (xy, yz, zx) = \begin{bmatrix} -y \\ -z \\ -x \end{bmatrix}\) to get the following vector potential.

\[
\begin{bmatrix} -y \\ -z \\ -x \end{bmatrix} \text{ Vector potential is } \begin{bmatrix} xy - \frac{1}{2}z^2 \\ yz \\ 0 \end{bmatrix}
\]

Notice that we did not get the original vector field when we asked for a vector potential of its \textit{curl}. That is because the vector potential is determined only up to a field whose \textit{curl} is zero. You can verify that this is the case. First, calculate the difference of the two vectors. Then compute the \textit{curl} of the difference.

\[
\begin{bmatrix} xy \\ yz \\ zx \end{bmatrix} - \begin{bmatrix} xy - \frac{1}{2}z^2 \\ yz \\ 0 \end{bmatrix} = \begin{bmatrix} \frac{1}{2}z^2 \\ 0 \\ xz \end{bmatrix}
\]

\[
\nabla \times \begin{bmatrix} \frac{1}{2}z^2 \\ 0 \\ xz \end{bmatrix} = \begin{bmatrix} 0 \\ 0 \\ 0 \end{bmatrix}
\]

Try the same experiment after changing the basis variables to \(u, v, w\) by choosing Compute > Vector Calculus > Set Basis Variables. Note that a vector field can be written either as the triple \((u, v, w)\) or as a column matrix.

374
Matrix-Valued Operators

Matrix-valued operators include the Hessian, the Jacobian, and the Wronskian matrices.

Hessian

The Hessian is the $n \times n$ matrix

$$
\begin{bmatrix}
\frac{\partial^2 f}{\partial x_1^2} & \frac{\partial^2 f}{\partial x_1 \partial x_2} & \cdots & \frac{\partial^2 f}{\partial x_1 \partial x_n} \\
\frac{\partial^2 f}{\partial x_2 \partial x_1} & \frac{\partial^2 f}{\partial x_2^2} & \cdots & \frac{\partial^2 f}{\partial x_2 \partial x_n} \\
\vdots & \vdots & \ddots & \vdots \\
\frac{\partial^2 f}{\partial x_n \partial x_1} & \frac{\partial^2 f}{\partial x_n \partial x_2} & \cdots & \frac{\partial^2 f}{\partial x_n^2}
\end{bmatrix}
$$

of second partial derivatives of a scalar function $f(x_1, x_2, \ldots, x_n)$ of $n$ variables.

The order of the variables affects the ordering of the rows and columns of the Hessian. For the following examples, the list of variables is $x, y, z$. 

Compute > Vector Calculus > Vector Potential

\[
\begin{bmatrix}
-v \\
-w \\
-u
\end{bmatrix}
\text{Vector potential is}
\begin{bmatrix}
uv - \frac{1}{2}w^2 \\
vw \\
0
\end{bmatrix}
\]

$(v, w, u)$ Vector potential is
\[
\begin{bmatrix}
\frac{1}{2}w^2 - uv \\
vw \\
0
\end{bmatrix}
\]
Choose Compute > Vector Calculus > Set Basis Variables and type $a, b, c$ in the input box to change the basis vectors.

Choose Compute > Vector Calculus > Set Basis Variables and type $a, b$ in the input box to change the basis vectors.

Choose Compute > Vector Calculus > Set Basis Variables and type $x, y, z, w$ in the input box to change the basis vectors.
Matrix-Valued Operators

Jacobian

The Jacobian is the \( n \times n \) matrix

\[
\begin{bmatrix}
\frac{\partial f_1}{\partial x_1} & \frac{\partial f_1}{\partial x_2} & \ldots & \frac{\partial f_1}{\partial x_n} \\
\frac{\partial f_2}{\partial x_1} & \frac{\partial f_2}{\partial x_2} & \ldots & \frac{\partial f_2}{\partial x_n} \\
\vdots & \vdots & \ddots & \vdots \\
\frac{\partial f_n}{\partial x_1} & \frac{\partial f_n}{\partial x_2} & \ldots & \frac{\partial f_n}{\partial x_n}
\end{bmatrix}
\]

of partial derivatives of the entries in a vector field

\[
(f_1(x_1, x_2, \ldots, x_n), f_2(x_1, x_2, \ldots, x_n), \ldots, f_n(x_1, x_2, \ldots, x_n))
\]

Jacobians resemble Hessians in that the order of the variables in the variable list determines the order of the columns of the matrix. In the following examples, the variable list is \( x, y, z \). To verify these examples, choose Compute > Vector Calculus > Jacobian while the insertion point is in the given vector field.

**Compute > Vector Calculus > Jacobian**

\((yz, xz, xy), \text{ Jacobian is } \begin{bmatrix} 0 & z & y \\ z & 0 & x \\ y & x & 0 \end{bmatrix}\)

\((x^2z, x + z, xz^2), \text{ Jacobian is } \begin{bmatrix} 2xz & 0 & x^2 \\ 1 & 0 & 1 \\ z^2 & 0 & 2xz \end{bmatrix}\)

Set the basis variables to \( a, b, c \).

**Compute > Vector Calculus > Jacobian**

\((x^2z, y + c, yz^2), \text{ Jacobian is } \begin{bmatrix} 0 & 0 & 0 \\ 0 & 0 & 1 \\ 0 & 0 & 0 \end{bmatrix}\)

Wronskian

The Wronskian with respect to functions \( f_1, f_2, \ldots, f_n \) defined on an interval \( I \), often denoted by \( W(f_1(x), f_2(x), \ldots, f_n(x)) \), is
Chapter 9 | Vector Calculus

defined as

\[
\begin{vmatrix}
  f_1(x) & f_2(x) & \cdots & f_n(x) \\
  f_1'(x) & f_2'(x) & \cdots & f_n'(x) \\
  \vdots & \vdots & \ddots & \vdots \\
  f_1^{(n-1)}(x) & f_2^{(n-1)}(x) & \cdots & f_n^{(n-1)}(x)
\end{vmatrix}
\]

The matrix is the Wronskian matrix. Observe that \( W (f_1(x), f_2(x), \ldots, f_n(x)) \) is a function defined on the interval \( I \). To compute the Wronskian, take the determinant of the Wronskian matrix.

\[\text{Compute} \rightarrow \text{Wronskian}\]

\([(x^3 - 3x^2, 3x^2 - 7, x^4 + 5x^2)], \text{Wronskian matrix is}\]

\[
\begin{bmatrix}
  x^3 - 3x^2 & 3x^2 - 7 & x^4 + 5x^2 \\
  3x^2 - 6x & 6x & 4x^3 + 10x \\
  6x - 6 & 6 & 12x^2 + 10
\end{bmatrix}, \text{determinant: } -6x^6 + 84x^4 - 336x^3 - 210x^2
\]

\[\text{Compute} \rightarrow \text{Matrices} \rightarrow \text{Determinant}\]

\[
\begin{bmatrix}
  x^3 - 3x^2 & 3x^2 - 7 & x^4 + 5x^2 \\
  3x^2 - 6x & 6x & 4x^3 + 10x \\
  6x - 6 & 6 & 12x^2 + 10
\end{bmatrix}, \text{determinant: } -6x^6 + 84x^4 - 336x^3 - 210x^2
\]

It follows that the Wronskian of the functions

\[
g_1(x) = x^3 - 3x^2 \\
g_2(x) = 3x^2 - 7 \\
g_3(x) = x^4 + 5x^2
\]

is given by

\[W (x^3 - 3x^2, 3x^2 - 7, x^4 + 5x^2) = -6x^6 + 84x^4 - 210x^2 - 336x^3\]

Consider the special case where there are two functions. We define two generic functions \( f_1 \) and \( f_2 \).

\[\text{Compute} \rightarrow \text{Definitions} \rightarrow \text{New Definition}\]

\( f_1(x) \quad f_2(x) \)

\[\text{Compute} \rightarrow \text{Wronskian}\]

\((f_1(x), f_2(x)), \text{Wronskian matrix is}\]

\[
\begin{bmatrix}
  f_1(x) & f_2(x) \\
  \frac{\partial f_1(x)}{\partial x} & \frac{\partial f_2(x)}{\partial x}
\end{bmatrix}
\]

Note

Two functions are proportional if and only if \( \frac{f_2(x)}{f_1(x)} \) is a constant, which is equivalent to

\[
\frac{d}{dx} \left( \frac{f_2(x)}{f_1(x)} \right) = 0. \text{ Since } \frac{d}{dx} \left( \frac{f_2(x)}{f_1(x)} \right) =
\]

\[
\frac{f_1(x) \frac{d f_2(x)}{dx} - f_2(x) \frac{d f_1(x)}{dx}}{(f_1(x))^2}, \text{ this is equivalent to the Wronskian being zero.}
\]
Compute > Matrices > Determinant

\[
\begin{bmatrix}
  f_1(x) & f_2(x) \\
  \frac{\partial f_1(x)}{\partial x} & \frac{\partial f_2(x)}{\partial x}
\end{bmatrix},
\text{ determinant: } f_1(x) \frac{\partial f_2(x)}{\partial x} - f_2(x) \frac{\partial f_1(x)}{\partial x}
\]

Plots of Complex Functions

A complex-valued function \( F(z) \) of a complex variable is a challenge to graph, because the natural graph would require four dimensions. One of the techniques for visualizing such functions is to make conformal plots.

Conformal Plots

A conformal plot of a complex function \( F(z) \) is the image of a two-dimensional rectangular grid of horizontal and vertical line segments. The default is an \( 11 \times 11 \) grid, with each of the intervals \( 0 \leq \text{Re}(z) \leq 1 \) and \( 0 \leq \text{Im}(z) \leq 1 \) subdivided into 10 equal subintervals. If \( F(z) \) is analytic, then it preserves angles at every point at which \( F'(z) \neq 0 \); hence, the image is a grid composed of two families of curves that intersect at right angles.

To create a conformal plot of \( F(z) = \frac{z - 1}{z + 1} \), put the insert point in the expression, and choose Compute > Plot 2D > Conformal. The number of grid lines and the view can be changed in the Plot Properties tabbed dialogs.
Chapter 9 | Vector Calculus

In the following example,

- \( \text{Re}(z) \) and \( \text{Im}(z) \) both range from \(-3\) to \(3\).
- The View Intervals are set at \( -2 \leq \text{Re}(z) \leq 4 \) and \( -3 \leq \text{Im}(z) \leq 3 \).
- The Grid Size has been increased to 40 by 40.
- Samples per Horizontal Grid Line and Samples per Vertical Grid Line have both been increased to 60.

\[ \frac{z - 1}{z + 1} \]

Animated Conformal Plots

To create an animated conformal plot of a complex function

- Place the insert point in the expression, and choose Compute > Plot 2D Animated > Conformal.

The number of grid lines and the view can be changed in the Plot Properties dialogs. Following is an animation of \( (z - t) / (z + t) \) as \( t \) varies from 1 to 2. In the following example,

- \( \text{Re}(z) \) and \( \text{Im}(z) \) both range from \(-3\) to \(3\).
- \( t \) ranges from 1 to 2.
- The View Intervals are set at \( -2 \leq \text{Re}(z) \leq 4 \) and \( -3 \leq \text{Im}(z) \leq 3 \).
Exercises

1. Evaluate the directional derivative of \( f(x, y, z) = 3x - 5y + 2z \)
   at \((2, 2, 1)\) in the direction of the outward normal to the sphere
   \(x^2 + y^2 + z^2 = 9\).

2. Find a vector \( \mathbf{v} \) normal to the surface \( z = \sqrt{x^2 + y^2 + (x^2 + y^2)^{3/2}} \)
   at the point \((x, y, z) \neq (0, 0, 0)\) on the surface.

3. Let \( f(x, y, z) = \frac{mM}{\sqrt{x^2 + y^2 + z^2}} \) denote Newton’s gravitational
   potential. Show that the gradient is given by

   \[
   \nabla f(x, y, z) = -\frac{mM}{(x^2 + y^2 + z^2)^{3/2}} \begin{bmatrix} x \\ y \\ z \end{bmatrix}
   \]

4. Let \( u_1(t), u_2(t), u_3(t) \) be three functions having third-order
   derivatives. Show that the derivative of the Wronskian
   \( W(u_1(t), u_2(t), u_3(t)) \) is the determinant

   \[
   \begin{vmatrix}
   u_1(t) & u_2(t) & u_3(t) \\
   \frac{d}{dt}u_1(t) & \frac{d}{dt}u_2(t) & \frac{d}{dt}u_3(t) \\
   \frac{d^3}{dt^3}u_1(t) & \frac{d^3}{dt^3}u_2(t) & \frac{d^3}{dt^3}u_3(t)
   \end{vmatrix}
   \]
Chapter 9 | Vector Calculus

In other words, the derivative of \( W(u_1(t), u_2(t), u_3(t)) \) may be obtained by first differentiating the elements in the last row of the Wronskian matrix of \((u_1(t), u_2(t), u_3(t))\) and then taking the derivative of the resulting matrix.

5. Starting with the function \( f(x, y) = \sin(xy) \), observe connections between the surface \( z = f(x, y) \), the gradient of \( f(x, y) \), and the vector field of \( \nabla f(x, y) \).

6. Observe the vector field of \((\sin xy, \cos xy)\) and describe the flow. Is there a function \( g(x, y) \) whose gradient is \((\sin xy, \cos xy)\)?

Solutions

1. The directional derivative is given by \( D_uf(x, y, z) = \nabla f(x, y, z) \cdot u \), where \( u \) is a unit vector in the direction of the outward normal to the sphere \( x^2 + y^2 + z^2 = 9 \). The vector

\[
\nabla (x^2 + y^2 + z^2) = \begin{bmatrix} 2x \\ 2y \\ 2z \end{bmatrix}
\]

is normal to the sphere \( x^2 + y^2 + z^2 = 9 \), and at \((2, 2, 1)\) this normal is \((4, 4, 2)\). A unit vector in the same direction is given by

\[
u = \begin{bmatrix} 4 \\ 4 \\ 2 \end{bmatrix} \div \left\| \begin{bmatrix} 4 \\ 4 \\ 2 \end{bmatrix} \right\| = \frac{1}{6} \begin{bmatrix} 4 \\ 4 \\ 2 \end{bmatrix} = \begin{bmatrix} 2/3 \\ 2/3 \\ 1/3 \end{bmatrix}
\]

Hence, \( \nabla f(x, y, z) \cdot u \) evaluated at \((2, 2, 1)\) is \(-\frac{2}{3}\).

2. A normal vector is given by

\[
\nabla \left( \sqrt{x^2 + y^2} + (x^2 + y^2)^{3/2} - z \right) = \begin{bmatrix} \frac{x}{\sqrt{x^2 + y^2}} + 3x\sqrt{x^2 + y^2} \\ \frac{y}{\sqrt{x^2 + y^2}} + 3y\sqrt{x^2 + y^2} \\ -1 \end{bmatrix}
\]

\[
= \frac{1}{\sqrt{x^2 + y^2}} \left( x(1 + 3x^2 + 3y^2), y(1 + 3x^2 + 3y^2), -\sqrt{x^2 + y^2} \right)
\]

Hence, any scalar multiple of

\[
\begin{bmatrix} x(1 + 3x^2 + 3y^2), y(1 + 3x^2 + 3y^2), -\sqrt{x^2 + y^2} \end{bmatrix}
\]
is also normal to the given surface.

3. Evaluate the expression

\[
\nabla \left( \frac{mM}{\sqrt{x^2 + y^2 + z^2}} \right) = \begin{bmatrix} -\frac{M m x}{(x^2 + y^2 + z^2)^{3/2}} \\ -\frac{M m y}{(x^2 + y^2 + z^2)^{3/2}} \\ -\frac{M m z}{(x^2 + y^2 + z^2)^{3/2}} \end{bmatrix} = - \frac{mM}{(x^2 + y^2 + z^2)^{3/2}} \begin{bmatrix} x \\ y \\ z \end{bmatrix}
\]

This gives the Newtonian gravitational force between two objects of masses \(m\) and \(M\), with one object at the origin and the other at the point \((x, y, z)\).

4. Evaluate each of \(\frac{d}{dt} u_1(t)\) \(\frac{d}{dt} u_2(t)\) \(\frac{d}{dt} u_3(t)\) and

\[
\begin{array}{c|ccc}
& \frac{d}{dt} u_1(t) & \frac{d}{dt} u_2(t) & \frac{d}{dt} u_3(t) \\
\hline
\frac{d^2}{dt^2} u_1(t) & \frac{d^2}{dt^2} u_2(t) & \frac{d^2}{dt^2} u_3(t) \\
\frac{d^3}{dt^3} u_1(t) & \frac{d^3}{dt^3} u_2(t) & \frac{d^3}{dt^3} u_3(t) \\
\end{array}
\]

Each gives

\[
\begin{align*}
& u_1(t) \frac{\partial u_2(t)}{\partial t} \frac{\partial^3 u_3(t)}{\partial t^3} - u_1(t) \frac{\partial u_3(t)}{\partial t} \frac{\partial^3 u_2(t)}{\partial t^3} - \frac{\partial u_1(t)}{\partial t} u_2(t) \frac{\partial^3 u_3(t)}{\partial t^3} \\
& + \frac{\partial u_1(t)}{\partial t} u_3(t) \frac{\partial^3 u_2(t)}{\partial t^3} + \frac{\partial^3 u_1(t)}{\partial t^3} u_2(t) \frac{\partial u_3(t)}{\partial t} - \frac{\partial^3 u_1(t)}{\partial t^3} u_3(t) \frac{\partial u_2(t)}{\partial t}.
\end{align*}
\]

5. The surface \(z = \sin(xy)\) has ridges along the hyperbolas \(xy = \frac{\pi}{2} + 2n\pi\) and valleys along the hyperbolas \(xy = \frac{3\pi}{2} + 2n\pi\) in the first quadrant. The gradient \(\nabla \sin(xy) = (ycos(xy), xcos(xy))\) produces a vector field whose vectors show the steepness of the surface \(z = \sin(xy)\). Note that plotting the gradient of \(f(x, y)\) is the same as plotting the vector field of \(\nabla f(x, y)\). The ridges and valleys are indicated by vectors of zero length.
Chapter 9 | Vector Calculus

6. A plot of the vector field \((\sin xy, \cos xy)\) suggests an interesting pattern of flow. However, a search for a scalar potential fails.
A differential equation is an equation that includes differentials or derivatives of an unknown function. A solution to a differential equation is any function that satisfies the given equation. Thus \( f(x) = \sin x \) is a solution to the differential equation \( y'' + y = 0 \), because if \( y = \sin x \), then \( y' = \cos x \) and \( y'' = -\sin x \), and hence \( y'' + y = \sin x - \sin x = 0 \). Differential equations are encountered in the study of problems in both pure and applied mathematics, in the sciences, in engineering, and in business and the social sciences.

Ordinary Differential Equations

With the choices on the Solve ODE submenu you will be able to find closed-form solutions to many differential equations. The solution is generally returned as an equation in \( y(x) \) and \( x \) (or whatever variables were specified) with any arbitrary constants represented as \( C_1, C_2, ..., C_n \).

To solve a differential equation

1. Type the differential equation using standard mathematical notation.

2. With the insert point in the equation, choose Compute > Solve ODE > Exact, Laplace, Numeric, or Series.
Chapter 10 | Differential Equations

To solve a differential equation with initial condition(s)
1. Place the differential equation in a one-column matrix or in a display, with initial condition(s) in separate rows.

2. Place the insert point in the equation and, choose Compute > Solve ODE > Numeric.

These different choices are explained in more detail in the next few sections.

Exact Solutions

Two methods, Exact and Laplace, return exact solutions to a linear differential equation. Laplace, which as its name suggests, uses the Laplace transform to derive solutions, works for either homogeneous or nonhomogeneous linear differential equations with constant coefficients. Initial conditions are displayed in the solution. Exact is more general in the sense that it works for some nonlinear differential equations as well.

Exact Method

To solve a differential equation by the Exact method
1. Place the insert point in the differential equation.

2. Choose Compute > Solve ODE > Exact.

When a notation is used for differentiation that names the independent variable, the variable is taken from context.

\[ \frac{dy}{dx} = xy \]

ODE Solution: \[ \{ C_1 e^{\frac{1}{2} x^2} \} \]

To check this result, define \( y(x) = e^{\frac{1}{2} x^2} C_1 \). Replace \( y \) by \( y(x) \) in the differential equation and evaluate both sides.

\[ \frac{dy}{dx} = xC_1 e^{\frac{1}{2} x^2} \]

\( xy(x) = xC_1 e^{\frac{1}{2} x^2} \)

For any given number \( C_1 \), the solution describes a curve. Since \( C_1 \) may, in general, take on infinitely many values, there is an infinite family of solution curves—or a one-parameter family of solution curves—for this equation.

When a prime indicates differentiation, the independent variable will be named if it is unambiguous; otherwise, a variable name must
be specified. In the equations \( y' = y \), \( y' = \sin x \) and \( y' = \sin x + t \), the
independent variable is ambiguous and a dialog box appears asking for
the independent variable.

**Compute > Solve ODE > Exact**

\[ y' = y \text{(Specify } t\text{)} \text{ODE Solution: } \{C_1 e^t\} \]
\[ \frac{dy}{dx} = \sin x \text{ODE solution: } \{C_1 - \cos x\} \]
\[ y' = \sin x \text{(Specify } t\text{)} \text{ODE Solution: } \{C_1 + t \sin x\} \]
\[ y' = \sin x + t \text{(Specify } x\text{)} \text{ODE Solution: } \{C_1 - \cos x + tx\} \]
\[ y' = \sin x + t \text{(Specify } t\text{)} \text{ODE Solution: } \left\{C_1 + \frac{1}{2} (t + \sin x)^2\right\} \]

There is a family of solutions, one for each choice of \( C_1 \). The followingigure shows solutions for \( y' = y \) corresponding to the choices
\( \frac{1}{2} \), 1, 2, 3, and 4 for \( C_1 \). To replicate this plot, drag solutions to the
frame one at a time.

**Compute > Plot 2D > Rectangular**

\( \frac{1}{2} e^x \)

(Select and drag to the frame each of the following)

\( e^x, 2e^x, 3e^x, 4e^x \)

Five solutions for \( y' = y \)

**Notation**

A variety of notations for a differential
equation will be interpreted properly. The
examples illustrate some of this variety. The
Leibniz notation \( \frac{dy}{dx} \) and the \( D_x \) notation
provide enough information so the
independent variable can be determined by
the computational engine. The prime notation
for derivative prompts a dialog in which you
can specify the independent variable.

Following is a plot of three particular solutions for \( D_x y = \sin x \)
corresponding to \( C_1 = 1, 2, 3 \). To replicate this plot, drag the second
and third solutions to the frame one at a time.
Chapter 10 | Differential Equations

Compute > Plot 2D > Rectangular
\[ e^x - \frac{1}{2} \cos x - \frac{1}{2} \sin x \]
\[ 2e^x - \frac{1}{2} \cos x - \frac{1}{2} \sin x \text{ (Select and drag to the frame)} \]
\[ 3e^x - \frac{1}{2} \cos x - \frac{1}{2} \sin x \text{ (Select and drag to the frame)} \]

Tip
The three solutions can be distinguished by evaluation at 0. For example, the solution with \( C_1 = 1 \) crosses the y-axis at \( y = 1/2 \).

Three solutions for \( D_x y - y = \sin x \)

Compute > Solve ODE > Exact
\[ y'' + y = x^2 \text{ (specify } x \text{), ODE solution: } \{ x^2 - C_1 \sin x + C_2 \cos x - 2 \} \]

The following plot shows three solutions generated with constants \((C_1, C_2) = (1, 1), (C_1, C_2) = (5, 1), \text{ and } (C_1, C_2) = (1, 5)\). To replicate this plot, drag the second and third solutions to the frame one at a time.

Compute > Plot 2D > Rectangular
\[ \sin x + \cos x + x^2 - 2 \]
\[ 5 \sin x + \cos x + x^2 - 2 \text{ (Select and drag to the frame)} \]
\[ \sin x + 5 \cos x + x^2 - 2 \text{ (Select and drag to the frame)} \]

Tip
The particular solution \( y(x) = \sin x + 5 \cos x + x^2 - 2 \) is the one whose graph crosses the y-axis at \( y = 3 \).
Ordinary Differential Equations

**Laplace Method**

Laplace transforms solve either homogeneous or nonhomogeneous linear systems in which the coefficients are all constants. Initial conditions appear explicitly in the solution.

To solve a differential equation by the Laplace method

- Place the insert point in the differential equation and choose Compute > Solve ODE > Laplace.

**Example 1**

\[ \frac{dy}{dx} = y, \text{ ODE Solution (Laplace): } \{ C_1 e^x \} \]

\[ y' + y = x + \sin x, \text{ (Specify } x \text{), ODE Solution (Laplace) } \{ x - \frac{1}{2} \cos x + \frac{1}{2} \sin x + C_1 e^{-x} - 1 \} \]

The following examples compare exact and Laplace solutions. In each case, the ODE Independent Variable is \( x \).

**Example 2**

\[ y' = \sin x, \text{ ODE Solution: } \{ C_1 - \cos x \} \]

\[ y' = y + x, \text{ ODE Solution: } \{ C_1 e^x - x - 1 \} \]

**Example 3**

\[ D_2 y = \cos x, \text{ ODE Solution (Laplace): } \{ C_1 + \sin x \} \]

**Series Solutions**

For many applications requiring a solution to a differential equation, a few terms of a Taylor series solution are sufficient.

To find a Taylor series solution to a differential equation

1. Type the differential equation in standard mathematical notation.
2. With the insert point in the equation, choose Compute > Solve ODE > Series.
3. In the dialog box, type the Variable, Center (Default 0), and
   Order (Default 5) and choose OK.

In the following examples, notice that the initial condition $y(0)$
appears explicitly in each solution.

**Compute > Solve ODE > Series**

$D_0 y = y$, Series solution is: \( \{ y(0) + xy(0) + \frac{1}{2} x^2 y(0) + \frac{1}{6} x^3 y(0) + \frac{1}{24} x^4 y(0) + O(x^5) \} \)

$y' = \frac{\sin x}{x}$, Series solution is: \( \{ y(0) + x - \frac{1}{18} x^3 + \frac{1}{800} x^5 + O(x^7) \} \)

$\frac{dy}{dx} + y = e^{-x^2}$, Series solution is: \( \{ y(0) - x(y(0) - 1) + x^2 \left( \frac{1}{2} y(0) - \frac{1}{2} \right) \\
- x^3 \left( \frac{1}{6} y(0) + \frac{1}{6} \right) + x^4 \left( \frac{1}{24} y(0) + \frac{1}{24} \right) + O(x^5) \} \)

**Heaviside and Dirac Functions**

Laplace and Fourier transforms interact closely with the Heaviside
unit-step function and the Dirac unit-impulse function. The Dirac
and Heaviside functions are related by

\[
\int_{-\infty}^{x} \text{Dirac}(t) \, dt = \text{Heaviside}(x) \quad \text{and} \quad \frac{d}{dx} \text{Heaviside}(x) = \text{Dirac}(x)
\]

The Dirac function is not a function in the usual sense. It represents an
ininitely short, infinitely strong unit-area impulse. It satisfies \( \text{Dirac}(x) = 0 \) if \( x \neq 0 \), and can be obtained as the limit of functions \( f_n(x) \) satisfying \( \int_{-\infty}^{\infty} f_n(x) \, dx = 1 \).

The Heaviside function satisfies

\[
\text{Heaviside}(x) = \begin{cases} 
0 & \text{if } x < 0 \\
\frac{1}{2} & \text{if } x = 0 \\
1 & \text{if } x > 0 
\end{cases}
\]

The value of the Heaviside function at 0 is taken to be \( \frac{1}{2} \).
Neither the Dirac or Heaviside function is defined for nonreal complex numbers.

**Compute > Evaluate**

Heaviside(\( \pi \)) = 1  \quad \text{Heaviside}(-\( e \)) = 0

Dirac(2) = 0

To enter the name of the Dirac or Heaviside function

1. Choose Insert > Math Objects > Math Name.
Ordinary Differential Equations

2. Type the function name in the Name box with upper and lower case as they appear above, and choose OK.

The Heaviside and Dirac functions respect conditions set by the functions “assume” and “additionally.”

```plaintext
Compute > Evaluate
assume (x, positive) = (0, \infty)
Heaviside (x) = 1

Compute > Evaluate
assume (x, real) = \mathbb{R}
additionally (x \neq 0) = \mathbb{R} \setminus \{0\}
Dirac (x) = 0
```

If you prefer to work with shorter names, you can define them as follows. Results of computations will, however, return the long name.

```plaintext
Compute > Definitions > New Definition
\delta (x) = \text{Dirac} (x) \quad H (x) = \text{Heaviside} (x)
```

You can test these definitions by calculating an appropriate integral or derivative.

```plaintext
Compute > Evaluate
\int_{-1}^{1} \delta (x) \, dx = 1 \quad H' (x) = \text{Dirac} (x)
```

You can create characteristic functions with the Heaviside function. For example, the product Heaviside (1 - x) Heaviside (2 + x) gives the function that is 1 on the interval [-2, 1] and 0 elsewhere.

### Laplace Transforms

If \( f \) is a function on \([0, \infty]\), the function \( \mathcal{L} (f) = \hat{f} \) defined by the integral

\[
\hat{f} (s) = \mathcal{L} (f (t), t, s) = \int_{0}^{\infty} e^{-st} f (t) \, dt
\]

for those values of \( s \) for which the integral converges is the Laplace transform of \( f \), that is, it is the integral transform with kernel \( K (s, t) = e^{-st} \). The Laplace transform depends on the function \( f \) and the number \( s \). The equation above also defines the Laplace operator \( \mathcal{L} \).

A constant coefficient linear differential equation in \( f (t) \) is transformed into an algebraic equation in \( \hat{f} (s) \) by the operator \( \mathcal{L} \). A solution can be found to the differential equation by first solving the algebraic equation to find \( \hat{f} (s) \) and then applying the inverse Laplace transform to determine \( f (t) \) from \( \hat{f} (s) \).
Expressions involving exponentials, polynomials, trigonometrics (sin, cos, sinh, cosh) with linear arguments, and Bessel functions (BesselJ, BesselI) with linear arguments can be transformed.

The Laplace transform also recognizes derivatives and integrals, the Heaviside unit-step function Heaviside(x), and the Dirac-delta unit impulse function Dirac(x).

**Computing Laplace Transforms**

To compute the Laplace transform of an expression

- With the insert point in the expression, choose Compute > Transforms > Laplace.

  \[ \text{Compute > Transforms > Laplace} \]
  
  \[ t, \text{Laplace Transform is: } \frac{1}{s^2} \]
  
  \[ t^{3/2} - e^t + \sinh at, \text{Laplace Transform is: } \frac{3\sqrt{\pi}}{4s^{3/2}} - \frac{a}{a^2 - s^2} - \frac{1}{s-1} \]

  You can also compute a Laplace transform using the symbol \( \mathcal{L} \).

To compute a Laplace transform using the symbol \( \mathcal{L} \)

1. From the Miscellaneous Symbols panel, choose \( \mathcal{L} \).
2. Choose Insert > Math Objects > Brackets.
3. Click \( (\) , and choose OK.
4. Inside the parentheses, type an expression in the variable \( t \).
5. Choose Compute > Evaluate.

\[
\text{Compute > Evaluate} \\
\mathcal{L}(t) = \frac{1}{s^2} \quad \mathcal{L}(t^3) = \frac{6}{s^4} \quad \mathcal{L}(3\sin t) = \frac{3}{s^2 + 1}
\]

To compute the Laplace transform of an expression \( \mathcal{E} \) with variable of integration \( x \) and transform variable \( y \)

1. Place the insert point in \( \mathcal{L}(E; x, y) \).
2. Choose Compute > Evaluate.

  You can use other variable names by specifying the variable of integration and the transform variable as in the following examples.

\[
\text{Compute > Evaluate} \\
\mathcal{L}(x, x, y) = \frac{1}{y^2} \quad \mathcal{L}(x^3, x, s) = \frac{6}{s^4} \quad \mathcal{L}(e^{2\pi w}, w, u) = -\frac{1}{2\pi - u}
\]

**Tip**

The default variable of integration is \( t \) and the default transform variable is \( s \). The computing engine evaluates a Laplace transform with \( t \) as input variable and produces a solution using the variable \( s \).
Computing Inverse Laplace Transforms

To compute the inverse Laplace transform of an expression
1. Place the insert point in the expression.
2. Choose Compute > Transforms > Inverse Laplace.

You can also compute an inverse Laplace transform by evaluating an expression of the form $L^{-1} (f (s))$.

**Tip**
The default variable for the inverse transform is $s$, and the default output variable is $t$. The inverse Laplace transform will interpret correctly an expression with the variable $s$ as input.

For other variable names, the variable of integration and the transform variable must be specified, as in the following examples.

If the range of parameters must be restricted, use the functions assume and additionally.

The following two examples demonstrate the use of the Laplace transform to solve a differential equation.

**Example**
In order to solve the problem
\[ f'' (t) + af (t) = 0, \quad f (0) = b \]
define $f (t)$ as a generic function and $a$ and $b$ as generic constants.

Then evaluate both sides of the equation:
\[ L (f'' (t) + af (t)) = L (0) \]
Chapter 10 | Differential Equations

to get
\[ s\mathcal{L}(f(t), t, s) - f(0) + a\mathcal{L}(f(t), t, s) = 0 \]

Solve this equation for \( \mathcal{L}(f(t), t, s) \) to get
\[ \mathcal{L}(f(t), t, s) = \frac{f(0)}{s+a} = \frac{b}{s+a} \]

Now use the inverse Laplace transform to get
\[ f(t) = \mathcal{L}^{-1}\left( \frac{b}{s+a} \right) = be^{-at} \]

Check: Define \( f(t) = be^{-at} \) and evaluate \( f'(t) + af(t) \) and \( f(0) \) to get
\[ f'(t) + af(t) = 0 \]
\[ f(0) = b \]

**Example**  
Consider the second-order differential equation
\[ y'' + y = 0 \]
with the initial conditions \( y(0) = 1 \) and \( y'(0) = -2 \). Define \( y(t) \) as a generic function and apply Evaluate to \( \mathcal{L}(y''(t) + y(t), t, s) \) to get
\[ \mathcal{L}(y''(t) + y(t), t, s) = s^2\mathcal{L}(y(t), t, s) - sy(0) - y'(0) + \mathcal{L}(y(t), t, s) \]

Solve the equation
\[ s^2\mathcal{L}(y(t), t, s) - sy(0) - y'(0) + \mathcal{L}(y(t), t, s) = 0 \]
for \( \mathcal{L}(y(t), t, s) \) with Solve > Exact to get
\[ \mathcal{L}(y(t), t, s) = \frac{sy(0) + y'(0)}{s^2 + 1} \]

Replace \( y(0) \) with 1 and \( y'(0) \) with -2 to get
\[ \mathcal{L}(y(t), t, s) = \frac{s-2}{s^2 + 1} \]

Now take the inverse Laplace transform by applying Evaluate to the expression
\[ \mathcal{L}^{-1}\left( \frac{s-2}{s^2 + 1}, s, t \right) \]
to get
\[ \mathcal{L}^{-1} \left( \frac{s - 2}{s^2 + 1}, s, t \right) = \cos t - 2 \sin t \]

Check: If \( y(t) = \cos t - 2 \sin t \) then \( y''(t) = -\cos t + 2 \sin t \) then indeed \( y''(t) + y(t) = 0, y(0) = 1, \) and \( y'(0) = -2. \)

**Fourier Transforms**

Fourier transforms provide techniques for solving problems in linear systems and provide a unifying mathematical approach to the study of diverse fields including electrical networks and information theory.

If \( f \) is a real-valued function on \( (-\infty, \infty) \), the function \( \hat{f} = \mathcal{F}(f) \) defined by the integral
\[ \hat{f}(w) = \mathcal{F} \left( f(x), x, w \right) = \int_{-\infty}^{\infty} e^{-iwx} f(x) \, dx \]

for those values of \( w \) for which the integral converges is the Fourier transform of \( f \); that is, it is the integral transform with kernel \( K(w, t) = e^{-iwt} \) or \( K(w, t) = e^{iwt} \). The Fourier transform depends on the function \( f \) and the number \( w \).

**Computing Fourier Transforms**

To compute the Fourier transform of an expression
1. Place the insert point in the expression.
2. Choose Compute > Transforms > Fourier.

**Compute > Transforms > Fourier**

1. Fourier Transform is: \( 2\pi \text{Dirac} (w) \)
2. Fourier Transform is: \( e^{-iwx} \)
3. Fourier Transform is: \( 2 \pi \text{Dirac} (2\pi + w) \)

You can also compute a Fourier transform using the symbol \( \mathcal{F} \).

To compute a Fourier transform using the symbol \( \mathcal{F} \)
1. From the Miscellaneous Symbols Panel, choose \( \mathcal{F} \).
2. Choose Insert > Math Objects > Brackets, click \( [ \) and choose OK.
3. Inside the parentheses, type an expression in terms of the variable \( x \).
Chapter 10 | Differential Equations

4. Choose Compute > Evaluate.

\[ \mathcal{F}(1) = 2\pi \text{Dirac}(w) \quad \mathcal{F}(e^{-iw}) = 2\pi \text{Dirac}(w - 1) \]

You can also specify both the expression variable and the transform variable.

\[ \mathcal{F}(1, x, y) = 2\pi \text{Dirac}(y) \quad \mathcal{F}(e^{-iy}, y, z) = 2\pi \text{Dirac}(z - 1) \]

Computing Inverse Fourier Transforms

To compute the inverse Fourier transform of an expression

- With the insert point in the expression, choose Compute > Transforms > Inverse Fourier.

\[ \mathcal{F}^{-1}(1, x, y) = 2\pi \text{Dirac}(x) \quad e^{-5iw}, \text{Is Fourier Transform of } \text{Dirac}(x + 5) \]

To compute an inverse Fourier transform using the symbol \( \mathcal{F}^{-1} \)

- With the insert point in the expression \( \mathcal{F}^{-1}(f(w)) \), choose Compute > Evaluate.

\[ \mathcal{F}^{-1}(-2\frac{1}{\omega}, \omega, t) = 2\text{Heaviside}(-t) - 1 \]

You can also specify the variable of integration and the transform variable, as in the following examples.

\[ \mathcal{F}^{-1}(2\pi \text{Dirac}(h), h, s) = 1 \quad \mathcal{F}^{-1}(-2i/w, w, t) = 2\text{Heaviside}(-t) - 1 \]

For some of these expressions, Simplify gives a better form for the solution.

\[ \mathcal{F}^{-1}(-i\pi \text{Dirac}(-\omega + \omega_0) + i\pi \text{Dirac}(\omega + \omega_0), \omega, t) = -\sin(t\omega_0) \]

\[ \mathcal{F}^{-1}(\frac{3}{2}\pi \text{Dirac}(\omega - 4) + 3\pi \text{Dirac}(\omega) + \frac{1}{2}\pi \text{Dirac}(\omega + 4), \omega, t) = \frac{3}{4}e^{(-4i)t} (e^{4it} + 1)^2 \]
Computing Fourier Transforms of Multiple Expressions

To compute the transforms and inverse transforms of multiple expressions:

- Type the expressions in a single column matrix preceded by the symbol \( \mathcal{F} \) or \( \mathcal{F}^{-1} \) and choose Compute > Evaluate.

\[
\mathcal{F} \left( e^{2\pi i x} \right) = \begin{pmatrix} 2\pi \text{Dirac}(w) \\ 2\pi \text{Dirac}(2\pi + w) \end{pmatrix}
\]

Systems

Systems consisting of more than one equation are handled in a consistent manner. Such problems include initial-value problems and systems of differential equations.

Exact Solutions

The statement of some problems requires more than one equation. You enter systems with initial conditions, systems of differential equations, boundary-value problems, or a mixture of these problems using \( n \times 1 \) matrices, where \( n \) is the number of equations and conditions involved.

To create a system of differential equations in a matrix

1. Choose Insert > Math Objects > Matrix.

2. Select 1 column, set the number of rows equal to the number of equations, and choose OK.

3. Choose View and select Helper Lines and Input Boxes to show where to enter the required equations.

4. Type the equations, one to a row.

To create a system of differential equations in a display

1. Choose Insert > Math Objects > Display.

2. Choose View and select Helper Lines and Input Boxes to show where to type the required equations.

3. Type the equations, one to a row, pressing Enter to create each new row as needed.
Chapter 10 | Differential Equations

To solve a system of differential equations
1. Leave the insert point in the matrix or display.
2. Choose Compute > Solve ODE > Exact, or
   Choose Compute > Solve ODE > Laplace.

Compute > Solve ODE > Exact
\[ y' + y = x \]
\[ y(0) = 1 \]
ODE solution: \( x + 2e^{-x} - 1 \)
\[ y'' + y = 0 \]
\[ y(0) = 0 \]
ODE solution: \( \sin x \)
\[ y'(0) = 1 \]

Compute > Solve ODE > Laplace
\[ y'' + y = x^2 \]
\[ y(0) = 1 \]
ODE solution (Laplace): \( 3\cos x + \sin x + x^2 - 2 \)
\[ y'(0) = 1 \]

The following examples illustrate some of the different notations you can use for entering and solving systems of differential equations.

Compute > Solve ODE > Laplace
\[ \frac{dy}{dx} = \sin x \]
\[ y(0) = 1 \]
ODE solution (Laplace): \( 2 - \cos x \)
\[ D_{xx} y - y = 0 \]
\[ y(0) = 1 \]
ODE solution (Laplace): \( C_1 e^x - e^{-x} (C_1 - 1) \)
\[ y'(0) = 0 \]
\[ D_{xxx} y - y = 0 \]
\[ y(0) = 1 \]
ODE solution (Laplace): \( \left\{ \frac{1}{4}e^x + \frac{2}{3} \left( \cos \frac{1}{2} \sqrt{3}x \right) e^{-\frac{1}{2}x} \right\} \)
\[ y'(0) = 0 \]
\[ y''(0) = 0 \]
A new independent variable is introduced in certain instances where none is provided.

Compute > Solve ODE > Laplace
\[ y' = x \]
\[ x' = -y \]
(Independent Variable: \( t \))
ODE solution (Laplace):
\[ \left\{ x(t) = C_5 e^{it} + C_6 e^{-it}, y(t) = iC_6 e^{-it} - iC_5 e^{it} \right\} \]
Notice that an exact solution to this problem involves a two-parameter family of solutions.

**Compute > Solve ODE > Exact**

\[ y' = x \]
\[ x' = -y \]
\[ x(0) = 0 \]
\[ y(0) = 1 \]

(Independent Variable: \( t \)), ODE solution: \( \{ x(t) = -\sin t, y(t) = \cos t \} \)

Subscripted dependent variables are allowed.

**Compute > Solve ODE > Laplace**

\[ D_x y_1 + y_1 = e^{2x} \]
\[ y_1(0) = 1 \]

ODE solution (Laplace): \( \left\{ \frac{2}{3} e^{-x} + \frac{1}{3} e^{2x} \right\} \)

\[ D_x y_2 - y_2 = 0 \]
\[ y_2(0) = 1 \]

ODE solution (Laplace): \( \{ \cosh x \} \)

The next two examples show solutions using Exact for nonlinear equations. The command Laplace produces no result for these equations, as Laplace transforms are appropriate for linear equations only.

**Compute > Solve ODE > Exact**

\[ y' = y^2 + 4 \]
\[ y(0) = -2 \]

(Independent Variable: \( t \)), ODE solution: \( \left\{ 2 \tan \left( 2t - \frac{1}{3} \pi + C_3 \pi \right) \right\} \) if \( C_3 \in \mathbb{Z} \)

\[ (x + 1)y' + y = \ln x \]
\[ y(1) = 10 \]

(Independent Variable: \( x \)), ODE solution: \( \left\{ \ln x - e^{-\pi x/(x+1)} \sqrt{e(\ln x - 10)} \right\} \)

**Series Solutions**

The following examples illustrate series solutions to two types of differential equations with boundary conditions.

**To solve a differential equation by the series method**

1. Enter the equation and boundary conditions in a display or one-column matrix.

2. Place the insert point in the display or matrix and choose Compute > Solve ODE > Series.

3. If the Math Computation Arguments dialog appears, type a variable, center, and order in the dialog box.
Chapter 10 | Differential Equations

For the following examples, the series center is 0 and order is 5 (the default values).

**Compute > Solve ODE > Series**

\[ y' = y^2 + 4 \]
\[ y(0) = -2 \]

(Variable: \( t \)), Series expansion: \( \{-2 + 8t - 16t^2 + \frac{128}{3}t^3 - \frac{320}{5}t^4 + O(t^5)\} \)

\[ D_{\infty}y_1 - y_1 = 0 \]
\[ y_1(0) = 1 \]

Series expansion: \( \left\{ 1 + \frac{1}{2}x^2 + \frac{1}{24}x^4 + O(x^5) \right\} \)

**Numerical Methods**

Appropriate systems can be solved numerically. The numeric solutions are functions that can be evaluated at points or plotted.

**Numerical Solutions for Initial-Value Problems**

An initial-value problem is a problem that has one or more conditions specified.

To solve an initial-value problem numerically

1. Start with a column matrix and enter an initial-value problem, such as

   \[ y' = -y \quad or \quad y' = \sin(x + y) - 2y \]
   \[ y(0) = 1 \]

   with one equation per row.

2. Choose Compute > Solve ODE > Numeric.

**Compute > Solve ODE > Numeric**

\[ y' = \sin(x + y) - 2y \]
\[ y(0) = 1 \]

(Variable: \( x \)), Functions defined: \( y \)

This calculation defines a function \( y \) that can be evaluated at given arguments. You can use the function to generate a table of values, and as you will see in the next section, the function can be plotted.

**Compute > Evaluate**

\[ y(1) = 0.54343 \]
\[ y(10.7) = -0.28601 \]
To generate a table of function values for a function $y$
1. Define the function $g(i) = 0.1i$ and choose Compute $>$ Matrix $>$ Fill Matrix.

2. In the dialog box, select 10 rows and 1 column, select Defined by function and type the function name $g$.

3. Select the column, and choose Matrices $>$ Map Function. Type $y$ in the dialog box and choose OK.

\[
\begin{array}{c|c}
0.1 & 0.89478 \\
0.2 & 0.80888 \\
0.3 & 0.73965 \\
0.4 & 0.68471 \\
0.5 & 0.64190 \\
0.6 & 0.60918 \\
0.7 & 0.58468 \\
0.8 & 0.56661 \\
0.9 & 0.55336 \\
1.0 & 0.54343 \\
\end{array}
\]

This calculation generates a list of function values for $y$ as $x$ varies from 0.1 to 1.

Graphical Solutions to Initial-Value Problems
To plot numerical solutions to initial-value problems
1. Compute the numerical solution to an initial-value problem.

2. Select the function defined.

3. Choose Compute $>$ Plot 2D $>$ Rectangular.

To find a solution to the initial-value problem $y' = \sin(xy), y(0) = 3$, enter the two equations into a $2 \times 1$ matrix, and choose Compute $>$ Solve ODE $>$ Numeric.

\[
\begin{aligned}
y'(x) &= \sin(xy) \\
y(0) &= 3, \text{ Functions defined: } y
\end{aligned}
\]

Now plot $y$ by choosing Compute $>$ Plot 2D $>$ Rectangular or Compute $>$ Plot 2D $>$ ODE.
Numerical Solutions to Systems of Differential Equations

To find numerical solutions for systems of differential equations with initial values

1. Enter the equations into an $n \times 1$ matrix or display.

2. Place the insert point into the matrix or display and choose Compute > Solve ODE > Numeric.

Solve the following system numerically by entering the equations into a $6 \times 1$ matrix and choosing Compute > Solve ODE > Numeric. Three functions $x$, $y$, and $z$ are returned as output.

\[ \begin{align*}
x' &= x + y - z \\
y' &= -x + y + z \\
z' &= -x - y + z \\
x(0) &= 1 \\
y(0) &= 1 \\
z(0) &= 1
\end{align*} \]

Functions defined: $x, y, z$.

The following table lists values of $x$, $y$, and $z$ as the independent variable $t$ varies from 0 to 1.
You can create a matrix with these values.

To generate a table of function values for numerical solutions $x, y, z$

1. With the insert point in the column at the right, choose Compute > Matrices > Map Function. Type $x$ in the dialog box.

2. Similarly, apply Map Function to get the $y$ and $z$ columns.

3. To create a matrix with all four columns, place the $t, x, y, z$ columns next to one another and choose Compute > Matrices > Concatenate.

4. To add a row at the top for labels, select the matrix by placing the insert point immediately to the right of the matrix. Choose Edit > Insert Rows.

5. To line up entries, select a column, choose Edit > Properties, and change Column Alignment to Left or Right.

You can also take advantage of the fact that you are using a text editor to move the values into a $12 \times 4$ table. This is only for the purpose of creating a special appearance—a table does not behave mathematically as a matrix. To make a table that will print with lines, choose Insert > Table. Copy the information from the matrix into the table by selecting, clicking, and dragging each piece of data. Choose Edit > Properties and add lines according to instructions in the Table Properties dialog box.

Note
For matrices that do not have built-in delimiters, you must select only the matrix, not including brackets, to have Insert Rows appear on a menu.
Chapter 10 | Differential Equations

Graphical Solutions to Systems of Ordinary Differential Equations

You can create and plot matrices for each of $x$, $y$, and $z$ of the preceding example.

**To create matrices and plot numerical solutions to initial-value problems**

1. Concatenate the columns for $t$ and $x$.
2. Choose Compute $\gg$ Plot 2D $\gg$ Rectangular.
3. Generate a similar matrix using $t$ and $y$ and drag it to the plot frame.
4. Generate a similar matrix using $t$ and $z$ and drag it to the plot frame.

```
Compute $\gg$ Plot 2D $\gg$ Rectangular

\[
\begin{bmatrix}
0 & 1.0 \\
0.1 & 1.116 \\
0.2 & 1.267 \\
0.3 & 1.458 \\
0.4 & 1.695 \\
0.5 & 1.98 \\
0.6 & 2.326 \\
0.7 & 2.726 \\
0.8 & 3.187 \\
0.9 & 3.708 \\
1.0 & 4.284
\end{bmatrix}
\]
```

Select and drag to the plot the matrix corresponding to $t$ and $y$
Select and drag to the plot the matrix corresponding to $t$ and $z$

Note that the numeric output for $t$ between 0 and 1 does not predict long-range behavior. This system of differential equations describes a highly unstable system.

\[x(1.0) \approx 4.2842,\]
\[y(1.0) \approx -0.5424,\] and
\[z(1.0) \approx -2.2842.\]
Bessel Functions

The Bessel functions \( I_v(z) = \text{BesselI}_v(z) \), \( J_v(z) = \text{BesselJ}_v(z) \), \( K_v(z) = \text{BesselK}_v(z) \), and \( Y_v(z) = \text{BesselY}_v(z) \) are rather complicated oscillatory functions with many interesting properties. They are defined for complex arguments \( v \) and \( z \).

The functions \( J_v(z) \) and \( Y_v(z) \) are solutions of the first and second kind, respectively, to the Bessel equation

\[
\frac{\ln|z|^2}{dz^2} + \frac{\ln|z|}{dz} + (z^2 - v^2) w = 0
\]

They can be defined in terms of the \( \Gamma \) function:

\[
J_v(z) = \frac{\Gamma\left(\frac{1}{2} \right)}{\sqrt{\pi} \Gamma\left(\frac{v+1}{2}\right)} \int_0^\pi \cos(z \cos t) \sin^{2v} t \, dt
\]

\[
Y_v(z) = \frac{J_v(z) \cos v \pi - J_{-v}(z)}{\sin v \pi}
\]

The functions \( I_v(z) \) and \( K_v(z) \) are solutions known as first and second kind, respectively, to the modified Bessel equation

\[
\frac{\ln|z|^2}{dz^2} + \frac{\ln|z|}{dz} - (z^2 + v^2) w = 0
\]

They can be defined in terms of the \( \Gamma \) function:

\[
I_v(z) = \frac{\Gamma\left(\frac{1}{2} \right)}{\sqrt{\pi} \Gamma\left(\frac{v+1}{2}\right)} \int_0^\pi \exp(z \cos t) \sin^{2v} t \, dt
\]

\[
K_v(z) = \frac{\pi I_{-v}(z) - I_v(z)}{2 \sin v \pi}
\]

The Gamma \( \Gamma \) is defined for all complex numbers except for the nonpositive integers. The Gamma function satisfies \( \Gamma(n) = (n-1)! \) if \( n \) is a positive integer.

To create custom names for the Bessel functions

1. Choose Insert > Math Objects > Math Name.
2. Type \( \text{BesselI} \), \( \text{BesselK} \), \( \text{BesselJ} \), or \( \text{BesselY} \) in the Name box with capital letters as indicated.
3. Click the Function radio button in the Name Type pane and choose OK.
Chapter 10 | Differential Equations

4. Type a subscript and press the spacebar to return to the baseline.

5. Type an argument enclosed in parentheses.

A floating-point value is returned if either of the arguments is a floating-point number and the other argument is numerical, or when you use Evaluate Numeric.

```
Compute > Evaluate
BesselI_{2+3i} (3.5 - 5i) = -12.996 - 2.3116i
BesselI_2 (6.0 + i) = -0.37649 - 0.21941i
```

```
Compute > Evaluate Numeric
BesselK_{2+3i} (3 - 5i) \approx 0.0073755 - 0.0047928 i
BesselY_2 (3i) \approx 0.039159 - 2.2452 i
```

Explicit symbolic expressions are returned when the index $v$ is a half integer.

```
Compute > Evaluate
BesselI_{1/2} (x) = \frac{\sqrt{\pi}}{\sqrt{2x}} \sin x
BesselY_{3/2} (x) = -\frac{\sqrt{2}}{\sqrt{\pi x}} (\sin x + \frac{1}{x} \cos x)
```

The negative real axis is a branch cut of the Bessel functions for noninteger indices $v$. A jump occurs when crossing this cut:

```
Compute > Evaluate
BesselI_{-3/4} (-1.2) = -0.76061 - 0.76061i
BesselI_{-3/4} (-1.2 + 10^{-10}i) = -0.76061 - 0.76061i
BesselI_{-3/4} (-1.2 - 10^{-10}i) = -0.50858 + 0.20505i
```

The Bessel functions can be used in conjunction with other mathematical operations.

```
Compute > Evaluate
\frac{d}{dx} \text{BesselI}_0 (x) = - \text{BesselI}_1 (x)
\frac{d}{dx} \text{BesselI}_1 (x) = \frac{1}{x} (x \text{BesselI}_0 (x) - \text{BesselI}_1 (x))
\lim_{x \to \infty} \text{BesselI}_2 (x^2 + 1) = 0
\lim_{x \to \infty} \text{BesselI}_{3/2} (x^2 + i) = \frac{\sqrt{\pi}}{\sqrt{x}} (i\infty + \infty)
```

If floating-point approximations are desired for arguments that are exact numerical expressions, then we recommend using a floating-point expression in the argument rather than evaluating the result numerically. In particular, for half-integer indices the symbolic result is costly to compute and floating-point evaluation of the resulting symbolic expression may be numerically unstable. Increasing the number for Digits Used in Computations may achieve a satisfactory result, but as a general rule, the use of a floating-point expression in the argument gives more accurate results.
Exercises

1. Find the general solution of the equation \( y'' - 6y' + 5y = 0 \).
2. Find the general solution of the equation \( x^2y'' - 3x y' - 6y = 0 \).
3. Find the general solution of the equation \( 2x^2 y' = xy + 3y^2 \).
4. Solve the initial-value problem \( y' + y = 2 \), \( y(0) = 0 \).
5. Solve the initial-value problem \( \frac{dy}{dx} - y + 3 = 0 \), \( y(0) = 1 \).
6. Solve the Bessel equation \( z^2 \frac{d^2 w}{dz^2} + z \frac{dw}{dz} + (z^2 - v^2) w = 0 \).
7. Solve the equation \( y' + y^2 + b + ax = 0 \) and verify that the result is indeed a solution.

8. By Newton’s law of cooling, the rate of change in the temperature of an object is \( \frac{dT}{dt} = k(T - R) \), where \( k \) is a constant that depends on how well insulated the object is, \( T \) is the temperature of the object, and \( R \) is room temperature. A cup of coffee is initially 160°; 10 minutes later, it is 120°. Assuming the room temperature is a constant 70°, give a formula for the temperature at any time \( t \). What will the temperature of the coffee be after 20 minutes?

Solutions

1. Compute > Solve ODE > Exact (Independent Variable \( t \)): \( y'' - 6y' + 5y = 0 \), Exact solution: \( C_1 e^{5t} + C_2 e^t \)
2. Compute > Solve ODE > Exact (Independent Variable \( x \)): \( x^2y'' - 3xy' - 6y = 0 \), Exact solution: \( C_1 x^{2+\sqrt{10}} + C_2 x^{2-\sqrt{10}} \)
3. Compute > Solve ODE > Exact (Independent Variable \( x \)): \( 2x^2 y' = xy + 3y^2 \), Exact solution: \( y(x) = \frac{x^{3/2}}{3\sqrt{x} + C_1 x} \)
4. Compute > Solve ODE > Laplace (Independent Variable \( t \)): \( y' + y = 2 \) \( y(0) = 0 \), Laplace solution: \( y(t) = 2 - 2e^{-t} \)
Chapter 10 | Differential Equations

5. Compute > Solve ODE > Exact: \[ \frac{dy}{dx} - y + 3 = 0 \]
   Solution: \( y(x) = 3 - 2e^x \)

6. Compute > Solve ODE > Exact: \[ z^2 \frac{d^2w}{dx^2} + z \frac{dw}{dx} + (z^2 - v^2) w = 0 \]
   Exact Solution: \( C_{31} \text{BesselJ}_v(z) + C_{32} \text{BesselY}_v(z) \).

7. Compute > Solve ODE > Exact: \[ y' + y^2 + b + ax = 0 \]
   Exact Solution: \( \log \left( \sqrt{\frac{a}{b + ax}} \right) \) + \( C_90 \text{AiryBi} \left( \frac{b + ax}{a} \right) \) = \( 20 \text{AiryAi} \left( \frac{b + ax}{a} \right) \)
   \[ T \]

8. Compute > Solve ODE > Exact: \[ \frac{dT}{dt} = k (T - 70) \]
   Exact Solution: \( T(t) = 70 + e^{kt} C_1 \)
   Solution: \( \{ k = \frac{1}{10} \ln \frac{5}{9}, C_1 = 90 \} \)
   Compute > Solve > Exact: \( 160 = C_1 e^{0} + 70 \), \( 120 = C_1 e^{10} + 70 \)
   Compute > Definitions > New Definition: \( C_1 = 90, k = \frac{1}{10} \ln \frac{5}{9} \)
   Compute > Definitions > New Definition: \( T(t) = 70 + e^{kt} C_1 \)
   Compute > Evaluate: \( T(t) = 90e^{\frac{1}{10} \ln \frac{5}{9}} + 70 \)
   Compute > Evaluate Numeric: \( T(20) = 97.778^\circ \)
Statistics is the science and art of obtaining and analyzing quantitative data in order to make sound inferences in the face of uncertainty. The word *statistics* is used to refer both to a set of quantitative data and to a field of study. The field includes the development and application of effective methods for obtaining and using quantitative data.

### Introduction to Statistics

You can perform statistical operations on data using the various items on the Statistics submenu. In addition to the menu items, a number of the standard statistical distribution functions and densities are available, either built in or definable.

The items Mean, Median, Mode, Moment, Quantile, Mean Deviation, Standard Deviation, and Variance on the Statistics submenu take a single argument that can be presented as a list of data or as a matrix. The result of an operation is a number or, in the case of a matrix or vector, a number for each column.

The items Correlation, Covariance, and Fit Curve to Data on the Statistics submenu take a single argument that must be a matrix. For the multiple regression curve-fitting commands, the columns must be labeled with variable names. The choice Compute > Statistics > Random Numbers allows you to get random samples from standard families of distributions.
Chapter 11 | Statistics

Lists and Matrices

You can store data in lists or in matrices. Numbers in a list should be separated by commas, with the numbers and commas both in mathematics mode. Lists can be plain or enclosed in brackets. A list of data is also referred to as a set of data. A list can be reshaped into a matrix.

To reshape a comma-delimited list or set of data into a matrix

1. Place the insert point in the list or set, and choose Compute > Matrices > Reshape.

2. In the dialog box that appears, type a number for Columns and choose OK.

3. If brackets do not appear, select the matrix with the mouse, choose Insert > Math Objects > Brackets, and select appropriate brackets.

\[
\begin{bmatrix}
1, & 3.1, & 2, & 9.6, & 3, & 10.5, & 4, & 6.8, & 5, & 2.9, & 6, & 2.2,
\end{bmatrix}
\]

For this plot, the matrix of points was used for two items. Item 1 is a Point Plot with Point Marker set to Circle. Item 2 has Line Style set to Dash. (See Reshaping Lists and Matrices, page 293, for more examples.)
Measures of Central Tendency

You can compute ordinary measures of central tendency. Several of these, such as Mean, Median, Mode, Geometric Mean, and Harmonic Mean, are items on the Statistics submenu.

**Arithmetic Mean**

The *mean* (arithmetic mean, average) of the numbers \( x_1, x_2, \ldots, x_n \) is the most commonly used measure of central tendency. It is the sum of the numbers divided by the number of numbers.

\[
\frac{\sum_{i=1}^{n} x_i}{n}
\]

To find the mean of the numbers in a list

1. Place the insert point in the list.

2. Choose Compute > Statistics > Mean.

```
Compute > Statistics > Mean
a, b, c Mean(s) \( \frac{1}{3}a + \frac{1}{3}b + \frac{1}{3}c \)  23, 5, −6, 18, 23, −22, 5 Mean(s) \( \frac{46}{7} \)
16.5, 22.1, 6.9, 14.2, 9.0, Mean(s) 13.74
```

Choosing Compute > Statistics > Mean gives the means of the columns. Applying Mean again, this time to the list of column means, gives the mean of the matrix entries.

```
Compute > Statistics > Mean
\[
\begin{bmatrix}
23 & 5 & −6 \\
18 & 23 & −22 \\
5 & 0 & 0
\end{bmatrix}
\]
Mean(s) \[ \frac{46}{7}, \frac{28}{7}, −\frac{28}{7} \] \[ \frac{46}{7}, \frac{28}{7}, −\frac{28}{7} \] Mean(s) \( \frac{46}{9} \)
```

Notice that two of the following matrices are interpreted as labeled matrices, so the first row is ignored.
Chapter 11 | Statistics

**Compute > Statistics > Mean**

\[
\begin{bmatrix}
  x & y & z \\
  1 & 1 & 4 \\
  3 & 2 & 5 \\
  5 & 3 & 6 \\
  7 & 4 & 7 \\
\end{bmatrix}
\]

Mean(s) \(\left[4, \frac{5}{2}, \frac{11}{2}\right]\)

\[
\begin{bmatrix}
a & b \\
  c & d \\
  f & g \\
\end{bmatrix}
\]

Mean(s) \(\left[\frac{1}{2}c + \frac{1}{2}f, \frac{1}{2}d + \frac{1}{2}g\right]\)

**Median**

A median of a finite list of numbers is a number such that at least half the numbers in the set are equal to or less than it, and at least half the numbers in the set are equal to or greater than it. If two different numbers satisfy this criterion, MuPAD takes the smaller number as the median. The value computed for a median may vary according to different conventions.

You do not have to arrange the numbers in increasing order before computing the median. Leave the insert point in a list or set of data, a vector, or a matrix and choose Compute > Statistics > Median.

**Compute > Statistics > Median**

\[
\begin{bmatrix}
  1, 5, 2 \\
  1, 2, 3, 4 \\
\end{bmatrix}
\]

Median(s) \(2, 2, 3, 3\)

\[
\begin{bmatrix}
  23 & 5 & -6 \\
  18 & 23 & -22 \\
  5 & 0 & 0 \\
\end{bmatrix}
\]

Median(s) \(\left[18, 5, -6\right]\)

\[
\begin{bmatrix}
a & b \\
  1 & 2 \\
  5 & 6 \\
  3 & 4 \\
\end{bmatrix}
\]

Median(s) \(\left[3, 4\right]\)

**Quantile**

The \(q\)th quantile of a set, where \(q\) is a number between zero and one, is a number \(Q\) satisfying the condition that the fraction \(q\) of the numbers falls below \(Q\) and the fraction \(1 - q\) lies above \(Q\). The 0.5th quantile is a median or 50th percentile, whereas the 0.25th quantile is a first quartile or 25th percentile, and so forth. Take the \(q\)th quantile
Measures of Central Tendency

of a matrix to find the qth quantiles of the columns.

The value of a quantile of a finite set of numbers may vary according to different conventions. The quantile is interpreted here according to the algorithms implemented by the MuPAD computational engine. You can find quantiles of a list of numbers, a set of numbers, a vector, or columns of a matrix.

Compute > Statistics > Quantile

1, 2, 3, 4, 5, 6, 7, 8, 9, 10 Quantile(s): 0.87, 9

{5, 6, 7, 8, 3, 57, 1.4, 37, 2} Quantile(s): 0.25, 2

[765, 654, 345, 789] Quantile(s): 0.99, 789

\[
\begin{bmatrix}
0.49 & -0.35 \\
-0.75 & 0.25 \\
0.33 & -2 \\
0.50 & 0.50
\end{bmatrix}
\]

Quantile(s): 0.75, 0.25

Quantile(s): 0.33, [5, 0, -22]

Quantile(s): 0.50, [18, 5, -6]

Mode

A mode is a value that occurs with maximum frequency. To find the mode or modes of a list of numbers or of the columns of a matrix, leave the insert point in the list or matrix and choose Compute > Statistics > Mode. The computational engine also returns the multiplicity of the mode or modes.

Compute > Statistics > Mode

23, 5, -6, 18, 23, -22, 5 Mode(s) [23, 5], 2

1, 1, 5, 5, 7, 7, 8, 9, 9, 9 Mode(s) [5, 9], 3

Mode(s) [23, 18, 5], 1, [23], 2, [-6, -22], 0, 1]

The following matrix is interpreted as a labeled matrix, and the modes returned are the modes of the matrix \[
\begin{bmatrix}
3 & 4 \\
1 & 2
\end{bmatrix}
\]
Chapter 11 | Statistics

**Compute > Statistics > Mode**

\[
\begin{array}{cc}
3 & 4 \\
1 & 2 \\
\end{array}
\]

Mode(s) \([3, 1, 1, [4, 2], 1]\)

**Geometric Mean**

The geometric mean of \(n\) nonnegative numbers \(x_1, x_2, \ldots, x_n\) is the \(n\)th root of the product of the numbers \(\sqrt[n]{x_1 x_2 \cdots x_n}\).

The geometric mean is useful with data for which the ratio of any two consecutive numbers is nearly constant, such as money invested with compound interest.

To find the geometric mean of a set of nonnegative numbers, leave the insert point in a list, set, vector, or matrix of numbers and choose Compute > Statistics > Geometric Mean. For a matrix, the result is a list of geometric means of the columns.

**Compute > Statistics > Geometric Mean**

\([3, 56, 14, 2]\) Geometric Mean(s) \(\sqrt[4]{704}\)

\(\begin{array}{ccc}
2.9 & 5.2 & 9.7 \\
6.2 & 8.8 & 1.1 \\
\end{array}\)

Geometric Mean(s) \([4.203, 6.7646, 3.2665]\)

You can also find the geometric mean directly from the defining formula, as follows.

**Compute > Evaluate Numeric**

\(\sqrt[4]{3 \times 56 \times 14 \times 2} \approx 8.2816\)

\(\sqrt[4]{(5.19)(7.3)(2.77)(3.67)(8)} \approx 4.9859\)

More generally, you can compute the geometric mean by defining the function

\[G(z, n) = \sqrt[n]{\prod_{i=1}^{n} z_i}\]

and a vector \(z = [z_1, z_2, \ldots, z_n]\) and then evaluating \(G(z, n)\).

**Compute > Definitions > New Definition**

\[G(z, n) = \sqrt[n]{\prod_{i=1}^{n} z_i}\]

\(s = [3, 56, 14, 2]\)

\(t = [5.19, 7.3, 2.77, -3.67, -8]\)

\(u = [4, 7, 18]\)

\(v = [4, 7, 13, 18]\)

414
Measures of Central Tendency

If you invest $1 and earn 10% per year for six years, the value of your investment in this and the succeeding years is

\[ 1.00, 1.10, 1.21, 1.33, 1.46, 1.61, 1.77 \]

The geometric mean of these seven numbers is 1.33.

**Harmonic Mean**

The harmonic mean of \( n \) positive numbers \( x_1, x_2, \ldots, x_n \) is the reciprocal of the mean of the reciprocals.

\[
\frac{n}{\sum_{i=1}^{n} \frac{1}{x_i}}
\]

The harmonic mean can be used in averaging speeds, where the distances applying to each speed are the same.

To find the harmonic mean of a set of positive numbers, leave the insertion point in a list, set, vector, or matrix of numbers, and choose Compute > Statistics > Harmonic Mean. For a matrix or vector, the result is a list of harmonic means of the columns.

\[
\frac{3}{\frac{1}{a} + \frac{1}{b} + \frac{1}{c}}
\]

\[ 0.67, 1.9, 6.2, 5.8, 4.7 \quad \text{HarmonicMean(s)} \quad 1.9491 \]

You can also compute a harmonic mean directly from the defining formula. Following are the harmonic mean of 2, 4, 6, and 8, and the harmonic mean of 0.67, 1.9, 6.2, 5.8, and 4.7, respectively.

\[
\frac{4}{\frac{1}{2} + \frac{1}{4} + \frac{1}{6} + \frac{1}{8}} = \frac{96}{25}
\]

\[ 5 \left( \frac{1}{0.67} + \frac{1}{1.9} + \frac{1}{6.2} + \frac{1}{5.8} + \frac{1}{4.7} \right)^{-1} = 1.9491 \]
You can compute the harmonic mean by defining the function

\[ H(z, n) = \frac{n}{\sum_{k=1}^{n} \frac{1}{z_k}} \]

and the vector \( z = [z_1, z_2, \ldots, z_n] \) and then evaluating \( H(z, n) \).

**Compute > Definitions > New Definition**

\[
\begin{align*}
H(z, n) &= \frac{n}{\sum_{k=1}^{n} \frac{1}{z_k}} \\
 s &= [2, 4, 6, 8] \\
 t &= [0.67, 1.9, 6.2, 5.8, 4.7] \\
 u &= [4, 7, 18] \\
 v &= [4, 7, 13, 18]
\end{align*}
\]

**Compute > Evaluate**

\[
\begin{align*}
H(s, 4) &= \frac{96}{25} \\
H(u, 3) &= \frac{756}{113} \\
H(t, 5) &= 1.9491 \\
H(v, 4) &= \frac{13104}{1721}
\end{align*}
\]

If you average 20 m.p.h. driving from your home to a friend’s home and 30 m.p.h. driving back home over the same route, then your “average” speed for the round trip is the harmonic mean

\[
\frac{2}{\frac{1}{20} + \frac{1}{30}} = 24 \text{ m.p.h.}
\]

This computation gives the speed that you would have to travel if you did the round trip at a constant speed, taking the same total amount of time.

**Measures of Dispersion**

The various measures of dispersion describe different aspects of the spread, or dispersion, of a set of variates about their mean.

**Mean Deviation**

The mean deviation is the mean of the distances of the data from the data mean. The mean deviation of \( x_1, x_2, \ldots, x_n \) is

\[
\frac{\sum_{i=1}^{n} |x_i - \frac{\sum_{j=1}^{n} x_j}{n}|}{n}
\]
where the vertical bars denote absolute value. For example, the mean
deviation of \( \{1, 2, 3, 4, 5\} \) is

\[
\frac{|1 - 3| + |2 - 3| + |3 - 3| + |4 - 3| + |5 - 3|}{5} = 6
\]

You can present the data as a list, vector, or matrix. In the latter case,
you get the mean deviations of the columns.

**Compute > Statistics > Mean Deviation**

\[
\begin{bmatrix}
-85 & -55 & -37 \\
-35 & 97 & 50
\end{bmatrix}
\]

Mean deviation(s) \([25, 76, \frac{87}{2}]\)

**Variance and Standard Deviation**

The *sample variance* for \( x_1, x_2, \ldots, x_n \) is the sum of the squares of
differences with the mean, divided by \( n - 1 \).

\[
\frac{\sum_{i=1}^{n} (x_i - \frac{\sum_{i=1}^{n} x_i}{n})^2}{n - 1}
\]

**To compute sample variance**

- Place the insert point in a list of data, in a vector, or in a matrix
  and choose Compute > Statistics > Variance.

**Compute > Statistics > Variance**

\[
\begin{bmatrix}
18.1 \\
5.3 \\
7.6
\end{bmatrix}
\]

Variance(s) \(46.563\)

\[
\begin{bmatrix}
23 & 5 & -6 \\
18 & 23 & -22 \\
5 & 0 & 0
\end{bmatrix}
\]

Variance(s) \([\frac{259}{3}, \frac{439}{3}, \frac{388}{3}]\)

Note that the following matrix is treated as a labeled matrix and
the first row is ignored in the computation.

**Compute > Statistics > Variance**

\[
\begin{pmatrix}
x & y \\
a & b \\
c & d
\end{pmatrix}
\]

Variance(s) \(2 (\frac{1}{2}a - \frac{1}{2}c)^2, 2 (\frac{1}{2}b - \frac{1}{2}d)^2\)
Chapter 11 | Statistics

The square root of the variance is called the standard deviation. It is the most commonly used measure of dispersion.

\[
\sqrt{\frac{\sum_{i=1}^{n} (x_i - \bar{x})^2}{n-1}}
\]

**Compute > Statistics > Standard Deviation**

\[
\begin{pmatrix}
5.1 & 89.4 & 29.47 & 18 \\
18.1 & 5.3 & 7.6 & \\
23 & 5 & -6 & \\
18 & 23 & -22 & \\
5 & 0 & 0 & \\
\end{pmatrix}
\]

Standard Deviation(s) 6.8237

\[
\begin{pmatrix}
23 & 5 & -6 & \\
18 & 23 & -22 & \\
5 & 0 & 0 & \\
\end{pmatrix}
\]

Standard Deviation(s) [\(\frac{1}{3}\sqrt{3}\sqrt{259}, \frac{1}{3}\sqrt{3}\sqrt{439}, \frac{2}{3}\sqrt{3}\sqrt{97}\)]

Note that the following matrix is treated as a labeled matrix, and the first row is ignored.

**Compute > Statistics > Standard Deviation**

\[
\begin{pmatrix}
x & y & \\
a & b & \\
c & d & \\
\end{pmatrix}
\]

Standard Deviation(s) \[\sqrt{2} \sqrt{\left(\frac{1}{2}a - \frac{1}{2}c\right)^2}, \sqrt{2} \sqrt{\left(\frac{1}{2}b - \frac{1}{2}d\right)^2}\]

**Covariance**

The covariance matrix of an \(m \times n\) matrix \(X = [x_{ij}]\) is an \(n \times n\) matrix with \((i, j)\)th entry

\[
\sum_{k=1}^{m} \left(x_{ki} - \frac{\sum_{j=1}^{n} x_{kj}}{m}\right) \left(x_{kj} - \frac{\sum_{i=1}^{m} x_{ij}}{m}\right)
\]

\(m - 1\)

Note that for each \(i\), the \((i, i)\)th entry is the variance of the data in the \(i\)th column, making the variances of the column vectors occur down the main diagonal of the covariance matrix. The definition of covariance matrix is symmetric in \(i\) and \(j\), so the covariance matrix is always a symmetric matrix.
Measures of Dispersion

Compute > Statistics > Mean

\[
\begin{bmatrix}
1 & 2 \\
3 & 5 \\
4 & 3 \\
\end{bmatrix}
\]
\[
\text{Mean(s)} \left\{ \frac{8}{3}, \frac{10}{3} \right\}
\]

\[
\begin{bmatrix}
8.5 & -5.5 & -3.7 \\
-3.5 & 9.7 & 5.0 \\
7.9 & 5.6 & 4.9 \\
\end{bmatrix}
\]
\[
\text{Mean(s)} \left\{ 4.3, 3.2667, 2.0667 \right\}
\]

Compute > Statistics > Variance

\[
\begin{bmatrix}
1 & 2 \\
3 & 5 \\
4 & 3 \\
\end{bmatrix}
\]
\[
\text{Variance(s)} \left\{ \frac{2}{3}, \frac{7}{3} \right\}
\]

\[
\begin{bmatrix}
8.5 & -5.5 & -3.7 \\
-3.5 & 9.7 & 5.0 \\
7.9 & 5.6 & 4.9 \\
\end{bmatrix}
\]
\[
\text{Variance(s)} \left\{ 45.72, 61.843, 24.943 \right\}
\]

Compute > Statistics > Covariance

\[
\begin{bmatrix}
1 & 2 \\
3 & 5 \\
4 & 3 \\
\end{bmatrix}
\]
\[
\text{Covariance matrix} \begin{bmatrix} 2.3333 & 1.1667 \\ 1.1667 & 2.3333 \end{bmatrix}
\]

\[
\begin{bmatrix}
8.5 & -5.5 & -3.7 \\
-3.5 & 9.7 & 5.0 \\
7.9 & 5.6 & 4.9 \\
\end{bmatrix}
\]
\[
\text{Covariance matrix} \begin{bmatrix} 45.72 & -39.3 & -18.45 \\ -39.3 & 61.843 & 38.018 \\ -18.45 & 38.018 & 24.943 \end{bmatrix}
\]

**Moment**

The rth moment of a set \( \{x_1, x_2, \ldots, x_n\} \) about the point \( a \) is the following sum:

\[
\frac{1}{n} \sum_{i=1}^{n} (x_i - a)^r
\]

Thus, the mean is also known as the first moment about zero. The second moment about zero is the quantity \( \mu^2 + \sigma^2 \), where \( \mu \) is the mean and \( \sigma^2 \) is the variance of the data. The rth moment about the mean is the sum

\[
\frac{1}{n} \sum_{i=1}^{n} \left( x_i - \frac{1}{n} \sum_{j=1}^{n} x_j \right)^r
\]
Chapter 11 | Statistics

As easily seen, the first moment about the mean is always 0.

Example

The 3rd and 4th moments of the set \{2, 4, 6, 8, 10, 12, 14, 16, 18\} about the mean are

\[
\frac{1}{9} \sum_{i=1}^{9} \left( 2i - \frac{1}{9} \sum_{j=1}^{9} 2j \right)^3 = 0
\]

\[
\frac{1}{9} \sum_{i=1}^{9} \left( 2i - \frac{1}{9} \sum_{j=1}^{9} 2j \right)^4 = \frac{3776}{3} \approx 1258.7
\]

Correlation

In dealing with two random variables, we refer to the measure of their linear correlation as the correlation coefficient. When two random variables are independent, this measure is 0. If two random variables \(X\) and \(Y\) are linearly related in the sense \(Y = a + bX\) for some constants \(a\) and \(b\), then the coefficient of correlation reaches one of the extreme values +1 or −1. In either of these cases, \(X\) and \(Y\) are referred to as perfectly correlated. The formula for the coefficient of correlation for two random variables is

\[
\rho = \rho (X,Y) = \frac{\text{Cov} (X,Y)}{\sigma_x \sigma_y} = \frac{\sigma_{xy}}{\sigma_x \sigma_y}
\]
where \( \sigma_x \) and \( \sigma_y \) are the standard deviations of the two random variables.

To compute the coefficient of correlation between two samples, enter the data as two columns of a matrix and choose Compute > Statistics > Correlation. You can apply this operation to any size matrix to get the coefficient of correlation for each pair of columns: the number in the \( i, j \) position is the coefficient of correlation between column \( i \) and column \( j \). A correlation matrix is always symmetric, with ones on the main diagonal.

\[
\text{Correlation matrix: } \begin{bmatrix} 1.0 & 7.4831 \times 10^{-2} \\ 7.4831 \times 10^{-2} & 1.0 \end{bmatrix}
\]

\[
\text{Correlation matrix: } \begin{bmatrix} 1.0 & -0.52883 & -0.71054 \\ -0.52883 & 1.0 & 0.97297 \\ -0.71054 & 0.97297 & 1.0 \end{bmatrix}
\]

The relationship \( \frac{\text{Cov}(X,Y)}{\sigma_x \sigma_y} = \rho(X,Y) \) among correlation, covariance, and the standard deviations is illustrated in the following:

\[
\text{Correlation matrix: } \begin{bmatrix} 1.0 & -0.52883 \\ -0.52883 & 1.0 \end{bmatrix}
\]

\[
\text{Covariance matrix: } \begin{bmatrix} 1677.0 & -381.5 \\ -381.5 & 310.33 \end{bmatrix}
\]

\[
\text{Standard Deviation(s): } \sqrt{1677} \approx 40.93
\]

\[
\text{Evaluate Numeric: } \frac{381.5}{\sqrt{1677}} \approx -0.5281
\]

**Distributions and Densities**

A cumulative distribution function \( F(x) \) of a random variable \( X \) is the function \( F(x) = P(X \leq x) \), the probability that \( X \leq x \). If \( F(x) \) has a derivative \( f(x) \), then \( f(x) \) is nonnegative and is called the probability density function of \( x \). The inverse distribution function \( G(\alpha) \)
Chapter 11 | Statistics

satisfies \( G(F(x)) = x \) and \( F(G(\alpha)) = \alpha \). The names for these functions are obtained by adding Dist, Den, or Inv to the name of the distribution. For example, NormalDist, NormalDen, and NormalInv are the three functions for the normal distribution. These function names will automatically turn gray when typed in mathematics mode.

Cumulative Distribution Functions

A cumulative distribution function is a nondecreasing function defined on the interval \((-\infty, \infty)\), with values in the interval \([0, 1]\). The definition of a distribution function generally describes only the values where the function is positive, the implicit assumption being that the distribution function is zero up to that point. For discrete cumulative distribution functions, the definition also gives only the values where the function changes, the implicit assumption being that the cumulative distribution function is a step function. Commonly, definitions of these functions are stated only for integers. The definition of a density function also generally describes only the values where the function is positive, the implicit assumption being that the function is zero elsewhere.

These distribution and density functions satisfy the relationships

\[ f(x) = \frac{d}{dx} F(x) \quad \text{and} \quad F(x) = \int_{-\infty}^{x} f(u)du \]

Also note that the cumulative distribution function satisfies

\[ \lim_{x \to \infty} F(x) = 1 \quad \text{and} \quad \lim_{x \to -\infty} F(x) = 0. \]

In Scientific WorkPlace and Scientific Notebook, cumulative distribution functions are named FunctionDist, and the density functions are named FunctionDen. For example, the probability density functions for the normal distributions are called NormalDen.

You can compute with several families of distributions: Normal, Cauchy, Student’s t, Chi-Square, F, Exponential, Weibull, Gamma, Beta, Uniform, Binomial, Poisson, and Hypergeometric.

Inverse Distribution Functions

For a distribution function \( F \) mapping \((-\infty, \infty)\) into \([0, 1]\), the inverse distribution function \( G \) performs the corresponding inverse mapping from \([0, 1]\) into \((-\infty, \infty)\); that is, \( G(F(x)) = x \) and \( F(G(\alpha)) = \alpha \). Equivalently, \( \text{Prob}[X \leq G(\alpha)] = F(x) = \alpha \). Note
that the value that is exceeded with probability $\alpha$ is given by the function $G(1 - \alpha)$. This function is also of interest.

$$\text{Prob}[X \leq G(1 - \alpha)] = F(x) = 1 - \alpha = 1 - \text{Prob}[X \leq G(\alpha)]$$

When cumulative distribution functions are named FunctionDist, then the inverse cumulative distribution functions are named FunctionInv. For example, NormalInv is the name of the inverse cumulative distribution function for the normal distribution.

**Distribution Tables**

Depending on the particular family of distributions, the distribution tables in statistics books list function values for selected parameters of one of the functions described earlier—either the cumulative distribution, the inverse cumulative distribution, or the probability density function. With access to these functions, not only can you compute the tabular entries easily and accurately, but you can also find the corresponding values directly for any variables and parameters to any degree of accuracy you wish.

**Families of Continuous Distributions**

The relationship of the various distribution, inverse distribution, and density functions to the entries in standard statistical tables is explained in the following sections for each of the families of distributions available.

**Gamma Function**

The Gamma function $\Gamma(t)$ that appears in the definition of the Student’s $t$ distribution and the gamma distribution is the continuous function $\Gamma(t) = \int_0^\infty e^{-x}x^{t-1}dx$ defined for positive real numbers $t$. The Gamma function satisfies

$$\Gamma(1) = 1 \quad \text{and} \quad \Gamma(t + 1) = t\Gamma(t)$$

and for positive integers $k$, it is the familiar factorial function

$$\Gamma(k) = (k - 1)!$$

The Gamma function symbol $\Gamma$ is recognized as a function. For example, place the insert point in the expression $\Gamma(5)$ and choose Evaluate to get $\Gamma(5) = 24$. Note that $24 = 4 \times 3 \times 2 \times 1$. (See page 157 for a plot of the Gamma function.)
Chapter 11 | Statistics

Use Rewrite > Factorial to convert the Gamma function to a factorial expression. (First you must assume that $x$ is an integer.)

**Compute** > **Evaluate**

| assume $(x, \text{ integer}) = \mathbb{Z}$ |

**Compute** > **Rewrite** > **Factorial**

$$\Gamma(x) = (x - 1)! \quad \binom{m}{n} = \frac{m!}{n!(m-n)!}$$

Use Rewrite > Gamma to convert factorials, binomials, and multinomial coefficients to expressions in the Gamma function.

**Compute** > **Rewrite** > **Gamma**

$$x! = \Gamma(x + 1) \quad \binom{m}{n} = \frac{\Gamma(m+1)}{\Gamma(n+1) \Gamma(m-n+1)}$$

Normal Distribution

The normal cumulative distribution function is defined for all real numbers $\mu$ and for positive $\sigma$ by the integral

$$\text{NormalDist}(x; \mu, \sigma) = \frac{1}{\sigma \sqrt{2\pi}} \int_{-\infty}^{x} e^{-\frac{(u-\mu)^2}{2\sigma^2}} du$$

of the normal probability density function

$$\text{NormalDen}(u; \mu, \sigma) = \frac{1}{\sigma \sqrt{2\pi}} e^{-\frac{(u-\mu)^2}{2\sigma^2}}$$

The inverse of the normal cumulative distribution function, NormalInv, is also available. All three of these function names can be typed in mathematics, and they will automatically turn gray as you type the final letter.

The parameters $\mu$ and $\sigma$ are optional parameters for mean and standard deviation, with the default values 0 and 1 defining the standard normal distribution

$$\text{NormalDist}(x) = \frac{1}{\sqrt{2\pi}} \int_{-\infty}^{x} e^{-\frac{u^2}{2}} du$$

A normal distribution table, as found in the back of a typical statistics book, lists some values of the standard normal cumulative distribution function. Certain versions of the table list the values $1 - \text{NormalDist}(x)$.
Families of Continuous Distributions

Note that the function NormalDist can be evaluated as a function of one variable (with default parameters $0, 1$) or as a function of one variable and two parameters.

Compute > Evaluate Numeric

| $\text{NormalDist}(2.44)$ | $\approx 0.99266$ | $\text{NormalDist}(2.44; 1, 2) \approx 0.76424$ |
| $\text{NormalDist}(2.44; 0, 1) \approx 0.99266$ | $\text{NormalDen}(2.44; 1, 2) \approx 0.15393$ |

Graphs of the normal density functions are the familiar bell-shaped curves. The plots to the right show the density functions $\text{NormalDen}(x; \mu, \sigma)$ and distribution functions $\text{NormalDist}(x; \mu, \sigma)$ for the parameters $(\mu, \sigma) = (0, 1), (0, 5), (0, 0.5), (1, 1)$

Student's t Distribution

The Student's t cumulative distribution function $\text{TDist}(x; v)$ is defined by the integral

$$\text{TDist}(x; v) = \frac{\Gamma\left(\frac{v+1}{2}\right)}{\Gamma\left(\frac{v}{2}\right)\sqrt{\pi v}} \int_{-\infty}^{x} \left(1 + \frac{1}{v} u^2\right)^{-\frac{v+1}{2}} du$$

of the density function

$$\text{TDen}(u; v) = \frac{\Gamma\left(\frac{v+1}{2}\right)}{\Gamma\left(\frac{v}{2}\right)\sqrt{\pi v}} \left(1 + \frac{1}{v} u^2\right)^{-\frac{v+1}{2}}$$

with shape parameter $v$, called degrees of freedom, that ranges over the positive integers. The variance for a Student's t distribution is $\frac{v}{v-2}$, provided $v > 2$.

The function $\text{TInv}(p; v)$ is the value of $x$ for which the integral has the value $p$, as demonstrated here:

Compute > Evaluate Numeric

| $\text{TDist}(63.66; 1) \approx 0.995$ | $\text{TDist}(-0.97847; 3) \approx 0.2$ |
| $\text{TInv}(0.995; 1) \approx 63.657$ | $\text{TInv}(0.2; 3) \approx -0.97847$ |

The plots to the right display the density and distribution functions $\text{TDen}(x; v)$ and $\text{TDist}(x; v)$ for the parameters $v = 1$ and $v = 15$ with $-5 \leq x \leq 5$.

Note that the Student's t density functions resemble the standard normal density function in shape, although these curves are a bit flatter at the center. It is not difficult to show, using the definitions of the
two density functions, that \( \lim_{v \to \infty} \text{TDen}(u; v) = \text{NormalDen}(u) \),
the density function for the standard normal distribution.

Student’s t distribution tables list values of the inverse distribution function corresponding to probabilities (values of the distribution function) and degrees of freedom. For values of \( v \) above 30, the normal distribution is such a close approximation for the Student’s t distribution that tables usually provide values only up to \( v = 30 \).

Example

Assuming a Student’s t distribution with 5 degrees of freedom, determine a value \( c \) such that
\[
\Pr(c < T < c) = 0.90
\]
where \( \Pr \) denotes probability. Now \( \Pr(-c < T < c) = \Pr(T \leq c) - \Pr(T \leq -c) = \text{TDist}(c; 5) - \text{TDist}(-c; 5) \). So, you need to solve
\[
2 \text{TDist}(c; 5) - 1 = 0.90
\]
\[
\text{TDist}(c; 5) = \frac{0.90 + 1}{2} = 0.95
\]
The problem is solved by \( \text{TInv}(0.95; 5) = 2.015 \).

Chi-Square Distribution

The chi-square cumulative distribution function is defined for non-negative \( x \) and \( \mu \) by the integral
\[
\text{ChiSquareDist}(x; \mu) = \frac{1}{\Gamma(\frac{\mu}{2}) 2^{\frac{\mu}{2}}} \int_0^x u^{\frac{\mu}{2}-1} e^{-\frac{u}{2}} du
\]
The integrand is the chi-square probability density function
\[
\text{ChiSquareDen}(u; \mu) = \frac{1}{\Gamma(\frac{\mu}{2}) 2^{\frac{\mu}{2}}} u^{\frac{\mu}{2}-1} e^{-\frac{u}{2}}
\]
The indexing parameter \( \mu > 0 \) is the mean of the distribution; it is referred to as the degrees of freedom.

The plots to the right show density functions ChiSquareDen\((x; \mu)\) and distribution functions ChiSquareDist\((x; \mu)\) for \( \mu = 1, 5, 10, 15 \) and \( 0 \leq x \leq 25 \).

The function, \( \text{ChiSquareInv}(t; v) \) gives the value of \( x \) for which
\[
\text{ChiSquareDist}(x; v) = t.
\]
This relationship is demonstrated in the following examples:
Families of Continuous Distributions

**Compute > Evaluate Numeric**

\[
\text{ChiSquareInv}(0.1; 5) \approx 1.6103 \quad \text{ChiSquareDist}(2.366; 3) \approx 0.5
\]

\[
\text{ChiSquareInv}(0.5; 3) \approx 2.366 \quad \text{ChiSquareDist}(1.6103; 5) \approx 9.9999 \times 10^{-2} \approx 0.1
\]

A chi-square distribution table shows values of \( \nu \) down the left column and values \( u \) of \( \text{ChiSquareDist} \) across the top row. The entry in row \( \nu \) and column \( u \) is \( \text{ChiSquareInv}(u; \nu) \).

**F Distribution**

The *F cumulative distribution function* is given by the integral

\[
\text{FDist}(x; n, m) = \frac{\Gamma\left(\frac{n+m}{2}\right)}{\Gamma\left(\frac{n}{2}\right)\Gamma\left(\frac{m}{2}\right)} \left( \frac{n}{m} \right)^{\frac{n}{2}} \int_0^x u^{\frac{n}{2}-2} \left( 1 + \frac{n}{m} u \right)^{-\frac{n+m}{2}} \, du
\]

of the probability density function

\[
\text{FDen}(u; n, m) = \frac{\Gamma\left(\frac{n+m}{2}\right)}{\Gamma\left(\frac{n}{2}\right)\Gamma\left(\frac{m}{2}\right)} \left( \frac{n}{m} \right)^{\frac{n}{2}} u^{\frac{n}{2}-2} \left( 1 + \frac{n}{m} u \right)^{-\frac{n+m}{2}}
\]

The variable \( x \) can be any positive number, and \( n \) and \( m \) can be any positive integers. The F distribution is used to determine the validity of the assumption of identical standard deviations of two normal populations. It is the distribution on which the analysis of variance procedure is based.

The inverse distribution function \( \text{FInv}(p; n, m) \) gives the value of \( x \) for which the integral \( \text{FDist}(x; n, m) \) has the value \( p \). These function names automatically turn gray when they are entered in mathematics mode. The relationship between these two functions is illustrated in the following examples.

**Compute > Evaluate Numeric**

\[
\text{FDist}(0.1; 3, 5) \approx 4.3419 \times 10^{-2}
\]

\[
\text{FDist}(3.7797; 2, 5) \approx 0.90000
\]

\[
\text{FInv}(0.9; 2, 5) \approx 3.7797
\]

\[
\text{FInv}(0.043419; 3, 5) \approx 0.1
\]

Standard F distribution tables list some of the values of the inverse F distribution function. Thus, for example, the 4.4th percentile for the F distribution having degrees of freedom (3, 5) is \( \text{FInv}(0.044; 3, 5) = 0.1 \), and the 90th percentile for the F distribution having degrees of freedom (2, 5) is \( \text{FInv}(0.90; 2, 5) = 3.7797 \).
Chapter 11 | Statistics

The plots on the previous page show probability density functions FDen\((x; n, m)\) and cumulative distribution functions FDist\((x; n, m)\) for \((n, m) = (1, 1), (2, 5), (3, 15), \) and \(0 \leq x \leq 5\).

**Exponential Distribution**

The exponential cumulative distribution function with parameter \(\mu\), or mean \(\mu\), is defined by the integral

\[
\text{ExponentialDist}(x; \mu) = \frac{1}{\mu} \int_0^x e^{-\frac{u}{\mu}} du = 1 - e^{-\frac{x}{\mu}}
\]

of the exponential density function

\[
\text{ExponentialDen}(u; \mu) = \frac{1}{\mu} e^{-\frac{u}{\mu}}
\]

for \(x \geq 0\), and is 0 otherwise.

The inverse exponential distribution function

\[
\text{ExponentialInv}(\alpha; \mu) = \mu \ln \left(\frac{1}{1 - \alpha}\right)
\]

is the value of \(x\) for which the integral has the value \(\alpha\), as illustrated by the following:

Compute > Evaluate Numeric

- \(\text{ExponentialInv}(0.73; 0.58) \approx 0.75941\)
- \(\text{ExponentialDist}(0.75941; 0.58) \approx 0.73000\)
- \(\text{ExponentialDen}(0.75941; 0.58) \approx 0.46552\)

The plots to the right show density functions \(\text{ExponentialDen}(x; \mu)\) and distribution functions \(\text{ExponentialDist}(x; \mu)\), for the parameters \(\mu = 1, 3, 5\) and \(0 \leq x \leq 25\).

**Weibull Distribution**

The Weibull distribution with scale parameter \(b > 0\) and shape parameter \(a > 0\) is defined by the integral

\[
\text{WeibullDist}(x; a, b) = ab^{-a} \int_0^x u^{a-1} e^{-u^b} du = 1 - e^{-x^b}
\]

of the density function

\[
\text{WeibullDen}(u; a, b) = ab^{-a} u^{a-1} e^{-u^b}
\]
for $x \geq 0$, and is 0 otherwise.

The inverse Weibull distribution function

$$\text{WeibullInv}(\alpha; a, b) = b \left( \ln \frac{1}{1 - \alpha} \right)^\frac{1}{a}$$

is the value of $x$ for which the integral has the value $\alpha$, as illustrated by the following:

<table>
<thead>
<tr>
<th>Compute &gt; Evaluate Numeric</th>
</tr>
</thead>
<tbody>
<tr>
<td>WeibullDist $(0.51431; 0.5, 0.3) \approx 0.73$</td>
</tr>
<tr>
<td>WeibullInv $(0.73; 0.5, 0.3) \approx 0.51431$</td>
</tr>
</tbody>
</table>

Plots show the probability density functions WeibullDen$(x; a, b)$ and cumulative distribution functions WeibullDist $(x; a, b)$ for parameters $(a, b) = (0.5, 1), (1, 1), (3, 0.5), \text{ and } (3, 1)$, and $0 \leq x \leq 3$.

**Gamma Distribution**

The gamma distribution is defined for $x > 0$ by the integral

$$\text{GammaDist}(x; a, b) = \frac{1}{b^a \Gamma(a)} \int_0^x u^{a-1} e^{-\frac{u}{b}} du$$

where $\Gamma(t) = \int_0^\infty e^{-u} u^{t-1} du$ is the Gamma function. The parameters $a$ and $b$ are called the shape parameter and scale parameter, respectively. The mean of this distribution is $ab$ and the variance is $ab^2$. The probability density function for the gamma distribution is

$$\text{GammaDen}(u; a, b) = \frac{1}{b^a \Gamma(a)} u^{a-1} e^{-\frac{u}{b}}$$

Plots show the probability density functions GammaDen$(x; a, b)$ and cumulative distribution functions GammaDist $(x; a, b)$ for $(a, b) = (1, 0.5), (1, 1), \text{ and } (2, 1)$ and $0 \leq x \leq 4$. 

429
Chapter 11 | Statistics

**Beta Distribution**

The beta distribution is defined for $0 \leq x \leq 1$ by the integral

$$
\text{BetaDist}(x; v, w) = \frac{1}{B(v, w)} \int_0^x u^{v-1} (1 - u)^{w-1} \, du
$$

where $B(v, w) = \int_0^1 u^{v-1} (1 - u)^{w-1} \, du$ is the Beta function with parameters $v$ and $w$.

The probability density function for the beta distribution is

$$
\text{BetaDen}(u; v, w) = \frac{u^{v-1} (1 - u)^{w-1}}{B(v, w)}
$$

The parameters $v$ and $w$ are positive real numbers called shape parameters, and $0 \leq u \leq 1$. The mean of the beta distribution is $\frac{v}{v + w}$.

**Compute > Evaluate Numeric**

\[\text{BetaDist}(0.5; 2, 3) \approx 0.6875\]
\[\text{BetaDen}(0.5; 2, 3) \approx 1.5\]
\[\text{BetaInv}(0.6875; 2, 3) \approx 0.5\]

Plots show the probability density functions $\text{BetaDen}(x; b, c)$ and cumulative distribution functions $\text{BetaDist}(x; b, c)$ for $(b, c) = (2, 3), (5, 1), (3, 8)$, and $0 \leq x \leq 1$. 

430
Cauchy Distribution

The Cauchy cumulative distribution function is defined for all real numbers $\alpha$, and for positive $\beta$, by the integral

$$\text{CauchyDist}(x; \alpha, \beta) = \frac{1}{\pi \beta} \int_{-\infty}^{x} \left( 1 + \left( \frac{u - \alpha}{\beta} \right)^2 \right)^{-1} \, du$$

The integrand is the Cauchy probability density function

$$\text{CauchyDen}(u; \alpha, \beta) = \frac{1}{\pi \beta \left( 1 + \left( \frac{u - \alpha}{\beta} \right)^2 \right)}$$

The median of this distribution is $\alpha$. The Cauchy probability density function is symmetric about $\alpha$ and has a unique maximum at $\alpha$.

Plots show the probability density functions $\text{CauchyDen}(x; \alpha, \beta)$ and cumulative distribution functions $\text{CauchyDist}(x; \alpha, \beta)$ for the parameters $(\alpha, \beta) = (-3, 1), (0, 1.5)$, and $(3, 1)$, and $-5 \leq x \leq 5$.

Uniform Distribution

The uniform cumulative distribution function $\text{UniformDist}(x; a, b)$ for $a < b$ is the function

$$\text{UniformDist}(x; a, b) = \begin{cases} 
0 & \text{if } x \leq a \\
\frac{x-a}{b-a} & \text{if } a \leq x \leq b \\
1 & \text{if } b \leq x
\end{cases}$$

The probability density function of the uniform distribution on an
Chapter 11 | Statistics

interval \([a, b]\), where \(a < b\), is the function

\[
\text{UniformDen}(x; a, b) = \begin{cases} 
0 & \text{if } x < a \\
\frac{1}{b-a} & \text{if } a \leq x \leq b \\
0 & \text{if } b < x
\end{cases}
\]

The uniform random variable is the continuous version of “choosing a number at random.” The probability that a uniform random variable on \([a, b]\) will have a value in either of two subintervals of \([a, b]\) of equal length is the same.

Plots show the probability density functions UniformDen\((x; a, b)\) and cumulative distribution functions UniformDist\((x; a, b)\) for \((a, b) = (0, 1), (1.5, 5), (3, 15)\) and \(-5 \leq x \leq 20\).

**Families of Discrete Distributions**

Several of the standard distributions are functions of a discrete variable, usually the integers. They are commonly plotted with bar graphs or broken line (polygonal) graphs.

**Binomial Distribution**

The binomial distribution functions are functions of a nonnegative integer \(x\),

\[
\text{BinomialDist}(x; n, p) = \sum_{k=0}^{x} \binom{n}{k} p^k q^{n-k}
\]

with Bernoulli trial parameter (or sample size) a positive integer \(n\), Bernoulli probability parameter a real number \(p\) with \(0 < p < 1\), and \(q = 1 - p\). (To enter binomial coefficients, \(\binom{n}{k} = \frac{n!}{k!(n-k)!}\), choose Compute > Math Objects, select the binomial fraction \(\frac{n!}{k!(n-k)!}\) and check None for line.) The corresponding binomial probability density function is

\[
\text{BinomialDen}(x; n, p) = \binom{n}{k} p^k q^{n-k}
\]

for the same conditions on \(x, n,\) and \(p\). The mean for this distribution is \(np\), and the variance is \(npq\).

Binomial distribution tables found in statistics books give selected values of either the binomial probability density function BinomialDen\((x; n, p)\) or the cumulative distribution function BinomialDist\((x; n, p)\).
Families of Discrete Distributions

The binomial density $\text{BinomialDen}(x; n, p)$ gives the probability of $x$ successes in $n$ independent Bernoulli trials, when the probability of success at each trial is $p$. It is by far the most common discrete distribution, since people deal with many experiments in which a dichotomous classification of the result is of primary interest. The name binomial distribution comes from the fact that the coefficients

\[
\binom{n}{k} = \frac{n!}{k! (n-k)!}
\]

are commonly called binomial coefficients.

**Example**

The probability that, in 100 tosses of a coin with $Pr(\text{heads}) = 0.55$, no more than 54 heads turn up, assuming a binomial distribution, is $Pr(X \leq 54) = \text{BinomialDist}(54; 100, 0.55) = 0.45868$.

The binomial distribution function with parameters $n$ and $p$ can be approximated by the normal distribution with mean $np$ and variance $np(1-p)$; that is,

\[
\text{BinomialDist}(x; n, p) \approx \text{NormalDist}(x; np, \sqrt{np(1-p)})
\]

Such approximations are reasonably good if both $np$ and $n(1-p)$ are greater than 5. For example, to find an approximate solution to the preceding problem using a normal distribution, use

\[
Pr(X \leq 54) \approx \text{NormalDist}(54; 55.0, 4.9749) = 0.42035
\]

The plots to the right show the graph of $\text{NormalDist}(x; 55.0, 4.9749)$ with a point plot of $\text{BinomialDist}(x; 100, 0.55)$, and the graph of $\text{NormalDen}(x; 55.0, 4.9749)$ with a point plot of $\text{BinomialDen}(x; 100, 0.55)$ for $0 \leq x \leq 100$.

**Poisson Distribution**

The Poisson cumulative distribution function is a discrete function defined for non-negative integers. The Poisson distribution with mean $\mu > 0$ is given by the summation

\[
\text{PoissonDist}(x; \mu) = \sum_{k=0}^{x} \frac{\mu^k e^{-\mu}}{k!}
\]
Chapter 11 | Statistics

The Poisson probability density function is

$$\text{PoissonDen}(k; \mu) = \frac{\mu^k e^{-\mu}}{k!}$$

for nonnegative integers $k$ and real numbers $\mu > 0$. A Poisson distribution table lists selected values of the Poisson probability density function $\text{PoissonDen}(k; \mu)$.

Compute > Evaluate Numeric

$$\text{PoissonDen}(2; 3) \approx 0.22404 \quad \text{PoissonDen}(5; 0.3) \approx 1.5002 \times 10^{-5}$$

The Poisson distribution can be used to approximate the binomial distribution when the probability is small and $n$ is large; that is,

$$\text{PoissonDist}(k; \mu) \approx \text{BinomialDist}(k; \mu (1 - p))$$

where $\mu = np$. This distribution has been used as a model for a variety of random phenomena of practical importance.

**Hypergeometric Distribution**

Suppose that, from a population of $M$ elements, of which $x$ possess a certain attribute, you draw a sample of $n$ items without replacement. The number of items that possess the certain attribute in such a sample is a hypergeometric variate. The hypergeometric cumulative distribution function is a discrete function defined for nonnegative integers $x$. The hypergeometric distribution with $M$ elements in the population, $K$ successes in the population, and sample size $n$ is defined by the following summation of quotients of binomial coefficients for $0 \leq x \leq n$:

$$\text{HypergeomDist}(x; M, K, n) = \sum_{k=0}^{x} \frac{\binom{K}{k} \binom{M-K}{n-k}}{\binom{M}{n}}$$

For $x < 0$, the distribution function is 0, and for $x \geq n$, the function is 1. The hypergeometric probability density function is

$$\text{HypergeomDen}(k; M, K, n) = \frac{\binom{K}{k} \binom{M-K}{n-k}}{\binom{M}{n}}$$

for integers $k$, $K$, $n$, and $M$ satisfying $0 \leq k \leq n$, $0 \leq K \leq M$, and $0 < n \leq M$.

The hypergeometric distribution is the model for sampling without replacement. The hypergeometric distribution can be approximated by the binomial distribution when the sample size is relatively small.
Random Numbers

Example

What is the probability of at most five successes when you draw a sample of 10 from a population of 100, of which 30 members are identified as successes?

The probability of exactly $x$ successes is given by

$$\text{HypergeomDen}(x; 100, 30, 10).$$

Thus, the probability of at most five successes is the sum of exactly 0, 1, 2, 3, 4, and 5 successes, or

$$\text{HypergeomDist}(5; 100, 30, 10) = 0.96123.$$  

The previous plots (created as polygonal plots) depict the functions

$$\text{HypergeomDen}(x; 100, 30, 10) \text{ and } \text{HypergeomDist}(x; 100, 30, 10)$$

for $0 \leq x \leq 10$.

Random Numbers

The random-number generators on the Statistics submenu give you a set of random numbers from one of several families of distribution functions. The choices in the dialog are Beta, Binomial, Cauchy, Chi-Square, Exponential, F, Gamma, Normal, Poisson, Student’s t, Uniform, and Weibull. Choose Compute > Statistics > Random Numbers.

Choose a distribution from the dialog, specify how many random numbers you want, and enter appropriate parameters. Following are sample results.

**Compute > Statistics > Random Numbers**

- Beta, Order 3, Order 7: 0.31172, 0.28533, 7.8338 × 10⁻², 0.14925, 0.41693
- Binomial, Number of Trials 10, Probability of Success 0.5: 6.2, 6.5, 6
- Cauchy, Median 10, Shape Parameter 5: 13.069, 13.412, 7.5245, −3.8907, 12.29
- Chi-Square, Degrees of Freedom 3: 0.91006, 2.2787, 4.4748, 2.7026, 1.5385
- Exponential, Mean Time Between Arrivals 10: 16.851, 16.865, 8.8222, 32.037, 12.434
- F, Degrees of Freedom 1 and 3: 1.1585 × 10⁻², 1.3279 × 10⁻², 0.18187, 1.5567, 1.8483
- Gamma, Shape Parameter 2, Scale Parameter 5: 4.4875, 7.3945, 10.114, 6.1566, 21.808
- Normal, Mean 3, Standard Deviation 7: 5.223, −4.8075, −5.5782, −1.1218, 1.357
- Poisson, Mean Number of Occurrences 4: 2, 4, 1, 2, 5
Chapter 11 | Statistics

**Compute > Statistics > Random Numbers**

Student’s t, Degrees of Freedom 7: \(-3.6549 \times 10^{-2}, -0.35357, 1.3031, -1.1615, 1.1861\)

Uniform, Lower End of Range 0, Upper End of Range 20: \(5.6016, 16.744, 10.275, 14.057, 10.136\)

Weibull, Shape Parameter 5, Scale Parameter 3: \(2.2615, 3.0731, 3.0868, 3.8504, 2.4592\)

**Curve Fitting**

You have the tools to do general curve fitting in an intuitive manner. Choose Compute > Statistics > Fit Curve to Data and make a choice in the dialog box.

- For straight-line fits, choose Multiple Regression or Multiple Regression (no constant).
- For best fits by polynomials, choose Polynomial of Degree [ ].

**Linear Regression**

Multiple Regression calculates linear-regression equations with *keyed* or labeled data matrices. The result is an equation expressing the variable at the head of the first column as a linear combination of the variables heading the remaining columns, plus a constant (that is missing if Multiple Regression (no constant) was chosen). The equation produced is the best fit to the data in the least-squares sense.

**Compute > Statistics > Fit Curve to Data > Multiple Regression**

(Location of Dependent Variable: First Column)

\[
\begin{bmatrix}
  y & x \\
  0 & 1.1 \\
  0.5 & 1.5 \\
  1 & 1.9 \\
  1.5 & 2.4
\end{bmatrix}
\]

Regression is: \(y = 1.159x - 1.2493\)

**Compute > Statistics > Fit Curve to Data > Multiple Regression**

(Location of Dependent Variable: First Column)

\[
\begin{bmatrix}
  z & x & y \\
  1 & 0 & 1.1 \\
  2 & 0.5 & 1.1 \\
  4 & 1 & 1.9 \\
  5 & 1.5 & 1.9
\end{bmatrix}
\]

Regression is: \(z = 2.0x + 1.25y - 0.375\)
Curve Fitting

The choice Multiple Regression (no constant) gives the following linear equations:

\[
\begin{bmatrix}
u & v \\
0 & 1.1 \\
0.5 & 1.5 \\
1 & 1.9 \\
1.5 & 2.4 \\
2 & 2.9 \\
\end{bmatrix}
\]

Regression is: \( u = 0.56733v \)

\[
\begin{bmatrix}
z & x & y \\
1 & 0 & 1.1 \\
2 & 0.5 & 1.1 \\
4 & 1 & 1.9 \\
5 & 1.5 & 1.9 \\
7 & 2 & 2.9 \\
\end{bmatrix}
\]

Regression is: \( z = 2.1829x + 0.91245y \)

\[
\begin{bmatrix}
x & y \\
a & b \\
c & d \\
\end{bmatrix}
\]

Regression is: \( x = \frac{1.0(ab + cd)}{b^2 + d^2} \)

Polynomial Fit

Polynomial of Degree \([\] \) calculates polynomial equations from labeled or unlabeled two-column data matrices. The result is a polynomial of the specified degree that is the best fit to the data in the least-squares sense. For the polynomial fit, the \( x \) column appears first.

To find the best fit by a polynomial of second degree to the set of points \((0, 0.64), (0.5, 0.09), (1, 0.04), (1.5, 0.49), (2, 1.44)\), remove the parentheses and convert the entries into a two-column matrix. To make this conversion, place the insert point in the list and choose Compute > Matrices > Reshape; then specify two columns.

\[
\begin{bmatrix}
0 & 0.64 \\
0.5 & 0.09 \\
1 & 0.04 \\
1.5 & 0.49 \\
2 & 1.44 \\
\end{bmatrix}
\]
Chapter 11 | Statistics

**Compute > Statistics > Fit Curve to Data**

(Check Polynomial of Degree [ ], type 2, choose OK.)

\[
\begin{pmatrix}
0 & 0.64 \\
0.5 & 0.09 \\
1 & 0.04 \\
1.5 & 0.49 \\
2 & 1.44 \\
\end{pmatrix}, \text{ Polynomial fit: } y = 1.0x^2 - 1.6x + 0.64
\]

You can plot the points and polynomial on the same graph. You will notice that these points were chosen such that they lie on the parabola.

**Compute > Plot 2D > Rectangular**

\[
\begin{pmatrix}
0 & 0.64 \\
0.5 & 0.09 \\
1 & 0.04 \\
1.5 & 0.49 \\
2 & 1.44 \\
\end{pmatrix}
\]

\[64 - 1.6x + 1.0x^2\]

(For Item 1, change Plot Style to Point and Point Marker to Circle.)

(For Item 2, set Plot Intervals to \(0 < x < 2\).)

The Fit Curve to Data command operates on labeled matrices.

**Compute > Statistics > Fit Curve to Data**

(Polynomial of Degree 2)

\[
\begin{pmatrix}
\begin{array}{c|c}
x & y \\
\hline
0 & 6 \\
1 & 0.1 \\
2 & -3 \\
3 & \end{array}
\end{pmatrix}, \text{ Polynomial fit: } y = 6.265 - 9.685x + 2.725x^2
\]

You can also fit data with polynomials of higher degree.
Curve Fitting

**Compute > Statistics > Fit Curve to Data** (Polynomial of Degree 3)

\[
\begin{bmatrix}
0 & 0.64 \\
0.5 & 0.99 \\
1.0 & 8.04 \\
1.5 & 0.49 \\
2.0 & -7.44
\end{bmatrix}
\]

Polynomial fit: \( y = 8.1143 \times 10^{-2} + 1.4114x + 9.1143x^2 - 5.92x^3 \)

Overdetermined Systems of Equations

The Solve command has been extended to handle overdetermined systems, returning the least-squares solution. Here we give an example of an overdetermined system. Note that (as before) the least-squares solution is the actual solution, when an actual solution exists.
Chapter 11 | Statistics

Compute > Solve > Exact

\[
\begin{bmatrix}
1 & 2 \\
3 & 4 \\
5 & 6 \\
7 & 8
\end{bmatrix}
\begin{bmatrix}
x \\
y
\end{bmatrix} =
\begin{bmatrix}
3 \\
7 \\
11 \\
15
\end{bmatrix}, \text{ Solution: } \begin{bmatrix}
1 \\
1
\end{bmatrix}
\]

It is easy to multiply both sides of a matrix equation by \( A^T \) to check that, when you “solve” \( AX = B \), you are actually getting the solution of \( (A^T A) X = A^T B \). Here,

\[
A = \begin{bmatrix}
1 & 2 \\
3 & 4 \\
5 & 6 \\
7 & 8
\end{bmatrix}, \quad X = \begin{bmatrix}
x \\
y
\end{bmatrix}, \quad B = \begin{bmatrix}
3 \\
7 \\
11 \\
15
\end{bmatrix}.
\]

Compute > Evaluate

\[
A^T A = \begin{bmatrix}
84 & 100 \\
100 & 120
\end{bmatrix}
\]

\[
A^T B = \begin{bmatrix}
184 \\
220
\end{bmatrix}
\]

This calculation gives the following equation, which has an exact solution.

Compute > Solve > Exact

\[
\begin{bmatrix}
84 & 100 \\
100 & 120
\end{bmatrix}
\begin{bmatrix}
x \\
y
\end{bmatrix} =
\begin{bmatrix}
184 \\
220
\end{bmatrix}, \text{ Solution: } \begin{bmatrix}
1 \\
1
\end{bmatrix}
\]

Exercises

1. Consider a normal random variable with mean 50 and standard deviation 10, and a random sample of size 80 from which we are to compute the values of \( \bar{X} \), the sample mean. What is the probability of getting a value of \( \bar{X} \) as low as 46?

2. Suppose a working widget deteriorates very little with age. That is, a widget that has been running for some time will have nearly the same failure probability during the following hour as it had during its first hour of operation. Then, the failure times have an exponential distribution \( P(T \leq t) \) of the form \( 1 - e^{-\frac{t}{\theta}} \). Given
that the widget has a mean life of 5 years, what is the probability that the widget will have a lifetime exceeding 7.5 years? If the widget is guaranteed for 2 years, what percentage of such widgets can be expected to need replacement while under warranty?

3. A widget has a mean life of 5 years with a standard deviation of 2 years. Assuming a normal distribution, what is the probability that the widget will have a lifetime exceeding 7.5 years? If the widget is guaranteed for 2 years, what percentage of such widgets can be expected to need replacement while under warranty?

4. The mean of a continuous distribution with probability density function $f(u)$ is the integral $\int_{-\infty}^{\infty} uf(u)du = \mu$ of the product of the variable and the probability density function. The variance is the integral $\int_{-\infty}^{\infty} (u - \mu)^2 f(u)du$. Find the mean and variance for each of the continuous distributions discussed in this chapter.

5. The mean of a discrete distribution with probability density function $f(u)$ is the sum $\sum_{-\infty}^{\infty} uf(u) = \mu$, and the variance is

$$\sum_{-\infty}^{\infty} (u - \mu)^2 f(u) = \sigma^2.$$  

Find the mean and variance for the discrete distributions discussed in this chapter. If the probability density function for a distribution is $f(n) = \left(\frac{1}{2}\right)^n$, what is the mean of the distribution? What is the variance?

6. A die is cast until a 4 appears. What is the probability that it must be cast more than 5 times?

7. A telephone switchboard handles 600 calls on average during a single rush hour. The board can make a maximum of 20 connections per minute. Use the Poisson distribution to evaluate the probability that the board will be overtaxed during any given minute of a rush hour.

8. Find the probability that $x^2 \leq 4$ for a normal distribution with mean 1 and standard deviation 1.
Chapter 11 | Statistics

Solutions

1. To solve this problem, you need to know that the distribution of the mean of a sample of size \( n \) from a normal distribution of mean \( \mu \) and standard deviation \( \sigma \) is normal with mean \( \mu \) and standard deviation \( \frac{\sigma}{\sqrt{n}} \). Thus, the probability is

\[
\Pr(\bar{X} \leq 46) = \text{NormalDist}\left(46; 50, \frac{1}{2}\sqrt{5}\right)
\]

\[
= \text{NormalDist}(46; 50, 1.118) = 1.7324 \times 10^{-4}
\]

2. ExponentialDist(7.5; 5) = 0.77687 = \( P(X \leq 7.5) \), so the probability that \( X \) is greater than 7.5 is \( 1 - 0.78 = 0.22 \).

ExponentialDist(2; 5) = 0.32968 = \( P(X \leq 2) \), so the answer to the second question is "about 33 percent."

3. NormalDist(7.5; 5, 2) = 0.89435 = \( P(X \leq 7.5) \), so the probability that \( X \) is greater than 7.5 is \( 1 - 0.894 = 0.106 \), or 10.6 percent.

NormalDist(2; 5, 2) = 6.6807 \times 10^{-2} = \( P(X \leq 2) \), so the answer to the second question is "about 7 percent."

4. For the normal distribution, Evaluate gives

\[
\int_{-\infty}^{\infty} \text{NormalDen}(u; \mu, \sigma) \, du = \mu
\]

\[
\int_{-\infty}^{\infty} \text{NormalDen}(u; \mu, \sigma)(u - \mu)^2 \, du = \sigma^2
\]

For the Student's t distribution, with five degrees of freedom, Evaluate gives \( \int_{-\infty}^{\infty} u \text{TDen}(u; 5) \, du = 0 \) for the mean and \( \int_{-\infty}^{\infty} u^2 \text{TDen}(u; 5) \, du = \frac{25}{3} \sqrt{5} \) for the variance.

5. Here is a sample solution. For the binomial distribution, Evaluate followed by Simplify gives the mean:

\[
\sum_{x=0}^{\infty} x \binom{n}{x} p^x (1 - p)^{n-x} = np (1 - p)^{n-1} \left(\frac{1}{-1+p}\right)^{n-1} = pn
\]
Exercises

Evaluate followed by Simplify and then Factor gives the variance:

\[ \sum_{x=0}^{n} (x - pn)^2 \binom{n}{x} p^n (1 - p)^{n-x} = pn - p^2 n = (1 - p) pn \]

(The intermediate expression for the variance is complicated and does not appear here. Also, you need to make the simplifications \((-1)^{2n} = 1\) and \((-1)^{2n+1} = -1\). Note that the symbol \(\binom{n}{x}\) is a binomial fraction, rather than a matrix. To enter a binomial fraction, choose Insert > Math Objects > Binomial, and choose None for Line.)

If the probability density function for a distribution is \(f(n) = (\frac{1}{2})^n\) for \(n \geq 0\), the mean of the distribution is \(\sum_{n=1}^{\infty} n \left(\frac{1}{2}\right)^n = 2\) and the variance is \(\sum_{n=1}^{\infty} (n - 2)^2 \left(\frac{1}{2}\right)^n = 2\).

6. The probability of getting a 4 on a single cast is \(\frac{1}{6}\), so the probability of getting a different result is \(\frac{5}{6}\). The probability of casting the die 5 times without getting a 4 is \(\left(\frac{5}{6}\right)^5 = 0.40188\).

7. With 600 calls on average during rush hour, the average number of calls per minute is 10. The probability that the number of connections in a given minute is less than or equal to 20 is the sum \(\sum_{k=0}^{20} \text{PoissonDen}(k, 10) = \sum_{k=0}^{20} \frac{10^k e^{-10}}{k!} = 0.99841\). Thus, the probability that the board will be overtaxed is \(1 - 0.99841 = 0.00159\).

8. \(x^2 \leq 4\) when \(-2 \leq x \leq 2\). So \(\Pr(x^2 \leq 4) = \Pr(x \leq 2) - \Pr(x \leq -2) = \text{NormalDist}(2, 1, 1) - \text{NormalDist}(-2; 1, 1) = 0.84\).
Applied modern algebra provides techniques for sending and receiving confidential messages, for assuring that recordings always sound perfect, and for packing a lot of data into a very small space. This chapter includes an introduction to some of the underlying computational tools that make such applications possible.

Solving Equations

Many techniques in applied modern algebra are designed to solve equations, from integer equations to polynomial equations to matrix equations. In this section, we describe a few of the methods that can be applied to such problems.

Integer Solutions

The solver can be restricted to the domain of integers. Choose Compute > Solve > Integer to find integer roots of polynomial expressions with rational coefficients, and integer solutions to equations of the same type.

To find integer roots or integer solutions to an equation

1. Place the insert point in an expression or equation.

2. Choose Compute > Solve > Integer.
Chapter 12 | Applied Modern Algebra

**Compute > Solve > Integer**

41x + 421x^2 − 165x^3 − 4x^4 + 4x^5 − 105, Solution: \{-7, 3, 5\}

2x^2 − 11x + 15 = 3x^2 − 16x + 21, Solution: \{2, 3\}

**Continued Fractions**

A *simple continued fraction* is an expression of the form

\[
a_0 + \frac{1}{a_1 + \frac{1}{a_2 + \frac{1}{a_3 + \frac{1}{\ldots}}}}
\]

where \(a_0\) is an integer and \(a_1, a_2, \ldots\) are positive integers. There can be either an infinite or a finite number of terms \(a_i\). A number is rational if and only if it can be expressed as a simple finite continued fraction. You can find rational approximations to irrational numbers by expanding the irrational as a simple continued fraction, then truncating the continued fraction to obtain a rational.

Continued fractions have been utilized within computer algorithms for computing rational approximations to real numbers, as well as solving indeterminate equations. Connections have been established between continued fractions and chaos theory.

Use the MuPAD command `numlib::contfrac` to construct a continued fraction of the real numerical expression \(x\) to \(n\) significant digits.

**To define a continued fractions command**

1. Choose Compute > Definitions > Define MuPAD Name.
2. In the MuPAD Name box, type `numlib::contfrac(x,n)`.
3. In the *Scientific WorkPlace (Notebook)* Name box, type `r(x;n)`.
4. Check “That is built in to MuPAD or is automatically loaded” and choose OK.

Use the continued fractions command to generate continued fractions.

**Compute > Evaluate**

\[
r(\pi, 10) = 3 + \frac{1}{7 + \frac{1}{15 + \frac{1}{1 + \frac{1}{292 + \frac{1}{1 + \frac{1}{1 + \ldots}}}}}}
\]

The two dots at the bottom indicate an infinite continued fraction. However, you can easily truncate the continued fraction.
To find a good rational approximation to $\pi$

1. Select the tail $\frac{1}{292} + \frac{1}{1}$ of the continued fraction and delete it.

2. Evaluate the remaining finite continued fraction.

\[
3 + \frac{1}{7 + \frac{1}{157 + \frac{1}{2}}} \approx 3.1416
\]

Recursive Solutions

Recursion finds solutions to a recursion or a system of recursions.

To solve a recursion or a system of recursions

- Place the insert point in a recursive equation, or in a system of recursive equations entered in a column matrix or display, and choose Compute $\triangleright$ Solve $\triangleright$ Recursion.

\[
y(n+2) + 3y(n+1) + 2y(n) = 0, \text{ Solution: } \{y(n) = (-1)^n C_1 + (-2)^n C_2\}
\]

You can also solve recursive equations written in sequence notation.

\[
x_n + 2x_{n+1} + x_{n+2} = 0, \text{ Solution: } \{x_n = (-1)^n (C_3 + C_2 n)\}
\]

\[
x_n + 3x_{n+1} + x_{n+2} = 0, \text{ Solution: } \{x_n = C_3 \left( -\frac{3}{2} \sqrt{5} - \frac{1}{2} \right)^n + C_4 \left( \frac{1}{2} \sqrt{5} - \frac{3}{2} \right)^n\}
\]

You can specify initial conditions by listing a system of equations in a column matrix.

\[
y_{n+2} + 3y_{n+1} + 2y_n = 0, \text{ Solution: } y_n = (-2)^n - 3 (-1)^n
\]

This closed-form solution makes it easy to find specific terms. For example, if you define $y(n) = (-2)^n - 3 (-1)^n$, then $y(n)$ can be directly evaluated.

\[
y(20) = 1048573
\]

Fibonacci Numbers

The Fibonacci numbers are defined by

\[
F_0 = 0, \quad F_1 = 1, \quad F_n = F_{n-1} + F_{n-2}
\]
Chapter 12 | Applied Modern Algebra

Integers Modulo m

The Euclidean algorithm for integers leads to the notion of congruence of two integers modulo a given integer.

Two integers \( a \) and \( b \) are congruent modulo \( m \) if and only if \( a - b \) is a multiple of \( m \), in which case we write \( a \equiv b \pmod{m} \). Thus, \( 15 \equiv 33 \pmod{9} \), because \( 15 - 33 = -18 \) is a multiple of \( 9 \). Given integers \( a \) and \( m \), the mod function is given by \( a \mod{m} = b \) if and only if \( a \equiv b \pmod{m} \) and \( 0 \leq b \leq m - 1 \); hence, \( a \mod{m} \) is the smallest nonnegative residue of \( a \) modulo \( m \).

The underlying computer algebra system does not understand the congruence notation \( a \equiv b \pmod{m} \), but it does understand the function notation \( a \mod{m} \). This section shows how to translate problems in algebra and number theory into language that will be handled correctly by the computational engine.

Traditionally the congruence notation \( a \equiv b \pmod{m} \) is written with the \( \mod{m} \) enclosed inside parentheses since the \( \mod{m} \) clarifies the expression \( a \equiv b \). In this context, the expression \( b \pmod{m} \) never appears without the preceding \( a \equiv \). On the other hand, the mod function is usually written in the form \( a \mod{m} \) without parentheses.

To evaluate the mod function

- Place the insert point in the expression \( a \mod{b} \) and choose Compute > Evaluate.

\[
\text{Compute > Evaluate}
\]

\[
23 \mod{14} = 9
\]

In terms of the \textit{floor} function \( \lfloor x \rfloor \), the mod function is given by

\[
a \mod{m} = a - \lfloor a/m \rfloor \times m
\]

\[
\text{Compute > Evaluate}
\]

\[
23 - \left\lfloor \frac{23}{14} \right\rfloor \times 14 = 9
\]

Multiplication Tables Modulo m

You can make tables that display the products modulo \( m \) of pairs of integers from the set \( \{0, 1, 2, \ldots, m - 1\} \).

To get a multiplication table modulo \( m \) with \( m = 6 \)

1. Type the equation \( g(i, j) = (i - 1)(j - 1) \) and choose Compute > Definitions > New Definition.
2. Choose Compute > Matrices > Fill Matrix
3. Select Defined by Function.
4. Type g in the Enter Function Name box.
5. Select 6 rows and 6 columns and choose OK.
6. Type mod 6 at the right of the matrix.
7. Choose Compute > Evaluate.

```
\begin{array}{cccccc}
0 & 0 & 0 & 0 & 0 & 0 \\
0 & 1 & 2 & 3 & 4 & 5 \\
0 & 2 & 4 & 6 & 8 & 10 \\
0 & 3 & 6 & 9 & 12 & 15 \\
0 & 4 & 8 & 12 & 16 & 20 \\
0 & 5 & 10 & 15 & 20 & 25 \\
\end{array}
\mod 6 =
\begin{array}{cccccc}
0 & 0 & 0 & 0 & 0 & 0 \\
0 & 1 & 2 & 3 & 4 & 5 \\
0 & 2 & 4 & 0 & 2 & 4 \\
0 & 3 & 0 & 3 & 0 & 3 \\
0 & 4 & 0 & 4 & 0 & 4 \\
0 & 5 & 4 & 3 & 2 & 1 \\
\end{array}
```

A more efficient way to generate the same multiplication is to define \( g(i, j) = (i - 1)(j - 1) \mod 6 \) and follow steps 2–6 above.

You can also find the multiplication table \( \mod m \) as the product of a column matrix with a row matrix.

```
\begin{array}{c}
0 \\
1 \\
2 \\
3 \\
4 \\
5 \\
\end{array}
\times
\begin{array}{cccccc}
0 & 1 & 2 & 3 & 4 & 5 \\
0 & 0 & 0 & 0 & 0 & 0 \\
0 & 1 & 2 & 3 & 4 & 5 \\
0 & 2 & 4 & 0 & 2 & 4 \\
0 & 3 & 0 & 3 & 0 & 3 \\
0 & 4 & 2 & 0 & 4 & 2 \\
0 & 5 & 4 & 3 & 2 & 1 \\
\end{array}
\mod 6 =
\begin{array}{cccccc}
0 & 0 & 0 & 0 & 0 & 0 \\
0 & 1 & 2 & 3 & 4 & 5 \\
0 & 2 & 4 & 0 & 2 & 4 \\
0 & 3 & 0 & 3 & 0 & 3 \\
0 & 4 & 2 & 0 & 4 & 2 \\
0 & 5 & 4 & 3 & 2 & 1 \\
\end{array}
```

Make a copy of this last matrix. Add a new row at the top (position 1) and add a new column at the left (position 1); fill in the blanks and change the new row and column to Bold font, to get the following multiplication table modulo 6:

```
\begin{array}{cccccc}
\times & 0 & 1 & 2 & 3 & 4 & 5 \\
0 & 0 & 0 & 0 & 0 & 0 & 0 \\
1 & 0 & 1 & 2 & 3 & 4 & 5 \\
2 & 0 & 2 & 4 & 0 & 2 & 4 \\
3 & 0 & 3 & 0 & 3 & 0 & 3 \\
4 & 0 & 4 & 2 & 0 & 4 & 2 \\
5 & 0 & 5 & 4 & 3 & 2 & 1 \\
\end{array}
```

**Tip**

A shortcut that creates the multiplication table \( \mod 6 \) in essentially one step is to define

\[
g(i, j) = |i - 2| |j - 2| \mod 6
\]

and use Compute > Matrices > Fill Matrix and the function \( g \) to create a \( 7 \times 7 \) matrix.
Chapter 12 | Applied Modern Algebra

From the table, we see that $2 \cdot 4 \mod 6 = 2$ and $3 \cdot 3 \mod 6 = 3$.

You can generate an addition table by defining $g(i, j) = i + j - 2 \mod 6$.

Example If $p$ is a prime, then the integers modulo $p$ form a field, called a Galois field and denoted $GF(p)$. For the prime $p = 7$, you can generate the multiplication table by defining $g(i, j) = (i - 1)(j - 1) \mod 7$ and choosing Compute > Matrices > Fill Matrix, then selecting Defined by function from the dialog box. You can generate the addition table in a similar manner using the function $f(i, j) = i + j - 2 \mod 7$.

<table>
<thead>
<tr>
<th></th>
<th>0</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
<td>0</td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
<td>0</td>
<td>1</td>
<td>2</td>
</tr>
<tr>
<td>4</td>
<td>4</td>
<td>5</td>
<td>6</td>
<td>0</td>
<td>1</td>
<td>2</td>
<td>3</td>
</tr>
<tr>
<td>5</td>
<td>5</td>
<td>6</td>
<td>0</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
</tr>
<tr>
<td>6</td>
<td>6</td>
<td>0</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
</tr>
</tbody>
</table>

Inverses Modulo $m$

If $ab \mod m = 1$, then $b$ is called an inverse of $a$ modulo $m$, and we write $a^{-1} \mod m$ for the least positive residue of $b$. The computation engine also recognizes both of the forms $1/a \mod m$ and $\frac{1}{a} \mod m$ for the inverse modulo $m$.

To compute the inverse of an integer modulo $m$

1. Type the inverse in standard notation.

2. Choose Compute > Evaluate.

The three notations $ab^{-1} \mod m$, $a/b \mod m$, and $a^{-1} \mod m$ are all interpreted as $a(b^{-1} \mod m) \mod m$; that is, first find the inverse of $b$ modulo $m$, multiply the result by $a$, and then reduce the product modulo $m$.

Note

The inverse of $5^{-1} \mod 7$ exists if and only if $5$ is relatively prime to $7$; that is, it exists if and only if $\gcd(5, 7) = 1$. Thus, modulo $6$, only $1$ and $5$ have inverses. Modulo any prime, every nonzero residue has an inverse. In terms of the multiplication table modulo $m$, the integer $a$ has an inverse modulo $m$ if and only if $1$ appears in row $a \mod m$ (and $1$ appears in column $a \mod m$).

Note

The inverse of $5^{-1} \mod 7$ is indeed $3$ because $5 \cdot 3 \mod 7 = 1$. 450
Integers Modulo \( m \)

Compute > Evaluate

\[ 3/23 \mod 257 = 56 \]

Solving congruences Modulo \( m \)

To solve a congruence of the form \( ax \equiv b \pmod{m} \)

- Multiply both sides by \( a^{-1} \mod m \) to get \( x \equiv b/a \mod m \).

The congruence \( 17x \equiv 23 \pmod{127} \) has a solution \( x = 91 \), as the following two evaluations illustrate.

Additional Solutions

Note that, since 91 is a solution to the congruence \( 17x \equiv 23 \pmod{127} \), additional solutions are given by \( 91 + 127n \), where \( n \) is any integer. In fact, \( x \equiv 91 \pmod{127} \) is just another way of writing \( x = 91 + 127n \) for some integer \( n \).

Pairs of Linear Congruences

Since linear congruences of the form \( ax \equiv b \pmod{m} \) can be reduced to simple congruences of the form \( x \equiv c \pmod{m} \), we consider systems of congruences in this latter form.

To solve a pair of linear congruences

- Reduce the problem to a single congruence.

Example

Consider the system of two congruences

\[
\begin{align*}
    x & \equiv 45 \pmod{237} \\
    x & \equiv 19 \pmod{419}
\end{align*}
\]

Checking, \( \gcd(237, 419) = 1 \), so 237 and 419 are relatively prime. The first congruence can be rewritten in the form \( x = 45 + 237k \) for some integer \( k \). Substituting this value into the second congruence, we see that

\[
45 + 237k = 19 + 419r
\]

for some integer \( r \). This last equation can be rewritten in the form \( 237k = 19 - 45 \mod 419 \), which has the solution

\[
k = (19 - 45)/237 \mod 419 = 60
\]

Hence,

\[
x = 45 + 237 \cdot 60 = 14265
\]
Chapter 12 | Applied Modern Algebra

Checking, \(14265 \mod 237 = 45\) and \(14265 \mod 419 = 19\). The complete set of solutions is given by

\[ x = 14265 + 237 \cdot 419s \equiv 14265 \pmod{99303} \]

Thus, the original pair of congruences has been reduced to a single congruence,

\[ x \equiv 14265 \pmod{99303} \]

In general, if \(m\) and \(n\) are relatively prime, then one solution to the pair

\[ \begin{align*}
  x & \equiv a \pmod{m} \\
  x & \equiv b \pmod{n}
\end{align*} \]

is given by

\[ x = a + m \left\lfloor \frac{(b - a)}{m} \pmod{n} \right\rfloor \]

A complete set of solutions is given by

\[ x = a + m \left\lfloor \frac{(b - a)}{m} \pmod{n} \right\rfloor + rmn \]

where \(r\) is an arbitrary integer.

**Systems of Linear Congruences**

You can reduce systems of any number of congruences to a single congruence by solving systems of congruences two at a time. The Chinese remainder theorem states that, if the moduli are relatively prime in pairs, then there is a unique solution modulo the product of all the moduli.

**To solve a system of congruences**

- Reduce the system to a single congruence.

**Example**

Consider the system of three linear congruences

\[ \begin{align*}
  x & \equiv 45 \pmod{237} \\
  x & \equiv 19 \pmod{419} \\
  x & \equiv 57 \pmod{523}
\end{align*} \]

Checking, \(\gcd(237 \cdot 419, 523) = 1\) and \(\gcd(237, 419) = 1\); hence this system has a solution. The first two congruences can be replaced
by the single congruence \( x \equiv 14265 \pmod{99303} \); hence the three
congruences can be replaced by the pair

\[
\begin{align*}
x & \equiv 14265 \pmod{99303} \\
x & \equiv 57 \pmod{523}
\end{align*}
\]

As before, \( 14265 + 99303k = 57 + 523r \) for some integers \( k \) and \( r \).
Thus, \( k = (57 - 14265)/99303 \pmod{523} = 134; \) hence \( x = 14265 + 99303 \cdot 134 = 13320867 \). This system of three congruences can thus
be reduced to the single congruence

\[ x \equiv 13320867 \pmod{51935469} \]

### Powers Modulo \( m \)

To calculate large powers modulo \( m \)

- Evaluate \( a^p \pmod{m} \).

#### Compute > Definitions > New Definition

\[
a = 2789596378267275 \\
n = 3848590389047349 \\
m = 2838490563537459
\]

#### Compute > Evaluate

\[ a^n \pmod{m} = 262201814109828 \]

Fermat’s Little Theorem states that, if \( p \) is prime and \( 0 < a < p \),
then

\[ a^{p-1} \pmod{p} = 1 \]

The integer 1009 is prime, and the following is no surprise.

#### Compute > Evaluate

\[ 2^{1008} \pmod{1009} = 1 \]

### Generating Large Primes

There is not a built-in function to generate large primes, but the
underlying computational system does have such a function. The fol-
lowing is an example of how to define functions that correspond to
existing functions in the underlying computational system.

In this example, \( p(x) \) is defined as the \textit{Scientific WorkPlace (Note-
book) Name} for the MuPAD function, \texttt{nextprime(x)}, which generates the
next prime greater than or equal to \( x \).
Chapter 12 | Applied Modern Algebra

To define \( p(x) \)
1. Choose Compute > Definitions > Define MuPAD Name.
2. Type `nextprime(x)` as the MuPAD Name.
3. Type \( p(x) \) as the Scientific WorkPlace (Notebook) Name.
4. Under The MuPAD Name is a Procedure, check That is Built In to MuPAD or is Automatically Loaded.
5. Choose OK.

Test the function using Evaluate.

\[
\text{Compute > Evaluate}
\]

\[
p(5) = 5
\]
\[
p(500) = 503
\]
\[
p(8290) = 8291
\]
\[
p(593756145682465582) = 593756145682465583
\]

Other Systems Modulo \( m \)

The mod function also works with matrices and with polynomials.

Matrices Modulo \( m \)

You can reduce the entries of an integer matrix modulo \( m \).

To reduce a matrix \( A \) modulo \( m \)
1. Type the expression \( A \mod m \).
2. Choose Compute > Evaluate.

\[
\text{Compute > Evaluate}
\]

\[
\begin{pmatrix} 5 & 8 \\ 9 & 4 \end{pmatrix} \mod 3 = \begin{pmatrix} 2 & 2 \\ 0 & 1 \end{pmatrix}
\]

\[
\begin{pmatrix} 3 & 7 & 5 \\ 5 & 4 & 8 \\ 2 & 0 & 5 \end{pmatrix}^{-1} \mod 11 = \begin{pmatrix} 9 & 9 & 3 \\ 2 & 5 & 1 \\ 3 & 3 & 10 \end{pmatrix}
\]

\[
\begin{pmatrix} 3 & 7 & 5 \\ 5 & 4 & 8 \\ 2 & 0 & 5 \end{pmatrix} \begin{pmatrix} 9 & 9 & 3 \\ 2 & 5 & 1 \\ 3 & 3 & 10 \end{pmatrix} \mod 11 = \begin{pmatrix} 1 & 0 & 0 \\ 0 & 1 & 0 \\ 0 & 0 & 1 \end{pmatrix}
\]

Note

Evaluating a matrix modulo \( m \) reduces each of the entries of the matrix modulo \( m \).
Other Systems Modulo m

Example  A $2 \times 2$ block cipher is given by
\[
\begin{bmatrix} y_1 \\ y_2 \end{bmatrix} = \begin{bmatrix} a_{11} & a_{12} \\ a_{21} & a_{22} \end{bmatrix} \begin{bmatrix} x_1 \\ x_2 \end{bmatrix} \mod 26
\]
where the $x_i$'s represent plaintext, the $y_i$'s represent ciphertext, and the matrix entries are integers. For example,
\[
\begin{bmatrix} 5 \\ 2 \end{bmatrix} \begin{bmatrix} 4 \\ 11 \end{bmatrix} \mod 26 = \begin{bmatrix} 4 \\ 7 \end{bmatrix}
\]
means that the plaintext pair $\{E, L\}$ (two adjacent letters in the secret message “Elroy was here”) gets mapped to the ciphertext pair $\{E, H\}$, using the correspondence $A \leftrightarrow 0, B \leftrightarrow 1, C \leftrightarrow 2, \ldots, Z \leftrightarrow 25$.

Given the ciphertext, you can recover the plaintext by computing the inverse of the two-by-two matrix modulo 26. For example,
\[
\begin{bmatrix} 5 & 8 \\ 2 & 7 \end{bmatrix}^{-1} \mod 26 = \begin{bmatrix} 25 & 16 \\ 4 & 3 \end{bmatrix}
\]
and hence
\[
\begin{bmatrix} 25 & 16 \\ 4 & 3 \end{bmatrix} \begin{bmatrix} 4 \\ 7 \end{bmatrix} \mod 26 = \begin{bmatrix} 4 \\ 11 \end{bmatrix}
\]
recovers the original plaintext. You can handle longer messages by replacing the column vector $\begin{bmatrix} E \\ L \end{bmatrix}$ by the matrix $\begin{bmatrix} E & R & Y & A & H & R \\ L & O & W & S & E & S \end{bmatrix}$ and calculating one matrix product
\[
\begin{bmatrix} 25 \\ 4 \\ 3 \end{bmatrix} \begin{bmatrix} 4 & 17 & 24 & 0 & 7 & 17 \\ 11 & 14 & 22 & 18 & 4 & 4 \end{bmatrix} \mod 26 = \begin{bmatrix} 16 & 25 & 16 & 2 & 5 & 21 \\ 23 & 6 & 6 & 2 & 14 & 2 \end{bmatrix}.
\]

Polynomials Modulo $m$

The mod function can also be combined with polynomials to reduce each of the coefficients modulo $m$.

To reduce integer polynomial coefficients modulo $m$

- Type `mod m` immediately to the right of the polynomial and choose Compute > Evaluate.

$$x^5 + 9x^4 - x^3 + 7x - 2 \mod 5 = x^5 + 4x^4 + 4x^3 + 2x + 3$$

Given a prime $p$, the set of polynomials with coefficients reduced modulo $p$ is a ring, denoted by $GF_p[x]$. 

Note

Evaluating a polynomial modulo $m$ reduces each of the coefficients in the polynomial modulo $m$. 

455
Chapter 12 | Applied Modern Algebra

To calculate the product of polynomials $a(x)$ and $b(x)$ in $GF_p[x]$

1. Expand the product $a(x)b(x)$.

2. Reduce the product modulo $p$.

To calculate the product of $4x^5 + 5x + 3$ and $6x^4 + x^3 + 3$ in $GF_7[x]$, do the following two operations.

Compute \( \times \) Expand

\[
(4x^5 + 5x + 3)(6x^4 + x^3 + 3) = 24x^9 + 4x^8 + 42x^5 + 23x^4 + 3x^3 + 15x + 9
\]

Compute \( \times \) Evaluate

\[
24x^9 + 4x^8 + 42x^5 + 23x^4 + 3x^3 + 15x + 9 \mod 7 = 3x^9 + 4x^8 + 2x^4 + 3x^3 + x + 2
\]

The sum of $4x^5 + 5x + 3$ and $6x^4 + x^3 + 3$ in $GF_7[x]$ is slightly simpler.

Compute \( \times \) Evaluate

\[
(4x^5 + 5x + 3) + (6x^4 + x^3 + 3) \mod 7 = 4x^5 + 6x^4 + x^3 + 5x + 6
\]

To factor a polynomial $a(x)$ in $GF_p[x]$

1. Type the expression $a(x) \mod p$.

2. Choose Compute \( \triangleright \) Factor.

To factor $x^{16} + x$ in $GF_2[x]$, apply the command Factor to the expression $x^{16} + x \mod 2$.

Compute \( \triangleright \) Factor

\[
x^{16} + x \mod 2 = x(x + 1)(x^2 + x + 1)(x^4 + x^3 + 1)(x^4 + x^3 + x^2 + x + 1)
\]

Polynomials Modulo Polynomials

The Euclidean algorithm for polynomials leads to the notion of congruence of polynomials modulo polynomials.

Two polynomials $f(x)$ and $g(x)$ are congruent modulo a polynomial $q(x)$ if and only if $f(x) - g(x)$ is a multiple of $q(x)$, in which case we write

\[
f(x) \equiv g(x) \pmod{q(x)}
\]

We write

\[
g(x) \mod q(x) = h(x)
\]
if \( h(x) \) is a polynomial of minimal degree that is congruent to \( g(x) \) modulo \( q(x) \).

**To reduce a polynomial** \( p(x) \)** modulo a polynomial** \( q(x) \)
- Place the insert point in the expression \( p(x) \mod (q(x)) \) and choose Compute > Evaluate.

\[
x^4 + x + 1 \mod (x^2 + 4x + 5) = -23x - 54
\]

To verify this calculation, note the following computation:

\[
\frac{x^4 + x + 1}{x^2 + 4x + 5} = x^2 - 4x + 11 + \frac{-23x - 54}{x^2 + 4x + 5}
\]

This result implies that indeed \( x^4 + x + 1 \mod (x^2 + 4x + 5) = -23x - 54 \).

**Greatest Common Divisor of Polynomials**

The greatest common divisor of two polynomials \( p(x) \) and \( q(x) \) is a polynomial \( d(x) \) of highest degree that divides both \( p(x) \) and \( q(x) \).

**To compute the greatest common divisor of two polynomials** \( p(x) \)** and** \( q(x) \)**

1. Type \( \text{gcd} \) in mathematics. (It will automatically turn gray.)
2. Place the insert point in the expression \( \text{gcd}(p(x), q(x)) \) and choose Compute > Evaluate.

\[
\text{gcd} (p(x), q(x)) = 3x^3 + x + 4
\]

Use the following procedure to verify that \( 3x^3 + x + 4 \) is indeed a common divisor.

\[
\frac{p(x)}{3x^3 + x + 4} = 6x^4 - 5x^2 + 4x + 3
\]

\[
\frac{q(x)}{3x^3 + x + 4} = 5x^2 - 3x + 2
\]
These results demonstrate that
\[ p(x) = (6x^4 - 5x^2 + 4x + 3)(3x^3 + x + 4) \]
and
\[ q(x) = (5x^2 - 3x + 2)(3x^3 + x + 4) \]

**Multiplicity of Roots of Polynomials**

A root \( a \) of a polynomial \( f(x) \) has *multiplicity* \( k \) if \( f(x) = (x - a)^k g(x) \), where \( g(a) \neq 0 \). If \( k > 1 \), then
\[ f'(x) = k(x-a)^{k-1}g(x) + (x-a)^k g'(x) = (x-a)^{k-1}(kg(x) + (x-a)g'(x)) \]
and hence
\[ \gcd(f(x), f'(x)) = (x-a)^{k-1}h(x) \neq 1 \]

This observation provides a test for multiple roots: If \( \gcd(f(x), f'(x)) \) is a constant, then \( f(x) \) has no multiple roots; otherwise, \( f(x) \) has at least one multiple root—in fact, each root of \( \gcd(f(x), f'(x)) \) is a multiple root of \( f(x) \).

**To test a polynomial \( f(x) \) for multiple roots**

1. Define the polynomial \( f(x) \).
2. Type the expression \( \gcd(f(x), f'(x)) \) and, with the insert point in this expression, choose Compute > Evaluate.
3. Observe whether or not the result is a constant.

The graphs of
\[ f(x) = 5537x^5 - 34804x^4 + 60229x^3 - 29267x^2 + 19888x + 54692 \]
and
\[ g(x) = 5537x^5 - 34797x^4 + 60207x^3 - 29260x^2 + 19873x + 54670 \]
appear indistinguishable. Both appear to have a root near 3.1.
Polynomials Modulo Polynomials

However, the test for multiple roots gives a different result for the two functions.

\[ \text{Compute} > \text{Evaluate} \]
\[ \gcd(f(x), f'(x)) = 791 \left(x - \frac{22}{7}\right) \quad \gcd(g(x), g'(x)) = 7 \]

Thus, \( x = \frac{22}{7} \) is a root of \( f(x) \) of multiplicity at least two, whereas \( g(x) \) has no multiple roots. Solving \( f(x) = 0 \) and \( g(x) = 0 \), the real solutions are computed below. We show both symbolic exact and numeric solutions.

\[ \text{Compute} > \text{Factor} \]
\[ f(x) = 113 (x^3 + x + 1) (7x - 22)^2 \]
\[ g(x) = 7(7x - 22) (113x - 355) (x^3 + x + 1) \]

To find an approximation to the roots of these two polynomials with multiplicities, choose Compute > Polynomials > Roots.

\[ \text{Compute} > \text{Polynomials} > \text{Roots} \]
\[ f(x), \text{roots:} \begin{bmatrix} -0.68233 \\ 3.1429 \\ 0.34116 - 1.1615i \\ 0.34116 + 1.1615i \end{bmatrix} \]
\[ g(x), \text{roots:} \begin{bmatrix} -0.68233 \\ 3.1416 \\ 0.34116 - 1.1615i \end{bmatrix} \]

The polynomial \( g \) has two distinct roots that are extremely close, whereas \( f \) has a root of multiplicity two at \( \frac{22}{7} \approx 3.1429 \).

The Galois Field \( GF_{p^n} \)

Assume that \( q(x) \) is an irreducible polynomial of degree \( n \) over \( GF_p \); that is, assume that \( q(x) \) is of degree \( n \) and, whenever \( q(x) = 0 \),
Chapter 12 | Applied Modern Algebra

\( a(x)b(x) \) for some \( a(x) \) and \( b(x) \) in \( GF_p[x] \), either \( \text{deg}(a(x)) = 0 \) or \( \text{deg}(b(x)) = 0 \).

Given two polynomials \( f(x) \) and \( g(x) \) in \( GF_p[x] \), define the product to be the polynomial \( (f(x)g(x) \mod q(x)) \mod p \) and the sum to be the polynomial \( (f(x) + g(x)) \mod p \).

With these definitions, the set of polynomials in \( GF_p[x] \) of degree less than \( n \) forms a field called the Galois field \( GF_{p^n} \).

The set of polynomials in \( GF_2[x] \) of degree less than 2 forms the field \( GF_4 = GF_2^2 \).

The multiplication and addition tables for \( GF_2 \) are given by

\[
\begin{array}{c|cc}
\times & 0 & 1 \\
0 & 0 & 0 \\
1 & 0 & 1 \\
\end{array}
\quad
\begin{array}{c|cc}
+ & 0 & 1 \\
0 & 0 & 1 \\
1 & 1 & 0 \\
\end{array}
\]

The polynomial \( q(x) = x^2 + x + 1 \) is an irreducible polynomial of degree 2 over \( GF_2 \). It is, in fact, the only one. The elements of \( GF_4 \) are 0, 1, \( x \), and \( 1 + x \).

To find the product \( x \cdot x \) in \( GF_4 \), reduce the product modulo \( x^2 + x + 1 \), then reduce the result modulo 2.

**Compute > Evaluate**

\[(x^2 \mod q(x)) \mod 2 = x + 1\]

Thus, \( x^2 = x + 1 \) in \( GF_4 \).

You can generate the entire multiplication table efficiently using matrix and modular arithmetic.
Compute > Evaluate

$$\begin{bmatrix} 0 & 0 & 0 & 0 \\ 0 & 1 & x & x+1 \\ 0 & x & x^2 & x(x+1) \\ 0 & x+1 & x(x+1) & (x+1)^2 \end{bmatrix} \mod x^2 + x + 1 = \begin{bmatrix} 0 & 0 & 0 & 0 \\ 0 & 1 & x & x+1 \\ 0 & x & -x - 1 & -1 \\ 0 & x+1 & -1 & x \end{bmatrix}$$

$$\begin{bmatrix} 0 & 0 & 0 & 0 \\ 0 & 1 & x & x+1 \\ 0 & x & -x - 1 & -1 \\ 0 & x+1 & -1 & x \end{bmatrix} \mod 2 = \begin{bmatrix} 0 & 0 & 0 & 0 \\ 0 & 1 & x & x+1 \\ 0 & x & x+1 & 1 \\ 0 & x+1 & 1 & x \end{bmatrix}$$

Sums require only reduction of polynomial sums modulo 2. The multiplication and addition tables are given by

<table>
<thead>
<tr>
<th>×</th>
<th>0</th>
<th>1</th>
<th>x</th>
<th>x+1</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
<td>x</td>
<td>x+1</td>
</tr>
<tr>
<td>x</td>
<td>0</td>
<td>x</td>
<td>x+1</td>
<td>1</td>
</tr>
<tr>
<td>x+1</td>
<td>0</td>
<td>x+1</td>
<td>1</td>
<td>x</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>+</th>
<th>0</th>
<th>1</th>
<th>x</th>
<th>x+1</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>1</td>
<td>x</td>
<td>x+1</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
<td>1</td>
<td>0</td>
<td>x</td>
</tr>
<tr>
<td>0</td>
<td>x</td>
<td>x+1</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>x</td>
<td>x+1</td>
<td>x</td>
<td>1</td>
<td></td>
</tr>
</tbody>
</table>

Converting from binary to decimal, we have 0 = (00)_2, 1 = (01)_2, 2 = (10)_2, and 3 = (11)_2. Using this shorthand notation for polynomials, the multiplication and addition tables become

<table>
<thead>
<tr>
<th>×</th>
<th>0</th>
<th>1</th>
<th>2</th>
<th>3</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>2</td>
<td>3</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>0</td>
<td>3</td>
<td>1</td>
<td>2</td>
</tr>
<tr>
<td>3</td>
<td>0</td>
<td>1</td>
<td>2</td>
<td>3</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>+</th>
<th>0</th>
<th>1</th>
<th>2</th>
<th>3</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>1</td>
<td>2</td>
<td>3</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>0</td>
<td>3</td>
<td>2</td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>3</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>3</td>
<td>2</td>
<td>1</td>
<td>0</td>
</tr>
</tbody>
</table>

Calculations in larger finite Galois fields can be done without generating addition and multiplication tables. In the following few paragraphs, assume that β is a root of the irreducible polynomial q(x) of
degree \( n \) used to generate \( GF_{p^n} \). Since every element of \( GF_{p^n} \) satisfies the polynomial \( x^{p^n} - x \) modulo \( p \), it follows that every nonzero element \( u \) of \( GF_{p^n} \) satisfies the polynomial \( x^{p^n-1} - 1 \) modulo \( p \), and hence the inverse of \( u \) is given by \( u^{p^n-2} \).

Let \( q(x) = x^4 + x + 1 \) and let \( \beta \) be a root of \( q(x) \), so that \( \beta^4 + \beta + 1 = 0 \). To calculate the inverse of \( \beta^3 + \beta^2 + 1 \) in \( GF_{2^4} \), carry out the following steps:

Compute > Evaluate
\[
\left( \left( \beta^3 + \beta^2 + 1 \right)^{14} \mod \beta^4 + \beta + 1 \right) \mod 2 = \beta^2
\]

To calculate the product of two elements \( u \) and \( v \) in \( GF_{p^n} \):

1. Expand the product \( uv \).
2. Evaluate the result modulo \( q(\beta) \).
3. Evaluate the result modulo \( p \).

Let \( q(x) = x^4 + x + 1 \) and let \( \beta \) be a root of \( q(x) \), so that \( \beta^4 + \beta + 1 = 0 \). To calculate the product of \( u = \beta^3 + \beta^2 + 1 \) and \( v = \beta^2 \) in \( GF_{2^4} \), carry out the following steps.

Compute > Expand
\[
(\beta^3 + \beta^2 + 1)(\beta^3 + \beta) = \beta^6 + \beta^5 + \beta^4 + 2\beta^3 + \beta
\]

Compute > Evaluate
\[
\beta^6 + \beta^5 + \beta^4 + 2\beta^3 + \beta \mod \beta^4 + \beta + 1 = \beta^3 - 2\beta^2 - \beta - 1
\]
\[
\beta^3 - 2\beta^2 - \beta - 1 \mod 2 = \beta^3 + \beta + 1
\]

Thus \( (\beta^3 + \beta^2 + 1)(\beta^3 + \beta) = \beta^3 + \beta + 1 \) in \( GF_{2^4} \).

These steps can also be combined.

Compute > Evaluate
\[
\left( \left( \beta^3 + \beta^2 + 1 \right)(\beta^3 + \beta) \mod \beta^4 + \beta + 1 \right) \mod 2 = \beta^3 + \beta + 1
\]

To calculate the inverse of an element \( u \) in \( GF_{p^n} \):

- Evaluate the expression \( (u^{p^n-2} \mod q(\beta)) \mod p \).

Compute > Evaluate
\[
\left( \left( \beta^3 + \beta^2 + 1 \right)^{14} \mod \beta^4 + \beta + 1 \right) \mod 2 = \beta^2
\]
\[
\left( \left( \beta^3 + \beta^2 + 1 \right) \beta^2 \mod \beta^4 + \beta + 1 \right) \mod 2 = 1
\]
This verifies that $\beta^2$ is the inverse of $\beta^3 + \beta^2 + 1$ in $\mathbb{GF}_2$.

**Example** This setting provides the basis for the Bose-Chaudhuri-Hocquenghem (BCH) Codes. Given the message word $(a_r, a_{r-1}, \ldots, a_2, a_1, a_0)$ as a number in base 2, associate the polynomial

$$a(x) = a_r x^r + a_{r-1} x^{r-1} + \cdots + a_2 x^2 + a_1 x + a_0$$

in $\mathbb{GF}_2[x]$. A codeword is then generated by the formula $a(x)q(x) \mod 2$, where $q(x)$ is a specially selected polynomial. Consider the Galois field $\mathbb{GF}_{2^4} = \mathbb{GF}_{16}$. Let $\alpha$ be a primitive element in $\mathbb{GF}_{16}$, so that the nonzero elements of $\mathbb{GF}_{16}$ are all powers of $\alpha$. In particular, this property holds if we take $\alpha$ to be a root of the irreducible polynomial $x^4 + x + 1$. Let $m_i(x)$ be the minimal polynomial of $\alpha^i$. If

$$q(x) = \text{lcm}[m_1(x), m_2(x), \ldots, m_{2^t}(x)]$$

then the corresponding BCH code corrects at least $t$ errors.

Since $\alpha^4 + \alpha + 1 = 0$, it follows that

$$0^2 = (\alpha^4 + \alpha + 1)^2 = (\alpha^4)^2 + \alpha^2 + 1 = (\alpha^2)^4 + \alpha^2 + 1$$

Hence, $m_1(x) = m_2(x)$. By the same reasoning, $m_2(x) = m_4(x) = m_8(x)$. Likewise,

$$m_3(x) = (x - \alpha^3)(x - \alpha^6)(x - \alpha^{12})(x - \alpha^9) = x^4 + x^3 + x^2 + x + 1$$

Hence, a double error-correcting code is generated by

$$q(x) = \text{lcm}[m_1(x), m_2(x), m_3(x), m_4(x)] \mod 2 = x^8 + x^7 + x^6 + x^4 + 1$$

**Linear Programming**

A linear programming problem consists of minimizing (or maximizing) a linear function subject to certain conditions or constraints expressible as linear inequalities. The word “programming” is used here in the sense of “planning.” The importance of linear programming derives in part from its many applications and in part from the existence of good general-purpose techniques for finding optimal solutions.
Chapter 12 | Applied Modern Algebra

The Simplex Algorithm

The basic purpose of the simplex algorithm is to solve linear programming problems. In the following example, the function \( f(x,y) = x + y \) is to be maximized subject to the two inequalities shown. The function \( f(x,y) \) is the objective function, and the set of linear constraints is called the linear system.

**To enter a linear programming problem with two constraints**
1. Create a \( 3 \times 1 \) matrix.
2. Type the function to be maximized in the first row.
3. Type the linear constraints in the subsequent rows.
4. Leave the insert point in the matrix.
5. Choose Compute > Simplex > Maximize.

\[
\begin{bmatrix}
  x + y \\
  4x + 3y \leq 6 \\
  3x + 4y \leq 4
\end{bmatrix}
\]

Maximum is at: \( \{ x = \frac{12}{7}, y = \frac{-2}{7} \} \)

Of course, these are the same coordinates that minimize \(-x - y\).

In the following linear programming problem, place the insert point in the matrix and choose Compute > Simplex > Minimize.

\[
\begin{bmatrix}
  -x - y \\
  4x + 3y \leq 6 \\
  3x + 4y \leq 4
\end{bmatrix}
\]

Minimum is at: \( \{ y = \frac{-2}{7}, x = \frac{12}{7} \} \)

Feasible Systems

Two things may prevent the existence of a solution. There may be no values of \( x \) and \( y \) satisfying the constraints. Even if there are such values, there may be none maximizing the objective function. If there are values satisfying the constraints, the system is called feasible.

The following example illustrates a set of inequality constraints with no function to be maximized or minimized. You can ask whether the constraints are feasible—that is, whether they define a nonempty set. Place the insert point in the matrix and choose Compute > Simplex > Feasible.
### Linear Programming

#### Compute > Simplex > Feasible?

\[
\begin{bmatrix}
4x + 3y & \leq 6 \\
3x + 4y & \leq 4 \\
x & \geq 0 \\
y & \geq 0
\end{bmatrix}

, Is feasible? \text{ true}

\[
\begin{bmatrix}
4x + 3y & \leq 6 \\
4x + 3y & \geq 7
\end{bmatrix}

, Is feasible? \text{ false}

Saying that the system \[
\begin{bmatrix}
4x + 3y & \leq 6 \\
4x + 3y & \geq 7
\end{bmatrix}
\]
is not feasible implies, in particular, that there are no values minimizing the objective function in the problem \[
\begin{bmatrix}
x + y \\
4x + 3y & \leq 6 \\
4x + 3y & \geq 7
\end{bmatrix}
\]. Geometrically, the two regions that satisfy the inequalities are disjoint.

#### Standard Form

A system of linear inequalities is in \textit{standard form} when all the inequalities are of the form \( \leq \). To convert a system of linear inequalities to a system in standard form, choose Compute > Simplex > Standardize.

#### Compute > Simplex > Standardize

\[
\begin{bmatrix}
4x + 3y & \leq 6 \\
3x + 4y & \leq 4 \\
x & \geq 0 \\
y & \geq 0
\end{bmatrix}

, System in standard form is:

\[
\begin{bmatrix}
-x & \leq 0 \\
-y & \leq 0 \\
3x + 4y & \leq 4 \\
4x + 3y & \leq 6
\end{bmatrix}
\]

With a linear function added, you can maximize the resulting linear programming problem.

#### Compute > Simplex > Maximize

\[
\begin{bmatrix}
x + 3y \\
3x - y & \leq 4 \\
4x + 3y & \leq 6 \\
y & \leq 0 \\
x & \leq 0
\end{bmatrix}

, Maximum is at: \{x = 0, y = 2\}

#### The Dual of a Linear Program

The other item on the Simplex menu is Dual. It computes the dual of a linear program.
Chapter 12 | Applied Modern Algebra

**Compute > Simplex > Dual**

\[
\begin{align*}
x + y & \\ 4x + 3y & \leq 6 \\ 3x + 4y & \leq 4 \\ x & \geq 0 \\ -y & \leq 0
\end{align*}
\]

, Dual system is:

\[
\begin{align*}
4u_3 + 6u_4 & \\
-3u_3 - 4u_4 & \leq -1 \\
-4u_3 - 3u_4 & \leq -1
\end{align*}
\]

Applying the simplex algorithm to these two linear programs yields the following results.

**Compute > Simplex > Maximize**

\[
\begin{align*}
x + y & \\ 4x + 3y & \leq 6 \\ 3x + 4y & \leq 4 \\ x & \geq 0 \\ -y & \leq 0
\end{align*}
\]

, Maximum is at: \( \{ y = 0, x = \frac{4}{5} \} \)

**Compute > Simplex > Minimize**

\[
\begin{align*}
6u_4 + 4u_3 & \\
1 & \leq 4u_4 + 3u_3 - u_2 \\
1 & \leq 3u_4 + 4u_3 - u_1 \\
u_1 & \geq 0 \\
u_2 & \geq 0 \\
u_3 & \geq 0 \\
u_4 & \geq 0
\end{align*}
\]

, Minimum is at: \( \{ u_1 = 0, u_2 = 0, u_4 = 0, u_3 = \frac{1}{2} \} \)

**Exercises**

1. Give a multiplication table for the integers modulo 11. From the table, find the inverses of 2 and 3. Verify your answers by evaluating \( 2^{-1} \mod 11 \) and \( 3^{-1} \mod 11 \).

2. Solve the congruence \( 5x + 4 \equiv 8 \pmod{13} \). Verify your answer by evaluating \( 5x + 4 \mod 13 \).

3. A jar is full of jelly beans. If the jelly beans are evenly divided among five children, there are three jelly beans left over; and if the jelly beans are evenly divided among seven adults, there are five jelly beans left over. How many jelly beans are in the jar? Are other solutions possible? If so, what are they?

4. What is the smallest 100-digit prime?
Exercises

5. If $p$ is the smallest 100-digit prime, what is $2^{p-1} \mod p$? What is $2^{(p-1)/2} \mod p$? What about $2^{(p-1)/4} \mod p$?

6. The matrix $M = \begin{bmatrix} 1 & 1 & 1 \\ 1 & 2 & 4 \\ 1 & 4 & 9 \end{bmatrix}$ is used as a block cipher modulo 26 to scramble letters in a message, three letters at a time. Assume $A \leftrightarrow 0, B \leftrightarrow 1, C \leftrightarrow 2$, and so forth. Descramble the ciphertext FKBHRTMTU.

7. Find an irreducible polynomial of degree 3. Use this polynomial to describe how to calculate sums and products in the field $GF_{27}$.

8. A barge company transports bales of hay and barrels of beer up the Mississippi River. The company charges $2.30 for each bale of hay and $3.00 for each barrel of beer. The bales of hay average 75 pounds and take up 5 cubic feet of space; the barrels of beer weigh 100 pounds and take up 4 cubic feet of space. A barge is limited to a payload of 150,000 pounds and 8,000 cubic feet. How much beer and how much hay should a barge transport to maximize the shipping charges?

9. The Riemann Hypothesis states that all of the nontrivial zeros of the Riemann zeta function lie on the line $\text{Re}(s) = \frac{1}{2}$. Visualize the Riemann zeta function along $\text{Re}(s) = \frac{1}{2}$ by drawing a curve in three-dimensional space.

10. Let $\mathbb{Z}_{30}$ denote the integers modulo 30. Write $\mathbb{Z}_{30}$ as a (disjoint) union of groups.

Solutions

1. Define the function $f(i, j) = ij$. Choose Compute > Matrices > Fill Matrix with 10 rows and 10 columns, and use the function $f$ to generate a matrix. Then, reduce the matrix mod 11 to get the following:
Chapter 12 | Applied Modern Algebra

Select the matrix and choose Edit > Insert Column(s). Add one column at position 1. You have now added a column on the left. Repeat this procedure using Insert Row(s), adding a row at position 1. Fill in the empty boxes with $\times$ and the integers 1 through 10 to generate the final multiplication table,

\[
\begin{array}{cccccccccc}
1 & 2 & 3 & 4 & 5 & 6 & 7 & 8 & 9 & 10 \\
2 & 4 & 6 & 8 & 10 & 3 & 5 & 7 & 9 & 1 \\
3 & 6 & 9 & 1 & 4 & 7 & 10 & 2 & 5 & 8 \\
4 & 8 & 1 & 5 & 9 & 2 & 6 & 10 & 3 & 7 \\
5 & 10 & 4 & 9 & 3 & 8 & 2 & 7 & 1 & 6 \\
6 & 1 & 7 & 2 & 8 & 3 & 9 & 4 & 10 & 5 \\
7 & 3 & 10 & 6 & 2 & 9 & 5 & 1 & 8 & 4 \\
8 & 5 & 2 & 10 & 7 & 4 & 1 & 9 & 6 & 3 \\
9 & 7 & 5 & 3 & 1 & 10 & 8 & 6 & 4 & 2 \\
10 & 9 & 8 & 7 & 6 & 5 & 4 & 3 & 2 & 1 \\
\end{array}
\]

From the table, $2 \cdot 6 = 1$ implies $2^{-1} = 6$, and $3 \cdot 4 = 1$ implies $3^{-1} = 4$. As a check, $2^{-1} \mod 11 = 6$ and $3^{-1} \mod 11 = 4$.

2. The solution is given by $x = (8 - 4)/5 \mod 13 = 6$. As a check, $6 \cdot 5 + 4 \mod 13 = 8$.

3. The problem requires the solution to the system

\[
x \equiv 3 \pmod{5} \\
x \equiv 5 \pmod{7}
\]

of congruences. The system is equivalent to the equation $x = 3 + 5a = 5 + 7b$, or $3 + 5a \equiv 5 \pmod{7}$, which has a solution
Exercises

\[ a = (5 - 3)/5 \mod 7 = 6 \], which means \( x = 3 + 5a = 33 \) jelly beans. Other possible solutions are \( x = 33 + 35n \), where \( n \) is any positive integer.

4. Define the function \( \text{nextp} \) as indicated in this chapter. Then \( \text{nextp}(10^{99}) \) produces a number with lots of zeroes that ends in 289. The prime \( p \) can be written as \( p = 10^{99} + 289 \).

5. Note that \( 2^{p-1} \mod p = 1 \) and \( 2^{(p-1)/2} \mod p = 1 \), whereas \( 2^{(p-1)/4} \mod p \) produces another number with lots of zeroes that ends in 288. More precisely, \( 2^{(p-1)/4} \equiv -1 \mod p \). This congruence illustrates the fact that, if \( p \) is a prime, then \( x^2 \equiv 1 \mod p \) has only two solutions, \( x \equiv 1 \mod p \) and \( x \equiv -1 \mod p \).

6. We have
\[
\begin{bmatrix}
1 & 1 & 1 \\
1 & 2 & 4 \\
1 & 4 & 9
\end{bmatrix}
\begin{bmatrix}
24 & 5 & 24 \\
5 & 18 & 3 \\
24 & 3 & 25
\end{bmatrix}
\mod 26
\]
The ciphertext F K B H R T M T U has a numerical equivalent of [5, 10, 1, 7, 17, 19, 12, 19, 20]. Picking three at a time, we get
\[
\begin{bmatrix}
24 & 5 & 24 \\
5 & 18 & 3 \\
24 & 3 & 25
\end{bmatrix}
\begin{bmatrix}
1 & 5 & 12 \\
10 & 17 & 19 \\
1 & 19 & 20
\end{bmatrix}
\mod 26
\begin{bmatrix}
12 & 7 & 5 \\
0 & 8 & 20 \\
19 & 18 & 13
\end{bmatrix}
\]
The vector [12, 0, 19, 7, 8, 18, 5, 20, 13] corresponds to the plaintext M A T H I S F U N, or MATH IS FUN.

7. Defining \( g(x) = x^3 + x + 1 \), we see that \( g(1) \mod 3 = 0 \), and hence \( g(x) \) is not irreducible (since it has a root in \( GF_3 \)). However, if \( f(x) = x^3 + 2x + 1 \), then \( f(0) \mod 3 = 1 \), \( f(1) \mod 3 = 1 \), and \( f(2) \mod 3 = 1 \), and hence \( f(x) \) is irreducible. (If \( f(x) \) were reducible, it would have a linear factor, and hence a root.) An element of \( GF_{27} \) can be thought of as a polynomial of degree less than 3 with coefficients in \( GF_3 \). Given the field elements \( 2x^2 + x + 2 \) and \( 2x + 1 \), the product is
\[
((2x^2 + x + 2)(2x + 1) \mod x^3 + 2x + 1) \mod 3 = x^2 + 1,
\]
and the sum is given by
\[
(2x^2 + x + 2) + (2x + 1) \mod 3 = 2x^2.
\]
Chapter 12 | Applied Modern Algebra

8. The objective function is $2.3h + 3b$. The constraints are $4h + 5b \leq 8000$, $75h + 100b \leq 150000$, $b \geq 0$, and $h \geq 0$. With the insert point in the display

$$
\begin{align*}
2.3h + 3b \\
5h + 4b &\leq 8000 \\
75h + 100b &\leq 150000 \\
b &\geq 0 \\
h &\geq 0
\end{align*}
$$

choose Compute > Simplex > Maximize to get: Maximum is 4550 at $h = 1000, b = 750$.

9. Type $(t, \text{Re} (\zeta (\frac{1}{2} + ti)), \text{Im} (\zeta (\frac{1}{2} + ti)))$ and choose Compute > Plot 3D > Tube. Type $(t, 0, 0)$ and drag it to the plot frame. From the Plot Properties dialog, choose the Items Plotted page. For Items 1 and 2, set Interval: 0 to 35, Points Sampled: 99, Points per Cross Section: 7, Radius: 0.2 and set the Surface Style to Hidden Line.

View the curve from several different angles. Note that the intersection points display zeros of the Riemann zeta function.

10. Consider first the positive integers $< 30$ that are relatively prime to 30. Let $G_1 = \{1, 7, 11, 13, 17, 19, 23, 29\}$ be the group of units modulo 30.

In a similar fashion, for each divisor $n$ of 30 define $G_n$ to be the
positive integers $a < 30$ such that gcd $(a, 30) = n$. Thus

\[
G_1 = \{1, 7, 11, 13, 17, 19, 23, 29\} \\
G_2 = \{2, 4, 8, 14, 16, 22, 26, 28\} \\
G_3 = \{3, 9, 21, 27\} \\
G_5 = \{5, 25\} \\
G_6 = \{6, 12, 18, 24\} \\
G_{10} = \{10, 20\} \\
G_{15} = \{15\} \\
G_{30} = \{0\}
\]

For each of these subsets, create a multiplication table modulo 30 such as the following one for $G_2$, for which 16 acts as an identity.

\[
\begin{bmatrix}
2 & 4 & 8 & 14 & 16 & 22 & 26 & 28 \\
4 & 2 & 8 & 16 & 22 & 26 & 28 & 14 \\
8 & 4 & 2 & 16 & 22 & 26 & 28 & 14 \\
14 & 8 & 2 & 16 & 22 & 26 & 28 & 14 \\
16 & 14 & 2 & 22 & 26 & 28 & 14 & 8 \\
22 & 22 & 14 & 2 & 26 & 28 & 14 & 8 \\
26 & 26 & 22 & 14 & 2 & 28 & 16 & 8 \\
28 & 28 & 26 & 22 & 14 & 2 & 28 & 16
\end{bmatrix} \mod 30
\]

Note that each of these sets is closed under multiplication, and that each element appears once in each row and once in each column. Since multiplication is certainly commutative and associative, it follows that each subset is in fact a group.
This appendix summarizes information about the Compute menu, corresponding commands on the Math Toolbar, and keyboard shortcuts for these commands. Details and examples are given in the main text.

**Compute Menu**

- **Calculus > Approximate Integral**  
  Apply approximation methods Left, Right, Left and Right, Middle, Lower, Upper, Lower and Upper, Lower Absolute, Upper Absolute, Lower and Upper Absolute, Trapezoid, or Simpson for approximating definite integrals by a mathematical expression.

- **Calculus > Change Variables**  
  Simplifies an indefinite integral: specify a substitution and get the result of the substitution.

- **Calculus > Find Extrema**  
  Given a mathematical expression, returns candidates for extrema.

- **Calculus > Implicit Differentiation**  
  Given an equation and a differentiation variable, performs differentiation.

**New in Version 6**

- Compute > Passthru Code to MuPAD
- Compute > Rewrite > Mixed
Appendix A | Menus and Shortcuts for Doing Mathematics

- **Calculus > Integrate by Parts**  Simplifies an indefinite integral: specify the part to be differentiated and invoke the integration by parts method.

- **Calculus > Iterate**  Find numerical approximations to a root of an equation $f(x) = x$, starting with your estimate of a root.

- **Calculus > Partial Fractions**  Writes a factorable rational function as a sum of simpler fractions. (Same as Polynomials > Partial Fractions)

- **Calculus > Plot Approximate Integral**  Plot pictures of Riemann sums obtained from midpoints, left endpoints, or right endpoints of subintervals.

- **Check Equality**  Verify equalities and inequalities. There are three possible responses: true, false, and undecidable.

- **Combine > Arctan**  Combines or simplifies expressions involving inverse tangent functions.

- **Combine > Exponentials**  Combines or simplifies expressions involving exponential functions with base $e$.

- **Combine > Hyperbolic Trigonometric Functions**  Products and powers of hyperbolic trigonometric functions are combined into a sum of hyperbolic functions whose arguments are integral linear combinations of the original arguments.

- **Combine > Logs**  Combines or simplifies expressions involving logarithmic functions with base $e$.

- **Combine > Powers**  Combines or simplifies expressions involving exponential functions with arbitrary base.

- **Combine > Trigonometric Functions**  Products and powers of trigonometric functions are combined into a sum of trigonometric functions whose arguments are integral linear combinations of the original arguments.

- **Definitions > Clear Definitions**  Removes all active user-defined definitions from a document.
• **Definitions > Define MuPAD Name**  Allows users to access functions available to the computation engine that do not appear as menu items, either functions from one of the libraries of the computation engine or user-defined functions.

• **Definitions > New Definition**  Allows users to define new functions and variables for computation.

• **Definitions > Show Definitions**  Provides a list of all active user-defined definitions in a document.

• **Definitions > Undefine**  Removes a selected user-defined definition from a document.

• **Evaluate**  Evaluate yields symbolic or numerical results, depending on the input.

• **Evaluate Numeric**  Evaluates and gives numerical results.

• **Expand**  Expand polynomial and rational products, trigonometric and exponential expressions.

• **Factor**  Factor polynomials and rational, trigonometric and exponential expressions.

• **Interpret**  Shows the interpretation of possibly ambiguous expressions as made by the computing engine.

• **Matrices > Adjugate**  Produces the adjugate or classical adjoint of a square matrix \( A \), namely, the transpose of the matrix of cofactors of \( A \).

• **Matrices > Characteristic Polynomial**  Produces the characteristic polynomial of a square matrix \( A \), namely, the determinant of the characteristic matrix \( xI - A \).

• **Matrices > Cholesky Decomposition**  Factors a real square, symmetric, and positive definite matrix \( A \) as a product \( A = GG^T \), with \( G \) a real positive-definite lower triangular square matrix.

• **Matrices > Column Basis**  Produces a basis for the vector space spanned by the columns of a matrix.

• **Matrices > Concatenate**  Merges two matrices with the same number of rows horizontally into one matrix.
Appendix A | Menus and Shortcuts for Doing Mathematics

- **Matrices > Condition Number**  Produces the condition number of an invertible matrix $A$, the product of the 2-norm of $A$ and the 2-norm of $A^{-1}$. This number measures the sensitivity of some solutions of linear equations $Ax = b$ to perturbations in the entries of $A$ and $b$.

- **Matrices > Definiteness Tests**  Determines whether a Hermitian matrix (a square matrix equal to its conjugate transpose) is positive definite, positive semidefinite, negative definite, or negative semidefinite.

- **Matrices > Determinant**  Produces the determinant of a square matrix.

- **Matrices > Eigenvalues**  Produces a list of eigenvalues of a square matrix, that is, the roots of its characteristic polynomial. The results are symbolic or numerical approximations depending on the matrix entries.

- **Matrices > Eigenvectors**  Produces a list of eigenvectors paired with eigenvalues of a square matrix, that is, the roots of its characteristic polynomial. Given a matrix $A$, these are a scalar $c$ and a vector $v$ with $Av = cv$. The results are symbolic or numeric depending on the matrix entries.

- **Matrices > Fill Matrix**  Create a matrix: choose from matrix types Band, Defined by Function, Identity, Jordan Block, Random (integers between -1000 and 1000), and Zero (filled with zeroes).

- **Matrices > Fraction-Free Gaussian Elimination**  Elementary row operations are used to reduce a matrix of integers to row echelon form with integer entries.

- **Matrices > Gaussian Elimination**  Elementary row operations are used to reduce a matrix to row echelon form. The results are symbolic or numeric depending on the matrix entries.

- **Matrices > Hermite Normal Form**  Produces, from a matrix $A$ with integer entries, a row echelon matrix $H = QA$ where $Q$ is invertible in the ring of matrices over the integers.

- **Matrices > Hermitian Transpose**  Produces, from a complex matrix, the Hermitian transpose.
• **Matrices > Inverse** Produces the inverse of a square, invertible matrix.

• **Matrices > Jordan Normal Form** Produces a factorization of a square matrix as $PJP^{-1}$, where $J$ is in Jordan normal form.

• **Matrices > Map Function** Applies a function (either built-in or user defined) to the entries of a matrix or vector.

• **Matrices > Minimal Polynomial** Computes the monic minimal polynomial of a square matrix.

• **Matrices > Norm** Computes the 2-norm, or Euclidean norm, of a matrix $A$ with real or complex entries. It is the number defined by $\|A\| = \max_{x \neq 0} \|Ax\| / \|x\|$. In the special case $A$ is a vector, this is the Euclidean length of the vector.

• **Matrices > Nullspace Basis** Finds a basis for the vector space consisting of all vectors $X$ satisfying $AX = 0$.

• **Matrices > Orthogonality Test** Tests a real matrix to determine if the inner product of any two different columns is zero and the inner product of every column with itself is one, and reports true or false.

• **Matrices > Permanent** Computes the sum of certain products of the entries of a square matrix $(a_{ij})$, namely, $\text{permanent}(a_{ij}) = \sum_{\sigma} a_{1\sigma(1)}a_{2\sigma(2)}\cdots a_{n\sigma(n)}$ where $\sigma$ ranges over all the permutations of $\{1, 2, \ldots, n\}$.

• **Matrices > PLU Decomposition** Factors a real matrix $A$ into a product $A = PLU$, with $L$ and $U$ real lower and upper triangular matrices with 1’s on the main diagonal of $L$, and with $P$ a permutation matrix. The matrices $P$ and $L$ are invertible and the matrix $U$ is a row echelon form of $A$.

• **Matrices > QR Decomposition** Factors a real $m \times n$ matrix $A$ with $m \geq n$ as a product $QR$, where $Q$ is an orthogonal $m \times m$ matrix and $R$ is upper-right triangular with the same rank as $A$. If the original matrix $A$ is square, then so is $R$. If $A$ has linearly independent columns, then $R$ is invertible.

• **Matrices > Random Matrix** Creates a matrix of integers. Set dimensions and the range of random entries. Select a matrix type—unrestricted, symmetric, antisymmetric, or triangular.
Appendix A | Menus and Shortcuts for Doing Mathematics

- **Matrices > Rank**  Reports the dimension of the vector space generated by the columns of a matrix.

- **Matrices > Rational Canonical Form**  Produces a block diagonal matrix with each block the companion matrix of its own minimum and characteristic polynomials.

- **Matrices > Reduced Row Echelon Form**  Produces a row-equivalent matrix in row echelon form in which the number of leading zeros increases as the row number increases; the first nonzero entry in each nonzero row is equal to 1; and each column that contains the leading nonzero entry for any row contains only zeros above and below that entry.

- **Matrices > Reshape**  Creates a matrix of specified dimensions from a list. Also changes dimensions of a matrix.

- **Matrices > Row Basis**  Produces a set of vectors that form a basis for the vector space spanned by the rows of a matrix.

- **Matrices > Singular Value Decomposition**  Factors an \( m \times n \) real matrix \( A \) into a product \( A = UDV \), with \( U \) and \( V \) real orthogonal \( m \times m \) and \( n \times n \) matrices, respectively, and \( D \) a diagonal matrix with positive numbers in the first \( \text{rank}(A) \) entries on the main diagonal, and zeros everywhere else.

- **Matrices > Smith Normal Form**  Given a matrix \( A \) over a principal ideal domain (in particular, a matrix of integers), produces an equivalent diagonal matrix of the form \( \text{diag}(1, \ldots, 1, p_1, p_2, \ldots, p_k, 0, \ldots, 0) \) where for each \( i, p_i \) is a factor of \( p_{i+1} \).

- **Matrices > Spectral Radius**  Computes the largest of the absolute values of the eigenvalues of a square matrix.

- **Matrices > Stack**  Merges two matrices with the same number of columns vertically into one matrix.
• **Matrices > Trace** Computes the sum of the diagonal elements of a square matrix.

• **Matrices > Transpose** Interchanges the rows and columns of a matrix.

• **Passthru Code to Engine** Allows users to enter and send MuPAD code directly to the compute engine.

• **Plot 2D > Approximate Integral** Plots an expression together with pictures of Riemann sums obtained from midpoints, left endpoints, or right endpoints of subintervals.

• **Plot 2D > Conformal** Given a complex function \( F(z) \), maps a two-dimensional grid from the plane into a second (curved) grid determined by the images of the original grid lines under \( F \). Yields a set of curves in the plane with the property that they also intersect at right angles at the points where \( F \) is analytic.

• **Plot 2D > Gradient** Plots a rectangular array of arrows that describe the gradient of an expression \( f(x,y) \).

• **Plot 2D > Implicit** Plots the graph of an equation in rectangular coordinates.

• **Plot 2D > Inequality** Plots points in the plane that satisfy a given inequality of the form \( f(x) < g(x) \) or \( f(x) > g(x) \).

• **Plot 2D > ODE** Plots a function \( f \) given as the numerical solution to an ordinary differential equation.

• **Plot 2D > Parametric** Plots a parametric curve \( (x(t), y(t)) \) in rectangular coordinates.

• **Plot 2D > Polar** Plots the polar graph of \( f(\theta) \) or the polar graph of a parametric curve \( (r(t), \theta(t)) \).

• **Plot 2D > Rectangular** Plots the graph of an expression \( f(x) \) in rectangular coordinates. Also plots the graph of a parametric curve \( (x(t), y(t)) \) in rectangular coordinates.

• **Plot 2D > Vector Field** Given an equation of the form \( F(x,y) = [u(x,y), v(x,y)] \), plots a vector field in rectangular coordinates.
Appendix A | Menus and Shortcuts for Doing Mathematics

- **Plot 2D Animated > Conformal** Animates a conformal plot as a parameter $t$ increases over an interval $a \leq t \leq b$.

- **Plot 2D Animated > Gradient** Animates a gradient as a parameter $t$ increases over an interval $a \leq t \leq b$.

- **Plot 2D Animated > Implicit** Animates an implicit plot as a parameter $t$ increases over an interval $a \leq t \leq b$.

- **Plot 2D Animated > Inequality** Animates an inequality as a parameter $t$ increases over an interval $a \leq t \leq b$.

- **Plot 2D Animated > Parametric** Animates the plot of a parametric curve as a parameter $t$ increases over an interval $a \leq t \leq b$.

- **Plot 2D Animated > Polar** Animates a polar plot as a parameter $t$ increases over an interval $a \leq t \leq b$.

- **Plot 2D Animated > Rectangular** Animates a rectangular plot as a parameter $t$ increases over an interval $a \leq t \leq b$.

- **Plot 3D > Curve in Space** Plots a rectangular curve, given a list or vector $(x(t), y(t), z(t))$.

- **Plot 3D > Cylindrical** Plots the expression $f(\theta, z)$ in cylindrical coordinates or the parameterized cylindrical surface $(r(s,t), \theta(s,t), z(s,t))$.

- **Plot 3D > Gradient** Plots a three-dimensional array of arrows that describe gradient of the expression $f(x, y, z)$.

- **Plot 3D > Implicit** Plots an equation $f(x, y, z) = c$.

- **Plot 3D > Parametric** Plots a parametric surface $(x(s,t), y(s,t), z(s,t))$ in rectangular coordinates.

- **Plot 3D > Rectangular** Plots a surface given by an expression $f(x, y)$ in rectangular coordinates. Also plots a parametric surface $(x(s,t), y(s,t), z(s,t))$ in rectangular coordinates.
Compute Menu

- **Plot 3D > Spherical**  
  Plot an expression \( f(\theta, \phi) \) in spherical coordinates or a parameterized surface \( (\rho(s,t), \theta(s,t), \phi(s,t)) \) in spherical coordinates.

- **Plot 3D > Tube**  
  Plots a fat curve \( (x(t), y(t), z(t)) \) of radius \( r(t) \).

- **Plot 3D > Vector Field**  
  Plots a vector field \( F(x, y, z) = [u(x, y, z), v(x, y, z), w(x, y, z)] \) in rectangular coordinates.

- **Plot 3D Animated > Curve in Space**  
  Animates a curve in space as a parameter \( t \) increases over an interval \( a \leq t \leq b \).

- **Plot 3D Animated > Cylindrical**  
  Animates a cylindrical plot as a parameter \( t \) increases over an interval \( a \leq t \leq b \).

- **Plot 3D Animated > Gradient**  
  Animates a gradient as a parameter \( t \) increases over an interval \( a \leq t \leq b \).

- **Plot 3D Animated > Implicit**  
  Animates an implicit plot as a parameter \( t \) increases over an interval \( a \leq t \leq b \).

- **Plot 3D Animated > Parametric**  
  Animates a parametric plot as a parameter \( t \) increases over an interval \( a \leq t \leq b \).

- **Plot 3D Animated > Rectangular**  
  Animates a rectangular plot as a parameter \( t \) increases over an interval \( a \leq t \leq b \).

- **Plot 3D Animated > Spherical**  
  Animates a spherical plot as a parameter \( t \) increases over an interval \( a \leq t \leq b \).

- **Plot 3D Animated > Tube**  
  Animates a tube plot as a parameter \( t \) increases over an interval \( a \leq t \leq b \).

- **Plot 3D Animated > Vector Field**  
  Animates a vector field as a parameter \( t \) increases over an interval \( a \leq t \leq b \).

- **Polynomials > Collect**  
  Rewrites a polynomial by collecting all coefficients of terms of the polynomial.

- **Polynomials > Companion Matrix**  
  Produces the companion matrix of a monic polynomial \( a_0 + a_1 X + \cdots + a_{n-1} X^{n-1} + X^n \) of degree \( n \), which is the \( n \times n \) matrix with a subdiagonal of ones, final column \( [ -a_0 \quad -a_1 \quad \cdots \quad -a_{n-1} ]^T \) and other entries zero.
Appendix A | Menus and Shortcuts for Doing Mathematics

- **Polynomials > Divide**  Rewrites a rational quotient of polynomials \( f(x)/g(x) \) with rational coefficients to the form \( q(x) + r(x)/g(x) \), where \( r(x) \) and \( q(x) \) are polynomials and \( \deg r(x) < \deg g(x) \).

- **Polynomials > Partial Fractions**  Writes a factorable rational function as a sum of simpler fractions.

- **Polynomials > Roots**  Finds real and complex roots of a real or complex polynomial with rational coefficients. It finds roots symbolically for polynomials of degree 4 or less, and finds the roots numerically for polynomials of higher degree.

- **Polynomials > Sort**  Rewrites a polynomial by collecting the numeric coefficients of terms of a polynomial expression and returns the terms in order of decreasing degree.

- **Power Series**  Produces the Taylor series of a function expanded about a specified point.

- **Rewrite > Arcos**  Rewrites an inverse trigonometric function in terms of arccos.

- **Rewrite > Arccot**  Rewrites an inverse trigonometric function in terms of arccot.

- **Rewrite > Arcsin**  Rewrites an inverse trigonometric function in terms of arcsin.

- **Rewrite > Arctan**  Rewrites an inverse trigonometric function in terms of arctan.

- **Rewrite > Cos**  Rewrites a trigonometric function in terms of the cosine function.

- **Rewrite > Equations as Matrix**  Converts a system of linear equations to the matrix of its coefficients.

- **Rewrite > Exponential**  Rewrites an expression in terms of the natural exponential function.

- **Rewrite > Factorial**  Rewrites an expression in terms of factorials.

- **Rewrite > Float**  Rewrites an expression in terms of floating-point numbers.
Compute Menu

- **Rewrite > Gamma**  Rewrites a factorial expression in terms of the gamma function.
- **Rewrite > Logarithm**  Rewrites an expression in terms of the natural logarithm.
- **Rewrite > Matrix as Equations**  Takes a matrix and produces a list of linear equations with the matrix entries as coefficients.
- **Rewrite > Mixed**  Converts a fraction to a mixed number.
- **Rewrite > Normal Form**  Combines rational polynomial expressions over a common denominator.
- **Rewrite > Polar**  Rewrites a complex number in polar form \(r e^{i\theta}\).
- **Rewrite > Rational**  Rewrites a floating-point number as a quotient of integers; rewrites an inverse in rational notation.
- **Rewrite > Rectangular**  Rewrites a complex number in rectangular form \(a + bi\).
- **Rewrite > Sin**  Rewrites a trigonometric expression in terms of the cosine function.
- **Rewrite > Sin and Cos**  Rewrites a trigonometric expression in terms of the sine and cosine functions.
- **Rewrite > Sinh and Cosh**  Rewrites an exponential expression in terms of the hyperbolic sine and cosine functions.
- **Rewrite > Tan**  Rewrites a trigonometric expression in terms of the tangent function.
- **Simplex > Dual**  Gives the dual of a linear programming problem.
- **Simplex > Feasible?**  Tests whether or not a set of constraints is feasible.
- **Simplex > Maximize**  Finds the maximum value of a linear expression subject to a feasible system of constraints.
Appendix A | Menus and Shortcuts for Doing Mathematics

- **Simplex > Minimize**  Finds the minimum value of a linear expression subject to a feasible system of constraints.
- **Simplex > Standardize**  Rewrites a linear programming problem in standard form.
- **Simplify**  Simplifies an algebraic expression, rationalizes denominators.
- **Solve > Exact**  Finds an exact solution to an equation or system of equations.
- **Solve > Integer**  Finds integer roots of polynomial expressions with rational coefficients, and integer solutions to equations of the same type.
- **Solve > Numeric**  Computes an approximate floating-point solution to an equation or an approximate floating-point solution in a given interval.
- **Solve > Recursion**  Solves a recursion or system of recursions.
- **Solve ODE > Exact**  Computes an exact solution to an ordinary differential equation.
- **Solve ODE > Laplace**  Uses the Laplace method to compute a solution to an ordinary differential equation.
- **Solve ODE > Numeric**  Computes an approximate solution to an ordinary differential equation.
- **Solve ODE > Series**  Computes an approximate finite series solution to an ordinary differential equation.
- **Statistics > Correlation**  Computes the coefficient of correlation between two samples.
- **Statistics > Covariance**  Computes the $n \times n$ covariance matrix of an $m \times n$ matrix.
- **Statistics > Fit Curve to Data > Multiple Regression**  Calculates linear-regression equations from *keyed* or labeled data matrices. The equation produced is the best fit to the data in the least-squares sense.
• **Statistics > Fit Curve to Data > Polynomial of Degree** \( n \)  
Calculates polynomial equations from labeled or unlabeled two-column data matrices. The result is a polynomial of the specified degree that is the best fit to the data in the least-squares sense.

• **Statistics > Geometric Mean**  
Calculates the \( n \)th root of the product of numbers in a comma delimited list or a vector, and calculates the \( n \)th roots of the products of numbers in columns of an \( n \times m \) matrix for \( n \geq 2 \).

• **Statistics > Harmonic Mean**  
Calculates the reciprocal of the mean of the reciprocals of numbers in a comma delimited list or a vector, and calculates the harmonic means for columns of an \( n \times m \) matrix for \( n \geq 2 \).

• **Statistics > Mean**  
Calculates the arithmetic mean, or average, of numbers in a comma delimited list or a vector, and calculates the arithmetic means of numbers in columns of an \( n \times m \) matrix for \( n \geq 2 \).

• **Statistics > Mean Deviation**  
Calculates the mean of the distances of the data from the data mean for data in a comma delimited list or in a vector, and calculates the mean deviations of data in columns of an \( n \times m \) matrix for \( n \geq 2 \).

• **Statistics > Median**  
Calculates a number such that at least half the numbers in a data set are equal to or less than it, and at least half the numbers in the data set are equal to or greater than it for data in a comma delimited list or in a vector, and calculates the medians of data in columns of an \( n \times m \) matrix for \( n \geq 2 \).

• **Statistics > Mode**  
Finds the value or values that occur with maximum frequency in a data set, and also gives the multiplicity of each of the modes for data in a comma delimited list or in a vector, and calculates the modes of data in columns of an \( n \times m \) matrix for \( n \geq 2 \).

• **Statistics > Moment**  
Computes the 1st, 2nd, and higher moments about the mean or about a specified point for data in a comma delimited list or in a vector, and calculates the moments of data in columns of an \( n \times m \) matrix for \( n \geq 2 \).
Appendix A | Menus and Shortcuts for Doing Mathematics

- **Statistics > Quantile** Computes the $q$th quantile of a set, where $q$ is a number between zero and one. The result is a number $Q$ for which the fraction $q$ of the numbers falls below $Q$ and the fraction $1 - q$ lies above $Q$ for data in a comma delimited list or in a vector, and calculates the quantiles of data in columns of an $n \times m$ matrix for $n \geq 2$.

- **Statistics > Random Numbers** Produces a list of random numbers from one of several families of distribution functions. You specify the distribution, the size of the set, and appropriate parameters.

- **Statistics > Standard Deviation** Computes the square root of the variance of a data set, giving a measure of variation from the mean for data in a comma delimited list or in a vector, and calculates the standard deviations for columns of an $n \times m$ matrix for $n \geq 2$.

- **Statistics > Variance** Computes the sample variance for data in a comma delimited list or in a vector, and computes the sample variances for columns of an $n \times m$ matrix for $n \geq 2$. For a data set of size $n$, the sample variance is the sum of the squares of differences with the mean, divided by $n - 1$.

- **Transforms > Fourier** Computes the Fourier transform

$$\mathcal{F} (f (x), x, w) = \int_{-\infty}^{\infty} e^{-iwx} f (x) \, dx$$

of a function $f (x)$.

- **Transforms > Inverse Fourier** Computes the inverse Fourier transform of a function.

- **Transforms > Inverse Laplace** Finds the inverse Laplace transform of a function.

- **Transforms > Laplace** Computes the Laplace transform

$$\mathcal{L} (f (t), t, s) = \int_{0}^{\infty} e^{-st} f (t) \, dt$$

of a function $f (t)$. 

486
Vector Calculus > Curl  Computes the curl
\[ \nabla \times F = \left( \frac{\partial r}{\partial y} - \frac{\partial q}{\partial z} \right) \left( \frac{\partial p}{\partial z} - \frac{\partial r}{\partial x} \right) \left( \frac{\partial q}{\partial x} - \frac{\partial p}{\partial y} \right) \]
of a function \( F(x, y, z) = (p(x, y, z), q(x, y, z), r(x, y, z)) \).

Vector Calculus > Divergence  Computes the divergence
\[ \nabla \cdot F = \frac{\partial p}{\partial x} (a, b, c) + \frac{\partial q}{\partial y} (a, b, c) + \frac{\partial r}{\partial z} (a, b, c) \]
of a function \( F(x, y, z) = (p(x, y, z), q(x, y, z), r(x, y, z)) \).

Vector Calculus > Gradient  Computes the gradient \( \nabla f \) of a scalar function \( f(x_1, x_2, \ldots, x_n) \) of \( n \) variables.

Vector Calculus > Hessian  Compute the \( n \times n \) Hessian matrix \( \frac{\partial^2 f}{\partial x_i \partial x_j} \) of second partial derivatives of a scalar function \( f(x_1, x_2, \ldots, x_n) \) of \( n \) variables.

Vector Calculus > Jacobian  Computes the \( n \times n \) Jacobian matrix \( \frac{\partial f_i}{\partial x_j} \) of partial derivatives of the entries in a vector field \( (f_1(x_1, x_2, \ldots, x_n), f_2(x_1, x_2, \ldots, x_n), \ldots, f_n(x_1, x_2, \ldots, x_n)) \).

Vector Calculus > Laplacian  Computes the Laplacian
\[ \nabla^2 f = \nabla \cdot \nabla f = \nabla \cdot \left( \frac{\partial f}{\partial x} \frac{\partial f}{\partial y} \frac{\partial f}{\partial z} \right) = \frac{\partial^2 f}{\partial x^2} + \frac{\partial^2 f}{\partial y^2} + \frac{\partial^2 f}{\partial z^2} \]
of a scalar field \( f(x, y, z) \).

Vector Calculus > Scalar Potential  Computes the scalar potential or informs that such a function does not exist.

Vector Calculus > Set Basis Variables  Allows the user to enter a new set of basis variables.
Appendix A | Menus and Shortcuts for Doing Mathematics

- **Vector Calculus > Vector Potential** Computes the vector potential of a vector fields. The vector potential of a vector fields is a vector field whose curl is the given vector field.

- **Vector Calculus > Wronskian** Computes the Wronskian, the determinant of the $n \times n$ matrix $\begin{vmatrix} f_1(x) & f_2(x) & \cdots & f_n(x) \\ \end{vmatrix}$, of a vector field $(f_1(x), f_2(x), \ldots, f_n(x))$.

### Toolbar and Keyboard Shortcuts for Compute Menu

#### Math Toolbar and Keyboard Shortcuts

Toolips identify the buttons on the toolbars in the program window. To see the button name, hold the mouse pointer on a toolbar button for several seconds until the tooltip appears.

Following are Math Toolbar and keyboard shortcuts for commands on the Compute menu.

<table>
<thead>
<tr>
<th>Button</th>
<th>Compute Menu</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>? ? ?</td>
<td>Evaluate</td>
<td>Ctrl+e</td>
</tr>
<tr>
<td>? ? ?</td>
<td>Definitions &gt; New Definition</td>
<td>Ctrl+ =</td>
</tr>
<tr>
<td>? ? ?</td>
<td>Definitions &gt; Show Definitions</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Interpret</td>
<td>Ctrl+shift+/ or Ctrl+?</td>
</tr>
<tr>
<td>% ?</td>
<td>Solve &gt; Exact</td>
<td></td>
</tr>
<tr>
<td>% ?</td>
<td>Simplify</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Expand</td>
<td></td>
</tr>
<tr>
<td>? ? ?</td>
<td>Plot 2D &gt; Rectangular</td>
<td></td>
</tr>
<tr>
<td>? ? ?</td>
<td>Plot 3D &gt; Rectangular</td>
<td></td>
</tr>
</tbody>
</table>
Menus and Shortcuts for Entering Mathematics

Keyboard shortcuts are available for many common tasks. The keyboard shortcuts for performing basic mathematical operations and entering symbols, characters, and the most common mathematical objects are faster to use than the mouse. The lists on the following pages summarize shortcuts related specifically to entering mathematics. For many additional shortcuts, consult Creating Documents with Scientific WorkPlace and Scientific Word, Version 6 or choose Help and search for keyboard shortcuts.

We use standard computer conventions to give keyboard instructions. The names of keys in the instructions match the names shown on most keyboards. Ctrl (Windows) and Cmd (Mac) are synonymous, as are Enter (Windows) and Return (Mac). Names of keys are always shown in Windows format. Mac users should substitute Mac keys (e.g., Cmd and Return) as appropriate.

A plus sign (+) between the names of two keys indicates that you must press the first key and hold it down while you press the second key. For example, Ctrl+g means that you press and hold down the Ctrl key, press g, and then release both keys.

Entering mathematics is straightforward. Working right in the program window, you use familiar notation to enter mathematical characters, symbols, and objects into your document. Simple commands let you create displayed or inline mathematics.

Editing mathematics is equally straightforward. You can use standard clipboard and drag-and-drop operations to cut, copy, paste, and

Entering Mathematics and Text
Entering Mathematical Objects
Entering Symbols and Characters
Entering Units of Measure
delete selections. You can also use the search and replace features to locate or change mathematical information.

**Entering Mathematics and Text**

During information entry you are either entering text or mathematics, and the results obtained from keystrokes and other user interface actions will differ depending on whether you are entering text or math. Thus we refer to being in either text mode or math mode. The default state is text mode; it is easy to toggle between the two modes and it is also easy to determine what mode you are in.

When you toggle to mathematics, the Math/Text button changes to an “M” and the program

- Displays the insert point between brackets for mathematics.
- Interprets anything you type as mathematics, displaying it in red in the program window.
- Italicizes alphabetic characters and displays numbers upright.
- Automatically formats mathematical expressions, inserting correct spacing around operators such as + and relations such as =.
- Advances the insert point to the next mathematical object when you press the spacebar.

**To switch from text to mathematics from the keyboard**

- Press Ctrl+m.

Subsequent editing in math mode will continue until you press the spacebar at the end of math. Subsequent editing in text mode will enter text objects.

**To switch from text to mathematics from the Insert menu**

- Choose Insert > Math.

Subsequent editing will enter math objects.

**To switch from mathematics to text from the keyboard**

- Press Spacebar once or twice.
To switch from mathematics to text from the Insert menu

- Choose Insert > Text.

Subsequent editing will enter text objects.

Unless you actively change to mathematics, the program displays a “T” on the Standard toolbar.

To toggle between mathematics and text from the Standard Toolbar

- To toggle entry mode to Math, click the “T” on the standard toolbar.

The “T” changes to “M” and the insert point changes to red and appears between brackets. Subsequent editing will enter math objects.

- To toggle entry mode to Text, click the “M” on the standard toolbar.

The “M” changes to “T” and the insert point changes to black. Subsequent editing will enter text objects.

Entering Mathematical Objects

You can enter mathematical objects from the keyboard, from the Math toolbar, and from the Insert > Math Objects menu. The menu operation Insert > Math Objects has been used throughout the previous chapters. The keyboard and toolbar choices are summarized in the following tables.

Toolips identify the buttons on the toolbars in the program window. To install the Math toolbar, if it does not appear in your program window, choose View > Toolbars and check Math toolbar.

Tip

Expanding parentheses, brackets, and braces grow to an appropriate size, depending on what they enclose, such as fractions or matrices. Their use also tends to minimize errors associated with unbalanced fences.

To enter math objects from the Math toolbar or the keyboard

- Click the appropriate button, or

- Hold the Ctrl key down and press the indicated key
Appendix B | Menus and Shortcuts for Entering Mathematics

<table>
<thead>
<tr>
<th>Insert Menu</th>
<th>Button</th>
<th>Press Ctrl+key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Math Objects &gt; Fraction</td>
<td>□</td>
<td>/</td>
</tr>
<tr>
<td>Math Objects &gt; Radical</td>
<td>√□</td>
<td>r</td>
</tr>
<tr>
<td>Math Objects &gt; Superscript</td>
<td>N^x</td>
<td>h or up arrow</td>
</tr>
<tr>
<td>Math Objects &gt; Subscript</td>
<td>N_x</td>
<td>l or down arrow</td>
</tr>
<tr>
<td>Math Objects &gt; Brackets, [ ]</td>
<td>[□]</td>
<td>[</td>
</tr>
<tr>
<td>Math Objects &gt; Brackets, ( )</td>
<td>(□)</td>
<td>( or 9</td>
</tr>
<tr>
<td>Math Objects &gt; Brackets, { }</td>
<td>{□}</td>
<td>{</td>
</tr>
<tr>
<td>Math Objects &gt; Brackets, ⟨ ⟩</td>
<td>⟨□⟩</td>
<td>⟨</td>
</tr>
<tr>
<td>Math Objects &gt; Brackets,</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Math Objects &gt; Operators, ∑</td>
<td>∑</td>
<td>7</td>
</tr>
<tr>
<td>Math Objects &gt; Operators, ∫</td>
<td>∫</td>
<td>i or 8</td>
</tr>
<tr>
<td>Math Objects &gt; Unit Name</td>
<td>ft</td>
<td>lb</td>
</tr>
<tr>
<td>Math Objects &gt; Display</td>
<td>d</td>
<td></td>
</tr>
<tr>
<td>Math Objects &gt; Operators</td>
<td>∑∫</td>
<td></td>
</tr>
<tr>
<td>Math Objects &gt; Math Name</td>
<td>sin</td>
<td>cos</td>
</tr>
<tr>
<td>Math Objects &gt; Binomial</td>
<td>(□)</td>
<td></td>
</tr>
<tr>
<td>Math Objects &gt; Decoration</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Entering Symbols and Characters**

There are many useful symbols and characters that can be entered directly from the keyboard. The following table summarizes many of those that are commonly used in mathematics.

**To enter symbols and characters from the keyboard**

- Press Ctrl+k and press the key indicated in the following table.
### Entering Symbols and Characters

<table>
<thead>
<tr>
<th>To enter</th>
<th>Press Ctrl+k then press</th>
<th>To enter</th>
<th>Press Ctrl+k then press</th>
</tr>
</thead>
<tbody>
<tr>
<td>\rightarrow</td>
<td>1</td>
<td>\subseteq</td>
<td>c or &amp;</td>
</tr>
<tr>
<td>\uparrow</td>
<td>2</td>
<td>\vee</td>
<td>v</td>
</tr>
<tr>
<td>\leftarrow</td>
<td>3</td>
<td>\cdot</td>
<td>b</td>
</tr>
<tr>
<td>\downarrow</td>
<td>4</td>
<td>\nabla</td>
<td>n</td>
</tr>
<tr>
<td>\geq</td>
<td>5</td>
<td>\downarrow</td>
<td>$</td>
</tr>
<tr>
<td>\cap</td>
<td>6</td>
<td>\Rightarrow</td>
<td>!</td>
</tr>
<tr>
<td>\subseteq</td>
<td>7</td>
<td>\uparrow</td>
<td>@</td>
</tr>
<tr>
<td>\cup</td>
<td>8</td>
<td>\equiv</td>
<td>#</td>
</tr>
<tr>
<td>\emptyset</td>
<td>9 or 0 or ( or )</td>
<td>⊄</td>
<td>%</td>
</tr>
<tr>
<td>\equiv</td>
<td>-</td>
<td>\equiv</td>
<td>_</td>
</tr>
<tr>
<td>\neq</td>
<td>=</td>
<td>\pm</td>
<td>+</td>
</tr>
<tr>
<td>\approx</td>
<td>w</td>
<td>\Re</td>
<td>W</td>
</tr>
<tr>
<td>\in</td>
<td>e</td>
<td>\notin</td>
<td>E</td>
</tr>
<tr>
<td>\sqrt{□}</td>
<td>r or R</td>
<td>\infty</td>
<td>I</td>
</tr>
<tr>
<td>\times</td>
<td>t or T</td>
<td>\emptyset</td>
<td>P</td>
</tr>
<tr>
<td>\int</td>
<td>i</td>
<td>{□}</td>
<td>{ or }</td>
</tr>
<tr>
<td>\emptyset</td>
<td>o</td>
<td>\forall</td>
<td>A</td>
</tr>
<tr>
<td>\bigcap</td>
<td>p</td>
<td>\bigoplus</td>
<td>S</td>
</tr>
<tr>
<td>\bigcup</td>
<td>[ or ]</td>
<td>\circ</td>
<td>D</td>
</tr>
<tr>
<td>\angle</td>
<td>a</td>
<td>\div</td>
<td>X</td>
</tr>
<tr>
<td>\Sigma</td>
<td>s</td>
<td>\cdot</td>
<td>C</td>
</tr>
<tr>
<td>\partial</td>
<td>d</td>
<td>\land</td>
<td>V</td>
</tr>
<tr>
<td>\bigcirc</td>
<td>f or F</td>
<td>\neg</td>
<td>N</td>
</tr>
<tr>
<td>\mathbb{N}</td>
<td>h or H</td>
<td>\leq</td>
<td>&lt;</td>
</tr>
<tr>
<td>\mathbb{N}</td>
<td>l or L</td>
<td>\geq</td>
<td>&gt;</td>
</tr>
<tr>
<td>\times</td>
<td>x</td>
<td>\exists</td>
<td>z</td>
</tr>
</tbody>
</table>

Last matrix created \[ m | \begin{bmatrix} \text{□} & \square \\ \text{□} & \square \end{bmatrix} \] M
Appendix B | Menus and Shortcuts for Entering Mathematics

**To enter Greek Letters from the Keyboard**

1. Press and hold the control key down and type the letter g.
2. Release the control key and type a Roman letter corresponding to the desired Greek letter.

Lowercase Roman letters yield lower-case Greek. Uppercase Roman letters yield uppercase Greek. Many uppercase Roman letters agree exactly with their Greek equivalents, and for these, no Ctrl+g prefix is needed.

<table>
<thead>
<tr>
<th>To enter</th>
<th>Press Ctrl+g then press</th>
<th>To enter</th>
<th>Press Ctrl+g then press</th>
</tr>
</thead>
<tbody>
<tr>
<td>alpha</td>
<td>α</td>
<td>pi</td>
<td>π</td>
</tr>
<tr>
<td>beta</td>
<td>β</td>
<td>Pi</td>
<td>Π</td>
</tr>
<tr>
<td>gamma</td>
<td>γ</td>
<td>varpi</td>
<td>Ω</td>
</tr>
<tr>
<td>Gamma</td>
<td>Γ</td>
<td>rho</td>
<td>ρ</td>
</tr>
<tr>
<td>delta</td>
<td>δ</td>
<td>varrho</td>
<td>ρ</td>
</tr>
<tr>
<td>Delta</td>
<td>Δ</td>
<td>sigma</td>
<td>σ</td>
</tr>
<tr>
<td>varepsilon</td>
<td>ε</td>
<td>e</td>
<td>E</td>
</tr>
<tr>
<td>epsilon</td>
<td>ε</td>
<td>varsigma</td>
<td>ζ</td>
</tr>
<tr>
<td>zeta</td>
<td>ζ</td>
<td>z</td>
<td>t</td>
</tr>
<tr>
<td>eta</td>
<td>η</td>
<td>h</td>
<td>u</td>
</tr>
<tr>
<td>theta</td>
<td>θ</td>
<td>y</td>
<td>U</td>
</tr>
<tr>
<td>vartheta</td>
<td>θ</td>
<td>Z</td>
<td>ψ</td>
</tr>
<tr>
<td>Theta</td>
<td>Θ</td>
<td>Y</td>
<td>Φ</td>
</tr>
<tr>
<td>iota</td>
<td>ι</td>
<td>i</td>
<td>φ</td>
</tr>
<tr>
<td>kappa</td>
<td>κ</td>
<td>k</td>
<td>χ</td>
</tr>
<tr>
<td>varkappa</td>
<td>κ</td>
<td>K</td>
<td>ψ</td>
</tr>
<tr>
<td>lambda</td>
<td>λ</td>
<td>I</td>
<td>Ψ</td>
</tr>
<tr>
<td>Lambda</td>
<td>Λ</td>
<td>L</td>
<td>W</td>
</tr>
<tr>
<td>mu</td>
<td>μ</td>
<td>m</td>
<td>ω</td>
</tr>
<tr>
<td>nu</td>
<td>ν</td>
<td>n</td>
<td>F</td>
</tr>
<tr>
<td>xi</td>
<td>ξ</td>
<td>x</td>
<td>X</td>
</tr>
</tbody>
</table>

**Examples**

Type Ctrl+g, g for γ (lowercase gamma), Ctrl+g, G for Γ (uppercase gamma) and Ctrl+g, D for Δ. Note that the shortcut Ctrl+g, A does nothing, as A is already the symbol for the uppercase alpha.
The Greek characters are mapped to U.S. keyboards like this:

![Keyboard layout with Greek characters]

**Uppercase Greek**

**Lowercase Greek**

**To enter symbols and characters from the Symbols toolbar or Symbols sidebar**
- Click the symbol or character you want on the Symbol pane on the sidebar.
- Or
  1. Click the symbol palette you want on the Symbols toolbar.
  2. From the list of available symbols, click the symbol you want.

**To enter symbols and characters using TeX commands**
If you are very familiar with TeX and know the TeX command for an object or operation, you can enter it in a TeX field or, if you know the TeX name for a character or symbol, from the keyboard.

**To enter a TeX field**
- Choose Insert > Typeset Object > TeX Field.
- Type the TeX command in the dialog box.
Appendix B | Menus and Shortcuts for Entering Mathematics

To enter a character or symbol using its TeX name

1. Type Ctrl+space.

2. Type the character or symbol name without the leading backslash (\).

3. Press Enter.

TeX is case-sensitive. The TeX name for \( \delta \) is delta and the TeX name for \( \Delta \) is Delta. Choose Help > Index > General Reference and search on Keyboard Shortcuts for more information.

In addition to the Greek alphabet, here are a few other examples.

<table>
<thead>
<tr>
<th>Character or symbol</th>
<th>\TeX\ name</th>
<th>Character or symbol</th>
<th>\TeX\ name</th>
<th>Character or symbol</th>
<th>\TeX\ name</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \aleph )</td>
<td>aleph</td>
<td>( \ldots )</td>
<td>dots</td>
<td>( | )</td>
<td>parallel</td>
</tr>
<tr>
<td>( \angle )</td>
<td>angle</td>
<td>( \emptyset )</td>
<td>emptyset</td>
<td>( \partial )</td>
<td>partial</td>
</tr>
<tr>
<td>( \approx )</td>
<td>approx</td>
<td>( \varepsilon )</td>
<td>euro</td>
<td>( \pm )</td>
<td>pm</td>
</tr>
<tr>
<td>( \bot )</td>
<td>bot</td>
<td>( \exists )</td>
<td>exists</td>
<td>( \Pi )</td>
<td>prod</td>
</tr>
<tr>
<td>( \bullet )</td>
<td>bullet</td>
<td>( \forall )</td>
<td>forall</td>
<td>( \subset )</td>
<td>subset</td>
</tr>
<tr>
<td>( \cap )</td>
<td>cap</td>
<td>( \geq )</td>
<td>geq</td>
<td>( \Sigma )</td>
<td>sum</td>
</tr>
<tr>
<td>( \cdots )</td>
<td>cdot</td>
<td>( \infty )</td>
<td>infty</td>
<td>( \therefore )</td>
<td>therefore</td>
</tr>
<tr>
<td>( \cdot )</td>
<td>cdots</td>
<td>( \infty )</td>
<td>( \therefore )</td>
<td>( \times )</td>
<td>times</td>
</tr>
<tr>
<td>( \circ )</td>
<td>cents</td>
<td>( \int )</td>
<td>int</td>
<td>( \top )</td>
<td>top</td>
</tr>
<tr>
<td>( \circ )</td>
<td>circ</td>
<td>( \leq )</td>
<td>leq</td>
<td>( \vdots )</td>
<td>vdots</td>
</tr>
<tr>
<td>( \cong )</td>
<td>cong</td>
<td>( \mp )</td>
<td>mp</td>
<td>( \vee )</td>
<td>vee</td>
</tr>
<tr>
<td>( \cup )</td>
<td>cup</td>
<td>( \nabla )</td>
<td>nabla</td>
<td>( \wedge )</td>
<td>wedge</td>
</tr>
<tr>
<td>( \ddots )</td>
<td>ddots</td>
<td>( \neq )</td>
<td>ne</td>
<td></td>
<td></td>
</tr>
<tr>
<td>( \div )</td>
<td>div</td>
<td>( \notin )</td>
<td>notin</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Entering Units of Measure

Enter units of measure from the Insert menu or from the keyboard.

To enter units from the Insert menu

1. Choose Insert > Math objects > Unit Name.
2. When the Unit Name dialog box appears, select a measurement category and a unit, then click Apply.

Units are automatically recognized and can be entered from the keyboard. Following the general guidelines given below, and a table of unit prefixes, are tables giving specific keyboard shortcuts for each of the built-in physical quantities.

To enter units from the keyboard

2. Type ‘u’ followed by the unit symbol, with the exceptions:

   - Type ‘mc’ for ‘micro’ in place of μ which will appear in the unit symbol.
   - Type ‘ahr’ for the hour symbol h.
   - Type ‘uda’ for the day symbol d.
   - Type ‘use’ for the second symbol s.
   - Type ‘ume’ for the meter symbol m.
   - Type ‘uan’ for the angstrom symbol Å.
   - Type ‘uCo’ for the Coulomb symbol C.
   - Type ‘uTe’ for the Tesla symbol T.
   - Type ‘uli’ for the Liter symbol l.
   - Type ‘ohm’ (after the prefix) for the symbols for ohm (and its derivatives) Ω.
   - Type ‘ucel’ and ‘ufahr’ for degrees Celsius °C and degrees Fahrenheit °F, respectively.
   - Type ‘udeg’ for the degree symbol (plane angle) °.
   - Type ‘udmn’ and ‘uds’ for (degree) minute ’ and (degree) second ″, respectively.

Autorecognition is case sensitive, so type upper case where indicated. The unit symbol should turn green when you type the last character.
### Appendix B | Menus and Shortcuts for Entering Mathematics

#### Unit prefixes

<table>
<thead>
<tr>
<th>Prefix</th>
<th>Factor</th>
<th>Symbol</th>
<th>Prefix</th>
<th>Factor</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>kilo</td>
<td>$10^3$</td>
<td>$k$</td>
<td>milli</td>
<td>$10^{-3}$</td>
<td>$m$</td>
</tr>
<tr>
<td>mega</td>
<td>$10^6$</td>
<td>$M$</td>
<td>micro</td>
<td>$10^{-6}$</td>
<td>$\mu$ (mc)</td>
</tr>
<tr>
<td>giga</td>
<td>$10^9$</td>
<td>$G$</td>
<td>nano</td>
<td>$10^{-9}$</td>
<td>$n$</td>
</tr>
<tr>
<td>tera</td>
<td>$10^{12}$</td>
<td>$T$</td>
<td>pico</td>
<td>$10^{-12}$</td>
<td>$p$</td>
</tr>
<tr>
<td>peta</td>
<td>$10^{15}$</td>
<td>$P$</td>
<td>femto</td>
<td>$10^{-15}$</td>
<td>$f$</td>
</tr>
<tr>
<td>exa</td>
<td>$10^{18}$</td>
<td>$E$</td>
<td>atto</td>
<td>$10^{-18}$</td>
<td>$a$</td>
</tr>
</tbody>
</table>

#### Activity

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Becquerel</td>
<td>Bq</td>
<td>uBq</td>
</tr>
<tr>
<td>Curie</td>
<td>Ci</td>
<td>uCi</td>
</tr>
</tbody>
</table>

#### Amount of substance

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attomole</td>
<td>amol</td>
<td>umamol</td>
</tr>
<tr>
<td>Examole</td>
<td>Emol</td>
<td>uEmol</td>
</tr>
<tr>
<td>Femtomole</td>
<td>fmol</td>
<td>ufmol</td>
</tr>
<tr>
<td>Gigamole</td>
<td>Gmol</td>
<td>uGmol</td>
</tr>
<tr>
<td>Kilomole</td>
<td>kmol</td>
<td>ukmol</td>
</tr>
<tr>
<td>Megamole</td>
<td>Mmol</td>
<td>uMmol</td>
</tr>
<tr>
<td>Micromole</td>
<td>(\mu\text{mol})</td>
<td>umcmol</td>
</tr>
<tr>
<td>Millimole</td>
<td>mmol</td>
<td>ummol</td>
</tr>
<tr>
<td>Mole</td>
<td>mol</td>
<td>umol</td>
</tr>
<tr>
<td>Nanomole</td>
<td>nmol</td>
<td>unnmol</td>
</tr>
<tr>
<td>Petamole</td>
<td>Pmol</td>
<td>upmol</td>
</tr>
<tr>
<td>Picomole</td>
<td>pmol</td>
<td>uppmol</td>
</tr>
<tr>
<td>Teramole</td>
<td>Tmol</td>
<td>utmol</td>
</tr>
</tbody>
</table>

#### Area

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acre</td>
<td>acre</td>
<td>uacre</td>
</tr>
<tr>
<td>Hectare</td>
<td>hectare</td>
<td>uhectare</td>
</tr>
<tr>
<td>Square foot</td>
<td>(\text{ft}^2)</td>
<td>u\text{ft} (insert exponent)</td>
</tr>
<tr>
<td>Square inch</td>
<td>(\text{in}^2)</td>
<td>u\text{in} (insert exponent)</td>
</tr>
<tr>
<td>Square meter</td>
<td>(\text{m}^2)</td>
<td>u\text{m} (insert exponent)</td>
</tr>
</tbody>
</table>

#### Tip

To enter units such as \(\text{ft}^2\), \(\text{ft}^3\), \(\text{in}^2\), \(\text{in}^3\), \(\text{m}^2\), and \(\text{m}^3\), type the unit symbol and then choose Insert > Math Objects > Superscript and type the appropriate number.
## Entering Units of Measure

### Current

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ampere</td>
<td>A</td>
<td>uA</td>
</tr>
<tr>
<td>Kiloampere</td>
<td>kA</td>
<td>ukA</td>
</tr>
<tr>
<td>Microampere</td>
<td>μA</td>
<td>umcA</td>
</tr>
<tr>
<td>Milliampere</td>
<td>mA</td>
<td>umA</td>
</tr>
<tr>
<td>Nanoampere</td>
<td>nA</td>
<td>unA</td>
</tr>
</tbody>
</table>

### Electric capacitance

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Farad</td>
<td>F</td>
<td>uF</td>
</tr>
<tr>
<td>Microfarad</td>
<td>μF</td>
<td>umcF</td>
</tr>
<tr>
<td>Millifarad</td>
<td>mF</td>
<td>umF</td>
</tr>
<tr>
<td>Nanofarad</td>
<td>nF</td>
<td>unF</td>
</tr>
<tr>
<td>Picofarad</td>
<td>pF</td>
<td>upF</td>
</tr>
</tbody>
</table>

### Electric charge

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Coulomb</td>
<td>C</td>
<td>uCo</td>
</tr>
</tbody>
</table>

### Electric conductance

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Kilosiemens</td>
<td>kS</td>
<td>ukS</td>
</tr>
<tr>
<td>Microsiemens</td>
<td>μS</td>
<td>umcS</td>
</tr>
<tr>
<td>Millisiemens</td>
<td>mS</td>
<td>umS</td>
</tr>
<tr>
<td>Siemens</td>
<td>S</td>
<td>uS</td>
</tr>
</tbody>
</table>

### Electrical potential difference

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Kilovolt</td>
<td>kV</td>
<td>ukV</td>
</tr>
<tr>
<td>Megavolt</td>
<td>MV</td>
<td>uMV</td>
</tr>
<tr>
<td>Microvolt</td>
<td>μV</td>
<td>umcV</td>
</tr>
<tr>
<td>Millivolt</td>
<td>mV</td>
<td>umV</td>
</tr>
<tr>
<td>Nanovolt</td>
<td>nV</td>
<td>unV</td>
</tr>
<tr>
<td>Picovolt</td>
<td>pV</td>
<td>upV</td>
</tr>
<tr>
<td>Volt</td>
<td>V</td>
<td>uV</td>
</tr>
</tbody>
</table>
### Electric resistance

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gigaohm</td>
<td>GΩ</td>
<td>uGohm</td>
</tr>
<tr>
<td>Kiloohm</td>
<td>kΩ</td>
<td>ukohm</td>
</tr>
<tr>
<td>Megaohm</td>
<td>MΩ</td>
<td>uMohm</td>
</tr>
<tr>
<td>Milliohm</td>
<td>mΩ</td>
<td>umohm</td>
</tr>
<tr>
<td>Ohm</td>
<td>Ω</td>
<td>uohm</td>
</tr>
</tbody>
</table>

### Energy

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>British thermal unit</td>
<td>Btu</td>
<td>uBtu</td>
</tr>
<tr>
<td>Calorie</td>
<td>cal</td>
<td>ucal</td>
</tr>
<tr>
<td>Electron volt</td>
<td>eV</td>
<td>ueV</td>
</tr>
<tr>
<td>Erg</td>
<td>erg</td>
<td>uerg</td>
</tr>
<tr>
<td>Gigaelectronvolt</td>
<td>GeV</td>
<td>uGeV</td>
</tr>
<tr>
<td>Gigajoule</td>
<td>GJ</td>
<td>uGJ</td>
</tr>
<tr>
<td>Joule</td>
<td>J</td>
<td>uJ</td>
</tr>
<tr>
<td>Kilocalorie</td>
<td>kcal</td>
<td>ukcal</td>
</tr>
<tr>
<td>Kilojoule</td>
<td>kJ</td>
<td>ukJ</td>
</tr>
<tr>
<td>Megaelectronvolt</td>
<td>MeV</td>
<td>uMeV</td>
</tr>
<tr>
<td>Megajoule</td>
<td>MJ</td>
<td>uMJ</td>
</tr>
<tr>
<td>Microjoule</td>
<td>μJ</td>
<td>umcJ</td>
</tr>
<tr>
<td>Millijoule</td>
<td>mJ</td>
<td>umJ</td>
</tr>
<tr>
<td>Nanojoule</td>
<td>nJ</td>
<td>unJ</td>
</tr>
</tbody>
</table>

### Force

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dyne</td>
<td>dyn</td>
<td>udyn</td>
</tr>
<tr>
<td>Kilonewton</td>
<td>kN</td>
<td>ukN</td>
</tr>
<tr>
<td>Meganewton</td>
<td>MN</td>
<td>uMN</td>
</tr>
<tr>
<td>Micronewton</td>
<td>μN</td>
<td>umcN</td>
</tr>
<tr>
<td>Millinewton</td>
<td>mN</td>
<td>umN</td>
</tr>
<tr>
<td>Newton</td>
<td>N</td>
<td>uN</td>
</tr>
<tr>
<td>Ounce-force</td>
<td>ozf</td>
<td>uozf</td>
</tr>
<tr>
<td>Pound-force</td>
<td>lbf</td>
<td>ulbf</td>
</tr>
</tbody>
</table>
### Entering Units of Measure

#### Frequency

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exahertz</td>
<td>EH:</td>
<td>uEHz</td>
</tr>
<tr>
<td>Gigahertz</td>
<td>GH:</td>
<td>uGHz</td>
</tr>
<tr>
<td>Hertz</td>
<td>Hz</td>
<td>uHz</td>
</tr>
<tr>
<td>Kilohertz</td>
<td>kHz</td>
<td>ukHz</td>
</tr>
<tr>
<td>Megahertz</td>
<td>MH:</td>
<td>uMHz</td>
</tr>
<tr>
<td>Petahertz</td>
<td>PH:</td>
<td>uPHz</td>
</tr>
<tr>
<td>Terahertz</td>
<td>THz</td>
<td>uTHz</td>
</tr>
</tbody>
</table>

#### Illuminance

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Footcandle</td>
<td>fc</td>
<td>ufc</td>
</tr>
<tr>
<td>Lux</td>
<td>lx</td>
<td>ulx</td>
</tr>
<tr>
<td>Phot</td>
<td>phot</td>
<td>uphot</td>
</tr>
</tbody>
</table>

#### Length

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ångström</td>
<td>Å</td>
<td>uan</td>
</tr>
<tr>
<td>Attometer</td>
<td>am</td>
<td>uame</td>
</tr>
<tr>
<td>Centimeter</td>
<td>cm</td>
<td>ucm</td>
</tr>
<tr>
<td>Decimeter</td>
<td>dm</td>
<td>udme</td>
</tr>
<tr>
<td>Femtometer</td>
<td>fm</td>
<td>ufme</td>
</tr>
<tr>
<td>Foot</td>
<td>ft</td>
<td>uft</td>
</tr>
<tr>
<td>Inch</td>
<td>in</td>
<td>uin</td>
</tr>
<tr>
<td>Kilometer</td>
<td>km</td>
<td>ukme</td>
</tr>
<tr>
<td>Meter</td>
<td>m</td>
<td>ume</td>
</tr>
<tr>
<td>Micrometer</td>
<td>μm</td>
<td>umcme</td>
</tr>
<tr>
<td>Mile</td>
<td>mi</td>
<td>umi</td>
</tr>
<tr>
<td>Millimeter</td>
<td>mm</td>
<td>umme</td>
</tr>
<tr>
<td>Nanometer</td>
<td>nm</td>
<td>unme</td>
</tr>
<tr>
<td>Picometer</td>
<td>pm</td>
<td>upme</td>
</tr>
</tbody>
</table>

#### Luminance

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stilb</td>
<td>sb</td>
<td>usb</td>
</tr>
</tbody>
</table>

#### Luminous flux

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lumen</td>
<td>lm</td>
<td>ulm</td>
</tr>
</tbody>
</table>
Appendix B | Menus and Shortcuts for Entering Mathematics

### Luminous intensity

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Candela</td>
<td>cd</td>
<td>ucd</td>
</tr>
</tbody>
</table>

### Magnetic flux

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maxwell</td>
<td>Mx</td>
<td>uMx</td>
</tr>
<tr>
<td>Microweber</td>
<td>μWb</td>
<td>umcWb</td>
</tr>
<tr>
<td>Milliweber</td>
<td>mWb</td>
<td>umWb</td>
</tr>
<tr>
<td>Nanoweber</td>
<td>nWb</td>
<td>unWb</td>
</tr>
<tr>
<td>Weber</td>
<td>Wb</td>
<td>uWb</td>
</tr>
</tbody>
</table>

### Magnetic flux density

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gauss</td>
<td>G</td>
<td>uGa</td>
</tr>
<tr>
<td>Microtesla</td>
<td>μT</td>
<td>umcT</td>
</tr>
<tr>
<td>Millitesla</td>
<td>mT</td>
<td>umT</td>
</tr>
<tr>
<td>Nanotesla</td>
<td>nT</td>
<td>unT</td>
</tr>
<tr>
<td>Picotesla</td>
<td>pT</td>
<td>upT</td>
</tr>
<tr>
<td>Tesla</td>
<td>T</td>
<td>uTe</td>
</tr>
</tbody>
</table>

### Magnetic inductance

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Henry</td>
<td>H</td>
<td>uHe</td>
</tr>
<tr>
<td>Microhenry</td>
<td>μH</td>
<td>umcH</td>
</tr>
<tr>
<td>Millihenry</td>
<td>mH</td>
<td>umH</td>
</tr>
</tbody>
</table>

### Mass

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Atomic mass unit</td>
<td>u</td>
<td>uu</td>
</tr>
<tr>
<td>Centigram</td>
<td>cg</td>
<td>ucg</td>
</tr>
<tr>
<td>Decigram</td>
<td>dg</td>
<td>udg</td>
</tr>
<tr>
<td>Gram</td>
<td>g</td>
<td>ugr</td>
</tr>
<tr>
<td>Kilogram</td>
<td>kg</td>
<td>ukg</td>
</tr>
<tr>
<td>Microgram</td>
<td>μg</td>
<td>umcg</td>
</tr>
<tr>
<td>Milligram</td>
<td>mg</td>
<td>umg</td>
</tr>
<tr>
<td>Pound-mass</td>
<td>lb</td>
<td>ulbm</td>
</tr>
<tr>
<td>Slug</td>
<td>slug</td>
<td>uslug</td>
</tr>
</tbody>
</table>
### Plane angle

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Degree</td>
<td>°</td>
<td>udeg</td>
</tr>
<tr>
<td>Microradian</td>
<td>µrad</td>
<td>umcrad</td>
</tr>
<tr>
<td>Milliradian</td>
<td>mrad</td>
<td>umrad</td>
</tr>
<tr>
<td>Minute</td>
<td>′</td>
<td>udmn</td>
</tr>
<tr>
<td>Radian</td>
<td>rad</td>
<td>urad</td>
</tr>
<tr>
<td>Second</td>
<td>″</td>
<td>uds</td>
</tr>
</tbody>
</table>

### Power

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gigawatt</td>
<td>GW</td>
<td>uGWa</td>
</tr>
<tr>
<td>Horsepower</td>
<td>hp</td>
<td>uhp</td>
</tr>
<tr>
<td>Kilowatt</td>
<td>kW</td>
<td>ukWa</td>
</tr>
<tr>
<td>Megawatt</td>
<td>MW</td>
<td>uMWa</td>
</tr>
<tr>
<td>Microwatt</td>
<td>µW</td>
<td>umcWa</td>
</tr>
<tr>
<td>Milliwatt</td>
<td>mW</td>
<td>umWa</td>
</tr>
<tr>
<td>Nanowatt</td>
<td>nW</td>
<td>unWa</td>
</tr>
<tr>
<td>Watt</td>
<td>W</td>
<td>uWa</td>
</tr>
</tbody>
</table>

### Pressure

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Atmosphere</td>
<td>atm</td>
<td>uatm</td>
</tr>
<tr>
<td>Bar</td>
<td>bar</td>
<td>ubar</td>
</tr>
<tr>
<td>Kilobar</td>
<td>kbar</td>
<td>ukbar</td>
</tr>
<tr>
<td>Kilopascal</td>
<td>kPa</td>
<td>ukPa</td>
</tr>
<tr>
<td>Megapascal</td>
<td>MPa</td>
<td>uMPa</td>
</tr>
<tr>
<td>Micropascal</td>
<td>µPa</td>
<td>umcPa</td>
</tr>
<tr>
<td>Millibar</td>
<td>mbar</td>
<td>umbar</td>
</tr>
<tr>
<td>Mercury</td>
<td>mmHg</td>
<td>ummHg</td>
</tr>
<tr>
<td>Pascal</td>
<td>Pa</td>
<td>uPa</td>
</tr>
<tr>
<td>Torr</td>
<td>torr</td>
<td>utorr</td>
</tr>
</tbody>
</table>

### Solid angle

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Steradian</td>
<td>sr</td>
<td>usr</td>
</tr>
</tbody>
</table>
Appendix B | Menus and Shortcuts for Entering Mathematics

### Temperature

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Celsius</td>
<td>°C</td>
<td>\texttt{ucel}</td>
</tr>
<tr>
<td>Fahrenheit</td>
<td>°F</td>
<td>\texttt{ufahr}</td>
</tr>
<tr>
<td>Kelvin</td>
<td>K</td>
<td>\texttt{uK}</td>
</tr>
</tbody>
</table>

### Time

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attosecond</td>
<td>as</td>
<td>\texttt{uas}</td>
</tr>
<tr>
<td>Day</td>
<td>d</td>
<td>\texttt{uda}</td>
</tr>
<tr>
<td>Femtosecond</td>
<td>fs</td>
<td>\texttt{ufs}</td>
</tr>
<tr>
<td>Hour</td>
<td>h</td>
<td>\texttt{uhr}</td>
</tr>
<tr>
<td>Microsecond</td>
<td>μs</td>
<td>\texttt{umcs}</td>
</tr>
<tr>
<td>Millisecond</td>
<td>ms</td>
<td>\texttt{ums}</td>
</tr>
<tr>
<td>Minute</td>
<td>min</td>
<td>\texttt{umn}</td>
</tr>
<tr>
<td>Nanosecond</td>
<td>ns</td>
<td>\texttt{uns}</td>
</tr>
<tr>
<td>Picosecond</td>
<td>ps</td>
<td>\texttt{ups}</td>
</tr>
<tr>
<td>Second</td>
<td>s</td>
<td>\texttt{use}</td>
</tr>
<tr>
<td>Year</td>
<td>y</td>
<td>\texttt{uy}</td>
</tr>
</tbody>
</table>

### Volume

<table>
<thead>
<tr>
<th>To enter</th>
<th>Unit Symbol</th>
<th>In Math, type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cubic foot</td>
<td>ft(^3)</td>
<td>\texttt{uft} (insert exponent)</td>
</tr>
<tr>
<td>Cubic inch</td>
<td>in(^3)</td>
<td>\texttt{umin} (insert exponent)</td>
</tr>
<tr>
<td>Cubic meter</td>
<td>m(^3)</td>
<td>\texttt{um} (insert exponent)</td>
</tr>
<tr>
<td>Gallon (US)</td>
<td>gal</td>
<td>\texttt{ugal}</td>
</tr>
<tr>
<td>Liter</td>
<td>l</td>
<td>\texttt{uli}</td>
</tr>
<tr>
<td>Milliliter</td>
<td>ml</td>
<td>\texttt{uml}</td>
</tr>
<tr>
<td>Pint</td>
<td>pint</td>
<td>\texttt{upint}</td>
</tr>
<tr>
<td>Quart</td>
<td>qt</td>
<td>\texttt{uqt}</td>
</tr>
</tbody>
</table>
Customizing the Program for Computing

Wherever there is number, there is beauty.  Proclus Diadochus (412–485)

The program window has an updated look with streamlined layouts for the toolbars and symbol panels. As before, a mouse-activated tooltip gives the name of each toolbar button and panel symbol. Most tools work the same way they did in earlier versions. The Version 6 system offers a number of ways to customize its features.

Use Preferences in the Tools menu to customize the universal and local settings. The Computation choices replace the previous Computation Setup and Engine Setup. You will find some new features in these dialogs.

You can define automatic substitution sequences for text and mathematics, thus speeding the entry of the text and mathematical expressions you use most often with an enhanced automatic substitution feature.

You can enter content quickly with fragments. With Version 6 you can create fragments containing XHTML code, TeX code, graphics, or anything else that can go on the clipboard. Fragments are no longer limited to TeX strings. Fragments and many other text editing shortcuts are documented in the manual Creating Documents with Scientific WorkPlace and Scientific Word, as well as in the Help.
Appendix C | Customizing the Program for Computing

Customizing the Toolbars

The Version 6 program window has three customizable toolbars.

- The Standard toolbar contains buttons for invoking common file operations and the text boxes for tag lists.
- The Editing toolbar buttons invoke ordinary editing tools.
- The Math toolbar buttons insert mathematical objects directly into your document or open dialog boxes so that you can make additional specifications. Certain buttons invoke common computational operations.

The Symbol toolbar has palettes of buttons for adding a wide variety of symbols to your documents. With the exception of those on the Symbol toolbar, the buttons on the toolbars are identical in function to commands on the menus. Point the mouse at each toolbar button for a few seconds to display a brief tooltip that identifies the button. As with menu commands, buttons that appear dimmed are unavailable.

The default screen displays the first three of these toolbars.

To add or remove toolbars
1. Choose View > Toolbars.
2. Check or uncheck the desired toolbars.

To customize a toolbar
1. Place the insert point in one of the toolbars and click the right button.
2. Choose Customize Toolbars.
3. Click and drag buttons from the panel to a toolbar.

With the Customize toolbar dialog box open, you can also add a new toolbar, restore the default set of toolbars, drag a button to a different position on a toolbar, or drag a button from one toolbar to another. You can show icons only, icons and text, or text only. The icons can be small or normal.
Customizing the Sidebars

The Version 6 sidebars display several palettes that make document editing easier. You can toggle the display of sidebars on either side of the document window, and you can choose which palettes to display in either sidebar using the Add drop-down menu.

You can toggle the display of either sidebar. Note the small graphic on the inside border of each, containing two arrowheads separated by a column of dots. Click this graphic to toggle the sidebar display. You can also toggle the sidebar display from the View menu.

Customizing the Compute Settings

Choose Tools > Preferences > Computation to change default behavior for Scope, Input, Output, Matrices, Derivatives, Entities, and Engine. Mac users choose SWPPro > Preferences > Computation.

Scope

When Default is chosen, the settings apply to all documents. With Scope set to This Document Only, the settings specified apply only to the open document.

Input

On the Input page, you can customize notation that activates several behaviors.

Base of Log

The default interpretation for log\(x\) is the same as ln\(x\), namely the natural logarithm with base \(e\). You can uncheck this option, so that log\(x\) = log\(_{10}\)\(x\).

Dot Accent

There are several different notation recognized for a derivative. (See Chapter 7 “Calculus” for a description of these.) The default includes the use of Newton’s notation for differentiation, also called the dot notation, placing a dot over the function name to represent a derivative. If \(x = f(t)\), then \(\dot{x}\) and \(\ddot{x}\) represent the first and second derivative, respectively, of \(x\) with respect to \(t\). This notation is common in physics and other applied mathematics. You can uncheck this option.
Appendix C | Customizing the Program for Computing

Bar Accent

The use of a bar over a complex expression is commonly used to denote the complex conjugate: if \( a \) and \( b \) are real numbers, then \( \overline{a + ib} = a - ib \). You can use this notation or disable it. An asterisk is also used for this purpose: if \( a \) and \( b \) are real numbers, then \( (a + ib)^* = a - ib \).

The imaginary unit can be denoted either by the letter \( i \), or \( i \) (ImaginaryI).

In electrical engineering and related fields, the imaginary unit is often denoted by \( j \) to avoid confusion with electrical current. The Python programming language also uses \( j \) to denote the imaginary unit. MATLAB associates both \( i \) and \( j \) with the imaginary unit. You can set \( j \) as the default notation for the imaginary unit.

The number \( e \) can be denoted either by the letter \( e \), or as \( e \) (ExponentialE).

Output

The appearance of mathematical expressions produced as the result of a computation can be customized.

Scientific Notation Output

Numbers with many digits are often presented in scientific notation, such as the speed of light in a vacuum \( 2.99792458 \times 10^8 \text{ m/s} \). You can set numbers for Digits Rendered (the number of digits displayed), the Upper threshold (digits to the left of the decimal before switching to scientific notation) and Lower threshold (zeros to the right of the decimal before switching to scientific notation).

Rational Numbers

You can reset the system so that fractions resulting from a computation are presented as mixed numbers, yielding computations such as \( 4\frac{2}{3} + 5\frac{1}{4} = 9\frac{11}{12} \). The default is for computations to result in, possibly improper, fractions: \( 4\frac{2}{3} + 5\frac{1}{4} = \frac{119}{12} \).

Trigonometric Functions

Scientific WorkPlace and Scientific Notebook recognize two types of functions—ordinary functions and trigtype functions. The distinction is that the argument of an ordinary function is always enclosed
in parentheses and the argument of a trigtype function often is not. If you check Use Parentheses for Trig Functions, then computations will produce trigonometric functions with parentheses enclosing the argument. See Trigtype Functions, page 122, for a complete list of trigtype functions and other details.

Inverse trigonometric and hyperbolic functions have two possible notations, \( \sin^{-1} x = \arcsin x \) for example, and both are used by default. You can disable the use of the “arc” prefix for inverse functions by unchecking the option Use “arc” prefix for inverse Trig Functions.

**Matrices**

You can reset the default matrix delimiter. The original default is square brackets.

**Default matrix delimiter**

The choices for default matrix delimiter are None, square brackets, and parentheses.

**Derivatives**

There are many choices of notation for derivatives. These settings can guarantee a uniform choice for output. The factory default is to use notation that agrees with the input.

**Derivative Output Notation**

The choices for Derivative Output Notation are input notation, \( \frac{d}{dx}, D \), primes, and dots.

**Derivatives as Primes**

The usual notation for higher derivatives is \( f^{(n)}(x) \). This setting lets you designate for which \( n \) the system switches from prime notation to the \( (n) \) notation. A setting of 4, for example, gives the sequence of notations \( f, f', f'', f''' \), \( f^{(4)} \), \( f^{(5)} \), ...

**Prime Notation**

By default, a prime after a function name means derivative. You can uncheck this option and disable it.

**Entities**

These settings allow you to change the appearance of several entities that result from a computation.

**Imaginary i Output**

Set the output for the imaginary unit as \( i, j, \) or \( \hat{i} \) (Imaginaryi).
Appendix C | Customizing the Program for Computing

**Differential $D$ Output**
Reset the output for the differential $D$ as $D$ (CapitalDifferentialD).

**Differential $d$ Output**
Reset the output for the differential $d$ as $d$ (DifferentialD).

**Exponential $e$ Output**
Reset the output for the exponential $e$ as $e$ (ExponentialE).

**Engine**

**Engine on**
The default is for the engine to be on. If you wish to temporarily disable the computation engine, simply uncheck Engine on. (When editing a large document, some activities are faster with the engine off.)

**Digits**
This setting determines the number of digits employed in computations. Set the number higher for increased accuracy, and lower for increased computation speed.

**Solve Options**
These options determine the appearance of solutions to equations.

**Maximum Degree**
For many polynomial equations of degree greater than 4, explicit solutions in terms of radicals do not exist. In these cases, implicit solutions are given in terms of roots of a polynomial. When the equation is a polynomial equation with degree 3 or 4, the explicit solution can be very complicated—and too large to preview, print, or save. To avoid this complication, you can set the engine to return solutions that are not rational solutions in implicit form for smaller degree polynomials as well.

See Equations With One Variable, page 53, for examples.

**Principal Value Only**
Use this setting to get simplified solutions. For example, the default for Solve > Exact applied to $\sin x = \frac{1}{2}$ returns the complete solution
\[
\left\{ \frac{1}{6} \pi + 2\pi k \mid k \in \mathbb{Z} \right\} \cup \left\{ \frac{5}{6} \pi + 2\pi k \mid k \in \mathbb{Z} \right\}
\]
With Principal Value Only checked, the solution returned is

\[ \frac{1}{6} \pi \]

**Ignore Special Cases**

Use this setting to get simplified solutions. For example, the default for Solve > Exact applied to \( e^x = y \) (variable \( x \)) returns the solution

\[
\begin{align*}
\{ & \ln y + 2i\pi k \mid k \in \mathbb{Z} \} \quad \text{if } y \neq 0 \\
& \emptyset \quad \text{if } y = 0
\end{align*}
\]

With Ignore Special Cases checked, the solution returned is

\[ \{\ln y + 2i\pi k \mid k \in \mathbb{Z}\} \]

Note that with both Ignore Special Cases and Principal Value Only checked the solution returned is simply \( \ln y \).

**Debugging**

You can investigate possible syntax errors in mathematics being sent to or returned by the computing engine by creating logs of the process.

**Customizing the Plot Settings**

Choose Tools > Preferences > Plots to change the settings for Axes, Layout, Labelling, and View.

**Axes**

The Axes Scaling options are Linear, Lin Log, Log Lin, and Log Log. The option Lin Log uses linear scaling along the horizontal axis and logarithmic scaling along the vertical axis. Log Lin uses logarithmic scaling along the horizontal axis and linear scaling along the vertical axis.

Check Equal Scaling Along Each Axis for plotting geometric objects, such as circles, where you want the scaling to be the same on both axes.

You can change the axis labels to other letters of names. The Axis Tick Marks can be None, Low, Normal, or High. Arrow tips at the positive ends of the axes can be turned on or off. You can turn on Grid Line for 2D plots.

The Axes Type choices are Not Specified, Automatic, Normal, Boxed, Frame, or None.
Appendix C | Customizing the Program for Computing

Layout
You can change the Default Size for New Plots in Pixels (1 in = 75 Pixels).

The Default Placement for New Plots choices are In line, Displayed, or Floating. Floating plots can be placed at the Top of page, Bottom of page, On a page of floats, Here, or Force Here. The placement can be Left, Right, Inside, Outside, or Full width.

View
Set the Background color by choosing from a color from the Basic colors or by entering numeric values. For 3D plots, you can check Orthogonal projection, Keep up vector, or Use default view intervals. You can also set the Initial View Intervals.

Automatic Substitution
You can create your own names for variables and functions that will be automatically recognized.

To recognize *bob* as the variable Robert
2. Type *bob* in the Keystrokes box
3. Choose Type of Substitution: Simple substitution.
5. Choose Enable or Disable Auto Substitution: In Math.
6. Leave the insert point in the Substitution entry box.
7. Choose Insert > Math Objects > Math Name.
8. Type Robert in the Name box.
9. Choose Name Type: Variable.
10. Check This is an engine string.
11. Check Add automatic substitution.
12. Choose Apply. (The name 'Robert' should appear in the Substitution Box in the Automatic Substitution box.)
13. In the Automatic Substitution dialog, choose Save.

**Compute > Definitions > New Definition**

(In mathematics, type bob.)

Robert = 17

**Compute > Evaluate**

Robert² = 289

For additional examples and information about automatic substitution, see Automatic Substitution, page 102, choose Help > Search, or consult the manual *Creating Documents with Scientific WorkPlace and Scientific Word.*
Constants and functions are available either as items on the Compute menu or through evaluating mathematical expressions. There are also many built-in functions and expressions. MuPAD equivalents are given for all of these and, where needed, a brief description of the constant, function, or expression.

The two menu items Compute > Definitions > Define MuPAD Name and Compute > Passthru to Engine offer additional ways to take advantage of the computational capabilities of MuPAD. This appendix concludes with a brief discussion of each of these items.

Constants

Common constants can be expressed in ordinary mathematical notation. See page 507 in Appendix C “Customizing the Program for Computing” for some choices for the appearance of some of the constants.

If a name such as gamma does not automatically gray when typed in mathematics, then choose Insert > Math Objects > Math Name and select or type the name.
Appendix D | MuPAD Functions and Expressions

<table>
<thead>
<tr>
<th>SWP/SNB</th>
<th>MuPAD</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>e</td>
<td>exp(1) or E</td>
<td>base of natural logs</td>
</tr>
<tr>
<td>i or j (see page 89)</td>
<td>I</td>
<td>imaginary unit: $\sqrt{-1}$</td>
</tr>
<tr>
<td>π</td>
<td>PI</td>
<td>circular constant</td>
</tr>
<tr>
<td>gamma</td>
<td>EULER</td>
<td></td>
</tr>
<tr>
<td>$\infty$</td>
<td>infinity</td>
<td>positive real infinity</td>
</tr>
<tr>
<td>true</td>
<td>TRUE</td>
<td>Boolean true</td>
</tr>
<tr>
<td>false</td>
<td>FALSE</td>
<td>Boolean false</td>
</tr>
</tbody>
</table>

FAIL or undecidable
This is the translation for MuPAD’s FAIL, UNKNOWN, or UNDEFINED. Either the answer cannot be determined or a nonexistent function was used.

Compute Menu Items

Following is a summary of Compute menu items and the equivalent functions or procedure in MuPAD. Items marked with $\mu$ are programmed, generally using several MuPAD functions and procedures.

Other MuPAD functions can be used by choosing Compute > Definitions > Define MuPAD Name and with Compute > Passthru Code to Engine (see Chapter 5 “Function Definitions”).

<table>
<thead>
<tr>
<th>Compute</th>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Evaluate</td>
<td>eval</td>
</tr>
<tr>
<td>Evaluate Numeric</td>
<td>float</td>
</tr>
<tr>
<td>Simplify</td>
<td>simplify</td>
</tr>
<tr>
<td>Factor</td>
<td>factor</td>
</tr>
<tr>
<td>Factor</td>
<td>ifactor</td>
</tr>
<tr>
<td>Expand</td>
<td>expand</td>
</tr>
<tr>
<td>Check Equality</td>
<td>testeq</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Compute &gt; Combine</th>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exponentials</td>
<td>combine</td>
</tr>
<tr>
<td>Logs</td>
<td>combine</td>
</tr>
<tr>
<td>Powers</td>
<td>simplify</td>
</tr>
<tr>
<td>Trig Functions</td>
<td>simplify</td>
</tr>
<tr>
<td>Arctan</td>
<td>combine</td>
</tr>
<tr>
<td>Hyperbolic Trig Functions</td>
<td>combine</td>
</tr>
</tbody>
</table>
### Compute Menu Items

<table>
<thead>
<tr>
<th>Compute &gt; Rewrite</th>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rational</td>
<td>numeric::rationalize</td>
</tr>
<tr>
<td>Float</td>
<td>float</td>
</tr>
<tr>
<td>Mixed</td>
<td></td>
</tr>
<tr>
<td>Exponential</td>
<td>rewrite</td>
</tr>
<tr>
<td>Factorial</td>
<td>rewrite</td>
</tr>
<tr>
<td>Gamma</td>
<td>rewrite</td>
</tr>
<tr>
<td>Logarithm</td>
<td>rewrite</td>
</tr>
<tr>
<td>Sin and Cos</td>
<td>rewrite</td>
</tr>
<tr>
<td>Sinh and Cosh</td>
<td>rewrite</td>
</tr>
<tr>
<td>Sin</td>
<td>rewrite</td>
</tr>
<tr>
<td>Cos</td>
<td>rewrite</td>
</tr>
<tr>
<td>Tan</td>
<td>rewrite</td>
</tr>
<tr>
<td>Arccos</td>
<td>rewrite</td>
</tr>
<tr>
<td>Arctan</td>
<td>rewrite</td>
</tr>
<tr>
<td>Arccot</td>
<td>rewrite</td>
</tr>
<tr>
<td>Polar</td>
<td></td>
</tr>
<tr>
<td>Rectangular</td>
<td>rectform</td>
</tr>
<tr>
<td>Normal Form</td>
<td>normal</td>
</tr>
<tr>
<td>Equations as Matrix</td>
<td>linalg::expr2Matrix</td>
</tr>
<tr>
<td>Matrix as Equations</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Compute &gt; Solve</th>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exact</td>
<td>solve</td>
</tr>
<tr>
<td>Numeric</td>
<td>numeric::fsolve</td>
</tr>
<tr>
<td>Integer</td>
<td>Dom::Integer, solve</td>
</tr>
<tr>
<td>Recursion</td>
<td>solve, rec</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Compute &gt; Polynomials</th>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Collect</td>
<td>collect</td>
</tr>
<tr>
<td>Divide</td>
<td>div</td>
</tr>
<tr>
<td>Partial Fractions</td>
<td>parfrac</td>
</tr>
<tr>
<td>Roots</td>
<td>solve</td>
</tr>
<tr>
<td>Sort</td>
<td>polylib::sortMonomials</td>
</tr>
<tr>
<td>Companion Matrix</td>
<td>linalg::companion</td>
</tr>
</tbody>
</table>
## Appendix D | MuPAD Functions and Expressions

### Compute > Calculus

<table>
<thead>
<tr>
<th>Function</th>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Integrate by Parts</td>
<td>intlib::by parts</td>
</tr>
<tr>
<td>Change Variables</td>
<td>intlib::changevar</td>
</tr>
<tr>
<td>Partial Fractions</td>
<td>parfrac</td>
</tr>
<tr>
<td>Approximate Integral</td>
<td>student::trapezoid</td>
</tr>
<tr>
<td>Approximate Integral</td>
<td>student::simpson</td>
</tr>
<tr>
<td>Approximate Integral Animated</td>
<td></td>
</tr>
<tr>
<td>Plot Approximate Integral</td>
<td></td>
</tr>
<tr>
<td>Plot Approximate Integral Animated</td>
<td></td>
</tr>
<tr>
<td>Find Extrema</td>
<td></td>
</tr>
<tr>
<td>Iterate</td>
<td></td>
</tr>
<tr>
<td>Implicit Differentiation</td>
<td>diff</td>
</tr>
</tbody>
</table>

### Compute > Solve ODE

<table>
<thead>
<tr>
<th>Function</th>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exact</td>
<td>ode::solve</td>
</tr>
<tr>
<td>Laplace</td>
<td>ode::laplace</td>
</tr>
<tr>
<td>Numeric</td>
<td>numeric::odesolve2</td>
</tr>
<tr>
<td>Series</td>
<td>ode::series</td>
</tr>
</tbody>
</table>

### Compute > Power Series

<table>
<thead>
<tr>
<th>Function</th>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power Series</td>
<td>series</td>
</tr>
<tr>
<td>Power Series</td>
<td>taylor</td>
</tr>
</tbody>
</table>

### Compute > Transforms

<table>
<thead>
<tr>
<th>Function</th>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fourier</td>
<td>transform::fourier</td>
</tr>
<tr>
<td>Inverse Fourier</td>
<td>transform::invfourier</td>
</tr>
<tr>
<td>Laplace</td>
<td>transform::laplace</td>
</tr>
<tr>
<td>Inverse Laplace</td>
<td>transform::invlaplace</td>
</tr>
</tbody>
</table>

### Compute > Vector Calculus

<table>
<thead>
<tr>
<th>Function</th>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gradient</td>
<td>linalg::grad</td>
</tr>
<tr>
<td>Divergence</td>
<td>linalg::divergence</td>
</tr>
<tr>
<td>Curl</td>
<td>linalg::curl</td>
</tr>
<tr>
<td>Laplacian</td>
<td>linalg::laplacian</td>
</tr>
<tr>
<td>Jacobian</td>
<td>linalg::jacobian</td>
</tr>
<tr>
<td>Hessian</td>
<td>linalg::hessian</td>
</tr>
<tr>
<td>Wronskian</td>
<td>ode::wronskianMatrix</td>
</tr>
<tr>
<td>Scalar Potential</td>
<td>scalarpot</td>
</tr>
<tr>
<td>Vector Potential</td>
<td>linalg::vectorPotential</td>
</tr>
<tr>
<td>Set Basis Variables</td>
<td></td>
</tr>
<tr>
<td>Compute &gt; Matrices</td>
<td>MuPAD</td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>------------------------</td>
</tr>
<tr>
<td>Adjugate</td>
<td>linalg::adjoint</td>
</tr>
<tr>
<td>Characteristic Polynomial</td>
<td>linalg::charPolynomial</td>
</tr>
<tr>
<td>Cholesky Decomposition</td>
<td>linalg::cholesky</td>
</tr>
<tr>
<td>Column Basis</td>
<td>linalg::basis</td>
</tr>
<tr>
<td>Concatenate</td>
<td>linalg::concatMatrix</td>
</tr>
<tr>
<td>Condition Number</td>
<td>norm</td>
</tr>
<tr>
<td>Definiteness Tests</td>
<td>linalg::isPosDef</td>
</tr>
<tr>
<td>Determinant</td>
<td>linalg::det</td>
</tr>
<tr>
<td>Eigenvalues</td>
<td>linalg::eigenvalues</td>
</tr>
<tr>
<td>Eigenvectors</td>
<td>linalg::eigenvectors</td>
</tr>
<tr>
<td>Fill Matrix</td>
<td></td>
</tr>
<tr>
<td>Fraction-free Gaussian Elimination</td>
<td>linalg::gaussElim</td>
</tr>
<tr>
<td>Gaussian Elimination</td>
<td>linalg::gaussElim</td>
</tr>
<tr>
<td>Hermite Normal Form</td>
<td>linalg::hermiteForm</td>
</tr>
<tr>
<td>Hermitian Transpose</td>
<td>conjugate + linalg::transpose</td>
</tr>
<tr>
<td>Inverse</td>
<td>numeric::inverse</td>
</tr>
<tr>
<td>Jordan Normal Form</td>
<td>linalg::jordanForm</td>
</tr>
<tr>
<td>Map Function</td>
<td>map</td>
</tr>
<tr>
<td>Minimum Polynomial</td>
<td>linalg::minpoly</td>
</tr>
<tr>
<td>Norm</td>
<td>norm</td>
</tr>
<tr>
<td>Nullspace Basis</td>
<td>linalg::nullspace</td>
</tr>
<tr>
<td>Orthogonality Test</td>
<td>linalg::isUnitary</td>
</tr>
<tr>
<td>Permanent</td>
<td>linalg::permanent</td>
</tr>
<tr>
<td>PLU Decomposition</td>
<td>numeric::factorLU</td>
</tr>
<tr>
<td>QR Decomposition</td>
<td>numeric::factorQR</td>
</tr>
<tr>
<td>Random Matrix</td>
<td>linalg::randomMatrix</td>
</tr>
<tr>
<td>Rank</td>
<td>linalg::rank</td>
</tr>
<tr>
<td>Rational Canonical Form</td>
<td>linalg::rationalForm</td>
</tr>
<tr>
<td>Reduced Row Echelon Form</td>
<td>linalg::GaussJordan</td>
</tr>
<tr>
<td>Reshape</td>
<td></td>
</tr>
<tr>
<td>Row Basis</td>
<td>linalg::basis</td>
</tr>
<tr>
<td>Singular Values</td>
<td>numeric::singularvalues</td>
</tr>
<tr>
<td>Singular Value Decomposition</td>
<td>numeric::singularvectors</td>
</tr>
<tr>
<td>Smith Normal Form</td>
<td>linalg::HermiteForm</td>
</tr>
<tr>
<td>Spectral Radius</td>
<td>numeric::spectralradius</td>
</tr>
<tr>
<td>Stack</td>
<td>linalg::stackMatrix</td>
</tr>
<tr>
<td>Trace</td>
<td>linalg::tr</td>
</tr>
<tr>
<td>Transpose</td>
<td>linalg::transpose</td>
</tr>
</tbody>
</table>
Appendix D | MuPAD Functions and Expressions

<table>
<thead>
<tr>
<th>Compute &gt; Simplex</th>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dual</td>
<td>linopt::dual</td>
</tr>
<tr>
<td>Feasible</td>
<td>linopt::Feasible</td>
</tr>
<tr>
<td>Maximize</td>
<td>linopt::maximize</td>
</tr>
<tr>
<td>Minimize</td>
<td>linopt::minimize</td>
</tr>
<tr>
<td>Standardize</td>
<td>linopt::Standardize</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Compute &gt; Stat. &gt; Fit Curve to Data</th>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multiple Regression</td>
<td>stats::reg</td>
</tr>
<tr>
<td>Multiple Regression (No Constant)</td>
<td>stats::linReg</td>
</tr>
<tr>
<td>Polynomial of Degree n</td>
<td>stats::reg</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Compute &gt; Stat. &gt; Random Numbers</th>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beta</td>
<td>stats::betaRandom</td>
</tr>
<tr>
<td>Binomial</td>
<td>stats::binomialRandom</td>
</tr>
<tr>
<td>Cauchy</td>
<td>stats::cauchyRandom</td>
</tr>
<tr>
<td>Chi-Square</td>
<td>stats::chisquareRandom</td>
</tr>
<tr>
<td>Exponential</td>
<td>stats::exponentialRandom</td>
</tr>
<tr>
<td>F</td>
<td>stats::fRandom</td>
</tr>
<tr>
<td>Gamma</td>
<td>stats::gammaRandom</td>
</tr>
<tr>
<td>Normal</td>
<td>stats::normalRandom</td>
</tr>
<tr>
<td>Poisson</td>
<td>stats::poissonRandom</td>
</tr>
<tr>
<td>Student's t</td>
<td>stats::tRandom</td>
</tr>
<tr>
<td>Uniform</td>
<td>stats::uniformRandom</td>
</tr>
<tr>
<td>Weibull</td>
<td>stats::weibullRandom</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Compute &gt; Statistics</th>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mean</td>
<td>stats::mean</td>
</tr>
<tr>
<td>Median</td>
<td>stats::median</td>
</tr>
<tr>
<td>Mode</td>
<td>stats::modal</td>
</tr>
<tr>
<td>Correlation</td>
<td>stats::correlation</td>
</tr>
<tr>
<td>Covariance (No Constant)</td>
<td>stats::covariance</td>
</tr>
<tr>
<td>Geometric Mean</td>
<td>stats::geometric</td>
</tr>
<tr>
<td>Harmonic Mean</td>
<td>stats::harmonic</td>
</tr>
<tr>
<td>Mean Deviation</td>
<td>stats::mean_deviation</td>
</tr>
<tr>
<td>Moment</td>
<td>stats::moment</td>
</tr>
<tr>
<td>Quantile</td>
<td>stats::quantile</td>
</tr>
<tr>
<td>Standard Deviation</td>
<td>stats::stdev</td>
</tr>
<tr>
<td>Variance</td>
<td>stats::variance</td>
</tr>
</tbody>
</table>
## Compute > Plot 2D

<table>
<thead>
<tr>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangular plot::Function2d</td>
</tr>
<tr>
<td>Polar plot::polar</td>
</tr>
<tr>
<td>Implicit plot::Implicit2d</td>
</tr>
<tr>
<td>Parametric plot::Curve2d</td>
</tr>
<tr>
<td>Conformal plot2d</td>
</tr>
<tr>
<td>Gradient //</td>
</tr>
<tr>
<td>Vector Field plot::VectorField2d</td>
</tr>
<tr>
<td>ODE plot::Ode2d</td>
</tr>
</tbody>
</table>

## Compute > Plot 3D

<table>
<thead>
<tr>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangular plot::Function2d</td>
</tr>
<tr>
<td>Cylindrical plot::Cylindrical</td>
</tr>
<tr>
<td>Spherical plot::Spherical</td>
</tr>
<tr>
<td>Implicit plot::Implicit3d</td>
</tr>
<tr>
<td>Tube plot::Tube</td>
</tr>
<tr>
<td>Gradient //</td>
</tr>
<tr>
<td>Vector Field //</td>
</tr>
</tbody>
</table>

## Compute > Plot 2D Animated

<table>
<thead>
<tr>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plot 2D Animated + Rectangular plotfunc or plot::Function2d</td>
</tr>
<tr>
<td>Plot 2D Animated + Polar plot::polar</td>
</tr>
<tr>
<td>Plot 2D Animated + Implicit plot::Implicit2d</td>
</tr>
<tr>
<td>Plot 2D Animated + Parametric plot::Curve2d</td>
</tr>
<tr>
<td>Plot 2D Animated + Conformal plot::Conformal</td>
</tr>
<tr>
<td>Plot 2D Animated + Gradient //</td>
</tr>
<tr>
<td>Plot 2D Animated + Vector Field plot::VectorField2d</td>
</tr>
<tr>
<td>Plot 2D Animated + ODE plot::Ode2d</td>
</tr>
</tbody>
</table>

## Compute > Plot 3D Animated

<table>
<thead>
<tr>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plot 3D Animated + Rectangular plotfunc3d or plot::Function3d</td>
</tr>
<tr>
<td>Plot 3D Animated + Cylindrical plot::Cylindrical</td>
</tr>
<tr>
<td>Plot 3D Animated + Spherical plot::Spherical</td>
</tr>
<tr>
<td>Plot 3D Animated + Implicit plot::Implicit3d</td>
</tr>
<tr>
<td>Plot 3D Animated + Tube plot::Tube</td>
</tr>
<tr>
<td>Plot 3D Animated + Gradient //</td>
</tr>
<tr>
<td>Plot 3D Animated + Vector Field //</td>
</tr>
</tbody>
</table>
Appendix D | MuPAD Functions and Expressions

Functions and Expressions

There are a number of built-in functions that you can evaluate with Compute > Evaluate. Some are entered directly in mathematics and some use a Math Name. If a function name does not automatically turn gray when typed in mathematics (many do), choose Insert > Math Objects > Math Name and type the function name in the Name box. The following lists show the MuPAD function names that are used to implement the built-in functions.

### Algebra and Number Theory

<table>
<thead>
<tr>
<th>SWP/SNB</th>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sqrt{x}$ or $x^{1/2}$</td>
<td>sqrt(x)</td>
</tr>
<tr>
<td>$\sqrt[n]{x}$</td>
<td>$x^{(1/n)}$</td>
</tr>
<tr>
<td>$</td>
<td>x</td>
</tr>
<tr>
<td>$\text{max}(a,b,c)$ or $a \lor b \lor c$</td>
<td>max(a,b,c)</td>
</tr>
<tr>
<td>$\text{min}(a,b,c)$ or $a \land b \land c$</td>
<td>min(a,b,c)</td>
</tr>
<tr>
<td>$\text{gcd}(x^2+1,x+1)$</td>
<td>gcd($x^2+1,x+1$)</td>
</tr>
<tr>
<td>$\text{lcm}(x^2+1,x+1)$</td>
<td>lcm($x^2+1,x+1$)</td>
</tr>
<tr>
<td>$\left\lfloor \frac{123}{34} \right\rfloor$</td>
<td>floor(123/34)</td>
</tr>
<tr>
<td>$\left\lceil \frac{123}{34} \right\rceil$</td>
<td>ceil(123/34)</td>
</tr>
<tr>
<td>$(\binom{6}{2})$</td>
<td>binomial(6,2)</td>
</tr>
<tr>
<td>$x!$</td>
<td>x!</td>
</tr>
<tr>
<td>$123 \mod 17$</td>
<td>123 mod 17</td>
</tr>
<tr>
<td>$a^n \mod m$</td>
<td>powermod(a,n,m)</td>
</tr>
<tr>
<td>$3x^3 + 2x \mod x^2 + 1$</td>
<td>divide + Rem</td>
</tr>
<tr>
<td>${a,b} \cup {b,c}$</td>
<td>{a,b} union {b,c}</td>
</tr>
<tr>
<td>${a,b} \cap {b,c}$</td>
<td>{a,b} intersect {b,c}</td>
</tr>
<tr>
<td>$\text{signum}(x)$</td>
<td>sign(x)</td>
</tr>
</tbody>
</table>

### Trigonometry

<table>
<thead>
<tr>
<th>SWP/SNB</th>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sin x$ or $\sin(x)$</td>
<td>sin(x)</td>
</tr>
<tr>
<td>$\cos x$ or $\cos(x)$</td>
<td>cos(x)</td>
</tr>
<tr>
<td>$\tan x$ or $\tan(x)$</td>
<td>tan(x)</td>
</tr>
<tr>
<td>$\text{cot } x$ or $\cot(x)$</td>
<td>cot(x)</td>
</tr>
<tr>
<td>$\text{sec } x$ or $\sec(x)$</td>
<td>sec(x)</td>
</tr>
<tr>
<td>$\text{csc } x$ or $\csc(x)$</td>
<td>csc(x)</td>
</tr>
</tbody>
</table>
### Functions and Expressions

#### Trigonometry

<table>
<thead>
<tr>
<th>SWP/SNB</th>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>\arcsin x or \sin^{-1} x or \arcsin(x) or \sin^{-1}(x)</td>
<td>\arcsin(x)</td>
</tr>
<tr>
<td>\arccos x or \cos^{-1} x or \arccos(x) or \cos^{-1}(x)</td>
<td>\arccos(x)</td>
</tr>
<tr>
<td>\arctan x or \tan^{-1} x or \arctan(x) or \tan^{-1}(x)</td>
<td>\arctan(x)</td>
</tr>
<tr>
<td>\arccot x or \cot^{-1} x or \arccot(x) or \cot^{-1}(x)</td>
<td>\arccot(x)</td>
</tr>
<tr>
<td>\arcsec x or \sec^{-1} x or \arcsec(x) or \sec^{-1}(x)</td>
<td>\arcsec(x)</td>
</tr>
<tr>
<td>\arccsc x or \csc^{-1} x or \arccsc(x) or \csc^{-1}(x)</td>
<td>\arccsc(x)</td>
</tr>
</tbody>
</table>

#### Exponential, Logarithmic, and Hyperbolic Functions

<table>
<thead>
<tr>
<th>SWP/SNB</th>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>e^x or exp(x)</td>
<td>exp(x)</td>
</tr>
<tr>
<td>\log x or \ln x</td>
<td>\ln(x)</td>
</tr>
<tr>
<td>\log_{10} x or \log_{10}(x)</td>
<td>\ln(x)/\ln(10)</td>
</tr>
<tr>
<td>\sinh x or \sinh(x)</td>
<td>\sinh(x)</td>
</tr>
<tr>
<td>\cosh x or \cosh(x)</td>
<td>\cosh(x)</td>
</tr>
<tr>
<td>\tanh x or \tanh(x)</td>
<td>\tanh(x)</td>
</tr>
<tr>
<td>\coth x or \coth(x)</td>
<td>\coth(x)</td>
</tr>
<tr>
<td>\cosh^{-1} x or \cosh^{-1}(x)</td>
<td>\arccosh(x)</td>
</tr>
<tr>
<td>\sinh^{-1} x or \sinh^{-1}(x)</td>
<td>\arcsinh(x)</td>
</tr>
<tr>
<td>\tanh^{-1} x or \tanh^{-1}(x)</td>
<td>\arctanh(x)</td>
</tr>
</tbody>
</table>

#### Calculus

<table>
<thead>
<tr>
<th>SWP/SNB</th>
<th>MuPAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>\frac{d}{dx}(x \sin x)</td>
<td>\text{diff}(x \sin(x), x)</td>
</tr>
<tr>
<td>f', Df, D</td>
<td>D(f)</td>
</tr>
<tr>
<td>f'(3)</td>
<td>D(f)(3)</td>
</tr>
<tr>
<td>\int x \sin x , dx</td>
<td>\text{int}(x \sin(x), x)</td>
</tr>
<tr>
<td>\int_0^1 x \sin x , dx</td>
<td>\text{int}(x \sin(x), x = 0..1)</td>
</tr>
<tr>
<td>\lim_{x \to 0} \frac{\sin x}{x}</td>
<td>\text{limit}(\sin(x)/x, x = 0)</td>
</tr>
<tr>
<td>\sum_{i=1}^{\infty} \frac{1}{i^2}</td>
<td>\text{sum}(i^2/2^i, i = 1..\infty)</td>
</tr>
</tbody>
</table>
### Complex Numbers

<table>
<thead>
<tr>
<th>SWP/SNB</th>
<th>MuPAD</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Re((z))</td>
<td>Re((z))</td>
<td>Real part (a) of (z = a + bi)</td>
</tr>
<tr>
<td>Im((z))</td>
<td>Im((z))</td>
<td>Imaginary part (b) of (z = a + bi)</td>
</tr>
<tr>
<td>(</td>
<td>z</td>
<td>)</td>
</tr>
</tbody>
</table>
| \(csgn(z)\) | \(csgn(z)\) | \[
\begin{align*}
1 & \text{ if } \text{Re}(z) > 0; \text{ or } \text{Re}(z) = 0 \text{ and } \text{Im}(z) > 0 \\
0 & \text{ if } z = 0 \\
-1 & \text{ if } \text{Re}(z) < 0; \text{ or } \text{Re}(z) = 0 \text{ and } \text{Im}(z) < 0
\end{align*}
\] |
| \(\text{signum}(z)\) | \(\text{sign}(z)\) | \[
\begin{align*}
\frac{z}{|z|} & \text{ if } z \neq 0 \\
0 & \text{ if } z = 0
\end{align*}
\] |
| \(z^*\) or \(\bar{z}\) | \(\text{conjugate}(z)\) | \(z^* = \text{Re}(z) - \text{Im}(z)i\) |
| \(\arg(z)\) | \(\text{atan}(\text{Im}(z)/\text{Re}(z))\) | \(z = |z|e^{i\arg(z)}\) |

### Linear Algebra

<table>
<thead>
<tr>
<th>SWP/SNB</th>
<th>MuPAD</th>
<th>Comments</th>
</tr>
</thead>
</table>
| \[
\begin{pmatrix}
1 & 2 & 3 \\
4 & 5 & 6
\end{pmatrix}
\] | \(\text{array(1..2,1..3,[[1,2,3],[4,5,6]]})\) | matrix |
| \(AB\) | \(A^*B\) | matrix product |
| \(A^{-1}\) | \(A^{*(-1)}\) | matrix inverse |
| \(A^T\) | \(\text{linalg::transpose}(A)\) | matrix transpose |
| \(A \mod 17\) | \(\text{map}(A, x \rightarrow x \mod 17)\) | |
| \(A^H\) | \(\text{conjugate + linalg::transpose}\) | Hermitian transpose |
| \(AB^{-1}\) | \(A^*B^{*(-1)}\) | |
| \(A^{-1} \mod 17\) | \(\text{map}(A^{*(-1)}, x \rightarrow x \mod 17)\) | |
| \(\|x\|_n\) | \(\text{norm}(x,n)\) | \(n\)-norm |
| \(\|x\|_F\) | \(\text{norm}(x,\text{Frobenius})\) | Frobenius norm |
| \(\|x\|_\infty\) | \(\text{norm}(x,\text{Infinity})\) | infinity norm |
### Vector Calculus

<table>
<thead>
<tr>
<th>SWP/SNB</th>
<th>MuPAD</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>∇xyz</td>
<td>linalg::grad(x<em>y</em>z,[x,y,z])</td>
<td>gradient</td>
</tr>
<tr>
<td>∥(1, −3, 4)∥ₚ</td>
<td>norm(SWPmatrix(1,3,[[1,-3,4]],p)</td>
<td>p-norm</td>
</tr>
<tr>
<td>v × w</td>
<td>linalg::crossProduct(S,T)</td>
<td>cross product</td>
</tr>
<tr>
<td>S · T</td>
<td>linalg::scalarProduct(S,T)</td>
<td></td>
</tr>
<tr>
<td>∇ · (x, xy, y − z)</td>
<td>linalg::divergence([x,x*y-y-z],[x,y,z])</td>
<td>divergence</td>
</tr>
<tr>
<td>∇ × (x, xy, y − z)</td>
<td>linalg::curl([x,x’y-y-z],[x,y,z])</td>
<td>curl</td>
</tr>
<tr>
<td>∇² (x²y²z³)</td>
<td>linalg::divergence(linalg::grad(x²*y²z³,[x,y,z]),[x,y,z])</td>
<td>Laplacian</td>
</tr>
</tbody>
</table>

### Differential Equations

<table>
<thead>
<tr>
<th>SWP/SNB</th>
<th>MuPAD</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>ℋ(f(t), t, w)</td>
<td>transform::fourier(expr,t,w)</td>
<td>Fourier transform</td>
</tr>
<tr>
<td>ℋ⁻¹(f(t), t, w)</td>
<td>transform::ifourier(expr,t,w)</td>
<td>inverse Fourier transform</td>
</tr>
<tr>
<td>ℋ(f(s), s, t)</td>
<td>transform::laplace(expr,s,t)</td>
<td>Laplace transform</td>
</tr>
<tr>
<td>ℋ⁻¹(f(s), s, t)</td>
<td>transform::ilaplace(expr,s,t)</td>
<td>inverse Laplace transform</td>
</tr>
<tr>
<td>Dirac(x), Dirac(x, n)</td>
<td>dirac(x), dirac(x,n)</td>
<td>Dirac function, nth derivative of Dirac function</td>
</tr>
</tbody>
</table>
| Heaviside(x) | heaviside(x)                                  | Heaviside function

### Statistics

<table>
<thead>
<tr>
<th>SWP/SNB</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>NormalDist, NormalDen, NormalInv</td>
<td>Normal distribution</td>
</tr>
<tr>
<td>TDist, TDen, TInv</td>
<td>Student’s t distribution</td>
</tr>
<tr>
<td>ChiSquareDist, ChiSquareDen, ChiSquareInv</td>
<td>Chi Square distribution</td>
</tr>
<tr>
<td>FDist, FDen, FInv</td>
<td>F distribution</td>
</tr>
<tr>
<td>ExponentialDist, ExponentialDen, ExponentialInv</td>
<td>Exponential distribution</td>
</tr>
<tr>
<td>WeibullDist, WeibullDen, WeibullInv</td>
<td>Weibull distribution</td>
</tr>
<tr>
<td>GammaDist, GammaDen, GammaInv</td>
<td>Gamma distribution</td>
</tr>
<tr>
<td>BetaDist, BetaDen, BetaInv</td>
<td>Beta distribution</td>
</tr>
<tr>
<td>CauchyDist, CauchyDen, CauchyInv</td>
<td>Cauchy distribution</td>
</tr>
<tr>
<td>UniformDist, UniformDen</td>
<td>Uniform distribution</td>
</tr>
<tr>
<td>BinomialDist, BinomialDen</td>
<td>Binomial distribution</td>
</tr>
<tr>
<td>PoissonDist, PoissonDen</td>
<td>Poisson distribution</td>
</tr>
<tr>
<td>HypergeomDist, HypergeomDen</td>
<td>Hypergeometric distribution</td>
</tr>
</tbody>
</table>
### Special Functions

<table>
<thead>
<tr>
<th>SWP/SNB</th>
<th>MuPAD</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>BesselIν(z)</td>
<td>besselI(ν,z)</td>
<td>Alternate notation: $I_ν(z)$</td>
</tr>
<tr>
<td>BesselKν(z)</td>
<td>besselK(ν,z)</td>
<td>Alternate notation: $K_ν(z)$</td>
</tr>
<tr>
<td>BesselJν(z)</td>
<td>besselJ(ν,z)</td>
<td>Alternate notation: $J_ν(z)$</td>
</tr>
<tr>
<td>BesselYν(z)</td>
<td>besselY(ν,z)</td>
<td>Alternate notation: $Y_ν(z)$</td>
</tr>
<tr>
<td>Beta(x,y)</td>
<td>beta(x,y)</td>
<td>Beta function: $\frac{\Gamma(x)\Gamma(y)}{\Gamma(x+y)}$</td>
</tr>
<tr>
<td>dilog(x)</td>
<td>dilog(x)</td>
<td>$\int_1^x \frac{\ln t}{1-t} dt$</td>
</tr>
<tr>
<td>erf(x)</td>
<td>erf(x)</td>
<td>error function: $\frac{2}{\sqrt{\pi}} \int_0^x e^{-t^2} dt$</td>
</tr>
<tr>
<td>1 - erf(x)</td>
<td>erfc(x)</td>
<td>complementary error function</td>
</tr>
<tr>
<td>$\mathcal{F} (f(t), t, w)$</td>
<td>transform::fourier(f(t),t,w)</td>
<td>Fourier transform</td>
</tr>
<tr>
<td>LambertW(x)</td>
<td>lambertW(x)</td>
<td>LambertW(x) $e^{LambertW(x)} = x$</td>
</tr>
<tr>
<td>$\mathcal{L} (f(t), t, s)$</td>
<td>transform::laplace(f(t),t,s)</td>
<td>Laplace transform</td>
</tr>
<tr>
<td>polylog(k,x)</td>
<td>heaviside(x)</td>
<td>polylogarithm: $\text{polylog}(k,x) = \sum_{n=1}^{\infty} \frac{x^n}{n^k}$</td>
</tr>
<tr>
<td>bernoulli(n)</td>
<td>bernoulli(n)</td>
<td>$n$th Bernoulli number $\frac{x^n}{n-1} = \sum_{n=1}^{\infty} \text{bernoulli}(n) \frac{x^n}{n!}$</td>
</tr>
<tr>
<td>bernoulli(n,x)</td>
<td>bernoulli(n,x)</td>
<td>$n$th Bernoulli polynomial $\frac{xe^x}{e^x-1} = \sum_{n=1}^{\infty} \text{bernoulli}(n,x) \frac{x^n}{n!}$</td>
</tr>
<tr>
<td>Chi(z)</td>
<td></td>
<td>$\text{Chi}(z)$ hyperbolic cosine integral: $\text{gamma} + \ln z - \int_0^z \frac{1 - \cosh t}{t} dt \quad (\arg(z) &lt; \pi)$</td>
</tr>
<tr>
<td>Ci(x)</td>
<td>Ci(x)</td>
<td>cosine integral: $\gamma + \ln x - \int_0^x \frac{1 - \cosh t}{t} dt$</td>
</tr>
<tr>
<td>Ei(x)</td>
<td>eint(x)</td>
<td>exponential integral: $\int_x^\infty \frac{e^t}{t} dt$</td>
</tr>
<tr>
<td>Γ(z)</td>
<td>igamma(z,0)</td>
<td>Gamma function: $\int_0^\infty e^{-t} t^{z-1} dt$</td>
</tr>
<tr>
<td>Γ(a,z)</td>
<td>igamma(a,z)</td>
<td>incomplete Gamma function: $\int_z^\infty e^{-t} t^{a-1} dt$</td>
</tr>
<tr>
<td>Si(x)</td>
<td>Si(x)</td>
<td>sine integral: $\int_0^x \frac{\sin t}{t} dt$</td>
</tr>
<tr>
<td>Shi(x)</td>
<td></td>
<td>hyperbolic sine integral: $\int_0^x \frac{\sinh t}{t} dt$</td>
</tr>
<tr>
<td>Psi(x)</td>
<td>psi(x)</td>
<td>Psi function: $\psi(x) = \frac{d}{dx} \ln \Gamma(x)$</td>
</tr>
<tr>
<td>Psi(x,n)</td>
<td>psi(x,n)</td>
<td>$n$th derivative of Psi function</td>
</tr>
<tr>
<td>$\zeta(s)$</td>
<td>zeta(x)</td>
<td>Zeta function: $\zeta(s) = \sum_{n=1}^{\infty} \frac{1}{n^s}$ for $s &gt; 1$</td>
</tr>
</tbody>
</table>
A
about, 112, 237
absolute convergence, 263
absolute value
  complex number, 33
  integration, 233
  number, 27
plots, 157
symbol, 27
acre, 498
activity, 498
addition
  complex numbers, 33
  general, 7
  matrices, 294
  numbers, 20
  polynomials, 40
  trigonometric formulas, 82
  vectors, 344
additionally, 112, 237
adjoint
  classical adjoint, 310
  Hermitian transpose, 308
adjugate, 310
algebra of functions, 106
allowable assumptions, 112
ambiguous notation, 8, 211
amount of substance, 498
ampere, 499
amplitude, 89
and, logical
  intersection, 32
  logical operator, 31
  minimum or meet, 28
angle
  conversions, 35
  degrees and radians, 77
  notation, 77, 503
ångström, 501
animated plots
  2D plots, 165
  3D plots, 172, 189
  gradient field 2D, 367
  gradient field 3D, 370
  vector field 2D, 365
  vector field 3D, 367
antiderivative, 226
Approximate Integral
  Left Boxes, 240, 248
  Lower Absolute Boxes, 243
  Lower Boxes, 241
  Midpoint, 246
  Right Boxes, 240, 248
  Simpson, 245, 251
  Trapezoid, 244, 250
  Upper Absolute Boxes, 243
approximation
  continued fractions, 446
  Evaluate Numeric, 26
  integrals, 246
  linear regression, 436
  Newton’s method by iteration, 217
  numerical integration, 253
  polynomial fit to data, 437
  power series, 265
  rational, 446
  Riemann sums, 238
  Approximate Integral
    Upper Boxes, 241
arbitrary constant, 8
arbitrary functions, 212
arc length, 254
area, 498
arg, 89
argument
  complex number, 89
  function, 99
### Index

**ordinary and trigtype functions**, 123  
**arithmetic mean**, 411  
**arithmetic-geometric mean**, 278  
**arrows**, 10  
**assigning values to variables**, 47, 59  
**assignment**  
  - deferred evaluation, 104  
  - defining variables, 103  
  - full evaluation, 105  
**assume**  
  - assumptions about variables, 111  
  - calculus example, 237  
**real**, 49  
**asymptotes**, 141  
**atmosphere**, 503  
**automatic selection**, 12  
**automatic substitution**, 102, 512  
**average**, 411  
**Axes Scaling**, 511  
**Axes Type**  
  - 2D plots, 144, 146  
  - axis scaling, 143  

**B**  

- **band matrix**, 289  
- **bar**, 503  
- **bar chart**, 162  
- **base of log**, 67, 507  
- **basic guidelines**, 7  
  - **basis**  
    - column space, 323  
    - nullspaces, 323  
    - orthonormal, 325  
    - rank of matrix, 326  
    - row space, 321  
    - variables, 359  
- **BCH code**, 463  
- **becquerel**, 498  
- **Bernoulli number**, 526  
  - **polynomial**, 526  
- **Bessel functions**, 392, 405  
- **beta**  
  - **distribution**, 430  
  - **function**, 526  
- **binary**  
  - **operations**, 10  
  - **relations**, 10, 12  
  - **representation**, 461  
- **binomial**  
  - **coefficients**, 22, 432  
  - **distribution**, 432  
  - **Rewrite Factorial**, 23  
- **block cipher**, 455  
- **blood flow problem**, 278  
- **brackets**  
  - **built-in delimiters**, 286  
  - **choosing and entering**, 5  
  - **expanding**, 6  
- **British thermal unit**, 500

**c**  

**Calculus**, see calculus  
- **Approximate Integral**, 246  
- **Change Variable**, 229  
- **Change Variables**, 234  
- **Find Extrema**, 220, 270  
- **Implicit Differentiation**, 111, 213  
- **Integrate by Parts**, 228, 234  
- **Iterate**, 216  
- **Partial Fractions**, 230, 234  
- **Plot Approx. Integral**, 238  
**calculus**, see Calculus  
- **definite integral**, 231  
- **derivative**, 209  
- **evaluate expression**, 201  
- **indefinite integral**, 226  
- **limit**, 202  
- **Newton’s method**, 217  
- **plotting derivatives**, 212  
- **calorie**, 500  
- **candela**, 502  
- **carrier waves**, 163  
- **case function**, 62, 108  
- **Cauchy distribution**, 431  
- **Cayley-Hamilton theorem**, 317  
- **ceiling function**, 29  
- **celsius**, 504  
- **center**  
  - **graphics**, 6  
  - **mathematics**, 6  
  - **text**, 6  
- **chain rule**, 213  
- **Change from i to j**, 508  
- **Change Variable**, 229  
- **characteristic**  
  - **matrix**, 328  
  - **polynomial**, 317  
  - **value**, 318  
  - **vector**, 318  
- **Check Equality**, 30  
- **chi-square distribution**, 426  
- **Chinese remainder theorem**, 452  
- **Cholesky Decomposition**, 336  
- **circle center and radius**, 74  
- **Clear Definitions**, 115  
- **code word**, 463  
- **coefficient of correlation**, 420  
- **cofactor**, 310  
- **Collect**, 44  
- **column**  
  - **matrix**, 290  
  - **select**, 15  
  - **space**, 323  
- **Combine**  
  - **Arctan**, 84
Index

Exponentials, 65
Hyperbolic Trig Functions, 87
Logs, 67
Powers, 65
Trig Functions, 83
companion matrix, 329
completing a square, 71
complex conjugate, 33, 346, 508
complex numbers
absolute value, 33
argument, 89
assume, 112
basic operations, 32
complex conjugate, 33
complex powers and roots, 91
form, 89
imaginary unit i or j, 32
polar form, 90
real and imaginary part, 33
rectangular form, 33, 90
trigonometric form, 90
complex or real default, 49
components, 341
composition of functions, 106
compound units, 35
Compute menu, 516
computing, 7
computing in place, 16
Concatenate, 208, 292
concave upward, 225
Condition Number, 315
conformal plot, 379
congruence
inverse modulo m, 450
matrix modulo m, 454
modulo m, 448
modulo polynomial, 456
polynomials modulo
polynomials, 456
solving linear congruences, 451
conjugate, 33
conjugate transpose, 308
constant of integration, 226
constants
generic constants, 111
MuPAD constants, 515
$\pi, i, e, 8$
constrained optima
Find Extrema, 270
Lagrange multipliers, 271
constraints, 463
conventions, 2
correlation, 420
cosecant, 76
cosine, 75
cotangent, 76
coulomb, 499
covariance, 418
cross product, 347
cubic meter, 504
cumulative distribution function, 421
curie, 498
curl, 361
current, 499
cursor, 4
curve fitting, 436, 437
curve sketching, 222
curves in space
polygonal paths, 181
rectangular plot, 178
tube plots, 179
custom name, 100
custom settings
Change from i to j, 32
imaginary unit, 32
input, 507
scope, 507
sidebars, 507
toolbars, 506
customer support, ix
customizing computation
settings, see Settings
cylindrical coordinates, 184
D
data
2D plots, 159
3D plots, 181
convert list to matrix, 293, 410
fitting curves to data, 436
random numbers, 435
reshape lists and matrices, 293
day, 504
decimal notation, 23
deferred evaluation, 104
Define MuPAD Name, 446
defined function
2D plots, 153
3D plots, 174
valid names, 100
definite integral
midpoint rule, 246
notation, 232
Simpson’s rule, 245, 251
trapezoid rule, 244, 250
using the definition, 237
Definiteness Tests, 320
definition, see assignment
defined evaluation, 104
defining a variable, 59
full evaluation, 105
function of one variable, 106
function of several variables, 111
generic constant, 111
generic function, 110, 212
making a definition, 59
remove a definition, 115
529
Index

subscripted function, 107
valid names, 100
Definitions, see definition
Clear Definitions, 115
Define MuPAD Name, 119
New Definition, 59, 103, 106, 107
Show Definitions, 115
Undefine, 115
degrees
degrees and radians, 77
keyboard shortcut, 503
notation and behavior, 77
plot trig functions, 152
unit names, 504
delimiters, 11
DeMoivre’s theorem, 91
derivative
2D plot, 212
definition, 209
directional, 363
implicit, 213
notation, 202, 209, 507, 509
piecewise-defined functions, 211
Descartes, folium, 196
determinant, 309
difference of sets, 32
differential, 274
differential equations
Bessel functions, 392, 405
direction field, 364
exact method, 386
graphical solutions, 401
initial-value problems, 400, 401
Laplace method, 389
linear, 386
numerical solutions, 400, 402
ordinary, 385
series solutions, 389
Solve ODE, 400
systems of equations, 402
digits in computations, 510
Digits Rendered, 508
Digits rendered, 66, 67
Dirac function, 390
direction, 356
direction field, 364
directional derivative, 363
discontinuities, 142
display, 14
graphics, 6
mathematics, 6
text, 6
distribution, see statistics
continuous distributions, 423
discrete distributions, 432
function, 421
tables, 423
divergence, 360
divide
division, 20
divisors, 119
general, 7
integers, 21
polynomials, 41
domain, 111
dot product, 294, 308, 346
double integral, 276
double-angle formulas, 82
dual of a linear program, 465
dyne, 500
E
e, 8, 508, 515
exponential function, 298
Eigenvectors, 318
Eigenvalues, 318
electric
capacitance, 499
charge, 499
conductance, 499
potential difference, 499
resistance, 500
electron volt, 500
elementary
Jordan matrix, 332
matrix, 300
number theory, 21
row operations, 300
ellipsoid, 176
elliptic integral, 277
email technical support, ix
empty set, 32, 49
energy, 500
Engine settings
Debugging, 511
Engine on, 18
Ignore Special Cases, 68
Maximum Degree, 510
Principal Value Only, 68
envelope, 163
equality
Check Equality, 30
logical operators, 31
equations, trigonometry, 78
equivalent matrices, 327
erf, 526
erg, 500
error function, 526
Euclidean
elementary
algorithm for polynomials, 456
norm, 312, 314
plane, 75
Euler identity, 90
Evaluate
add numbers, 20
at endpoints, 47, 204
Index

calculus expression, 201
expression, 7
matrices, 294
multiply numbers, 20
polynomial, 40
series, 262
Evaluate Numeric, 26
evaluation
deferred evaluation, 103
full evaluation, 103, 105
exact solutions, 52
exp, 66
Expand
complex trigonometric functions, 92
polynomial, 40
expanding brackets, 5
exponential distribution, 428
exponential equations, 68
exponential function
complex numbers, 90
laws of exponents, 66
matrices, 316
notation, 65
exponential integral, 526
exponents, 5, 24
expressions
naming expressions, 103
plotting expressions, 151
valid names, 100
external functions, 119
extreme values
Find Extrema, 220, 270
Lagrange multipliers, 271
on a curve, 219
on a surface, 268
F
F distribution, 427
Factor
integer, 21
polynomial, 44
factorial, 22, 423
fahrenheit, 504
farad, 499
feasible system, 464
fence, 5
Fermat’s little theorem, 453
Fill Matrix
Band, 289
element, 206
Find Extrema, 220
finite field, 459
floating point, 23, 26
floor function, 448
greatest integer, 29
foot, 501
footcandle, 501
force, 500
Formula, 115
Fourier transform, 395
fraction
mixed number, 21
notation, 8
rationalize denominator, 25
template, 5
frequency, 501
Frobenius form, 330
Frobenius norm, 314
full evaluation, 105
function name, 99
subscripts as function arguments, 107
valid names, 100
functions, see distributions
absolute value, 33
algebra and number theory, 522
assume real, 49
beta function, 430
built-in, 522
calculus, 523
ceiling, 29
complex numbers, 524
defining case functions, 108
defining generic functions, 110
definitions, 59
differential equations, 525
floor, 29
Gamma, 423
greatest integer, 29
Im, 33
inverse, 60
istrue, 31
linear algebra, 524
menu items, 516
MuPAD, 522
notation, 99
piecewise definition, 108
plotting, 151
Re, 33
smallest integer, 29
special functions, 526
statistics, 525
step, 29
tables of equivalents, 515
trigonometry, 522
trigtype, 122
valid names, 100
vector calculus, 525
fundamental theorem
algebra, 49
calculus, 278
G
gallon, 504
Galois field
integers mod p, 450
inverse, 462
irreducible polynomial, 459
Index

product, 462
\( \Gamma \), 526
gamma, 515
gamma distribution, 429
Gamma function
definition, 526
plot, 157
statistics, 423
gauss, 502
Gaussian Elimination, 299
gcd
integers, 22
polynomials, 46, 457
generic constants, 111
generic functions, 110, 212
Geometric Mean, 414
\( GF_{16} \), 462
\( GF_{4} \), 460
\( GF_{p^n} \), 460
gradient
field, 367
optimization, 271
vector calculus, 358
gram, 502
Gram-Schmidt
orthogonalization, 326
Graph User Settings, 140
graphical solutions
initial-value problems, 401
systems of ODEs, 404
greatest common divisor
integers, 22
polynomials, 46
greatest integer function, 29
Greek letters, 9
green unit symbol, 77
grid, 163

H
Harmonic Mean, 415
Heaviside function, 158, 390
hour, 504
hyperbolic
cosine integral, 526
function inverse, 88
functions, 86
sine integral, 526
hyperboloid, 176
hypergeometric distribution, 434
H
i, 8, 509
Ignore Special Cases, 68, 511
ill-formed expressions, 211
illuminance, 501
imaginary
part, 33
unit, 32, 508
Implicit
Plot 2D, 132
Plot 3D, 177
Implicit Differentiation, 213
improper integrals
definite integrals, 235
doubly improper, 235
example, 236, 278
in-place computations, 16, 203
inch, 501
indefinite integral, 226
index symbol, 8
inequality
numbers, 30
plot, 136
solve, 58
\( \infty \)-norm, 313
initial conditions, 386
initial-value problems, 400
inline plots, 148
input settings
Base of Log, 67
Insert, see Math Objects
Math, 1, 4, 20
Math Objects, 492
Text, 4, 20
insert point, 4
integer
modulo m, 448
restraint, 112
solutions, 445
integrable function, 231
integration
blood flow problem, 278
change of variable, 234
computing volumes, 274
definite, 231
improper, 235
indirect, 226
integration by parts, 234
iterated, 274
notation, 202
Index

numerical integration, 253
partial fractions, 234
piecewise-defined functions, 226
integral test, 264
integral transform, 391
Integrate by Parts, 228
interactive plot tools, 138
interchange matrix rows, 301
Interpret, 8, 211, 227
intersection, 32
inverse
  distribution function, 422
  function, 60
  function plot, 135
  hyperbolic functions, 88
  matrices, 296
  modulo m, 450
  trigonometric functions, 83
inverse function, 106
irreducible polynomial, 459
irrotational, 372
Is prime, 119
istrue, 31
iterated integral
  definite integrals, 274
  indefinite integrals, 276
iteration
  Newton iteration function, 218
  solving equations, 216
Ithprime, 120

J
Jacobian, 377
join, 28, 31
Jordan Normal Form, 332
joule, 500

K
kelvin, 504
keyboard conventions, 2
keyboard shortcuts
  algebra, 69
  common tasks, 11
  entering units, 34, 497
  Greek characters, 494
  matrix, 336
  symbols and characters, 492
  TeX commands, 495
kilogram, 502

L
Lagrange multiplier, 271
Laplace method, 389
Laplace transform, 391
Laplacian, 362
law of cosines, 94
law of sines, 94
layout properties, 147
lcm
  integers, 22
  polynomials, 46
least common multiple
  integers, 22
  polynomials, 46
least positive residue, 450
least-squares solution, 439
Left Boxes, 240, 244, 245, 248
length
  units of length, 501
  vector, 312
level curve, 269
limit, 202
  at infinity, 205
  infinite, 205
  notation, 203
  one-sided, 205
line
  graph, 162
  style, 141
vector equation, 356
linear programming, see Simplex
  constraints, 464
dual, 465
  objective function, 464
  standard form, 465
linear regression, 436
list of data, 410
liter, 504
local maximum, 219
local minimum, 219
local minimum and maximum on a surface, 268
logarithmic function, 65
logarithms
  base, 67
  notation, 67
logical operators, 31
long division
  integers, 21
  polynomials, 41
Lower Absolute Boxes, 243
Lower Boxes, 241
lumen, 501
luminance, 501
luminous flux, 501
luminous intensity, 502
lux, 501

M
MacKichan Software, ix
Maclaurin series, 265
magnetic
  flux, 502
  flux density, 502
  inductance, 501, 502
making assumptions about variables, 237
mass, 502
Math Name, 100
Index

Math Objects
  Binomial, 23
  Brackets, 6, 62
  Display, 6, 55
  Formula, 115
  Fraction, 5, 20
  Math Name, 100
  Matrix, 15, 55
  Operator, 41, 202
  Radical, 5, 25
  Subscript, 5, 24
  Superscript, 5, 24
  Unit Name, 34
Math toolbar, 9
Math/Text button, 4
mathematics mode, 4, 490

Matrices, see matrix
  Adjugate, 310
  Characteristic Polynomial, 317
  Cholesky Decomposition, 336
  Column Basis, 323
  Concatenate, 292
  Condition Number, 315
  Definiteness Tests, 320
  Determinant, 309
  Eigenvalues, 315, 318
  Eigenvectors, 318
  Fraction-Free Gaussian Elimination, 299
  Gaussian Elimination, 299
  Hermite Normal Form, 328
  Hermitian Transpose, 308
  Inverse, 295
  Jordan Normal Form, 332
  Minimal Polynomial, 317
  Norm, 312, 352
  Nullspace Basis, 323
  Orthogonality Test, 324
  Permanent, 311
  PLU Decomposition, 335
  QR Decomposition, 325, 336
  Rank, 326
  Rational Canonical Form, 329
  Reduced Row Echelon Form, 299
  Reshape, 293, 410
  Row Basis, 321
  Singular Value
    Decomposition, 334
    Values, 334
  Smith Normal Form, 327
  Spectral Radius, 314
  Stack, 292
  Trace, 307
  Transpose, 307
  matrix, see Matrices
    addition, 294
    additive inverse, 297
    adjugate, 310
    algebra, 285
    alignment, 291
    brackets, 286
    classical adjoint, 310
    cofactor, 310
    column space, 323
    companion matrix, 329
    convert equations to matrix, 304
    convert matrix to equations, 304
    definition, 285
    deleting rows and columns, 290
    determinant, 309
    echelon forms, 298
    elementary, 300
    elementary row operations, 300
    entries, 285
    equations, 302
  equivalence, 327
  exponential functions, 316
  Frobenius form, 330
  identity, 295
  insert rows and columns, 290
  inverse, 296
  Jordan form, 332
  matrix equations, 302
  matrix multiplication, 294
  maximum entry, 311
  minimum entry, 311
  modulo m, 454
  normal form, 327, 328
  notation, 286
  nullspace, 323
  operations on entries, 298
  orthogonal, 325, 336
  orthonormal columns, 325
  polynomial expressions, 297
  positive definite, 320
  powers, 294, 296
  product, 294
  projection matrix, 338
  rational canonical form, 330
  replacing a block of cells, 291
  row operations, 298
  row space, 321
  scalar multiplication, 294
  screen appearance, 286, 287
  similar, 326
  swap rows, 301
  transpose, 307
  unitary, 334
  matrix operator
    adjugate, 310
    condition number, 315
    determinant, 309
    Euclidean norm, 312
    exponential function, 316
    Hermitian transpose, 308
<table>
<thead>
<tr>
<th>Index</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hilbert-Schmidt (Frobenius) norm, 314</td>
</tr>
<tr>
<td>( \infty )-norm, 313</td>
</tr>
<tr>
<td>maximum and minimum, 311</td>
</tr>
<tr>
<td>norm, 312</td>
</tr>
<tr>
<td>1-norm, 313</td>
</tr>
<tr>
<td>permanent, 311</td>
</tr>
<tr>
<td>trace, 307</td>
</tr>
<tr>
<td>transpose, 307</td>
</tr>
<tr>
<td>maximum</td>
</tr>
<tr>
<td>degree, 53, 510</td>
</tr>
<tr>
<td>finite sequence, 29</td>
</tr>
<tr>
<td>join, 28</td>
</tr>
<tr>
<td>matrix entries, 311</td>
</tr>
<tr>
<td>numbers, 28</td>
</tr>
<tr>
<td>optimization, 219</td>
</tr>
<tr>
<td>maxwell, 502</td>
</tr>
<tr>
<td>Mean</td>
</tr>
<tr>
<td>Geometric Mean, 414</td>
</tr>
<tr>
<td>Harmonic Mean, 415</td>
</tr>
<tr>
<td>Mean, 411</td>
</tr>
<tr>
<td>Mean Deviation, 416</td>
</tr>
<tr>
<td>Median, 412</td>
</tr>
<tr>
<td>meet, 28, 31</td>
</tr>
<tr>
<td>meter, 501</td>
</tr>
<tr>
<td>methods of integration</td>
</tr>
<tr>
<td>change of variable, 229, 234</td>
</tr>
<tr>
<td>integration by parts, 228, 234</td>
</tr>
<tr>
<td>partial fractions, 230, 234</td>
</tr>
<tr>
<td>Middle Boxes, 238</td>
</tr>
<tr>
<td>midpoint rule, 246</td>
</tr>
<tr>
<td>mile, 501</td>
</tr>
<tr>
<td>minimal polynomial, 317</td>
</tr>
<tr>
<td>minimum</td>
</tr>
<tr>
<td>finite sequence, 29</td>
</tr>
<tr>
<td>matrix entries, 311</td>
</tr>
<tr>
<td>meet, 28</td>
</tr>
<tr>
<td>numbers, 28</td>
</tr>
<tr>
<td>optimization, 219</td>
</tr>
<tr>
<td>polynomial, 317</td>
</tr>
<tr>
<td>minute, 503, 504</td>
</tr>
<tr>
<td>miscellaneous symbols, 10</td>
</tr>
<tr>
<td>mixed number, 21</td>
</tr>
<tr>
<td>mixed number output, 508</td>
</tr>
<tr>
<td>mod function, 448</td>
</tr>
<tr>
<td>mode, 413</td>
</tr>
<tr>
<td>modern algebra, 445</td>
</tr>
<tr>
<td>modulo, 448</td>
</tr>
<tr>
<td>mole, 498</td>
</tr>
<tr>
<td>moment, 419</td>
</tr>
<tr>
<td>mouse pointer, 4</td>
</tr>
<tr>
<td>multcase function, 62, 108</td>
</tr>
<tr>
<td>multiple choice examination formula, 118</td>
</tr>
<tr>
<td>multiple integral, 274</td>
</tr>
<tr>
<td>Multiple Regression, 436</td>
</tr>
<tr>
<td>multiple roots, 458</td>
</tr>
<tr>
<td>multiple-angle formulas, 82</td>
</tr>
<tr>
<td>multiplication</td>
</tr>
<tr>
<td>general, 7</td>
</tr>
<tr>
<td>inner product, 294</td>
</tr>
<tr>
<td>matrices, 294</td>
</tr>
<tr>
<td>matrices by scalars, 294</td>
</tr>
<tr>
<td>numbers, 20</td>
</tr>
<tr>
<td>polynomials, 40</td>
</tr>
<tr>
<td>vector cross product, 347</td>
</tr>
<tr>
<td>vector dot product, 346</td>
</tr>
<tr>
<td>vector with scalar, 345</td>
</tr>
<tr>
<td>multiplicity of a root, 458</td>
</tr>
<tr>
<td>multivariable calculus, 268</td>
</tr>
<tr>
<td>MuPAD</td>
</tr>
<tr>
<td>constants, 515</td>
</tr>
<tr>
<td>engine, 18</td>
</tr>
<tr>
<td>functions, 119, 516</td>
</tr>
<tr>
<td>swapRow, 301</td>
</tr>
<tr>
<td>( N )</td>
</tr>
<tr>
<td>nabla symbol, 358</td>
</tr>
<tr>
<td>naming expressions</td>
</tr>
<tr>
<td>definitions, 103</td>
</tr>
<tr>
<td>valid names, 100</td>
</tr>
<tr>
<td>naming functions</td>
</tr>
<tr>
<td>subscripts as arguments, 107</td>
</tr>
<tr>
<td>valid names, 100</td>
</tr>
<tr>
<td>natural linear notation, 8</td>
</tr>
<tr>
<td>negated relations, 10</td>
</tr>
<tr>
<td>negative, 112</td>
</tr>
<tr>
<td>New Definition</td>
</tr>
<tr>
<td>assignment, 103</td>
</tr>
<tr>
<td>function, 60, 106</td>
</tr>
<tr>
<td>function and expression names, 100</td>
</tr>
<tr>
<td>variables, 59</td>
</tr>
<tr>
<td>newton, 500</td>
</tr>
<tr>
<td>Newton iteration function, 218</td>
</tr>
<tr>
<td>Newton's method, 217, 218</td>
</tr>
<tr>
<td>nextprime, 119, 453</td>
</tr>
<tr>
<td>no rules, 7</td>
</tr>
<tr>
<td>nonzero, 112</td>
</tr>
<tr>
<td>Norm, 312</td>
</tr>
<tr>
<td>normal distribution, 424</td>
</tr>
<tr>
<td>notation, 2</td>
</tr>
<tr>
<td>null delimiter, 108</td>
</tr>
<tr>
<td>nullspace, 323</td>
</tr>
<tr>
<td>number theory</td>
</tr>
<tr>
<td>lcm and gcd, 22</td>
</tr>
<tr>
<td>prime numbers, 21</td>
</tr>
<tr>
<td>numbers</td>
</tr>
<tr>
<td>basic operations, 23</td>
</tr>
<tr>
<td>complex numbers, 32</td>
</tr>
<tr>
<td>mathematics mode, 19</td>
</tr>
<tr>
<td>mixed numbers, 21</td>
</tr>
<tr>
<td>real numbers, 23</td>
</tr>
<tr>
<td>symbolic, 23</td>
</tr>
<tr>
<td>numerical</td>
</tr>
<tr>
<td>integration, 253</td>
</tr>
<tr>
<td>results, 26</td>
</tr>
<tr>
<td>solutions to ODEs, 400</td>
</tr>
<tr>
<td>( 0 )</td>
</tr>
<tr>
<td>objective function, 464</td>
</tr>
</tbody>
</table>
Index

ohm, 500
1-norm, 313
one-parameter family, 386
Operator, 100, 202
optimization
  Find Extrema, 270
  Lagrange multipliers, 271
  local extremes, 219
  several variables, 268
or, logical
  logical operator, 31
  maximum or join, 28
  union, 32
order of integration, 276
ordered pair, 341
ordered triple, 341
ordinary differential equation
  initial conditions, 386
  series solutions, 389, 399
  solve systems, 397
orientation of 3D plot, 174
orthogonal matrix, 324, 334
Orthogonality Test, 324
orthonormal, 324, 325, 334, 336
ounce-force, 500
output
  differential, 510
  exponential, 510
  imaginary $i$, 509
  output settings, 508
overdetermined systems, 439

p
parallelepiped, 350
parallelogram, 352
parametric equations, 258
parametric plot, 134
parametric polar plot, 164
parentheses and trig type
  functions, 76
partial derivatives
  extreme values on a surface, 268
  notation, 209
Partial Fractions
  algebra, 43
  integration, 230
  partial sums, 262
  pascal, 503
Passthru Code to Engine, 121
pentagon, 136, 160
percentile, 412
Permanent, 311
Phi, 119
$\phi$, 119
phot, 501
Physical Quantity, see units
  $\pi$, 8, 515
piecewise-defined function
  definite integral, 233
  definition, 62
  derivative, 211
  indefinite integral, 226
  notation, 108
pint, 504
plane
  in 3-space, 354
  vector equation, 353
plane angle, 503
Plot 2D
  Approximate Integral, 239
  Conformal, 379
  Gradient, 367
  Implicit, 132
  Inequality, 136
  ODE, 401
  Parametric, 134
  Polar, 131, 164
  Rectangular, 131
  Vector Field, 364
Plot 2D Animated
  Conformal, 380
  Gradient, 370
  Implicit, 170
  Inequality, 170
  Parametric, 167
  Polar, 168
  Rectangular, 165
  Vector Field, 365
Plot 3D
  Curve in Space, 178
  Cylindrical, 183
  Gradient, 370
  Implicit, 177
  Parametric, 175
  Rectangular, 171
  Spherical, 185
  Tube, 179, 256
  Vector Field, 366
Plot 3D Animated
  Curve, 191
  Cylindrical, 192
  Gradient, 372
  Implicit, 194
  Parametric, 190
  Rectangular, 173, 190
  Spherical, 193
  Tube, 195
  Vector Field, 367
Plot Approximate Integral
  Left Boxes, 240
  Lower Absolute Boxes, 243
  Lower Boxes, 241
  Middle Boxes, 238
  Right Boxes, 240
  Upper Absolute Boxes, 243
  Upper Boxes, 241
  plot coordinates, 139
  plot inverse function, 135
  Plot Properties, 140
Index

Items Plotted, 140
plotting
adding expression, 130
discontinuities, 142
envelope, 163
expressions, 129, 151
grid, 163
inverse, 133, 135
multiple expressions, 152
piecewise function, 155
points, 141
Riemann sums, 238
tools, 138, 165
zoom tool, 139
PLU Decomposition, 335
point marker, 141
point plots, 159
Poisson distribution, 433
polar
coordinates, 90, 131
form, 89, 90
plots, 259
polygon, 181
polygonal path plot, 159
Polynomials, see polynomials
Collect, 44
Companion Matrix, 329
Divide, 41, 224
Partial Fractions, 43, 230
Roots, 48, 49
Sort, 44
polynomials
collecting and ordering terms, 44
congruent, 456
Factor, 44
gen ears common divisor, 457
irreducible, 459
long division, 41
matrix values, 297
modulo m, 455
modulo polynomials, 456
roots of 3rd- and 4th-degree polynomials, 50
roots of fifth and higher degree polynomials, 51
roots of second-degree polynomials, 49
positive, 112
positive definite symmetric matrix, 320
potential
scalar, 372
vector, 373
pound-force, 500
pound-mass, 502
power, 503
Power Series, 265
powers
complex powers, 91
modulo powers, 453
notation, 24
power series, 265
pressure, 503
prime number, 21
Principal Value Only, 68, 93, 510
probability density function, 421
problems and solutions
algebra, 70
applied modern algebra, 466
calculus, 277
differential equations, 407
function definitions, 124
matrices, 337
numbers and units, 36
plotting, 196
statistics, 440
trigonometry, 93
vector calculus, 381
product
formula, 213
polynomials, 40
program resources, ix
projection matrix, 338
Psi function, 526
Pythagorean identities, 82
Q
QR Decomposition, 325, 336
Quantile, 412
quart, 504
quotient of polynomials, 41
quotient rule, 213
R
radian, 503
radical notation, 24
Random Numbers, 435
Rank, 326
ratio test, 263
rational canonical form, 330
rational expression, 41
rationalize denominator, 25
real
assume, 112
default for real roots, 49
real part of complex number, 33
recognizing constants, 8
rectangular coordinates, 131
recursion, 447
regression, 436
removing definitions, 115
reshape
list, 293
lists and matrices, 410
matrix, 293
residue, 448
resize a plot, 147
restraints on variables, 111
Index

restrict domain, 111
resultant, 119
revise matrix, 290
Rewrite
  Arccos, 85
  Arccot, 85
  Arcsin, 84
  Arctan, 85
  Cos, 81
  Equations as Matrix, 304
  Exponential, 86
  Factorial, 23, 423
  Float, 24, 26
  Gamma, 424
  Logarithm, 88
  Matrix as Equations, 304
  Mixed, 21
  Normal Form, 42
  Polar, 90
  Rational, 23, 42
  Rectangular, 48, 90
  Sin, 81
  Sin and Cos, 81, 82, 91, 92
  Sinh and Cosh, 87
  Tan, 81
  Riemann sum, 231, 238
  Right Boxes, 240, 248
  root test, 263
roots
  complex roots, 91
  exponential notation, 24
  numbers, 24
  polynomials, 48
  radical notation, 24
  rotate 3D plot, 174
  row echelon forms, 299
  row operations, 298
  row space, 321
  rows, 15, 290
$ S$
  scalar potential, 372
  scientific notation, 26, 508
  scope, 507
  secant, 76
  second, 503, 504
  second derivative, 225
  selection
    automatic, 12
    mathematics in a display, 14
    mathematics in a matrix, 15
    operating on, 16
    replacing, 16
    user, 15
    with the mouse, 5, 16
sequence
  finite, 29
  notation, 260
terms as functions, 261
series
  integral test, 264
  Maclaurin, 265
  notation, 262
  ratio test, 263
  root test, 263
  solution, 399
  Taylor, 266, 389
set of data, 410
sets
  difference, 32
  empty set, 32
  intersection, 32
  union, 32
sidebars, 507
siemens, 499
sigma, 41
similar matrices, 326
similar triangles, 75
Simplex
  Dual, 465
Feasible, 464
Maximize, 464
Minimize, 464
Standardize, 465
Simplify
  built-in function, 24
  mixed numbers, 21
  polynomial, 50
Simpson, 245, 251
sine, 75
sine integral, 526
singular value decomposition, 334
singular values, 334
slug, 502
smallest integer function, 29
smallest nonnegative residue, 448
Smith Normal Form, 327
solenoidal, 374
solid angle, 503
solid of revolution
  parametric plots, 258
  polar plots, 259
  rectangular plots, 256
  tube plots, 256
solution to ODE, 385
Solve
  Exact, 52, 54, 215
  Integer, 445
  Numeric, 56, 215
  Recursion, 447
solve
  equations, 13
  systems of linear equations, 301
  the function "solve", 54
Solve ODE
  Exact, 386, 398
  Laplace, 389, 398
  Numeric, 400
Series, 389
Solve Options
  Ignore Special Cases, 68, 511
  Maximum Degree, 510
  Principal Value Only, 68, 510
solving equations, see Solve
  by iteration, 216
  inverse trig functions, 85
  matrix equations, 302
  Newton's method, 217
  trigonometric equations, 78
solving triangles, 94
Sort, 44
Spectral Radius, 314
stacking matrices, 292
Standard deviation, 418
star plot, 136
Statistics, see statistics
  Correlation, 420
  Covariance, 418
  Fit Curve to Data, 436
  Geometric Mean, 414
  Harmonic Mean, 415
  Mean, 411
  Mean Deviation, 416
  Median, 412
  Mode, 413
  Moment, 419
  Quantile, 412
  Random Numbers, 435
  Standard Deviation, 417
  Variance, 417
statistics, see Statistics
  cumulative distributions, 421
  distribution
    beta, 430
    binomial, 432
    Cauchy, 431
    chi-square, 426
    exponential, 428
  F, 427
  gamma, 429
  hypergeometric, 434
  normal, 424
  Poisson, 433
  Student's t, 425
  uniform, 431
  Weibull, 428
  inverse distribution function, 422
  multiple regression, 436
  polynomial fit to data, 437
  probability density function, 421
statistics functions
  BetaDen, 430, 431
  BetaDist, 430
  BinomialDen, 432
  BinomialDist, 432
  CauchyDist, 431
  ChiSquareDen, 426
  ChiSquareDist, 426
  ExponentialDen, 428
  ExponentialDist, 428
  FDen, 427
  FDist, 427
  GammaDen, 429
  GammaDist, 429
  HypergeomDen, 434
  HypergeomDist, 434
  NormalDen, 424
  NormalDist, 424
  PoissonDen, 433
  PoissonDist, 433
  TDen, 425
  TDist, 425
  UniformDen, 431
  UniformDist, 431
  WeibullDen, 428
  WeibullDist, 428
step function, 29
steradian, 503
stere, 504
stilb, 501
Student's t distribution, 425
subscript
  as function argument, 107
  on function name, 100
substitution
  automatic substitution, 102
  change of variable, 229
summation notation, 41
superscript, 5
surface area, 257
surface of revolution, 180, 257
swap matrix rows, 301
Symbol sidebar, 11
symbolic real numbers, 23
Symbols
  shortcuts, 492
  toolbar, 9
system of congruences, 452
system of ODEs, 397, 402
systems of equations
  differential equations, 402
  equations to matrix, 304
  linear equations, 302
  matrix to equations, 304
  notation, 55
  solving, 55
T
  table of values
    from a function, 205
    using auxiliary functions, 206
table with formulas, 117
tables of equivalents
Index

compute menu items, 516
functions, 522
tables of units, 497
tangent function, 76
tangent line, 215, 277
tautology, 31
Taylor polynomials
one variable, 267
two variables, 272
Taylor series, 266
technical support, ix
techniques of integration
change of variable, 229, 234
integration by parts, 228, 234
partial fractions, 230, 234
telephone MacKichan, ix
temperature, 504
tesla, 502
test for multiple roots, 458
Text/Math button, 4
three-dimensional vector, 341
time, 504
Toggle Text/Math button, 4
toll-free number, ix
torr, 503
total differential, 274
Trace, 307
Transforms
Fourier, 395, 396
Inverse Fourier, 396
Inverse Laplace, 393
Laplace, 391
translate view, 139
Transpose, 307
trapezoid rule, 244, 250
trigonometric
form of z, 89
inverse functions, 83
trigonometry
identities, 80
simplifying expressions, 83
solution of triangles, 94
solving trigonometric
equations, 78
trigonometric functions, 75
trigtype functions
argument defaults, 123
parentheses, 76
triple cross product, 349
troubleshooting, ix
Tube, 256
tube plot, 179
two-dimensional vector, 341
2-norm, 312, 352
U
unassume, 112
Undefine, 115
uniform distribution, 431
union, 32
unit circle, 75
Unit Name, 34
unit prefixes, 498
unitary matrix, 334
units
activity, 498
amount of substance, 498
angle, 503
area, 498
arithmetic operations, 35
compound names, 35
converting, 35
current, 499
degree, 77
electric capacitance, 499
electric charge, 499
electric conductance, 499
electric resistance, 500
electrical potential difference, 499
energy, 500
force, 500
frequency, 501
illuminance, 501
keyboard shortcuts, 497
length, 501
luminance, 501
luminous flux, 501
magnetic flux, 502
magnetic flux density, 502
magnetic inductance, 501, 502
mass, 502
physical units, 33
plane angle, 503
pressure, 503
solid angle, 503
temperature, 504
time, 504
volume, 504
Upper Absolute Boxes, 243
Upper Boxes, 241
user selection, 16
user-defined
functions, 106
V
valid names for definitions, 100
Vandermonde matrix, 287
variables
defered evaluation, 105
definitions, 59
full evaluation, 105
making assumptions, 111, 237
valid names, 100
Variance, 417, 418
vector
components, 341
cross product, 347
definition, 341
Index

- dot product, 294, 346
- inner product, 294, 346
- length, 312
- matrix notation, 285
- norm, 351
- notation, 342
- product with scalar, 345
- sum, 344
- triple cross product, 349
- triple scalar product, 350

Vector Calculus

- Curl, 361
- Divergence, 360
- Gradient, 358
- Hessian, 375
- Jacobian, 377
- Laplacian, 362
- Scalar Potential, 373
- Set Basis Variables, 359, 362, 374
- Vector Potential, 374
- Wronskian, 378
- vector calculus, 341
- vector equation
  - line, 356
  - plane, 353
- vector field
  - divergence, 360
  - plot, 363
  - solenoidal, 374
- vector space
  - column space, 323
  - nullspaces, 323
  - row space, 321
- vertical notation, 8
- View Intervals
- Plot 3D, 171
- volt, 499
- volume
  - iterated integral, 274
  - surface of revolution, 257
  - units, 504
- watt, 503
- weber, 501, 502
- Weibull distribution, 428
- Wronskian, 377

Y

- year, 504

Z

- zeta function, 262, 526
- zoom in and out, 139